电脑词典

  • A3D 3D定位音效技术

    这是由Aureal Semiconductor开发的一套互动3D定位音效技术。它在3D音效定位上有很独到的地方。最初的A3D技术只需一对音箱输出，但在新的版本中也加入了对四只音箱的支持。


  • A3D Aureal声音技术

    A3D（Aureal 3-Dimensional），这是一项由Aureal开发的声音技术，它可以在两个扬声器上提供三维效果的声音。大部分的声卡和PC机都支持这一技术。与环绕立体声不同，它需要的扬声器个数比较少，只要两个，而环绕立体声通常需要4-5个。


  • 动态矩阵 Aactive matrix

    Aactive matrix 动态矩阵

    动态矩阵也被称为薄膜晶体管（TFT），是一种被用于笔记本电脑和台式电脑平面液晶显示器的技术。和双扫描（被动矩阵）显示器相比，动态矩阵显示器显示的图像更生动，提供的观察视角也更大。台式电脑显示器通常采用阴极射线管（CRT）技术。


  • 动态网络 Aactive Network

    Aactive Network 动态网络

    动态网络是这样一种网络，该网络上的各个节点经过编程处理，可以依据通过该节点的信息执行定制化的任务。例如，一个节点可以经过编程或者定制化处理，以一个单独用户为基础处置信息包，或者处置不同于其它信息包的多点传送信息包。动态网络的这种处理方法，在一个由移动用户构成的网络中显得特别重要。


  • AC97 音响数字/模拟转换

    AC-97即音响数字/模拟转换97。AC 97能使PC与一般音响系统相容，以配合家用电器的标准。该规格支持一些新的功能，如支持Modem等。


 Access Control 访问控制
：按用户身份及其所归属的某预定义组来限制用户对某些信息项的访问，或限制对某些控制功能的使用。访问控制通常用于系统管理员控制用户对服务器、目录、文件等网络资源的访问。


 ACL 访问控制表
：Access Control List (ACL)，访问控制表。用户和设备可以访问的那些现有服务和信息的列表。用户必须具有相应的授权才能修改目标的ACL。通常要求用户提供注册姓名和口令，它是用来保证系统安全性的一种手段。


  • ACL 访问控制表

    ACL是存在于计算机中的一张表，它使操作系统明白每个用户对特定系统对象，例如文件目录或单个文件的存取权限。每个对象拥有一个在访问控制表中定义的安全属性。这张表对于每个系统用户有拥有一个访问权限。最一般的访问权限包括读文件（包括所有目录中的文件），写一个或多个文件和执行一个文件（如果它是一个可执行文件或者是程序的时候）。Windows NT，Novell公司的Netware，Digital公司的 OpenVMS和基于UNIX系统是使用这种访问控制表的系统。而此表的实现在各个系统中却不一样。


 ACOPS　自动CPU过热保护
：ACOPS是（Automatic CPU Overheat Prevention System）的缩写。特指一类计算机主板的一种功能。此类主板在CPU插槽的中央有一个温度传感器，当计算机的CPU散热不佳或散热风扇不转导致CPU温度超出安全范围时，系统会通过喇叭发出警告并自动执行降温程序。


  • Acrobat Adobe阅读软件

    Acrobat是Adobe公司的软件，它可以捕获一个文件，并以该文件的初始形式查看。当你为打印媒介制作文件，或希望文件在互连网上共享时，使用Acrobat是比较理想的。一个Acrobat文件通常是PDF形式的，要阅读这种文件需要Actobat Reader。Actobat Reader是免费的，可以从Adobe的网站下载。Actobat Reader可以作为单独的阅读器，也可以嵌入到网页中。


 Active Directory　动态目录
：Active Directory是Windows 2000 的目录服务，它取代了NT 4.0版中的安全帐户管理器(SAM)。Active Directory由目录林、域、组织单位、容器和对象等组成。


 Adapter 适配器
：任何能在物理上不同的系统之间进行通信的硬件设备。这个术语常指插在计算机中的外设卡，它提供从计算机总线到另一种诸如硬盘或网络的介质的接口。


  • Adapter 适配器

    适配器、转接器：(1)用于连接多个部件(例如具有不同尺寸的部件)的一种机构；(2)将某个设备同计算机或另一设备电子地或物理地连接起来的一种部件；(3)用于加入不同光纤连接器类型的一种硬件。对照coupler(耦合器)；(4)修改系统部件而让它以特殊方式操作的印刷电路板。


 ADSI　动态目录服务接口
：ADSI（Active Directory Services Interfaces）是一种目录服务抽象接口，与组件对象模型 (COM) 兼容的编程语言，如 Visual Basic、VBScript、JavaScript、C 和 C++，可以使用该接口对基础目录服务进行一般的目录调用。


  • ADSL 非对称数字用户环线

    ADSL是DSL技术的一个分支，同样也是使用普通电话线路来传输数据，但它使用的频率要比语音波段高。不过，要想使用ADSL技术，必须在用户端安装一个分离语音和ADSL数据的POTS分配器。ADSL有一种名叫“G.lite”，面向普通线费者的版本，无需安装POTS分配器，但是，线路上的所有电话必须连接低通滤波器，以把它们和较高的ADSL频率分隔开。


  • ADSL 非对称数字用户线路

    非对称数字用户线路。这种DSL叫做非对称DSL，将成为广大家庭和小型商业客户最熟悉的一种DSL。ADSL之所以叫做非对称是因为它的两个双工通道都用来向用户传输数据。仅有很小一部分带宽用来回送用户的信息。然而，大部Internet 特别是富于图形和多媒体Web 数据需要很大的下传带宽，同时用户信息相对比较少，上传的带宽也不要很大。使用ADSL时，下传的速率可以达到6.1 Mbps，而上传速率也可以达到640 Kbps。高的下传速率意味着您的电话可以传输动画，声音和立体图形。另外，一小部分的带宽可以用来传输语音信号，您可以同时打电话而不用再使用第二条电话线。不象电视线路提供的相同的服务，使用ADSL，您不需要和您的邻居争用带宽。有时候，现有的电话线可以使用ADSL，而有时候却要升级，除非电话公司提供了无分离器的ADSL，您就必须安装一个DSL调制解调器。


  • 加速图形接口 AGP

    AGP 加速图形接口

    AGP是一种接口规范，可以使3D图形在普通个人电脑上以更快的速度显示。AGP是一种设计用来更快，更平稳地传送3D图形的接口。它使用普通个人电脑的主内存来刷新显示器显示的图像，支持纹理贴图，零缓冲和阿尔法混合等3D图形技术。

    AGP接口对主内存的使用是动态的，也就是说，当主内存没有被用来进行图形加速处理的时候，它可以重新被操作系统或者其它应用程序使用。


  • Algorithm 算法

    算法是用来解决一个问题的程序或者公式。“算法”（algorithm）这个词源自生活在公元9世纪的波斯数学家Al-Khowarizmi。一个电脑程序可以被看成是一个精心设计的算法。在数学和电脑学科，一个算法通常意味着一个可以解决循环问题的小程序。

    • width="295" height="33" usemap="#MapMap2Map" border="0">


  • aliasing 混淆

    在声音和图像生成时，混淆是指在进行频率取样时，和一个正确频率一起生成的一个错误频率。对于图像生成来说，混淆会产生锯齿状的边缘或者梯阶效果，而对于声音生成来说，混淆会产生杂音。


  • Alpha DEC公司微处理器

    Alpha是由DEC公司开发的一种微处理器。DEC公司已经被康柏电脑公司收购，因此，Alpha微处理器也就成了康柏电脑公司旗下的一种产品。


 Alphamosic Graphics　字母镶嵌图形
：视频信息的图形产生方式之一，它是把整个屏幕划分为 24 列，每列再分 40 块区域，每个区域内不是点阵式的字符就是特殊图形符号。此方式显示的图形有如小方块堆砌而成。


  • BIOS基本输入/输出系统 AMI BIOS

    AMI BIOS 基本输入/输出系统

    AMIBIOS是历史最悠久的BIOS（基本输入/输出系统）芯片之一，大概也是今天的个人电脑中使用最为广泛的一种BIOS芯片。当你打开电脑的时候，“AMIBIOS”是最有可能出现在屏幕上的几个名称之一。AMIBIOS由总部位于美国乔治亚州Norcross市的美国Megatrends公司生产。除了BIOS芯片之外，美国Megatrends公司还生产RAID系统，主板和其它一些电脑配件产品。


 Anonymous FTP 匿名文件传输
：匿名文件传输能够使用户与远程主机建立连接并以匿名身份从远程主机上拷贝文件，而不必是该远程主机的注册用户。用户使用特殊的用户名“Anonymous”和“guest”就可有限制地访问远程主机上公开的文件。


 API 应用程序界面
：Application Program Interface（API）被定义为应用程序可用以与计算机操作系统交换信息和命令的标准集。一个标准的应用程序界面为用户或软件开发商提供一个通用编程环境，以编写可交互运行于不同厂商计算机的应用程序。API不是产品，而是战略，所有操作系统与网络操作系统都有API。在网络环境中不同机器的API兼容是必要的，否则程序对其所驻留的机器将是不兼容的。


  • API 应用程序设计接口

    Windows应用程序设计接口。API是一个程序内（或一组相关程序内）的一组函数调用，程序员用它创建其他程序。不必知道函内部，只要知道函数原型及返回值。将一组函数转入API的问题实质是此函数提供每个人可使用的技术规范资料。Windows API大概是今天世界上最著名的API了。现在API已发展到了Win32 API。在它的核心中，依靠三个主要组件提供Windows的大部分函数。这三个组件分别是USER32.DLL、GDI32.DLL、KERNEL32.DLL。


 ARP 地址解析协议
：ARP(Address Resoloution Protocol，地址解析协议)是获取物理地址的一个TCP/IP协议。某节点的IP地址的ARP请求被广播到网络上后，这个节点会收到确认 其物理地址的应答，这样的数据包才能被传送出去。RARP(逆向ARP)经常在无盘 工作站上使用，以获得它的逻辑IP地址。


 ARP 地址解析协议
：(Address Resolution Protocol，地址解析协议，用于将IP地址映射为MAC地址的网间网协议。


  • ASP 服务器开发专用脚本

    (Active Sever Page)ASP是微软公司为IIS服务器开发的一种专用接口（也有人说是脚本）。它类似于CGI，同属于服务器端应用程序，功能强大而且容易编写，与IIS的结合堪称天衣无缝，但也只能用在IIS上。ASP最强大的一点，就是采用了ADO数据库接口引擎，在与数据库的连接上非常方便，这点，如果用过VB6就有体会了。ASP可以用VBScript或JavaScript编写。它的有关帮助中，一般是采用VBScript编写。


  • ATAPI AT附件包接口

    AT附件包接口(AT Attachment Packet Interface)，ATAPI是一个用于计算机和CD-ROM驱动器及磁带驱动器之间的接口。大部的计算机使用的是IDE接口。ATAPI提供了比IDE更强的功能命令来控制CD-ROM演播器或磁带备份器，这样就可以使用IDE接口来控制一些新设备了。ATAPI是EIDE接口的一部分。


 Attenuation 衰减
：在局域网中，当电缆超出规格中的最大长度时所出现的一种信号强度损失现象。衰减会阻止成功的数据通信。可采取一种叫做中继器的设备来扩大网络的电缆的范围。衰减可用分贝或奈培表示。


  • 鉴别与授权 Authentication and Authorization

    Authentication and Authorization 鉴别与授权 在分布式计算环境中，除了附属于本地服务器的资源以外，用户通常还能访问其它资源。传统上，用户访问本地资源前须登录，当访问远距离资源时（可能在其它城市）用户必须再登录一次。这种访问每种资源前都须登录的方法不仅麻烦，而且很难管理。带有当前口令的用户帐户必须保存于每个服务器。另外，与远距离设备的连接并非安全可靠，入侵者能够监视线路并且截取登录信息为自己所用。明显地，需要有更好的方法。如果入侵者装作另外的合法用户并且截获了加密的口令，那么口令加密方法也会失败。

    UNIX、NetWare 4．x以及其它操作系统使用“可靠主机”的概念，即一个系统相信另一个系统已经正确地检查了用户身份合法性。关于它的方法将在接下去的段中讨论。用户一旦被验证，他就可以访问所授权的任何资源。用于检验用户对远距离资源访问的信息随着用户登录时间的不同而不同，所以即使信息被截取了，一旦用户注销后它将不能被再次使用。

    鉴别技术必须判断请求是否来自正确的用户或应用以及请求没有被某种方法修改。一旦请求被检验后，授权过程就决定用户对资源的访问类型。

    下面谈到的是在分布式网络环境中提供鉴别服务的两种重要产品。

    Kerberos

    Kerberos鉴别服务是由麻省理工学院的Athena工程作为分布式环境中开放系统的鉴别机制而开发的。它用于开放软件基金会（OSF）分布式计算环境（DCE）和由广大网络操作系统供应商提供。

    RSA Data SecurityRSA数据安全性

    RSA密码系统是位于加利福利亚州Redwood市的RSA 数据安全有限公司的产品，它被准许用于许多公司的产品中。它是一个有鉴别功能的公开密钥加密方案，其中最出名的是提供NetWare 4．x的鉴别服务用在RSA系统中，密钥大得实际上可以保证它决不会被推导出来。

    传统加密方法使用一个密钥，而公开密钥加密系统使用两个密钥。私人密钥具有保密性而公开密钥供公共使用。公开密钥用于加密信息，私人密钥用于解密。RSA系统用这项技术提供鉴别、签名检验及其它安全性需求。

    NetWare 4．x验证

    NetWare 4．x采用RSA安全性系统来验证用户并且授予他们使用网络的权力，它与包含对象信息的访问控制表协同工作。由于它工作在后台，所以用户不知道鉴别过程。它为每位登录的用户分配一个唯一的标识，这个标识不是用户的口令而是用来鉴别网络用户的每次请求。鉴别保证每位用户的口令仅仅用于登录处理，并且它很快转变为一个不同代码，用于标识用户和用户在现行会话中登录的工作站。鉴别还保证消息来自当前会话工作站的合法用户，并且未被破坏、伪造或修改。

    相关条目：Kerberos Authentication Kerberos鉴别；RSA Data Security RSA数据安全性；Security 安全性。


  • Authorization 授权，认证

    在计算机中，特别是在网络上的远程计算机中，向个人授予的权力。它使得用户可以使用系统和存储在该系统上的数据。在典型情况下，权限由系统管理员设置，而由计算机按一定形式的用户标识进行验证，例如通过代码标号或口令进行验证。


  • Authorware 多媒体创作软件 Authorwsre

    Authorware 多媒体创作软件

    Authorware是由Macromedia公司开发的一种非常流行的多媒体创作工具软件。它被广泛应用于创造性工作，适用于Windows操作系统和Macintosh操作系统的交互式学习软件。


 Autosizing　自动调整大小
：显示器以一种分辨率接收信号，但以另一种分辨率显示图像的能力。监视器的这种自动尺寸调整能力保持了图像的纵横比不变，但它对图像进行了扩大或缩小处理以适应当前可用的空间。


  • Average seek time 平均寻道时间

    指硬盘磁头移动到数据所在磁道时所用的时间，单位为毫秒（ms）。注意，它与平均访问时间的差别，平均寻道时间当然是越小越好，现在我们所使用的高级硬盘完成数据的搜索只需要7-11 毫秒，现在一般应该选择平均寻道时间低于9ms的产品。


  • AVI 影音文件

    Audio Video Interleaved。声音图象交叉存取。AVI是一种微软媒体文件格式，类似于MPEG和QuickTime。在AVI中，声音和图象是交叉的存取在一个文件中的每个段的。


  • utoexec.bat 自动批处理文件

    EXEC.BAT对于用过DOS的人肯定比较熟悉。它是在启动的时候要运行的一个批处理文件。现在已经不常用了，有时候编制java程序的时候会用到这个东西。它无非就是设置一些路径，运行一些在启动时必须运行的程序而已。


  • B2B 商务对商务

    (Business to Business)商务对商务。在Internet上，B2B，也被称为e-biz，是商家与商家之间的产品、服务、信息的交换，而不是商家与消费者之间的。尽管早期的热点集中在Internet的零售上，有预言说在不远的将来，B2B年收益将远远超过B2C（商家对个人，有时也称作e-tailing）的。根据2000年早期的研究，B2B与电子零售（e-tailing）的资金比为10：1。在以后的5年，B2B可望有41%的年增长率。


 Back Door 后门
：绕过安全性控制而获取对程序或系统访问权的方法。在软件的开发阶段，程序员常会在软件内创建后门以便可以修改程序中的缺陷。如果后门被其他人知道，或是在发布软件之前没有删除后门，那么它就成了安全风险。


  • Backup 备份

    备份是指将联机的大容量存储设备中的所有数据写入到脱机的大容量存储设备的过程。备份通常是将数据从硬盘拷贝到磁带上。


  • Bandwidth 带宽

    1.每条位并行总线上可传输数据的容量，使用"比特/秒"作为度量单位。

    2.网络可以使用的传输频率，表示成一个频带的上下界频率之差，单位用赫兹表示。高带宽允许更快速的大容量传输。


  • BASIC 编程语言

    我们通常觉得BASIC语言就是基本这个英文单词，其实它是Beginner's All-Purpose Symbolic Instruction Code的缩写。这是一种比较简单易学的编程语言。原来它是由John Kemeney和Thomas Kurtz在1963年开发的一种交互式大型机分时语言，但是很快它就在个人计算机上广泛使用了。在IBM的第一代计算机PCJr上就有BASIC。由于它的易学与易用，现在仍然被广泛使用。过去的BASIC不是结构化的，因此限制了它的应用，但是现在Microsoft公司的Visual Basic将面向对象技术和图形界面加入了这种语言，使它有了新的生命力。


  • BBS 电子布告栏系统

    用计算机处理的布告栏能够在商店和其他的公共场合发现，在那儿人们可以留下信息和想买和卖东西的广告。BBS经常被局部的计算机用户群使用，经常提供下载共享软件、免费软件和在线的信息和服务。有许多专门的有兴趣的公告栏，包括有计算机公司用来提供信息和产品的。现在许多的BBS都有网页。


  • Beta Test Beta测试

    在软件开发中，Beta测试是软件测试的第二个阶段，它主要是交给一些准用户进行测试，在实际使用中测试。而Alpha（也就是希腊字母中的第一个字母）是软件测试的第一个阶段，这一阶段包括模块测试，组件测试和系统测试。


  • Beta 测试第二版

    在软件领域，“beta”是指一种新应用程序或者软件在正式投放市场之前，在测试阶段推出的第二个版本。


  • 装订 Bindery

    装订文件是NetWare 4．x之前的NetWare操作系统的数据库文件，保存服务器的安全、记帐、名字管理信息。它具有如下功能与特点：

    网络上每个服务器维护各自的装订文件。

    装订文件包括对象记录。对象是服务器实体，例如用户、组和服务器名字。

    对象的属性称作“特性”。内容有口令、帐户限制、记帐平衡、组员等。

    特性的值保存在独立但相关的文件中。

    装订文件包括SYS：SYSTEM目录下的两个文件：

    NET＄BIND．SYS保持有装订对象及特性信息。

    NET＄BVAL．SYS保持有特性的值。

    装订文件是隐含的，备份者必须检查它们是否被备份了。另外还可以单独对它们进行备份。

    装订文件对NetWare的操作非常重要，并且常常被引用。SYS：SYSTEM目录以及其中的装订文件应该位于最快的驱动器上，或者常驻Cache内存中。这需要保证服务器的内存足够大。

    装订文件中的对象具有对象类型码，这些编码标识对象的类别。通过相应的应用程序，用户可以访问装订类型表，根据给定的名字查询相应的对象。这采用的是4字节ID码，一旦找到，对象的属性值用于确定对系统的访问或者能发生的动作类型。

    装订文件有两个相关的NetWare实用程序：BINDFIX．EXE用于修复损坏的装订文件；BINDREST．EXE在BINDFIX．EXE修复不成功时，恢复装订文件到修复前的状态。


 BIS　商务信息系统
：BIS(Business Information System)是指计算机、打印机、通信装置，以及其他用于处理数据的设备的组合。完全自动化的商务信息系统能够接收、处理和存储数据；能够根据需要传输信息；并且能够根据命令生成报告或打印输出。


 BISDN　宽带综合业务数字网
：BISDN(Broadband Integrated Services Digital Network)宽带综合业务数字网既是一个概念也是一系列的服务，同时它又是以光纤和无线介质的宽带网进行综合数字传输服务的。BISDN支持从2 Mbps到至今未知的更大的传输速率。


  • Bit 比特

    内存中最小单位，也叫“位”。它只有两个状态分别以0和1表示。


  • bit 位

    位是电脑二进制中最小的度量单位。32位要么是指一种可以一次处理32位数据的微处理器，要么是指每一种颜色采用32位的彩色显示模式。现在的个人电脑有些是32 bit，有些是64 bit。


  • BITNET网 BITNET

    Because It＇s Time Network（BITNET），是由研究教育网络公司（CREN）管理的国际性网络，CREN为BITNET网提供信息服务。BITNET主要用于电子函件服务，但是也提供一些其它服务。它与Internet之间的信关允许交换电子函件和其它服务。BITNET包括2500多台主机，分布于美国、加拿大、墨西哥南美欧洲和日本，主机场点主要是大学。

    BITNET始建于八十年代，从ARPANET发展而来。ARPANET由DARPA（国防部高级研究规划局）的前身ARPA（高级研究规划局）提供资金。它连接防御性设施、政府研究实验室和大学，后来并入了Internet。BITNET是一个独立的学术网，没有获得DARPA的资助，因为DARPA仅限于支持军队建设。

    相关条目：Internet Internet网。


  • 面向位协议 Bit－Oriented Protocol

    在设备间的通信对话中，控制码用于控制其它设备或者提供对话状态的信息。面向字节或字符的规程使用整个字节表示建立的控制码，如ASCII码（美国标准信息交换码），面向位协议依靠单独的位来控制信息

    在面向位传输中．数据被传送为稳定的位流。传输方式是同步的，传送、接收设备通过同步信号确定数据流中字符的开始与结束。与它相对立的是异步通信，异步通信中每个字符由一个起始位与停止位分开

    在实际数据传输之前，发送者传给接收者一个同步字符，使接收者时钟同步。这种位模式通常是特殊编码的8位的位串。IBM的同步数据链路控制（SDLL）规程是面向位的，同步字符是位串01111110其后是0位地址、8位控制字段以及数据。接收端的时钟提供同步信号将数据分成一个个字符，数据之后是错误检测和结束标志。

    IBM的高级数据链路控制规程（HDLC）与SDLC一样也是面向位的规程，用于控制同步通信 HDLC里于X．25分组交换网络，SDLC是HDLC的子集。

    相关条目：Byte Oriented Protocol 面向字节协议；Synchronous Data Link Control同步数据链路控制（规程）；Synchronous Communication同步通信。


 Block Clipher　块密码
：一种私人密钥加密方法，采用固定长度的数据块（通常为 64 位）来加密数据。加密后的数据块与原有数据块的位数一样。


  • 磁盘块再分配 Block Suballocation

    NetWare 4．x具有最大化磁盘空间的功能。它将部分使用的磁盘块（一般一块8K字节）分成大小为512字节的再分配块，来存储小文件或文件片段。

    相关条目：Disks，Partitions，and Volumes Under NetWare NetWare中的磁盘、分区与（文件）卷宗。


 Bluetooth　蓝牙
：蓝牙是无线数据和语音传输的开放式标准，蓝牙协议能使包括蜂窝电话、掌上电脑、笔记本电脑、相关外设和家庭Hub等包括家庭RF的众多设备之间进行信息交换。


  • BNC连接器 BNC Connector

    BNC连接器用于连接、扩充、终结以太网、ARCNET网等同轴电缆网。它的种类多，有BNCT型连接器BNC桶形连接器和BNC终结器，如图B－10所示。

    BNC连接器直接连到电缆上。它有一个固定在电缆中心线的中心插针和与屏蔽地线相连的外壳。

    BNC连接器插到T型连接器的两端，然后由外套旋进固定起来。

    BNCT型连接器可以将电缆与网络接口卡相连。电缆从“T”的两边连到电缆干线中相邻的站点。

    BNC终结器具有终结同轴电缆的电阻。同轴电缆干线的两端各需要一个终结器，并且一端还需要接一条接地引线。如图中所示。

    BNC桶形连接器用于连接两个电缆段。

    相关条目：Transmission Media，Methods，and Equipment传输介质、方法与设备；Ethernet以太网；


  • Bookmark 书签

    指在gopher客户程序（client）和web浏览器（browser）中，用户在菜单（menu）或页（page）上做的标志，以便今后查找的参考。在gopher客户程序中，所有书签出现在一个gopher的菜单上。在Web浏览器中，它们出现热点清单（hot list）中。


  • 边界网关协议 Border Gateway Protocol

    Border Gateway Protocol（BGP） 边界网关协议（BGP） BGP是Internet外部网关路由协议。它可以从网络中传送的数据分组中收集相邻节点的可达性信息。还增加了费用、安全等路由属性。BGP降低了路由信息交换所需的带宽，因为信息的交换是递增方式进行的而不是通过传送整个数据库。

    相关条目：Domain 域；Routing，Internet Internet路由选择；Routing Protocols路由选择协议。


  • 中断盒 Breakout BoX

    参见“测试设备与技术”条目。


 BRI　基本速率接口
：BRI(Basic Rate Interface）指用户与综合业务数字网（ISDN）交换机之间的接口。它包含两条64kbit/s的B信道和一条16kbit/s的D信道。两条B信道处理话音和数据；D信道则处理有关呼叫和客户的信息。


 Bridge 网桥
：将多个网络、子网或环连接成一个个大的逻辑网，网桥中保留节点的地址表，在他的基础上，可以向特定的子网转发数据包，这样，就减少了在其他的子网上 循环而导致的网络堵塞，网桥比转发器、更复杂。


  • 桥接 Bridging

    桥接器是用于在两个或多个网段或子网间提供通信路径的互联设备。这些网段或子网具有相同的地址及网络拓扑结构。图－11说明服务器如何在两个网络适配器之间进行桥接。某网络上的工作站可以利用桥接器向其它网上的工作站广播消息，所以桥接器是连接网络段的两端口（或多端口）设备。另外，桥接器还可以将业务忙的网络分为两段，减少每段上的通信量以提高性能。它还能过滤网络广播信息，只允许必要的通信信息通过桥接器到达另外的网络。本书中讨论的其它互联设备有中继器、路由器和网关。

    安装桥接器的原因如下：

    扩展整个网络的距离和节点数目。

    减少连接节点过多引起的通信瓶颈。

    链接不同网络，如以太网、令牌环网。并且在它们之间传送分组。前提是假设它们采用相同的网络协议。

    桥接器可以是一个独立的设备，或者通过安装一个或多个网卡在服务器中建立，前提是服务器操作系统支持桥接。通过桥接器相连的每个LAN网段都有一个特定的网络号码。打个比方，网络号类似于街道名，工作站号类似于房间号。桥接器在相联网段间传送数据分组。Novell NetWare、Banyan VINES及Microsoft公司的网络具有服务器桥接功能。如果桥接功能使服务器陷入瘫痪，就需要外部桥接器，外部桥接器由Cisoc、3COM、Cabletron等供应商制造。

    桥接器具有过滤功能，该功能的实现是通过读取以太网或令牌环帧中的地址来确定数据分组属于哪一个LAN网段。但是，桥接器不能访问网络层协议信息，所以它不能提供最优路径选择。路由器可以通过编程（或学习）在专门路径中为分组选择路由以减少费用或者避免通信拥塞。而且多协议路由器能够用于处理具有多通信协议的网络通信。

    随着网络的增长，桥接的数目也随之增大，可能会出现循环回路或者无效路径。在桥接网络中避免循环回路将在以后讨论。桥接器缺少拥塞管理，无法确定最优数据路径。当许多工作站都需要发送时就会引起拥塞。在桥接的网络中，流控制由端系统完成。桥接器在为弥补拥塞问题而传送额外的分组时，实际上可能反而使问题扩大了。这些问题将在本节“生成树算法”中讨论。

    Types of Bridges 桥接器类型

    桥接器类型总的说来有两种：本地与远程桥接器。本地桥接器为LAN提供连接点，用于在同一建筑物或区域内互连LAN网段。如图B－12下端所示。远程桥接器具有连接远地网络模拟或数字通信链路端口，如图B－12上端所示。远程桥接器之间的连接采用的是使用调制解调器的模拟线路，或者采用吞吐量为1．544Mbps的T1等数字专用线路。

    模拟线路基本上是声音级拨号电话线，提供桥接器连接的线路可以是临时的（参见本书的“电路交换服务”），也可以是长期的（参见“专用线路”）。由于电话公司能够对连接负责，所以专用线比拨号连接的速度快、质量好，但是，租费可能与网络的使用需要不相符。拨号线适于偶尔的使用，如文件传输或公司场地间的电子函件的批量传输。而租用线路是连续使用的最佳选择。

    Bridge Functionality 桥接器功能

    桥接器可以连接两个相似或不相似的LAN网段，可以将桥接器看作邮件分类装置，查看数据分组的地址并且送到合适的网段。桥接发生在相当于开放系统互连（OSI）协议模型的数据链路层。遵循IEEE 802标准的介质访问控制（MAC）规程的设备能够通过桥接器相连。以太网、令牌环、光纤分布式数据接口（FDDI）都是遵循IEEE 802标准进行MAC级桥接的例子。正因为如此，将以太网或令牌环网连到FDDI主干网的桥接设备使用较普遍，参见“主干网”中的讨论。

    数据链路层又可以分为上部的逻辑链路控制（LLC）子层与下部的MAC子层。支持IEEE 802标准的设备有一个模块化MAC子层，可以适用于许多网络类型，如以太网、令牌环，见图B－13所示。上部的LLC子层用作“交换板”，在MAC子层中的网络模块之间转移数据分组。在上文的例子中，将以太网的帧解包，采用令牌环的帧格式重新包装。这种额外的处理带来了一些延迟，所以桥接器的速率由它每秒能够处理的分组而定。

    桥接器具有如下功能：

    帧传送 帧传送是一种形式的过滤，如果数据分组的地址与段地址相匹配，那么桥接器将数据分组传送到LAN网段上，这可以防止在本段编址的数据分组通过桥接器。如果没有过滤作用，那么数据分组被传送到网上的每个位置。当数据分组到达桥接器时，桥接器读出其目的地址，并且决定它是否应该能够通过桥接器朝前传送。

    循环回路解决方案 大量桥接的LAN可能存在循环回路，从而引起数据分组连续不停地传送，一些桥接器会检测出这些循环的数据分组并且加以拦截。

    学习技能 桥接器建立了描述路由的地址表。方法是通过检查分组流动或者从旅行中学得网络拓扑的“侦探分组”中获得信息。第一种方法叫做透明式桥接，第二种方法叫做源路由选择，这些学习技能将在以下的部分中讨论。

    早期的桥接器要求网络管理员手工输入地址表，这是一项非常乏味的工作。如果某工作站的用户转移到其它位置，那么该表必须定期更新。现在的先进桥接器能够采用这里谈到的技术获得网络上其它工作站的地址。注意，透明桥接器常常称为自学习桥接器，采用的是IEEE 802．1标准的生成树算法。以太网环境中采用的是透明式桥接，令牌环环境中采用的是源路由选择技术。

    Transparent Bridging 透明式桥接

    透明式桥接器在安装通电后能够自动获悉网络环境的拓扑结构。当数据分组传送到桥接器的端口，透明式桥接器查看其源地址，并且在桥接表中增添表项。这些表项建立了源地址与分组经过网络的地址的联系。具有两个LAN网段（123网段和456网段）的典型表格如图B－14所示，桥接表经常随着新源地址的增加或者网络的改变而更新。

    到达的数据分组根据桥接表信息继续向前发送，如果目的网络类型发生了改变则必须被重新包装。如果一个地址在表中没有找到，那么一个发现过程将被重新启动。将一帧发送到不包括发出其帧的所有LAN网段，如果目的点以网络地址作为响应返回，那么桥接器在桥接表中可以新增一条表目，如果有足够的时间后，桥接器可以得到网络上所有节点的地址。

    互联网段的数目是学习过程中必须了解的问题，如果一个桥接器只与两个网段相连，那么桥接表的创建就相对简单。哪些工作站在桥接器这一边，哪些在另一边就可确定下来。但是桥接器必须首先通过将数据分组从桥接器的一边传送到另一边，并且等待目的站点的应答才知道每个连接的网络的地址。

    如何将多个LAN网段互连起来呢？图B－15上面的网必须将左边网段的数据分组经过中间网段传送到右边网段。这将在中间部分引起性能问题。但是，仅仅需要两个桥接器。一种替换的方法是在每一个LAN网段上连接一个桥接器，这些桥接器又全部接到象FDDI环那样的主干网上。如图B－15下面所示。

    在大型互联网中，多条桥接路径可能会形成闭合回路，使数据分组无休止地循环，从而导致性能降低或者整个网络陷入瘫痪。最糟的是，为解决这个问题无休止产生的那些新分组导致“传播风暴”．但是多条路径对容错又是必要的，如图B－16所示。如果LANA与LANB之间的链路断开了，间接通过LANC的替换链路可以保持传输的正常进行。生成树算法（STA）可以建立多条路径而不引起循环回路，但是它采用的方法是封锁一条路径，直到需要时才允许使用。被封锁的路径应该是仅在需要时才工作的模拟或数字链路。另外一种被称作负载分担的策略也能在一定程度上解决该问题。

    生成树算法

    生成树桥接器通过禁止以太网中的某些链路来检测和中止循环传送。IEEE801．2－D生成树协议（STP）由维持辅助桥接器作为备份来抑制冗余桥接器中的循环回路。如果主桥接器不工作了，辅助 桥接器将代替 它继续工作。

    该算法为每一个桥接器分配一个唯一的标识，该标识通常是桥接器的MAC地址。

    每个桥接器分配一个优先级值。

    为每个桥接器的每个端口分配一个唯一的标识。

    每个桥接器端口被赋予一个路费权值。网络管理员可以人工改变路费权值，为特殊端口设立优先权。

    该算法从桥接器中选定一个作为根桥接器，具有最小标识的桥接器被选作根。一旦选定了根桥接器其它桥接器就能够确定通过哪个端口访问根桥接器的路费权值最小，该端口称作该桥接器的根端口。如果几个端口的路费权值一样，那么就选择桥接器间网段数最少的端口。最后一步是根据最少路费原则确定由哪个桥接器的哪个端口提供路径通过网络达到其根。

    该过程允许使用一部分端口以到达某些桥接器，另一部分端口封闭以防止循环回路。封闭端口连到一拨就通的调制解调器或者某些桥接器，这些桥接器仅仅在需要路径或线路在引起回路的情况下仍能安全使用时才建立与交换通信链路的连接。

    负载分担桥接器

    当桥接器使用专线跨越较大区域时，绝大多数网络管理员都认为阻塞线路和将其仅用于备份不是经济可行的。一些桥接器生产厂家推出了负载分担桥接器，它使用备份链路来分担网络负载而不会引起回路。这是最有效的桥接器型式，它采用生成树算法和使用双链路来传送数据分组，改进了互联网的性能。

    Source Route Bridge 源路由桥接

    IBM的令牌环网采用了一种特殊的源路由选择方法，不仅告诉桥接器数据分组的目的地，而且告诉它如何到达。在源路选择器中，数据分组本身具有继续传送的信息，由于分组中有路径信息，所以能够自己找到路径从而在网络中继续传送。

    通过“发现”方法来实现源路由选择的桥接器，首先确定一个分组走向目的站应该选择的路由。注意，虽然这听起来象路由选择，其实源路由选择桥接器只是确知其余桥接器地址的传送设备。数据分组中具有有利于广域网的最优路由选择信息。在透明式桥接中，有必要将某些链路封锁起来防止环路的出现。而在源路由选择桥接中，避免了循环回路，所以可以方便、安全地在广域链路中建立平行冗余路径。

    “侦探分组”被源桥接器发出以发现一条通过网络的路径。网络中有多个桥接器就有多个侦探分组从中间桥接器到达目的地，目的节点便向源节点发送回响应信息。然后根据象桥接器之间网段数等因素确定最优路径。该路径被存入桥接器中，并加在发送到目的地的所有的后继数据分组中。

    路径发现处理最初需要完成一些工作，但最后桥接器知道了最常用的路径。如果令牌环网络较大，那么有可能出现建立侦探分组的“风暴”，使网络陷入瘫痪。令牌环的硬件限制桥间网段数为7，有助于减少“风暴”的出现，但是同时也限制了网络的大小。

    Bridging Enthernet and Token Ring 桥接以太网与令牌环

    我们一直假设在全以太网或者全令牌环环境之中装置桥接器，但是这样的情况很少。组织往往需要桥接部门LAN，形成混合的拓扑结构。其中遇到的问题有：

    以太网使用生成树算法的自学习桥接器，令牌环网采用源路由选择技术；以太网桥接器保持地址表而令牌环网保持路径信息。

    以太网与令牌环网的帧状态和错误信息编码不同。

    两种网络类型间有些帧信息没有相应成分。例如令牌环采用了优先机制，表明某些帧较其它帧更重要，而以太网没有这种特性。

    以太网

    1500字节分组和令牌环4，000～17，800字节的分组在分组结构上不同。

    这些问题需要转换桥接器解决，转换桥接器IBM 8209具有一个以太网端口和一个令牌环端口，它提供转换服务使两个网络能够互相交换分组。它通过强制令牌环网使用1，500字节帧来解决帧的问题。对令牌环节点，桥接器作为源路由选择桥接器出现；对以太网节点，它作为生成树桥接器出现。

    FDDI Backbone BridgesFDDI主干网桥接器

    光纤分布式数据接口（FDDI）标准是一种适用于大楼或校园环境中的主干网介质。具有FDDI接口的桥接器能够将LAN网段链接到FDDI主干网。当将以太网桥接到FDDI主干网时，以太网的帧要在网络中传输必须重新打包。

    方法有以下两种：

    封装 该方法仅仅在以太网的帧上再加一层FDDI封装，将其作为分组在主干网中传输。当它被送到目的网络的桥接器时，被解封并且传送到目的点。封装的方法被大部分的以太网－FDDI网桥接器所采用，它假定除桥接器外以太网上的节点不需要与直接连接到FDDI局域网的节点通信。封装使帧信息只有他们在接收网桥接器中被解封后才能使用。

    转换 转换桥接器可以将以太网分组转换为FDDI分组，大多数有关问题及某些解决措施将在最后讨论。转换虽然不如封装有效，但是它允许以太网上的节点与FDDI网上的节点通信，在FDDI仅仅用作主干道网的情况下，封装比转换好。

    Remate Bridging Technigues 远程桥接技术

    远程桥接器有多种连接方法，本书后面的条目“数据传输率”介绍了常见网络应用的传输速率和能够帮助确定满足传输需求的活动。

    异步桥接器 拨号调制解调器和异步链路对偶尔的低容量的互联网通信已经足够了。大容量的通信需要专用模拟线路或下面将讨论的数字线路。异步桥接设备有连接高速调制解调器的RS－232和V．35端口。V．32bis调制解调器能够工作于14．4Kbps的速率，正在出现的标准使用压缩方法能提供更高的速率。见本书后面“调制解调器”。

    专用或交换数字线路 数字线路的速率可为64Kbps或更高，上至T1速率为1．544Mbps，T3速率为45Mbps。T1中有24条能处理声音或数据通信的信道，信道服务单元／数据服务单元（CSU／DSU）将桥接器与数字线路相连，如图B－17所示。如果打算混合传送声音与数据，那么需要一个多路复用器。请参见“多路复用”、“T1／T3服务”和“广域网”的有关内容。

    分组交换服务 分组交换服务能够提供任意点到任意点的连接，相对于专线点对点的连接。桥接器能够在分组交换网中建立与多个远距离节点的链路。由于链路是交换的，连接时间可以较短，所以客户只需按使用付费。一些分组交换服务列举如下：

    X．25分组交换传输速度为56Kbps。

    帧中继是一种速率为1．544Mpbs或更高的流水线帧传送服务。它假定现代传输工具是可靠的，相对而言没有错误，因而取消了额外的错误检测。

    交换式多兆位数据服务（SMDS）是在光纤环网络上运行的城域网服务。

    Bridging Versus Routing桥接方式与路由选择方式的比较

    路由器往往比桥接器好，因为它们能够在复杂网络中提供更好的通信管理。路由器可以通过与另一个路由器共享网络状态信息绕过拥塞或失效的连接。相当于OSI协议栈中的网络层协议能够采用这个网络状态信息，但桥接器却看不到。由于路由器工作在网络层，他们能够在数据分组中得到更多的信息，并且能够利用它们改进分组的传送。

    相关条目：Compus Network 校园网；Carrier Services 电信服务；Circuit－Switching Services 电路交换服务；Digital Circuits and Services数字电路［线路］与服务；Enterprise Networks 企业网；Metropolitan Area Networks城域网；Routers路由器；Wide Area Networks广域网。


  • 宽带综合业务数字网 Broadband ISDN

    宽带综合业务数字网（B－ISDN）是国际电报电话咨询委员会（CCITT）的一个建议，定义兆到千兆位的数据、声音、视频传输操作。B－ISDN用户接口连接在所有用户所在地的光缆上，现在的双绞线不适合于BISDN的较高的传输率，B－ISDN的速率大大高于窄带ISDN服务（参见“综合业务数字网”）。B－ISDN最初的速率在150－600Mbps范围内。

    B－ISDN的创建是为了克服ISDN的某些局限，ISDN连接适合于家庭和小规模商业用户，而B－ISDN用作如广域网连接、电视会议、科学或医疗传输等高速数据传输。但是B－ISDN需要一个能够处理兆到千兆位信息的网络，这个网络可以利用电信服务。它的底部是光纤网（SONET）及异步传输模式（ATM）交换服务，如图B－18所示。

    SONET是B－ISDN的物理传输主干网。它是一个基于光纤的联网标准，定义了一个传输率等级和符合国际同步数字系列（SDH）标准的数据帧格式。SONET被用作互联世界范围内电信交换局的传输介质，将指明未来的全球通信。B－ISDN、FDDI、SMDS能够在SONET网上传送，SONET现在用作电信交换局业务与许多客户所在地之间的介质。SONET传输率最低为51．4Mbps，随后可以以52Mbps为单位增加，速度能够达到50Gbps。

    ATM是B－ISDN的交换技术，能够向B－ISDN用户提供对SONET光纤网的访问。ATM层所接收的信息被放入定长的报文分组中，在SONET网上编址并且传送。ATM可以在SONET网所连接的链路之间超高速交换这些报文分组。它充分利用了光缆的传输速度。

    ATM是一项面向报文分组和多路复用服务，因而它能提供唯一将多节点的交换服务和来自不同源节点信息的多路复用相结合的服务。ATM不象时分多路复用，它在多路复用的流中设有专用时间片。这样，来自一个源节点的突发传送能够使用其它源节不用的时间片。ATM能够处理所有类型的信息，包括变长视频信息和局域网的突发传送信息。

    相关条目：Asynchronous Transfer Mode异步传输模式；Integrated Services Digital Network 综合业务数字网；Synchronous Optical Network 同步光纤网。


  • 宽带（通信）服务 Broadband Services

    宽带分组交换服务，或者“快速分组”服务的数据传输率为T1速率（1．544Mbps）或者更高。由于不提供错误检测，宽带网络能够部分提高其性能。报文分组定序和丢失报文分组的重获由源和目的工作站的协议处理，而不是由网络管理。宽带分组交换服务有：帧中继、交换式多兆位数据服务（SMDS）以及异步传输模式（ATM）。这些服务的优点列举如下：

    有求必应的带宽能够适应突发传送，突发传送使用其它连接没有使用的带宽。

    传输率比普通专用线路的1．544Mpbs高。

    客户只须为所使用的带宽交费。不象点对点租用专路昂贵、经常不用和不适合突发传送。

    在分组交换网络中，数据流被分成若干段，每段放入一个报文分组中，分组被编址，并且发送到网络中。网络常常被画作一朵“云”，因为分组能够经不同的路径到达目的节点。这些路径提供了冗余，能够处理突发通信并且在一条路径失败后保持网络继续工作。但是必须记住，在客户与电信交换网络间需要有交换或专用线路。

    相关条目：Asynchronous Transfer Mode异步传输模式；Broadband ISDN 宽带综合业务数字网；Carrier Services 电信服务；Frame Relay 帧中继；High－bit－rate Digital Subscriber Line 高位速率数字用户专用线；Switched Multimegabit Data Service交换式多兆位数据服务；Wide Area Networks 广域网。


  • 广播风暴 Broadcast Storm

    当主机系统响应一个在网上不断循环的报文分组或者试图响应一个没有应答的系统时就会发生广播风暴。一般为了改变这种状态，请求或者响应分组源源不断地产生出来，常使情况变得更糕。随着网络上分组数目的增加，拥塞会随之出现，从而降低网络的性能以至于使之陷入瘫痪。


  • 广播 Broadcast

    在无线电通信中，广播是一对多的信号传送，发送机将信号传播给接收机。在以太网等网络中，工作站在共享介质上广播分组传输，其它节点“收听”这些广播，但仅仅接收地址是它的报文分组。

    当一个用户向以太网的另一个用户发送一条消息，该消息广播到所有的工作站。具有相应监视设备的窃听者能够将该消息截获，加密技术能够提供一些保密性。电视会议同样也用到了广播，视频信号能够从一个工作站广播到多个目的工作站。


  • 桥路器（桥接器／路由器） Brouter（Bridge／router）

    桥路器是桥接器与路由器技术的综合设备，它既能够桥接多项协议又能够为其中的一部分协议提供路由选择功能。在这个意义上，桥路器是一个工作在开放系统互连（OSI）协议栈的网络层和数据链路层的网间传送报文分组的设备。

    相关条目：Multiprotocol Router多协议路由器；Router 路由器。


  • Bug 程序缺陷、臭虫

    电脑系统或者程序中存在的任何一种破坏正常运转能力的问题或者缺陷，都可以叫做“bug”。


  • 公告牌系统 Bulletin Board System

    BBS是一个其它用户能够相连的主机系统，提供消息与文件交换服务。拨号电话线路是常用的BBS访问途径，用户登录到系统后可以读出发送消息，或者装载和拆卸文件。单独的用户能够在户外操作BBS，公司能够通过建立BBS向客户或雇员提供消息、文件和最新消息，许多BBS提供特殊意义的信息。例如，Macrocosm USA在加利福利亚州Cambria运行的BBS提供环境与社会方面的变化信息。

    BBS提供的消息传递系统可以使用户进行电子会话。当用户登录后便可以发送和阅读消息。一些系统允许多个用户同时登录，这样他们能够进行“现场会议”，任何用户键入的文本出现在屏幕上能够被其它用户阅读和响应。组织能够建立的专用BBS系统使远地雇员能够交换消息和文件。许多产品供应商建立了公司BBS系统使客户能够访问帮助信息和卸下文件更新。

    BBS的管理员称作系统操作员（SYSOP），他对系统的修改、定制或对文件及其它信息的访问具有无限的安全权力。BBS使用了许多文件传输协议，如XMODEM、YMODEM和ZMODEM。高级BBS系统提供建立BBS网的能力，在建网中采用了FidoNet或者PCRelay技术。一种情况是，一个BBS系统在预定时间呼叫另一个BBS系统，交换可能被用户遗漏的存储－转发消息。另一种情况是几个BBS系统呼叫一个中心BBSHub以传送报文。

    BBS软件中的功能包括：

    同时支持多个用户的能力，包括需要进行联机会话的用户。

    可以与FidoNet或者PCRelay网相连，实现BBS之间的消息共享。

    安全功能：防止未授权用户入侵系统，防止用户浏览未授权的文件与消息。

    BBS软件包括Clank Development公司（Utah Murray）的PCBoard，eSoft公司（Colorado，Aurora）的TBBS以及RBBS－PC。RBBS－PC可以免费使用，可从Technology Consultants（电话4071／627－6969）BBS向下装载得到。


 Bundled Software　捆绑软件
：指作为系统总价的一部分包含在计算机系统中的软件，或是与计算机一同销售，作为组合的硬件、软件包一部分的程序，也可以说是打包销售的几种程序。现在常称为软件套件。比如我们所熟悉的IE，就是捆绑在Windows中。


  • NetWare的突发方式 Burst Mode，NetWare

    NetWare于1993年初新添加了突发方式技术，以增强本地互联网分组交换（IPX）协议，适用于广域网链路。突发方式使得一个工作站使用一个文件只需请求一次，然后服务器以一连串分组响应，而不需回答，从而提高了吞吐量。当突发分组全部接收后才发出一个确认响应。突发方式大大降低了网络中的信通量，对提高广域链路的性能非常必要。

    突发方式在下列环境中可以提高性能：

    传送大规模文件的LAN网段。

    具有低速（9，600波特或更低）异步链路的WAN。

    桥接器和路由器链接的互联网。

    使用X．25分组交换或T1的WAN以及卫星链路。

    突发方式中分组的大小由工作站与服务器协商决定，低速机器如PC机不能受益于突发方式，因为它们总线的信息传输速度无法跟上突发方式。如果网络有问题或者工作站丢失报文分组，就需要在这些机器中禁用突发方式。


 Burst Modem　突发式调制解调器
：指卫星通信系统中使用的一种调制解调器。由于各地球站发送高速突发数据，有时这些数据会同另一个地球站交织在一起，因而需要对它们进行精确定时，然后再用突发式调制解调器发送。


  • 突发传送 Bursts

    突发传送是两设备之间不间断的连续数据传送。微处理器如Intel 80486、Motorola 68030允许用突发方式将成组数据传送到内存和板上的高速缓存。IBM公司的微通道（Micro Channel）总线提供突发传送方式，总线上的适配器能够用突发方式控制总线发送多个成组数据。

    在汇聚和传送来自几个源节点数据的多路复用总线设备或数据通信信道上，突发方式将整个信道专用于传送一个源节点的数据。具有突发方式功能的设备常常为成组方式操作提供最大吞吐率。例如，基于Intel芯片的PC机扩展工业标准体系结构（EISA）总线具有速率为33Mbps的突发方式，在突发传送时，一次数据移动只要一个时钟周期，而不是通常的两个时钟周期。


  • 总线拓扑 Bus Topology

    网络电缆系统的布局以及工作站在电缆上访问和传送数据的方法都是网络拓扑结构的一部分。总线拓朴结构的网络只有一条唯一的电缆干线，如图B－19所示，它以菊链的形式连接一个接一个工作站。在实际的安装中，电缆线穿过一个接一个的办公室。所有的节点共享同一介质，某一时刻只有一个节点能够广播消息。虽然总线拓扑适合办公室的布局，易于安装，但是干线电缆的故障将导致整个网络陷入瘫痪。

    最常见的总线拓扑结构的网络是以太网。同轴电缆曾是它主要的传输介质，但现在大多数新的安装使用了双绞线。双绞线以太网（10Base－T）是安装成星形的总线拓扑结构，总线本身被紧缩到一个称作集线器的小盒子中，从集线器连接点到工作站的线路分支呈星形布局。如图B－20所示。

    相关条目：Ethernet 以太网；Topology拓朴结构。


  • 面向字节规程 Byte－Oriented Protocol

    在设备间的任何通信会话中，控制码用于控制另外一个设备或者提供对话状态的信息。面向字节或字符的规程使用整个字节来表示建立的控制码，例如按美国标准信息交换码（ASCⅡ）方案所定义的控制码。相对而言，面向位规程的控制码依靠的是单独的位。

    面向字节的规程以字符串的形式来传送数据，这种传输方法是异步的。每一字符通过一个起始位和停止位分开，不需要同步机制。大部分调制解调器中使用的异步规程与IBM公司的二进制同步通信规程（BISYNC）都是面向字节规程。

    相关条目Asynchronous Communications 异步通信；Bit－Oriented Protocol 面向位规程；Modems 调制解调器。


  • Cable Modem 电缆调制解调器

    又名线缆调制解调器。它利用有线电视网进行数据传输，主要面向计算机用户的终端，它是连接有线电视同轴电缆与用户计算机之间的中间设备。


 Cable 电缆
：由铜导线或被保护外壳包着的光纤构成的传输介质。


  • Cache 高速缓冲存储器

    它是位于CPU与内存间的一种容量较小但速度很高的存储器。一般来说，CPU的速度远高于内存，当CPU直接从内存中存取数据时要等待一定时间周期，而Cache则可以保存CPU刚用过或循环使用的一部分数据，如果CPU需要再次使用该部分数据时可从Cache中直接调用，这样就避免了重复存取数据，减少了CPU的等待时间，因而提高了系统的效率。Cache又分为L1 Cache（一级缓存）和L2 Cache（二级缓存），目前L1 Cache主要是集成在CPU内部，而L2 Cache集成在主板上或是CPU上。


 CDMA　码分多址技术
：CDMA（Code Division Multiple Access）是在数字通信技术的分支扩频通信的基础上发展起来的一种技术。就是用具有噪声特性的载波以及比简单点到几点通信所需带宽宽得多的频带去传输相同的数据。


 CD-ROM　只读光盘机
：CD-ROM（Compact-Disc-Read-Only-Memory）。1986年，SONY、Philips一起制定的黄皮书标准，定义档案资料格式。定义了用于电脑数据存储的MODE1和用于压缩视频图象存储的MODE2两类型，使CD成为通用的储存介质。并加上侦错码及更正码等位元，以确保电脑资料能够完整读取无误。现在一般都称为光盘驱动器。


 CFTV　付费电视
：CFTV（Coin-Freed Television）也称投币式电视，是某些发达国家实行的一种无人管理的有偿收费电视节目的形式。即在发射电视信号时同时加入密码电波，只有已交费的用户所持有的解调卡，才能够识别这种密码还原出准确的图像。


  • CGI 公共网关接口

    提供一个计算机程序同HTTP协议或者WWW服务的接口，也就是人机交互接口；有了它，服务器可以提供交互式的站点以代替过去静态的文本和图象。CGI通常使用PERL、C/C++、DELPHI等进行编写。


  • Chipset 芯片组

    是构成主板电路的核心。一定意义上讲，它决定了主板的级别和档次。它就是“南桥”和“北桥”的统称，就是把以前复杂的电路和元件最大限度地集成在几颗芯片内的芯片组。


  • Client/Server 客户机/服务器

    客户机/服务器，一种分布信息或文件的方法，其中应用程序通过一个中央服务器对文件进行归档（存储），可以通过客户应用程序请求获得。也是一种局域网结构，其中文件和其它资源保存在一台中央服务器计算机上，人们通过客户机同网络交互。


 CMIP 通用管理信息协议
：CMIP(Common Management Information Protocol)是建立在开放系统互连通信模式上的网络管理协议。相关的通用管理信息服务（CMIS）定义了访问和控制网络对象，设备和从对象设备接收状态信息的方法。


  • CMOS 可读写芯片

    CMOS是主板上一块可读写的RAM芯片，用于保存当前系统的硬件配置信息和用户设定的某些参数。CMOS RAM由主板上的电池供电，即使系统掉电信息也不会丢失。对CMOS中各项参数的设定和更新可通过开机时特定的按键实现（一般是Del键）。进入BIOS设置程序可对CMOS进行设置。一般CMOS设置习惯上也被叫做BIOS设置。


  • CNNIC 中国互联网络信息中心

    中国互联网络信息中心是成立于1997年6月3日的非盈利管理与服务机构，行使国家互联网络信息中心的职责。中国科学院计算机网络信息中心承担CNNIC的运行和管理工作，CNNIC在业务上接受信息产业部领导，在行政上接受中国科学院领导。CNNIC工作委员会，对CNNIC的建设、运行和管理进行监督评定。


  • 公用对象请求代管者体系结构 Common Object Request Broker Architecture

    公用对象请求代管者体系结构（CORBA） CORBA是对象管理组（OMG）在其对象管理体系结构（OMA）中所定义的基本对象消息传递技术规范。OMG联合了大约200家公司，其中许多为OMA的形成做出了贡献，包括DEC、惠普、HyperDesk和SunSoft。该体系结构也被基本目的是开发多供应商公用应用程序环境的X／Open小组和开放软件基金会（OSF）采纳，OSF正在开发可移植的系统软件，它们是分布式计算环境（DCE）和分布式管理环境（DME）。

    应该指出的是，CORBA的竞争对手是Microsoft的对象链接与嵌入（OLE），OLE在其Windows产品和即将推出的面向对象的操作系统Cairo中实现，它关心的是在Windows台式系统应用程序之间共享对象，然而，CORBA却注重互联网和互用（交叉平台）对象的通信。通过联合Digital公司，开发形成了公用对象模型（COM），Microsoft公司能够间接使用CORBA技术。

    正如在“对象管理体系结构（OMA）”中所述，OMA由4个主要部分组成：

    应用程序对象 它是可选的即插即用应用程序，如电子报表程序和字处理程序。

    公用功能 它是位于公用区域内的程序，所有的应用都能访问它们。公用功能减少了冗余代码。

    对象服务 它提供了实现对象技术的基本服务。

    对象请求代管者（ORB）它是对象之间用来通信的公用接口。

    ORB提供了对象之间通信的接口，它也提供了消息格式以便具有不同接口的对象能够相互通信。可以把ORB想象成执行下列功能的智能消息传输总线：

    接收来自其它对象的请求。

    寻找能服务这个请求的“提供者”对象。

    把送到目的对象的消息格式化。

    将结果格式化并返回给请求者。

    这个过程令人感兴趣的部分是ORB能在分布式环境中寻找提供者，即使这个对象位于另一个城市的广域网链路上。程序员和管理人员能指定应使用的对象，而且ORB能通过使用闲散系统或高性能系统上的对象来优化分布式系统。

    对象技术对于将来实现分布式系统非常关键，这类系统的复杂性因为实现了消息传递服务的对象模型（如ORB）而得到简化。对象只是简单地提出请求，服务由其它对象提供。开发者不必过多地了解对象与之通信的系统。实际上，对象技术提供了一种设计本地应用程序的方法，该应用程序将来能扩充到分布式环境中。

    CORBA包括下列部件：

    ORB驱动程序（ORB engine）。

    动态调用接口。

    接口定义语言（IDL）。

    对象适配器。

    ORB接口。

    工具库。

    接口库。

    ORB由许多供应商各自实现，所以将来开发的重点在于提供ORB之间的互用性。这将在CORBA的2．0版本中实现。OMG也致力于为CORBA提供标准接口。

    相关条目：Object Linking and Embedding对象链接与嵌入；Object Management Architecture 对象管理体系结构；Object Management Group对象管理组；Object－Oriented Interface and Open System 面向对象的接口和操作系统；Object-Oriented Technology面向对象技术；Object Request Broker对象请求代管者；Objects对象，目标，实体。


  • 公用开放软件环境 Common Open Software Environment

    COSE是一个供应商联合会，其中包括IBM、HP、SunSoft、Novell公司。这些供应商联合为UNIX推出一个能与MicrosoftWindows匹敌的公用台式系统环境（CDE）。这个组织的目标是：

    为上述厂商系统所支持的通用台式系统图形环境开发一个提供应用程序编程接口（API）的规范。

    采用公用网络环境。

    标识相互认可的图形、多媒体和对象技术。

    定义分布式系统的系统管理。

    这个规范说明了应用程序间通信和消息传递；数据显示；编辑；对象管理；视窗管理；台式系统集成；剪切与粘贴；鼠标拖拉与放置等操作。规范提交给X／Open（加州的Menlo Park）评估。一般说来，COSE规范定义一个非常接近于Microsoft Windows的环境。随着Microsoft WindowsNT及其Windows接口的出现，UNIX与初始的COSE面临着更大的竞争。

    COSE规范包含下列环境和技术组成部分：

    HP的虚拟用户环境（VUE）。

    IBM的公用用户访问模式和一个面向对象的用户接口OS／2 Release 2．0 Workplace Shell。

    开放软件基金会（OSF）的Motif工具箱（Motif Tool kit）和Windows管理器（Windows Manager）

    SunSoft公司OpenLook与台式产品工具（ToolTalk）和一个称为开放网络计算机加（ONC＋）的分布式计算服务与联网协议集。

    UNIX系统实验室（USL）的台式系统管理器（Desktop Manager）．

    Sun公司开放网络计算（ONC）环境的远程过程调用（RPC）和开放软件基金会（OSF）的分布式计算环境（DCE）。

    标准通用标记语言（SGML），它提供集成和共享建立在其它环境中信息的手段。

    多用途Internet邮件扩充（MIME），Internet环境下的一个复合文档标准。

    随着向USL购买，Novell获得了对UNIX SVR4的控制，这使其他UNIX厂商惊慌失措。为了努力统一公用UNIX操作系统工业，Novell将源代码和UNIX商标给予X／Open组织。X／Open将获得与COSE小组定义的一个规范集相兼容的UNIX实现的UNIX商标。这个规范集称为COSE Spec 1170 APIs，它定义了提高操作系统间应用程序可移植性的一个编程接口。

    相关条目：UNIX UNIX操作系统。


  • IBM IBM的通信公用编程接口 Common Programming Interface for Communication

    IBMIBM的通信公用编程接口（CPI－C） CPI－C是一个高级通信接口，是IBM公司的系统应用体系结构（SAA）中公用编程接口大家族的一员。它用于为SAA平台间的应用程序，如IBMMVS（多道虚拟存储）、VS（虚拟存储）、OS／4oo和基于OS／2的系统的执行提供一个公用环境。

    CPI－C最重要的功能是它提供了一个LU 6．2（逻辑单元6．2）服务接口，LU 6．2是IBM的高级程序对程序通信（APPC）的技术名称。开发LU 6．2是为了允许IBM环境中的计算机能建立自己的通信会话，而不是依赖主机来实现。LU 6．2在系统之间而不是在主机之间提供对等通信，并允许这些系统运行分布式应用程序如文件共享与远程访问。LU 6．2支持全部的IBM平台，包括局域网、台式系统和大型计算机。

    CPI－C是当前与LU 6．2接口的一个较流行的方法，还有一个较老的接口称为LU6．2协议边界（Protocol Boundary）。IBM在其联网方案（Networking Blueprint）中实现了CPI－C，提供到开放系统互连（OSI）及传输控制协议／Internet协议（TCP／IP）传输协议的映射，IBM也把CPI－C提交给X／Open组织，X／Open组织将采纳它作为开发客户机／服务器事务处理应用程序的标准。

    IBM在其CPI－C的实现中影响着X／Open并支持诸如CPI－C应用程序之间全双工通信之类的功能，所以程序能同时发送和接收数据。它也支持多供应商分布式目录服务，包括X．500和开放软件基金会（OSF）分布式计算环境（DCE）中的目录服务。这些服务让应用程序不需要知道物理位置信息就能定位用户与资源。

    相关条目：Advanced Program－to－program Communications高级程序对程序通信；Networking Blueprint IBM的联网方案；Systems Application Architecture系统应用体系结构。


  • 通信控制器 Communication Controller

    通信控制器管理到主机或计算机网络的数据输入输出。它可以是复杂的前台大型计算机接口或者简单的设备如多路复用器、桥接器和路由器。这些设备把计算机的并行数据转换为通信线上传输的串行数据，并完成所有必要的控制功能、错误检测和同步。现代设备还完成数据压缩、路由选择、安全性功能，并收集管理信息。举例如下：

    终端服务器用于将大量终端连接到主机系统。所有终端连接进一个盒子里，这个盒子通过网络或远程链路与主机相联。

    前台处理器提供终端和网络到主机系统的连接。

    多路复用器把来自多个设备的数据流合并到一条线路，使用各种介质进行传输。

    中继器、桥接器、路由器用来互连局域网。

    在IBM大型计算机环境中，通信控制器为IBM3750，IBM 3720，IBM 3725和IBM 3745。这些设备用于将远地的群控器连接到主机。可行的连接方法有两种。在第一种方法中，远地的群控器通过远程通信链路连接到主机方与主机相连的通信控制器；在第二种方法中，通信控制器在远地并提供一个多群控器的连接点然后这个通信控制器管理来自群控器的信息流，再通过远程通信链路传送给主机方与主机相连的通信控制器。

    通信控制器常称作前台处理器，因为它是一个主机系统的分离设备，处理所有与外部设备，如终端的通信。这就防止主机不断地被外部设备打断，使得它能更有效地处理应用。通信控制器实现下列功能：

    在终端与网络节点之间建立通信会话。

    管理通信链路上的数据通信和控制数据的流动。

    集中群控器的连接，并轮询群控器看他们是否有数据要传送。

    为数据的输入或输出提供缓冲。

    检错和纠错。

    提供数据传送到目的地的路由选择功能。

    通信控制器实际上是一台计算机，内部有总线、存储器和中央处理器（CPU），还包含与主机通道连接的适配器和与群控器连接的接口部件。CPU管理通道适配器与接口部件之间的数据流。

    IBM通信控制器包括较早的已停止使用的3705和具有增强功能的新型号：

    IBM 3705 提供128至353个速率可达230．4Kbps的通信链路，能处理BISYNC．SDLC或ASCII协议，它支持8个通道连接的主机，它依赖主机进行控制和诊断。

    IBM 3725 设计作为对IBM3705的取代。有两种型号：1型支持达256条全双工通信链路和8个主机；2型支持80条全双工链路和4个主机。

    IBM 3720 一种廉价控制器。对于价格较低的主机如IBM 9370主机比较理想。不同型号提供与16至28条通信链路的直接或远程连接，还具有一个令牌环接口。

    IBM 3745 于1988年首次推出的通信控制器。有两种型号：210型只有一个控制单元；410型有两个控制单元，可作为两个独立的通信控制器工作或者一个作为备用或备份支持以防止软件或硬件发生故障。210型可升级到410型以支持多达16个主机和8个令牌环适配器，这些设备还包括存放有重新启动软件模块的硬盘。

    相关条目：IBM Mainframe Environment IBM大型计算机环境；System Network Architecture系统网络体系结构。


  • 通信服务器 Communication Server

    通信服务器是一个专用系统，为网络上需要通过远程通信链路传送文件或访问远地系统或网络上信息的用户提供通信服务。通信服务器根据软件和硬件能力为一个或同时为多个用户提供通信信道。通信服务器可能提供一个或多个下列功能：

    网关功能 通过转换数据格式、通信协议和电缆信号提供用户与主机的连接。

    访问服务 允许远地用户从家里或其它远距离位置经拨号进入网络，这种类型系统将在本节“远程控制软件”中进一步讨论。

    调制解调器 通信服务器能为内部用户提供一组异步调制解调器，用于拨号访问远地系统、信息服务或其它资源。

    桥接器和路由器功能 维持与远地局域网的专用或拨号（间歇的）链路并在局域网间自动传送数据分组。

    电子函件服务器 自动连接其它局域网或电子邮局，收集和传递电子函件。系统可以按规定时间间隔呼叫，或者有足够的电子函件输出时就进行呼叫。

    Remote Control Software 远程控制软件

    远程工作站是一台单独的远地PC机，使用一种异步通信方法和调制解调器经拨号进入局域网。其使用者可能是在家里工作的雇员、远地的管理人员或需要检测公司数据库的部门代表。可通过以下两种方法建立远程工作站会话：

    远程执行 在远程执行方法（有时称为“远程节点”）中，所有的处理都在远程工作站上进行。用户所需的程序和数据文件必须经通信线路传送到用户工作站上处理，除非文件已事先拷贝到了工作站上。该方法不适用于和信息系统实时交互。

    本地执行 本地执行方法把一个局域网上的专用工作站连接到远地工作站，所有的处理在专用工作站上进行，而显示返回到远程工作站屏幕上，用户能键入键盘命令。这种方法很有效，因为只有键盘和屏幕信息在远程连接上传输，然而必须在局域网上安装一台计算机以运行远程用户的通信会话。

    产品如Microcom公司Carbon Copy、Norton－Lambert公司的Close－Up和Symantec公司的NortonpcANYWHERE，它们提供的远程控制能力有：

    使远地工作站的用户感到好象工作在与LAN直接相连的工作站上一样。

    用户能实时访问数据库文件，响应时间很短。

    文件和数据库访问按局域网的速度实现，这是因为所有的处理都由本地的网络工作站完成，只有键盘输入和屏幕显示要在本地PC机与远程工作站之间传送。

    NetWare访问服务器软件 Novell公司的NetWare访问服务器（NAS）软件提供了一个能运行多达15个远程会话的专用通信服务器。该软件在80386或更快的系统上运行。如果准备同时运行多于5个的会话，最好使用80486。该软件充分利用80386的功能，将它的处理时间分成15台虚拟的640KBPC机。这为多用户的远程访问提供了15台虚拟机。可在系统中安装多端口串行卡以适应调制解调器。图C－23显示了这种配置。

    NetWare访问服务器软件提供了与远程控制软件相同的功能，不同之处仅在于它是一个支持多达15个用户的单一系统，本地网络工作站不需要抽时间来执行为远程用户的任务。该软件提供了一种“回拨”的安全特性，用户返回呼叫以验证他们呼出的当地电话号码。这就保证了另一个地方的未授权用户不能企图拨号进入。一个称为NetWare Connect的新产品提供了这些及其他一些功能。


  • 通信服务 Communication Services

    参见“电信服务”条目。


  • 通信 Communication

    Communication 通信 参见“数据通信（Data Communication）”条目。


  • 复杂指令系统计算机 Complex Instruction Set Computer

    Complex Instruction Set Computer （CISC） 复杂指令系统计算机（CISC） 微处理器是台式计算机系统的基本处理部件，每个微处理器的核心是运行指令的电路。指令由完成任务的多个步骤所组成，例如把数值传送进寄存器或进行相加运算。这些指令被称为微理器的微代码（microcode），不同制造商的微处理器有不同的微代码系统，制造商可按自己的意愿使微代码做得简单或复杂。指令系统越丰富，微处理器编程就越简单，然而，执行速度也相应越慢。下面的对比显示了两类微处理器的差异：

    复杂指令系统计算机（CISC）方案 包含一个丰富的微代码系统，简化了处理器上运行程序的编制。

    精简指令系统计算机（RISC）方案 顾名思义，它有一个精简的指令系统。从而提高了微理器的效率，但需要更复杂的外部程序。

    RISC方案基于John Cocke在IBM公司的工作，他发现约20％的计算机指令完成约80％的工作。因此，RISC系统通常比CISC系统要快。他的80／20规则促进了RISC体系结构的开发。

    大多数台式微处理器方案如Intel和Motorola芯片都采用CISC方案；工作站处理器加MIDS芯片DEC Alpha和IBM RS系列芯片均采用RISC体系结构。当前和将来的处理器方案似乎更倾向于RISC。

    相关条目：Reduced Instruction Set Computer 精简指令系统计算机。


  • 复合文档 Compound Documents

    复合文档不仅包含文本而且包括图形、电子表格数据、声音、视频图象以及其它信息。可以把复合文档想象成一个所有者，它装着文本、图形以及多媒体信息如声音和图象。目前建立复合文档的趋势是使用面向对象技术，在这里，非标准信息如图像和声音可以作为独立的、自包含式对象包含在文档中。流行的台式环境如Microsoft Windows和Macintosh均使用这种技术，如下所述：

    Microsoft Object Linking and Embedding（OLE）是许多Windows产品所具有的对象技术，它包含网络连接功能，以便用户能共享对象

    Apple Amber是一个使用称作Bento文档内容标准的复合文档体系结构。Amber是一个开放标准，能与Microsoft OLE 2．0完全交互操作。如果开发者所开发的应用程序与Amber兼容，那么该程序也与OLE 2．0兼容。Bento是一种多媒体信息的文件转换格式

    Lotus Development′s Link，Embed，and Launch－to－Edid（LEL）是一个对象链接标准，它为UNIX环境下的Lotus Notes用户提供一个类似MicrosoftOLE环境。LEL用在Sun、HP、IBM和Novell这些公司所开发的UNIX版本，Windows下建立的文档也能在UNIX中读取。

    Common Object Request Broker Architecture（CORBA）是由对象管理组开发的一个标准，它为对象在多供应商产品环境交换信息提供一种途径，在这种情况下，对象是指复合文档的一个成分。

    除了这些对象标准外，还有文档体系结构和语言，可用来为建立可移植于多个系统的复合文档提供一条途径。考虑一个ASCII（美国国家信息交换标准代码）文档，它包含标准文本字符。所有台式计算机都能识别ASCII，所以可把DOS计算机上建立的ASCII文件传送到Macintosh计算机上。文档体系结构和语言力求建立通用文档，使得它能从一个平台移到另一个平台，同时保持全部格式如文档使用的字形。详细内容参见“文档交换标准”条目。

    Object－Oriented Compound Documents面向对象的复合文档

    对象（Object）是一个自含式信息块，附有描述数据的额外信息：怎样格式化它，建立它的应用程序，以及当它保存在单独磁盘文件中怎样定位相关信息的位置等等。复合文档是对象和文本的集合，图C－24描述的是一个在Microsoft Windows下使用对象链接与嵌入（OLE）技术生成的复合文档。其它操作环境也正在实现类似技术，所以这个术语可以认为是通用的。例如，多功能Internet邮件扩展标准（MIME）是在Internet环境下交换包含文本、图形、声音、图象等信息邮件的复合文档标准。

    本节下面描述Windows环境下的复合文档。有许多相关主题描述了文档体系结构、文档描述语言和电子文档交换。参见“文档交换标准”、“文档管理”、“电子数据交换”、“群件”、“对象管理体系结构”、“标准通用标记语言”和“工作流软件”条目。

    复合文档改变了用户组织文档以及与网络上其他用户协同工作的方法。它们提供了一个新的文档观念。在老的以应用为中心观念（application－centric view）中，用户同时注意在单一应用程序的功能上。为了生成有图形、文本等多种成分的复合文档，必须能够从一个应用程序转到另一个应用程序，然后分别打印每个成分。OLE提供了一个以文档为中心的观念（document－centric view）。其中，文档成为用户组织和操纵文献、项目或报告中所有成分的地方。所有成分保存在一个文档里，当打印文档时就打印了所有的成分。当编辑复合文档里的任何一个成分时，用户只需选择该成分图标并双击鼠标，建立该成分的应用程序就会出现在屏幕上。在OLE 2．0中，用来编辑成分的应用程序的各组成部分在编辑完成前实际上取代了下拉菜单等组成部分和当前应用程序的工具，这种基本的功能称为嵌入（embedding）

    提示：嵌入的主要优点是：在其它应用中所创建的成分存储在单一文件之中而不是分别存储于不同文件，减少了磁盘簇链和交叉引用。

    链接（Linking）比嵌入更动态，但每个成分必须作为一个独立的磁盘文件。在这种方案下，用户打开并修改每个成分的磁盘文件。被链接文件的自动改变有利于对复合文档中这些文件的引用。代表复合文档中的对象的文件可以位于网络上的任何地方，例如，图形部门的艺术家能为市场部门建立的复合文档提交图形成分。任何时候，艺术家都可修改其计算机上的原始文件，当市场部门的用户打开复合文档时，应用程序检查艺术家的计算机上的文件是否被修改了，并在必要时更新复合文档。

    在Windowsfor Workgroup和Windows NT环境中，一个称作Clipbook的实用工具为网络上的工作提供切割与粘贴功能。你可把与其他用户共享的对象放在ClipBook中。用户然后就可以在他们的计算机上打开ClipBook，并把对象粘贴进他们的文档。这些对象维持了一条到你的计算机上的文件的链接，所以如果你修改了文件，其他用户文件中的拷贝也发生改变。然而．如果你没有开机，其他用户就不能从你的计算机上得到更新信息。

    相关条目：Document Interchange Standards文档交换标准；Object Linking and Embedding对象链接与嵌入；Workflow Software工作流软件。


  • 压缩技术 Compression Techniques

    随着多媒体、视频图象、文档映象等技术的出现，数据压缩成了网络管理员的一个重要课题。数据压缩基本上是挤压数据使得它占用更少的磁盘存储空间和更短的传输时间。压缩的依据是数字数据中包含大量的重复，它将这些重复信息用占用空间较少的符号或代码来代替。基本的压缩技术有：

    空格压缩（Null Compression） 将一串空格用一个压缩码代替，压缩码后面的数值代表空格的个数。

    游长压缩（Run－Length Compression）它是空格压缩技术的扩充，压缩任何4个或更多的重复字符的串。该字符串被一个压缩码、一个重复字符和一个代表重复字符个数的值所取代。

    关键字编码（Key－word encoding）创建一张由表示普通字符集的值所组成的表。频繁出现的单词如for、the或字符对如sh、th，被表示为一些标记（token），用来保存或传送这些字符。

    哈夫曼统计方法（Huffman statistical method）这种压缩技术假定数据中的字符有一个变化分布，换句话说，有些字符的出现次数比其余的多。字符出现越频繁，用于编码的位数就越少。这种编码方案保存在一张表中，在数据传输时，它能被传送到接收方调制解调器使其知道如何译码字符。

    因为压缩算法是基于软件的，所以实时环境中，存在着额外开销，会引起不少问题。而文件备份、归档过程中的压缩不会有什么问题。使用高性能的系统有助于消除大部分的额外开销和性能问题。另外，压缩消除了文件的可移植性，除非解压缩软件也与文件一起传送。

    注意，有些文件已经被压缩，进一步的外部压缩不会有任何好处，一些图形文件格式，如标签映象文件格式（TIFF），就已经包含了压缩。

    Storage System Compression存储系统压缩

    在讨论文件存储的压缩算法之前，应该明确文件压缩不同于磁盘编码。磁盘编码通常由磁盘驱动器把更多的数字1和0写到磁盘的物理表面上。文件压缩把文件中的字符和位串挤压到更小的尺寸。它在文件信息传送到硬盘驱动器的写头之前由软件完成。现代的使用编码的硬盘驱动器只是从CPU接收1和o的位流，并且把它们压挤到比没有使用编码小得多的空间中。磁盘编码简单讨论到这儿，下面将着重讨论文件压缩。

    磁盘记录系统如硬盘驱动器通过改变磁盘表面的磁场来记录信息。两种可能状态间的磁场变化称为磁通翻转（flux transition）。简单地说，磁通翻转代表数字1，磁通不翻转代表数字0。编码提供了一种方法使每个磁通翻转代表更多数字信息。改进调频制MFM（Modified frequency modulation）将一个磁通翻转表示多个1，将磁通不翻转表示多个o。编码技术包括下述几种。

    游长受限码（Run Length limited（RLU））把位组合格式表示为代码，可以用较少的磁通翻转来存储。与MFM相比，存储容量提高了5o％。

    改进的游长受限码（Advanced run length limited（ARLL） 通过把位组合格式转换成能用四倍密度磁通翻转来存储的代码，从而把MFM的记录密度翻了一倍。

    因为磁盘编码是由硬盘驱动器在硬件级自动处理的，这里没有必要进一步讨论。当你购买一个硬盘驱动器，它使用一种编码方案而获得一定的容量，但是只要驱动器的容量满足你的要求，购买后，就不必关心它的编码方案了。

    文件压缩技术

    文件压缩的实现有几种方式，提供的各种工具使你能每次压缩一个文件，或压缩一组文件。一组文件能压缩成单个文件，更易于传送到其它用户，解压缩工具把文件解开。一个流行的共享文件压缩工具称为PKZIP（威斯康辛州Glendale的PKWARE公司），用于CompuServe和其它公告牌软件上压缩文件，可以从大多数公告牌服务上卸下PKZIP。

    大多数操作系统，包括DOS、NetWare、Windows NT等现在都包含压缩软件。在NetWare 4．x中，能自动压缩指定文件或整卷上的或指定目录中的所有文件。指定文件属性能被设置以标记你希望系统在它们不用时自动压缩的文件。启动自动压缩系统时要小心，一些应用程序由于文件处在压缩状态而不能正常工作。

    文件压缩里两个重要概念是无失真（lossless）和有失真（lossy）：

    无失真压缩（Lossless Compression）无失真压缩系统假定从已压缩文件中返回所有信息，文件中每一位都是重要的，所以压缩算法精确地压缩和解压文件。

    有失真压缩（Lossy Compression）有失真系统假定在压缩和解压过程中允许一定的信息损失。许多高清晰度的图形文件包含的信息如果在压缩阶段丢失了也不会引起变化。例如，如果你以高分辨率扫描彩色图画，但是你的显示器不能显示这种清晰度，你就可以使用有失真压缩方案，因为不会遗漏细节。声音和图象文件也适于用有失真压缩，因为信息损失引起的变化很小，解压播放时可能觉察不出来。

    虽然无失真压缩中没有信息损失，但压缩比通常只有2∶1，有失真压缩根据被压缩信息的类型提供的压缩比从100∶1至200∶1，声音和图象信息能很好地压缩，因为它通常包含大量冗余信息。

    Grraphics Video and Voice Compression图形、视频和声音压缩

    随着多媒体和电视会议的出现，高效的压缩系统变得重要起来，根据视频图象分辨率，一幅典型的彩色图形图象需占用2MB或更多的磁盘空间，1秒钟未压缩的全运动视频图象所需磁盘空间约10MB。网络管理员关心多媒体文件的大小是因为将它们拷贝到服务器或其他用户时会占用网络带宽。

    幸运的是，大多数多媒体图象能使用前面讨论过的有失真压缩技术。在视频图象压缩中，每帧必须是通过删除冗余信息进行精简的象素阵列，视频图象压缩通常使用特殊的集成电路来处理，而不是使用软件，因为软件操作太慢。标准视频图象一般约为30帧／秒，但有些研究发现对许多观众来说16帧／秒也可接受，所以帧删除方法提供了另一种压缩方式。

    处理多媒体信息的几个压缩标准描述如下：

    联合图象专家组（JPEG）压缩（Joint Photographic Experts Group（JPEG）compression）JPEG使用普通算法压缩静态图象。三维彩色和坐标图象信息首先被转换成更适于压缩的格式。颜色信息也被编码，如果系统不能使用的话，则删掉一部分。压缩值是用户可选的，取决于能容忍的图象降级的程度。一旦这些初始设置被确定，就可使用无失真或有失真压缩技术来压缩文件。JPEG不是为处理视频图象而专门设计的，但通过压缩帧并减小帧的尺寸与频率，它在一定程度上做到了这一点。

    片段压缩（Fractal Compression）在Iterated Systems公司开发的片段压缩技术中，随着压缩启动程序（一种专用板）使用一种以各种方式操作片段的数学变换来寻找图象中的匹配模式时，图象被分成越来越小的片段。重复的模式被保存起来以重建原始图，不匹配的数据被认为是不重要的并被删掉。用户可选择处理运行的时间量，它决定了对数据的压缩量。

    音频－视频交替（AVI）（Audio－Video Interleave（AVI））AVI由Microsoft开发，作为一种在CD－ROM盘上存储活动视频图象的方法。读取信息时使用软件解压。这种技术结合了无失真技术和一种快速但并非有效的特殊压缩算法。AVI图象减少了每秒的帧数，从而产生令人不满意的图象。然而，对某些应用来说，这种技术是可以接受的。

    数字视频交互（DVI）（Digital Video Interactive（DVI））DVI是由Intel开发的活动视频图象压缩方案，被认为是事实上的标准。与AVI相似，它最初用于CDROM应用，并成功地把视频图象以这种格式带到了台式系统。

    Indeo视频图象（Indeo Video）Indeo视频是一种数字视频图象记录格式和压缩软件技术，它能够将视频图象文件压缩到未压缩前的1／5至1／1o。例如，Indeo能将一个5oMB的文件减小到9MB。Indeo类似的产品有Microsoft Video for Windows、OS／2操作系统和Apple Quicktime for Macintosh and Windows。播放根据提供的硬件类型而优化，所以较快系统上的帧播放率会有所提高。视频图象的记录使用Intel i750视频图象处理器来优化，因为视频图象在接收时就被压缩，而不是先存储再压缩。它使用了多种压缩技术，包括有失真和无失真技术。

    运动图象专家组（MPEG）（Motion Picture Experts Group（MPEG））MPEG正在开发若干视频压缩标准，该标准定义国际通用格式、数据速率和压缩技术。MPEG－1规范定义了音频和视频以及如何以1．5Mbps至2Mbps的速率从盘上访问全运动视频图象。MPEG－2致力于提供质量超过NTSC、PAI和SECAM广播系统的全运动视频图象。

    其它压缩方法正处于研究阶段，现有的方法也正被重新修订，CCITT委员会正在从事可视电话和综合业务数字网（ISDN）上的电视会议以及其它一些服务的标准的制订。

    Compression for Datoo Communication数据通信压缩

    压缩可以提高广域链路中的吞吐量。在你需要决定链路是使用由调制解调器连接的较便宜的电话线还是使用较昂贵的专用连接时，若你要选择较便宜的方案，一个拥有数据压缩功能的调制解调器会提供额外的吞吐量。

    如果需要全时（full－time）连接，数据压缩也会帮助你充分利用这些连接。然而，也会有限制，如果传输速率超过了64Kbps，在广域网的连接点上就不能自动地完成数据压缩，因为压缩跟不上线路的速度。解决的办法是在发送之前使用PKZIP之类的压缩工具把文件手工压缩到较小的长度，文件压缩后被传送到接收方，由接收方将其解压缩。

    调制解调器制造商使用了许多前面提及的数据压缩技术，但随着CCITT V．42bis数据压缩标准的采纳和在大多数调制解调器中的具体实现，Lempel－Ziv技术逐渐流行起来。Motorola Codex已经实现了数据速率超过100kbps的测试，虽然目前的限度是28．8Kbps．

    在Lempel－Ziv数据压缩算法中，所有单字符串占据了整个表。当新字符串出现时，就建立一种类似于图C－25所示的树型结构，该图显示了树的“T”分支。注意沿着树的任何一个分支，可演绎出一个三字符的词。树的每个分支由一个码字来标识，在所有的传输中传送的都是码字。如果出现新字符串，就在树的适当分支上增加节点，并生成一个新的码字来代表它。

    还有其它压缩方法如Microcom联网协议（MNP）类型5和类型7系列。但是近几年V．42标准是大多数调制解调器厂商使用的压缩方法。

    相关条目：Modems调制解调器；Videoconferencing and Desktop Video电视会议与台式（桌面）视频系统。


  • 集中器设备 Concentrator Devices

    集中器（Concentrator）是连接终端、计算机或通信设备的中心连接点设备。它能成为电缆会合的中心点。技术上，一个集中器聚合一定数量的输入线和一定数量的输出线，或者为许多设备提供一条中心通信链路，集中器设备有多种类型，大部分用于大型计算机世界，下面我们将对它们逐一讨论。

    集中器 在大型计算机环境下，集中器能合并来自许多终端的线路并在分层方案中提供到另一个集中器的连接，或者直接连到主机的前端处理机。使用多路复用方法或争用方法可在一条高速线路上传输来自多条慢速终端线路的数据。在多路复用方法中，一个终端在多路复用流中得到一个固定的时间片；在争用方法中，每个低速线路在短期内能获得高速线路的全部入口。

    前端处理机 前端处理机与上面谈到的集中器功能相似，但是它通常是一台专用计算机，能够较高速地实现集中器功能并支持更多的附属设备。

    局域网集中器 在局域网环境下，集中器已由简单的线路管理设备发展为提供“紧缩主干（collapsed backbone）”、桥接和路由功能的Hub设备。紧缩主干相当于把一个总线电缆系统，如细同轴电缆以太网压缩进一个小盒子里，然后用较便宜的双绞线连到每个工作站。可以把双绞线从每个工作站连到中心点的集中器或Hub，而不是以菊链配置把同轴电缆从一个工作站连到另一个工作站。Hub是模块化设备，可插入许多多端口集中器卡。模块卡通常为工作站连接提供8至12个RJ－型的插孔，所以增加的卡越多，能在Hub上集中的连接就越多，参见“Hubs”条目。

    端口共享和选择装置 端口共享装置用于远地的多个终端共享一个到计算机或主机系统的调制解调器连接。它安装在终端和调制解调器之间。

    多路复用器 多路复用器最初的设计是，基于减少需要通过远程通信链路与主机设备通信的终端设备的数据传输开销。多路复用器将来自多个终端的数据混合到一条线路上，混合后的数据在另一端带有多种译码器的链路上进行传送。多路复用调整了租用高速数字链路（如T1）的价格。一种取代方法可以是为每个终端租用一条低速的模拟专用链路以及把它们连接到线路上所需的调制解调器设备。多路复用器有多种类型：时分多路复用器依次为每台设备在数据流中分配一时间片；频分多路复用器提供多个频带信道使每个设备用一个信道进行通信，详细内容参见“多路复用”条目。


  • 调节 Conditioning

    调节线是普通电话线经过放大和衰减均衡，以减少由噪声、相位抖动和失真引起的传输问题。电话公司根据要求提供线路调节，当以高速率如19，200bps进行通信时，常常有必要提高传输性能。租用数字线如T1和T3就经过了调节。


  • 配置管理 Configuration Management

    配置管理涉及网络管理的很多方面，在其最简单的形式中，网络管理人员维护一个具有关于桥接器、路由器、工作站、服务器以及网络上其它设备的各种信息的数据库。当需要改变网络配置或判断某些故障原因时，他们就可参考这些信息。这个数据库能包含重要的永久性信息，如物理连接和附属构件。

    在先进的配置管理系统中，在网络设备上就可以实现对中央数据库的设置进行修改。例如，可能有必要在企业网上改变一个子网的标识号，这需要更新所有路由器以便它们能寻址这个子网。在一个自动化系统中，在数据库中进行修改并且通过在网络上发送更新命令的管理软件可对路由器进行自动更新。

    网络的配置管理所涉及的内容有口令管理、打印配置、用户或组管理等。信息在中心地区管理，必要时分发给远地的系统。在软件方面，配置管理可从一个地方提供软件安装、更新和重新配置。该处理应跟踪版本号、许可证，并且在需要它们的系统上实施更新。信息数据库提供了这类信息，因为它跟踪了结点的版本号。

    在硬件方面，配置管理所提供的系统配置方法是，一旦安装了新的硬件，它就对系统进行配置并把这个信息报告给相关的系统。诸如顺序号设置、版本号之类的信息都返回给管理数据库。一旦管理系统得知硬件所在的位置，它就能自动更新驱动程序。

    随着网络规模的扩大，配置管理软件以及其它中心定位的管理软件（如安全性、记帐和性能跟踪）变得更为重要。由于旅行时间和花费的原因，网络管理人员不可能去现场完成这些功能。利用当前网络使该过程自动化是一项当然和经济的措施。

    The Desktop Management Task Farce（DMTF）台式系统管理任务组（DMTF）

    DMTF是一组厂商，他们从事于管理联网的台式系统的协作策略。DMTF签约成员包括DEC、HP、IBM、Intel、Microsoft、Novell、Sunconnect和SynOptics。

    DMTF主要致力于规定一种方法来访问能集成到许多管理环境中的台式管理信息。DMTF计划为台式系统管理建立一个开放的应用程序编程接口（API）集，它还将规定管理台式系统管理部件的方法。API和相关的规程称作台式系统管理接口（DMI）。

    DMI为访问网络上的台式计算机的硬件和软件建立了一个公用的规则集，这个接口运行在多厂商台式系统上，但可为许多厂商管理系统提供信息。DMI能在各种部件上实现，如视频卡、传真机、调制解调器、打印机、大容量存储设备、网卡，以及简单网络管理协议（SNMP）和LCC上的公用管理（CMOL）控制台。

    相关条目：Desktop Management Interface 台式［桌面］系统管理接口；Desktop Management Task Force台式［桌面］系统管理任务组；Distributed Management 分布式管理；Distributed Management Environment分布式管理环境；Management Standards and Tools管理标准与工具。


  • 无连接和面向连接事务 Connectionless and Connection－Oriented Transactions

    事务是一项独立的工作，一般是商业事务的一部分，它包括大型计算机或后台服务器系统中数据库的修改。联机事务处理（OLTP）用于在实时环境中收集和处理与事务相关的数据并且修改共享的数据库和其它文件的内容。联机事务处理意味着事务立即被执行，即是面向连接的事务。面向连接的事务可能使用远程过程调用（RPC）或会话通信技术如IBM的通信公用编程接口（CPI－C）。还有命名管道，它是OS／2中同步两个网络节点交换的机制。

    事务也可以是面向批处理的，其中，一批事务被保存一段时间，以后再运行。另外，SQL（结构化查询语言）数据库使用存储的过程，其中，客户把保存在服务器上的一组过程作为一个单一的功能调用。存储的过程有助于最小化客户机和服务器之间的通信。

    无连接事务是面向消息的事务，使用存储－转发技术。用户以消息的形式发出请求或命令，然后等待回答。它的特点是，在客户机和服务器之间没有通信会话或连接，服务器可能经过很长时间才响应。消息传递系统包括IBM的消息排队接口，OS／2和Windows中的邮件槽和Novell的信报处理服务（MHS）。

    消息传递模式需要在数据交换的两端，即客户机和服务器，设置队列管理程序。消息在发送点被规格化并发送到接收点的相应队列。消息队列一般是异步的——一个事件必须在另一事件结束后才发生。然而，消息可从一个发送点传送到多个接收点。例如，消息可以分发到多个处理器，使它们能够并行执行某个任务。

    相关条目：Encina Encina产品；On－Line Transaction Processing联机事务处理；Tuxedo，UNIX System Laboratories UNIX系统实验室的Tuxedo 中间件。


  • 无连接网络协议 Connectionless Network Protocol

    CLNP相当于开放系统互连（OSI）因特网协议（IP），它们的主要区别是地址的长短不同。CLNP的地址长度是20字节，而IP的是4字节。所以CLNP被考虑用于Internet网上，以解决地址不够的问题。CLNP位于OSI协议栈的网络层，顾名思义，它在OSI网络上提供无连接的数据报服务。

    相关条目：Connection－Oriented and Connectionless Protocols面向连接的和无连接协议。


  • 面向连接和无连接协议 Connection－Oriented and Connectionless Protocols

    通信协议要么是面向连接的，要么是无连接的。这依赖于信息发送方是否需要与接收方联系并通过联系来维持一个对话（面向连接的），还是没有任何预先联系就发送消息（无连接的）且希望接收方能顺序接收所有内容。这些方法揭示了网络上实现通信的两种途径。

    在面向连接的方法中，网络负责顺序发送报文分组并且以一种可靠的方法检测丢失和冲突。这种方法被“可靠的”传输服务使用。

    在无连接的方法中，网络只需要将报文分组发送到接收点，检错与流控由发送方和接收方处理。这种方法被称作“最佳工作（best－effort）”或“无应答（unacknowledged）”的传输协议所使用。

    假定你想给你在另一个城市的朋友发送一系列信件，信件类似于通过计算机网络发送的数据分组。有两种发送方法，一种方法是把信件交给一位可信的朋友，由他私人传送，之后再向你证实已经发送。在这种方法中，你在传送的两端都保持着联系，你的朋友提供了面向连接的服务。另外一种是，你在信封上注明地址并将它们投进邮局，你并没有得到保证说每封信都会达到目的地，如果都到达了，它们可能在不同的时间到达并且不是连续的，这就象一个无连接服务。

    Connection－Oriented Communication面向连接的通信

    在面向连接方法中，在两个端点之间建立了一条数据通信信道（电路）。这条信道提供了一条在网络上顺序发送报文分组的预定义路径，这个连接类似于语音电话。发送方与接收方保持联系以协调会话和报文分组接收或失败的信号。但这并不意味着面向连接的信道比无连接的信道使用了更多的带宽，两种方法都只在报文分组传输时才使用带宽。

    为面向连接的会话建立的通信信道自然是逻辑的，常被称作虚电路（virtual circuit），它关心的是端点。与在网络上寻求一条实际的物理路径相比，这条信道更关心的是保持两个端点的联系。在有多条到达目的地路径的网络中，物理路径在会话期间随着数据模式的改变而改变，但是端点（和中间节点）一直保持对路径进行跟踪，图C－26所示为多路复用电路中的逻辑路径。

    一台计算机上的应用程序启动与另一台计算机的面向连接的会话，它通过访问基本的通信协议来请求这样的对话。在传输控制协议／因特网协议（TCP／IP）组中，TCP提供面向连接的服务，而IP（较低层的协议）提供传输服务。在NetWare SPX／IPX协议组中，SPX提供面向连接的服务。

    因为报文分组是通过虚电路传输的，所以并不需要使用全分组地址，这是由于网络已经知道了发送方与接收方的地址。网络路径上的每个节点都保持跟踪虚电路和需要交换分组的端口。顺序编号用来保证分组的顺序流动。虚电路需要一个建立过程，但电路一旦建立，它就为长时间的处理提供一条有效的路径，如由管理程序对网络站点的连续监控和许多大文件的传送。与此相比，无连接方法是设计用于突发的、暂时的通信，这种方法中如用虚电路建立就不是很有效的。

    面向连接的会话的建立过程如下：

    1．源应用程序请求一个面向连接的通信会话。

    2．建立会话（需要一段时间，是选用无连接的协议的一个原因）。

    3．在逻辑连接上开始数据传输。

    4．传输结束时，信道解除连接。

    在分组交换远程通信网络中，有些信道永不断连。两点之间建立的一条永久信道称为永久虚电路（PVC）（Permanent virtual circuits（PVCs））。PVC类似于专用电话线。

    面向连接的协议大部分位于与开放系统互连（OSI）协议模型相当的运输层协议中。通用的面向连接的协议包括Internet和UNIX环境下的TCP（传输控制协议）、Novell的顺序分组交换（SPX）、IBM／Microsoft的NetBIOS和OSI的连接模型网络协议（CMNP）。

    Connectionless Communication 无连接通信

    在无连接方法中，网络除了把分组传送到目的地以外不需做任何事情，如果分组丢失了，接收方必须检测出错误并请求重发；如果分组因采用不同的路径而没有按序到达，接收方必须将它们重新排序。无连接的协议有TCP／IP协议组的IP部分，NetWare的SPX／IPX协议的IPX部分和OSI的无连接网络协议（CLNP）。这些协议在与OSI协议模型相当的网络层中。

    在无连接的通信会话中，每个数据分组是一个在网络上传输的独立单元，称作数据报。发送方和接收方之间没有初始协商，发送方仅仅向网络上发送数据报，每个分组含有源地址和目的地址。

    该方法中没有接收方发来的分组接收或未接收的应答，也没有流控制，所以分组可能不按次序到达，接收方必须对它们重新排序。如果接收到有错误的分组，则将它删掉。当重新整理分组时，就会发现被删掉的包并请求重发。

    使用无连接的协议有许多好处。就性能来说，无连接策略通常更好，因为大多数网络上只有相对少的错误，所以被破坏的或丢失的分组很少，端点不需很多时间来重发。

    Comparing the Protocols协议的比较

    面向连接的服务更适于需要稳定数据流的应用，例如，与Novell NetWare一起提供的远程监控程序使用的是面向连接的协议SPX。面向连接的服务可靠性也更高，并能更有效从问题中恢复。

    虽然无连接的服务中每个分组有更多的额外开销，而面向连接的服务在端点上需要更多的处理来建立和保持连接。但是额外开销有时没有被证实，例如与局域网用户和服务器交互有关的短暂突发传输。

    相关条目：Connectionless Network Protocol无连接网络协议；Datagram Delivery Protocol数据报传递协议；Datagram Network Services数据报网络服务；Fast Packet Switching快速分组交换；Virtual Circuits 虚电［线］路。


  • 所有者对象 Container Objects

    所有者对象是目录服务结构，如NetWare4．x的“NetWare目录服务”的一部分。所有者对象保持有其它对象，包括其它所有者对象，从而形成用于组织一个机构的用户帐户和资源的分层索引树的分支。所有者对象通常代表一个公司的分部或部门和包含属于该分部或部门的用户帐户和资源。部门的经理或监管人员对所有者对象有特殊的管理权限，自动赋予它们权力以管理所有者对象中的对象。

    相关条目：Directory Services目录服务；X．500 Directory Services X．500目录服务。


  • 争用 Contention

    争用发生在使用共享介质和载波监听多路访问（CSMA）方法的网络，主要是以太网上。站点共享介质竞争并使用其通信信道。当两个或更多个设备同时企图使用信道时就会发生争用，这时，所有工作站都等待一段随机时间然后再次企图访问。许多站点争用电缆时情况就变得更糟，因为等待时间降低了性能，而且工作站需要不断申请使用电缆。


  • 受控访问单元 Controlled Access Unit

    CAU类似于一个令牌环多站访问单元，但是它具有打开和关闭端口的管理功能。

    相关条目：Token Ring 令牌环。


  • Cookie 网络小甜饼

    一种给用户带来运气的程序，每次运行它时都会发出一些祝福信息。主要是一引起网站用这个程序用户启动或登录网站过程的一部分。这些cookie小程序可以在windows\cookies中找到。不过有的网站会利用cookie偷偷获取用户的一些私人信息。


  • 协同处理 Cooperative Accessing

    协同处理发生在两台或多台计算机分担一个程序或计算任务处理的分布式计算系统中。协同处理需要一个复杂的程序能在网络上处理分配负载、共享数据文件和内存竞争，同时要维持信息的同步安全性和准确性。

    允许协同处理的平台是一个分布式的客户机／服务器系统，其中系统之间能相互通信。该处理最容易实现在使用公用通信协议、可兼容的处理平台和外部设备的环境中。随着能调用其它机器上的过程的远程过程调用（RPC）的出现，协同处理变得更有可行性，即使在多机种环境中也是这样。

    相关条目：Enterprise Networks 企业网。


  • 铜质分布式数据接口 Copper Distributed Data Interface

    CDDI是运行在屏蔽的和非屏蔽的双绞线上光纤分布式数据接口（FDDI）的一个版本。它目前是一个标准，先是Cabletron和Crescendo分别开发，两公司结合了他们的技术工作，并且于1993年得到了ANSI标准认可。典型的CDDI网络由带有许多用于连接工作站的端口的一些集中器所组成。因为CDDI限制了电缆距离，一个CDDI集中器可以作为一个子网连接到一个FDDI环上。

    相关条目：Fiber Distributed Data Interface光纤分布式数据接口。


  • 开放系统公司 Corporation for Open Systems

    开放系统公司是一个非赢利性组织，它致力于保证遵循开放系统互连（OSI）和综合业务数字网（ISDN）标准的供应商产品之间的互用性。COS是一家OSI协议产品供应商，提供一致性测试、验证和OSI产品的推广。COS赞助位于弗吉尼亚州Mclean的OSInet公司，该公司进行互用性测试，并在通过其测试的产品上印上“COS Mark”标记。

    相关条目：Open System Interconnection Mode开放（式）系统互连模型。


 CRC　循环冗余检查
：CRC（Cyclical Redundancy Check），就是在每个数据块（称之为帧）中加入一个FCS（Frame Check Sequence，帧检查序列）。FCS包含了帧的详细信息，专门用于发送/接收装置比较帧的正确与否。如果数据有误，则再次发送。


 CRM　客户关系管理
：CRM(Customer Relationship Management)客户关系管理是由Gartner Group创造的一个新词，它包括销售、市场营销、客户服务以及支持应用。


  • CRT 阴极射线管

    CRT是目前广泛应用的显示器件，它最早用于电视接收机，然后用于计算机系统，作为字符显示器和图象、图形显示器。它是一个漏斗形的电真空器件，由电子枪，偏转装置和荧光屏构成。电子枪是CRT的主要组成部分，包括灯丝，阴极，栅极，加速阳极和聚焦极。CRT在加电以后，灯丝会发热，热量辐射到阴极，阴极受热便发射电子，电子束打到荧光屏上形成光点，由光点组成图象。


  • 密码术；密码学 Cryptography

    Cryptography 密码术；密码学 参见安全性（Security）条目。


 Daemon 后台程序
：与UNIX系统相关的程序，执行清理或维护工具的功能，但不能由用户调用。它在后台运行，并且只在必要的时候才被激活，例如要更正其他程序不能恢复的错误时。


 DAO 数据访问对象
：DAO(Data Access Objects)是由VB提供的应用程序接口 (API)，它可以使程序员访问Microsoft Access 数据库。DAO对象包括Access的数据引擎功能。通过数据引擎功能，它可以访问结构化查询语言 (SQL) 数据库。


 DASD 直接访问存储设备
：Direct Access Storage Device的首字母缩略词。一种数据存储设备，存储于其中的信息可以被直接访问，而不必顺序通过所有的存储区域。例如：磁盘驱动器是一种 DASD，而磁带单元则不是 DASD，因为磁带中的数据是按线形顺序存储的。


  • DDN 数字数据网络

    数字数据网络(Digital Data Network)，DDN即数字数据网。它是利用光纤（数字微波和卫星）数字传输通道和数字交叉复用节点组成的数字数据传输网，可以为用户提供各种速率的高质量数字专用电路和其它新业务，以满足用户多媒体通信和组建中高速计算机通信网的需要。DDN业务区别是于传统模拟电话专线的显著特点是数字电路传输质量高，时延小，通信速率可根据需要选择；电路可以自动迂回，可靠性高；一线可以 多用，即可以通话、传真、传送数据，还可以组建会议电视系统，开放帧中续业务，做多媒体服务，或组建自己的虚拟专网，设立网管中心，自己管理自己的网络。


 DDR　双倍速率SDRAM
：DDR（Dual Data Rate SDRSM）是最新的内存标准之一，在系统时钟触发沿的上、下沿都能进行数据传输，因此即使在133MHz的总线频率下，带宽也能达到约2.1GB/S，为SDRAM的的两倍左右。


  • Desktop 桌面、台式电脑

    在电脑应用领域，“desktop”这个词一般被用来指包括显示器，电脑主机，键盘和其他所有外接设备的个人电脑。而大部分时候，它也是作为Windows“桌面”的称呼。Windows 存放桌面文件的目录名就是Desktop。


  • DHCP 动态主机配置协议

    动态主机配置协议(Dynamic Host Configuration Protocol)。HCP提供了一种在局域网内为主机动态指定IP地址的方法。系统管理员指定一定范围的IP地址，用户机则通过相应的TCP/IP软件从DHCP服务器获得TCP/IP配置信息。这一过程称为租用。用户租用IP地址有时间限制的。在安装TCP/IP协议和使用TCP/IP协议进行通迅时，有三个参数必须配置：IP地址、子网掩码 、缺省网关。这三个参数可以手动配置，也可以使用DHCP自动配置。


  • Digital camera 数码相机 Digital camera

    Digital camera 数码相机

    一种采用数字化格式录制运动或者静止图像的相机。和传统模拟相机录制无限变化的光强度不同，数码相机录制离散的数字，以便能够存储在一块闪存卡，软磁盘或者硬盘中。和其他所有数字式设备一样，数码相机拥有可以表现出来的固定最大分辨率。数码相机录制的图像可以被一根串口缆线，USB缆线或者存储媒介本身传送到一台个人电脑上。


  • 分布式数据库 Distributed Database

    分布式计算系统包括分布在多个站点上的数据。用户应可以访问这些数据而不必管它的具体位置。用户毕竟更对结果感兴趣，而不是计算机网络的细节。下面列出了开发分布式数据库系统的通用指南，这是由关系数据库设计者之一的ChrisJ．Date最早总结的。

    局部独立性，使每个站点保持一种独立性，使得数据和资源可以被本地机构保护和管理。

    非集中化消除了代表单一故障点的中心数据站点。

    连续操作即使在备份期间也可为用户提供服务。

    透明性对用户隐匿了数据的具体位置，因此用户不必了解数据在何处和如何得到它们。

    分片（分区）提供了一种将数据库化整为零并存于多个站点的手段。

    复制提供了将数据库的多个分片拷贝到多个站点的方法。

    分布式查询处理使得用户以最佳路径和可满足要求的最优资源对远程站点进行查询。

    分布式事务处理保证对多个数据库的写操作被正确地写在所有数据库上，否则任何地方发生了故障则复原退出。

    硬件独立性意味着对多供应商计算机系统和平台的支持。

    操作系统独立性意味着可支持许多操作系统。

    网络独立性意味着支持多种网络拓扑结构和通信协议。

    DBMS独立性允许用户在其客户机应用程序中访问任何数据库管理系统，见Database Connectivity APIs and Middleware“数据库连接API和中间件”。

    一旦数据被分布化，就需要采用处理、分片和复制手段来保证数据的可靠性、可用性及对数据的保护。

    客户机－服务器连接

    下面的方法用于提供客户机和服务器间的连接以及交换请求和响应信息。使用下面的两种连接方法之一交换信息。

    面向连接的“电路” 用于在网上建立一条通信信道使两条系统可实时交换信息或在事务完成前维持持续的连接。

    无连接数据报服务 用于定时要求不严时交换信息。它并不建立一个“电路”，而是将信息打包于数据报中并通过最佳路径传送到目的地。

    远程过程调用（RPC）机制使一个系统上的应用过程可以引用另一系统上的另一应用过程。调用方（客户机）通过面向连接或无连接服务，先向服务器发出请求，然后等待其响应，在客户机得到响应后，如果有必要的话，再进行下一次请求。

    存储转发消息传递系统对时间限制很宽松。用户应用程序以类似电子函件的消息向服务器发出请求，服务器收到消息后，处理该请求并将响应消息返回用户或用户邮箱。用户可以在任何时候拾取这个响应消息。这种方法假设服务器有多种用户可执行的存储过程，并对那些需要访问公司数据库信息的移动用户来说是很实用的。

    在多机种环境中做到这些连接并不简单。存在的多种通信协议、应用程序接口和各种组成要求都使集成起来十分困难。但已有了分布式计算的开发工具和环境，如OSF（开放软件基金会）的分布式计算环境（DCE）和SunSoft的开放式网络计算（ONC）环境。本书中对这两个环境均有叙述。

    在数据库连接场所，所谓的标准接口之间都有细微的区别，防碍了一个供应商的客户机应用程序访问另一供应商DBMS上的数据。几个供应商和标准集团正致力于缓和这个问题。SQL访问组（SAG）正在制定关于数据库连接的ANSI和OSI标准。Microsoft公司正在制定它的为Windows应用程序提供通用接口的开放式数据库连通（ODBC）。另外IBM也在提出自己的分布式关系数据库体系结构。

    事务处理

    当数据分布在多个数据库服务器上时，就需要各种保护措施来保证数据正确地写到所有数据库中。例如，考虑一个在三个分离的远程数据库上修改的客户帐户平衡表，如果在事务写阶段，任何一个数据库连接失败，数据库之间就失去同步。怎样检测并更正这种情形呢？事务处理（TP）监示一个叫做两阶段提交的过程并在某种程度上解决了这个问题。

    分布式系统上的实时事务处理需要一个两阶段提交过程保证将事务得到多个数据库上时的数据完整性。所涉及到的每个数据库在事务被提交给任何其他数据库时都要授权给它。如果事务成功，则被提交，否则事务应被回退。与容错系统类似，两阶段提交保护系统防止在事务写期间发生系统错误。它也允许操作员异常终止一个事务并将数据库恢复到原先的状态。事务监示器按下面的过程跟踪事务过程。

    1．写操作命令被送到每个数据库后，事务监示器等待一个响应信号以保证所有的系统都准备好写。如果所有系统都来响应，事务将在这里异常终止。

    2．假定都响应了，事务监示器指示数据库开始写，然后等待每一个系统表明数据写成功的确认信号。

    3．若未得到所有系统响应信号（由于线路或系统故障），事务监示器命令所有数据库将此次的写操作取消。

    在后面的“Transaction Processing 事务处理”条目中有更详细叙述。

    分区和复制

    分区是将一个数据库分成若干个相关信息块的方法，而复制则是将这些块拷贝到其它地方的过程。主数据库仍在一个站点上维护，而一个分区则是这个数据库的一部分，它被复制到另一站点，使用分区和复制是基于下列原因：

    使其他站点的用户更容易访问特定的数据。

    通过复制保护数据。

    在主要或辅助站点出现故障时提供可替换数据来源。

    复制技术可以替换前面所讲的实时两阶段提交技术。两阶段提交技术可提供数据库的即时同步，但其附加开销足以影响性能。另外，一个持续性问题如WAN链路故障会导致异常终止。大量事务的复制是非实时、可定期更新数据库的方法。更新日程表由网络管理员制定，或当一个已崩溃（或丢失链路）的服务器恢复时进行更新。

    然而，关系数据库的分区决非易事，但却非常适合下面所讲的面向对象数据库。关系数据库中的处理过程是复制整个数据库，而不是更新一个分区。

    Distributed Object－Oriented Systems面向对象分布式系统

    面向对象系统提供企业环境中数据存储和应用程序生成的独特解决方法。面向对象系统有如下特征：

    对象是现实世界实体的抽象，如顾客数据库中的人，记帐系统中的发票，或网络目录服务数据库中的打印机和服务器。

    一个对象不但拥有数据，还包括一组涉及操纵或报告对象中数据的过程。

    对象有类和子类。首先定义类，它作为那个类中生成对象的模板。例如，一个计算机仓库的详细目录可以是一个叫做“计算机”的类。

    一个子类是层次结构中特指一个类。叫做“膝上机”的子类可能在仓库清单“计算机”类下定义。

    继承是类层次中的重要特性。任何由某个类生成的子类不但继承了其它类的特性，还可以有自己特有的特性，继承通过生成可重用对象简化了开发过程。

    在发送消息，激活对象的过程中，对象之间相互作用。

    对象是多态的。在其中，一个消息可以根据不同的对象以不同方式激活，例如，可以为一个发票对象激活打印命令打印发票，也可以为一个顾客对象激活一个打印命令打印其名字和地址。

    对象中的信息是封闭的且只可通过激活属于这个对象的过程来改变。外部实体不能越过这些过程直接改变其内部数据。这就形成了一个高度可控环境，易于维护和建立应用程序。

    因为对象将数据放在类似于字段的实体中，所以你可以将一个对象同数据库中的一条记录相类比，但仅此而已，对象拥有自己的内部过程，用于处理其所包含的数据，而关系数据库中的任何操作都由外部过程处理。这使得对象有一定的独立性。移动一个对象时，抽取它的信息的过程也要随之一起移动。

    对分布式系统更为重要的是，多个不同的应用程序由只激活一个对象的过程就可以访问一个对象中的信息。你所要做的只是把数据放入对象并定义将数据取出的过程。这些过程可以通过相对简单的应用程序经由服务器向对象发出消息而激活。创建这些应用程序很简单，因为相应过程已被定义并作为对象的一部分而生成。另外，对象具有天然的可分布性，因为它们之间相互独立，而不象在数据库中，将大量数据被放在单个文件里，你可以“置对象于此，置对象于彼”。这种方法令人感兴趣的一个特征是，设计者事先不需知道数据对象将存放在哪里。只需使用合适的机制保持复制数据同步，就可以在任何时间任何地点将数据对象分区并复制。

    NetWare 4．x目录服务是一个分布式面向对象数据库的好例子。它用一个类似于图D－24的层次树结构数据库存储关于人员和资源的信息。该数据库由网络管理员更新。典型的更新包括增删用户、打印机、服务器和其他网络资源。该数据库为网络提供文件资料和为部门级管理人员规定管理权限，以及为用户规定对资源的访问权限。用户访问数据库时先是定位，然后访问象打印机和服务器一类的资源，或发送消息到网上的其他用户。

    图中XYZ公司在美国、英国和韩国设有分公司。美国分公司在洛杉矶和纽约有办公室。图中也显示了洛杉矶分公司的部门情况。假设数据库的原版放在纽约的公司总部。在索引树中，洛杉矶表示一个可以作为分区点的分支。用一个工具来定义这个分区，新的分区就被复制到洛杉矶服务器上。在那个办公室的用户就可以查询本地分区，寻找资源，而不必通过WAN链路访问纽约总部的数据库。

    如果纽约总部的管理员在数据库中增加了一个对象以表示洛杉矶办公室的一个新雇员，主数据库就必须更新洛杉矶办公室的分区以保证数据同步。然而，通常并不严格要求立刻更新。因此可以用低速WAN链路，以拨号方式在两地间进行更新。洛杉矶的用户一般不会马上就需要用到数据库的信息。一次更新经历几分钟乃至夜间几小时也将是允许的。

    相关条目：Database Management System 数据库管理系统；Distributed分布式计算；Object Oriented Technology面向对象技术。


  • OSF DCE的分布式文件系统 Distributed File System，OSF DCE

    分布式文件系统（DFS）是Andrew文件系统（AFS）的一个版本，包含在开放软件基金会（OSF）的分布式计算环境（DCE）中。

    相关条目：Distributed Computing 分布式计算；Distributed File System分布式文件系统。


  • 分布式文件系统 Distributed File Systems

    分布式文件系统的设计基于客户机／服务器模式。一个典型的网络可能包括多个供多用户访问的服务器。另外，对等特性允许一些系统扮演客户机和服务器的双重角色。例如，用户可以“发表”一个允许其他客户机访问的目录，一旦被访问，这个目录对客户机来说就象使用本地驱动器一样，下面是三个基本的分布式文件系统。

    网络文件系统（NFS） 最早由Sun微系统公司作为TCP／IP网上的文件共享系统开发。Sun公司估计现在大约有超过310万个系统在运行NFS，大到大型计算机、小至PC机，其中至少有80％的系统是非Sun平台。

    Andrew文件系统（AFS） 结构与NFS相似，由卡内基·梅隆大学信息技术中心（ITC）开发、现由前ITC职员组成的Transarc公司负责开发和销售。AFS较NFS有所增强。

    分布式文件系统（DFS） 是AFS的一个版本，作为开放软件基金会（OSF）的分布式计算环境（DCE）中的文件系统部分。

    如果文件的访问仅限于一个用户，那么分布式文件系统就很容易实现。可惜的是，在许多网络环境中这种限制是不现实的，必须采取并发控制来实现文件的多用户访问，表现为如下几个形式：

    只读共享 任何客户机只能访问文件，而不能修改它，这实现起来很简单。

    受控写操作 采用这种方法，可有多个用户打开一个文件，但只有一个用户进行写修改。而该用户所作的修改并不一定出现在其它已打开此文件的用户的屏幕上。

    并发写操作 这种方法允许多个用户同时读写一个文件。但这需要操作系统作大量的监控工作以防止文件重写，并保证用户能够看到最新信息。这种方法即使实现得很好，许多环境中的处理要求和网络通信量也可能使它变得不可接受。

    NFS和AFS的区别在于对并发写操作的处理方法上。当一个客户机向服务器请求一个文件（或数据库记录），文件被放在客户工作站的高速缓存中，若另一个用户也请求同一文件，则它也会被放入那个客户工作站的高速缓存中。当两个客户都对文件进行修改时，从技术上而言就存在着该文件的三个版本（每个客户机一个，再加上服务器上的一个）。有两种方法可以在这些版本之间保持同步：

    无状态系统 在这个系统中，服务器并不保存其客户机正在缓存的文件的信息。因此，客户机必须协同服务器定期检查是否有其他客户改变了自己正在缓存的文件。这种方法在大的环境中会产生额外的LAN通信开销，但对小型LAN来说，这是一种令人满意的方法。NFS就是个无状态系统。

    回呼（Callback）系统 在这种方法中，服务器记录它的那些客户机的所作所为，并保留它们正在缓存的文件信息。服务器在一个客户机改变了一个文件时使用一种叫回叫应答（ca11backpromise）的技术通知其它客户机。这种方法减少了大量网络通信。AFS（及OSFDCE的DFS）就是回叫系统。客户机改变文件时，持有这些文件拷贝的其它客户机就被回叫并通知这些改变。

    无状态操作在运行性能上有其长处，但AFS通过保证不会被回叫应答充斥也达到了这一点。方法是在一定时间后取消回叫。客户机检查回叫应答中的时间期限以保证回叫应答是当前有效的。回叫应答的另一个有趣的特征是向用户保证了文件的当前有效性。换句话说，若一个被缓存的文件有一个回叫应答，则客户机就认为文件是当前有效的，除非服务器呼叫指出服务器上的该文件已改变了。

    Network File System（NFS）网络文件系统（NFS）

    NFS是个分布式的客户机／服务器文件系统。NFS的实质在于用户间计算机的共享。用户可以联结到共享计算机并象访问本地硬盘一样访问共享计算机上的文件。管理员可以建立远程系统上文件的访问，以至于用户感觉不到他们是在访问远程文件。

    NFS是个到处可用和广泛实现的开放式系统。下面是NFS最初的设计目标：

    允许用户象访问本地文件一样访问其他系统上的文件。提供对无盘工作站的支持以降低网络开销。

    简化应用程序对远程文件的访问使得不需要因访问这些文件而调用特殊的过程。

    使用一次一个服务请求以使系统能从已崩溃的服务器或工作站上恢复。

    采用安全措施保护文件免遭偷窃与破坏。

    使NFS协议可移植和简单，以便它们能在许多不同计算机上实现，包括低档的PC机。

    大型计算机、小型计算机和文件服务器运行NFS时，都为多个用户提供了一个文件存储区。工作站只需要运行TCP／IP协议来访问这些系统和位于NFS存储区内的文件。工作站上的NFS通常由TCP／IP软件支持。对DOS用户，一个远程NFS文件存储区看起来是另一个磁盘驱动器盘符。对Macintosh用户，远程NFS文件存储区就是一个图标。

    NFS的客户机和服务器部分的功能如下：

    服务器目录共享 服务器广播或通知正在共享的目录，一个共享目录通常叫做出版或出口目录。有关共享目录和谁可访问它们的信息放在一个文件中，由操作系统启动时读取。

    客户机访问 在共享目录上建立一种链接和访问文件的过程叫做装联（mounting），用户将网络用作一条通信链路来访问远程文件系统。

    NFS的一个重要组成是虚拟文件系统（VFS），它是应用程序与低层文件系统间的接口。VFS提供的一些操作如下：

    close文件关闭操作

    create 文件生成操作

    fsync将改变保存到文件中

    getattr 取文件属性

    link 用另一个名字访问一个文件

    lookup 读目录项

    mkdir建立新目录

    open 文件打开操作

    rdwr 文件读写操作

    remove 删除一个文件

    rename 文件改名

    rmdir删除一目录

    setattr 设置文件属性

    Andrew File System（AFS）Andrew文件系统（AFS）

    AFS是专门为在大型分布式环境中提供可靠的文件服务而设计的。它通过基于单元的结构生成一种可管理的分布式环境。一个单元是某个独立区域中文件服务器和客户机系统的集合，这个独立区域由特定的机构管理。通常代表一个组织的计算资源。用户可以和同一单元中其他用户方便地共享信息，他们也可以和其他单元内的用户共享信息，这取决于那些单元中的机构所授予的访问权限。

    AFS服务器运行下列进程：

    文件服务器进程 这个进程响应客户工作站对文件服务的请求，维护目录结构，监控文件和目录状态信息，检查用户的访问。

    基本监察（BOS）服务器进程 这个进程运行于有BOS设定的服务器。它监控和管理运行其他服务的进程并可自动重启服务器进程，而不需人工帮助。

    卷宗服务器进程 此进程处理与卷宗有关的文件系统操作，如卷宗生成、移动、复制、备份和恢复。

    卷宗定位服务器进程 该进程提供了对文件卷宗的位置透明性。即使卷宗被移动了，用户也能访问它而不需要知道卷宗移动了。

    鉴别服务器进程 此进程通过授权和相互鉴别提供网络安全性。用一个“鉴别服务器”维护一个存有口令和加密密钥的鉴别数据库，此系统是基于Kerberos的。

    保护服务器进程 此进程基于一个保护数据库中的访问信息，使用户和组获得对文件服务的访问权。

    更新服务器进程 此进程将AFS的更新和任何配置文件传播到所有AFS服务器。

    AFS还配有一套用于差错处理，系统备份和AFS分布式文件系统管理的实用工具程序。例如，SCOUT定期探查和收集AFS文件服务器的信息。信息在给定格式的屏幕上提供给管理员。设置多种阈值向管理者报告一些将发生的问题，如磁盘空间将用完等。另一个工具是USS，可创建基于带有字段常量模板的用户帐户。Ubik提供数据库复制和同步服务。一个复制的数据库是一个其信息放于多个位置的系统以便于本地用户更方便地访问这些数据信息。同步机制保证所有数据库的信息是一致的。

    相关条目：Distributed Computing分布式计算；Distributed Computing Environment，OSF 开放软件基金会（OSF）的分布式计算环境；Distributed Database分布式数据库；File Systems in the Network Environment 网络环境中的文件系统。


  • 分布式管理环境 Distributed Management Environment

    DME是开放软件基金会为管理基于分布式计算环境（DCE）的分布式网络而采取的策略。DME是一个多机种环境中集合系统和网络管理的结构，同时与现有解决方案保持兼容。

    它的目的是通过下列组成部分提供分布式计算机网络的管理：

    对象管理框架 包括用于创建面向对象管理应用程序的开发工具，管理请求代管者提供对象间的通信。

    网络管理选项（NMO）包含工业标准管理协议，如SNMP和CMIP。NMO定义了管理员－代理者关系。在这种关系中代理者收集网上的资源信息将其报告给管理系统。

    分布式服务 提供软件准许和分配工具，及多种监控和管理工具，用于跟踪网上事件和潜在的问题向管理者报警。

    写本书时，DME的前途并不明朗，（读者可直接与开放软件基金会（OSF）联系，以得到更多细节，电话是（617）621－8700，马萨诸塞州的剑桥大学。）例如，1993年来，OSF停止了DME中的关键对象管理框架部分的开发。

    相关条目：Distributed Computing Environment，OSF开放软件基金会（OSF）的分布式计算环境；Distributed Management分布式管理；Open Software Foundation开放软件基金会；Management Standards and Tools 管理标准与工具。


  • 分布式管理 Distributed Management

    随着分布式系统的增长和资源从曾经集中的域中分散出来，管理硬件、软件、用户、更新、配置和安全性的问题也多样化了。而且另外与内部独立系统改变有关的还有一个同步问题。操作系统、硬件或协议的差异使这更加复杂。

    分布式管理系统需提供如下功能：

    管理用户及其工作站配置。

    管理软件分布、更新与准许权限。

    管理硬件监控、维护和编目功能。

    另外，管理系统应提供收集网络数据的方法，并将这些数据报告给管理者。

    分布式网络管理系统可以利用网络平台的优点将管理功能分散到网络上，而不是将它们集中于单一的数据中心。管理员仍可以从一个位置运行管理系统，而由分布于网络上的管理机构收集信息并应答给管理系统。过去由于时间和传输限制而无法获取的信息现在可被管理者使用了。容错管理和预防性维护也大大简化了。对即将产生的问题也可提出警告。 下面是一些常见的分布式管理系统：

    DEC的企业管理体系结构（EMA）。

    SunSoft面向SPARC和INTEL 80×86系统的管理系统。

    Novell的开放式管理平台。

    OSF的分布式管理环境（DME）。在写本书仍在开发中。

    相关条目：Electronic Software Distribution and Licensing电子软件分布与准许；Management standards and Tools管理标准与工具。


  • DEC的分布式命名服务 Distributed Name Service，DEC

    Distributed Name Service，DEC DEC的分布式命名服务 参见DECdns条目。


  • 分布式对象管理系统 Distributed Object Management Systems

    Distributed Object Management Systems（DOMS） 分布式对象管理系统（DOMS） 分布式对象管理系统是在分布式计算平台上推广使用面向对象环境和接口操作系统或服务。对象管理集团（OMG）的通用对象请求代管体系结构（CORBA）就是这样一个系统，Microsoft的Cario和SunSoft全方位分布式对象（DOE）初起也看作面向对象计算系统。


  • SunSoft的全分布式对象 Distributed Objects EveryWhere（DOE），SunSoft

    全分布式对象（或DDE工程）是SunSoft为其Solaris操作系统开发一个完全分布式对象环境的第一步。DOE的设计基于对象管理组（OMG）的通用对象请求代管体系结构（CORBA）。DOE允许开发人员生成可在多供应商平台上工作的模块化应用程序。

    HP、IBM和Sun微系统公司都独立地开发自己的面向对象接口技术，但在1993年中它们同意共享各自的技术。这些面向对象技术是：

    IBM的系列对象模型（SOM）和分布式系统对象模型（DSOM） 这些模型指定了一个接口，使在不同环境中生成的对象类能进行相互的操作。SOM是在IBM WorkPlace She11中作为一个机制实现的，目的是为了提供屏幕对象图标和开发者生成这类图标的工具。DSOM是提供了跨平台交互操作的网络版本。

    HP的分布式对象管理设施（DOMF） 该机制提供了对象间的通信。它最初是与SunSoft一起开发的。

    Sun的全分布式对象（DOE）DOE提供了在对象环境中开发具有可重用部分应用程序的工具。在将对象的优点带到分布式企业计算网上的同时，DOE允许相互合作。

    DOE提供了一个具有标准化接口和对象清单的面向对象开发环境，接口和清单都是开发人员生成面向对象应用程序时要使用的。而该标准化接口独立于系统平台并且允许在多个不同系统上的应用程序相互通信。在当前接口保持一致时，对象易于扩展或替换。为了便于更新，对象应用程序中的关键成分易于识别和修改。分布式对象应用程序并不依赖于任何编程语言。DOE规定支持OMG的接口定义语言（IDL），这意味着任何支持此接口的程序设计语言都是兼容的。

    DOE等同于计算机工业的其他开发工具，如Microsoft公司的对象链接与嵌入（OLE）和Apple公司的OpenDOC，基于IBM公司的SOM。

    相关条目：Common Object Request Broker Architecture公用对象请求代管者体系结构；Distributed Object Management Facility分布式对象管理设施；Object－Oriented Interfaces and Operating Systems面向对象接口和操作系统；System Object Mode系统对象模型。


  • 分布式处理 Distributed Processing

    Distributed Processing 分布式处理 参见Distributed Computing分布式计算，Distributed Database分布式数据库，Distributed File Systems分布式文件系统和Distributed Management分布式管理。


  • 分布式队列双总线 Distributed Queue Dual Bus

    Distributed Queue Dual Bus（DQDB） 分布式队列双总线 （DQDB） 分布式队列双总线（DQDB）是IEEE 802．6委员会定义的城域网（MAN）标准的访问技术。因为MAN和Ethernet（以太网）、令牌环、令牌总线一样都是802．x标准，所以很适于一般的局域网技术。不同的是，MAN是为基于光缆的范围可达50公里的大范围高速度网络设计的。

    DQDB与基于令牌的网络有相似之处。例如，在一个4Mbps的令牌环中，工作站在拥有一个令牌时能进行传输。然而，令牌环绕网络的时间限制了传输率。为突破这个限制，开发了在环上允许多个令牌的16Mbps的令牌环。DQDB在其总线拓朴结构中进一步接受了这个概念，它将占用总线的时间分成时间片，任何工作站都可在任何时刻将数据分组放到时间片中，犹如一列有许多可容车厢的列车，任一工作站都可将信息放到车厢中运输到其它地方。DQDB是真正的共享总线技术，因为所有节点都可按需要访问总线直至网络的饱和点。

    相关条目：Metropolitan Area Networks城域网。


  • 分布式关系数据库体系结构 Distributed Relational Database Architecture

    Distributed Relational Database Architecture（DRDA） 分布式关系数据库体系结构（DRDA） 分布式关系数据库体系结构（DRDA）是一个跨IBM平台访问、遵循SQL标准的数据库信息的IBM标准。它是IBM的信息仓库框架中的重要组成部分，该框架定义了庞大的后台服务器，客户机可通过较小的基于工作组的中介服务器来访问它。DRDA具有下列功能：

    定义了客户机和后台数据库之间的接口协议。

    提供了IBM的DB2、DBM、SQL／DS和SQL／400数据库系统的互连框架。

    支持多供应商提供的数据库系统。

    支持分布式数据库上的事务（工作单元）处理。

    在DRDA中，客户机叫做应用请求器（ARS），后台服务器叫做应用服务器（AS），协议叫做应用支持协议（ASP），提供AR和AS间的接口。整个过程操作在SNA网上，但也计划支持OSI和TCP／IP。有一个附加的协议叫做数据库支持协议（DSP），它使一个AS能对另一服务器扮演AR的角色。通过这种方法服务器之间能相互通话并传递来自客户AR的请求，如图D－25所示。最初的协议对一个数据库只支持一个结构化查询语言（SQL）的语句，但未来的版本将对一个或多个数据库提供多个语句的支持。

    DRDA是IBM环境中建立客户机／服务器计算的基础之一。其它基础是高级的对等联网（APPN）和分布式数据管理（DDM）。通过信息仓库和DRDA，IBM计算机将它的企业中心组成部分的大型计算机，用作各种类型信息（包括多媒体信息）的存储平台。

    相关条目：Advanced Peer－to－Peer Networking 高级对等联网；Database Connectivity APIs and Middle－ware 数据库连接应用程序编程接口（APIs）和中间件；Distributed Database 分布式数据库；IBM 国际商用机器公司；IBM Networking Blueprint IBM联网方案；Information Warehouse信息仓库。


  • 分布式系统对象模型 Distributed System Object Model

    DSOM是IBM的系统对象模型（SOM）的扩展，它使对象能在分布式计算环境中跨平台通信。SOM是一种面向对象技术，它规定了一种接口，使不同环境中创建的对象类能相互操作。SOM作为一种机制在IBM WorkPlace Shell中实现，这种机制提供了屏幕上的对象图标和开发者创建这类图标的工具。DSOM是提供了跨平台互操作能力的网络版本。

    SOM和DSOM为面向对象应用程序的开发人员提供了低级语言，有一种叫做VisualAge的未来产品，将提供为建立图形接口应用程序的面向对象工具，而不需要任何编程语言的知识。

    相关条目：Object Management Architecture对象管理体系结构；Object－Oriented Interfaces and Operating Systems面向对象接口和操作系统；Object－OrientedT echnology面向对象技术；Object Request Broker对象请求代管者；Objects对象，目标，实体；System Object Model，IBM IBM的系统对象模型。


 DMI 桌面管理界面
：DMI（Desktop Management Interface桌面管理界面）是一种新型的系统管理规范，它利用BIOS的程序自动检测系统各种资源如主板、显示卡、外设的工作状况，并能随时将工作状况报告给管理者。管理者根据DMI提供的信息很容易发现系统故障。该接口不仅为管理者提供了更多的方便，还能降低维护成本。


  • 文档交换标准 Document Interchange Standards

    如果没有如美国标准信息交换码（ASCⅡ）等字符格式标准，计算机信息的交换是不可能的。ACSII码将字母表中的每个字母用一个7位的码来表示，并使用8位编码提供了一个扩展字符集。几乎每个计算机都识别ASCII代码集，所以你与其它用户交换的任何文件能无需转换地显示出来（除了定制编码扩展）。但是，在这种情况的方式中，并没有你在文档中采用的格式，如页面布局、段落排列和字符风格等。于是需要一种在不同平台上交换文件时保存文档格式的方法。

    已开发出了许多文档交换标准，使用户能运行在同一操作系统下的应用程序之间，或不同平台上的应用程序之间交换文档。例如，一个UNIX应用程序和一个DOS应用程序都能打开并格式化文档，只要系统和文档采用相同的文档交换标准，格式化信息如黑体标题、段落标识、页面布局（页边空白、栏外标题、标尾）和其它文本信息都被编码到文档中，于是文档在各种系统上显示时都会是一样的。这些信息通常还包括图形格式信息。Microsoft的建成已久的丰富文本格式（RTF）具有文档格式信息，但除了在Microsoft自己的产品中，RTF并不能很好工作。

    文档规定要有下列特性：

    文档具有内容，它以特定的布局安排在页面中。

    文档具有结构，它定义了文档的段，如标题和段落。

    一个特定的文档体系结构，通过使用一种能被任何需要打开并显示文档的系统理解的语言，描述以上特性。文档应该以同样的方式表示信息，不管它下层的系统是什么（只要系统认识文档的体系结构）。用户应能编辑任何交换文档，或者发送者应能给文档上锁以防止再作编辑，虽然严格控制，这后一种功能是很难达到完善的地步的。

    在包含有许多不同计算平台的企业计算环境中，标准的文档格式对于用户间的信息交换是基本的。企业网的基本目的就是为所有用户提供一种信息交换的方法。在建好这样的一个网络后，使用简单的文件交换技术，仅维持如ASCII码之类信息是很荒唐的。提供了跨平台文档交换能力的先进文档体系结构是必不可少的。

    有好些领域的工作正在进行之中，包括面向对象信息交换，如在Microsoft Windows对象链接与嵌入（OLE）或Apple的Amber所实现的那样。这些环境强有力地支持面向图形和声音及视频等多媒体信息的交换。但是，对于包括声音和视频的复杂对象，接收这种文档的人必须有一个应用程序能“回放”这些声音和图象，或者必须有一条链路回到创建该对象的应用程序。例如，一个用户用鼠标双击一个，音对象，于是能放出声音的应用程序就被调用。但这会限制文档的便携性。在网上，相应的应用程序必须存在于用户的环境中。在OLE和Amber中，对象能维持网上别处应用程序的链接。于是用户不再需要在他们本地系统中保存该应用程序。但如果该应用程序不能采用的话，将文档移到另一网络仍会带来问题。详见：“复合文档”和“对象链接与嵌入”。

    电子数据交换（EDI）是在美国国家标准协会（ANSI）控制下的电子交换标准，它起源于航运业和交通业。EDI为商用单据如购货单、发票和船运通知等规定了结构，并为一个机构提供了通过通信链路交换这些单据的方法。交换关系通常在供应商和顾客之间，例如EDI提供了一种在可重订单据的基础上，顾客计算机向供应商计算机定购的办法。交货也是一样，并且开出发票。在最简单的单据中，EDI类似于公司间的电子函件。在某些机构中，Email已经由EDI实现。一旦安装了一个合适的系统，EDI具有降低开销和工作量需求的潜力。参见“电子数据交换。”

    Open Document Architecture 开放文档体系结构（ODA）

    开放文档体系结构（ODA）是国际标准化组织（ISO）为系统间交换那些包括有各种信息的文档而制定的标准，以便接收者能象创建该文本时一样查询这些文本，并在必要时修改。前提是发送和接收两个系统都要遵从ODA标准。ODA常用于通过X．400邮件系统交换文本或使用文件传输访问方式（FTAM）时。

    ODA复合文档有以下组成部分：

    文本（ISO 字符集）。

    基于ISO 超文件计算机图形标准的几何图形。

    基于CCITT传真标准的光栅图形。

    ODA文档包括许多布局对象，它定义了一个文档中的表示要素，如页面和每页重复的栏外标题和标尾。逻辑对象是加到文档布局中的要素，如章、节、段、标题、脚注和其它可格式化的对象。ODA文档要经历三个阶段，产生三种类型的文本。

    首先创建和编辑的文档叫可处理文档，它处于一种可校订状态，即使在交换后。

    下一阶段是布局处理，它规定了文档按页面的表示。于是形成了不可校订的格式化文档或可作进一步校订的格式化可处理文档。

    最后阶段是影象阶段，它形成最终打印或交换的文档。

    内容布局结构可以修改，但其逻辑结构被保留，这意味着你能改变文档的表示方法，而不能改变最初作者的内容。当文档在不同设备上显示或在不同类型打印机上打印时其表示格式有时不一样。

    Standard Generalized Markup Language（SGML）标准规范化标记语言（SGML）

    SGML是一种文档语言，它定义了文档的结构和内容，但它没有象ODA那样定义格式参数。它超出了ASCII码集，为综合和共享其它环境中创建的信息提供了方法。SGML基本上用于工作流和文档管理环境中，它生成的文档是智能的，而不是“愚笨”的。SGML文档包含用于定义段落和标题之类组成部分的属性，使文档具有软硬件独立性。使用这种文档，工作流软件能将精力更多地集中在功能上而不是在文档的转换上。用户和编程人员也可将信息存储在这种文档中，当这些文档在其它系统中使用时，它们能够转换以执行相应操作或格式化。Novell NetWare 4．x中的Dynatext文档查看软件就是基于SGML的。

    使用SGML，文档格式能从包含数据的文档中分离出来。这些格式信息被放在文档类型定义（DTD）文件中，格式标志标识文档的每一个部分。例如，一个段落可能有一个格式标志表示它是缩进圆体表格。字样并不是SGML定义的部分，它们与下面定义的Adobe Acrobat之类的产品有关。

    SGML Open是一种包括Novell、Oracle和Intergraph的供应商组织，它的目的是将SGML作为一种可互操作标准来推动其发展。SGML缺乏显示信息，但SGMLOpen正推出和采用另一种ISO标准，叫做文档格式语义规范语言（DSSSL），来实现显示，它定义了一个带有文档显示信息的附加文件。

    Acrobat Adobe System IncAdobe 系统公司的 Acrobat

    Adobe系统公司的Acrobat提供了移动文档交换能力，使文档接受者能浏览格式化的文本。Acrobat适用于文献编集出版社和使用许多不同类型计算机处理包括大量图形内容文档的其它商务应用。Acrobat包括下列模块：

    便携文档格式（PDF）软件，它在Macintosh和基于Windows的计算机上代替了打印驱动程序（包括Postscript驱动程序）。生成源文档的应用程序不再要求打印用于交换的文本。PDF是一种文档描述语言，类似于Postscript，它描述文本将以怎样的形式输出，文档输出时怎样查看它。

    交换软件，它运行在每种不同的计算机系统上，如DO〕S、Macintosh和UNIx系统。该软件用于浏览并编辑已交换的文档。

    读者软件，它使其他人能浏览并打印交换的文档，但不能创建文档。该软件以低价格单独出售。

    Adobe增加了Acrobat对SGML的支持，使用户能修改他们和其他用户交换的文档。

    Multipurpose Internet Marl Extension（MIME）Internet多功能邮件传递扩展标准（MIME）

    MIME是一个Internet标准，它使不同类型的数据，如图形、声音、视频和文档等都包含在电子函件的消息中。格式化功能使用户能指定字体风格、字体大小和文档中的页布局，这样使那些没有类似应用程序的其它系统上的用户能阅读并理解它们。

    相关条目：Compound Documents 复合文档；Electronic Data Interchange 电子数据交换；Electronic Mail电子函件；Groupware 群件；Imaging影像，映像，成象；Workflow Software工作流软件。


  • 文档管理 Document Management

    文档管理指文档、电子表格、图形和影象扫描文档的存储、分类和检索。每个文本具有一个类似于索引卡的记录，记录了诸如作者、文档描述、建立日期和使用的应用程序类型之类的信息。这些文档一般归档在较便宜的磁带上，必要时归档在可读写的光盘上。

    在一个法律事务所的案例中，文档管理跟踪一个文档发生的所有活动，如键字的数目、校订和打印等，使客户为这些服务付费。

    文本管理系统与面向对象的操作系统紧密相关，如Microsoft Windows的未来版本和IBM／AppleTaligent工程。面向文档的接口将自动地使一个应用程序基于文档的信息之上。

    文档管理在法律事务所、保险公司、政府财政部门、广告代理公司和其它具有大量书面文件或影象操作活动的商业领域中最为有用。

    相关条目：Archiving 归档；Backup and Data Archiving备份和数据归档；Compound Documents 复合文档；Document Interchange Standards文档交换标准；Groupware群件；Hierarchical Storage Management Systems分层存储管理系统；Imaging影象，映象，成象；Storage Management System，Novell Novell的存储管理系统；Workflow Software工作流软件。


  • 域名服务 Domain Name Service

    DNS是一个Internet和TCP／IP的服务，用于映射网络地址号码。例如，191．31．140．115映射为好记的名字，如tbones．acme．com．Internet。TCP／IP的实用工具如telnet文件传输协议（FTP）和简单邮件传输协议（SMTP）也通过访问DNS来确定你所指定的名字，并将其分解为网络地址。当选择了一个名字后，DNS将该名字翻译为一个数字地址，并将其插入到传输的信息中。DNS的一个重要特点是，其地址信息是存在一个层次结构的多个地方，而不是在一个中心站点。每个场所都有一个域名服务器，来维护本地节点的信息。

    域和DNS随着Internet的发展而被引入其中。其结构是一棵具有许多分支子树的分层树，如图D－26所示，该图示意的是Internet的一部分。在分层的文件系统中，一个目录具有许多子目录，以同样的方式，你可以想象DNS的这棵树。从树的顶层，有时也叫根层，被分支为几个主要的分支，叫做域，下列是一些顶层Internet的域：

    GOV＝政府部门

    EDU＝教育机构

    ORG＝组织（非盈利型或非商业型）

    COM＝商业

    MIL＝军事

    NET＝网络服务供给者

    也有国家域，如CA（加拿大）、UK（英国）、JP（日本）、DE（德国）、AU（澳大利亚），在US（美国）域中，对50个州中的每一个都有一个两字母的代码名。这些域由那些局限于一个国家的公司或组织命名用。而国际性公司使用COM域。

    Setting Up DNS 建立 DNS

    要加入一个域，你首先要与管理该域的组织联系。每个场所必须提供一个名字服务器，存有能被网上其它计算机查询的DNS信息。你也可以从许多商业的Internet服务提供者中得到一个为你运行的名字服务器。于是你所要做的事就是为你域中的用户提供到该服务提供者的连接。

    当你写一个DNS名字时，应将主机名写在左边，接下来写各层域名，一直到根。例如，为寻址在国家科学基金会（NSF）中的科学与信息技术系统（STIS），你应使用下列地址：

    stis．nsf．gov

    作为一个例子，假设你是一个大的叫做XYZ的跨国公司，并且你希望与Internet连接。你先与com域联系，要求一个场所登记。你还要建立一台计算机来为你公司域中的用户处理命名服务。这个系统与最近的Internet访问域取得联系。如果是一个小公司的话，也可只建立一条到服务提供者的链路，成为提供者域中的一部分。不管哪种方法，只要寻址是正确的，电子函件和其它传输信息最终都能通过网络找到到目的地的路径。

    Running Local DNS Servers运行本地 DNS服务器

    以上DNS讨论大部分是关于作为全球Internet网的域和命字。一个组织的内部命名结构也可参照同样的模式，但要包括部门或分部域。应建立一台或多台计算机来管理DNS命名。DNS是一个能驻留在几个不同服务器上的分布式数据库，以防系统崩溃。下面讨论主DNS服务器和辅DNS服务器：

    主DNS服务器 这是主要的服务器，它在内存和磁盘上都保持有整个数据库的拷贝。如果系统崩溃，该数据库能重载到内存中。

    辅DNS服务器 这是辅助DNS服务器，它获得一份来自主DNS服务器的数据库备份。当主服务器作修改时，辅服务器也要求作相应修改。

    按这种方式来分布数据库有几个优点。首先，如果网络跨城市、国家并需要广域电信链路，你通过在每个地方放一份数据库的备份，使那些昂贵的广域链路上的通信量减小。用户通过查询本地的数据库备份来搜索资源和其它用户。其次，数据库的分布化还提供了容错能力。但每个数据服务器必须有自己的电源，并位于不会受火灾、洪水、地震之类灾害威胁的理想区域中。

    Internet组织正致力于采用X．500目录服务标准，因为它具有DNS中所没有的功能。例如，X．500提供了名字查询服务，能返回关于用户和资源的信息，如物理地址、电话号码等。

    相关条目：Directory Services 目录服务；Internet Internet网；Transmission Control Protocol／Internet Protocol（TCP／IP）传输控制协议／因特网协议（TCP／IP）；X．500 Directory Services X．500目录服务。


  • 域 Domains

    域定义了分层结构中不同级别的权限，例如，在政府界，有些城市有其自己的管理域。城市属于县域，县又属于州域，州属于国家域，每个域履行自己的控制权限，但又包括在更大的域中。类似地，组织内的计算资源也能分组成为域。工作组或部门形成域，而该域又可能属于更大的域。建立域的目的是为了方便管理和安全保密。

    注意：单元和域是类似的概念。一个单元代表由一个中央权限管理的系统的一个特定的组。

    Windows NT DomainsWindows NT的域

    在Windows NT Advanced Server环境中，网络域的存在是为了简化管理并以验证形式提供安全功能。如图D27所示，一个用户能登录到自己的本地机器上，但要被这台机器验证。或者，他登录到域中，并为访问该域中的服务器而受到验证。主域服务器验证用户，然后让他或她访问域中的其它服务器。不管是主域服务器还是辅域服务器都有一个安全帐户管理（SAM）数据库拷贝，里边存有名字和口令信息。辅服务器备份这些信息，并在主服务器出错时提供登录服务。

    在用户的计算机、主域服务器和其它用户可访问的服务器之间具有信任关系，其它服务器“相信”主域服务器已正确地鉴别用户。这使用户只需登录到每个单独的服务器上。图D28图示了记帐和销售部门中的主域服务器之间怎样建立一种信任关系，以便能验证任一需要访问部门间资源的用户。

    Lotus Notes DomainsLotus Notes 的域

    在Lotus Notes中，一个域包括一个或多个Notes服务器，这些服务器共享一个通用的公用名（Public Name）和地址簿（Address Book）数据库。该数据库含有关于每个域中用户的信息，如他们的邮政地址、邮件加密信息和于域中其它Notes服务器的信息。该域还为其它产品提供了网关服务。

    Routing Domains路由选择的域

    Intcrnet和开放系统互连（OSI）网络被分成一些自治区域，或是包含主机系统和路由器，并由单一职权管理的域。这些在一个自治区域内的系统和路由器叫做域内系统（OSI术语）或内部系统（Internet术语）。自治系统间的任一连接叫做域间互连。

    在Internet中，内部网关协议（IGPs）如路由选择信息协议（RIP）和优先开放最短路径（OSPF）协议用于域内的路由选择。外部路由选择协议用于提供域间路由选择。外部网关协议（EGP）为两个位于各自域边缘的相邻路由器提供一种方法交换消息和信息。

    这些协议使网络管理员建立具有分层结构的网络。每个域内能有自己的路由选择，改变这些表并不影响其它域，并且减少了网上通信，而且每个路由器不需要重新配置自己的路由选择表。每个域还可有自己的路由选择策略。例如某个域可以根据价格进行路由选择，而另一个域可以根据速度进行路由选择。

    相关条目：Domain Name Service域名服务；Lotus Notes Lotus的Notes软件；Routing Protocols路由选择协议；Windows NT，Microsoft Microsoft的Windows NT。


  • NetWare礑OS请求解释器 DOS Requester，NetWare

    DOS Requester，NetWare NetWare礑OS请求解释器 NetWare DOS请求解释器是允许DOS工作站访问NetWare网络资源的一组模块。对NetWare服务的请求被送往一个叫做IPXODI的模块，它将请求加上头部信息，并包装数据以便通过网络传输。

    DOS Rognester Modules DOS请求解释器模块

    下列命令，一般包含在一个叫做Startnet．Bat的批处理文件中（位于NWCLIENT目录中），装入DOSn Requester文件和服务。每条命令将在下面描述：

    LSL

    NE2000．COM（或其它LAN驱动程序）

    IPXODI

    VLM

    链路支持层（LSL）驱动程序

    LSL是一个软件驱动程序，用于在多个通信协议和支持Novell开放数据链路接口（ODI）规范的网络接口卡之间控制传送，如图D－29所示。可将LSL想作一个中间人或交换板操作员，它接收数据分组并将它们送到相应的协议栈中，或者通过同一网卡从不同的协议栈中将数据分组传送出去。

    有几种可能的LSL配置。LSL在下列配置中起中介作用：

    单个网卡和单个协议栈。

    单个网卡和多个协议栈。

    多个接口卡和单个协议栈。

    多个接口卡和多个协议栈。

    LAN驱动程序

    在Startnet．Bat文件中列出的LAN驱动程序依赖于工作站软件安装期间选择的网络接口卡。LAN驱动程序提供了安装在系统中的网卡的特定硬件信息。写到ODI多链路接口驱动器程序（MLID）规范中的驱动程序并不直接连到通信协议栈。MLID只处理介质访问信息而让LSL来处理所有与协议相关的操作。

    IPXODI

    如图D－29所示，LSL驱动程序位于网间分组交换（IPX）协议栈和网络接口卡驱动程序之间。IPXODI是装入一个IPX协议栈，并把它连接到LSL的驱动程序。其它的协议栈必须有选择地安装。你需要购买Novell LAN Workplace产品（DOS、Macintosh或OS／2）为工作站提供与ODI兼容的TCP／IP（传输控制协议／因特网协议）协议栈。

    虚拟可装入模块（VLM）

    VLM是一个用于装载DOS请求解释器软件的可执行（EXE）文件。DOS请求器最重要的工作就是决定来自工作站的服务请求是转回DOS，还是通过网络转向服务器。然而VLM．EXE只完成装载工作。VLM加载下列模块，你可以在NWCLIENT目录列表中看到它们。

    CONN．VLM 这是一个连接管理器，它使工作站能同时连接一台或多台服务器。它跟踪网上用户可用的网络服务和存储设备。

    IPXNCP．VLM 这是IPX分组处理模块。

    AUTO．VLM 这是提供重连接服务的模块。

    TRAN．VLM 这个模块将信息导向正确的传输协议，如IPX或TCP／IP等。

    NDS．VLM 这个模块提供对NetWare 4．x目录服务的访问。

    BIND．VLM 这个模块提供对基于装订（bindery）服务的访问（NetWare 4．x以前的版本）。

    NWP．VLM 这个多路复用模块，将信息导向NetWare 4．x目录服务或基于装订的（NetWare 4．x以前版）服务，或是PersonalNetware，这主要看要使用哪一个。多路复用器允许其中一个或所有服务混合使用。

    RSA．VLM 该模块提供RSA（Rivest、Shamir和Adleman）加密算法和验证能力。

    F10．VLM 这是文件输入／输出模块，它负责管理缓冲或非缓冲读写、基于突发方式读写和大Internet分组读／写的控制。

    GENERAL．VLM 这个模块为所列其它模块提供通信功能。

    REDIR．VLM 这个模块提供实际的DOS重定向服务。

    PRINT．VLM 这个模块提供从工作站到网上打印机的打印重定向服务。

    NETX．VLM 这是一个可选模块，它提供对NetWare以前版本外壳程序的向后兼容。因为有些应用程序需要以前外壳程序的功能。

    相关条目：LAN Workplace Products，Novell Novell的LAN Workplace产品；NetWare NetWare网络操作系统；Novell Novell公司；Open Data－Link Interface（ODI）开放数据链路接口（ODI）。


  • Download 下载

    "下载"是指通过网络从一台距离很远的电脑接受数据，并把接受到的数据存储在进行"下载"的电脑上。平时你听别人说的"去down一个东东下来！"就是指去下载一个东西回来。


  • 向下规模化，下移 Downsizing

    Downsizing 向下规模化，下移 向下规模化：原指开除高薪的高级雇员，代之以“临时”的劳动力

    ——摘自加州Foster市《上向杂志》

    向下规模化是指机构内将小型计算机和大型计算机替换成基于LAN的服务器和工作站的过程，一般要涉及到UNIX机柜或强大的超级服务器并转换到客户机－服务器计算。

    许多机构已花费太多投资，却不能完全替换这些大型计算机和小型计算机系统，或要求使用它们的特殊工程和科学应用，或重新设计网络系统价格太高等，这些原因都使得他们都离不开原来的系统。


  • DPI 打印分辨率

    Dot Per Inch的缩写。每英寸所打印的点数或线数，用来表示打印机打印分辨率。这是衡量打印机打印精度的主要参数之一。一般来说，该值越大，表明打印机的打印精度越高。


 DPI　每英寸的点数
：DPI是Dot Per Inch的缩写，是衡量打印机分辨率的一个重要参数。DPI是指每英寸可打印的点数。如300 DPI，即表示打印输出的每一个点为1/300英寸或每英寸可打印300个点。DPI 值越高，打印输出的效果越精细，相应的输出时间也就越长。


  • DRAM 动态随机存取内存

    最常用的一种电脑内存。它通常使用一个晶体管和一个电容器来代表一个比特。和ROM及PROM等固件内存不同，随机存取内存的两种主要类型（动态和静态）都会在切断电源之后，丢失所储存的数据。


  • Driver 驱动程序

    驱动程序是一个和特定的物理设备（或特定的软件）打交道的程序。这个程序包括一些对此硬件设备有特殊用途的知识，这个硬件设备如何和计算机传输信息，数据格式如何，应该如何初始化，如何中止等类似的问题。在PC上，这类程序通常以DLL文件的形式出现，当然，过去的老驱动程序则是以SYS的形式出现。


  • DSL 数字用户环线

    一种可以显著提高普通电话线数字容量的技术。DSL有两种类型的用途：一种是ADSL（非对称数字用户环线），用于要求很快的下载速度，但上传速度较慢可以接受的互联网接入领域；还有一种是SDSL（对称数字用户环线），用于对下载和上传速度都有较高要求的短距离网络连接。

    和同样也是数字技术，但需要通过转换电话网络的ISDN不同，DSL可以提供“不间断”的连接。在一家电信运营商的中央办公室，DSL流量被聚集成为一个名叫“DSL接入多重通道”（DSLAM）的单元，并被传送给适当的ISP和数据网络。


 DTR 数据终端就绪
：DTR（ Data Terminal Ready ），数据终端就绪的首字母缩略词。例如，在串行通信中使用的一个信号，通过计算机发送到调制解调器上，以表明计算机已经准备就绪，可以接收未来的传输。


  • 双工传输 Duplex Transmission

    Duplex Transmission 双工传输 参见Transmission Media，Method，and Equipment 传输介质，方式和设备。


  • 双工系统 Duplexed Systems

    Duplexed Systems 双工系统 双工系统以镜象形式提供数据保护，它一次同时将数据写到两个地方。镜象意味着镜象的两个盘是连到一个磁盘通道（适配器卡）上。双工意味着每个盘连到它自己的适配器卡上，这增加了另一级别的数据保护。整个服务器也能双工，这样即使一台服务器不能工作了，用户也决不会没有服务器。双工服务器用高速接口（光纤）连接起来，并被放在分开的地方以防止局部灾害。

    相关条目：Disk Mirroring and Duplexing 磁盘镜象和双工。


 Dvorak Keyboard　Dvorak键盘
：目前最常见的键盘排列方式，又称为 QWERTY 键盘，排列方式的设计使得常用字母较为接近键盘中央。另一个原因是旧式打字机若不适当错开打字模，将很容易卡在一起。


  • 动态数据交换 Dynamic Data Exchange

    Dynamic Data Exchange（DDE） 动态数据交换 （DDE） DDE是指在一台计算机上运行的进程之间交换信息的一种互处理技术。它在Microsoft Windows产品中采用。

    相关条目：NetDDE 网络动态数据交换。


  • 动态路由选择 Dynamic Routing

    Dynamic Routing 动态路由选择 动态路由选择是指路由器随着网络拓扑结构和通信流量的改变而自动调整的过程。与之相对的是静态路由选择，它需要路由器管理人员手工输入路由。动态路由选择在所有现代路由器中都使用，但必要时仍要采用编程，按规则定制路由。相关条目：Routing Protocols路由选择协议。


  • HP的分布式对象管理设施 Distributed Object Management Facility（DOMF），Hewlett－Packard

    Distributed Object Management Facility（DOMF），Hewlett－Packard HP的分布式对象管理设施 （DOMF） DOMF提供分布式环境中对象间的通信机制。DOMF提供基本的对象通信和管理服务，形成了分布式对象计算的基础。使用DOMF，开发人员可以生成运行在具有不同操作系统、用户接口和通信协议的多供应商环境中的应用程序。它为网络用户和其应用程序提供了一种方法——访问来自大量应用程序的如电子表格数据或图形等对象，而不仅限于访问生成此对象的应用程序。

    DOMF是HP公司对对象管理组（OMG）的通用对象请求代管体系结构（CORBA）的实现。CORBA定义在DMG的对象管理体系结构（OMA）中。OMG是包括SunSoft、HP及30o多个其他成员组成的工业联盟。1993年末，HP宣布了它的对象请求代管+（ORB＋）系列对象工具和服务，它们是基于DOMF的。

    相关条目：Common Object Request Broker Architecture公用对象请求代管者体系结构；Distributed Objects Everywhere，SunSoft SunSoft全分布式对象；Object Management Architecture对象管理体系结构；Object－Oriented Interfaces and Operating Systems面向对象接口和操作系统；Object-Oriented Technology面向对象技术；Object Request Broker对象请求代管者；Objects 对象，目标，实体。


 EDA　电子文件受权
：EDA（Electronic Document Authorization）指电子文件授权，是工作流软件系统最常用的一种功能。它超越文电鉴别和数字签名来对电子表格或信息的接受者提供保证。其发送者具有特许权或适当的费用限制来签署和发送文件。


 Edge Device 边界设备
：边界设备是一个在不同类型网络间（如Ethernet和ATM）传送数据的物理设备。边界设备不负责收集网络路由信息，它只是使用在网络层获得的路由信息。边界路由器就是一种边界设备。


  • EDO RAM 动态存储器

    (extended data output RAM)EDORAM是一种在通常RAM中加入一块静态RAM（SRAM）而生成的动态存储器（DRAM）。因为静态RAM的访问速度要快于DRAM，所以这会加快访问内存的速度。EDRAM有时作为二级缓存和ESDRAM（带缓存的RAM）一起使用。装入EDRAM中SRAM部分中的数据可以被处理器以15ns的速度访问。如果数据未在SRAM，需要35ns时间从EDRAM中获得。EDO RAM是一种随机访问存储器（RAM）芯片，它供快速处理器，如Pentium进行快速的内存访问。EDO RAM原先是为66 MHz Pentium处理器优化设计的，对于新一代速度更快的计算机，使用不同类型的同步动态RAM（SDRAM）是更为合适的。


  • EIA／TIA 568 商用建 EIA／TIA 568 Commercial Building Wiring Standard

    EIA／TIA 568 Commercial Building Wiring Standard EIA／TIA 568 商用建 筑布线标准

    结构化布线是设计用于实现未来的服务和发展的预先规划的线缆系统，因此可以适应未来的改动和重新配置。电子工业协会（EIA）和电信工业协会（TIA）开发了一个叫做EIA／TIA 568商用建筑布线标准的商业建筑电信布线标准。这个标准提供了统一的布线标准并支持多厂商产品和环境。

    按照EIA／TIA 568标准，布线标准提供下列特性和功能：

    一般的商用建筑电信布线系统。

    规定的介质、拓扑结构、端结点和连接点，及其管理。

    支持多产品、多厂商环境。

    对以后用于商业企业的电信产品设计起指导作用。

    与布线使用产品无关的商用建筑电信线路规划和安装能力。

    EIA／TIA 568的规范适用于所有在Ethernet 10Base-T、令牌环、PBX、ISDN及其他网上使用的非屏蔽双绞线（UTP）布线方案。EIA／TIA568由于使用网络布线和安装标准化，所以对客户来说是有很大好处的，它在规整化布线、设计、安装和管理领域打开了竞争产品及服务的市场。

    EIA／TIA定义了下面五类双绞线电缆。电缆布线的详细内容见“Cabling电缆布线”条目。

    第1类 传统的电话电缆。

    第2类 适用4Mbps数据传输的电缆。

    第3类 支持令牌环（4Mbps）和10Mbps的Ethernet 10Base-T网的电缆。

    第4类 支持16Mbps令牌环网的电缆。

    第5类 支持100Mbps以上的新兴技术，如Fast Ethernet的电缆。

    Wiring System Structure 布线系统结构

    EIA／TIA568规范要求的一个如图E1所示的分层物理星形拓扑结构。电缆呈星形从电信室（TC）敷设到办公室墙上的插座。计算机设备就通过墙上的插座与网络相连。每层楼的TC都在设备室连接，每层楼的设备则与主交叉连接（main cross-connect）设备互连。区域的最大距离是3，000米（9，840英尺），覆盖1百万平方米（大约1千万平方英尺）的办公房间，可有多达5万个独立的用户。

    TC＝电信室EF＝人口设施

    ER＝设备室MC＝主交叉点

    结构化布线体系结构有五个子系统。整个系统可由图E－2映射出来。工作区 工作区布线子系统包括通信插座（墙上的接线盒和面板）、线路和将工作区设备（计算机、打印机等等）连到水平布线子系统上的连接器。通常的面板如图E－3所示，可以使用嵌入式连接器，如模块化电话或数字插座和用于低速数据通信的调制模块化插座。也可以使用连接同轴电缆和光缆的嵌入式BNC连接器。水平布线 水平布线系统敷设于每个工作站插座和电信室之间。电信室到通信插座的最大水平距离是90米（295英尺），这不依赖于介质的类型。水平布线系统可以识别四种类型的电缆：

    四对100欧姆非屏蔽双绞线（DTP）电缆．

    两对150欧姆屏蔽双绞线（STP）电缆．

    50欧姆同轴电缆。

    线芯直径62．5微米的光缆。

    电信室 电信室包括中间区的工作站连接设备和到设备室的连接。电信室是一个可以提供水平线路连结和入口设备连接的通用设施，允许使用的电信室数目没有限制。

    设备室 设备室在水平布线系统中为所有电信室提供集中连结点，并为主干线路提供连结。设备室和电信室之间主要的区别在于设备。设备室为一个或多个电信线路系统提供了机械端接。

    主干布线 建筑物的主干线路在建筑物楼层间敷设并互连每层楼的设备室。主干电缆最后并入主交叉连结设备，后者为整个设施提供集中式布线中心。主干电缆的类型如下，每种类型电缆的长度限制见图E－4。

    四对100欧姆UTP电缆。

    两对150欧姆STP电缆。

    50欧姆同轴电缆。

    线芯直径为62．5微米的光缆。

    主交叉连结 主交叉连结是主干线路和连结其他建筑物线路的集中连结点。

    入口设施 入口设施包含建筑物的电信服务入口，包括通过分界物的访问。入口设施还包含校园范围的主干连结，同时也包含网络分界点，后者是到本地交换电信局的电信设施的互连点。分界点通常距交换局设施进入建筑的入口处12英寸，但交换局可以设定成其他值。

    管理 这个子系统包括连结分布式子系统的交叉连结和内部连结。它是管理结构化布线变化的地方。

    安装EIA／TIA568结构化布线系统还是使用象以太网那样的传统电缆系统，存在一个折衷的问题。EIA／TIA568有严格的规则且大型安装时费用昂贵，但它是一个提供了未来扩展的标准。另一方面，传统的以太网可以遵循Ethernet 10Base－2或10Base－T标准，它们在本书的“Ethernet 10Base－2”和“Ethernet 10BaseT”中有各自的描述。传统的方法在小型的安装或是已有安装好的电缆安装方面是划算的。

    注意：有一个类似的标准，叫EIA／TIA606（商用建筑电信基础设施管理标准），定义了管理布线系统的统一过程，包括其路径和空间、接地及捆绑以及文档和标号过程。

    相关条目：Cabling电缆布线；Fiber－Optic Cable 光缆。


  • EISA（扩展工业标准体系结构）总线 EISA（Extended Industry Standard Architecture）Bus

    EISA（Extended Industry Standard Architecture）Bus EISA（扩展工业标准体系结构）总线 参见“扩展工业标准体系结构总线”条目。


  • EISA总线 扩展工业标准结构

    EISA（Extended Industy Standard Architecture:扩展工业标准结构）是EISA集团为配合32位CPU而设计的总线扩展标准。它吸收了IBM微通道总线的精华，并且兼容ISA总线。但现今已被淘汰。


  • 电磁干扰 Electromagnetic Interference

    Electromagnetic Interference（EMI） 电磁干扰（EMI） EMI是干扰电缆信号并降低信号完好性的电子噪音，EMI通常由电磁辐射发生源如马达和机器产生的。

    相关条目：Cabling 电缆布线；Power and Grounding Problems and Solutions电源和接地问题及解决方法。


  • 电子数据交换 Electronic Data Interchange

    Electronic Data Interchange（EDI） 电子数据交换（EDI） EDI，是两个组织之间结构化商业数据（如订单、发票和货运通知单等）的电子交换，通常在供应商和客户之间发生。例如，EDI可以基于记录级使用户能用自己的计算机向供应商的计算机发出货物订单。EDI系统负责协调传送和生成发票。EDI处理的基本商务活动如下：

    分派，财会，健康保健，制造，购货，零售，税表归档，电信，运输

    就形成的简单性而言，EDI象公司间的电子函件。在一些组织内，电子函件就是做EDI所做的工作。然而，完善的EDI系统一旦建立就可以减少开销和劳动力。早期的EDI使用很简单的标准表格，使得公司不得不基于这些通用表格设计自己的文本。新的EDI系统允许公司使用简单编程和创作工具生成客户系统。

    美国国家标准化协会（ANSI）将EDI标准的开发在1979年委托给认可标准委员会（ASC）的X．12组织，X．12曾与运输数据协调委员会（TDCC）一起参与过货运业方面的工作，与统一编码咨询组织（OCC）一起参与食品分配工业的工作。下面是一些类似的标准：

    管理商业和运输的电子数据交换（EDIFACT）。

    国际标准化组织（ISO）9735标准，综合了EDIFACT标准和ANSI标准。

    x．12保证了计算平台之间的文本兼容性。文本模拟标准的商业表格在以记录和字段结构化了的标准数据文件格式中使用ASCII数据。例如，由于文本数据分离器遵循同一格式，一个从基于PC的EDI系统发出的文本可以被一个基于大型计算机的EDI系统阅读。与电子函件系统相似，电子文本使用存储转发过程进行发送。用这种方式，日常的事务可以积累起来并在晚间发送到主机系统以减少开支。

    X．12标准定义了大量模拟大多数商用标准文本的EDI事务表格，如发票和订单。这些表有如下特征：

    拥有多个变长记录（称为段）的平坦式文件结构。

    段包含ASCII文本并以回车终止符结束。

    字段数据——如“行号”、“数量”和“价格”记录——包含于段中并由一种特殊的字符代码分隔。

    数据词典定义了每个元素。若干个段在加入了相应的供传输用的头部和尾部信息后被包装到一个块中。

    一般地，EDI在大型计算机和小型计算机上实现。但近来基于PC的应用程序也实现了EDI，如TI公司（得克萨斯州的Dalas）和Sterling Software公司（俄亥俄州的Columbus）的产品。增值网（VAN）提供者（也叫清仓者），如AT＆T（Easy Link），Sprint和GE信息服务公司都提供传送EDI文本通信服务，这些公司能提供数据打包、数据协议转换（转换成国际标准）和计费服务。

    相关条目：Document　Interchange Standard文档交换标准。


  • 电子工业协会 Electronic Industries Association

    Electronic Industries Association （EIA ） 电子工业协会（EIA） 1924年成立的EIA是美国的一个电子制造商组织。EIA颁布了许多与电信和计算机通信有关的标准，并与其他协会如美国国家标准协会（ANSI）和国际电报电话咨询委员会（CCITT）有密切联系，CCITT现称为国际电信联盟（ITU）。

    EIA在电信方面主要定义了调制解调器和计算机之间的串行接口。下表是一些常用的标准。物理层规范定义了37针（DB－37）、25针（DB－25）和9针（DB－9）连结器及相关电缆，另外还有电气特性，如每个针上的信号类型及信号时序。

    RS－232－C 使用DB－25或DB－9连结器的串行连结标准，电缆最大长度50英尺。

    RS－449 定义了RS－422与RS－423子集的用DB－37连结的串行接口。

    RS－422 定义了平衡式多点接口。

    RS－423 非平衡数字接口。

    EIA－232，就是众所周知的RS－232，它定义了数据终端设备（DTE）和数据通信设备（DCE）之间的串行连结。这个标准被广泛采用。

    EIARS－232标准即CCITT的V．24标准。但CCITT V系列协议比EIA标准稍具优势，部分原因是由于它是欧洲的政府标准指定要使用的协议类型。

    EIA标准大部分和CCITT标准等价。例如Group3传真，一个传输率最高为9．6Kbps的传真机标准，是CCITT的T．4建议，也是EIA465标准。

    在结构化网络布线领域，EIA最近与电信工业协会（TIA）联合制定了商用建筑电信布线标准（EIA／TIA568和569）；这是一个在校园环境中使用数据级双绞线的分层布线系统的标准。这个标准提供的布线结构使得建筑设计者可以不必事先知道使用什么设备从而便于进行高速数据通信设备的布局。

    相关条目：CCITT 国际电报电话咨询委员会；Nodem 调制解调器；“Vdot”Standards “V点”系列标准。


  • 对漫游计算机的电子函件广播 Electronic Mail Broadcasts to a Roaming Computer

    Electronic Mail Broadcasts to a Roaming Computer（EMBARC） 对漫游计算机的电子函件广播 EMBARC是一个单向呼叫与页面调度通信服务的提供者，它借高达30000字符的报文传递容量与Sky－Tel竞争，而SkyTel的报文传递容量只有240个字符。EMBARC也允许用户同时向多个用户发送消息。这特别有助于更新多个远程机器上的信息。EMBARC的用户有多种信息来源，如《今日美国》（USA Today）。


  • 电子函件 Electronic Mail

    Electronic Mail 电子函件 电子函件（E－mail）可能是网络上最常见的应用。确实，企业网的发展就是基于使团体内的每个人都可以通过互连共享电子函件这一需要。而对企业数据库及其他资源的访问则是一个附加的效益。

    E－mail带来的好处是显而易见的，用户间可以快速地实现交流。如果一个用户不能立即取出一个报文，那么报文在被取出前就可以一直放在电子信箱里，这就消除了所谓的电话占线。E－mail也可以便捷地对诸如销售报表，图形和需要传送到用户手中的其他数据信息进行打包。你只需将信息与报文相连即可。甚至可以将整个文件连到电子函件报文上。电子函件的另一个易被人忽略的优点在于使你进行报文答复时有时间整理你的思绪。

    E－mail最大的问题在于它太容易使用，从而导致用户会被报文淹没：一天中要回复的报文太多。另外，电子信箱需要一些管理功能，实现报文解封和归档那些将来使用的报文。发送者由于总是接不到你的电子函件回执，因此会经常发送些冗余报文。

    电子函件和报文传递系统越来越成为一个企业网计算策略的重要部分，这些系统帮助用户增进了联系，提高了生产率。另外，报文传递系统还成为分布式环境中程序开发的重要工具。报文可用来携载从一个用户到远程数据库的服务请求，远程数据库就将响应包装在报文中并回送给用户。当然，这不适用于实时过程，但分布式环境并不总是需要实时操作的。

    当前有许多不同的电子函件系统应用于网络、大型计算机系统和公共数据网上。例如Internet的报文标准——简单邮件传输协议（SMTP）、应用在IBM大型计算机环境中的IBM专用办公系统（PROFS）和SNA分布式服务（SNADS）以及DEC环境中使用的VAXmail或All－In－1。另外，台式网络环境中也有许多电子函件系统。单一组织内可能有多个电子函件系统，这些系统可供该组织中的部门或工作组分别在自己的局域网中应用。当组织实现互连后，经常会使用电子函件信关系统在不同系统间进行报文格式转换。最近，基于x．400的系统正在流行。X．400是个在不同平台上提供报文交换的标准报文传递系统。

    Electronic Mail Features 电子函件特性

    企业网上的电子函件系统包含下面的成分：

    提供报文生成、编址、发送、接收和转发功能的用户前端应用程序。还有其他特性，如文件和其他信息与报文连结的能力以及个人地址簿的管理能力等。

    从发送者寄发报文到接收者的后端电子函件服务器应用程序。一个报文存储器保存着报文直至它们都已传寄，一个转换程序或信关允许不同电子函件系统的用户交换邮件。

    维护网上用户和服务的数据库搜索服务。用户可以使用这种服务查找一个用户及他的电子函件地址。一些电子函件系统的其他特性包括对安全报文的加密能力，或增加一个数字签名来验证报文的可靠性并防止更改。还有许多系统中提供了发送和接收传真的能力。

    Electronic Mail System and Standards 电子函件系统和标准

    大型计算机和网络环境中存在许多电子函件标准。在局域网（LAN）中则以Novell的报文处理服务（MHS）最为出色，它提供了用于报文收集和路由的后端服务器。其他的标准包括Internet的SMTP和国际 X．400标准。

    X．400

    国际电报电话咨询委员会（CCITT）的X．400MHS标准定义了一个运行于多种平台上的存储转发邮件系统之间的电子报文交换系统。用国际标准化组织（ISO）的术语，X．400叫做面向报文的文本交换系统（MOTIS）。它说明了建设具有互操作性电子函件系统所需的协议过程、组成、术语和检测手段。X．400基于一个包含下列成分的分布式客户服务器模式：

    用户代理UA（User Agcnt） 这个成分运行在用户计算机上，它提供了在电子函件前端应用所需的 “报文生成”、读取、浏览及其他特性。

    报文传输代理MTA（Message Transfer Agent）这个成分从UA处接收报文，并在必要时将它们转换并寻径到其他MTA。

    报文存储MS（Message Store） 这是个报文存储区。用于存储用户系统因关机或无效而不能直接传送的报文。用户可以在任何时间从MS中取出这些报文。

    访问单元AU（Access Unit）AU为其他实体如传真机、专线电报机的用户提供至邮件系统的访问。

    索引系统（Directory System） 这个成分提供X．500的用户名及地址查阅功能。X．500是解决电子函件系统间名称和地址格式不一致的方法。

    x．400中定义的其他服务包括分布表，用于用户组的寻址；定义域，用于管理本地和远程报文点；安全特性，提供报文鉴别，正确传送和接收的证明；非授权用户的检测，防止传输途中对报文的修改及其他特性。

    Internet简易邮件传输协议（SMTP）

    SMTP是Internet网上的电子函件传送标准。使用SMTP，开发人员可以将任何一个用户接口作为前端机。在PC机上基于SMTP的邮件系统允许用户不经过信关就可以和UNIx系统上的用户发送和接收报文，或者向Internet上的任一用户发送报文。信关用于一个电子函件系统上的用户向基于SMTP的网络用户发送邮件。

    多用途Internet邮件系统（MIME）是Internet环境中基于SMTP格式建立的一个复合文本报文发送标准。使用MIME，用户可以将包括声音、视频、图形和文本在内的多媒体电子函件报文，发送到任何一个TCP／IP网上的用户。丰富文本（richtext）信息也可以融入报文，它定义了文本的字体、格式和布局特征，使得文本可以很容易地在多个不同类型系统上重现。

    Internet工程任务组（IETF）正准备采纳用于Internet的专有增强邮件（PEM）协议。PEM提供了报文签名和加封、报文和签名完整性验证、加密及解密等功能。电子函件的发送者和接收者持有一对私人密钥和公开密钥。发送者用私人钥匙签发一个报文，接收者则使用相应的公开钥匙检查这个签字。更多的信息请参阅“密钥加密技术”条目。

    Novell报文处理服务（MHS）

    Novell的NetWare MHS提供局域和广域网上的报文处理。使用MHS的应用包括电子函件，工作组规划，电子数据交换（EDI）和网络传真。MHS提供后台传送服务供前台用户的应用程序使用。而这些应用程序通常不是由Novell开发的。严格地讲，MHS不是电子函件系统。它还处理应用程序间的报文流。开发人员可以利用MHS生成能与其他应用程序进行对话和信息交换的应用程序。例如，可以使用MHS查询别的系统上的数据库。

    典型的MHS配置包括向一组用户提供报文传送服务的主机系统。多个主机可以支持一家公司的单个工作组、部门或分部。而在主机系统间用集线器对报文进行路由发送。集线器处理与目的系统的连接和传送寻址到这些目的系统的报文等活动。远程连结可以使用异步拨号线或专用线，不过这要视需要而定。例如，公司可以在其不同分部间用专用线发报文，或者是定期地在拨号线上向另一家公司发送电子函件报文。

    NetWare全局MHS是报文处理系统的最新版。这是个商业和企业范围可伸缩的报文传递服务器。它包括一套与NetWare 3．11或NetWare 4．x相结合的NetWare可装入模块（NLM），它们提供一个具有存储转发能力的报文传递和诸多服务的平台，这些服务是指电子函件、工作流自动化、日历、规划和传真等。MHS还有NetWare 2．2版、基于DOS的膝上机版和远程用户版。

    结合了任选协议模块的NetWare Global MHS在UNIX和TCP／IP网上的SMTP，IBMAS／400和大型计算机上的SNADS和CCITT（ITU）X．400邮件网络间提供了互操作性。在前台或客户机提供了多种允许用户生成、管理报文的电子函件实用工具。包括在Global MHS一起提供的First Mail就是个入门级E－mail实用程序。

    Building Enterprise E－mail System 建立企业电子函件系统

    企业计算机系统通常包含了许多电子函件系统。客户机从它们的前台应用程序向叫做报文传输代理（MTA）的后台“邮局”发送邮件。每个不同的MTA必须连结起来提供整个企业网上的报文交换。然而，每个邮件系统都有自己的编址格式、报文格式和传输协议，要成功地进行报文交换就需要进行转换或标准化。由于存在许多不同的电子函件系统，转换是当前的潮流。下面讨论两种集成异种电子函件系统的方法，同时请见图E－5。

    信关（Gateways） 信关是互连异种电子函件系统的一种方法，它主要完成从一个电子函件系统到另一个的报文格式翻译以及这些系统间的名称映射。名称映射很复杂，会增加额外的管理开销。每个不同的电子函件系统都要在其他系统之间建立自己的信关，因此信关的方法，只适用于只有少数不同系统存在的情况。另外，电子函件系统不一致的特性也会使通过信关的报文发生不正常转换。

    主干交换（Backbone Switching） 在这种方法中，所有报文都送到一个起“主干”作用的单个计算机或互连计算机簇。由主干系统处理来自电子函件系统、信关和应用程序的报文传送。许多不同的电子函件系统可以在全局范围内使用X．400这一国际认可的报文处理系统进行连结。

    企业邮件交换（EMX），作为SoftSwitch公司的主干交换系统倍受业界青睐。EMX是个多协议MTA，它在使用不同协议的电子函件系统，如IBM的SNA分布服务（SNADS），Internet的简单邮件传输协议（SMTP），Novell的报文处理服务（MHS）及其他协议之间提供了完全的互操作性。EMX完全可以满足一个团体或组织的需要。它允许组织建立一个连结现有电子函件系统并允许任何用户交换邮件的X．400企业邮件主干网。EMX形成一个在现有网络平台上扩展整个组织的逻辑邮件主干网。EMX驻留在通过网络连结的一个或多个物理系统中。

    E－mail API Standards电子函件 API 标准

    下面讨论的应用程序编程接口（API），有助于开发人员在他们应用程序中，集成对多种电子函件系统的支持。它们定义了一个报文传递服务与应用程序间的接口，还提供了文件随带和寻址服务。

    报文传递API（MAPI） MAPI为Windows应用程序访问邮件应用程序如Microsoft Mail、Lotus开发公司的CC：mail和Novell的报文处理服务（MHS）提供了一种方法。

    厂商无关报文传递（VIM） 象MAPI一样，VIM是一个交叉平台API，它允许开发人员生成运行在多个不同平台上的具有邮件功能的应用程序，并允许那些不同平台上的用户共享邮件。VIM最初由Lotus开发。

    公用邮件调用（CMC）CMC是电子函件软件开发商组成的业界集团提出的一个电子函件API，主要解决MAPI和VIM间的差异，CMC在业界受到广泛支持并可能成为工业标准。

    苹果公司开放协作环境（AOCE） 苹果计算机公司的AOCE技术用于统一电子和工作组通信，如声音邮件，电子函件、传真等。

    标准报文格式（SMF）SMF是Novell的报文处理服务（MHS）中的报文传递接口。

    Mail－Enabled Applications 支持邮件的应用程序

    前面讨论的电子函件和API形成了一类叫支持邮件的应用程序的独特软件。这些应用程序可以利用电子函件系统的存储转发和面向报文特征。本书中提到的群件和工作流软件都实现了邮件特性。

    支持邮件的应用程序使用电子函件通信机制来传输报文、数据和文本。软件供应商已开始在字处理、电子表格和数据库应用程序中实现这种机制以便用户可以直接在应用程序内部发送和接收电子函件。它们特别适于用户需要与多种不同类型硬件和软件系统通信的异机种、分布式计算环境。

    相关条目：Groupware群件；Messaging APIs消息传递API；E－Mail电子函件；Messaging APIs，Inter－Application应用程序间的报文传递API；Workflow Software工作流软件。


  • 电子软件分发（ESD）和特许（ESL） Electronic Software Distribution（ESD）and Licensing

    Electronic Software Distribution（ESD）and Licensing（ESL） 电子软件分发（ESD）和特许（ESL） 软件分发和特许登记是大型网上的一个大问题，若没有一个用于安装和更新程序、应用程序、驱动程序的自动化方法，网络管理员或其助手就要花时间手工更新网络上的工作站。在多数情况下，这意味着要花费时间和资金。通常一个团体可能有几千个分散的工作站，有些站点甚至需要花几天时间才能到达。当然，正常的处理过程是雇人做这些工作或让用户自己更新机器，但只依赖单一管理软件包进行自动更新则更合乎情理。

    ESD和ESL已被认为对大型网的正确管理有至关重要的作用，ESD提供自动软件更新，ESL提供软件使用的自动跟踪以保证一个团体只能使用自己有准许权限的软件。

    Software Distribution and Management Programs 软件分发与管理程序

    理想地，软件分发程序将软件拷至工作站，安装它，配置它，并在必要时定期更新它。配置包括改变系统设定和启动文件中的选项，如在DOS机器上的AUTOEXEC．BAT和CONFIG．SYS程序能够查看系统配置并在必要时更新这些配置。

    软件分发和管理程序的大部分工作由台式管理任务组（DMTF）处理并在DMTF的台式管理接口（DMI）中定义，DMI的部分工作是作为一个代理，负责收集网上工作站和其他结点信息并将其存放于一个叫管理信息格式文件（MIFF）的文件中。MIFF是一个标准的ASCII文件，包含工作站的硬件部件信息、操作系统、应用软件、版本号和其他信息。管理程序可在整个网络访问MIFF文件并报回信息，供管理员评价网络，确定故障，运行诊断程序以及察看潜在的问题。另外，它还为安装和配置特定机器上的应用程序提供必要的信息，如显示器、打印机类型及内存配置。

    没有这些工具，管理者是不可能优先收集这样的信息的。管理工具很方便地生成一个关于工作站需要软件更新的报告并在网上自动更新这些工作站。更新还可以在空闲时间进行以减小网络通信负担。下面是市场上几种主要的管理和软件分发产品：

    Microsoft正在其Hermes管理产品中实现由Software Spectrum（位于德克萨斯的Garland）的开发的管理和软件分发功能。管理软件运行于Windows NT上。而客户机软件运行于DOS，Windows和Windows NT机器上。这个软件遵从DMI规范。MIFF收集工作站信息，Hermes访问这些信息以提供管理报告并执行软件分发和安装。也可在工作站上执行诊断功能，还允许管理者从自己的工作站上控制另外一台工作站。

    注意：Microsoft制订了一个即插即用（Plug－and－Play）规范，它定义了安装时自动配置的软件和硬件。见“Microsoft的即插即用工业标准体系结构总线”条目。

    Novell的Network Navigator Electronic Software Distribution（网上电子软件分发航行家）允许管理员在无用户协助下从一个中心位置更新用户机器上的软件，如操作系统升级、数据文件和应用程序。它使用一种原型特征（Scripting Feature）建立检查、配置和更新系统的自动化例程。系统可以提供预定的更新及这些更新的报告。其他特征包括预定的病毒检测，预定数据更新，详细的审计报告和安全性特征。

    IBM的NetView Distribution Manager（NDM）是一个可以分发、安装和更新网络工作站上软件的管理软件。

    Licensing Applications 特许应用程序

    特许软件包用于保证一个公司在其合法界限内使用软件。一个特许软件包持有允许用户访问软件应用程序的钥匙，每把钥匙实际上是一个从供应商处购得的许可证。特许程序将钥匙发给需要使用一个软件的用户。当钥匙发出后，其他用户就不得再访问此应用程序，除非这把钥匙被放回或有多把同样的钥匙。特许程序通常包括一些控制，禁止非授权用户程序，或禁止用户长时间把持一把钥匙。

    有两个主要的开发产品：

    Network License Server （NetLS）NetLS是由Gradient Technologies公司开发，它基于可用的和正被使用的许可证数目向网上用户提供对应用软件的访问。这个软件同时提供软件版本追踪，详细目录和使用追踪，追踪对于确定谁正在使用软件和是否需要增加许可证是很重要的。

    The Licensing Service API（LSAPI） LSAPI是由DEC、Lotus、Microsoft、Novell和其他供应商提出的一个特许标准，它规定了应用程序和NetLS许可服务器如何协作来跟踪软件使用的特许情况。Microsoft已将LSAPI作为其Windows开放系统体系结构（WO3A）策略的一部分。服务器基本上获得了客户机上的应用程序执行权。

    注意，NetLS是一个发送许可证的服务器部件，而LSAPI是开发者用于与一个运用NetLS的服务器连接的编程接口。特许领域方面的其他开发有：

    开放软件基金会（OSF）正使用NetLS作为其分布式管理环境（DME）的特许管理部分，NetLS被链接到OSF的分布式计算环境（DCE）。

    Novell的NetWare电子软件特许是使用Gradient的NetLS的NetWare可装入模块（NLM），它监控软件的使用和仅当许可证可采用时才使应用程序能够被使用。下面的许可证分配方法能有效地屏蔽应用程序的使用，并对授权用户提供足够有用的许可证。

    私用（Personal）这个特征允许网络管理者指定哪些用户可以使用一个软件包。

    上锁结点这个方法是使许可证仅在特别指定的工作站上（基于结点标识）可用。

    特定时间 这个方法是使许可证在特定时间内，或限定时间长度内可用。

    相关条目：Desktop Management Interface台式系统管理接口；Management Standards and Tools 管理标准与工具；Windows Open System Architecture Windows开放系统体系结构。


  • 电梯式查找［寻道］算法 Elevator Seeking

    Elevator Seeking 电梯式查找［寻道］算法 电梯式查找是操作系统的一个磁盘优化功能，它的思想是根据磁头的当前位置，怎么使陆续发来的读／写请求最优地驱动磁头访问。电梯式查找的操作与大楼电梯的操作相似。大楼电梯并不是根据谁先按了按钮而随机地在楼层间上或下，它在上下过程中在楼层间停顿，搭载乘客。电梯式查找减少了磁盘头的运动，因此改善了访问时间，减少了硬件损耗。磁盘读写都可以从电梯式查找中受益。

    相关条目：Disk Storage System 磁盘存储系统。


  • Email client 电子邮件客户端程序

    一种帮助普通用户发送，接收和编辑电子邮件的应用程序。我们最常使用的Outlook、Foxmail等等都属于电子邮件客户端程序。


 Email Filter 电子邮件过滤器
：可以根据电子邮件中包含的信息自动地将收到的电子邮件进行归类并将其收入相应的文件夹或邮件箱的阅读软件。例如，来自一个用户的叔叔 Joe 的所有邮件可能放在一个名为“Uncle Joe”的文件夹中。过滤器也可用于封锁或接收发自指定来源的电子邮件。


  • 电子函件 E－Mail

    E－Mail 电子函件 参见Electronic Mail“电子函件”条目。


  • 封装 Encapsulation

    Encapsulation 封装 封装，有时也叫隧道（tunneling），是将一个协议报文分组插入另一个协议报文分组。本地协议分组“背”着被封装的分组跨过本地协议网传输。尽管这增加了额外开销，但它提供了一种将一个网上报文分组通过一个使用不同协议的中间网传送到另一个网上的方法。

    例如，在IP隧道技术中，就可以将NetWare的IPX分组封装到TCP／IP分组中，再象图E－6那样通过TCP／IP网传递。另一个例子是将AppleTalk分组封装到DECnet分组中，通过DECnet开放系统互连（OSI）网发送。在接收端，报文分组被解封并被送到目的地。

    公共数据网提供者，如AT＆T用封装的方法在带有同步光纤网（SONET）接口的ATM（异步传输模式）信元交换设备上传送数据分组。在多兆位数据交换服务SMDS中，分组结构在信元交换结构的顶层定义，用户数据分组被封装在SMDS分组中，然后放入信元中，以利用信元交换的高速性。

    封装也提供了一种使用光纤分布式数据接口（FDDI）作为局域网或校园网的主干网的方法。FDDI信封置于以太网帧外面，整个包通过FDDI主干网传送。当它到达目的网的桥接器时，就被解包并送到目的地。封装通常在大多数以太网到FDDI网桥接器中执行。这种方法假设以太网上的节点决不与直接连到FDDI局域网上的节点通信（桥接器除外）。封装使得帧在它们被接收桥接器解封之前不可用。在将以太网分组送到直接与FDDI局域网相连的工作站上时需进行翻译。

    相关条目：Datagrams数据报；Networks网络；Packets分组。


  • Encina应用程序 Encina

    Encina Encina应用程序 Encina是Transarc公司（位于宾夕法尼亚的匹兹堡）的一个产品，用于在开放系统环境中建立和操作分布式联机处理（OLTP）应用程序。它提供了一个遵循工业标准、集成了屏幕管理器、远程数据库管理系统（RDBMS）和其他OLTP系统的开发、执行和管理环境。开发过程中，Encina将常规大型计算机事务处理系统，如IBM的客户信息控制系统（CICS）的概念与麻省理工学院（MIT）和卡内基·梅隆大学80年代在分布式系统和事务系统上的研究成果相结合。Encina现在用于HP、IBM和Sun微系统公司的环境，并为开放软件基金会（OSF）的分布式计算环境（DCE）提供OLTP功能。

    事务处理意味着一个事务应被立即执行，如一个数据库管理系统中的银行帐户的更新，而不是象批处理那样，先将一批事务存放一段时间，然后成批处理。许多批处理过程如帐单的邮递，都在夜间进行。事务处理在用户与计算机（OLTP）直接相连时就可以实时进行。若事务处理完成，其结果可以立即在数据库中得到。最常见的OLTP例子是飞机订票系统，银行交易系统和帐户系统，如订单。报文传递系统也可以按照非实时的存储转发方法进行事务处理。

    Encina的监控特征在分布式数据库环境中是很关键的。在那里，事务能涉及多个数据库服务器上的变化，但这些变化都必须被看作单个工作单元。它们必须被同步，并在所有服务器上园满完成，否则，就必须被彻底取消。如果一个服务器在写过程中被关闭，那么事务处理中其他系统上的所有写的东西就必须被取消。

    Encina提供了下列事务监控功能：

    初启和终止 这个过程由通知所有参与的服务器启动一次事务操作，并在事务完全完成或被取消时终止事务过程。

    两阶段委托 这是一个在两阶段跟踪一个分布式事务处理的过程，以保证所有参与的系统都准备好记录一个事务和完成一个事务。事务处理过程中任何一个失败都会引起所有参与系统完全撤回这个事务。

    意外处理 这是处理出现的错误的过程。

    恢复 如果事务处理失败，任何记录必须被撤回，因此所有服务器都必须恢复到事务操作启动前的状态。

    异常终止 用户可能要求中途停止事务操作，如果是这样，写到任何服务器上的任何数据都必须被撤回。

    除了事务监控以外，Encina还以模块形式提供了其他管理功能，这些功能可按用户或开发者的需要定制，包括事务远程过程调用（RPC）、Transactional C（一种编程语言）和支持在SNA和TCP／IP网上的通信；

    工业界越来越趋向于接受OLTP是由于如下几个理由：工作站和联网设备相对便宜且企业网正在增加。许多现行的部门网都正在连入企业网，这使得分散的数据库和大型计算机系统都可以被企业中的多个用户访问了；分布式数据的发展适应了这种结构，这就需要带有两阶段委托的OLTP来实时地维持整个企业网上信息的准确性。

    Encina和类似产品现在可以应付这些需要了。类似产品包括：

    UNIX系统实验室的Tuxed（位于新泽西州的Sumnit）。

    IBMCICS，在自己的AIX／6000应用中使用许多Encina功能。

    相关条目：Connectionless and Connection－Connection Transactions 连接事务；Distributed Computing分布式计算；On－line Transactions Processing 联机事务处理；Transaction Processing 事务处理；Touxedo UNIX系统实验室的Tuxedo中间件；Two－Phase Commit 两阶段委托。


  • 加密 Encryption

    Encryption 加密 参见Security（安全性）条目。


  • 端系统对中间系统 End System－to－Intermediate System（ES－IS）Routing

    End System－to－Intermediate System（ES－IS）Routing 端系统对中间系统 （ES－IS）的路由选择

    ES－IS路由选择是在单独的域内开放系统互连（OSI）中路由选择的方法，一个域是由一家公司或组织管理的一组网络。对域的访问由域管理员设置的安全措施控制。一个典型的网络由一组称为端系统的用户计算机组成，这些计算机通常是属于一个部门或工作组的。这些子网经由路由器连到主干网上，ES－IS路由选择仅在端系统和路由器或中间系统之间进行。其他类型的路由选择则跨域进行。

    相关条目：Domains域；Routing路由选择；OSI开放系统互连。


  • DEC的企业（点）管理体系结构 Enterprise Management Architecture，DEC

    Enterprise Management Architecture，DEC DEC的企业（点）管理体系结构 这是数据设备公司（DEC）的企业网分布式管理体系结构。

    相关条目：DEC Enterprise Management Architecture DEC企业网管理体系结构。


  • 企业网 Enterprise Networks

    Enterprise Networks 企业网 一个企业，按照Webster字典的说法，是由商业目的组织起来的公司进行的颇为重要或是需要胆量或精力的工程。有了这个认识，你就可以明白，许多公司正致力于把它们分开的部门或工作组网络与公司内网络互连，使得公司内的所有计算机用户可以访问任何数据或计算资源。你可以把这种互联网叫做联合系统，因为它在独立的多机种系统间提供互操作性。然而，一个企业网的最终目的是减少使用的通信协议数，在应用程序间提高更多的互操作性和提高从任何系统访问数据的能力。

    企业网是由工作组计算演变出来的，而后者与台式机到网络的集成有关。企业网从范围上讲，既可以是局域的，也可以是广域的。它集成了一个组织中所有的系统，不论它们是基于DOS的计算机、Apple的Macintosh机、UNIX工作站、小型计算机、还是大型计算机。公司已开始反感所谓的“大腕”供应商，如IBM和DEC的专用接口，并转向可以提供更多开放性和可接受多销售商产品的系统。IBM和DEC现在也支持开放标准。向用户提供专用系统访问的网关再也不是解决的方法了。这种方法限制性太强，并且不宜扩充以适应一个互连组织的数据访问要求。

    企业网应象图E－7那样模拟成一个“即插即用”平台，可供一个组织连接它所有的计算资源。部门和工作组通过桥接器、路由器和广域电信链路相连。用户和工作组都不是孤立的，用户和工作站在维护一定程度的性能、安全及可靠性的同时，可以与其他甚至运行不同操作系统的计算机用户和计算机共享信息。在企业网中，信息分布于整个网上，用户必须便捷地访问它们，而同时敏感的信息则必须受保护以防越权访问。

    完成这些乏味的目标，关键是遵循下面两点：

    建立一个符合基本标准的，允许多供应商硬件和软件产品协调工作的网络平台。

    建立支持多个标准的操作系统和应用程序。

    当计算机处理能力提高及台式机资源价格下跌时，达到这两点就简单多了。销售商可以不致力于单个标准或协议结构，而是很容易支持所有的。计算机现在拥有实现这一切的处理能力、内存要求和用户接口，从而使用户免为复杂性所困忧。当发现一个网络为相连的DOS、UNIX和Windows NT工作站，同时传输IPX、TCP／IP和NetBIOS协议分组是很正常的。服务器和工作站现在在内存中保存了多个协议栈用来同多种系统通信。

    然而，这种策略只能用于连接网络的环境（即OSI模型的物理层、数据链路层、网络层和运输层）。这只是因为一台UNIX工作站可以发送TCP／IP分组到NetWare服务器上，但并不意味着它可以无缝地访问服务器上的资源。协议栈中的高层协议也需要互操作性，必须通过应用程序使UNIX能使用自己的UNIx应用程序访问NetWare服务器上的数据。与之相应，Windows用户也应可以直接从本地应用程序，如Microsoft Excel中访问一个UNIX系统或IBM大型计算机上的信息。

    Client－Server Computingand Middleware 客户机／服务器计算和中间件

    值得庆幸的是，这种层次的互操作性正随着客户机／服务器计算、“中间件”产品，平台间报文传递服务和支持其它供应商产品的供应策略等的发展初露端倪。

    客户机／服务器计算是应允许多个客户机访问单个服务器上的数据的需要而产生的。多数情况下，使用同一个或兼容的操作系统和计算机平台。由于网络的发展，客户机取得了访问多种后台服务器上数据的能力。而现在的动向是允许运行在任何操作系统上的任何客户机访问任何后台数据库服务。这是建立企业网系统的一支基本的催化剂。扩展通信则是另一个。

    在客户机和服务器系统间传输信息的机制如下：

    对话系统 提供一个运行于实时状况下的客户机服务器间的紧凑接口。系统间可建立一个逻辑连接并在连接上进行单向或双向对话以完成一项任务。这个过程用于完成多个任务，而不仅仅是一个事务，任务的顺序可以指定，甚至可覆盖。

    远程过程调用（RPC） 是在一个同步连接之上连接两台计算机的一个调用。这个连接需要维护以保证两系统间实时条件下的数据完整性。这种连接在“任务关键”类应用，如银行交易中是很重要的。

    报文传递系统 在其中，信息和请求在计算机间象电子函件（E－mail）在用户间传送一样进行传送。报文沿一条到达目的地的路径被存储和转发。然而报文系统对于实时数据库更新的能力有限，它们只提供高效的读服务。

    下面是一些重要的经销商或工业联盟引导企业计算系统的策略：

    Microsoft的视窗开放系统体系结构（WOSA）这种策略将中间件直接建到操作系统内以便在整个企业内使信息更容易地流动。WOSA包括一个数据库接口标准——开放数据库连接（ODBC）。

    Apple计算机公司的Apple开放协作环境（AOCE） 这是个企业内的工作组合作或工作流合作的开发环境。

    开放软件基金会（OSF）的分布式计算环境（DCE）这是一套支撑软件，隐去了多供应商产品、技术和标准之间的差异，提供了分布式应用程序的开发和维护工具。

    SQL访问组（SAG）和X／Open集团组成的数据库厂商联盟正在加强结构化查询语言（SQL）标准以支持跨多供应商系统的数据库访问。

    集成数据库应用程序编程接口（IDAPI）是Borland公司的标准数据库应用程序编程接口（API）。

    分布式关系数据库访问（DRDA）是IBM的跨IBM平台的数据库信息访问标准，遵循SQL标准。

    Oracle Glue为应用程序提供了一种支持动态数据交换（DDE）的方法，如Microsoft Excel和Visual Basic与Oracle和IBM DB2服务器的链接。

    对象管理组（OMG）正在提供实现交叉平台、面向对象环境的标准。公用对象请求代管者体系结构（CORBA）是OMG的对象管理体系结构（OMA）的一部分。

    通用开放软件环境（COSE）是包括IBM、HP、SunSoft和Novell在内的供应商联盟，合作推出一个通用的UNIX平台环境。

    在IBM环境中，高级程序对程序通信（APPC）和高级对等网络（APPN）策略提供了一种方法，以实现支持合作、对等联网的分散式计算环境。IBM的Networking Blueprint定义了对诸如TCP／IP和OSI协议等工业标准通信协议的支持。APPN允许每个工作站在网上初始化自己的通信会话，这就支持了在传统的集中式IBM环境中的客户机／服务器计算、分布式数据库和多供应商产品间的远程过程调用。

    互操作性也发生在操作系统级。新的操作系统如Microsoft Windows NT提供诸如TCP／IP和NetBIOS这样的多种协议，使得客户机可以访问许多后台服务。OSF的DCE更广泛地接受了这个概念，提供了一种开发环境，使任何供应商能够开发带有内置多供应商分布处理能力和服务的应用程序，其中服务包括搜索服务、文电鉴别、公开密钥加密等等。DCE基本上是可供一个组织建设自己企业网的公用基础设施。Messaging Workflow and Workgraups 报文传递、工作流和工作组

    另一个软件范畴正使企业网络趋向辉煌。报文传递系统提供通信工具，使得网络用户可以进行工程合作和执行群件及工作流软件。下面的报文传递标准对电子函件、群件、工作流和工作组应用程序提供了不同层次的互操作性。

    公用邮件传呼（CMC）这个业界支持的规范允许应用程序在多种支撑平台上进行报文传递服务。X．400 API协议正在支持并改进这个标准。

    Apple开放协作环境（AOCE）Apple计算机公司的AOCE提供了在分布式Macintosh和多供应商环境中生成应用程序的工具。

    报文传递API（MAPI）MAPI是Microsoft的视窗开放系统体系结构的一部分，是个Windows专用报文传递接口。

    供应商无关报文传递（VIM）VIM是Lotus定义的接口，该接口使应用程序可以和Lotus CC：Mail和Lotus Notes进行通信。

    Future Trends未来趋势

    当前的趋势是在分布式计算环境中增加客户机／服务器计算。用户要求与多种后台服务，包括运行于不同平台上的数据库管理系统的快速连接。支持这种潮流的局域网硬件包括交换式以太局域网和快速分组交换广域网服务，如帧中继、多兆位数据交换服务（SMDS）和异步传输模式（ATM）。当广域网（WAN）开始变得更象局域网（LAN），带有突发传送和频繁访问多个区域的远程资源时，传统的T1专用线就不可能提供这种支持了。

    支持多媒体的图形用户接口，如Windows，迫切需要声音E－mail服务器和视频服务器等新型存储设备。同时，交换式以太网或快速以太网选择可以提供局部环境中的带宽。交换式以太网可提供微分段功能（microsegmentation）这样可以微分到仅有一台工作站连到一个LAN网段与声音和视频服务器通信。优先特权是传送实时视频的方法，它挂起通信链路中的许多分组以保证视频信息有足够的带宽按时按序到达。优先特权可以在Ethernet 100VG－AnyLAN、ATM和其他类型的网络中采用。

    供应商现在提供支持许多不同局域网（LAN）和介质类型的集线器并允许在这些局域网间通信。这就有可能建成不受物理硬件限制的“虚拟局域网（LAN）”。一个令牌环网段上的用户和一个Ethernet网段上的用户可以成为同一工作组的一部分。ATM交换式Hub能够在一条虚线路上提供链接任何用户与任何其它用户或设备的带宽和连结，而不需要路由选择设备。

    为了规划未来的发展，很有必要评估企业网络上的通信协议并最终选定一或两个协议。为支持将来的带宽需求，将ATM集线器看作结构化布线系统中的主交换设备，其最终目的是将来增加部门和工作组的ATM集线器。

    相关条目：Asynchronous Transfer Mode异步传输模式；Cabling电缆布线；Client－Server Computing 客户／服务器计算；Distributed Computing分布式计算；Groupware群件；Hubs 集线器；Interoperability 互操作性；Structured Wiring System结构化布线系统；Switched Services 交换式互用性服务；Workflow Software工作流软件。


  • IBM的企业级系统体系结构 Enterprise System Architecture，IBM

    Enterprise System Architecture，IBM IBM的企业级系统体系结构 参见IBM系统应用程序体系结构。


  • IBM的企业级系统连接 Enterprise System Connections（SCON），IBM

    Enterprise System Connections（SCON），IBM IBM的企业级系统连接（ES－CON） ESCON是一组IBM服务产品和服务。提供了一个企业内部的动态连接环境。ESCON在至多60公里（36英里）的距离上通过光纤链路提供大型计算机系统间通道到通道的直接连接。它也为通信控制器和其他设备提供了一种方法，以共享一条单通道访问大型计算机。

    相关条目：Cluster Controller簇控制器；IBM IBM公司；IBM Mainframe Environment IBM大型计算机环境。


 EPP 增强型并行端口
：EPP(Enhanced Parallel Port)，一种标准的并行端口规范。它能把一个并行端口转换为一个能处理多个外设如磁盘驱动器、磁带机、CD-ROM驱动器和其它大量存储设备的扩充总线。在笔记本电脑上，EPP得到了大量应用。


  • 检错和纠错 Error Detection and Correction

    Error Detection and Correction 检错和纠错 检错和纠错的过程发生在文件传输过程中。导致传输错误的原因有下面几点：

    由电路中电子热运动引起的干扰。

    由电缆中电阻引起的信号衰减。

    由电感和电容造成的信号畸变。

    由信号泄漏造成的传输丢失。

    大气中静电干扰的冲击。

    估计出错的概率是200，000位中有一位。在一次通信会话中可能发生两件事：接收设备检测到错误并要求重传；或使用多种技术重建信息从而无需重传。

    检错使用简单的奇偶校验方法或更为复杂的循环冗余校验。在奇偶校验方法中，每个字符加一个额外位，这一位是1还是0取决于字符中1的数目是偶还是奇。这种方法在只有一位出错时是正确的，但若有两位同时出错就不行了，因为这时的奇偶校验看起来是正确的。更为复杂的方法是块检测方法，这种方法是由发送器按块生成一个检查和（checksum）字符。主要是将每个字符的值累加，然后将和除以255，就得到了检查和。检查和随块传送，然后接收器按相同算法检查它的结果是否与检查和相一致，若有偏差，则要求重新传送。

    但总有未检测到的出错情况，一个叫做循环冗余校验（CRC）的先进检错方法可以将未检出的错误控制在一百万块一个以下。CRC使用一个更复杂的算法产生一个16位长的校验值。CRC用在同步和异步传输中。

    相关条目：Asynchronous Communication 异步通信；Flow Control Methods流控制方法；Handshaking联络，信号交换；Microcom Networking Protocol Microcom联网协议；Serial Communication串行通信；Synchronous Communication 同步通信。


  • Ethernet 以太网

    以太网，属网络低层协议，通常在OSI模型的物理层和数据链路层操作。它是总线型协议中最常见的，数据速率为10Mbps（兆比特/秒）的同轴电缆系统。该系统相对比较便宜且容易安装，直接利用每个工作站网卡上的BNC-T型连接器，就可以将电缆从一个工作站连接到另一个工作站，完成网络传输控制任务。


  • 100Base－X以太网 Ethernet 100Base－X

    Ethernet 100Base－X 100Base－X以太网 参见快速以太网（Fast Ethernet）。


  • 10Base－2（细电缆）以太网 Ethernet 10Base－2（Thinnet）

    Ethernet 10Base－2（Thinnet）10Base－2（细电缆）以太网 注：以太网标准的背景知识请参阅“Ethernet”。

    细同轴电缆在物理上比粗Ethernet电缆管理要方便些，而且不需要在站上设置收发器。这种电缆价格便宜，但最大干线长度却比较短。图E－12是一个细缆以太网，图E－13则是其布线系统的组成。

    10Base-2网的组成如下所述：

    网络接口板 大多数以太网板同时支持粗、细两种以太网电缆连接。接口板的后面应连一个BNC型连结器，也可能有一个粗以太网连接器。干线电缆连到一个BNCT型连接器上，BNCT型连接器再和板面部的BNC连结器相连。若接口卡安装在无盘工作站上，则必须插入远程启动PROM（可编程只读存储器）芯片。

    中继器（repeater） 中继器是可选设备，用于连结两个以太网干线并增强它们之间的信号。在局域网上传输的消息在到达目的地或通过一个LAN网桥接器前通过的重复器数目不应超过2个。

    细以太网电缆 用于细以太网的电缆是50欧姆，直径0．2英寸的RG－58A／V或RG－58C／U同轴电缆。细以太网缆可从许多供应商那里购得，通常是预截成标准长度与连结器连结在一起出售。也可购买大量电缆，但需要进行切割并在两端连结BNC连接器。注意细缆联网也可采用防火填充电缆，内部非填充电缆、地下电缆和架空电缆。

    BNC电缆连结器 所有电缆段的两端都必须连结BNC连结器。BNC电缆连接器包括一个中心插针，一个外壳和一个下卡式套筒。安装时需用同轴电缆剥皮和压接工具。这在电子商店有售。

    BNCT型连结器 T型连结器与以太网接口板后部的BNC连接器相连。T型连结器提供信号输入和信号输出两种电缆连接。每个工作站都需要一个T型连接器，即使是主干线中的最后一个站也应将BNC终接器与T型连结器的开端相连。

    BNC筒型连结器 BNC筒型连结器用于连结两段电缆。

    BNC终结器（Terminators） 每段电缆的两个终端处都应有一个50欧姆的BNC终接器。每个电缆段应有一个终接器接地而另一个不接地。

    在使用RG－58A／U或RG58C／U同轴电缆进行以太网布线时应注意以下几点规则和限制；

    最大干线段长度是186米（607英尺）。

    使用T型连结器将电缆与网络接口板相连。

    最多只能使用4个中继器连结5个干线段。只有其中三个段允许使用工作站，另两个用于扩展距离。

    最大网络干线长度是910米（3，035英尺）。

    一个干线上的节点数不应超过30。中继器，桥接器、路由器和服务器都算作节点。所有段上的节点总数不能超过1024个。

    干线段的每个结束端都要设置一个终接器，其中的一个应接地。

    Combined Thick and－Thin Cable 粗和细电缆组合使用

    可以把粗、细两种以太网电缆系统组合起来。例如，你可以用粗以太网连结两个距离超过了细以太网距离限制的细以太网段。使用中继器也可扩展以太网。干线段的最大数目是5个。

    粗电缆段和细电缆段的组合可以使用一个BNC到N系列适配器接成。在电缆的一端可以采用一个N系列阴的或阳的适配器得到。组合的粗细电缆段长度介于607到1640英尺之间。下面的等式是用来计算一个组合干线段可用的细电缆的最大长度。

    1，640feet-L/3．28 ＝t

    其中L是建立干线段长度，t是可用的细电缆最大长度。


  • 10Base－5（粗电缆）以太网 Ethernet 10Base－5（Thicknet）

    Ethernet 10Base－5（Thicknet） 10Base－5（粗电缆）以太网 注：以太网标准的背景知识，见“Ethernet”

    10Base－5以太网指的就是标准以太网，因为这是以太网的最初实现。图E－14是一个粗同轴电缆以太网电缆分布方案。粗以太网干线上的每个站都与一个收发器电缆相连接。收发器不同于细缆以太网I使用的BNCT型连接器，它是一个小盒子，提供工作站与电缆的电气隔离。收发器中的“心跳”检测是判断工作站是否完好连接的常用方法。

    注：作为一个联网系统，10Base-5即将被淘汰。之所以在这里讨论它是因为存在许多可能需要扩展或修改的现有安装。

    粗以太网的组成如下所述。

    网络接口板 大多数以太网板同时支持粗、细两种以太网缆。接口板应使用一个阴DIX型连接器与粗以太网收发器电缆进行连接。如果接口卡安在服务器上，那么应挑选最好的。如果安装在工作站上，特别是工作站只是偶而对网络进行访问时，你大可以吝啬一点。若卡是要安装在无盘工作站上的，则应使用远程启动PROM。

    中继器 中继器是可选设备，用于连结两个以太网干线并加强它们之间的信号。一个中继器通过收发器电缆与每个电缆段的一个收发器相连。局域网（LAN）上传输的消息在到达目的地或通过一个桥接器前不得经过两个以上的中继器。

    收发器（Transceiver） 收发器是工作站连到粗以太网电缆上的中继盒。它有三种连结器：两个是粗以太网电缆入／出连结器，第三个使用收发器电缆连结工作站和收发器。收发器与网络电缆干线的连结有两种方法。卡紧式方法刺穿电缆，而不需切断电缆再装一个连结器。另外一个方法，带BNC接头的收发器用T型连结器连结电缆端头。注意，切断电缆和安装连结器要使用特殊的工具。

    收发器电缆 收发器电缆通常与收发器一起形成一个收发单元。电缆的任一端都装有一个阴DIX型连结器和一个阳DIX型连结器，与收发器连结器相连并滚动锁扣，锁住通往网络接口板的电缆。收发器电缆通常比干线电缆更易弯曲。

    粗以太网干线电缆 用于粗以太网的电缆是50欧姆，直径0．4英寸的同轴电缆，比收发器电缆要结实，很容易买到大批或预切成定长的粗以太网电缆，进行连结时要使用同轴电缆剥皮和压接工具。注意联网时粗缆可以采用防火填充电缆，内部非填充电缆，地下电缆和架空电缆。

    N系列阳连接器 N系列阳连接器在使用带T型连接器的收发器时安装到电缆两端。预装电缆则已装好了这种连结器。

    N系列筒形连接器 N系列筒形连接器用于结合两个电缆段。

    N系列终接器 每个电缆段的结束端两头都要使用50欧姆N系列终接器。每个电缆段、连一个有地线的终接器，一个不带地线的终接器。

    10Base－5标准的规范和限制如下：

    最大干线段长度是500米（1，640英尺）。

    发收器与干线段相连。

    工作站到收发器最大距离是150米（164英尺）。

    两个收发器之间的最小距离是2．5米（8英尺）。

    最多只能使用4个中继器连接5个干线段。只有其中三个可以放置工作站，其他2个用于扩展距离。

    结合起来的最大干线长度是2，460米（8，200英尺）。

    一个干线只能有至多100个工作站，中继器也包括在内。

    每个干线段两头都要接50欧姆终接器，其中一个接地。为防止回流，不要将两端同时接地。


  • 10Base－T（双绞线）以太网 Ethernet 10BaSe－T（Twisted－pair）

    Ethernet 10BaSe－T（Twisted－pair） 10Base－T（双绞线）以太网 注：以太网的背景知识见“Ethernet”

    10Base－T没有同轴电缆的限制和高价格，但实现了以太网的大部分优点。另外，一种星形或分布式拓扑结构使得部门或其他区域中的工作站群可以联网。

    10Base－T的部分规范与其他IEEE802．3标准兼容，所以从一种介质转变为另一种介质就容易多了。在将同轴电缆换成双绞线时可以保留现有的以太网卡。另外，可以使用支持双绞线、同轴电缆和光缆等以太网干线的中继器把一个双绞线干线网段加到现有的干线中去。多数供应商都将10Base－T产品作为以太网产品系列的一部分。

    10BaseT规范包括一个叫做链路完整性检测（link integrity testing）的电缆检测特性。系统使用这种特性不间断地检测双绞线是否开路或短路。监控在一个中心点进行。

    一个基本的10BaseT网络如图E15所示。工作站都连到一个作为中继器使用的中心Hub（或者叫集线器）上。当一个工作站的信号到达时，集线器将信号传播到所有输出线上。在一个分层配置中，可以把一个hub连到另一个hub上。连接工作站的是最大长度为100米（328英尺）的非屏蔽双绞线电缆。电缆可连接到工作站附近的收发器上，收发器再通过一种限长为50米（164英尺）的15线电缆与工作站相连。

    尽管更高级的电缆如5型电缆具备适应以后更快传输技术如100Mbps以太网技术的能力，10BaseT连接还是采用3型电缆。关于电缆类型和技术，可参见“Cabling”。图E－16中，使用同轴电缆或光缆主干连结一个建筑内不同部门之间的布线中心或配线室。在配线室用一个10Base－T集线器与主干网相连。集线器再通过一个50线电话分号缆与电话插孔板相连。在插孔板和工作站旁的面板之间用双绞线连结。在工作站，电缆从面板拉到收发器，然后再与工作站相接。现在多数10Base－T网卡都有内置收发器，可以直接插入RJ－45电缆。

    注意：现有的双绞线不一定适合10BaseT网。使用前应用电气对比仪检查电缆。

    下面是10Base－T网络的组成，但一个系统不一定使用所有的组成部分。

    网络接口卡 要使用带有DIx型15插针的连接器或10Base－T RJ45连结器的以太网卡。若在无盘工作站上安装网卡，则要使用远程启动PROM芯片。

    注意：几家供应商生产服务器用的10Base-T“hub”网卡，卡的后部有一端口与一种“章鱼”电缆相连，并通过它实现与工作站的连结。

    集线器（Hub） 集线器有多达12个端口。盒上接有用于与同轴电缆或光缆主干连结的端口。

    双绞线（Twisted－Pair Cable）10Base－T使用带有RJ45连结器的最长为100米的双绞线。可以购买批量的电缆和连结器制作所需长度的电缆。如果自己安装电缆，要使用RJ压接工具。

    收发器（Transceiver） 收发器的一端是RJ－45连结器，而另一端是DB－15连结器。然而现在的网卡大多都有内置的收发器。

    收发器电缆 收发器电缆用于收发器与网络接口卡后部的连接。

    插孔板（Punchdown）连结器电缆 如果要使用现存的电话电缆，一个50线的Telco电缆直接连结集线器与电话插孔板会简化安装过程。可与集线器供应商商谈。

    墙面板（Wallplate） 墙面板是带RJ插头的连结器。若同时也进行电话连接，就买一个双头面板。10Base－T cable Specifications 10Base－T电缆规范

    下面列出的是10Base－T的规范。注意有些规范是灵活的，依赖于厂商提供的产品。从墙面板到集线器完整的连结见图E－17。

    注意：高速以太网的新数据级结构化布线使用4对电缆。详情见“Cabling”和“EIA／TIA568商用建筑布线标准”。

    使用3型、4型或5型非屏蔽双绞线。

    电缆末端使用RJ－45插座，1针和2针是“发送”，3针和6针是“接收”。每对交叉相连以使发送器的一端连到接收器的另一端。

    用一个收发器和一个15线的收发器电缆与工作站相连，但有些网卡有内置收发器。

    收发器到集线器的距离不能超过100米（328英尺）。

    典型地，一个集线器可以连接12台工作站。

    一个中心集线器可接多达12个集线器用于网络站数目的扩展。

    集线器可与同轴电缆或光缆主干网相连成为更大的以太网络的一部分。

    不用桥接器时一个网上至多可有1024个工作站。

    相关条目：Cabling 电缆布线；EIA／TIA568 Commercial Building Wiring Standard EIA／TIA568商用建筑布线标准；Ethernet以太网。


  • 以太网 Ethernet

    Ethernet 以太网 以太网系统最早是由施乐（Xerox）公司创建的，但在1980年，由DEC、Intel和Xerox共同开发成为一个标准。这个标准以开发者的开头字母成为DIX以太网。电子电气工程师协会（IEEE）802．3标准定义了一个与之类似，但稍有不同的网，它使用了另一种帧格式。（帧是通过一条链路传输的位流的结构和编码）。因为IEEE802．3标准已被国际标准化组织（ISO）接纳，所以我们在此就讨论它。

    以太网有10Mbps的吞吐量，使用一种叫载波监听的访问方法，在这种方法中，所有工作站共享一根网络电缆，但同一时刻只有一台工作站可以使用电缆。电缆访问的仲裁使用带冲突检测的载波监听多路访问方法（CSMA／CD）。

    IEEE 802．3委员会负责定义OSI协议栈中的物理层。这一层被分为两个子层：介质访问控制（MAC）子层和数据链路子层。CSMA／CD，令牌环和令牌总线网位于MAC层，数据链路子层可作为一个桥接器，必要时在网间传送信息分组。这方面内容在本书前面的“OSI模型中的数据链路层”条目中有描述。

    除了1Base－5外、IEEE 802．3标准的各种改进都有10Mbps的传输速度。1Base－5传输率为1Mpbs，但其双绞线段更长，在单个扩展的局域网（LAN）中可以连接多达8，000个工作站。由于通用性的考虑，本书只讨论10Base－5，10Base－2和10Base－T这几种拓扑结构，但所有的拓扑结构都在下面列出。注意名字的第一个数字是指以Mbps为单位的速度，最后一个数字表示每段的长度（单位是100米），Base代表基带而Broad表示宽带。

    10Base－5 最大段长度为500米的同轴电缆，使用基带传输方法。

    10Base－2 最大段长度为185米的同轴电缆（RG－58A／U），使用基带传输方法。

    10Base－T 最大段长度100米的双绞线电缆。

    1Base－5 最大段长度500米，最大传输率为1Mbps的双绞线电缆。

    10Broad－36最大段长度3，600米，使用宽带传输方法的同轴电缆（RG－59A／UCATV类型）。

    10Base－F 支持长达4公里的光缆主干网，传输率10Mbps。EIA／TIA已验证这种电缆适于在其商用建筑布线标准（CBWS）中进行校园建筑间的交叉连结。

    100Base－X 一种新的以太网标准，支持100Mbps的吞吐量，并在分层双绞线布线配置上使用当前的CSMA／CD访问方法。

    100VG－AnyLAN 一种新的以太网标准，支持100Mbps的吞吐量，并在分层双绞线布线配置上使用一种新的叫做需求优先（demand priority）的访问方法。

    除了新的100VG－AnyLAN标准以外，802．3以太网的拓扑结构都是使用CSMA／CD访问方法的线性总线。在同轴电缆以太网的实现中，工作站的连接是一种菊花链的方式，如图E－8左边所示，将每个站间的电缆段连接起来，这些段形成一个整体的。大型电缆系统，叫干线（trunk）。以太网的双绞线版本（10Base－T）则配置成星形拓扑结构，每个工作站的分支电缆都连到中央布线集线器上，如图E－8右部所示。

    Carrier Sense Multiple Access With Collision Detection（CSMA／CD）带有冲突检测的载波监听多路访问（CSMA／CD）

    以太网适配器只有在独占电缆时，才能在共享网上传输信息分组。冲突检测用于解决对电缆的同时访问。当电缆空闲时，两个站可能同时试图访问它。如果两个站都开始传送数据，就会产生一个冲突，其结果是数据破坏。使用CSMA／CD协议，检测机制监听到冲突时，两个工作站都各自退避一个随机时间后再进行传输尝试。

    CSMA／CD方法在网上交通很轻时是有效的。当通信量增大时，更多的冲突将会发生。工作站一再退避和重发，而网络一直很忙。这种现象将会持续，逐步升级，从而导致性能下降和用户可以觉察到的延迟。一个解决方法是，减少每个LAN段上的工作站数目。在需要交换式集线器的微分段技术中，少到甚至一个工作站就可以占据一个段，这就彻底消除了争用。

    冲突问题是对以太网段干线长度进行限制的一个因素。最大长度是2．500米（1．5英里）。超过这个限制的干线会因信号传播的延迟而导致冲突检测机制中的错误，因为处于过长电缆两端的工作站，在同时访问电缆时可能监听不到另一个的访问。这种多路访问监听的失败会导致数据损失并会阻塞LAN网段。

    Segmentalion 分段

    分段是把一个以太网段分割成两个或更多片段的过程。目的是减少与每个段相连的工作站数目，提高性能。通常单个段被分开并加入桥接器或路由器来连接这些片段，桥接器和路由器就管理网间的数据通信。

    当有新用户特别是哪些要求高带宽的用户加入网络时，分段就受到特别的重视。视频应用就需要几乎所有带宽。另外，视频是直接实时的，必须优先传递，但这会降低其他用户的性能。视频用户能够共享他们自己的网段。

    NetWare、Windows for Workgroups、Windows NT和类似的操作系统都有内置路由选择能力。每个置于服务器中的网络适配器都有一个单独的LAN段，由操作系统管理段间数据通信。图E－9是个安装了两个分别运行星形和总线拓扑结构以太网的网络接口卡的服务器。拓扑结构的选择依赖于办公环境的布局和使用的电缆类型。

    过滤（Filtering）是分段方案的一个重要部分。一旦你分割了一个网络以减少通信量和提高性能，你就应该过滤信息分组，以减少不使用这些分组的网上的通信量。互联网络桥接／路由方法的一个缺点就是桥接器和路由器在网间传输分组时引入了延迟。交换式集线器可以消除这种延迟问题。

    Enthernet Switching Hubs 以太网交换式集线器

    交换式集线器是在分段概念上的扩展，它在一个盒子中提供微分段。甚至一个工作站就可以有一条到服务器或其他设备的直接、非共享链路，这减少了争用并保证了网上10Mbps的速率。有工程工作站或多媒体工作站的网络从交换式集线器提供的高传输率中获益匪浅。

    交换式集线器是低等待（low－latency）设备，实行图E－10所示的矩阵交换。许多交换式集线器使用高速专用连接与服务器相连，如100Mbps的FDDI接口，其原因是以太网标准的10Mbps吞吐量通常不足以处理到服务器的吞吐量。将一个以数个MIPS运行的多处理超级服务器与一个低速网相连是很荒谬的。注意图E－10中的数字，FDDI的传输能力是100Mbps，图中交换式集线器提供10个端口，每个端口是10Mbps，所以FDDI端口的100Mbps带宽可以充分利用来处理同时进行传输操作的10台工作站。

    Enthernet at 100 Mbits／sec100MbpS级的以太网

    随着多媒体、高清晰度电视、实时视频以及结合了上述几种形式的电子函件的广泛应用，迫切需要台式机有更高的带宽。计算机辅助制造（CAM）和计算机辅助设计（CAD）用户通常需要很高的带宽，新兴的应用，如图象和文档存储也需要高带宽。运行在100Mbps的以太网标准有两个：

    100VG－AnyLAN以太网它由Novell，Microsoft、HP、AT＆T及另外11个供应商提供支持，使用类似于10Base－T以太网使用的那种四线3型电缆，并使用一种叫做需求优先的新优先级方法。

    IEEE802．12委员会负责它的开发，参见“Ethernet 100VG－AnyLAN”。

    100Base－X以太网 它保留了CSMA／CD访问方法，运行于非屏蔽双绞线（UTP）5型数据级电缆上。IEEE802．3委员会现在负责其开发。

    电缆对100Mbps的以太网来说是很重要的。声音级（VoiceGrade）电缆不适于快速以太网（Fast Ethernet）。100VG－Any LAN需要3型电缆（使用了电缆中所有4对线）。同样要注意到光纤分布式数据接口（FDDI）和铜缆分布数字接口（CDDI）形式的局域网同样可以提供100Mbps的传输率。然而，由于价格昂贵和实现上缺乏经验，它们并未用于进行LAN连结。就日益增长的传输率趋势来说，光缆会带来长远的利益。

    Frame Formats帧格式

    一个以太帧表示了在以太网上传输的数据分组的结构。它描述了分组中头部、数据位的位置。你如果想在网上连一个协议分析器并监控网络的通信，那么了解帧的类型是很重要的，你可通过它查看分组中内容。并对它们的统计结果进行整理，从而排除网上所出现的问题。

    以太网中有4种帧格式：

    Ethernet－Ⅱ最初的以太网帧格式。它分配了唯一的用于AppleTalk Phase I网，与DEC系统相连的网或与使用TCP／IP协议的计算机相连的网上的信息分组头部。

    Ethernet-802．3这种帧格式通常用在Novell NetWare网中。

    Ethernet－802．2这种格式约定用在Novell NetWare4．x网中。

    Ethernet-SNAP 这种帧格式用于AppleTalk PhaseⅡ网上。

    在图E－11中，上面是最初的Ethernet-Ⅱ帧，下面是IEEE802．3帧，这些帧中重要的域描述如下：

    前置同步信号（Preamble） 这个域标志一帧的开始。

    开始帧定界符（SFD） 这个域提供一个指示IEEE802．3以太帧开始的附加域。

    目的和源地址 这些域存放源地址和目的地址。

    数据域长度（LEN）这个域指示了帧中数据部分的长度。

    循环冗余检验和（CRC） 这个域存放一个由发送者在分组上计算出的值。接收者使用相同的计算方法比较是否产生了同样的值，若不同，帧就被视为损坏，需要重传。

    相关条目：Ethernet 10Base－2 10Base2以太网；Ethernet 10Base5 10Base－5以太网；Ethernet 10Base T 10Base－T以太网；Ethernet 100VG－AnyLAN 100VG－AnyLAN以太网；Fast Ethernet快速以太网。


  • 100VG－AnyLAN（语音级 ）以太网 Ethernet100VG－AnyLAN（Voice Grade）

    Ethernet100VG－AnyLAN（Voice Grade） 100VG－AnyLAN（语音级 ）以太网 注意：以太网标准的背景知识见“Ethernet”。

    以太网已被证明是多功能的网络标准。有成千上万个网安装了10Base－2标准和更新的10Base－T双绞线标准。以太网经过良好的检测并被广泛接受。双绞线布线技术降低了网络安装费用并利用结构化布线技术的优点简化了布线过程。现在，高速以太网（100Base-X）标准也可采用，如100VG－AnyLAN（声音级）和快速以太网都可向台式机提供100Mbps的传输率。这些新的高速标准是实现诸如多媒体，实时视频和图象应用等需要较高吞吐量的应用所必需的。

    100VG-AnyLAN建议是基于AT＆T和HP公司开发的技术，它受IEEE802．12委员会指导。这个标准使用图E－18所示的4线双绞线电缆。并且使用了新的叫做需求优先的访问方法取代了现在以太网上带冲突检测的载波监听多路访问（CSMA／CD）方法。

    100VG－AnyLAN Specifications100VG－AnyLAN的规范

    100VG-AnyLAN在每个站上使用4对3型声音级电缆布线。与之竞争的以太网100Mbps标准（100Base－X）使用的是5型数据级电缆，但这会导致许多地点电缆重新布线。若安装了高速5型电缆，100VG－AnyLAN也可以利用其优点。如果这样，电缆的距离就可以从100米猛增到150米。

    原来以太网的访问方法被改变了，但帧格式却没有变。新的访问方法叫需求优先（Demand Priority）。由于帧格式没变，因此可以在现有的以太网标准和100VG－AnyLAN标准间进行桥接。HP公司认为，是以太网帧格式而不是CSMA／CD，才是定义不同以太网标准的互操作性和兼容性的成分。

    在需求优先方案中，由集线器仲裁工作站对电缆进行访问的时间和方式，优先级系统可以保证时间敏感的应用如实时视频可以按照它们的需要访问网络。集线器方法因基本上消除了争用而提高了有效性。决定哪个工作站可进行访问的是集线器。

    因为100VG-AnyLAN在拓扑结构上与10Base－T很相似，所以适配器和其他组成成分可以共享许多相同的特性。一台计算机带的是10Base－T也好，是100VG－AnyLAN也好，都可以直接插入100VG－AnyLAN集线器并且以各自设定的速率运行。和保留了现有以太网的帧格式一样，星形拓扑结构和结构化布线系统方法也被保留了下来。另外，还使用10Base－T的连接器。

    信令方法

    100VG－AnyLAN使用当前10Base-T网安装的相同电缆，因为这种电缆是声音级的，所以要保证线路上可靠的100Mbps速率传输，就要使用四重信令方法（quartet signaling）。10Base－T使用电缆中的两对双绞线，一对用于发送一对用于接收，100VG－AnyLAN使用了全部的4对双绞线。

    四重信令方法使用与10Base-T相同的频率，但电缆中每对线都以25MHz传输信号。编码方案也由10Base-T中的曼彻斯特编码变为5B6B编码。100VG－AnyLAN中分裂于各对线上较低信号频率保持了要求标准内的无线电频率发送并允许使用声音级电缆。相对地，10Base－T标准分割于两对线上传送20MHz的信号。

    需求优先级（Demand Priority）

    需求优先级方法是100VG－AnyLAN中新的访问方法，取代了现在以太网标准中的CSMA／CD方法。使用需求优先级方法时，工作站在发送的同时也可以接收。这可以通过使用4对双绞线和使用四重信令方法来实现。

    需求优先级法利用了结构化布线设计和集线器中心方法的优点，如图E－19所示。这种设计与10Base－T的方法类似，但集线器对管理网络访问有更多的控制。当一台工作站需要传输时，它向集线器发出请求并可以申请一个传输的优先级。若网上不忙，工作站就可以开始传送。所有的传送直接通过hub，hub提供快速交换到目的节点。

    优先级机制可以保证一些如视频之类时间敏感的通信可以获得比其它类型通信更高的优先级。若有多个传输请求到达集线器，只有最高优先级的才会优先得到服务。如果两个工作站同时申请同一优先级，则两者交替地得到服务。这种传输方法明显优于现在以太网上的CSMA／CD方法。在CSMA／CD方法中，工作站各自独立地竞争访问权，而不受中心集线器的控制，冲突就会在两个或多个工作站同时请求访问时发生。冲突发生后，每个工作站都要退避，且在进行下一次尝试之前要等待一段时间。这就降低了性能并且由于工作站仍会继续申请访问而产生更多的争用冲突。

    需求优先级法还有一个优点，就是通过集线器进行的传送，不会象在标准以太网中那样广播到所有其它工作站。这样，就减少了传输被窃听者监听的可能性，确保了数据的秘密性。

    相关条目：Cabling 电缆布线；EIA／TIA568Commercial Building Wiring Standard EIA／TIA568商用建筑布线标准；Ethernet以太网。


  • EtherTalk 适配器 EtherTalk

    EtherTalk EtherTalk 适配器 EtherTalk是电气电子工程师协会（IEEE）802．3以太网标准在Apple Macintosh计算机上的实现。EtherTalk适配器由Apple公司提供，包括用于同轴电缆、双缆线和光缆的各种介质适配器。用在Macintosh I上的网卡叫Ethernet NuBus（NB）卡，用在Macintosh LC上的网卡叫Ethernet LC卡。对于非NuBus系统也可用外部适配器。它连到小型计算机系统接口（SCSI）的端口上。

    相关条目：Apple Computer 苹果计算机公司；AppleTalk AppleTalk协议；Ethernet 以太网。


  • 扩展工业标准体系结构（EISA）总线 Extended Industry Standard Architecture Bus

    Extended Industry Standard Architecture（EISA）Bus 扩展工业标准体系结构（EISA）总线 EISA总线1989年由工业厂商联盟设计，用于支持现有的ISA扩充板，同时为以后的发展提供一个平台。为支持1SA卡，它使用8MHz的时钟速率，但总线提供的DMA（直接存储器访问）速度可达33Mbps。EISA总线的输出／输出（I／O）总线和微处理总线是分离的，因此I／O总线可保持低时钟速率以支持1SA卡而微处理器总线则可以高速率运行。EISA机器可以向多个用户提供高速磁盘输出。

    EISA总线是全32位的，所以这种设计可处理比ISA总线更多的引脚。连结器是一个两层槽设计，既能接受ISA卡，又能接受EISA卡。顶层与ISA卡相连，低层则与EISA 卡相连。尽管EISA总线保持与ISA兼容的8MHz时钟速率，但它们支持一种突发式数据传送方法，可以以三倍于ISA总线的速率传送数据。大型网络服务器的设计大多选用EISA总线。

    相关条目：Microchannel Architecture微通道体系结构总线；Peripheral Component Interconnect 外围部件互连。


  • 外部网关协议 Exterior Gateway Protocols

    Exterior Gateway Protocols（EGP） 外部网关协议（EGP） Internet和使用传输控制协议／因特网协议（TCP／IP）的网总体上都被分成各个独立的系统，这些系统是使用同一路由选择协议且由一个组织管理的主机和路由器的集合。独立的系统被看作域（domain）。一个独立系统可能是由一个大学或一个公司管理的互连路由器的集合。在域内和域外有两类处理通信的协议：内部路由选择协议用于一个域内；而外部路由选择协议则是各自域边界上的两个相邻路由器之间交换报文和信息的方法。

    相关条目：Internet Internet网；Routing，Internet Internet网中的路由选择；Routing Protocols 路由选择协议。


  • External Bus 外部总线

    外部总线，通常所说的总线(Bus)指片外总线，是CPU与内存RAM、ROM和输入/输出设备接口之间进行通讯的通路。


 Extranet 外联网
：又称“企业外联网”。是使用因特网技术建立的可支持企事业之间进行业务往来和信息交流的综合网络信息系统。


 Failback 自动恢复
：出故障时自动恢复。在簇网络系统（有两台或多台服务器互联的网络）中，由于要对某台服务器进行维修，需将网络资源和服务暂时重定向到备用系统。在此之后将网络资源和服务恢复为由原始主机提供的过程，称为故障恢复。


  • FAT 文件分配表

    File Allocation Table，文件分配表。位于磁盘0扇区上的一个特殊的文件，它包含了磁盘上的文件的大小以及文件存放的簇的位置等信息。


  • FAT32 32位文件分配表

    File Allocation Table 32，32位文件分配表。FAT32使每个簇变得更小，FAT32支持的磁盘容量达到2,048GB，而FAT只能支持2GB的磁盘大小。FAT32使每个文件存放的空间变小，即达到了增大磁盘空间的目的。


  • Fax modem 传真调制解调器

    一种以传真格式将数据编码并发送出去（也可接收）的调制解调器。它发送的数据可以由一台传真机或另一台调制解调器解码并转换成图像。图像必须已经在主机上被编码。文本和图像可以用随调制解调器一同提供的特殊软件转换成传真格式。纸张上的文档必须先被扫描到计算机内。传真调制解调器可以是内置的，也可以是外接的，它可能组合了传真功能和传统的调制解调器的功能。


  • 传真服务器 FAX Servers

    FAX Servers 传真服务器 传真服务器日益成为网络的重要组成部分。它是带有传真设备、管理接收和发出传真的计算机。工作站用户不必架设办公室传真机线路，而只须从台式机向传真服务器发送传真，由传真服务器将传真通过与其连接的电话线发送出去。因为传真服务器可供多个用户共享，所以就不必在一个公司内安装那么多传真机了。

    传真机也提供重要的界内服务。例如，操作员可以监管进来的传真，并通过局域网（LAN）发送到相应的用户那里，或取消那些不必要的传真。另一种方法是，给LAN上的用户分配一个与其电子函件地址相联系的传真号，传真就进入用户的电子邮箱，这就是界内路由服务。

    界内路由选择方法很快就会形成标准。负责制定美国传真标准的电信工业协会（TIA）正在研究一套由国际计算机传真协会（ICFA）提出的界内路由选择技术。其中的一项技术，是建立一个唯一的供传真路由到指定目的地的扩展电话号码。

    公司也可以建立自己的传真信息服务。网上用户或拨号用户可以通过电话按键或点计算机上的菜单从文档列表中选出自己的信息，再由传真服务器发给他们。

    开发人员正在他们的软件中包含传真功能，采用的方式类似于包含电子函件特征的方式。例如，在Lotus Notes这样的应用程序中，你可以将正在处理的文本传真出去。还有开发人员正在进行以二进制文件形式将格式化文本信息从一个传真机传到另一个上的工作。这种做法消除了文件数字化过程。接收传真的系统可以将其打印出来或以可编辑文件的形式保存。这个过程基本上是由传真机管理的传输会话。

    一些厂商还提供另一个令人感兴趣的功能，允许把传真放到电子函件报文中通过邮路传送。你将封装传真的电子函件报文发送到公司传真服务器上，然后由服务器解封并按照到达界内或界外目的地的正常路线发送传真。如果你们公司的电子函件系统有一个免费号码而且你定期拾取邮件，那么这种方式就节约了一个呼叫。

    下面是传真服务器的其他功能：

    传真服务器保存传真活动的日志文件供日后查核。

    传真服务器管理公司的传真地址薄。

    传真服务器是易于管理的集中系统。

    Microsoft公司正致力于简化工作站上的传真和电子函件技术。其Microsoft At Work策略致力于使办公设备更具智能化并可与台式计算机和网络互连。在Windows及其应用程序中会有使这些设备工作的菜单选项。

    相关条目：Electronic Mail 电子函件；Microsoft At Work Architecture 微软的At Work体系结构；Servers，Network网络服务器。


 FCC & BCC　转发与密送
：在一些英文版的电子邮件发送软件中，我们会经常看到FCC或BCC，它们分别代表转发和密送。这两者的区别是使用前者时，所有的接收者了解接收邮件的所有接收者；而在密送时，接收方不知道还有其它的接收者。


  • FDDI 光纤分布式数据接口

    Fiber Distributed Data Interface光纤分布式数据接口。光纤分布式数据接口是美国国家标准化组织制定的在光缆上发送数字信号的一组协议，它的传输速率可以达到100Mbps。FDDI使用双环令牌传递网络拓扑结构，可以在100公里以上的距离支持500台计算机。FDDI通常用作骨干网，连接具有许多局域网段和大图形传输、语音和视频会议以及其他带宽要求大的应用产生的繁重流量的大型网络。


  • 联邦信息处理标准 Federal Information Processing Standards

    Federal Information Processing Standards联邦信息处理标准（FIPS） FIPS是在美国政府计算机标准化计划下开发的标准。这个计划定义了用于政府机关的自动化数据处理和远程通信标准。FIPS遵循美国国家标准协会（ANSI）标准，政府机关必须遵从FIPS标准，供应商则基于商业用途有选择地遵循ANSI定义的标准。国家标准和技术协会（NIST）负责草拟规范。已接受的标准包括那些ASCII字符编码方案、数据加密及计算机编程语言，如COBEL和FORTRAN等。

    最近，美国政府宣布将密钥escrow加密技术作为一个联邦信息处理标准。密钥escrow方法使联邦执法机构可以通过获取由多个机构持有的解密密钥部分进行通信解密。政府机关电话将使用这种密钥标准。

    另一个重要的FIPS是政府OSI框架文件（GOSIP）。它要求美国的政府机关使用与OSI（开放系统互连）兼容的计算机设备，或要求供应商与提供OSI功能的政府部门进行贸易。

    相关条目：Government OSI Profile政府OSI框架文件。


  • 联合数据库 Federated Database

    Federated Database 联合数据库 许多组织的计算资源，包括在部门或分部作为独立系统存在的局域网（LAN）、小型计算机和大型计算机，这些系统有各自的数据库，当建造一个企业计算平台来互连一个组织时，组织内分散的异构数据库系统就应结合成联合系统以供多个用户访问数据。中间件产品或象分布式计算环境（DCE）这样的环境，提供一个软件层，通过它用户可以与不同的系统互操作。因为几乎没有哪个组织从头设计其企业网和数据库，所以一个联合系统才是大多数组织应采用的现实系统。

    当一个联合系统有了一定的互操作性，可以集成异构系统时，通常由局部管理者提供安全和管理的独立性，每一个系统都保持一定程度的独立性。另一方面，在一些企业环境中，管理者正致力于通过减少使用的通信协议数目来达到所有级别上的互操作性，并提供网络上任何用户应用程序对任何数据的访问。

    相关条目：Client－Server Computing 客户机／服务器计算；Distributed Computing 分布式计算；Distributed Database 分布式数据库；Enterprise Network企业网络。


  • SunSoft ONC的联合命名服务 Federated Naming Services，SunSoft ONC

    Federated Naming Services，SunSoft ONC SunSoft ONC的联合命名服务 在SunSoft的开放网络计算+（ONC+）环境中，有个网络信息服务+（NIS+）组成部分，这个组成部分提供了客户机／服务器环境中的命名服务、NIS十指的是一个企业或组织的命名服务，它提供的服务是在单个授权管理的域（或单元）中。

    某些情况下，企业可能会使用几个不同类型的命名服务，如NetWare的命名服务、OSI名字服务，或是开放软件基金会（OSF）的分布式计算环境（DCE）的命名服务，联合命名提供了命名的通用性，它是通过支持这些或其他命名系统，包括提供更高层次命名或专用命名系统达到这一目的的。

    相关条目：Directory Services 目录服务；Open Network Computing 开放网络计算；Sun Microsystems Inc．Sun微系统公司。


  • 光纤通道 Fiber Channel

    Fiber Channel 光纤通道 光纤通道是校园范围内的互连标准，其设计主要用于外设、大容量存储系统（如RAID设备）、影像和存档系统、大型计算机、工程工作站和其他高速设备的互连。光纤通道有网络特征，在传统观念上它不是一个网络，而是在一个相对局部的环境中由光缆互连计算设备的高速通道。如图F－9中的图书馆或校园环境。光纤通道的速度是它最引人注目的特征：它在多种电缆类型，包括多模光纤、同轴电缆和屏蔽双绞线上提供了从133Mbps到1Gbps的带宽。

    美国国家标准协会（ANSI）X3T9委员会正在开发光纤通道互连标准。当本书与读者见面时，它应该已被评审并加入到国际标准化组织（ISO）的标准中了。光纤通道系统开创组织（FCSI），包括HP、IBM和Sun微系统公司，正大力提倡光纤通道。另外，主要的厂商如Emulex正在开发光纤通道产品。FCSI的主要目的是开发一个供工作站和外设使用的高速开放连结标准。

    某种程度上，光纤通道正在与新兴的异步传输模式（ATM）产品竞争，因为它可以形成局域网（LAN）的交换环境。ATM提供相似的规范，但更好地支持了广域网。尽管这些产品初看似乎相似，但你应把ATM看作多用户LAN或WAN技术而把光纤通道看作高速设备互连的方式。光纤通道对于连结两个或更多并行处理系统或将大容量存储系统接到超级服务器上是个明智的选择。然而，光纤通道也提供交换服务，也能建立带有许多用户工作站的网络。

    Where Fibre Channel Fits In 光纤通道的用武之地

    现有的网络技术，如以太网，受制于有限的传输率。这些网络将数据打包并通常使用无连接方法通过共享网络发送。这种策略对高速工作站和外设间的通信来说是不行的。例如，一个小型研究实验室可能有由一个科研组使用的多台工作站需要与外部设备、超级服务器、小型计算机、大型计算机和超级计算机进行连结，使用象以太网这样的局域网（LAN）技术在这种“集群”环境中是不现实的，因为局域网（LAN）的吞吐量远远低于计算机设备的处理能力和吞吐量。

    光纤通道接口在空闲时为其他设备对通道的访问提供传送数据的电路。甚至可以同时进行多路会话。光纤通道有三种可能的连结类型：

    点对点设备连结 供较大距离和传输率使用。其中的一个例子是在一个RAID磁盘系统和一台超级服务器间进行直接连结。注意这种点对点连结可以发生在其他用户共享的网络上，但电缆只有当通信会话完毕才能使用。

    集群（工作组）连结 用于高速工作站。

    交换式LAN连结 支持以太网、FDDI和令牌环网，允许工作站间多路同时点对点连结。

    光纤通道接口支持变长传输，这意味着它可传输大的数据块而不必把它分成更小的分组。光纤通道也支持下列通道和网络技术的互连。为了实现这一点，光纤通道使用了封装技术将地址头加到帧上并通过光纤通道交换设备或网络传送帧。从这方面来说，光纤通道被供应商叫做“通用端口”。

    异步传输模式（ATM）

    光纤分布式数据接口（FDDI）

    高性能并行接口（HIPPI）

    智能外围接口（IPI）

    象以太网和令牌环一样的网络

    小型计算机系统接口（SCSI）

    光纤通道传输来自设备的信息，首先通过简单的读取缓冲区信息、打包，再通过一种“机制”发送。机制（Fabric）描述了在光纤通道中建立连结的所有方式，从一条电缆连结两台设备，到使用电路交换和分组交换技术连接多台设备的交换设备。基本的数据格式、分组结构或帧类型，在交换方案中并不重要。光纤通道也克服了设备的制约。比如SCSI接口，通常SCSI的一个适配器可以连结8台或16台设备，而使用光纤通道交换方式则可以连结几百万台设备。

    上面已经提到，光纤通道可以建立设备间专用的点到点连结。这些连结有点象线路，而且在连结间可同时存在多个高带宽线路。线路是双向的且两个方向上的传输速率都可达100Mbps。当一个设备希望通过交换设备或网络传送时，它要做的仅仅是得到一条到目的设备的专用线路。这与进行一次声音电话呼叫类似。如果当前网络很繁忙，那么端口隔一会儿再试。

    前面已经说过，光纤通道与ATM相似并与之竞争。但光纤通道擅长于外部连结技术，而ATM则适于WAN环境或适于电话会议应用。等待（延迟）是另一个要考虑的因素。光纤通道使用的帧长度是2K字节，帧的1．5％用于头部信息。另一方面，AT＆T信元（ce11）有53个字节长，其中有10％用于头部信息。这意味着在可比条件下，光纤通道的数据传输量比ATM大。

    网络管理员应该考虑，在局域环境中为高带宽用户和设备使用光纤通道的可能性，而把ATM作为网络主干和广域网（WAN）互连。两个产品同时兴起，预计光纤通道的价格会低于ATM。

    相关条目：Asynchronous Transfer Mode 异步传输模式；Connection－Oriented and Connection1ess Protocols 面向连接和无连接协议；Matrix Switches矩阵交换器。


  • 光纤分布式数据接口 Fiber Distributed Data Interface

    Fiber Distributed Data Interface（FDDI） 光纤分布式数据接口（FDDI） FDDI是美国国家标准组织（ANSI）的X3T9．5委员会制订的光缆标准。它以100Mbps的传输率远行，并使用一种最长距离为100公里（60英里）、支持500个节点的双环拓扑结构。后面会提到，它也支持铜线连结，但传输距离大大缩短了。FDDI的双计数器轮转环（dual counter rotating rings）提供冗余性（容错）。如果一条链路失效或电缆被切断了，环可以自己重新配置，如图F－2右边所示，这样它可以继续进行网络传输。

    FDDI是建造主干（见本书的“Backbone Networks主干网络”）的优良介质。如图F－3所示。连有小型计算机、大型计算机和其他系统的局域网（LAN）段可以与主干网相连。仅包含几个LAN网段的小型网络也许使用同轴电缆以太主干网更有好处，但对于拥有许多LAN网络，且担负着高性能工作站，图形文件传输或其他网间通信的繁重通信量的大型网络来说，使用FDDI则更为明智。

    直接与FDDI电缆连接的工作站与相邻的站之间有两个点到点的连结。在双环配置中，一个通道用于传输而另一个用于备份。一些叫做双连站（DAS）的工作站同时与这两个环相连，而单连站（SAS）则通过集线器进行连结，一个集线器可连接多个单连站，这种配置的优点是，一个SAS的故障不会使整个环瘫痪，而且多数SAS都是经常需要关机的用户工作站，若与环直接相连则导致环的中断。

    同时注意，路由器和局域网（LAN）与FDDI环的连结。光缆旁路器提供电路在路由器不能工作时的旁路，保持环的贯通。对于一些应保持连续连接的重要设备，如服务器，应使用冗余连接。如果一个连接失败，则另一个可以接替它，如图F－3所示的两个DAS服务器连接。

    要记住，象FDDI这样的任何共享网络，它的带宽都可能会饱和。例如，FDDI的带宽为100Mbps，但十个10Mbps的以太网工作站同时传输文件就可能使带宽饱和。你应对你的主干通信要求作出评估。也许使用高速交换式集线器是个解决方法。随着视频和多媒体应用的日益增长，100Mbps的带宽可能会形成“瓶颈”，异步传输模式（ATM）交换式集线器可能更适合于你的网络主干要求，了解更多的内容请见“Asynchronous Transfer Mode异步传输模式”。另外，快速以太网也可提供一个更为经济的100Mbps网络，请参见“Ethernet l00VG－AnyLAN”和“Fast Ethernet”。

    一些在“Hubs”条目中讨论的集线器和交换设备的工作站提供以太网接口，为服务器或超级用户提供FDDI接口。如果一个服务器是个带有专用高速总线的多处理系统，它可以处理比一个或多个10Mbps以太网段发送给它的通信量还多的信号，那么就应该在这些服务器中使用FDDI适配器。图F－4图示了10个以太网工作站与一个交换式集线器通信，再由集线器将这些通信结合起来通过FDDI送到服务器。

    下面是光缆的一些优点：

    光缆不受电磁干扰，适于在经常由于干扰而发生麻烦的区域使用。

    光缆很安全。它不向外辐射信号，偷听者不可能捕捉信号。

    光纤不存在铜线中固有的数据出错和数据分组重传的问题。

    光纤网几乎不用中继器就可以传输数英里，而且光缆可以取代其他传送方法，如微波和远程通信链路。

    FDDI Access Method FDDI访问方法

    FDDI使用令牌传送访问方法，一个令牌帧沿着网络从一个站到另一个站。如果一个站需要传送，它获得一个令牌，然后站开始传送，传送完后将令牌放回环。一个时限机制用来防止一个站长时间占用令牌。为适应大通信量的站，网络管理员可以给这个站特权，允许它在释放令牌前长时间传输。注意以下特征：

    直接连到FDDI的工作站起中继器一样的作用。它们从上游邻站那儿接收分组并传送到下游邻站那里。当一个节点在分组中看到自己站的地址时它就将分组拷贝到自己的存储区中。

    网上可以存在多个帧。如果一个工作站在它的分组区正在传送时就交还了令牌，那么其他站就可以开始发送。

    站管理机制使得系统管理员可以管理和监控FDDI网络，隔离故障节点，并选择通信路由。

    Types of FDDIFDDI的类型

    上面讲的都集中于成熟的FDDI标准。但是新兴的多媒体和实时图象应用程序，因其对时间敏感的特征而有着特殊的传送要求。在实时视频传送中分组传送的延迟可以使视频图象抖动而失真。当一些分组被延迟而另一些分组按时到达时，那些延迟的分组就丢掉了。FDDI令牌传递特征及其变长分组结构不能提供电视直播所须的均匀数据流。关于这个问题，下面将讨论几种方法。

    FDDI现有三种传输模式。前两种，是异步和同步模式，在最初的FDDI标准中就实现了。第三种基于连结的模式则可提供专用线路。这种模式在新的FDDI－Ⅱ标准中实现，但需要新的适配卡。

    异步服务 异步环模式是基于令牌的，任何工作站都可以获得令牌来访问网络。这种模式意味着通信无优先等级，因此不能进行时间敏感的通信和视频图象。在现有FDDI网络上解决实况转播和多媒体传送问题的方法只能是将进入的分组缓存起来直到全到齐后按顺序存放，再播放出电视图象。然而，这种方法导致的延迟对直播电视会议是不可接受的，因为电视会议中人们正在举行会谈，如果一些人只是观看存储的视频图象倒也可以接受。

    同步服务 同步令牌传递环模式允许时间敏感通信，如视频图象可以优先传送以保证分组按时到达。拥有同步能力的FDDI卡赋予网络管理员为时间敏感通信分配部分带宽的能力。异步工作站则争用剩余的带宽。同步服务能力的增加对大多数现有FDDI卡必须进行软件升级。ANSI委员会已制订出一个标准，因此这个特征在大多数新卡中将作为一个标准选项提供。

    基于连结的服务 基于连结的模式（只限于FDDI－Ⅱ）可以用授权的带宽在两个工作站之间建立专用通信线路。FDDI－Ⅱ中基于连结的服务通过在传输中分配规则的、重复的时间片建立两站间的专用通信信道。这种方法叫做等时传输。

    Fiber Cable 光缆

    光缆分单模光缆和多模光缆。单模光缆只能通过一种频率的光，而多模光缆可以通过几种频率的光，更详细的讨论请参见“光纤电缆”主条目。还要注意的是，FDDI的双绞线铜缆版本已被标准化了，它将在本部分后面讨论。

    可以使用的最小光缆类型是62．5／125微米多模光缆。

    FDDI规范坚持使用多模光缆。任何FDDI供应商都遵守这个规程。对将来发展的期望，一些用户可能更喜欢采用较高带宽的光缆。

    多模光缆比单模光缆更值得推荐，因为它更适合于将来的产品。

    光缆一度被认为价格昂贵，但竞争使其价格有了可观的下降，它是将来技术的较好选择。关于光缆的类型和价格请见“光纤电缆”条目。

    FDDI／OSI Relationship FDDI／OSI关系

    FDDI对应于开放系统互连（OSI）模型的关系见图F－5。FDDI顶层对应于数据链路层的介质访问控制（MAC）子层。在它上面是IEEE802．2逻辑链路控制层，它在以太网和令牌环网之间充当桥接器并进行分组传输。本站的分组被送到更高的协议层而不是继续发送。

    图中的站管理（SMT）标准管理站和环的配置、初始化、站的插入和移走以及诊断。

    FDDI－Ⅱ

    FDDI－I标准是专为需要传送实时视频或其他不能容忍延迟的信息的网络设计的。FDDI－Ⅱ要求所有FDDI－Ⅱ网上的节点都使用FDDI－Ⅱ，否则它就变成FDDI。现在的FDDI工作站必须连到自己的网上。

    FDDI－Ⅱ使用多路频分技术将频带分成可以保证多媒体通信传送的专用线路。它可建立起最多16个分开的线路，每个线路6．144Mbps，总共99．072Mbps。这种变化是因为带宽可以按需分配，每个这样的信道可以细分成总共96个独立的64Kbps线路。

    这些信道支持异步或等时通信，环中分配规则的分时槽，通过它进行数据传输。拥有优先权的工作站可以使用自己所需数量的槽及时传送数据。如果槽不用了，可以立即再分配给有使用要求的其他工作站。

    FDDI－Ⅱ在本书与读者见面时就会形成标准，但它可能不会成为一项被广泛使用的网络技术。一个原因是因为它与现在FDDI设计不兼容，另一个则是因为新兴的异步传输模式（ATM）设备对于大通信量和依赖时间的通信负载的网络技术更为合适。

    FDDI／UTP

    遵循FDDI标准的一个替换电缆技术是使用非屏蔽双绞线（UTP）铜缆。它最初由IBM、DEC、CabletronSystems、Crescendo Communication及其他厂商开发。ANSI双绞线物理介质相关（TP－PMD）标准定义了一个运行5型数据级电缆和IBM 第1型屏蔽双绞线（STP）电缆的FDDI网络。除了电缆距离以外，它提供了常规FDDI功能。UTP支持节点间100米（330英尺）距离而光缆则可以支持2公里。

    5型电缆被证明可用于在一个类似于10Base－T以太网的星形拓扑结构配置中进行短距离100Mbps高速数据通信。5型电缆是结构化布线定义的一部分，要求特殊的接线板、插孔板设备和墙面板。对双绞线进行严格定义才可能进行高速传输，例如，电缆线的绞合必须一直保持正常直至墙面板和插孔板的接头处。

    已经安装有5型数据级双绞线的10Base-T以太网可以顺利地升级到FDDI／UTP铜线标准。但要记住，FDDI和10Base－T的电缆配置是不一样的，尽管两者都支持到集线器的工作站连接，但FDDI还支持形成双环的站到站配置中的工作站连接。

    在一个类似于星形的配置中，工作站都连向一个集线器设备，它可以与光纤FDDI环相连。从集线器中出来的电缆在某个点上要将第一对和第二对线交叉，这可以在从集线器到接线板的线上完成。接线板把电缆通过建筑物墙壁连到工作站。

    连接远地局域网的网络主干还必须用基于光纤的FDDI。然而，在基于铜线的FDDI的使用日趋下降的同时，基于光纤的FDDI卡价格现在越来越便宜了。管理员应慎重地评价市场上的产品和可接受的价格。

    相关条目：Cabling电缆布线；Fiber－Optic Cable光缆。


  • 光缆 Fiber－Optic Cable

    Fiber－Optic Cable 光缆 光缆使用光子传输数据信号。光缆由纯玻璃制成，光几乎不可能透过纯玻璃逃逸，但是铜缆则存在以下在光缆中不存在的问题。

    长距离信号传输受到信号衰减的影响，会引起信号强度和幅值的损失从而限制了电缆的长度。

    电容，是引起电缆上信号畸变的不良特性，电缆的长度或绝缘层的厚度越大，电容和引起的畸变越大。

    相互干扰，是双绞线电缆干扰的主要来源，它是由邻近电线的信号“泄漏”造成的。

    光纤可以防止电磁干扰且自身不产生幅射，后一个特征在需要安全性的地方是很重要的。铜缆则自身就幅射能量，可以被侦听。在光缆上搭接线是可以被检测出来的，因为光缆中的信号强度改变了。光缆传播的距离也比铜线长。

    光缆使光通过一束玻璃来传输信号。这束玻璃极其纯净，按照Codenoll技术公司（一家主要的光缆生产商）的迈克尔·科顿的说法，“你通过3英里厚的光缆窗和通过八分之一英寸厚的玻璃窗看到的东西是一样的”，光缆的纤维芯是纯二氧化硅，这可以适应多种变化。你可以将光缆缠在身体周围，然后从它的一端射入一束光，立刻就能看到光在另一端出现。

    计算机信号通过把电信号0和1变成光学编码的0和1在光缆上发送。你只需要在一端设置一个发光二极管，将光射入光缆，然后在另一端放一个光检测器收集它，再把它转化为电信号。

    Cable Construction 光缆的构造

    请看一下图F－6的光纤电缆。线芯是光缆的透明玻璃成分。光信号就是通过它从一端传到另一端的。包围着线芯的玻璃护套——敷盖层是个关键的成分，它和镜子一样把光反射回线芯，当光通过光缆时，它的光线在敷盖层上的反射有多种不同的方式，如图F－7所示。光线反射角越小，光束从一端到达另一端的时间就越长。当这种时间差别达到纳秒（10↑9秒）级时，它导致的延迟就会使光缆的长度受到限制，究竟是多少依赖于线芯的直径。这种散射以纳秒／千米为计量单位的，这里讨论的多模光缆的散射通常是在15-30纳秒的范围内。

    下面是光缆的类型：

    塑料光缆 价格便宜且通常与廉价部件一起使用，作用距离仅有数米。

    塑料包皮二氧化硅光缆 性能比塑料光缆好一些，但价格贵一些。

    单层（Single-index）单模光纤电缆 适于长距离传输，它的中心直径很小，带宽很高。单模式电缆用的信号发生器是激光发生器。这种电缆是最昂贵和最难处理的。但它的带宽最高，传送距离最长。

    步层（step－index）多模光纤电缆 其中心直径比较大，发散特征也比较明显。这种电缆的发散率是每千米15到30纳秒。电缆适于局域网（LAN）环境，光发生器是发光二极管（LED）。

    分级层（Graded－index）多模光缆 有多层玻璃，其发散率足以应付距离的增长。电缆的发散率是每千米1纳秒。

    电缆规范是以分数形式列出中心和外皮直径的。例如，FDDI最小推荐类型电缆是62．5／125微米多模光纤。这表示中心是62．5微米直径，而中心加涂层直径是125微米。

    步层和分级层多模光缆的中心直径规范是50～1000微米。

    分层模式电缆的涂层直径从125到1050微米，分级层的涂层直径是125～140微米。

    单模分步电缆中心直径4～10微米；涂层直径75～125微米。

    Optical Cable Types光缆类型

    下面的光缆类型是弗吉尼亚罗诺克的Optical Cable公司（703／265－0690）提供的。它列在下面作为多厂商电缆类型的示例：

    A系列单路和多路互连电缆柔韧，富有弹性，对插孔线和跳线器很理想。如图F－8所示。

    12－纤维标准B－系列中断电缆多达156根光纤。是为LAN中带有连结器的终结方式设计。

    12纤维标准D系列分布电缆多达156根光纤。它是紧束式设计，适于长距主干线路。它是为插线板中带有连结器的终结方式设计。

    36－纤维DB－系列子组（Subgrouping）电缆有1000根光纤。它是为带有简单直接终结方式的高光纤计数打包设计的，也是通风电缆（防火）。

    12纤维D系列S型通风电缆有12根光纤，为通风区域设计。

    4－纤维标准B－系列通风中断电缆有102根光纤，为通风区域设计。

    D－系列分布外包电缆有156根光纤，为直埋环境中防啮齿类动物咬损设计。

    M－系列架空电缆有48根光纤和一个不锈钢或全绝缘载线或自持循环电缆，用于外部空中架设安装。

    Comparison Pricing 价格对比

    纽约Yonkers的Codenoll技术公司试图纠正光纤比铜线贵的传言。它们在其《光纤LAN手册》中列出下表，你可以打914／965－6300电话得到。其中CodeNet产品是以太网配置。

    ISA／Ethernet零售价对比

    第3类 第5类 CodeNet

    ISA网卡249（美元） 249（美元） 495（美元）

    集线器电缆（50Ω）50 338 100

    连结器／电缆 3 53 56

    劳务费（＄45／小时） 30 40 45

    集线器（每端口） 365 365 115

    总计（美元／端口） 697 1045811

    这些评估是基于下面的事实做出的：

    光缆每米0．86美元，或0．26美元／英尺。

    非屏蔽双绞线0．46美元／米，或0．14美元／英尺。

    屏蔽双绞线2．05美元／米，或0．62美元／英尺。

    第5类数据级电缆2．31美元／米，或0．70美元／英尺。

    相关条目：Cabling 电缆布线。


  • NetWare的文件和目录属性 File and Directory Attributes，NetWare

    File and Directory Attributes，NetWare NetWare的文件和目录属性 NetWare操作系统中的文件和目录可以被标记为下面列出的属性。当一个目录中的个别文件被指定为一些属性时，它们将替换一个用户在此目标中所拥有的任何权利。例如，如果一个用户有权删除一个目录中的文件，你可以通过指定禁止删除权来取消对这些文件的删除权。用户可以在他们的私人目录中设置这些权利，如果他们拥有此目录修改权的话。

    A 需要归档 被设置后表示一个文件被修改后需要备份。对目录无影响。

    Cc 不能压缩（NetWare 4．x） 状态属性，表示一个文件因磁盘空间不够而不能压缩。不能对目录使用，用户不能设置此属性。

    C已压缩（NetWare 4．x）状态属性，表示文件已被压缩，不能用于目录且用户不能设置此属性。

    CI禁止拷贝 设置后可防止Macintosh用户拷贝文件。不能用于目录。

    DI禁止删除 设置后可防止用户删除一个文件或目录。

    DC 不能压缩（NetWare 4．x）赋于文件时，防止文件被压缩。赋于目录时，防止目录中的文件被压缩。

    DM不能迁移（NetWare 4．x） 赋于文件时，防止文件被迁移到辅助存储设备如光盘库上。用于目录时，防止目录中文件被迁移。

    X 只执行 防止用户拷贝文件，保护软件的私有性。不能用于目录。一旦设置连ADMIN用户也不能清除它。然而文件可被删除然后从一备份或原始盘重存。

    H 隐含 在DIR列表时隐藏一个文件或目录，防止文件或目录被拷贝或删除。

    IM 立即压缩（NetWare 4．x）赋于文件时对文件尽快进行压缩。赋于目录时对目录中的文件尽快进行压缩。

    M 已被迁移（NetWare 4．x）状态属性，表示文件已被迁移到辅助存储设备如光盘库上。

    P 清除（Purge）赋于文件时文件被删后立即从系统中清除。赋于目录时目录和目录内的所有文件在删除后被清除。被清除的文件和目录不能用NetWare的Administrator或FILER程序恢复。

    RO 只读 设置后防止用户修改、删除或更名 一个文件。RO设置后D和R属性也被设置，对目录无影响。

    RI禁止改名 设置后防止用户对文件或目录进行改名。

    S 可共享 设置后可允许多个用户同时访问文件，通常用于记录加锁数据库文件。对目录无影响。

    SY 系统 设置后可防止用户在DIR列表中看一个文件或目录

    T事务的 用于文件时事务跟踪系统会保护文件。对目录无影响。

    相关条目：Accessright访问权限；NetWare NetWare网络操作系统；Rightsin Novell NetWare Novell的NetWare权限；Security Rights 安全权限。


  • 文件服务器 File Server

    File Server 文件服务器 参见Servers，Network 网络服务器。


 File Server　文件服务器
：在局域网中，所有用户都可访问的文件存储设备。与磁盘服务器不同，文件服务器比较复杂，它不仅要存储文件，而且还要在用户请求和改变文件时管理这些文件并保持这些文件的顺序。为了处理多个请求，这些请求有时是同时到达的，文件服务器包括处理器和控制软件，当然还有磁盘以存储文件。文件服务器常常是一台专门用来管理共享文件的有大硬盘的计算机。


  • 网络环境中的文件系统 File Systems in the Network Environment

    File Systems in the Network Environment 网络环境中的文件系统 文件系统用于在物理介质如磁盘上存储和检索文件。其他介质还包括光盘和磁带，但大多数操作系统需要特殊的驱动程序对这些介质进行读写。我们的讨论集中于磁盘存储系统，关于分布式文件系统特征的讨论请参见“Distributed File System（分布式文件系统）”。

    磁盘驱动器有可以前后移动的读写头，读写头下面的磁盘旋转形成磁道。数据就被写入磁道并从磁道读出。你可以联想一个音乐唱片，但是磁盘并不是从外到内的螺旋线，每个磁道都是个封闭的圆，并被分成若干个扇区。每道上的扇区数几乎都在8到50个之间。每个扇区由磁盘控制器使用磁标志标识。

    操作系统处于上一级，扇区和磁道的管理由磁盘控制器完成。然而操作系统以簇或块将信息传送到磁盘上，簇／块的大小是可变的，究竟是多少取决于操作系统类型和安装操作系统时设定的值。簇／块长可依据你存到磁盘上的文件类型，在大多数操作系统安装时设定。例如，若磁盘要存放小文件，则小的簇／块长比较好。若要存储大文件，最好使用大的簇／块。这都关系到读写操作的效率。如果一个小文件被操作系统使用大簇／块写到磁盘上，那么大部分空间就浪费了。但如果一个大文件用小簇／块写到磁盘上，文件就必须分成几个部分，这些部分最终可能分散于整个磁盘上，使读写操作的效率降低。

    需要使用一种方法跟踪磁盘上的文件和存储位置。另外被分成碎片的文件由于其不能用相邻簇存放而可能分散于整个磁盘，操作系统必须跟踪文件碎片的位置，在后面几个部分中将讨论几个流行的操作系统：

    DOS File Allocation Table（FAT） DOS的文件分配表（FAT）

    FAT是磁盘操作系统（DOS）的一部分。FAT跟踪磁盘上的簇和它们属于的文件。当产生一个文件请求时DOS检查FAT来定位文件的第一个簇。一个文件的簇可能分散在磁盘上，文件被分成碎片。这是由于DOS在存新文件时可以使用被删除文件的可用空间。如果一个文件在一个可用空间放下它就“被分成碎片。簇中包含着下一簇的地址信息。

    FAT是个效率不高的磁盘文件存储机制。它必须经常更新。由于FAT存放于磁盘的固定位置，读／写头就必须频繁地来回以刷新簇分配信息。OS／2操作系统的高性能文件系统（HPFS）是Microsoft公司对这些问题的一个解决方法。

    FAT有两份拷贝——一份作为万一第一份坏了时的备份。这份FAT也存放在固定位置，因此系统初启时可以定位引导文件。

    DOS使用一个8字符文件名和3个字符扩展名的文件名格式。文件存放于目录中，目录中还可以有子目录。文件属性有只读、隐含、系统和档案四种。

    High Performance File System（HPFS） 高性能文件系统（HPFS）

    HPFS是为OS／2这一DOS的增强形式设计的文件系统。提供了更长的文件名和DOS FAT所没有的增强的性能特性。它同时提供对大容量硬盘的访问、更有组织的特性和改进的安全特性。其他特性包括：

    HPFS保留了DOS中使用的FAT系统，但增加了按文件名的目录自动排序。

    DOS中的簇分配方法被512字节的简单物理扇区分配代替，这有助于减少由文件定位而不能用的磁盘空间。

    目录项中有修改、建立和访问日期、时间等信息。

    HPFS的目录项指向FNODE，FNODE包含文件数据或指向文件数据位置的指针

    HPFS有热修复功能，可将写到损坏扇区的数据移至另一区域。

    NT Fik System（NTFS）NT文件系统（NTFS）

    NTFS是Windows NT操作环境和Windows NT高级服务器网络操作系统环境的文件系统。NTFS有如下功能：

    通过可恢复性（事务跟踪）和热修复等这样的容错特性带来的可靠性。

    一个增加功能性的平台。

    支持可移植操作系统接口（POSIX）的要求。

    消除了FAT和HPFS文件系统的局限。

    NTFS提供了更长的文件名、数据保护和恢复及通过目录和文件许可权达到的安全性。NTFS支持大容量磁盘和文件的多硬盘存储（这叫做跨盘文件卷宗），例如一个公司的数据库可能太大以致要跨几个驱动器存储。

    NTFS提供可控制文件所有权和访问的内置安全特征。NTFS卷宗中文件不能从DOS或其他操作系统访问。这是Windows NT安全系统的一部分，但只是在你使用NTFS时是这样。

    NTFS允许文件名可长达256个字符。尽管DOS用户不能访问NTFS卷宗，但NTFS文件却可以被拷到DOS卷宗下。每个NTFS文件包含一个DOS可读的遵循DO3文件名格式的文件名。这个文件名由NTFS截取长文件名的前几个字符生成。

    NerWare File System NetWare文件系统

    NetWare文件系统高效快捷。它的容量高达32T字节（1TB＝10↑3GB＝10↑6MB），一个文件（如数据库）可以大到4GB。卷宗是硬盘的组成部分，而必要时卷宗又可跨接多个磁盘，最多可跨32个硬盘 它也支持多万个并发记录或文件锁定。信息以块方式存放并使用文件分配表（FAT）跟踪块。FAT和DOS中的一样，跟踪文件在磁盘上的位置。使用目录项表（DET）存放文件名、属性、用户权限和其他信息。

    嵌入Novell的NetWare网络操作系统的文件系统叫做NetWare核心协议（NCP）。

    NetWare文件系统在文件名方式和目录结构生成方式上与DOS相似。文件系统可容错，支持磁盘镜象和双工。一个叫SFT LevelⅢ的可选产品提供服务器双工。还提供下列增强性能的特征（根据推出的版本）。

    电梯查找 基于读写磁头的位置优化对陆续到来的读请求的响应。

    文件高速缓存 将常用信息放到高速缓冲存储器以减少磁盘访问。

    后台写 为提高性能将磁盘读和磁盘写分开。

    并行查找 如果使用磁盘镜象，磁盘读请求可以来自两个磁盘。

    快速FAT 将文件分配表放到内存加快访问速度。

    文件压缩 在NetWare 4．x上，文件可被压缩以扩大磁盘可用空间。

    块再分配 用单独的磁盘块存储小文件或文件碎片以扩大磁盘可用空间。

    Distributed File Systems分布式文件系统

    下面有四个主要的分布式文件系统，其基本思想是相似的。

    网络文件系统（NFS）这是Sun微系统公司专门为分布式计算环境设计的开放式操作系统，它的规范已准备采用，可供任何供应商实现。事实上，其他网络操作系统的许多特性都来源于NFS。其文件系统叫虚拟文件系统（VFS），VFS作为操作系统与文件系统的接口。Sun的实现使用传输控制协议／Internet网协议（TCP／IP）并为用户提供用户对UNIx系统小型计算机，大型计算机和其他分布式系统服务的透明访问。NFS的设计是使网上所有用户可以共享一个文件集。用户可以建立到文件服务器的暂时或永久连结访问这些文件。客户机／服务器计算是NFS的强大功能。

    Andrew文件系统（AFS）这是卡内基·梅隆大学开发的与NFS很相似的文件系统。AFS系统使用相同的VFS接口访问文件，但AFS使用与NFS不同的客户高速缓存特性。使用客户高速缓存，信息被放到客户机的本地驱动器上以使客户可以在那里与之交互操作，当任何其他用户改变了这些数据时再由服务器告诉客户。在NFS中，客户必须定期检查服务器，看自己从服务器上缓存的信息是否被改动了。

    分布式文件系统（DFS） 这是开放软件基金会（OSF）的分布式计算环境（DCE）的文件系统部分。DFS与AFS相似，但客户通过访问数据的令牌可以从服务器获得对那个特定范围数据的控制。当一个客户拥有令牌时，其他客户不能改变那里的数据。

    文件传输访问和管理（FTAM） FTAM是OSI环境中实现的文件传输服务。它允许客户（称为起动者）与服务器（称为响应者）交换文件。FTAM设计用于帮助用户在支持OSI协议的分散系统上访问文件。用户可以在记录级处理文件（FTAM就是以记录形式存放文件的）。细节请见“File Transfer Access and Management（文件传输访问和管理）”条目。

    分布式文件系统的详细论述在“Distributed File Systems分布式文件系统”条目中。

    Apple Talk Filing Protocol（AFP）App1eTa1k文件编整协议（AFP）

    AppleTa1k文件编整协议（AFP）存在于AppleTalk协议栈的表示层和应用层。AFP允许用户与AppTalk文件服务器通信。它将用户命令下传到更低层协议，这些低层协议处理系统间连结的建立和数据流控。AFP有下列特性：

    AFP为用户建立一个环境，使远程文件服务器上的文件就象在本地一样使用。

    除了用户必须在开始时建立到远程文件服务器的连结外，对文件服务器的访问和对本地文件的访问使用相同的过程。

    AFP提供限制用户访问文件的安全特权。

    AppleShare基于AFP，Macintosh系统可以通过内置的App1eShare客户机软件访问AppleShare服务器。Macintosh System7的文件共享实用程序，通过允许用户访问其他用户系统上的文件或使自己系统上的文件为其他用户所用，增加了分布式文件服务的功能。

    File Tromsfer Protocol（FTP）文件传输协议 （FTP）

    FTP是在象Internet那样的TCP／IP环境中用于文件传输的协议。在其中用户作为一个客户机可以从远程服务器上卸下文件。FTP是每个TCP／IP系统的核心部分并在相对于OSI协议模型的应用层实现。它的操作基于Telnet程序和TCP协议。FTP可以在许多计算机系统上采用并作为系统间文件传输的公用协议。

    相关条目：Apple Talk Filing Protocol AppleTalk文件编整协议；Distributed File Systems分布式文件系统；File Transfer Protocol文件传输协议；High Performance Filing Systems高性能文件系统；NTFS Windows NT文件系统。


  • 分布式文件系统 File Systems，Distributed

    File Systems，Distributed 分布式文件系统 参见Distributed File System 分布式文件系统。


  • 文件传输访问和管理 File Transfer Access and Management

    File Transfer Access and Management（FTAM） 文件传输访问和管理（FTAM） FTAM是在开放环境中提供客户机（启动者）和服务器（响应者）之间文件传输服务的OSI（开放系统互连）标准。它也提供对分散系统上的文件的访问和管理。在这些方面，它正致力成为一个通用的文件系统。FTAM的一个有趣的特征是它实现在OSI协议栈的所有七层上。注意FTAM是全面遵从美国政府OSI框架文件（GOSIP）的文件系统，当和X．400邮件信关一起使用时，可提供GOSIP 1．0框架文件和服务要求。

    FTAM的设计是帮助用户访问兼容的用FTAM实现的分散系统上的文件。这与文件传输协议（FTP）和网络文件系统（NFS）相似，这两者都运行在TCP／IP环境中。用户可以到记录级处理文件，FTAM就是这样存储文件的。在这方面，FTAM有某些关系数据库的特征。用户可以锁定文件或单个的记录。

    在FTAM系统中，服务器要维护有关用户和会话的面向连接的信息，直到会话结束。在无状态系统，如NFS中，请求采用无连接的方式，彼此独立地进行。这种无状态操作有许多好处。如果服务器崩溃了，请求简单消失，客户再申请另一个请求，崩溃后的恢复得到了简化。但在有状态系统中，两个系统都必须了解另一个系统是否崩溃，以便它们能够恢复状态和防止数据丢失。

    系统间文件的传输首先要建立一个面向连接的会话。FTAM客户机与FTAM服务器联系并请求一次会话。一旦会话建立就可开始文件传输。FTAM使用了虚拟文件存储的概念，它提供一个通用的文件概况。FTAM文件系统隐藏了不同供应商系统间的差异。它指定文档类型为直接二进制信息的文件或每行以回车符结束的文本文件。FTAM把数据解释成记录并且提供存储面向记录的结构化文件的虚拟文件存储能力。FTAM的主要功能有：

    将文件传输到FTAM服务器和从FTA服务器检索文件。

    删除FTAM服务器上的文件。

    读取FTAM服务器的文件属性。

    列表，生成和删除FTAM服务器上的目录。

    到目前为止，FTAM还没有作为一个可在局域网（LAN）环境中进行不同厂商系统间文件传输的有效系统流行起来。许多FTAM的实现现在也不能进行彼此间的互操作。但作为将大型计算机信息系统带入分布式环境的一种方法，FTAM工作得很好。

    相关条目：Distributed File System 分布式文件系统；International Standard Organization 国际标准化组织；Open System Interconnection Model 开放系统互连模型。


  • 文件传输协议 File Transfer Protocol

    File Transfer Protocol（FTP） 文件传输协议（FTP） FTP是在象Internet那样的TCP／IP（传输控制协议／Internet协议）环境中传输文件的一个协议。通常是客户机上的用户从远程服务器上卸下文件。FTP是每个TCP／IP系统的核心组成部分，在相对于OSI协议模型的应用层实现。它的操作基于Telnet程序和TCP协议。FTP在许多计算机系统上采用，是系统间文件传输的公共协议。

    FTP的特征有：

    支持ASCⅡ，EBCDIC，二进制和格式化（未翻译的）文件。

    赋予用户显示、生成和删除文件、目录的读写能力。

    口令保护。

    数据压缩。

    你可使用FTP与另一系统连接并执行各种文件列表和系统间文件传输的命令。一次会话以键入ftp命令，后跟主机名开始。例如你键入：

    pstis·nsf·gov。

    或者只键入ftp，这时会出现一个对话过程，使你进入指定的ftp命令，一旦登录成功，你可以看见ftp＞提示。然后就可发出如下一些命令：

    help 显示命令帮助表。同样可以键入命令名得到指定的帮助。

    dir或ls 列出远程系统目录中的文件。

    cd目录名 改变目录（在cd后键入目录名）。

    cdup 移到上一级目录。

    pwd显示现行目录名。

    get文件名 从远程系统拷贝文件到你的系统中。

    put文件名 将你的系统中的一个文件发送到远程系统中。

    bye或quit 结束会话。

    除非选择不同的传输方式，文件是作为ASCⅡ文本传送的。传输二进制文件要在命令前键入binary，传输文本文件要在命令前键入acsii。传输方式有两种，流传输方式发送原始数据而块传输方式发送经过检错的数据块。

    Anonymous FTP 匿名FTP

    匿名FTP是FTP的扩展，用于访问Internet上公共服务器上的数据。当一个拥有公共信息的地方建立了一个其他用户可以访问的系统时，它就在服务器上建立一个带有“anonymous”匿名的帐户。大多数情况下访问这个帐户是不需要口令的，所以任何访问服务器的用户都可浏览这个系统。这样的服务器上的信息类型一般是公用领域软件和发表的论文信息等公用信息。用户可以使用Internet的资源检索工具——ARCHIE实用程序查找匿名FTP文档的索引。

    Trivial File Transfer Protocol（TFTP ）普通文件传输协议（TFTP）

    TFTP是FTP的一个分类实现，是FTP的一个简化版本。它不能列出目录或鉴别用户。服务器仅和远程服务器相互传送文件。

    相关条目：File Systems in the Network Environment网络环境中的文件系统；Internet Internet网。


  • Windows NT的文件和目录许 Fileand Directory Permissions，Windows NT

    Fileand Directory Permissions，Windows NT Windows NT的文件和目录许可权 参见 Permissions in Windows NT Windows NT中的准许权限。


  • 文件共享 Filesharing

    Filesharing 文件共享 参见Document Management 文档管理。


  • 筛选，过滤 Filtering

    Filtering 筛选，过滤 过滤是由桥接器、路由器在信息分组上执行的过程，用它阻止某些类型的分组通过桥接器或路由器。分组的过滤可能基于分组类型——TCP／IP、IPX或AppleTalk——或者是目的地址。在路由器中进行过滤是为了防止局部分组经过一个互联网而增加不必要的通信负担，从而降低性能。路由器建立的这种壁垒就是通常所说的防火墙（firewa1l）。

    相关条目：Bridges桥接器；Routers路由器。


  • FINGER实用程序 FINGER

    FINGER FINGER实用程序 FINGER是早期的Internet实用程序，用于提供登录到服务器上的用户信息。这是搜索服务的早期尝试。用户首先要知道要查询的服务器，然后使用FINGER显示用户列表。FINGER提供的用户信息包括了用户提供的私人注记、好的想法或一些指导等信息，这些信息都包含在一个独立的文件中。

    使用WHOIS命令可以获得更多信息，它生成一个中央数据库并把用户信息放入库中，用户就可以查询数据库以得到用户或服务的信息。然而，这项服务因数据库维护方面的原因而受到限制。

    域名服务（DNS）是Internet上访问用户或服务信息的现行方法。然而Internet团体正在试验一个带有高级特征的全局搜索服务——X．500搜索服务标准。

    相关条目：Domain Name Service 域名服务；Internet Internet网；X．500 Directory Service X．500目录服务。


  • Firewall 防火墙

    一种确保网络安全的方法。防火墙可以被安全在一个单独的路由器中，用来过滤不想要的信息包，也可以被安装在路由器和主机中，发挥更大的网络安全保护作用。防火墙被广泛用来让用户在一个安全屏障后接入互联网，还被用来把一家企业的公共网络服务器和企业内部网络隔开。另外，防火墙还可以被用来保护企业内部网络某一个部分的安全。例如，一个研究或者会计子网可能很容易受到来自企业内部网络里面的窥探。


  • Flash Flash

    Flash

    Flash是美国Macromedia公司面向Windows和Mac平台开发的一种动画软件。它被用来为互联网网站，个人电脑展示应用和游戏开发交互式图形。Flash软件创造出来的动画效果，在互联网上需要通过浏览器中的插件程序来展现，而在网下则需要一个Flash播放器来运行。


  • FLASH 动感网页制作工具

    一种能够提供交互式的矢量图并且充满动感的WWW网页文件，能够完美地将图像，声音结合在一起作出精美震撼的作品，真可谓是"没有做不到，只有想不到"。现在最新版本是5.0。


 Flash　动画制作软件
：Flash是由Macromedia公司出品的网页制作“三剑客”软件之一，是专业的网页动画制作软件。它生成的动画可嵌入声音、电影、图形等各种文件，另还可与JS等相结合进行编程，进行交互性更强的控制。


  • 流控方法 Flow Control Methods

    Flow Control Methods 流控方法 流控（也叫联络）是用于通信设备之间管理数据流的异步通信协议。如果一台工作站在一个时刻接收的信息多于它的缓存或处理的能力，它就向发送方发出信号请求暂停传送直到它跟得上发送方。流控的信令可以用硬件（带外信令）或软件（带内信令）实现。

    硬件流控发生在使用多线电缆直接相连的两系统间。使用1至2根线进行数据传送，其他的线用于信令。例如，在请求发送／允许发送（RTS／CTS）信令方法中，一台终端设备通过使其RTS线有效表明可以发送数据，其他设备使其CTS线有效作为响应，为实现流控，接收者可以随时关闭其CTS线。

    软件流控假设设备在单线通道上通信，如与调制解调器相连的电话线。在这种情况下使用的流控方法是XON／XOFF。XON字符表示设备可以接收数据，XOFF字符则停止数据流直到XON被发送。

    相关条目：Asynchronous Communication异步通信；Serial Communication 串行通信。


  • 转发 Forwarding

    Forwarding 转发 在环网环境中，通信电缆由多台工作站共享，分组在到达目的地之前都从一个站到一个站绕环传送。每个站接收一个分组并检查它的地址，如果地址不是本站的，则站转发分组到下一站。

    转发也发生在桥接器或路由器上，分组到达桥接器或路由器后，由桥接器或路由器检查分组地址并将它转发到一个邻接的局域网（LAN）上。过滤功能过滤某些分组使它们不再通过路由器或桥接器转发出去。


  • 部分T1／部分T3 Fractional T1／Fractional T3

    Fractional T1／Fractional T3 部分T1／部分T3 部分T1线路是全T1线路的子通道，可从电话公司或其他提供者处以低价购得。全T1线路有24个部分T1线路，每个分线路有64Kbps的带宽。T3舷路则有哌?个T1通道，用户可以买一个或多个分线路而不必买整个线路，并且随时可以增加另外的分线路。

    一个客户进入电信网的访问信道由访问速率决定。一个T1线路信道能够表示下列中任一个：

    信道化T1，其中的一个道是24个T1时间片中任何一个。

    非信道化T1，其中的所有24个T1时间片看成一个信道。

    部分T1，其中的一个信道是一个1到23个时间片的组合。

    相关条目：T1／T3 Services T1／T3服务。


  • 帧中继 Frame Relay

    Frame Relay 帧中继 帧中继是一种用于连接计算机系统的面向分组的通信方法。它主要用在公共或专用网上的局域网互联以及广域网连接。大多数公共电信局都提供帧中继服务，把它作为建立高性能的虚拟广域连接的一种途径。帧中继是进入带宽范围从56Kbps到1．544Mbps的广域分组交换网的用户接口。帧中继是从综合业务数字网中发展起来的，并在1984年推荐为国际电话电报咨询委员会（CCITT）的一项标准，另外，由美国国家标准协会授权的美国TIS标准委员会也对帧中继做了一些初步工作。

    大多数主要的电信公司象AT＆T，MCI，US Sprint，和地方贝尔运营公司都提供了帧中继服务。与帧中继网相连，需要一个路由器和一条从用户场地到交换局帧中继入口的线路。这种线路一般是象T1那样的租用数字线路，但取决于通信量而定。图F－10描述了两种可能的广域连接方法，如下面所述：

    专用网方法 在这种方法中，每个场点将需要三条专用（租用）线路和相联的路由器，以便与其它每一个场点相连，这样总共需要6条专线和12个路由器。

    帧中继方法 在这种公共网方法中，每个场点仅需要一条专用（租用）线路和相联的路由器直至帧中继网。这时，在其它网间的交换是在帧中继网内处理的。来自多个用户的分组被多路复用到一条连到帧中继网上的线路，通过帧中继网它们被送到一个或多个目的站。

    永久虚电路（PVC）是通过帧中继网连接两个端节点的预先确定的通路。帧中继服务的提供者根据客户的要求，在两个指定的节点间分配PVC。这些信道保持连续不间断地运行，并且保证提供一种客户洽商好了的指定级别的服务。交换式虚电路在1993年后期被加到帧中继标准：这样，帧中继就成为了真正的“快速分组”交换网。

    Improved Packet Switching 改善的分组交换

    在过去的几年里，交换局在美国国内和国际网上已经安装了大量的光纤电缆，这样可以增加带宽。为了充分利用高带宽的优点，新的通信方案去掉原有方案中固有的常规开销，变得更为切实可用。帧中继通过取消网络自身进行流控和错误处理做到这一点的，避免了因网络自身做这些事情而导致的延迟。比较而言，老的x．25网技术实行扩展检错是由于使用不可靠的电话线传输数据。

    在帧中继中消除这个特性不会出现问题，即使是发生了错误。帧中继设想端节点设备是可编程的智能机器，它们能进行错误处理。端系统不会由于这种错误控制而超负荷，因为通常很少有错误。相对而言，X．25设想网络需要检错纠错是因为端节点是连到主机的终端。

    在帧中继中，中间节点（交换器）仅仅沿着预定的通路中继帧。在X．25中，中间节点必须完整地接收每一个分组，并在转发之前进行检错，如果有错误发生，节点要求发送方重传。使用这种方法，一旦分组丢失，发送方就尽快地重发一个分组。在X．25中每个中间节点使用状态表来处理管理、流控和检错，而在帧中继中是不需要的。

    如果一个分组由于帧中继网的拥塞而被破坏或丢失，检测帧丢失和请求重发是接收系统的工作。帧中继网把自己的所有精力都用来传递分组。在子网中的交换节点不会执行任何纠错，尽管它们能检测出被损坏的分组，一旦检测出，分组就会被丢弃了。

    Setting Up Frame Re1ay Connections建立帧中继连接

    为了建立帧中继连接，你需要与和US sprint，MCI，AT＆T或本地的地方贝尔运营公司等电信公司联系，通常要象下面那样进行通信速度的选择，以及专用线通信或交换式通信的选择。

    由Switched－56服务或综合业务数字网（ISDN）提供56／64Kbps交换式访问；高级数字网（ADN）提供专用线访问。

    两条ISDN线路或两条ADN线路提供128Kbps的访问。

    通过T1线路或部分T1线路可使用384Kbps到1．544Mpbs的连接。

    一旦你选定了一种服务，你就要计划一条从你的场地到帧中继服务提供者的链结。在你的场地放置路由器和帧中继访问设备以建立到提供者的帧中继端口的联接，如图F－11所示。

    帧中继端口一般用PVC连接。PVC是逻辑链路，它具有特定的端接点和服务特性。它们在网状拓扑结构上提供逻辑连接，且在使用前为交换局提供一种确定服务特性和速率的方法。它们也在端接点之间提供快速连接。在得到提供者的服务时，你可以为PVC规定一些服务特性，下面列举了一些服务特性。

    访问速率 这是线路的速度，它决定在网上的数据传输的速度。在美国，一般访问速率是1．544Mbps（T1）和56Kbps。

    提交的信息速率（CIR）CIR是帧中继电路上最高的平均数据传输率。它通常比传输速率慢；当传输突发数据时，传输速度可以超过CIR。

    提交的成组数据大小（CBS） CBS是网络提供者在一定的时间间隔内和正常的网络条件下所允许传输的最大数据量（位数）。

    额外的成组数据大小（EBS）EBS是超过CBS的最大非提交数据量，CBS数据是网络将在一定的时间间隔内发送出去的数据。EBS数据是被网络看作可以丢弃的数据。

    下面将列举另外一些由帧中继网提供的特性。

    网络服务 下面的管理特性和服务在帧中继网中可以采用：

    虚电路状态消息 远程服务在网络和用户之间提供通信。它确保PVC的存在和报告被删除的PVC。

    广播 这种可选服务使一个用户能把帧发给多个目的站。

    全局寻址 这种可选服务使帧中继网具有象局域网一样的能力。

    简单流控 这种可选服务为那些需要流控的设备提供XON／XOFF流控机制。

    拥塞控制 当帧中继网拥塞时，帧可以适宜地丢弃（端节点负责重发它们），或根据用户指定的级别丢弃。例如，用户可以指明一些对事务运作不是很关键的通信帧是可以丢弃的（DE）。路由器或帧中继交换器可以用DE来标识帧，DE的使用提供了一个方法，确保重要的信息通过网络传送，而不重要的信息可以在网络不太忙时重传。

    安全性 帧中继中有几个安全性选项：

    仅用专用线路才能访问网。

    需要口令访问网。

    不活动的站点超过一定时间就被注销。

    Frame Relay Specifications 帧中继规范

    在公共分组交换网上，一个帧中继网可以连接两个局域网（LAN）。这个过程非常简单——来自LAN的帧被放到帧中继的帧中，且通过网络的底层（帧中继的网状连结）送到目的地。统计式多路实用技术把来自客户站点多个源的数据有效地交替放在一条单一线路上传到帧中继网。帧中继是高级数据链路控制规程（HDLC）的改进，所以它能用于一些桥接器和路由器的升级。帧中继由于它的变长帧格式而不适合声音和视频通信。

    帧的结构 图F－12显示了帧中继分组的帧结构。帧两末端的标志域用特殊的位序列定界帧。开始标志域后面是帧中继头部，它包含地址和拥塞控制信息。在它后面的是信息（载体）和帧检验序列（FCS）。在接受方，帧将重新计算，得到一个新的FCS值并与FCS域的值比较，FCS域的值是由发送方计算并填写的。如果它们不匹配，分组就被丢弃，而端站必须解决分组丢失的问题。这种简单的检错就是帧中继交换器所做的全部工作。

    帧中继头部包含下列信息：

    口数据链路连接标识符（DLCI） 这个信息包含标识号，它标识多路复用到通道的逻辑连结。

    可以丢弃（DE）这个信息为帧设置了一个种级别指示，指示当拥塞发生时一个帧能否被丢弃。

    前行显示拥塞通告（FECN） 这个信息告诉路由器接收的帧在所经通路上发生过拥塞。

    倒行显示拥塞通告（BECN） 这个信息设置在遇到拥塞的帧上，而这些帧将沿着与拥塞帧相反的方向发送。这个信息用于帮助高层协议在提供流控时采取适当的操作。

    Frame Relay Providers帧中继的提供者

    大多数交换局现在都提供帧中继服务，例如象Compuserve这样的公共数字网（PDA）提供者就是这样。每个交换局有特殊的地点号，称为存在点（points－of－presence）。通过这个存在点用户能够链接到网上，通过本地交换电信局（LEC）或其它的提供者，客户能够访问存在点。下面列举了一些服务：

    BT North America Inc．′s global Expresslane（800／872－7654）。

    CompuServe Frame－Net Service（800／433-0389）。

    MCI Hyperstream Frame Relay（800／933－9029）。

    US Sprin＇ts Frame Relay service（800／8877－2000）。

    Williams Telecommunications Groups Wilpak（918／588－3210）。

    Frame Relay Forum 帧中继论坛

    FRF总部在加利福尼亚州Mountain view（415／962－2579），是帧中继用户、供应商和服务提供者的联合会。这个组织是由那些为发展帧中继标准建立实现协议的委员会组成。协议是根据团体中的成员或其它人提供的信息和建议建立的。FRF有关于帧中继的技术资料和市场信息。

    相关条目：Carrier Services 电信服务；Fast Packet Switching 快速分组交换；Packet Switching Networks分组交换网；Switched Services交换式服务；Virtual Circuits 虚电路。


  • 通信帧 Frames in Communication

    Frames in Communication 通信帧 帧描画了以串行流的形式在通信信道上发送的数据的结构，如图F－13所示。在串行通讯中，数据以流的形式从源端发送到目的端。两个系统共同维护当前的通讯会话。数据流被分成若干个帧，帧是由一个起始位、几个数据位和1个停止位组成的。异步通信帧中数据代表一个字符。以太网帧中的数据包含一个完整的或者部分的信息分组。分组在源端较高层协议中形成并分割进一个或多个帧的数据域中。

    帧定义了数据和控制信息在位流中的格式。在异步通讯中，每个帧是由一个起始位和停止位分隔的，在同步通讯中，每个帧是由时间分隔开的。下面描述了以太网帧中的域：

    标志 这个域包含一个位串（通常是01111110），它标识帧的开始和结束。

    地址 这个域可以指定源和目的地址。

    控制 这个域包含同步通信的信息或指示出下个域中的数据大小。

    数据 这个域包含被帧携带的数据。

    帧检查序列（FCS） 这个域包含验证分组正确性的检错值。

    注意：之所以采用帧的形式传送数据，是当线路发生误操作时，可及时地进行错误恢复。只有被破坏的帧才要求进行重传。

    帧中的数据可以是变长也可以是定长的。如果帧定义了变长数据域，那么它的大小可以在几千个字节的范围内变化。大多数LAN（例如帧中继）采用变长的数据域。使用定长帧（称为信元）的网，如ATM，具有预定义的发送速率，这在传送如视频图象这样时间敏感的信息时是很有用的。定长信元不会在网络交换设备处导致延迟，而变长帧却可能阻止其他帧传送。然而，拥有变长数据域的帧可以每次传送更多的用户数据。数据域越大，与帧相关的帧格式和头部信息就越少。例如，在光纤通道中，一次完整的传输可能就是仅有一个头部的一个帧，相反，同样的传输可能需要许多ATM信元，而每个信元都有各自的头部。

    相关条目：Asynchronous Communication 异步通信；Packets 分组；Serial Communication串行通信；Synchronous Communication 同步通信。


  • 频分多路复用 Frequency Division Multiplexing

    Frequency Division Multiplexing（FDM） 频分多路复用（FDM） 参见Multiplexing 多路复用。


  • 前端（台）处理机 Front－End Processor

    Front－End Processor 前端（台）处理机 前端处理机（FEP）是一个专用计算机，用来控制IBM主机和与其通信的终端之间的通信。IBM3725和3745还运行网络控制程序（NCP），NCP与运行在物理单元（PU）上的程序进行通信。前端处理机FEP与IBM 3270主机相连接。

    前端处理机，或通常被称为通信控制机，主要功能是减轻主机运行的应用程序的负担，采用这种方法，主机就不会经常地被外部设备中断。

    通信控制机建立会话，管理通信链路，检错和纠错，并且为集群控制器提供集中点。老式3705提供最多352条速度高至230．4Kbps的通讯线路并能连接8台主机，IBM3745提供全双工通信线路和用于后援与备份服务的双处理器，且支持IBM令牌环网。IBM 3745也支持IBM系统网络结构（SNA）网和公共分组交换网（使用相应的软件）。

    相关条目：Communication Controller 通信控制器；IBM Mainframe Environment IBM大型计算机环境。


  • 前端（台）系统 Front－End System

    Front－End System 前端（台）系统 在客户机／服务器环境中，前端系统一般是网上的一台计算机，用户可以用这台计算机访问存在各端服务器系统上的数据。

    相关条目：Client-Server Computing客户机／服务器计算；Distributed Computing 分布式计算。


  • FTP Server 文件传输服务器

    在TCP/IP网络中，客户机可通过文件传输协议(File Transport Protocol)下载或加载文件服务器上的文件，以实现资源共享，FTP Server 已成为互联网上的一种重要资源。


  • FTP 文件传输协议

    File Transfer Protocol，文件传输协议。是一种用于同主机交换文件的 客户机/服务器 模式的协议。如同Xmodem, Ymodem, Zmodem 和 Kermit。通常我们在进行网页上传的时候用到的就是FTP协议。


  • 全双工传输 Full－Duplex Transmissions

    Full－Duplex Transmissions 全双工传输 参见传输介质、方法和设备。


 3G 第三代移动通信
：3G是Third Generation的简称，是指第三代移动通信。第一代移动通信是模拟无线网络，第二代是目前广为使用的GSM和CDMA。3G将具有更宽的带宽，其传输速度将超过180Kbps，不仅能传输话音，还能传输数据，从而提供快捷、方便的无线应用，如无线接入Internet。


  • 网关，信关 Gateway

    Gateway 网关，信关 网关是一个计算机系统或是其它设备，它充当使用不同通信协议、数据结构形式、编程语言和（或）体系结构的两个系统之间的翻译器。网关不象桥接器，桥接器仅在两个系统中间传递信息而不转换。为了和目的系统匹配，网关总要重新包装信息或改变它的文法。

    注意：大多数网关工作在开放系统互连（OSI）协议模型的顶层－一 应用层。由于网关要进行协议转换所以它们的性能并不惊人。

    IBM主机网关 一台IBM主机网关可以使局域网（LAN）工作站和过去不能识别的连到局域网上的智能计算机系统相连。通过使用网关，LAN上的工作站被IBM主机看作3270终端，PC机的键盘被映象成3270键盘格式。但是，同时按下ALT－ESC两键或其它合适的键序列，就可在3270会话和通常独立的计算机会话之间转换。更复杂的网关功能，允许连到网关的PC机与主机相互传送文件，或运行客户机／服务器应用程序，使PC机访问主机系统上的后端数据库服务。IBM的高级对等联网（APPN），在IBM环境下提供了对等联网服务，于是网关的作用毋庸置疑。换句话说，IBM主机仅作为网络的一部分。

    DEC网关 用户使用DEC网关的理由与使用IBM主机网关的理由相同。数字式PATHWORKS产品使大量个人计算机能够访问DECVMS（虚拟内存系统）系统。

    LAN网关 它为数据流从一个LAN传到另一个LAN提供了一条通路，它是使用一个中间LAN服务作为互连方式实现的。这种中间LAN通常使用不同的协议，因此数据必须转换才能在它上面传送。路由器或许能完成这些服务。例如，许多路由器提供以太网和FDDI的连接。要从以太LAN传到FDDILAN上的分组或者被翻译（网关功能）并送到FDDILAN的一个结点，或者被路由到另一个连到FDDILAN的以太LAN上。后一种选择是一种封装形式，FDDI网作为以太LAN的主干网服务。另外，还有诸如AppleTalk－to－TCP／IP、IPX－to－TCP／IP和其它的协议网关。

    电子函件网关 电子函件网关可以在不同供应商报文传递应用间翻译报文。这样，拥有不同E－mail应用程序的用户就能通过网络共享报文。一个典型的E－mail网关能把报文转换成X．400格式，进行电子函件的传递。在许多E－mail系统中，X．400是一个通用的标准。大多数E－mail系统都能把它们的报文转换成X．400格式并能解释X，400报文，所以X．400可以看作是一个E－mail交换系统。

    Internet网关 在Internet世界中，曾经被称为网关的设备现在叫路由器，而现在网关指的是协议转换系统，例如电子函件中继器。现在被称为路由器的Internet设备主要是连接两个或更多的网络，或者作为内部网和外部网之间的链接点。这种设备从主机处接收分组，检验它们的地址，然后把分组路由到其它的路由器或主机系统。网关现在通常是应用程序间的转换设备，例如，网关可以在OSI虚终端和Internet Telnet终端程序之间进行转换。

    相关条目：DECnet DECnet网；DEC PATHWORKS DEC PATHWORKS系列产品；Electronic Mail电子函件；IBM Mainframe Environment IBM大型计算机环境；Internet Internet网；Routing，Internet Internet路由选择。


  • Gateway 网关

    网关。将两个使用不同协议的网络段连接在一起的设备。它的作用就是对两个网络段中的使用不同传输协议的数据进行互相的翻译转换。举个例子，一个商业内部局域网就常常需要通过网关发送电子邮件到Internet的相关地址。


  • 网关对网关协议 Gateway－to－Gateway Protocol

    Gateway－to－Gateway Protocol 网关对网关协议 这个协议是为了使用Internet而开发的首批路由选择协议之一。它类似于Xerox网络系统（XNS）的路由选择信息协议（RIP），但是RIP由于跟不上网络的动态变化，而变得不能适应用户的需求。终于，使用独立系统（域）概念研究和开发了内部网关协议（IGPS）和外部网关协议（EGPS）。

    相关条目：Domain 域；Routing，Internet Internet路由选择；Routing Protocols 路由选择协议。


  • 全局命名服务 Global Naming Services

    Global Naming Services 全局命名服务 命名服务类似于电话薄和网上的用户服务目录。全局命名服务可以跟踪企业计算系统或跨跃全球的网上用户和服务。Internet标准委员会正在研究把开放系统互连（OSI）的X．500全局命名服务，作为一种方法为每一个连到网上的用户提供查询服务。

    相关条目：Directory Services 目录服务；Directory Services，NetWare NetWare中的目录服务；Directory Services Naming，NetWare 4．X NetWare 4．x的目录服务命名；Distributed Computing分布式计算；Electronic Mail电子函件；X．500 Directory Services X．500目录服务。


  • Oracle的Glue解决方法 Glue，Oracle

    Glue，Oracle Oracle的Glue解决方法 Glue是对被oracle称为应用程序接口裂缝（APIgap）的一种解决方法。它提供一种方法，以连接运行UNIX、Macintosh、Windows和其它系统上各种前端应用程序和后端数据库服务。Glue提供了一种一致的高级方法，使用现存的数据库应用工具，访问下列系统上的数据：它们是ORACLEV6、ORACLE 7 Cooperative Server Database、dBASE and Paradox database、Orac1e Mail Server、Sharp Wizard electronic organizer和许多原生的文件系统。

    相关条目：Database Connectivity APIs and Middleware 数据库互联性API和中间件；Database Management System 数据库管理系统；Distributed Database 分布式数据库。


  • 政府OSI框架文件 Government OSI Profile

    Government OSI Profile（GOSIP） 政府OSI框架文件（GOSIP） GOSIP是政府采纳的一组标准，它规定政府机关采购计算机设备使用开放系统互连（OSI）标准。OSI制订了一组由国际标准化组织（ISO）承认的管理功能、安全特性和其它网络功能的标准。OSI是很广泛的，正努力把其标准推向全球，尽管任何一个组织和供应商都遵守所有的OSI标准是不可能的。美国、英国、加拿大、日本、法国、德国和澳大利亚已经应用了GOSIP标准。

    美国的GOSIP是由GOSIP联邦信息处理标准（FIPS）规定的，由政府于1990年通过国家标准和技术协会（NIST）发布。GOSIP严格遵循OSI标准，在计算机设备之间提供互操作性。美国政府的GOSIP定义了OSI的一个子集，目的是向用户提供一个进入网络的接口，并且向网上的一些（但并非所有的）系统提供GOSIP服务。

    为了紧跟技术和OSI标准的发展，GOSIP定期性地更新。在美国，这些更新每年进行一次。由政府机关组成的高级需求组，用稳定应用协议（Stable Implementors Agreements）提供的信息来指导它们的更新活动，最近一次的年更新标准称作FIPS146。实现和使用GOSIP的技术规范和指导，概括于政府开放系统互连框架文件GOSIP用户指导书中，读者若感兴趣的话，可以与位于马里兰州Goithersburg的NIST联系获取。

    虽然GOSIP的大部分内容仍在定义并将继续经历改变，但有趣的是，在TCP／IP盛行的今天，政府正在极力推行OSI标准。实际上，OSI和TCP／IP是相互竞争的标准。许多政府合同中都包含了TCP／IP规范，附带有包括向GOSIP迁移的协定。正如它所写的那样，NIST正在考虑把TCP／IP产品加入到GOSIP中。但是在1994年初，一些政府机构建议政府放弃它的GOSIP标准。在许多情况下，政府机构已经钻了空子，避免购买OSI产品，所以进一步削弱了使用GOSIP的理由。

    图G－1示意了GOSIP第二版的结构。第三版的GOSIP正在出现，而第四版GOSIP的特性正在制订。GOSIP3包括支持CCITTX．500搜索服务标准、电子数据互换（EDI）、事务处理和光纤分布式数据接口（FDDI）。通用管理信息协议（CMIP）被建议作为管理上述所有服务的一种方法。

    政府间的GOSIP定义不一定兼容，因为每个国家都可以按照自己的意愿来定义GOSIP。一些国家挑选面向连接的传输协议，而另一些国家却挑选无连接的协议。

    相关条目：International Standardization Organization 国际标准化组织；Open System Interconnection Model 开放系统互连模型。


 GPRS　通用分组无线业务
：GPRS(General Packet Radio Service)是在现有GSM网络基础上发展起来的分组交换系统，与互联网或企业网相连，向移动客户提供丰富的数据业务。


 GPRS　通用分组无线业务
：GPRS(General Packet Radio Services)是一种新型的分组数据传输业务。它在现有的GSM网络的基础上增加一些硬件设备和软件升级，形成一个新的网络逻辑实体，并以分组交换技术为基础，采用IP数据网络协议，使现有GSM网的数据业务突破了最高速率为9.6kbit／s的限制，最高数据速率可达170kbit／s。用户通过GPRS可以在移动状态下使用各种高速数据业务，包括收发电子邮件，因特网浏览等IP业务功能。


  • 接地问题 Grounding Problems

    Grounding Problems 接地问题 参见Power and Grounding Problems and Solutions 电源和接地问题及解决方法。


  • 组 Groups

    Groups 组 组是用户或用户帐户的集合。通过建立组，可以简化对大量用户进行管理和确定权限的任务。直接把消息发给组显然比把消息分发给组中每个用户容易。组有名字，并且能包括工作在类似项目、属于同一部门或属于公司内的一个俱乐部的用户。一个用户可以属于多个组，例如，一个用户可以属于管理者组、顾问组和高尔夫球组。

    你把目录和文件的访问权赋予用户，用同样的办法可把这些权限赋予组。然而，简单得多的办法是把权限赋予组，然后把用户加到组中，用户便拥有那个组的所有权限和特权。在计划一个网时，组应当被规定并在增加任何用户之前建立。这样，当你建立一个新的用户帐户时，就可以把用户加进组内。一个用户可以成为多个组中的成员。发送消息到组比发送一个个消息到组中每一个成员要容易得多。

    下面是一些使用组方法的例子：

    一个字处理组有权运行某个字处理程序并在它的数据目录里存储文件。

    电子函件组可以简化报文寻址。例如可建立一个经理组、一个雇员组或一个临时工组。

    系统管理组在安全的网络目录中有权操作。

    备份组对备份目录有特别访问权。

    另外关于一个组方面令人感兴趣的是，它能方便地修改和删除一大群用户的权限。你既可以删除整个组，也可以从组中删除用户。当用户从组中被删除时，它们仍然在系统中拥有一个帐户，但是它们和组有关的权利不再有效。

    Groups in Windows NT Windows NT中的组

    Windows NT包括一组拥有预定义访问权的预定义组，访问权使它的成员能够执行系统上各种任务和活动。

    存在两种类型的组：本地组和全局组。本地组是由能直接访问本地机的用户组成，换句话说，他们就在自己的键盘前。全局组是由能访问网上其他工作计算机资源的用户组成。本地组的成员仅仅只在被定义组处的工作站上有权利，一个具型的本地组例子是超级用户组，它的成员拥有一些（但非所有的）管理本地机的管理员权利。而一个典型的全局组是网络组，它包括任何一个从网上其它计算机访问NT服务器的用户。

    下面所述帐号由NT自动建立的。在许多情况下，这些组中的组应该为每种类型的用户提供一些合适的访问权利。如果不是有这样，你可建立自己的组，然后用windows NT用户管理工具为自己的组赋予常规的访问权。

    管理员组（The Administrator Group）

    在NT工作站上，管理员组有最高的控制权和访问权。管理用户由于是管理员组中的成员而获得相应的访问权利，起初，组的成员有管理员用户帐户和初始用户帐户，如果NT工作站是Windows NT的高级服务器域的一部分，那么组就称为Domain Admins，必要时它也可以非常容易地被删除。

    管理员组有权执行下列任务：

    在本地建立和管理本地系统上的用户和组帐户。

    赋予用户权利。

    锁住和解锁工作站。

    格式化和管理硬盘。

    建立普通程序管理员组。

    使目录和打印机可共享。

    维护一个本地系统框架文件。

    超级用户组（The Power User Group）

    在访问系统的能力上，超级用户比管理员用户降了一级。超级用户组的成员有执行下面所列任务的权利：

    本地登录。

    远程访问赋予了超级用户帐户的计算机。

    修改系统时间。

    关闭系统。

    超级用户组的成员好象是管理员助理。该组最重要的任务之一就是建立新的用户和组的帐户并在系统上设立共享目录。超级用户成员能执行下列任务：

    在本地系统上建立和管理用户和组的帐户。

    锁住但不废弃工作站上的锁。

    建立普通程序管理员。

    使目录和打印机共享。

    维护一个本地登录框架文件。

    用户组（The Users Group）

    在初始安装后所有增加的用户帐户被加入用户组。管理员、客户和初始用户帐号不属于用户组。用户组有权本地登录和关闭系统、锁住工作站和维护一个本地框架文件。用户组可以获得所属目录和文件的使用权。

    客户组（The Guest Group）

    用户组为暂时用户提供对系统的有限访问。客户组成员有权本地登录，如需要，可赋予它们附加的文件和目录使用权。可以把客户当作暂时的雇员，起初任何一个用户可以不要口令登录，然而对系统只有非常有限的访问权。例如，客户组成员能够把文件写入和存在软盘中，但不能对硬盘驱动器操作。你或许想提高客户帐户的权力，那么可建立一个特殊的文件目录和赋予客户组用户在该目录中存储文件的权力。

    全员组（The Everyone Group）

    全员组包括所有使用计算机的用户，当你想为系统中的每一个用户分配权利和许可时只需把这里的权利和准许赋予全员组。全员组也包括访问网上计算机的用户，尽管这些人也在用户组，但你能够赋予全员组所需的目录和文件准许权限。全员组成员有权执行下列任务：

    本地登录。

    远程访问赋予了超级用户帐户的计算机。

    关闭系统。

    备份操作员组

    备份操作人员有权执行备份任务，它需要具有能读系统中所有文件的能力。这包括文件的拥有者拒绝所有的用户（包括备份操作员组成员）访问的文件。执行备份的权利高于文件和目录拥有者确定的文件和目录使用权。备份操作员有权执行下列任务：

    本地登录。

    关闭系统。

    备份文件和目录。

    重存文件和目录。

    网络组和交互组

    网络组由所有能访问网络连接的计算机的用户组成，交互组包括所有的本地计算机用户。换句话说，这些组的成员取决于它正在访问那个系统，是本地系统还是网络系统。

    相关条目：Account，User Network 用户网络的帐户；Users and Groups 用户和组。


  • 群件 Groupware

    Groupware 群件 群件是一个网络软件概念，它定义了由一组（群）人使用的应用程序。它是基于这样一个设想，因为网络连接用户，这些用户应当通过网络互相操作，作为一个整体而提高组的生产率。电子函件是一个很好的群件例子。它能使用户间相互通信和协调活动。此处，群件是一个许多不同地方定义许多不同事情的术语。

    一个真正的群件包括允许不同系统上的用户能在一个项目上交互和协调工作。编辑一个文件并把它发送给另一个用户观看还不是一个群体的例子，但它已经非常接近了。一个集中式网络查看组成员安排表，然后把会议安排在大家都能参与的时间片，这是一个群件的例子。

    另外一个群件例子是，Windows for Workgroups中的对象链接和嵌入（OLE）特性，它使网上的不同用户为一个称为复合文档的主文档提供诸如图形、文本和电子表格信息这样的元件，如图G－2所示。复合文档里元件维持一个到建立这个元件的工作站上文件的链路。如果工作站上的文件被改变了，复合文档里的链接至这个文件上的元件也改变。例如一个艺术家，任何时候只需简单地编辑存在他计算机上的文件就可以修改复合文档里的艺术品，下一次市场部打开复合文档时，艺术文件里的任何改动都自动地在复合文档中更新。

    进一步说，一个调度应用程序可以在网上召开一次会议，参加者只需坐在自己的工作站旁，然后打开屏幕上的文档并一起在文档上操作来协商作一个项目。当文档打开时，它会出现在所有参加者的屏幕上，文档中任意一个变化都会出现在每一个人的屏幕上。同步电话会议和电视会议可以帮助用户协调彼此的活动。实际上，运行于Microsoft Windows下的桌面电视会议系统，可用来让用户在一个窗口上观看其他用户同时操作另一些窗口中的文档。

    另外，一个令人感兴趣的群件概念是公告牌（bulletin board）和交互式会议。

    公告牌是一个能把信息传到其它用户观看并能响应信息的地方。典型地，公司事务和日程可以发往公告牌区。热点标题会产生强烈响应和反响。人们可以从公告牌上读信息并可以把自己的信息发往公告牌。当然所有的对话都可以存储到盘上并打印出来看。Instant documentation！

    公告牌典型地进行消息会话，而一个交互会议是一个预定的事件，这个事件可以用一个发表独创意见的会议来类比。一个公司可以安排一次所有雇员都能对公司的政策和新产品开发提交文件的会议。强调一下，人们只有当信息滚动显示时或自己参加时才能看到消息。整个会话能被存储和打印以备将来参考。参与者不需打断会议就可以进入或退出，并且如果他们宁可匿名的话，还可以使用“操纵杆”来代替他们的名字。

    一旦群件应用程序放在恰当的地方和用户开始从中获益，传统的通信方法就会弃之不用。由于旅行和不能有效地利用时间，开会看来是越来越不方便。实际上，会议成为每天都要举行的事情，与会人员在他们方便的时间用电子函件的方式参加会议。电子函件传递消息正成为一种与他人进行通信的 种方法，尤其是其他人很难通过电话联系时。当用户可以把各种消息诸如声音、图形和视频图象附加给电子消息并即时发送它们的时候，即使是邮政快件似乎也过时了。

    下面列出了一些群件的优点和人们理想的期望：

    在一个组织中，群件促进合作并在一个联合项目中帮助人们进行通信和协作。

    群件可协调人和过程之间的交互活动。

    群件有助于规定文档流和完成一个项目必须做的工作。

    群件把共享信息放进一个结构化的复合文档中为用户提供了唯一的信息共享方法。文档成为集中存储共享信息的地方。

    理想地，群件应能使合作项目中的每一个人能以一种更有效的方法完成各自指定的工作。

    理想地，群件只简单规定一些用现存应用程序来共享信息和帮助用户协作的方法，而不是来自某一供应商的特殊应用软件。

    Electronic Mail and Groupware 电子函件和群件

    当今，群件的一个最重要的组成部分是电子函件。电子消息系统提供一个“主干”，在这“主干”的任何一组用户能够合作项目和在共享文档上操作。实际上，电子函件可以叫做廉价群件，因为它的消息传递服务允许人们彼此协商。

    电子消息传递是一种存储转发技术。你把消息发给一个用户时，就把它放进用户邮箱，接收方可以在稍后的时间内阅读该邮件。你还可以在消息里附带文档和图形文件，这将大大地简化与其他用户交换文档的任务。想一想原来采用的方法：把文档放进共享目录里，然后呼叫用户告诉他们文件已经存放在目录里了。如果用户是远程用户，你必须使用调制解调器和处理一些相关的问题，如商定线路速度、协议、数据位和其他因素，有了电子函件，每个用户可以用他们自己的应用程序拨号进入一个中心电子邮局，他们在那里投入和给出消息。

    电子函件的一个发展趋势是，能够把各种不同类型的对象（信息集合）放进消息。例如使用Microsoft或其他公司的E－mail应用程序的用户能在电子函件中插入声音录音和电视剪辑。中间件产品使这些都很容易实现。在许多应用程序的菜单上，电子函件正成为一个标准功能。几乎每一个基于Windows的产品在它的菜单上都有或将有“电子函件”选项，这样用户就能直接从应用程序发送和接收邮件。

    电子函件系统唯一的问题就是，存在那样多的系统和已经使用了这样的系统。当一个组织准备集成系统和用户时，管理者将面临在这些不同的E－mail系统里交换消息的任务。例如，销售处Joe用Microsoft Mail应当能把消息发给使用Lotus Notes的管理处Hany。有几种方法进行这种交换：

    把整个公司转接到一个电子函件系统，这是一个不大可能实现的建议。

    建立能把消息从一个系统翻译到另一个系统的信关。但是，对每一个不同的系统都需一个信关，或者你可以把Novell的消息处理服务（MHS）作为一个进入大多数标准系统的信关。

    电子函件主干网为电子函件的交换提供了一个通用协议环境。对每种不同类型的E－mail系统仍需要一个信关，但这时信关是连到主干网上的。与Novell MHS一样，简单邮件传输协议（SMTP）和X．400标准都使用这种方法。

    选择消息交换系统作为中心电子函件路由器和必要时在系统间翻译消息。Softswitch（宾夕尼法亚州的Wayne）的企业邮件交换（EMX）就是这样一个产品。

    Warkflow Softare 工作流软件

    工作流软件组合电子消息传递和文档管理以及影像处理。这个概念就是通过把文挡经过几级处理过程，送给一个有设备和技能操作文档、或有权签署和生效文档的群件成员来移动一个文档。尽管工作流软件不被认为是一个真正的群件应用程序，但是它促进了工作组在工作自动处理时的协作。

    下面有一些关于工作流软件的关键特性：

    文档包含路由选择信息，它使文档分派给预先指定的用户和设备。

    文档能同时访问。

    一个文档当“正在施工”时是可查看的，直到它退出了工作流处理过程。

    工作流软件有文件编排系统，队列和维持系统运行的工作流管理软件。

    被授权的用户可以在许多级别上停止活动，锁住部分或全部文档防止进一步编辑。

    工作流软件可以通过验证和数字签名提供安全性：

    接收方确信发送方的鉴别，文档是可鉴别的，并且在传输过程中没有被修改；发送方确信授权方对文档中的任何修改都能被检测出来。

    出自Action Technologies（加利福尼亚州的Alameda）、DEC（马萨诸塞州的Maynard）、IBM（纽约州的White Plains）、Lotus Development（马萨诸塞州的Cambridge）和其他公司的工作流系统都很有效，象Windows这样的图形用户环境非常适合工作流应用程序，来自不同应用程序的图形、文本和其他元件在图形用户环境中，被当作对象集成进文档中流动。

    Enabling Technulogies支撑技术

    一些标准正在出现，它们使群体特性成为应用程序的一部分并使这些特性可跨平台工作。一些标准在下面提到，一些标准在本书别的地方相应的条目下讨论。

    Standard Generalized Markup Language（SGML）SGML定义了一种把信息存进文档的标准方法。通过提供一些集成或共享其他环境所建信息的方法从而超过了ASCⅡ码标准。SGML文档能作为“智慧文挡”观看，而ASCII文档却被看作“哑”文挡。文件包含定义每一节或元件的属性，如段、表、头部或页面的布局格式。包含信息可以传输到任何其它系统，只需用同样的方法格式化文档。SGML是制作跨越多个供应商界限的工作流应用程序的主要工具。

    Windows Open System Architecture（WOSA）WOSA是一个Microsoft体系结构，它规定怎样建立交叉于不同的平台和允许在企业内信息自由流动的应用程序。利用WOSA，开发商可以制作容易访问E－mail，后端数据库和主机连接的应用程序。任何一个运行于Windows环境下的应用程序均能访问这些资源。

    Apple Open Collaborative Environment（AOCE）苹果计算机公司的AOCE是专门为在网络环境里统一工作组和工作组流而设计的。实现的环境是由一系列应用程序接口（API）和使用应用程序和下列服务进行通信的软件模块组成的：

    应用程序间的消息交换。

    E－mail使能应用程序，以便用户能够从他们的应用程序内部发送电子函件。

    存储用户姓名和地址以及网上资源的搜索命名服务。

    检验用户登录和为用户提供全局访问授权的验证服务。

    给文档附加合法电子签名的数字签名。

    GroupWare Products群件产品

    电子函件和文档影象正成为群件的一个重要方面，获取的文档（在传真纸和打印纸上）能被所有用户共享。光学字符识别（OCR）也提供了一种获得文档、扫描文档和把它们转换为计算机可读文本的方法。下面讨论一些通用的群件产品。

    Microsoft Windows for Workgroups是一个完整的工作组（workgroup）环境。它是一个网络操作系统，它包括许多帮助用户共享信息及协作的工具和应用程序。列举如下：

    对象链接和嵌入（OLE）用于建立网上复合文档。

    一个简单的消息系统使许多用户能在网上举行“电话会议”。

    Microsoft mail电子函件软件使用户交换E－mail消息。

    Microsoft schedule组调度软件可以使用户安排会议并跟踪安排情况。

    Banyan提供了智能消息传递服务（IMS），它是一个让用户存储、管理和路由文档和消息的产品。它提供了E－mail和工作流软件。

    数字设备公司（DEC）提供了Teamlind产品和All－in－1综合办公系统。All－In－1连接用户到PATHWORKS（一个DEC网络操作系统），它提供了连接性、X．400E－mail服务、文件转换、VAX Notes组会议软件和Team Route工作流应用程序。

    Lotus开发公司的Notes是一个为大型组织设计的群件包。它提供了消息传递、数据库和文档处理功能。

    Wordperfect Office提供了集成E－Mail、日历、日程安排表、任务管理和工作流软件。

    相关条目：Compound Documentation 复合文档；Documentation Exchange Standard 文档交换标准；Documentation Management 文档管理；Electronic Mail电子函件；Imaging影象，成象，映象；Information TransferAPIs，E－mail Email的消息传递API；Inter－Application APIs应用程序间API；Workflow Software工作流软件。


  • GUI 图形用户界面

    一种全屏幕图形界面（不局限于字符和数字），用户通过点击设备（例如鼠标）操纵图形的屏幕元素，可以运行程序，执行命令，更一般地，与计算机交互作用。这与在提示符下敲入命令相对。通常，拨号网络用户需要通过SLIP或 PPP访问，才能在自己的圆形用户界面中直接与Internet设施打交道。


  • Hacker 黑客

    黑客，计算机专家，喜欢与网络打交道并试验系统局限性的人，热衷于编程的或熟练的程序员(在Internet之外，单词hacker有着令人厌恶的涵义，指闯入计算机网络，窃取或故意破坏信息的人。在Internet上，这种有恶意的黑客被称cracker)，他们热爱发现并修正网络系统上的BUG，他们希望我们的网络能够更加安全。


  • 半双工传输 Half－Duplex Transmission

    Half－Duplex Transmission 半双工传输 参见“Transmission Media，Methods，and Equipment传输介质、方法和设备”条目。


  • 握手，联络，信号交换 Handshaking

    Handshaking 握手，联络，信号交换 参见“Flow Control Methods流控制方法”条目。


  • 硬盘 Hard Disk

    Hard Disk 硬盘

    硬盘是一种主要的电脑存储媒介，由一个或者多个铝制或者玻璃制的碟片组成。这些碟片外覆盖有铁磁性材料。绝大多数硬盘都是固定硬盘，被永久性地密封固定在硬盘驱动器中。不过，现在可移动硬盘越来越普及，种类也越来越多。

    绝大多数台式电脑使用的硬盘要么采用IDE接口，要么采用SCSI接口。SCSI接口硬盘的优势在于，最多可以有七种不同的设备可以联接在同一个控制器面板上。由于硬盘以每秒3000—10000转的恒定高速度旋转，因此，从硬盘上读取数据只需要很短的时间。在笔记本电脑中，硬盘可以在空闲的时候停止旋转，以便延长电池的使用时间。老式硬盘的存储容量最小只有5MB，而且，使用的是直径达12英寸的碟片。现在的硬盘，存储容量高达数十GB，台式电脑硬盘使用的碟片直径一般为3.5英寸，笔记本电脑硬盘使用的碟片直径一般为2.5英寸。

    新硬盘一般都在装配工厂中经过低级格式化，目的在于把一些原始的扇区鉴别信息存储在硬盘上。


 Hardware 硬件
：一个计算机系统分为硬件部分和软件部分，硬件就是指计算机系统中的物理构成部分，比如显示器、主板、CPU、内存、各种插卡……这些都称为Hardware。


 HDF 层次型数据格式
：HDF(Hierarchical Data Format)，可以存储不同类型的图像和数码数据的文件格式，并且可以在不同类型的机器上传输，同时还有统一处理这种文件格式的函数库。大多数普通计算机都支持这种文件格式。


 HDML　手持装置标示语言
：从超文件标示语言(HTML)衍生而来，这种程序语言让移动装置如手持式计算机或智能电话可以存取互联网络的内容。


 HDTV　高清晰度电视
：HDTV(Hign Definition Television)指一种比目前标准的电视在色彩和声音上都更好的电视系统。通常指数字电视，即电视台采用数字方式进行信号传输的一种电视。


  • Microsoft的企业网管理系统 Hermes，Microsoft

    Hermes

    Hermes，Microsoft Microsoft的企业网管理系统（Hermes） Hermes：希腊神话故事里的一个神，为众神的信使并掌管商业、道路和旅行者。

    Microsoft Hermes是一个企业网络管理系统。它是一组基于Windows NT的工具，用来管理网上的计算机、工作站和其它设备。Hermes的主要目的是帮助网络管理员收集网上的计算机系统的信息，并且帮助他们更新这些系统，而不需要管理员亲自跑到每个站点处或叫其它用户完成更新工作。由于减少了系统升级和排错的负担，网络管理员可以集中精力监控网络，以防止潜在的错误发生。为了达到这个目的，Hermes向管理员提供所需的信息。

    下面列出了一些由Hermes提供的功能：

    库存功能，能把工作站的硬件和软件信息存到一个Hermes能访问的文件中。

    软件分发功能，自动地安装软件并更新到用户的机器上。

    许可软件（Licensing Software），能有效地跟踪软件许可证的号码，以确保一个机构使用的软件是软件许可协议中规定的软件。对用户来说，只有在一定的优先级或者时间范围内才能使用某些软件。

    诊断工具，能跟踪网络的性能和状态。可以通过设置阀值和报警以警告管理员潜在的问题或者过载状态。

    辅助功能，可以使管理者（从自己的管理工作站上）查看用户的屏幕并向用户发出命令。这个功能类似远程通信软件包，在培训环境或者桌面帮助环境中大有潜力。另外，管理员还可以查看工作站的特定信息，以帮助故障诊断和修理。

    不管用户从什么地方进入系统，都存在一个虚拟的用户定义的台式系统供用户使用。由于一个工作站上的窗口位置、打开的应用程序以及其他的桌面特性均可被保存，因此用户可以移到另外一台工作站上重新开始他的工作。例如，用户可以在办公室里为一个会议建立一个描述，然后他走到会议室，在另外一台计算机上重新获得原来那台计算机上的桌面环境。

    远程软件分发是Hermes最重要的功能之一。网络管理员可以生成安装“作业”以更新操作系统、应用程序、实用工具以及驱动程序，另外还包括连接工作站和服务器的外壳（shell）程序或请求器（requestor）程序。可以建立一个更新软件包，以便在特定的工作站或服务器上采取一组特定的安装或更新动作。可以根据工作站的硬件特性、软件版本号和当前的状态信息来采取相应的动作。例如，对于拥有特定驱动程序版本号的所有工作站，可以把驱动程序更新成为新版本的驱动程序，另外，这种更新也可以基于工作站上的显视卡类型。在另一个例子中，一个象Windows一样的图形用户接口可以被安装到所有的超过4MBRAM的工作站上。

    Hermes可以阅读由台式系统管理任务组（DMTF）在台式系统管理接口（DMI）中定义的管理信息格式文件（MIFFs）。MIFF是一个包含工作站信息的文本文件，这些信息包括工作站的可用内存、基本输入输出系统（BIOS）类型、操作系统版本号、应用程序类型和版本号、可使用的驱动程序以及其他信息。当工作站第一次开机或者是用户第一次登录时，就可以获得这些信息。DMI为MIFFs提供了一个标准接口。相应地，供应商也在他们的产品中提供了MIFF兼容能力。Hermes以及其他的网络管理程序是通过轮询网络上的站点来获得MIFFs中的信息的。然后，这些信息就用来决定是需要安装软件或者是更新软件，其根据来自软件或硬件的版本号或是由网络管理员定义的其它信息。

    迄今为止，Hermes是针对Microsoft的局域网环境和NetWare环境的。由于它的软件分发功能，Hermes更适于安装Microsoft自己的应用程序。自从产品以同样的方式生产出来，并且第三方供应商又同Microsoft合作后，上述的一些不兼容问题正逐渐被解决。IBM正在使它的NetView管理系统靠近Windows NT，HP也正使其Open View管理系统接近Windows NT。而Microsoft通过在Hermes中增加把信息发往上述两个平台的功能，增强了Hermes的功能。

    相关条目：Electronic Software Distributionand Licensing电子软件分发和许可；Management Standards and Tools管理标准与工具。


  • 异构网络环境 Heterogeneous Network Environments

    Heterogeneous Network Environments 异构网络环境 异构网络环境是由不同制造商生产的计算机和系统组成的，这些计算机系统运行不同的操作系统和通信协议，想统一其计算机资源的机构通常会面临集成异种机系统的任务。一般地，每一个部门或分部已经根据操作系统、局域网拓扑结构、通信协议、应用程序、电子函件系统以及其它因素规定了自己的网络需要。

    企业网的目标就是使这些分散的资源可以进行互连和互操作，以便网络用户可以和其他用户一起共享文件和电子函件，或者访问企业的数据资源。此外，可交互操作环境是使用群件和工作流软件应用程序的基础，它可使机构中所有用户都能一起或以组的形式访问和分享这些应用程序。

    开发企业级系统的目标之一就是减少使用的协议数目，能减一个是一个，想只用一两个协议是不现实的，除非开发出可被全球广泛接受的强健的局域或广域通信协议。TCP／IP协议被广泛地采纳和使用，被看作是广域链路互连的可靠选择，但即使是它，也还有改进的余地。

    目前，需要使用象路由器一样的多协议部件，以使在同一个网络上运行不同的通信协议。例如，NetWare和Windows NT服务器可以运行两个或更多的协议栈，并能处理或转发一系列不同类型的协议。如使用TCP／IP协议栈和NetWare网络文件系统（NFS）的NetWare服务器，可以向UNIX工作站客户机提供文件服务，这些UNIX客户机能在NetWare服务器上读写文件。与此同时，运行IPX／SPX的客户机自然也可访问运行IPX／SPX的NetWare服务器。

    在更高的应用级别中，“中间件（middleware）”产品能隐藏应用程序间的差异并允许信息交换、消息传递以及其他的一些跨平台活动。

    联合异种机系统的另一个目标是允许用户访问“后台”数据库和大型计算机，原来由于协议和平台不同，用户是不可能访问这些系统的。当访问数据时，或者是数据的格式不能被正确地解释时，用户的应用程序会给用户带来一些麻烦。许多供应商正试图解决这些问题，例如客户机／服务器计算产品供应商正在简化用户的前台应用程序和后台数据库之间的接口。

    Microsoft′s Open Database Connectivity（开放数据库连接）是一个Windows应用程序和后台数据库之间的接口标准。

    IBM＇s Distributed Relation Database Access（分布式关系数据库访问）是一个在遵循SQL标准的IBM平台之间访问数据库信息的标准。

    Oracle Glue为支持动态数据交换（DDE）的应用程序（如Microsoft Excel和Visual Basic等）提供了一种途径，以链接Oracle和IBM DB2服务器。

    现在的发展趋势是，建立一个隐藏平台潜在差异的综合开发环境。开放式软件基金会（OSF）的分布式计算环境（DCE）是一个使用公用的工业工具、标准、协议，为共同工作的不同平台建立应用程序的完整环境。Sun微系统公司的开放网络计算（ONC）和Apple计算机公司的开放协作环境（AOCE）都是类似的环境。

    相关条目：Distributed Computing 分布式计算；Distributed Database 分布式数据库；Distributed File Systems分布式文件系统；Enterprise Network 企业网。 ● Hierarchical Storage Management（HSM）Systems分层存储管理（HSM）系统

    HSM系统自动地把很少使用的文件或指定的文件从主磁盘上移到辅助的光盘或磁带上。这种过程叫迁移（migration）。由于辅助存储设备仍然和主系统相连，因此如果用户查看已经被迁移的原来信息和文件时，数据还可以反迁移到主磁盘上。HSM系统能向管理者提供文件地址报告、归档日期以及其他用来有效管理文件系统的信息。HSM系统是为下述用途设计的：

    当千兆位的信息必须随时可供用户使用、并且把这些信息都存储在磁盘上是不现实的时候，可以考虑采用HSM系统。

    HSM系统可以作为备份和归档系统操作，它一般不需人的干预（除非为安全起见，要把磁盘和磁带移开）。注意，那些未被迁移的文件仍然需要定期备份。

    文档影象系统需要光盘HSM系统。一个典型的影象文件（例如发票、订单、合同等等）以及与它有关的信息可能需要几兆字节的磁盘空间。光盘存储系统可以满足这种需求。

    当磁盘上的大部分文件很少被访问时，HSM系统可以帮助减少对大量磁盘存储器的需要；把这些文件放在替换的存储设备上，而把的磁盘空间供重要的文件使用，这种思想是很有意义的。实际上，一些供应商已经使用光盘作为其主要的数据仓库。在短时间内的非活动文件被迁移，可以留下更多的主磁盘空间供重要文件使用。对于一个使用多媒体的系统来说，这是一种非常有用的策略。另一方面，由于磁盘价格的降低，一些专家认为使用大量的磁盘是一个更实际的方法。

    图H－1描述了通常的HSM系统的配置。文件如果在一定的时间间隔内未被使用，就会从服务器的磁盘联机存储设备迁移到光盘上。另外，一些文件还可以标识成为立即迁移或者是在一个特定的时间迁移。你也可以用同样的方法迁回这些文件。例如，如果要求一个文件在月末报告，你就可以在报告的前一天晚上把文件迁回磁盘。从磁带上迁回大概需要2到3分钟，从光盘上迁回需要8到10秒。

    一段时间以后，为了提供额外的数据安全性和数据冗余性，归档文件可以从光盘上拷贝或迁移到磁带上。被移到磁带上的文件可以从可重写的光盘上删除以释放其占用的空间。对那些将报废的光介质来说，这个处理过程是必需的，因为一些介质的可擦除和可重写次数是有限制的。

    在NetWare的HSM系统中，信息是以卷宗的形式迁移的。任何一个卷宗都可被记为需迁移的，一般是根据文件最近一次的访问时间。当卷宗的空间占用超过一定的百分比时，系统就会启动文件迁移操作。一般而言，存放最久的文件会首当其冲地被迁移。

    相关条目：Archiving 归档；Backup and Data Archiving备份和数据归档；High Capacity Storage System，Novell NetWare Novell NetWare的大容量存储系统；Jukebox Optical Storage Devices自动换盘光盘存储设备；Optical Libraries 光盘存储库。


  • 高性能文件系统 High Performance File System

    High Performance File System（HPFS） 高性能文件系统（HPFS） HPFS是Microsoft的LAN Manager中的文件系统，同时也是IBM的LAN Server和OS／2产品。在OS／2中，它就是HPFS，但是在LAN Manager和LAN Server产品中，它是HPFS386，这是HPFS的改进版本。

    HPFS提供了DOS文件系统中的文件分配表（FAT）所没有的长文件名和性能增强特性。另外，HPSF还能访问较大的硬盘驱动器，提供更多的组织特性并改善了文件系统的安全特性。在下面，我们看一下其他的特性：

    FAT系统是从磁盘操作系统（DOS）中保留下来的，但是增加了根据文件名对目录自动排序的功能。

    按簇分配被简单的按512个字节的扇区分配所代替，这有助于减少被文件加锁的没有使用的磁盘空间。

    目录项保持诸如修改、建立和访问日期与时间等信息。

    可以在一片连续的空间内存储最大为16MB的文件。

    HPSF包括热修复特性，它可以把数据从坏扇区处移到另外的扇区上。

    HPFS具有格式化磁盘、读、写、删除和其他一些通常的文件维护功能，文件被存放到一串链接在一起的磁盘块中。

    一个首节点（fnode）包含一个指向文件首块数据的指针。全长512个字节的首节点包含了文件属性、大小和访问控制信息。首节点的位置紧靠文件在磁盘上的物理位置，从而消除了DOS文件系统中磁头的频繁移动。HPFS文件系统是以改进树的形式组织的，以这种方式组织文件信息可以非常容易地确定文件的位置。当查寻文件时，HPFS只需沿着树查找即可。树的每一条分支指向另一个索引节点，直至找到首节点。

    HPFS386增加了对HPFS文件系统的32位访问，另外还增加了容错和安全性功能。HPFS386可以在处理器的较高特权级别上运行，这样就在普通的HPFS文件系统上改善了文件系统的稳定性和性能。

    相关条目：File Systemsin the Network Environment网络环境中的文件系统；LAN Manager，Microsoft Microsoft的LAN Manager；LAN Server 局域网服务器系统；OS／2OS／2操作系统；Windows for Workgroups，Microsoft Microsoft的Windows for Workgroups；Windows NT，Microsoft Microsoft的Windows NT。


  • 高性能并行接口 High Performance Parallel Interface

    High Performance Parallel Interface（HIPPI） 高性能并行接口（HIPPI） HIPPI是一个美国国家标准协会（ANSI）标准，它类似但不兼容于连接Cray巨型机和图形工作站的HSXI／O总线。它是由Los Alamos国家实验室（LANL）研制出来的，其数据传输率为800Mbps或1600Mbps。该接口是点对点的，这意味着它可以在两个设备之间建立连接。HIPPI是单工操作的，也就是说它只能沿着一个方向传输数据；但是，两条单工通道可以组成一条双工通道，该推荐标准的设计是为了允许在HIPPI上运行电气电子工程师协会（IEEE）的802．2协议，并使用该接口连接外围设备或在处理器之间、巨型机之间建立连接。

    该接口规范要求一条50根铜质双绞线组成的电缆。数据在其中的32根双绞线上传输，每根双绞线的速率达到25Mbps，因此整个吞吐量达到800Mbps。接口支持32位的总线操作，也可以用双电缆来实现64位的总线操作（吞吐量达到1600Mbps）。铜缆的实际传输距离被限制在25米（82．5英尺）以内，但是如果使用光纤作为传输介质时，可以延长到2公里（1．2英里）。

    HIPPI包含建立连接所需的请求线和连接线以及确保数据被正确传输的奇偶线。传输序列是由突发数据组成的，突发数据形成64KB到4．3GB的变长数据报。数据被放到帧缓冲区中，并且当缓冲区中的数据被处理时，可以继续向缓冲区填充数据。在推荐的HIPPI标准中包括一个8到32端口的开关，在连接已经建立的环境中，这种交换开关可以用来建立一条连接两个不同端点的电路。数据以极高的速度传送，传送后连接被解除。HIPPI适用于到高性能外围设备和巨型机的直接连接，但是它不适合作为局域网（LAN）的连接。

    可以用光纤通道取代HIPPI，从而获得更长的传输距离和更快的传输速度（最快为800Mbps）。由于可以在HIPPI和光纤通道之间进行转换，因此它们可以工作于同一个环境之中。

    相关条目：Fiber Channel光纤通道。


  • IBM 的高性能路由选择 High Performance Routing（HPR），IBM

    High Performance Routing（HPR），IBMIBM 的高性能路由选择（HPR） HPR是一个由IBM制订的网间互连协议，它是高级对等联网（APPN）协议的升级版。最初，HPR叫做APPN+，但现在正式把它称为APPNHPR或简称为HPR。IBM设计这个协议作为对传输控制协议／因特网协议（TCP／IP）的替代。HPR通过绕过故障结点进行路由选择以及避免由网络节点处理数据分组辅助操作，改善了网络的性能。IBM打算在1994年通过它的6611路由器来推广HPR协议，并且将在1995年提供对异步传输模式（ATM）的支持。

    相关条目：IBMIBM公司；IBM Networking Blueprint IBM联网方案；Routing Protocol 路由选择协议；Systems Network Architecture，IBM IBM的系统网络体系结构（SNA）。


  • 高位速率数字用户专用线 High－bit－rate Digital Subscriber Line

    High－bit－rate Digital Subscriber Line（HDSL）高位速率数字用户专用线（HDSL） HDSL允许在现有的、基于铜缆的、提供电话服务的线路上传输数据，传输速率在784Kbps和T1速率（1．544Mbps）之间。服务是全双工的，传输介质是两对双绞线，不需要信号中继器，减少了安装时间。

    非对称数字用户专线（ADSL）是一个与HDSL有关的产品，它的传输介质是一对双绞线，在一个方向上提供1．544Mbps的线路，而在另一个方向上提供较低速率（一般为16Kbps）的数据信道。ADSL是为使用现有的铜质电话线向家庭提供交互式视频服务而设计的。HDSL能提供同样的服务并提供全双工线路。借助ADSL和HDSL，电话公司可以开展同本地电缆公司（提供视频服务及对特殊多媒体文件服务器的访问）的竞争。另外，电话公司仍需设计出保存数字信息库的文件服务器，以及避免服务竞争的特殊体系结构和访问方法。

    ADSL是链接到电话公司正在修建的光纤网的高速链路，尽管一些专家认为，HDSL和ADSL会威胁全光缆布线（光缆具有长远的好处并且提供更高的数据传输率）。另一方面，其他专家认为，ADSL和HDSL是光缆的有益补充，因为ADSL和HDSL会促进更多的光纤需要。另外一个编码方案（超高位速率数字用户专用环路VHDSL）可以在两对双绞线上提供3Mbps到6Mbps的服务。

    相关条目：Asymmetrical Digital Subscriber Line 非对称数字用户专线；Carrier Services 电信服务；Channel信道，通道；Circuit－Switching Services 电路交换服务；Digital Circuits and Services 数字电路和服务；Local Loops 本地环路；Telecommunication远程通信，电信。


  • 高级数据链路控制（规程） High－Level Data Link Control

    High－Level Data Link Control（HDLC） 高级数据链路控制（规程 ）（HDLC） HDLC是一个在同步网上传输数据、面向位的数据链路层协议，它是由国际标准化组织（ISO）制订的。HDLC是IBM的同步数据链路控制规程（SDLC）的一个超集。SDLC是由BISYNC通信协议发展成功的，起初是通过IBM的系统网络结构（SNA）产品推出。HDLC的另外一个名字叫高级数据通信控制规程（ADCCP），这个名字是由美国国家标准协会（ANSI）命名的，但是HDLC却更为广大用户接受。由于供应商的不同，SDLC和HDLC之间存在不兼容性。

    HDLC是面向位的，这意味着数据是一位一位地监控的，传输的数据以二进制数据组成，不存在任何特殊的控制代码，但帧中的信息包含了控制和响应命令。HDLC支持全双工传输，在同一时刻，数据在两个方向上传输，导致了较高的吞吐率。HDLC适合于点对点和多点（多路播送或一对多）连接。HDLC的子集被用来向X．25、ISDN和帧中继网提供信令和控制数据链路。

    当建立一个HDLC会话时，一个称为主站（primary station）的站点就用来管理数据的流动。其他的站点就称为从站（secondary station），主站发出命令，从站作出响应。存在三种可能的连接方法，如图H－4所示。上面的两种连接既支持两个系统之间的点对点（point－to－point）连接，也支持一个主站和两个或多个从站之间的多点（multipoint）连接。

    通常模式是非平衡的，因为从站仅在主站许可的情况下，才能传输数据。

    异步模式是非平衡的，但是从站可以在自己一方启动一次传输。

    异步平衡模式是为在一条双工线路上实现两台计算机之间的点对点连接而设计的。每个站点能在它自己的线路上发送命令和响应，并且在双工线路上接收命令和响应。这种模式被用来将站点连接到X．25分组交换网。

    HDLC帧为通信系统之间发送数据和命令与响应消息定义了结构。帧结构如图H－5所示，下面我们将讨论一下帧中的各字段含义。

    标志字段包含01111110位序列，它指明了HDLC帧的开始和结束。如果帧中数据的任何一部分有多于5个1的位序列，这时就通过零位插入（zero－bit insertion）技术在这个序列中插入一个零，以确保数据不会被当作标志。

    地址字段一般包含从站的地址。通常是8位，但有可能因为多点连接（包括许多不同的地址）而扩展地址字段。在这个字段中还可以插入广播地址，从而可以把消息发往多点连接上的所有站点。

    控制字段指明帧中的信息是数据、命令还是响应。主站发送命令而从站发送响应。控制信息可以是帧应答、帧重传请求、传输挂起请求和其他一些命令以及响应。

    通讯会话由主站和从站之间的连接建立开始。主站向一个或多个站点传送一幅特别的帧来启动建立过程。从站以在会话期间用作错误和流控的信息作为响应。当一切就绪时，数据传输就开始了。当数据传输终止时，主站就会发送一个帧来解除会话连接。

    正如上面提到的那样，HDLC是X．25分组交换网的数据链路层控制的基础。但是CCITT又为X．25另外定义一个链路访问过程平衡（LAPB）协议，它是HDLC的子集。LAPB是为点对点的连接设计的，所以不必用地址字段来标识从站。它为异步平衡模式会话提供了帧结构、错误和流控机制。HDLC的另外一个子集是链路访问过程D信道（LAP－D）协议，该协议与综合业务数字网（ISDN）相联。D信道是信令信道，用来控制数据流通过两个B信道。可以把B信道看作为两条独立的电话线，而把D信道作为建立呼叫的线路。

    相关条目：Link Access Procedure 链路访问过程；Synchronous Communications 同步通信；Synchronous Data Link Control同步数据链路控制（规程）。


  • High－Speed Networking 高速联网 高速网包括传输速度高于在1990年前占主导地位的传统传输速度的LAN和WAN。高速网现在变得更普通并且更经济；下面简要地描述一下高速网。

    同步以太网（Isochronous Ethernet）它类似于共享介质以太网，但提供了一些支持时间敏感通信（如视频）的电路。在双绞线上的传输速率达到16Mbps。在1994年底可望实现标准化。

    光纤分布式数据接口（FDDI）这是一个主要运行在光缆上的共享介质网，它也可以运行在铜缆上，不过传输距离有限。FDDI支持数据、声音和多媒体。FDDI－Ⅱ是FDDI的一个新版本，它支持用来传输多媒体信息的专用电路。FDDI Follow On LAN（FFOL）最终会代替FDDI，FFOL的数据传输率达到2．4Gbps。

    光纤通道（Fible Channel） 这是一个交换式网络，它是为计算机和外围设备之间的通道连接设计的。

    在同轴电缆或双绞线上的数据传输率达到133Mbps。

    交换式多兆位数据服务（SMDS）这是一个由本地交换电信局提供的城域交换式数据服务，SMDS的带宽范围在T1（1．544Mbps）和T3（44．7Mbps）之间。使用SMDS的用户是那些想在城域范围内获得类似LAN服务的客户。

    帧中继（Frame Relay） 这是一个由本地电信局提供的城域和广域分组交换技术，其数据传输率为T－1（1．544Mbps）或更高。

    异步传输模式（ATM） 是一个运行于铜缆或光缆上的交换网，支持局域或广域环境中的数据、声音和多媒体信息的传输。

    相关条目：Asynchronous Transfer Mode 异步传输模式；Ethernet 100VG－AnyLAN（Voice Grade）100VG－AnyLAN（声级）以太网；Fast Ethernet 快速以太网；Fiber Distributed Data Interface光纤分布式数据接口；Fiber Channel光纤通道；Frame Relay帧中继。


  • 高速串行接口 High－Speed Serial Interface

    High－Speed Serial Interface（HSSI） 高速串行接口（HSSI） HSSI是一个由Cisco System 和T3plus Networking公司共同推出的串行接口标准。它的最高数据传输率为52Mbps，最远的传输距离为15米（50英尺）。它类似于通常连接计算机和调制解调器的RS－232和V．35接口，但是传输速度更高。


  • 私人目录 Home Directory

    Home Directory 私人目录 Home目录是为每一个加到网上的用户帐户建立的。它为用户提供了一个建立子目录、存放文件以及安装个人应用程序的地方。Home目录是任选的，但是它提供了一个初始登录“地点”，这对无盘工作站的用户是必要的。管理者允许用户把文件存放在共享公用目录中，但显然在这个目录中不能存放私人文件或者是对其他用户保密的文件。

    一些管理员把用户Home目录的全部目录和文件权限都赋给了用户，拥有这些权限的用户可以建立新的目录，可以把这些目录的权限赋给其他的用户。通过这种方法，用户可以控制目录的访问级别，并且决定网上哪些用户能访问目录中的文件。管理员也可以阻止赋给用户生成目录结构的权力和为它们定义安全性。但是，大多数网络操作系统有办法限制磁盘空间的使用，并且超级用户仍然能超越用户加在个人目录上的安全性措施。

    如果你决定建立一个用户目录，首先就要建立一个称为HOME或USERS的目录，然后在这个目录下为每一个用户建立一个子目录。当你新增一个用户时，网络操作系统（如NetWare和Windows NT）会有选择地建立用户目录。在一个有许多用户的环境中，可能有必要为用户目录专设一个服务器。

    相关条目：Account，User Network 用户网络的帐户；Groups 组；Usersand Groups 用户和（小）组。


  • 同构网络环境 Homogeneous Network Environments

    Homogeneous Network Environments 同构网络环境 一般地，同构网络环境中的网络部件是由同一个供应商供应的或者是兼容设备，它们运行在同一个操作系统或者是网络操作系统下。直到80年代中期，IBM和DEC还能宣称许多公司仅使用它们的产品。但是随着个人计算机的普及以及局域网的增加，桌面上就开始流行各种不同类型的系统。现在，大多数管理者不再使用专有系统了。还具有同构网络的公司已不多见。这是由于机构互连部门和工作组网非常普遍。请与“异构网络环境”比较。

    相关条目：Heterogeneous Network Environment 异构网络环境。


  • 跳跃（计）数，过路数，中继数 Hop

    Hop 跳跃（计）数，过路数，中继数 一个过路（hop）表示数据分组在一个由互联网段或子网组成的网中通过一个路由器的传输。在许多网中，使用许多个路由器来连结不同的段，这样形成了许多数据分组能到达目的地的路径。度量这种路径的一种方法是过路数（hop count），或者是数据分组到达目的地需通过的路由器数目。例如，一条只有三个hop的路径显然比拥有四个hop的路径更有效。路由器根据这个原则来决定把分组发往哪一个端口。但是当分组没有高优先级，且较长的路径便宜但速度不高时，网络管理员可能会采用较长的路径来传输分组。

    数据分组自身带有标识信息、源和目的地址，以及能表明分组应该采取的路由类型的优先级信息。在距离向量算法（DVA）中，路由选择是基于到达目的地的最少hop数。也可把这种方法称为Bellman-Ford算法，它可用于计算路由。

    路由选择信息协议（RIP）是首批使用DVA的路由选择协议之一。RIP规定hop数最多为16，如果通过的路径多于16个hop，RIP将丢弃分组。每隔30秒路由器之间就互相传递地址表和重新计算路径。这不仅会给网络增加通信负担，而且需要许多计算，可能导致路由器之间的不同步。远地路由器如果没有收到某些路由表信息，它们因有不同的路由选择表而终止自己的工作。由于这些原因，目前使用了更加有效的链路状态路由选择方法，然而，管理员仍然能用hop度量方法来进行路径选择。

    相关条目：Distance－Vector Algorithm Routing Protocol 距离－向量算法路由选择协议；Routing Information Protocols路由选择信息协议；Routing Protocols路由选择协议。


  • 水平布线系统 Horizontal Wiring System

    Horizontal Wiring System 水平布线系统 在结构化布线系统里，水平布线是指在一幢大楼的某一层，把电缆从电信配线室铺设到工作站、打印机以及其他网络设备，如图H6所示。相对地，垂直布线是指把电缆从每层的配线室铺设到大楼的地下室或第一层的主设备房。

    通常地，垂直布线系统被认为是的主干道，它可以由光缆组成，这样就能处理主干道上日益增长的通信负载。当使用结构化布线时，水平布线通常是铜质双绞线，尽管也可以用光缆连接数据吞吐量很大的台式机。在水平布线中铜质双绞线有多种等级，这往往取决于局域网的速度。新的100MbpsLAN可能需要3类到5类的数据级电缆，有关这方面的内容请参见“Cabling”条目。

    相关条目：Cabling（电缆）布线；EIA／TIA568 Commercial Building Wiring Standard EIA／TIA568商用建筑布线标准；Structured Wiring 结构化布线。


  • 主机 Host

    Host 主机 主计算机通常在集中式计算机模式中被定义为大型分时计算机系统，在这种模式中，多个终端与之通信，并且依靠它进行处理。与此相比，在客户机／服务器模式中，用户的计算机执行自己的一些处理，并访问服务器以获得文件管理、安全性以及打印机管理等服务。

    IBM环境

    在IBM环境中，主机系统是指称为“主机处理器（host processor）”的大型机，例如，IBM3090型，IBM4381型或IBM9370型。这种大型机通常运行MVS（多重虚拟存储）操作系统，并以扩展体系结构（XA）或企业系统体系结构（ESA）的方式运行。MVS是IBM系统应用体系结构（SAA）的一部分。

    图H－7显示了连到IBM主机的不同设备。众多的终端或用作终端运行的智能计算机与簇控制器相连，终端不会和主机直接相连。簇控制器把与之相连的多个终端上的数据流多路复用到一条连至主机的通道上。打印机也可以与簇控制器相连。通信控制器是另外一个直接连至主机的设备。通信控制器通过一条远程通信链路与远程簇控制器相连，远程簇控制器多路复用多个当地设备上的数据。请参见“IBM的簇控制器” 、“IBM 大型机环境”、“信息仓库”以及“IBM的系统网络体系结构（SNA）”条目

    ISO术语

    在用一系列路由器连接多个局域网的网络环境中，通常把端系统（end system－ES）当作主机。例如，如果会计部门用一个路由器与销售部门相连，就可以把每个部门中的工作站叫做主机或端系统，而把路由器称为中间系统（Intermediate system-IS）。在一个端系统和另一个端系统之间进行通信，可能需要经过多个中间系统。请参见“OSI路由选择”条目。


  • Novell NetWare的热修复 Hot Fix，Novell NetWare

    Hot Fix，Novell NetWare Novell NetWare的热修复 热修复是Novell NetWare的一个功能，它在硬盘存储系统上完成坏块重定向的功能。当系统运行时，热修复会探测和纠正磁盘错误。坏扇区的数据被移到磁盘上的其他地方，并且将坏扇区标识为不可用。磁盘上有一块专为坏块而保留的特殊区域，这块区域称为热修复重定向区。这块区域不供其它类型的存储使用，因此一片确保的磁盘空间总是可用于重定的坏块的数据”

    管理员需要监控已经被重定向的坏块数目。如果重定向块数增加，就预示着驱动器可能有故障或已老化。因此有必要扩大重定向区，或者是更换磁盘。

    相关条目：Disks，Partitions，and Volumes Under NetWare Netware的磁盘、分区以及（文件）卷。


  • HTML 超文本标记语言

    超文本标记语言。是一种可以标记超链接、不同标题风格、粗体、斜体和插入图片的WWW万维网页面生成语言，你所看到的本页内容就是用HTML语言编写成的。


  • HTML 超文本链接标示语言

    HTML是Hyper Text Markup Language的缩写，直译为超文本链接标示语言。它是一套用来做标记的标准，是互联网网站上所用文件的一种标准编程语言。我们目前所看到的绝大部分网页就是用HTML语言编写而成。


  • HTTP 超文本传输协议

    HyperText Transfer Protocol。超文本传输协议。该协议主要用于从WWW服务器传输超文本到本地浏览器，这就是你为什么在浏览器中你看到的网页地址都是以http://开头的原因。


  • Hub管理接口 Hub Management Interface

    Hub Management Interface（HMI） Hub管理接口（HMI） Novell的Hub管理接口标准化了安装在服务器上的Hub适配器实现和管理的方法，一个Hub适配器是一块插在设置作为服务器的计算机系统扩展槽中的卡。Hub适配器提供了一个插口和一根章鱼（octopus）型的电缆，这根电缆有8到12个以太网或令牌环网端口。可以在同一台服务器上安装几个Hub适配器，并且这些适配器可以互相连接。

    HMI由五个NetWare开放数据链路接口（ODI）的扩展组成，ODI能使hub设备供应商编写收集Hub信息的驱动程序。HMI建于Novell提出的Hub管理体系结构（HMA）周围。Novell还提供HubCon，这是一个配置Hub和查看Hub统计数据的管理工具。Cabletron、SynOptics、Chipcom以及其他主要的供应商都支持该接口。HubCon有助于管理者配置Hub并收集有关Hub性能的信息。HubCon能运行在服务器上或从远程工作站上运行。

    相关条目：Hubs Hub，集线器，集中器。


  • HUB 集线器

    就象车轮的轴心一样，将多台计算机或者多个子网络连接在一起的中央设备，应用在星型网络中。静态集线器只是简单的转发消息；将源数据包转发到目的网段中。智能集线器除了能转发消息外，还有中继器的功能，将数据流加强并且进行错误修复，达到增大传输距离的功能。


 Hub，集线器，集中器 Hubs

Hubs Hub，集线器，集中器 Hub的类型很多，仅这个主题就可写满一本书。简单来说，Hub是来自工作站连线的集中器。Hub分无源Hub和有源Hub。

无源（Passive）Hub它是一个小盒子，盒子中有几个端口供连接星形拓扑中的计算机站点使用。无源Hub也可能是一个布线板或插孔块。无源Hub的一个重要特性是没有信号放大。无源Hub仅仅是一个不需要电气连接的接线盒子。

有源（Active）Hub有源Hub通常有比无源Hub有更多的端口，并且它实际上再生从一个设备到另一个设备的信号，如图H8所示。有源Hub需要电气连接。有源Hub的使用类似于中继器，它能延伸连至工作站的电缆长度。

简单的有源Hub的任务只有一个——从一个站点接收一个信号并准确地传输到另一个站点，而冲突检测由各个工作站上的网卡完成。

一般地，Hub之间互相连接，从而组成如图H－9左部所示的层次结构，右部是其物理配置。这是一种结构化布线系统（structured wiring system）配置，在EIA／TIA568商用建筑布线标准中有详细的讨论。在每层楼的水平布线中，通常用铜双绞线作为传输介质，而在垂直方向上的层与层之间用光缆来作传输介质，尽管这些电缆类型没有严格的定义。数据级电缆目前能提供高于100Mbps的传输速率，因此可作为主干道电缆使用。结构化布线易于安装、管理和扩展，它也支持新的高速网以及未来的网络技术，例如异步传输模式（ATM）。Hub使结构化布线成为可能并带来下列好处：

当公司改组时，用建立Hub周围的结构化布线系统会使网络的改变易于实现。

使用结构化布线和Hub可以逐步地扩充网络。

Hub能适应许多不同的网络，包括以太网，令牌环网，FDDI，以及诸如帧中继、SMDS、ATM等广域网连接。

Hub提供了集中管理和网络信息的自动收集。

Hub提供了容错功能，从而保证网络线路系统的正常工作。

使用铜双绞线的一个不利因素就是它的传输距离有限，而Hub可以从某种程度上解决这个问题，因为Hub是一种中继设备。例如，在以太10Base－T网中，一个工作站可以位于由最多4个Hub组成的菊链的末端。

Hub网络的典型拓扑结构是星形结构。然而在令牌环网中，信号是在网上的逻辑环路上传输的，而以太网中的信号则是以广播的方式送到各个站点。星形拓扑结构要求Hub和每个工作站之间都要用一根电缆连接，这样做自然有它的优点。连至工作站的电缆是分开的，所以电缆上的错误仅仅只影响一个工作站。管理员可在只连一根电缆的Hub运行诊断程序，从而确定数据流动或隔离故障。

Hub Evo1ution Hub的发展历程

原来的以太局域网是由横贯办公楼的纵横交错的电缆组成，并且以菊链的方式连接每一个工作站。当所有的工作站连接好时，你在电缆的每个末端插上一个终结器并启动网络。如果网络第一次启动就正常工作，那么你将是非常幸运的，因为松的连接器、外部干扰、接地环路、弯曲或挤压的电缆、连接由缆和T型连接头的简单错误都会导致网络崩溃。工作部门必须尽力确定错误发生的准确位置。测量到电缆故障点的距离还要使用特殊工具。针对以上问题人们就设计了Hub。

自从简单的中继式Hub出现以来，Hub已经经历了几代的发展。目前它们已经是结构化布线系统的主要部件——管理并监控整个网络的控制中心。借助于支持局域或广域连接的插入模块，Hub可以成为整个一层楼、一幢楼、校园区或全球的网络布线中心。这些布线Hub形成了整个网络的主干道。由于主干道被包含在一个盒子中，因此我们通常把Hub称为“紧缩主干（collapsed backbone）”设备。

随着星形配置的10Base－T的流行，Hub在台式机网络环境中越来越流行。图H－10展示了一个典型的八端口Hub。管理员过去通过增加一些Hub并用电缆把这些Hub和网上的Hub连接起来扩展他们的网。但为什么不做一个有扩展槽的盒子，然后在一个可以插入的扩展槽的扩展模板上放置10或12个RJ－45连接器呢？这个盒子会提供电源并降低某些部件的成本。

图H－11展示了一个典型的多槽Hub，图H－12显示了这个Hub的插入中继器模板。图上的设备是Chiocom（马塞诸州的Southborough）公司制造的六槽在线系统集线器和八口10Base-T插入模板。这个Hub使用了一种特殊的总线结构，可以使Hub支持三个以太网，四个FDDI或七个令牌环网。

布线Hub是许多种类的网络通信模板互连的平台，它们类似于一个计算机系统，包含一个电源和一条插入式扩展总线，但与计算机比较起来还有许多不同。例如，插入式扩展总线通常是高速、专有的。Wellfleet通信公司（位于华盛顿的Billerica）有一个对称多处理模板系统，它将一个处理器模板链连接到一个链路模板。这一对和其它类似的模板对连至四条处理网间通信的256Mbps总线。这个器件支持大部分LAN、WAN和FDDI接口。根据安装的模板数不同，性能可从100，000PPS（每秒传输的分组数目）到500，000PPS变化。

布线Hub是网络的集中连接和管理点。它们提供一些管理工具，允许你从工作站上实施控制，通常使用Windows的基于图形的应用程序展示整个网络的结构图，并且你可以放大显示单个网段察看统计或审计信息。管理控制台经不同频道信号传输（out－of－band）串行连接连至Hub，所以即使是网的其余部分发生了故障。你也能从一个远程地点管理Hub。

第一代Hub

对于构造以Hub为中心的星形布线的以太网已有多次尝试，但最后产业界将10BaseT以太网定为标准。使用双绞线的结构化布线系统开始得到发展。拥有八个或更多端口的简单中继器设备为众多的工作站提供了连接。在某些情况下可以用现存的双绞线来连接这些工作站。

第一代Hub是简单的中继器，它们仅仅支持一种传输介质。它们所支持的布线结构适合于大约20个用户组成的部门或工作组LAN。中继器的价格大约是每个端口100美元。通常它们不支持诸如简单网络管理协议（SNMP）之类的管理协议。

在现今的市场上，第一代Hub产品仍然在供应，这是因为仍然存在许多小型LAN。一个有益的开发是Hub适配器，它是一个能直接插入服务器扩展槽中的Hub。一根特殊的电缆连至适配器背面，为工作站们提供多端口连接。多个Hub适配器能安装在同一台服务器中，并且用十字连接电缆把它们桥接起来。

第二代Hub

第二代Hub叫做“聪明Hub”或是智能Hub，具有管理功能。在这些Hub中增加了支持多种介质类型和桥接这些介质的功能。第二代Hub还包括搜集Hub中有关模板以及每个端口的统计信息的功能。SNMP管理功能也开始出现在第二代Hub中。

第二代Hub的另外一个特性是带有支持不同介质（例如以太网，令牌环网和FDDI）的多总线底板。总线方案既可以是一种网络类型一条总线，也可以是支持所有网络类型的多通道总线。一般地，底板是由高性能的精简指令系统计算机（RISC）处理器管理的。

第二代hub另外一个特性是它能在一个单集线器内建立逻辑的LAN网段。这个特性允许位于远程管理控制台的管理者根据机构和性能上的原因把一个LAN分成多个更小的网段。

第三代Hub

第三代Hub是企业Hub，用来满足一个机构所有的布线和网间互连需要。它们具有智能特性、高速底板和高度模块化，支持一组包括广域连接和高级管理在内的插入模板。

这种设备具有极快的高速总线，能处理企业所有的通信。具有监控并报告整个网络状况的管理功能。可靠性也是一个非常重要的特性——有许多冗余功能以防止部件（例如电源、总线以及广域链路）故障。一些新兴的Hub使用了异步传输模式（ATM）的信元交换底板，这种底板以每种千兆位的速度工作。

特别地，第三代Hub具有一些支持使用数据级双绞线建成的结构化布线系统的特性。下面是其中的一部分：

支持多个以太网、令牌环网以及FDDI局域网的分段底板。

提供网间互连功能的高速主干道。

为每一个工作站把网络微分段成专用LAN的交换能力。

端节点到端节点的专用电路能支持容量或时间敏感的信息传送。

在重负载的情况下，内置于每个模板的分布式管理特性改善了性能。

Categorizing Hubs Hub分类

我们可以把Hub粗略地分成三类，这基本上是根据结构化布线配置（每层的工作站使用水平布线相连接，楼层之间使用垂直布线相连接）定义的。这三类是工作组Hub、中间Hub和企业Hub，将在下面作详细的讨论。每一类都在结构化布线系统里有一席之地。

工作组Hub

一个工作组Hub连接一组相邻的机器。例如，可能连接8台艺术部里的计算机。在同一层楼中，可能有几个不同的工作组。

工作组Hub的一个显著变化是Hub适配器，Hub适配器基本上是一个减少插入到服务器接口卡数目的集线器盒子。不过前提条件是服务器与工作组相邻而不是在中心管理区域。从Hub适配器上延伸出一根供多个工作站使用的插入端口的“章鱼”电缆，或者是用50针的远程通信连接器连接适配卡和配线室中的接插板。你可以在一台服务器中插入几个Hub适配器，并用布线带（wiring straps）把这些适配器连接起来，于是在这几块适配卡上的端口之间就建立了一个桥接器。Novell已经定义了用来管理Hub适配器的Hub管理系统体系结构（HMA）和一个称为HubCon的NetWare可加载模块（NLM）。

中间Hub

一般地，一个中间Hub会出现在每层楼中的配线室中。每一个工作组Hub都通过电缆与中间Hub相连。而每层楼的中间Hub就连至垂直主干电缆，垂直主干电缆通过楼层之间的管道与企业Hub相连。中间Hub也可以通过光纤链路直接与企业Hub相连。

中间Hub并不是必不可少的，但它们可能会形成将来企业Hub的基础。例如，一个中间Hub可以集中一层楼上所有工作站Hub的连接，然后，每层楼的中间Hub可使用图H－13所示的主干电缆链接起来，再后，中间Hub可以连入企业Hub。正如下面所讨论的那样，企业Hub能提供更好的通信控制和管理。

企业Hub

企业Hub是所有连至工作组Hub的端系统中心连接点。企业Hub或是形成了主干网自身，或是提供到一个主干网的连接。它们可以提供桥接、路由以及广域连接服务。还可以在企业Hub中置入先进的管理模板。

如前所述，你可以从工作组Hub开始，再用中间Hub连接工作组Hub。然后用主干网如FDDI连接所有的中间Hub，或者是安装企业Hub来完成这个功能。企业Hub比FDDI主干网提供更好的管理，支持更多的通信以及提供更好的集成方法。

企业Hub的设计必须满足整个机构对关键任务处理的需求，并且能适应新兴的技术如异步传输模式（ATM）。这里列出了部分特性。

在一个场点集成多个不同的网络部件。

由冗余、容错特性带来的高可靠性。

一个供部门或工作组Hub使用的中心连接点。

支持由多重处理超级服务器产生的吞吐量的高速连接（服务器模板装进Hub是可能的）

从管理控制台动态重配置网络的能力。

管理控制台上的端口交换能力。

改善管理并节约费用的高级管理特性，如错误检测和诊断，热拔插部件以及模块化扩展。

Wiring Hub Features布线Hub的特性

Hub的特性是由Hub的类型和供应商来决定的，下面主要讨论的是企业Hub的特性。企业Hub能把许多不同类型的网络集成到一个中心盒子，并提供桥接、路由选择和管理功能。中间Hub并不要求具有这类功能，一个支持一种类型网络的底板以及一个到自治主干网的连接也许已经足够了。同样地，工作组Hub也仅需要简单的中继器设备以提供到其他Hub或主干网的连接。

下面是图H14的讨论：

机箱和底板

机箱（chassis）是一个Hub部件外面的盒子。它的设计和布局决定了你能放入Hub的扩展模板和其他部件的数量。机箱为电源提供了连接点，因此你需要注意机箱是如何支持双电源连接的。

从概念上讲，Hub的底板类似于个人计算机上的母板，但设计上更为优良。底板为扩展模板提供了总线以及许多连接点，所以你必须确保底板上有足够的插槽供将来扩展模板使用，或者是今后能够扩展底板。一些Hub通过高速连接提供到另外机箱的底板扩展。

Hub上的总线配置不同于计算机底板上的总线配置，它要求多个通信通道，只有这样不同的插入（plugin）模板才能被链接。例如，两个以太网模板需要一个通信通道，而两个令牌环网模板又需要另外一个通信通道。通道设计是大多数Hub的主要差别。图H－15展示了几种不同的设计方法。

标准总线（Standard bus）标准总线是EISA或MCA总线，类似于在个人计算机上使用的总线。每个连至总线的模板必须使用一个中断才能获准访问总线。这种技术通常不适合企业网。

多总线（Multiple bus）底板上有几条总线，每条总线都是用于传输特定类型的数据流。一个典型的多总线Hub应包含以太网总线、令牌环网总线以及FDDI总线。每条总线上可以挂接多个模板，但这些模板必须属于同一种网络类型。

分段总线（Segmented bus）在这种设计中，总线被分成几段，并且用通用的连接器连结起来。模板插入到连接器中，并能与总线上的其他模板相连，从而形成逻辑LAN段。任一块模板上的任一个端口都能在管理控制台上工作的网络管理员控制下成为一个定制的LAN段的一部分，不过前提是假设这些端口是同一种LAN类型（以太网或令牌环网）。

多路复用总线（Multiplexed bus）用多路复用技术，可以把一条总线分成多条逻辑总线每条总线是多路复用流中的一个通道。另外，这种技术还具有分段总线的许多优点。

大多数Hub都包含一条管理总线，它能分别访问Hub中的所有模板，因为Hub不是主底板总线的一部分，所以总线上的数据通信不会干扰它的监控功能。因此如果没有独立的管理总线，在网络通信高峰期极需监控时，你就不能监控网络。

分段是Hub的一个功能。一个网段是一组站点，这些站点共享同一个网络号并在它们之间传递数据分组。网段之间的连接是用桥接器来实现的，段中的站点如果太多，会使通信受阻，因此最好把网络分成更多的段。每一个段中的用户应共享相同的资源，并且这些用户应属于同一部门或工作组。但是，底板上的通道数会限制你能配置的段数。一般地，大多数Hub具有三个以太网通道和两个令牌环网通道，这意味着你最多只能配置三个以太网段和两个令牌环网段。为了克服这个限制，一些供应商就提供了交换设备，它可以使你把一个通道进一步划分成多个段。而下面将要讲述的端口交换（Port－Switching）Hub是另外一种解决方法。但是，请注意，网段之间的桥接器会增加许多开销。

当Hub技术和结构化布线成为连接一个企业可接受的方案时，对高速底板的需要就显得越来越迫切，高性能的RISC处理器改善了底板的性能，并且提供了对更多的节点、集成化桥接、路由选择以及广域联网的处理支持。

端口交换特性

端口交换是Hub的一种相当新的特性，它提供了一种快速重新配置工作站连接的方法，例如当用户调换部门时。设想当一个公司重组或高度面向工作组时会发生什么事情呢？每一个用户都需要加入不同的部门或工作组，其工作站必须连至一个合适的网段，以便访问网段中的资源。特别地，工作组经常是短期建立的，管理员需要一种快速方法把一个工作组内所有的用户配置进一个段中，而不管他们物理位置如何，以便他们能容易地共享公用的LAN信息。当撤消一个工作组时，这些工作站又能重新配置进其它的段。

在老的模式中，用与工作站相连的Hub模板来确定LAN段，模板是硬件连线的，仅在相连端口之间中继信号。为了把一个用户移到一个新的LAN段，你必须在物理上把电缆从一个中继器模板移到另一个中继器模板。如果一个中继器模板有十个端口，但部门或工作组仅有五台工作站，就会有五个端口被闲置，而与此同时另外的模板却可能没有足够的端口供使用。

在新的模式中，模板连至高速多段底板，如图H－16所示。基本上每一个端口自身都有一条至底板的连接，而不是模板本身的硬件连线段。管理员在管理工作站通过选择组成段的端口来配置段。这些段是逻辑连接的，而不是物理连接的。注意图中分散的端口组成了不同的LAN段。很重要的一点就是共享底板能生成横跨多端口模板的段。

这种“虚拟LAN”功能支持拥有分散地点成员的临时工作组。在这种策略中，不会浪费Hub端口。每一个端口都连向底板，并可以被配置进任何一个LAN段。这种现行技术的一个限制是不能在同一个段中连接不同类型的网络，如令牌环网和以太网。连接不同类型的网络需要使用桥接器。

注意：不要混淆端口交换和交换式Hub这两个概念，交换式Hub将在稍后讨论。端口交换是一种把工作站配置进逻辑网段的管理功能，而交换式Hub有一系列端口，并且提供一种方法在任意两个端口之间建立专用连接。

你能建立的网段数是依Hub以及Hub底板的设计而定的，一些供应商仅仅在底板上支持几个段，而有些供应商可支持一百多个段。请注意，大量的小段会带来桥接问题。如果一个段中的用户想访问另一个段中的用户和资源，就必须桥接所有的段，所需大量桥接器最终影响系统以及预算。

对网间互连协议如IP来说，端口交换仍然是一个问题，这是因为为了进行通信，工作站使用了网络层中网络地址。如果一个工作站从一个逻辑段移到另一个逻辑段时，网络地址就必须用手工更新。

可靠性特性

对布线Hub的可靠性和容错提出了越来越多的需要，这是因为所有的布线、集线器单元、桥接器、路由器、管理部件乃至服务器都位于同一地点。对关键任务应用程序而言，一般都要使用冗余Hub来防止故障的发生。如果一个Hub发生故障时，另外一个Hub就立即接通顶替有故障的Hub保证网络的正常工作，这里列出了Hub的部分冗余特性：

电源冗余（Power redundancy）大多数Hub支持备份电源，它既可以分担主电源的负载，也可以顶替主电源（当主电源发生故障时）。

热拔插模板（Hot swap modules）这个特性可以使你在不关闭整个单元的情况下更换一个模板。

管理（Management）管理特性通常包括远程管理功能和对SNMP的支持。

易重构（Easy reconfiguration） 当工作站或用户在工作组之间调动时，应该能按照新的安排方便地重新配置工作站，这种功能在一些系统上可用软件实现。

一些Hub使用以太网或FDDI作为底板，而不采用专有方法。使用以太网和FDDI会有潜在的性能下降，这是因为当更多工作站使用总线时，会使总线的带宽恶化。专有总线系统用硬件和软件的方法改善系统的性能，例如使用RISC处理器。

安全特性

Hub能提供一个在以前的布线方法中实现不了的安全级，例如，端口交换特性能控制端口之间的通信链路，并能防止一个用户同另一个工作站相连或是实现一个网间连结。介质存取控制（MAC）子层地址提供了一种筛选功能，所采用的方法类似于桥接器筛选。

一些Hub还具有断开入侵者连接的管理功能。例如，一个入侵者用协议分析器获得了一个工作站的软件地址，然后使用这个地址来访问网络的许多部分，具有高级安全功能的Hub设备可以用位于工作站上的网络接口适配器上的硬件地址链接一个软件地址，然后仅为来自这个工作站的请求提供服务。

模板

模板是插入Hub底板的独立设备，它能为工作站提供连接、桥接、路由选择和管理功能。下面列出了一些最普通的模板类型。Hub供应商之间可进行互相协作，于是由一个制造商生产的特定模板就能插入到另一个制造商的Hub中。

冗余电源Hub模板提供热拔插功能，从而可替换故障部件。

以太网模板能支持同轴电缆、双绞线和光纤到使用10BaseT或其他网络拓扑结构的以太网工作站的连接。

令牌环网模板能支持12到24个端口和各种类型的屏蔽或非屏幕的双绞铜线和光缆

FDDI模板能支持企业主干网或高性能的工作站。

桥接和路由模板能用多种协议（如NovellSPX／IPX，AppleTalk，TCP／IP，DECnet等等）在Hub内建立网间互连。

SNA／SDLC转换模板允许在令牌环网中使用SNASDLC设备。

管理模板能有效地支持工业标准SNMP或新兴的标准如CMIP。

协议监控设备可作模板形式使用，如Cabletron公司的Novell LANtern协议分析器适合它的智能布线Hub。

Cabletron和Silicon Graphics Inc为称为分布式网络服务器模板（DNSM）的Cabletron MMAC智能布线Hub开发出了一个作为Hub使用的全功能Unix Indigo工作站。以太网、令牌环网和FDDI网上的用户均能访问这个计算机模板，这个模板运行Cabletron的SPECTRUM，Silicon Graphic的NetVisualyzer以及其他管理系统。DNSMIM能当作一个直接从Hub管理网络的管理工作站使用。

模板具有指示灯，能够让管理员一目了然地观察到每个端口的状态信息。例如，红灯指示端口故障。尽管指示灯可以指示问题的发生，但还得假设管理员定期进入设备间检查它们的状态。真正需要的是一种网上发生问题时可以立即警告管理员的网络管理工具。

管理特性

管理特性是很重要的。大多数高档Hub都有它自己的微处理器，能运行程序以跟踪数据分组和错误，并把这些信息保存到一个管理信息库（MIB）中。运行在网络管理员工作站上的管理程序会随时从MIB中收集信息，并把这些信息转换成管理员可读的格式。这些信息可帮助管理员跟踪网络运行态势、诊断与排错、指出拥塞问题并避免发生潜在的问题，当可能导致错误的各种阈值满足时，就发警报以警告管理员。例如，当网络通信超过某级限制时，就可以向管理员发警报，这时他就会采取纠正措施，如把LAN分段或者是把传输大量数据的用户移到专用网段上。

大多数供应商都支持简单网络管理协议（SNMP）。SNMP运行在传输控制协议／因特网协议（TCP／IP）上面，并且通过TCP／IP把从工作站MIB获得的信息传给管理计算机。如果阈值满足，SNMP通过TCP／IP向管理计算机发一个警告消息（警报）。另外的管理方案有国际标准化组织（ISO）的公用管理信息协议（CMIP）以及IBM NetView。

一般Hub是由图形软件应用程序管理的，它可以使管理员从单个管理工作站上控制每一台设备和每一个网络节点。管理软件通常是基于UNIX的，也有基于OS／2和Windows的。一个Hub中的管理功能也能提供下列服务：

自动断开与破坏网络的故障节点的连接。

为测试目的而提供一种隔离端口的方法。例如，一个节点可能向网上发送了过多的数据分组，为了诊断你能隔离这个节点。

根据时间或星期中的某天来建立和断开与工作站的连接。

一些Hub供应商推出了作为模板置入到Hub内的协议分析工具。

远程地点网络部件的非现场管理。

一旦你收集了信息，你就需要管理它们。管理软件能提供一些工具，如对数据排序和以表格、图表或图形方式显示有用的信息。例如，你能监视有关网络使用的情况以及哪里可能发生数据拥塞。图形用户接口可以使你突出显示一个特指的LAN网段，并且显示出这个部分的有关节点、桥接器和路由器信息。你还能增加或移动用户。管理软件还提供了一种方法来收集特定时间内的网络信息供分析使用，或查看历史信息与当前信息进行对比，这些信息能帮助你决定是否需要添置新的部件或扩充模板。

交换式Hub

交换式Hub是一个相当新的概念，它利用了星型布线拓朴结构和Hub设计的优点以减少网络段上的竞争，这是通过交换式技术来实现的，请注意不要与端口交换概念混淆。端口交换是一个管理功能，管理员使用管理程序可非常容易地把一个工作站从一个网段移到另一个网段。交换式技术是把LAN进行微分段使得一个网段上的工作站少到只有一台，这样就不会引起竞争。最初的交换式Hub是为部门使用而设计的，并构筑在它们自己的机箱里，最新的交换式设备则是能插入Hub的模板单元。下面让我们来进一步认识交换式Hub。如果你有一个20个用户的网，并且由于过量的通信导致网络瘫痪，你就可以把网络分为两段和桥接它们，这样每个网段上的通信负载就减少了一半。这要假定你将平常相互会话的用户放在同一网段里，这就减少了要求通过LAN桥接器的通信量。如果说通信量仍然是一个问题，你可以把LAN分成四个段或六个段如此等等。交换式Hub准确地执行这种分段功能。它有一系列端口，其中每一个端口是为连接工作组Hub或甚至单个工作站而设计的专用LAN段。交换式Hub通过内部交换矩阵来处理工作站之间的传送。交换处理发生在介质存取控制（MAC）子层。关键在于一个网段中的工作站越少，通信和竞争也就越少。如果一个网段上的一个工作站想与另一个网段上的工作站或服务器通信，交换设备就可作为一个桥接器并且在网段之间建立一条临时电路。但是这种交换式桥接器的功能却比普通的桥接器功能好，这是因为它在设备间建立直接电路消除了存储和转发延迟。大多数交换式Hub适用于以太网；如果单个工作站连至一个端口上，它就获得至交换式Hub的10Mbps的吞吐量以及与之通信的端口。由于没有其他工作站共享这个端口，因此就不存在竞争并且这个工作站可以获得全部的带宽。一些供应商正在研制令牌环网的交换式Hub。另外现已推出实现异步传输模式（ATM）的高速交换式Hub。交换式Hub思想是由Kalpana公司在它的EtherSwitch中首先提出来的。EtherSwitch技术现正被使用在其他供应商的产品之中。例如，HP公司在它的EtherTwist hub中集成了该技术，SynOptics通信公司也在它的Lattis Switch Series 5000 Hub包含该技术。

Future Develupments 未来发展

Hub设计正迈向交换式概念。主要的Hub供应商们如SynOptics、Cabletron和Ungermann－Base，都已宣布他们的产品能使用户实现以太网、令牌环网以及FDDI帧的交换，并有能力在未来升级到ATM信元中继。未来的趋势是将多协议支持、桥接、路由选择、广域联网、管理功能以及协议分析等集中到一个盒子中。插入到Hub中的所有部件产生的带宽，将需要由异步传输模式（ATM）提供的快速交换技术，从理论上来说，这种技术能达到每秒千兆位的交换速度。通过ATM交换，Hub上的任一个端口都有可能拥有一条至其他端口的专用电路。

主要的电信局已经在他们的长途网络中使用了ATM交换技术。在WAN链路上要求LAN到LAN连接的公司下一步就是安装ATM交换器，这种装置起初能作为本地环境的主干网工作并提供至远程LAN的高速链路，下一步是要在中间Hub中包含ATM，并最终在工作组Hub和台式机中包含ATM。至少主要的Hub供应商都有这样的计划。几乎所有的供应商都正在他们的企业Hub设备中实现了ATM交换技术，随着技术上的改进以及价格的下降，我们将会看到在不久的将来，ATM将成为主要的联网策略。相关条目 Bridging桥接；Cabling（电缆）布线；EIA／TIA 568 Commercial Building Wiring Standard EIA／TIA 568商用建筑布线标准；Fiber－Optic Cable光（纤电）缆；Matrix Switch交换 矩阵；Repeater 中继器；Routers路由器。
访问控制提供一种方法以控制用户对网络资源的访问，它包括登录口令方案的制定，登录时间和计算机的限定，以及对文件、打印机等资源的管理。访问控制表（ACLs）是用于描述用户访问权限的小型数据库。它通常隶属于文件系统目录，指明用户的访问权限，如可读、可写、可删除等。在面向对象的系统中，表示文件服务器和打印机等资源的对象包含访问控制表。根据访问控制表，每一个用户对网络上的文件和其它资源可以有不同的访问权限。

并根据访问控制表确定用户对网络资源的使用权限。


  • Novell NetWare的大容量存储系统 High Capacity Storage System（HCSS），Novell NetWare

    High Capacity Storage System（HCSS），Novell NetWare Novell NetWare的大容量存储系统 （HCSS） NetWare 4．x中的HCSS，提供了一种把文件从快速磁盘存储系统迁移到辅助存储系统的方法，如图H－2所示。一般地，辅助存储系统是一个大容量光盘系统，但也可以是磁带系统。用户仍然可以使用迁移到辅助存储系统上的文件，当用户访问这些文件时，系统可以把它们迁回到磁盘系统。除了在访问时有点延迟外，用户甚至不会意识到文件保存在辅助存储系统上。自动换盘设备可以自动地联结任何一个磁盘或磁带，因此可以供用户访问保存在辅助存储设备上的几千兆位的信息。

    那些最近很少访问或周期性访问的文件是迁移的主要对象。实际上，一些光盘供应商认为所有非定期访问的文件都应迁移到光盘系统上。他们把光盘系统作为自己的数据仓库（data warehouse），影象文档、历史纪录以及大型多媒体文件都需要光盘存储系统。当一个组织应用多媒体和影象文件对，他们会很快发现将需要光存储系统。

    通常，HCSS光存设备是指自动换盘光盘库（jukebox），它们对一组可重写光盘进行读和写操作，并且使用一种联结和解联指定光盘的自动换盘装置。一般自动换盘光盘库包括多至四个光驱和一个可以从机架上托起一个盘并把该盘夹在指定驱动器的设备。出于安全的原因，你可以取出并锁好光盘，或者把光盘移到另一台光存设备中。

    HCSS提供了一种归档的取代方案，文件可以拷贝到磁带或其它备份介质上。本质上，HCSS文件总是联机的，因此HCSS消除了从常规数据档案中检索文件的麻烦。例如，用户并不需要和档案管理员联系然后由他确定磁带（或其它）档案的位置，联结并恢复数据。那些要访问已迁移文件的用户可以通过查找熟悉的NetWare目录结构访问它们。虽然访问已迁移的文件需要多一点的时间，但是和从通常的档案设备中检索文件相比是微不足道的。

    HCSS是为律师事务所、医院、保险公司等拥有很少访问文档的机构而设计的。对于那些大的、地理分散的机构而言，HCSS的优点是不言而喻的。例如，一家保险公司的代理机构可以向保险公司的中心档案处调用一份档案和查阅老的客户记录，而这一切都不需要档案操作人员的介入（假设代理机构有访问权）。

    Structure of HCSS HSCC的结构

    HCSS的硬件由自动换盘光盘库和相连的服务器组成的。服务器的磁盘上必须保留自由空间，以便能高速缓存数据。高速缓存是HCSS的一个重要特性。

    原则上，用户不会直接向光盘访问文件。如果他们需要一个文件，系统会首先把文件移到服务器磁盘上的一个指定的HCSS文件卷宗中，HCSS卷宗的大小决定了用户一次能使用的迁回文件数。当需要新文件时，就会把这个文件移到HCSS卷宗上，并把最近最少使用的文件迁移到光盘上，如图H3所示。在这方面，把迁回文件高速缓存到HCSS卷宗上所采用的方法类似于磁盘读写文件被高速缓存在内存中

    HCSS卷宗的大小至少应能存放最大的被迁回的文件。如果卷宗的空间太小，就可能没有足够的空间存放用户想迁回的所有文件，否则HCSS系统需要额外的时间来迁移卷宗中的文件，以便留下更多的空间供新的文件使用。总之，卷宗的容量是越大越好。另外，你还需要考虑已经迁回的文件是否能满足用户要求，或者用户是否总是需要那些必须迁回的文件呢？换句话说，一个用户需要的文件是否已经被另一个用户迁回了呢？如果概率很小，那么所有的文件请求都将需要迁回文件而产生访问延迟。你必须确保HCSS的卷宗容量能存放一次请求的所有文件。

    保存到HCSS设备上的文件位于一个类似于NetWare目录结构的目录结构中。典型的方案就是在Net－Ware服务器上建一个卷宗，并且在这个卷宗中只存放需要迁移的文件。

    注意：

    每台服务器上仅仅只有一个NetWare卷宗能支持HCSS。你应该生成一个特别的HCSS卷宗，并且在这个卷宗中仅仅存放HCSS文件。

    该卷宗在根目录上，能容纳任意数量的HCSS目录。

    通过设置阈值，你可以控制HCSS卷宗中的文件，当遇到阈值的上限时（卷宗满了），文件就开始迁移到光盘直到阈值的下限。

    为避免峰值期，你可以为文件迁移指定一天中合适的时间。

    如果用户所请求的文件导致HCSS卷宗满，那么最近最少使用的文件被移到光盘上。

    HCSS目录和文件的访问权限的控制方法与NetWare其它目录的控制方法相同。

    典型的HCSS目录结构是以称为HCSS的根目录开始的。在这种目录结构中，子目录就与光盘的面有关。例如，一个律师事务所很可能拥有诸如CASES393，CASES493和CASES593的子目录。用户可以把这些目录结构中的文件当做本地磁盘上的文件看待。如果用户需要一个文件，这个文件就会被迁回到HCSS卷宗上，除有一点访问延时外，用户可能不会意识到文件是从光盘上迁回的。

    相关条目：Archiving 归档；Backup and Data Archiving 备份和数据归档；Hierarchical Storage Management Systems分层存储管理系统；Jukebox Optical Devices 自动换盘光盘库；Optical Libraries 光盘存储器。


 IA 信息家电
：IA是Information Appliance的缩写。什么是信息家电呢？简单来说，信息家电是指各种具有连接国际网络及信息存取的装置，主要特色是容易学习使用，就好像日常使用的家电一样。


 IB 智能大厦
：IB(Intelligence Building)智能大厦。智能大厦定义为：通过对建筑物的4个基本要素：结构、系统、服务、管理以及它们之间的相互关系的优化，来提供一个高生产力的、并且经济有效的环境。


  • Icon 图标

    图标位于你的计算机桌面上，双击图标即可打开它们，也可将其拖按到一个新的目录，或是将其扔至同样是图标的垃圾箱 （对于Windows用户而言是回收箱〕中将其删除。


  • 互联网内容提供商 ICP

    ICP 互联网内容提供商

    ICP常被用做两个短语的缩写，其中一个是“互联网缓存协议”（Internet Cache Protocol），另外一个是“互联网内容提供商”（Internet Content Provider）。一般来说，后面一个使用更频繁一些。

    互联网缓存协议（Internet Cache Protocol）：

    众多互联网协议中的一种，被一台代理服务器用来向另外一台代理服务器查询储存在缓存中的网页内容，而无需接入互联网去访问该网页。

    互联网内容提供商（Internet Content Provider）

    一个为互联网网站提供新闻，参考，音频或者视频内容的机构或者企业。


 ICS　Internet连接共享服务
：ICS（Internet Connection Sharing）是Win 2000针对家庭网络或小型的Intranet网络提供的一种Internet连接共享服务。ICS实际上相当于一种网络地址转换器，所谓网络地址转换器就是当数据包向前传递的过程中，可以转换数据包中的IP地址和TCP/UCP端口等地址信息。有了网络地址转换器，家庭网络或小型的办公网络中的电脑就可以使用专有地址，并且通过网络地址转换器将专有地址转换成ISP分配的单一的公共IP地址。


  • IDE 集成驱动电子设备

    集成驱动电子设备(Integrated Drive Electronics)，更规范的名称为ATA(AT附加设备，AT Attachment)，它是一种在主机处理器和磁盘驱动器之间广泛使用的集成总线。绝大部分PC机的硬盘和相当数量的CD-ROM驱动器都是通过这种接口和主机联结的。我们常见的所谓“多功能卡”就是由IDE接口、串并口、游戏口和软驱接口组成的。


  • IIS Internet信息服务器

    IIS是一组Internet服务器加上一些可以在NT操作系统下运行的服务组成，是Microsoft用于控制Internet服务器市场的一个步骤，这一行动也得到了Netscape、Sun Microsystems、O'Reilly和其它公司的支持。有了IIS，Microsoft就包括了一系列用于建立管理网站、搜索引擎的程序集。Microsoft指出，由于IIS和NT服务器在许多方面是一体化的，因为可以提供更快的网页服务。


 IIS　Internet信息服务器
：IIS(Internet Information Server)是一组Internet服务器加上一些可以在NT操作系统下运行的服务组成，microsoft就包括了一系列用于建立管理网站、搜索引擎的程序集，Microsoft指出，由于IIS和NT服务器在许多方面是一体化的，因此可以提供更快的网页服务。


 IIS 网络信息服务器
：网络信息服务器(Internet Information Server)是微软所发展的一项软件，主要的用途是可以让使用者在Windows NT服务器上，进行建立网站的工作。IIS所提供的功能包括WWW、FTP以及Gopher等功能，而且具有安全性，目前已经被广泛使用。


 IMAP4　信息访问协议4
：IMAP4(Internet Message Access Protocol 4)是IMAP的最新版本。它允许使用电子邮件程序来访问邮件服务器上的电子邮件和公告栏信息。与POP不同，IMAP 使用户可以有效地从多台计算机上获取信息。


 INF File 适配器安装信息文件
：INF File(Information File)，为特定的适配器创建的文件，给操作系统提供了安装设备所需的信息，例如此设备的有效的逻辑配置列表、与此设备相关的驱动程序文件的名称等等。设备生产商一般在提供适配器时，都附带一张含有INF文件的磁盘。


 INF File 信息文件
：信息文件(Information File)，为特定的适配器创建的文件，给操作系统提供了安装设备所需的信息，例如此设备的有效的逻辑配置列表、与此设备相关的驱动程序文件的名称等等。设备生产商一般在提供适配器时，都附带一张含有INF文件的磁盘。


 Insert Mode　插入模式
：大部分的文字处理程序，如Word，在输入文字后，文字会插入到原有文字的中间，则称为Insert Mode；如果文字会取代目前位置的文字，则称为Replace Mode。这两种模式可以通过键盘上的〔Insert〕按键来进行切换。


 Instructions Cache 指令缓存
：由于系统主内存的速度较慢，当CPU读取指令的时候，会导致CPU停下来等待内存传输的情况。指令缓存就是在主内存与CPU之间增加一个快速的存储区域，即使CPU未要求到指令，主内存也会自动把指令预先送到指令缓存，当CPU要求到指令时，可以直接从指令缓存中读出，无须再存取主内存，减少了CPU的等待时间。


  • Interface 界面

    界面是指联接计算机和操作者的命令或图形。比如80年代，人们通过键入命令行进行操作与计算机建立界面。后来苹果机出现了，并将图形用户界面（GUI）广 为普及。你现在正在使用的桌面和图标就属于界面。


  • Internal Bus 内部总线

    在CPU内部，寄存器之间和算术逻辑部件ALU与控制部件之间传输数据所用的总线称为片内总线（即芯片内部的总线）。


  • Internet backbone Internet骨干网

    用来连接多个局域和地区网的几个高速网络之一，每个骨干网中至少有一个和其他 Internet 骨干网进行包交换的连接点。不同的供应商拥有它们自己的骨干网，以独立于其他供应商。


  • 网间分组交换 Internetwork Packet Exchange

    Internetwork Packet Exchange（IPX） 网间分组交换（IPX） 网间分组交换（IPX）是Novell NetWare的内置式对等联网协议。IPX是从Xerox网络系统（XNS）协议派生而来的，XNS是在70年代推出的一种网络。NetWare是一个客户机／服务器操作系统，它向客户机提供文件共享服务、打印机服务、安全服务及其它一些可选的特性，如数据库、应用程序、通信，传真和电子函件服务。IPX是提供这些服务的主要手段，PC Week杂志在1993年7月12日那期的报告指出，使用IPX的客户大约有2千万人。

    IPX PacketsIPX分组 ．一

    一个分组是一个包含数据（“负载”）和头部（“向导”）信息的位集合，头部信息包括源和目的地址，以及用来处理错误和使分组保持顺序的控制信息。分组是以帧位流的形式通过一条通信信道到达一个目的地的。每个分组是一个分开的信息块，可能有一个不同于其它在网上传输的分组的地址。分组中的数据可能是来自一个客户机的服务请求或者是一个来自服务器的响应。数据也可以是从一个系统传到另一个系统的文本信息。一般分组的大小是512～6500个字节，所以在网上传输一个大文件可能需要多个分组。

    IPX是一个操作在OSI协议模型中网络层上的数据报协议（datagram protocol）。数据报是传输在一条无连接通信链路上分组的另外一个名字。无连接通信意指从一个源点发送到一个目的地数据分组的发送，没有任何预先的连接建立，也不存在源站和目的站共同监控分组的交换。源站简单地假定目的站能处理它所发送的任何信息。目的站接收分组并重新排序这些分组。如果有的分组丢失了，则目的站要求重发丢失的分组。

    与此相对，顺序分组交换（Sequences Packet Exchange，SPX）是一个面向连接的协议，并且操作在OSI协议模型的运输层上。面向连接意指在两个通信系统之间建立一个监控数据分组传输的会话。SPX面向连接的会话需要更多的建立时间，但它能保证正确地传输敏感和定时信息。SPX分组的长度可能更短一些，因为它不需要全部寻址信息。另一方面，一个无连接会话能快速且有效地建立起来，但它的分组可能更大一些，因为它需要完整的地址以使分组传输到目的地。N上因为它们能更有效地传输那些在一个在大多数情况下，无连接方法使用在相对而言的无差错LA

    网络环境中作普通交换的数据，这些数据通常是以间歇性的突发方式到来的，它们要求大量的额外开销以至于不能为每一组突发数据建立一个会话。相反地，当使用如NetWare Remote Console等实用工具时，使用面向连接的会话更好。为提供持续的、实时的有关一台服务器状态的信息，NetWare Remote Console使用SPX在管理者工作站和一台服务器之间建立一条相对永久的连接。因为这个连接总是在使用，又因为分组是以规则的时间传送的，所以使用面向连接的SPX。

    Using IPX 使用 IPX

    IPX内置于NetWare操作系统，这样工作站只需安装通信协议并运行一个与NetWare服务器对话的客户机软件包。IPX不适用许多非NetWare环境，虽说用它来访问Internet是一件很有趣的事情。

    要获得IPX支持就必须在工作站上安装IPX以及相应的请求者软件，如DOS Requester和OS／2 Requester。现行的软件版本包含Novell的开放数据链路接口（ODI），它提供了一种装载多协议栈的方法，如它能一个接一个地装载IPX和TCP／IP。请求者软件基本上是一种重定向工具，它查看用户键入的命令，以决定是把命令送往本地操作系统还是通过网络送往服务器上的网络操作系统。如果请求的目的地是网络，则请求者软件把请求封装在一个IPX分组中，并把这个分组送往网络接口卡，而网卡以位流的形式把这个分组发送出去。事实上，IPX分组可以有几个不同的目的地：

    同一个LAN段上的服务器。

    同一个LAN段上的工作站。

    另一个LAN段上的服务器或工作站。

    分组的头部信息包含一个LAN段地址。当分组在网络上广播传输时，路由器将查看这个信息并把分组转发到一个合适的LAN段（这个段就是分组的目的网络段）。

    Novell NetWare支持多种数据链路并在这些数据链路上传输IPX分组，支持的链路包括ARCNET、LocalTalk、Ethernet、token ring、光纤分布式数据接口（FDDI）等等。

    在NetWare环境中，下面的协议与IPX紧密联系：

    NetWare核心协议（NCP） NetWare核心协议（NCP）是NetWare服务器和客户机之间传送信息的主要协议。NCP处理登录请求和许多其它对文件系统和打印系统的请求。IPx是运载传输的基本协议。NCP是二个LAN协议，这个协议的设计思想是建立在服务器与工作站很接近这样一个假设上的。一旦加入路由器并涉及到与广域网链路的连接，则NCP会导致传输拥塞。这是因为NCP使用一个请求／响应策略来管理服务器／工作站通讯。如果一个工作站发出一个请求，则在它发出另一个请求之前，必须首先等待一个来自服务器的响应。这种请求应答增加了额外的传输，但下面几个方案将解决这个问题。

    服务公告协议（SAP）NetWare服务器及路由器在NetWare网络上每60秒钟就用SAP来广播一个消息以指示它能提供的服务类型。

    路由选择信息协议（RIP）NetWare用RIP使网络路由器通告有关网络上路由选择路径的最新变化信息。NetWare服务器具有路由器的功能。RIP使用距离向量算法（DVA）计算路由选择路径。在DVA中，路由选择是基于到目的站的最少“hop”（过路，中继）数。Novell的RIP也包括一个用来指明链路速度的域，RIP还提供另外一种方法来定义分组传到目的站的路径。

    每隔60秒，路由器就交换彼此的RIP路由选择表，并且路由器根据新到来的信息重新构造自己的路由选择表。如果路由器未能及时地重建自己的路由选择表，则有可能发生问题，这种情况通常发生在路由器连接了一条慢速WAN链路。此外，交换路由选择表还能在LAN上增加额外的传输量，这将导致更频繁地发生拥挤，并进一步延迟路由选择表更新。如果一个路由选择器发生故障，重建路由选择表的工作与重新安装一个路由器一样耽误时间。

    这些问题将被Novell的一种新的路由选择协议所解决，这个协议叫NetWare链路服务协议（NLSP）。

    Wide Area Networking Support 广域联网支持

    在过去，由于操作系统与协议的某些缺点，NovellNetWare和IPX不能很好地支持广域联网。下面列出这些缺点及Novell对这些缺点的改进，这些改进已增加到新的IPX中。

    BURST MODE（突发方式）在IPX网上要求应答分组能导致所谓的“ping－pong（乒乓）”效应，在这种效应中，分组被发送去而返回该分组的应答。所有这些行为会明显降低广域链路的性能。IPX的新的突发方式特性能允许在一个应答消息之前最多发送128个分组。突发方式可能会提高50％的性能。但是，在多协议网上，它可能阻碍其它协议产生的传输。例如，如果IPX正在突发传送分组通过一个路由器，则TCP／IP的传送只有当这台路由器处于空闲状态时才能使用它。路由器能有效地使你提高某些传送的优先级，使这些传送先于其它传送通过。

    注意：在NetWare 4．x中包括对突发方式的支持，对以前的NetWare版本作为一个增加功能使用。

    LARGE FRAME SIZE（增加帧长度）以前，发送到路由器的位流被分成多个512个字节长的分组，以防止产生拥塞。现在，Novell提供一种方法来发送通过路由器的大数据分组以改善网间分组交换。分组的大小可在设置时协商。

    注意：Novell提供large IPX（LIPX）NLM（可装入模块）来处理大分组。它是随NetWare 4．x一同推出的，且对以前的NetWare版本作为一个增加的功能使用。

    REDUCED SAP TRAFFIC（精减的SAP传送）服务公告协议（SAP）发送告知工作站或其它设备有关一台NetWare服务器上可用服务的分组。但是，如果服务不重要或位于广域链路另一端的工作站不关心这种服务，则SAP将产生不必要的传送。为减轻部分额外负担，你可增加SAP广播之间的时间间隔，或者你可用Novell提供的过滤器减少在广域链路上的SAP传送。

    IPX EvolutionIPX的发展历程

    IPX的后继是NetWare链路服务协议（NLSP），它用一个链路状态路由选择算法替代SAP和RIP，从而提高了网络互连能力。如果链路发生故障，链路状态路由选择算法在路由选择处理上提供更多的控制和更快的响应以建立新的路径。路径选择是根据避免拥挤域区、线路速度、线路使用费用或其它各种优先级来确定的。NLSP是基于优先开放最短路径和中间系统对中间系统（IS－IS）算法。

    Novell也已经升级SPX以包括平滑窗口、突发方式和大的分组。此外，新的工作站外壳程序能有效地寻找另一条路径来代替发生故障的路径。

    相关条目：Datagram Network Services数据报网络服务；NetWare NetWare网络操作系统；Novell Novell公司；Routing Protocols路由选择协议；Sequenced Packet Exchange 顺序分组交换。


  • 网间路由选择 Internetwork Routing

    Internetwork Routing 网间路由选择 任何一个使用路由器并包含多条从源站到目的站路径的互联网需要高效的路由选择机制以确保分组信息能以一种高效和及时的方式被传输到目的站。Internet就是这样一个网，它是由许多构筑在传输控制协议／因特网协议（TCP／IP）之上的专用网互联起来的全球性网络。

    相关条目：Networks 网络；Routers路由器；Routing Protocols路由选择协议；WideArea Networks广域网。


  • 网络互联 Internetworking

    Internetworking 网络互联 参看“Networks网络”。


  • 互操作性，互用性 Interoperability

    Interoperability 互操作性，互用性 互操作性是指不同的计算机系统、网络、操作系统和应用程序一起工作并共享信息的能力。互操作性分为不同的级别，这是因为两个系统连接并共享信息，不能简单地认为用户也能从自己的应用程序中访问这些信息。例如，一台UNIX工作站能用TCP／IP通信协议与一台Novell NetWare服务器相连。但是，UNIX工作站的用户除非使用兼容的文件协议，否则不能访问服务器上的文件。在这个例子中，加载到NetWare文件服务器上的Novell NetWare NFS将允许UNIX用户和NetWare客户一样以一种集成化无缝的方式访问文件及其它的网络资源。

    但是即使是这种级别的互操作性也不能保证UNIx用户有可能打开和编辑他在NetWare服务器上所访问的文件。用户访问非兼容的文件格式，将需要翻译器和转换器。在某些情况下，应用程序自身就能访问操作在其它环境中的应用程序所生成的文件格式。主要的软件供应商如Microsoft，通过生成工作在多个环境中的应用程序，部分地缓解了这种差异性。例如，Microsoft Excel电子表格程序能工作在Windows环境和Macintosh环境。如果一个Windows用户传输一个文件到一个Macintosh用户，则这个Macintosh用户能打开这个文件并使用这个文件所提供的格式化代码。

    术语“开放式系统”意指通过遵循彼此认可的标准设计的能协同工作的产品，如由国际标准化组织（ISO）推出的开放系统互连（OSI）模型OSI模型由七层组成，其中的每层都描述了系统之间是如何连接和通信的。0SI模型是通用全球的设计和建造可互操作系统的一个参考点。协议栈的底层定义了联网硬件，以及系统是怎样实际相互传送数据的，而上层定义了应用程序间的互操作。大多数供应商生产的产品都是松散地遵守这个标准的，这意味着某些层按OSI定义实现了而另一些层则没有。由于不是严格地遵守该标准，所以互操作性仍为网络管理者所关注。

    开放软件基金会（OSF）正致力于在表示层和应用层上支持互操作性的工作。它的分布式计算环境（DCE）提供给程序设计人员一些工具，程序设计人员能用这些工具生成互操作性的应用程序，从而把他们从用低层协议工作的复杂性中解脱出来。所生成的应用程序能运行在分布式异构网络环境中。由OSFDCE提供的远程过程调用（RPC）具有传输独立性和传输透明性。传输独立性意指RPC能运行在任何一个广域网或局域网上，而传输透明性指不管应用程序在哪种网络环境中运行，分布式应用程序代码均以同样的方式运行。

    电子函件和消息传递系统提供了一种唯一的方法解决了互操作问题。一个企业E－mail系统用E－mail系统作为一个信关或交换系统来向不同系统上的用户提供一种交换消息、文件和其它信息的办法。消息传递系统也实现在应用程序中以提供应用程序间通信或用户和应用程序之间的非实时消息交换。例如，一个用户可能为得到一份报告而向数据库发一个请求，第二天就从他／她的邮箱中收到这份报告。比电子函件更优秀的是群件和工作流软件应用程序，它们允许用户协调他们的调度和工程。

    在企业计算环境中，互操作性是主要关注的问题。企业网中聚集了以前属于各个部门和分部的计算资源，目的是允许整个网上的用户访问各个系统上的数据。运行在Windows、Macintosh、DOS和其它环境中的前端应用程序需要访问各种后端系统上的数据，这些数据以各种格式出现并能用结构化查询语言（SQL）访问。但由于各个供应商的SQL都存在微小的差异，因此前端应用程序必须知晓每种差异，或靠后端服务器翻译发送给他们的命令。转换功能来屏蔽这种差异，另一种解决方法是“中间件”。它在前端和后端应用程序之间提供了一个互操作性的层。下面列出部分中间件，并将在本书的其它章节中加以讨论。

    Microsoft开放数据库连接（ODBC）ODBC提供一些由大多数后端数据库系统所执行的公用功能。

    然后，前端应用程序被编写并进入ODBC利用ODBC的这些功能。

    独立数据库API（IDAPI）IDAPI在功能上类似于ODBC，且也是根据调用级接口设计的。

    分布式关系数据库体系结构（DRDA）DRDA是在遵循SQL标准的IBM和非IBM平台上访问数据库信息的一个IBM标准。它是IBM信息仓库框架的一个关键部件。

    苹果公司的数据访问语言（DAL）Apple开发出DAL以向Macintosh用户提供访问多个后端数据库产品的能力，后端数据库包括IBM大型计算机和中型机数据库。DAL与SQL相关。

    Oracle′s Glue Glue是一个API，包括一系列访问后端数据库服务器的命令。据报道，与ODBC相比Glue将花较少的步骤访问数据。

    在一个面向对象的系统中，一个对象请求代管者（ORB）提供关键通信工具，以在系统的应用程序、服务和工具之间分发消息。你可把ORB想象成为一种软件总线，或主干网，提供一个公用的消息传递接口，通过这个接口许多不同种类的系统能互相通讯。一个对象向ORB提交一个请求，然后ORB就找到能为这个请求服务的对象、格式化请求并把它发送给服务对象。接收对象这时响应这个请求并向ORB返回一个响应，ORB格式化和转发响应给请求者。在这种模型中，对象简单地指定一个要执行的任务，它们不需要知道服务任务的对象的任何细节及其地址。ORB处理查找对象、格式化消息以及传输消息的所有细节。对分布式环境中的所有对象而言，ORB是一个通用接口。

    STREAMS是一个允许在一个网络上使用多个通信协议的开发和操作环境。它应用在UNIX和Novell NetWare环境中，同时也适用于其它一些环境。运行在STREAMS环境中的应用程序能非常容易地使用它所支持的任何一个通信协议。STREAMS是一个模块化系统，在这个系统中协议栈能按需求增加或删除，它以模块的形式向开发者们提供一组实现通信协议的工具。

    在低层上，互操作性提供多协议支持，所以用户能访问许多不同类型的系统。例如，如果TCP／IP和SPX／IPX协议栈安装在一台计算机上，则这台计算机上的用户能访问一台NetWare服务器以及一台UNIX服务器。Nove11的开放数据链路接口（ODI）和Microsoft的网络驱动程序接口规范（NDIS）提供了装载多协议栈并在单个网络接口卡上操作这些协议的能力。

    相关条目：Compound Documents复合文档；Distributed Computing Environment，OSF OSF的分布式计算环境；Document Interchange Standards文档交换标准；Electroic Mail电子函件；Groupware群件；Messaging API，Inter－Application应用程序间的消息传递API；Middleware 中间件；Object Linkingand Embedding对象链接和嵌入；Object Request Broker对象请求代管者；Open System Interconnection Model开放系统互连模型；Remote Procedure Calls远程过程调用；Windows Open System Architecture Windows开放系统体系结构。


  • 进程间通信 Interprocess Communication

    Interprocess Communication 进程间通信（IPC） 进程间通信（IPC）是运行在多任务操作系统中或联网计算机上的程序和进程使用的一组技术。IPC分为两种类型：

    口本地过程调用（LPC）LPC在多任务操作系统中使用，它们允许并发运行的任务能彼此对话。LPC能共享内存空间、同步任务并相互发送消息。

    远程过程调用（RPC） RPC类似于LPC，但却工作在网络上。RPC首先出现在运行UNIX操作系统的SUN微系统公司和HP公司的计算机上。

    程序使用IPC的一个好处是，能有效地利用其它程序或计算机的过程。客户机／服务器模式就利用了RPC。客户在他自己的机器上执行部分任务，但还要依赖服务器提供的后端文件服务。RPC为客户提供通信机制，以使服务请求发送到后端服务器。如果把一个客户机／服务器应用程序想象成为一个被分拆在前端和后端系统之间的程序，则RPC 就能被看作是在网络上重新集成它们的部件，RPC有时称作耦合（coupling）机制。

    UNIX中正常的进程间通信机制是管道（pipe），而套节字（socket）是工作在多个网络上的进程间通信的机制。80年代初，当TCP／IP协议栈被集成到BerkeleyUNIX中时，它就成为UNIX的一部分。这项工程是由DARPA投资的，若想详细了解请参看“传输控制协议／Internet协议”讨论。

    在OS／2保护模式中，程序运行在属于它自己的一片内存保护区，或能在诸如IBM LAN Server或Microsoft LAN Manager一样的网络上通讯。保护模式禁止一个程序破坏其它程序所用的内存区。如果程序需要相互通信或共享内存区，则可使用这里描述的IPC特性。

    共享内存（shared memory） 借助使用共享内存，进程能改变内存中其他进程也能读的值。这个内存空间变成一种公告牌，在公告牌中进程能公告状态信息和需要在进程间共享或传递的数据。共享内存总是一片指定区域，这个区域通常是在存放正常程序数据区域的外面。

    队列（Queues） 一个IPC队列是一个结构化的排序内存段表，这个队列就是进程存放或检索数据的地方。队列的顺序可有多种，包括先进先出（FIFU）和后进先出（LIFO）。

    信号标（Semaphores）信号标为那些访问相同资源的进程提供一个同步机制。注意信号标不是用于传输数据，它只是简单地协调对共享资源的访问。信号标可以包含一个增加或减小的值，用以指出什么资源正被访问和访问的次数。

    口管道（Pipes） 一个管道通过交换消息为进程间通讯提供了一种途径。而命名管道（named pipes）为运行在不同计算机系统上的多个进程提供了一种在网络上通信的方法。邮槽（Mai1 slots）是一个存储转发消息传递系统，它不需要站点之间相互同步。命名管道和邮槽是OS／2的扩展，仅仅用在IBM LAN Server和Microsoft LAN Manager环境中。

    相关条目：Application Program Interface应用程序编程接口；Remote Procedure Calls远程过程调用。


  • 中断 Interrupts

    Interrupts 中断 一个中断，或IRQ，是一台计算机（这里只讨论基于Inter芯片的系统）中的一个部件，它为获得处理器服务而发出请求。当计算机的一个部件，如一个COM端口或软盘控制器，需要CPU注意时，则它会在一条中断线上发一个请求。每一个部件都有它自己的中断请求线，所以当你在一台计算机中安装一块新的适配器时，使用一条原来没有使用的中断线是很重要的。如果你不能找到一个可用的中断，那么你可能需要停用一个不很重要的部件，如第二个COM端口或第二个并行端口（参看下表）。当安装多个适配器时，一定要确保任何适配器不能使用同一个中断。在适配器上改变中断，是通过在随机带来的手册指导下移动跳线或设置dip开关进行的。当有一个中断与硬盘驱动器控制器的中断冲突时，系统通常自举失败。下面为你的系统造一张在用的中断表，以使你在你的适配器上改变设置以避免中断冲突。

    系统部件IRQI／O端口地址

    EGA／VGA视频适配器 23C0～3CF


  • IP 网络协议

    Internet Protocol网络协议。处理数据(data gram)从一个主机到另一个主机的路由选择问题的协议。与传输控制协议 (Transmission Control Protocol， TCP)协同工作以保证数据在互联网上准确传送。联在网上的每一台计算机都有其唯一的IP地址。


 iPAQ　Pocket PC
：iPAQ是美国Compaq电脑公司推出的一系列高性能PocketPC的昵称，该系列掌上电脑具有强大的多媒体功能，采用Win CE 3.0操作系统。


  • IRC 互联网中转聊天

    一种采用文本形式的多通道互联网聊天系统，可以使用户通过互联网进行即时交谈。


 IrDA 红外线传输装置
：IrDA是Infrared Data Association的缩写，是1993年由100家以上的电脑周边产品制造商所组成的一个组织，现在IrDA已经泛指红外线传输资料的装置，目前常用于笔记本电脑和手机等产品中。


  • 铱系统 Iridium System

    Iridium System 铱系统 铱系统是Motorola推出的全球移动电话服务。它由66颗低轨道卫星组成，并使用4，800bps的窄带数字语音编码。世界行政无线电协会（WARC）同意为这个服务分配一个无线电（信号）频谱。在1993年8月，Motorola已经获得了首期财政支持。投资者包括BCE公司、洛克希德公司、日本铱公司和US Sprint公司。提供的服务可能有移动通信、传真和从地球上任一个地方调文件页。这个系统可能会在1996～1997年的某个时候实现联机。


  • 综合业务数字网／宽带综合业务数字网 ISDN／B－ISDN


  • IS－IS域 间路 由选择协议 IS－IS Interdomain Routing Protocol

    IS－IS Interdomain Routing Protocol（IDRP） IS－IS域 间路 由选择协议（IDRP） IDRP是一个链路状态开放系统互连协议，它规定路由器与其它域中路由器的通信方法。

    相关条目：Routing，OSI OSI中的路由选择。


 ISNews　电子新闻系统
：ISNews（Individualized Science News）是德国正在开发的综合文字、图像和声音等多种信息媒体的系统。它包括电子报纸、电子辞典生产和管理工具、多媒体电子邮件系统、超文本写作系统、文字识别和生产系统、影像管理系统、基于面向对象数据库的超媒体系统和多媒体用户接口环境。


  • 等时服务 Isohronous Service

    Isohronous Service 等时服务 等时服务基本上保证了数据网上的一个通信通道内的确定带宽。象音频、视频这样的实时服务的传送需要等时服务，这是因为，对于这样的服务，分组传递的延迟是不允许的。等时服务提供了同步的实时音频、视频传输。

    具有可变长度分组的网络，不能有效地提供等时服务，除非使用优先分级方法将一部分带宽分给视频通信专用。由于ATM（异步传输模式）的信元都具有同样的大小，所以它提供等时服务。例如，它通过专门使用一个数据流中的所有第三个信元，来确保按时精确地传送。

    无论某通信信道是否使用，等时服务对它的带宽进行预留待分配或预分配。这时，带宽允许具有很低延迟的时间同步传送。当信息源产生的信号或事件是以已知周期间隔出现时，就需要这种服务。

    相关条目：Cell Relay 信元中继；Fast Packet Switching快速分组交换；Frames in Communication通信中的帧；Video Conferencing and Desktop Video电视会议（视频会议）和台式视频系统。


  • IT 信息技术

    信息技术(Information Technology)。IT是一个术语，它包括了各种用于创建，存储，交换和使用信息（商业数据，语音信息，图像，动画，多媒体等等信息）的技术。出于方便的考虑，其中也包括电话和计算机技术，这个词来源于“信息革命”。


  • IT 信息技术产业

    信息技术产业（Information Technology）。由于各国的产业结构不同，对信息产业的理解也有差异，而且信息产业的内容也在不断地发生变化。一般是指国民经济活动中，从事信息产品及其装备、设备和信息服务的生产和流通的各部门的集合。


 IVR　交互式语音响应
：IVR(Interactive Voice Response)是一个应用软件，大家不要觉得这是个什么硬件产品。它接收语音输入和键盘选择，产生相应的响应，这些响应可能是电子邮件形式的，可能是传真形式的。它通常是大型应用程序的一个用户接口部分。


  • 超时传输，Jabber传输 Jabber

    Jabber 超时传输，Jabber传输 超时传输通过网络结点上有故障的收发器，在共享网络电缆上随机传送数据。随机数据可能破坏其它站的传送。若传输时间超过与传输帧大小相对应的时间，设备上的超时传输控制功能将防止进行进一步的传送。

    如果一个网络的垃圾数据泛滥，那么收发器或内置收发器的网卡可能会被损坏。这时，可以使用“测试设备和技术”中讨论的测试工具或管理系统来对这些故障进行隔离。相应地，在一个小网络上，可以移开一些站或对网络进行分段，以确定哪一端还有垃圾数据，进而对它再分段，直到发现了产生问题的根源。


  • Java 编程语言

    Java是一种编程语言，被特意设计用于互联网的分布式环境。Java具有类似于C++语言的“形式和感觉”，但它要比C++语言更易于使用，而且在编程时彻底采用了一种“以对象为导向”的方式。使用Java编写的应用程序，既可以在一台单独的电脑上运行，也可以被分布在一个网络的服务器端和客户端运行。另外，Java还可以被用来编写容量很小的应用程序模块或者applet，做为网页的一部分使用。applet可使网页使用者和网页之间进行交互式操作。

    Java是Sun微系统公司在1995年推出的，推出之后马上给互联网的交互式应用带来了新面貌。目前，最常用的两种互联网浏览器软件中都包括一个Java虚拟机。几乎所有的操作系统中都增添了Java编译程序。


 JPEG 联合图像专家组规范
：JPEG是Joint Photographic Experts Group 的首字母缩略词，即以压缩格式存储图像的 ISO/ITU 标准。JPEG 在压缩率和图像质量损失之间进行折衷，当图像质量有明显损失时，压缩率可达 100:1，而在只允许有微小损失时，压缩率可能只有 20:1。


  • JSP 网页控制技术

    Java Server Page，Java服务器页，JSP是通过使用小服务器程序（这些程序工作在服务器端，在将网页传送给用户前改变其内容）控制网页内容的技术。开发Java语言的Sun公司将JSP技术称为小服务器程序API，它和Microsoft公司的ASP技术是兼容的。所不同的是，JSP是一段JAVA程序，它在服务器上直接运行，而ASP是通过一个脚本解释器间接执行的。


  • 自动换盘光盘存储设备 Jukebox Optical Storage Device

    Jukebox Optical Storage Device 自动换盘光盘存储设备 自动换盘光盘存储设备是一种可以自动装卸光盘的光盘设备，它提供多达500GB的近机信息。这种设备常被称为光盘库、机器人驱动程序或自动换盘器等。自动换盘设备可以具有多达50个盘槽和一个选择设备，其中，可以通过选择器遍历槽或槽移动来达到选择器对准的目的。盘槽和选择设备的安排对性能的影响依赖于盘片和选择设备之间的空间。通常，这种设备的寻道时间在85微秒左右，传输率在700Kbps数量级。

    自动换盘设备适用于需要大容量存储的环境，如图象、归档、分层存储管理（HSM）。其中，HSM是一种将很少使用或不使用的文件通过一个称为“迁移”的过程从快速磁存储设备，移动到自动换盘光盘存储设备的策略。对于需要移出的文件，它们又会被迁回磁存储设备。如果在一定的时间周期之后，或在一段时间内，光盘上的文件没有被使用，它们就可能会被移动到磁带上存档。

    相关条目：Archiving归档；Backup and Data Archiving 备份和数据归档：Hierarchical Storage 分层存储管理系统；High Capacity Storage System 大容量存储系统；Novell NetWare；Optical Libraries 光盘库。


  • Kerberos鉴别 Kerberos Authentication

    Kerberos Authentication Kerberos鉴别 Kerberos鉴别服务是由麻省理工学院的Project Athena针对分布式环境的开放式系统开发的鉴别机制。它已被开放软件基金会（OSF）的分布式计算环境（DCE），以及许多网络操作系统供应商所采用。

    Kerberos是针对分布式环境而设计的，在这种情况下，一些工作站可能安装于不安全场所，而且用户也并非是完全可信的。Kerberos具有如下特点：

    客户在登录时，将被鉴别。其他客户相信Kerberos鉴别服务器已经正确地对客户进行了验证。

    用户必须获得由鉴别服务器发行的许可证，以使用对象服务器上的可用服务。产生一个鉴别器，它上面包含一些附加信息，对象服务器用这些信息与许可证比较，以此来验证是否进行了合法确认。这个过程是在后台进行的。

    许可证提供被鉴别的用户访问一个服务时所需的授权资格。

    许可证是用个人密钥加密的，包含客户的身份、他们的地址、时间戳和其它信息。时间戳用于阻止侵入者，以保护正在网络传送的、并在几小时后就会过期的信息。

    所有客户和服务器间的会话都是暂时的。如果一个客户需要一个新的会话，就必须获得一个新的鉴别器。许可证在一定时间之后就会过期，所以客户需要周期性地获得新的许可证以访问特定服务器。

    Kerberos系统要求修改每个网络服务以使用Kerberos。另外，还要求有一个特定的服务器处理Kerberos鉴别服务。这个系统必须安放在安全场所。另外，如果Kerberos服务器失效，网络访问将被切断，所以建议增设一个冗余的服务器。虽然Kerberos的成本较高，但却为需要它的机构提供了一个安全的环境。

    相关条目：Key Encryption Technology密钥加密技术；Security安全性。


  • Kermit文件运输协议 Kermit

    Kermit Kermit文件运输协议 Kermit文件运输协议是用于在PC之间交换文件的一种简单的文件运输协议。该协议是哥仑比亚大学开发的，由于在Kermit the Frog之后而获得此名。它提供了一条从大型计算机下载文件到微机的途径。它已被用于进行公用数据传输。

    Kermit文件运输协议是一个半双工的通信协议。

    它支持7位ASCII字符。

    数据以可多达96字节长度的可变长度的分组形式传输。

    对每个被传送分组需要一个确认。

    Kermit文件运输协议在每次会话中可以传送多个文件。

    相关条目；Asynchronous Communications 异步通信；Transmission Media，Methods，and Equipment传输介质、方式和设备。


  • 操作系统内核 Kernel

    Kernel 操作系统内核 操作系统内核是指大多数操作系统的核心部分。它由操作系统中用于管理存储器、文件、外设和系统资源的那些部分组成。操作系统内核通常运行进程，并提供进程间的通信。下面列出了它的一些核心功能：

    事件的调度和同步。

    进程间的通信（消息传递）。

    存储器管理。

    进程管理。

    输入输出例程的管理。

    Carnegie－Mellon大学开发的Mach操作系统采用客户机／服务器体系结构，它包含一个实现最少功能的、而且相对而言较小的微内核。它管理设备驱动程序、消息、线程和虚拟存储器。其他功能被模块化，通过使用进程间通信机制与操作系统内核通信。远程过程调用（RPC）用于与其他系统上运行的进程进行通信。

    在DOS操作系统，操作系统内核被认为是界于基本输入输出系统（BIOS）和应用软件之间的那部分。应用命令通过操作系统内核传递到BIOS，然后再传送到相关硬件。

    相关条目：Mach，Carnegie－Mellon Microkernel Carnegie－Mellon的微内核Mach；Microkernel 微内核。


  • 密钥加密技术 Key Encryption Technology

    Key Encryption Technology 密钥加密技术 密钥技术提供的加密服务可保证在开放式环境中网络传输的安全性。有两种大量使用的密钥加密技术：私用密钥（对称加密）和公共密钥（非对称加密）。

    任何一种加密体制的目的都是为了保证个人数据通信的安全。伴随着国际网络、公共和个人电子函件系统，以及无线电通信的发展，对安全性的要求也越来越高。幸运的是，微电子的发展使得我们可以很容易实现安全保护，而且价格也越来越便宜。也许，技术人员使用的用于监督网络传输量的协议分析器有助于提醒管理人员认识到他们的数据传输并不安全。任何拥有这一设备的人都可以查看从网络上选定的数据流。

    私用密钥加密方法又称为对称密码，公共密钥方法称为非对称密码。

    在私用密钥机制中，信息采用发送方和接收方保存的私有的密钥进行加密。这种系统假定双方已经通过一些人工方法交换了密钥，并且采用的密钥交换方式并不危及安全性。

    公共密钥机制为每个用户产生两个相关的密钥。一个由用户私下保存，另一个放于公共区。如果某人想给你送消息，他（她）用你的公开密钥对信息加密。当收到信息后，你可用私存的密钥对信息解密。

    相关条目：Data Encryption Standard 数据加密标准；Private Key Cryptography 私用密钥密码学；Public Key Cryptographic Systems公开密钥加密系统；Security 安全性。


 Key recovry 密钥恢复
：一种私钥加密方法。授权方（例如政府代理机构）使用专用软件可以从加密数据中恢复密钥。按目前的法律，自 1998 年后从美国出口的任何加密软件都必须能实现密钥恢复。这条规定代替了早期提出的任何出口加密软件必须实现密钥托管的规定。


  • Knowbots智能程序 Knowbots

    Knowbots Knowbots智能程序 “Knowbots”由麻省理工学院的Marvin Minsky提出思想，它是用于象在因特网这样的大型网络数据库上搜索信息的数据库智能代理程序。Carl Malamud在他的书“Stacks，Interoperability in Today’s Computer Network”（《栈，当今计算机网络的互操作性》，Englewood Cliffs，New Jersey：Prentice－Hall，1992）中对这一思想做了进一步介绍：

    “也许数据库系统最有前途的部件是knowbot智能程序，它是一个进入网络的智能程序。Knowbot访问不同节点来为它的主人查找所需信息。为得到信息，Knowbot可以执行任务，也可能会遍历数据库或合同购买条目等，并将消息发回给它的主人。其中，它的主人可以是一个人，也可以是另一个knowbot。”

    由于信息基础设施已发展得太大，同时通过因特网和其他网络可得到的信息又太多，Knowbot变得更加重要。Knowbot可以在无需用户干预的条件下对信息定位，这虽然为信息服务机构提供了挣钱的好机会，但对用户而言却是既省时间又省钱的。Malamud等人提出，当联机工作被咨询时，系统可自动为作者记取酬金。

    相关条目：Internet 因特网。


  • Microsoft的局域 网管理器，Microsoft的 LAN Manager LAN Manager，Microsoft

    LAN Manager，Microsoft Microsoft的局域 网管理器，Microsoft的 LAN Manager Microsoft的局域网管理器是一个在OS／2操作系统上运行的网络管理和文件系统。虽然，Microsoft和IBM曾合作开发OS／2，但Microsoft现已不再开发该操作系统了。IBM对OS／2进行了进一步增强，提供IBM LAN服务器网络操作系统，它是一种基于LAN管理的产品。现在IBM OS／2和IBM LAN服务器都和它们的原始产品已经不尽相同。Microsoft为了Windows NT高级服务器网络操作系统而购买了LAN管理器。

    图L－3示意了OS／2 LAN管理器的层次式体系结构。OS／2是一个多任务操作系统，它可以以分离和保护会话的方式运行不同的程序。LAN管理器在这些会话之一中运行，并使用OS／2高性能文件系统（HPFS）的升级版本来管理多用户。LAN管理器与OS／2紧密相连，故不能在其他操作系统上运行。OS／2是一种预分级的多任务操作系统，即它在需要时，可以停止一个进程，而转向具有高优先级的进程服务。

    虽然LAN管理器正在被Windows NT高级服务器系统替换，Microsoft仍然支持LAN管理器，并指出它的缺陷。根据Microsoft的建议，将来需要扩展网络选项的顾客应该考虑Windows NT高级服务器。它速度快，提供全32位操作，并且包括了Machintosh的支持，如支持远地客户的远程访问服务（RAS）。

    相关条目：Mail Slots OS／2的邮件传递系统：Named Pipes命名管道；Windows NT Advanced Server，Microsoft Microsoft　的Windows NT高级服务器。


  • 局域网请求解释器 LAN Requester

    LAN Requester 局域网请求解释器 LAN请求软件驻存在工作站上，它向运行在工作站上的应用程序提供了一条请求网络服务器所提供服务的途径。LAN请求软件就象一个命令的交通指示灯，它使本地服务的指令转向到本地操作系统，并使网络服务命令转向到运行在服务器上的网络操作系统。

    相关条目：Client Software 客户机软件；DOS Requester，NetWare NetWare的DOS请求解释器；LAN Workp1ace Products，Novell Novell的局域网Workplace产品；Network Driver Interface Specification 网络驱动程序接口规范；Open Data－link Interface 开放数据链路接口。


  • 局域网服务器 LAN Server

    LAN Server 局域网服务器 参见IBM LAN Server IBM的局域网服务器。


  • 局域网故障诊断 LAN Troubleshooting

    LAN Troubleshooting 局域网故障诊断 参见Testing Equipment and Techniques 测试设备和技术。


  • Novell的 LAN Workplace产品，Novell的局域网 Workplace产品 LAN Workplace Products，Novell

    LAN Workplace Products，Novell Novell的 LAN Workplace产品，Novell的局域网 Workplace产品 Novell的LAN Work Place产品使得DOS、windows、OS／2 Machintosh的用户，可以直接访问需要TCP／IP协议的资源，如UNIX系统、DEC公司的VAX系统和IBM大型计算机。主要有四种Novell的LANWork－Place产品：

    LAN Work Placefor DOS 使用开放数据链路接口（ODI）为DOS和Windows用户提供以太网、令牌环网和ARCNET网适配器上的IPX／SPX和TCP／IP协议。

    LAN WorkGroup 为DOS和WINDOWS的NetWare客户提供LAN WorkPlace for DOS的所有特性。然而，这种产品必须安装在服务器上，并且具有管理性功能，如应用—使用的监控和软件升级。

    LAN Work Place for OS／2 使OS／2用户可以直接访问Apple Machintosh计算机、UNIX系统、VAX系列、IBM大型计算机和其他系统。由于OS／2系统支持多任务，所以它具有多重并发会话的特点。

    LAN Work Placefor Macintosh 使Apple Macintosh用户访问TCP／IP网络上的资源。

    使用这些产品，NetWare用户可以使用在基于UNIX系统或其它使用TCP／IP协议的系统上的应用软件。与TCP／IP兼容的主机系统可以与用户在相同的LAN网段，也通过多协议路由器相连而位于不同的网段。


  • LAN 局域网

    局域网(Local Area Network)。连接一组或者一群距离接近的在同一较小物理地域内(如同一办公室或建筑物)的计算机和网络设备的网络。局域网通常使用同轴电缆或者双绞线进行连接。速度通常比城域网(MAN)和广域网(WAN)快，但范围最小。局域网有总线型、环型、星型和网状型几种物理拓扑结构。


  • LANtastic局域网操作系统 LANtastic

    LANtastic LANtastic局域网操作系统 LANtastic局域网操作系统是Artisoft（Tucsonn，Arizona）开发并推向市场的一种点对点的网络产品。它首先是针对允许小型商务共享文件和资源的网络而设计的。今天，LANtastic网络产品已经成熟，并具有许多高级特性：

    安全性。

    复杂的打印机功能。

    内置电子函件。

    磁盘高速缓冲存储器。

    CD－ROM共享。

    音频能力。

    Windows界面。

    LANtastic网络在DOS和windows环境下运行。用户可在一次登录后访问多种资源。管理特性包括具有全面观察网络，以管理用户权限和监督网络通信的能力。LANtastic还支持不间断电源，以保证在掉电时的服务器正常关闭。审查跟踪功能使LANtastic系统能够对子目录和设备的所有访问都做记录，如资源使用的时间和长度等。

    LANtastic可从包含以太网适配器等初始工具箱中获得。完整的工具箱可极大地简化在一个小事务环境下安装网络。其它工具分组包括可多达500用户的许可证。


  • 膝上机联网 Laptop Connections

    Laptop Connections 膝上机联网 膝上型计算机使得用户能够在旅途中携带。但当用户返回办公室后，他们却可能需要将这种计算机连接到局域网上。许多膝上机太小，它们没有适配器接口，所以为了连接到LAN上，用户可以采用下述的方式之一：

    购买一个带有适配器槽的对接站（docking station），然后再安装网络适配器卡。

    购买一个外接LAN适配器。

    通过电话连接器联接到LAN。

    购买一个具有内置LAN适配器的膝上机。

    最后一种选择是不现实的，但它确实是一种选择，特别是对于那些不介意放弃旧设备的用户。第三种选择对于在路途中的膝上机用户是一种比较实际的选择。LAN适配器是一个比较小的设备，大约为50张堆集起的＄10票据那么大。（这大概也是你要购买一个这种设备所需付出的钱数）。注释：与个人计算机存储卡国际协会（PCMCIA）兼容的网络适配器卡已相当普及。它们具有信用卡大小的体积，可插入可移动计算机的扩展内存槽中。许多新的膝上机包含了PCMCIA槽。

    外接LAN适配器连接到膝上机的并行口，大多数都与现有的LAN网卡标准兼容，所以能使用包含NetWare的驱动程序。Xircom公司（Calabasas，California）、D－Link系统（Irvine，California）和IQ技术公司（Bothell，Washington）通过同轴电缆或双绞线连接器构成令牌网、ARCNET和以太网。相关条目：Mobile Computing 移动计算；Wireless Mobile Communication 无线移动通信。


  • 大型网间分组交换 Large Internetwork Packet Exchange

    Large Internetwork Packet Exchange 大型网间分组交换 当在运行网间分组交换协议的网络上使用路由器时，NetWare自动将分组的大小设置为576字节。这保证了分组能够通过路由器。这是因为NetWare并不知道路由器可操作的分组的大小。NetWare V．4．x自动支持大型网间分组（LIP），这就在使用路由器时，为客户和服务器协商选择一个合适的分组大小提供了途径，而无需服务器指定576字节的限制。然而，你必须知道网络上路由器能够处理的分组大小。如果一个路由器不能处理大于576字节的分组，就必须禁止大的分组。

    这种设置基本上使NetWare在设置分组体积的协商过程中，忽视路由器检查。然而，你必须确保路由器能够传输更大的分组。如果在网络上有一个不允许更大的分组的路由器，就需要设置回576字节的分组大小或替换路由器。为了在服务器上设置回576字节的分组大小，用SERVMAN应用程序将ILP关闭。


  • 分层体系结构 Layered Architecture

    Layered Architecture 分层体系结构 网络操作系统和网络通信系统使用分层体系结构。分层结构为供应商设计与其他厂商的产品有关的硬件或软件提供了一条途径，如果没有开放和标准的协议，那么你就只好完全采用单一厂商的设备。唯一供货商、专卖系统是IBM和DEC在七十年代和八十年代初希望推给顾客的服务方式。然而，台式机器、局域网、客户机／服务器计算导致的异构系统的发展，使得人们对单一厂商提供的专卖网络系统的兴趣越来越小。

    分层是一种设计趋势，它在“协议栈”一级描述不同的功能和服务。图L－4示意了经常用于进行对比的开放系统互联（OSI）协议栈。它被设计成一种开放式结构，任何厂商都能设计出与其他接受标准的厂商开发的产品能协调工作的产品。虽然OSI具有国际性，然而，它却发展缓慢。这主要是由于工业界已经建立了其他一些标准，许多厂商也在支持多协议方面付出了较大的努力。

    协议栈定义通信硬件和软件在不同级如何协调工作。所以如果你想设计一个能够和其他厂商生产的设备卡协调工作的网络接口卡，你就必须接受栈的低层定义协议。栈的上部定义了较高级的通信和应用接口。低层定义在物理介质上传输位流的过程。在高层，分层结构将用户应用程序和下面的通信服务相分离。

    注意：

    低层为高层提供服务。

    每一层都提供一些服务。

    服务由协议定义。

    程序员只需关心与他的工作直接相关的那些层的协议，它们向高层提供服务，并由低层提供服务。

    当系统通信时，在每个系统中的协议栈的每一层的对等协议协调完成通信过程。例如，一个系统的运输层将根据另一个系统的运输层的情况协调它的活动。打个比方，设想在两个使馆之间需要安排一次正式会议，在表面上，两位大使签署正式协议，而在背后，外交官和官员们整理文件，制定日程，并进行其他活动。外交官具有级别，每个级别的外交官为更高级的官员做一些服务。在最高级别的大使向低级外交官下达命令，并使用外交官提供的服务。同时，大使级以下的外交官会与另一个使馆的同等级别的外交官进行协调工作。每个外交官都按照为他们这个级别制定的外交惯例执行。例如，在特定级别的一个外交官员可能提供语言服务或技术文件。根据翻译和归档过程，这个官员与另一个使馆的同等官员进行通信。

    在外交领域，一个使馆的官员只需简单地拿起电话找另一个使馆的同等级的官员。在网络通信领域，在每个协议层的实体们通过对信息打包与对等实体通信，或将它们传递到低层通信服务。最终，分组抵达最低的物理层，变成数据位流，在物理连接间传递。当信息传递过协议层，它们形成一个称为“协议数据单元（PDU）”的分组。每一层的实体按照另一个系统中对等实体预定的消息格式向PDU中加入自己的信息。当分组抵达另一个系统，它向上通过协议栈，给每个实体的信息被取下，并传送给实体。图L－5进一步讨论和示意了这一过程。

    实体，就象不同级别的外交官，驻留在协议栈的每一层，并为高层提供服务。

    一个计算机的实体与另一个计算机中对等地位的实体通信。

    虽然实体与它们的等位实体通信，它们必须利用低层的服务才能使得那些消息得以通过。在信息通过协议栈时，由每个实体附加到PDU的信息称为“协议控制信息（PCI）”。下面列出了在每一级附加的一些信息：

    应用层目标结点地址信息

    表示层增加的码组信息

    会话层增加的通信会话信息

    运输层增加的校验和头

    网络层增加的分组属性／序列信息

    数据链路层增加的分组校验和尾／消息结束

    物理层转换为位流和传送

    服务访问点（SAP）是相邻层的实体用于通信消息的连接点。它们就象地址，任何一个协议在一个时刻都可能会有一些同时发生的SAP活动。

    图L－6示意了当协议数据单元向下传送通过协议栈的多层时发生的情况。利用前面介绍的外交对比，设想大使希望送给另一使馆的大使一个消息。他（她）写了一封信，并交于下一级别的助手。这个助手将信装入信封，并在信封上写明另一使馆和他同等级别的外交人员的地址。这个信件包被传给下一级别的外交人员，他再对这个信件打包，并在信封上写明另一使馆和他同等级别的外交人员的地址。这个过程根据级别进行下去直到到达“物理层”为止。在“物理层”，信件分组被邮差送往另一使馆。在另一使馆，每个外交人员只阅读给他的信息地址，并将里面的信封送给上一级别的外交官。

    两个系统间的通信通过将初始请求在协议栈中下传，通过导线，并在另一系统的协议栈中上递。每一层提供传送信息的特定服务，并允许每一层与另一系统中的对等层进行通信。

    相关条目：Open Systems Interconnection Model 开放式系统互连模型；Packets 包，分组；Protocol Data Unit协议数据单元；Protocols，Communication 通信的协议。


 LCD 液晶显示屏
：最简单地说，液晶显示屏是中间夹有一些液晶材料的两块玻璃板。在此夹层的各个节点上通以微小的电流，就能够让液晶显现出图案，诸如计算器上的数字、PDA上的文本、笔记本电脑显示器上的图像之类的东西。


  • 叶对象 Leaf Objects

    Leaf Objects 叶对象 叶对象是象NetWare目录服务（NDS）系统中的目录树结构中的终结点。目录服务为组织代表实际生命的实体对象提供了一条途径，对象可以是用户、文件服务器、打印机和组（group）等。每个对象包含关于实体的信息，如它的名字、网络地址或用户帐号数等。它也包含一些用于以详细帐目为对象建档的信息，如它的物理位置，系列号、操作员、操作员的电话号和其他有用信息。

    图L－7示意了目录服务的一个例子。这个例子是NetWare 4．x的基于Windows的NetWare管理器的屏幕显示。树的结构如下：

    C＝国别包容器

    O＝组织包容器

    OU＝组织部门包容器

    CN＝公用名

    分组包容器（container）对象可以包含其他对象或其他分组包容器。公共名对象是叶对象。它们终止于树支，并且从它们不能再分支出其他对象。可用分组包容器来组织一个目录树。例如，Cambrian Corp是一个高O层对象，它包括三个OU对象（Administration、Marketing和Sales）。这些对象中的每一个都包含它们自己的对象，但在该例中只有Sales对象被展开显示了。为了整洁起见，其他对象被折叠了。

    目录并不仅用于组织一个公司的资源。它还为对象增设安全性和访问权限提供了途径。例如，网络管理器能够授权部门总管只在特定OU对象内增加用户和资源对象，例如销售部（Sales）。部门内有帐号的用户被限制使用该部门内的资源对象，除非特别授权给他来随意使用组织内的对象。

    相关条目：Directory Services 目录服务；Directory Services，NetWare NetWare的目录服务；GlobalNaming Services 全局命名服务；Name Service名称服务；X．500 Directory Services X．500的目录服务。


  • 自学习桥接器 Learning Bridges

    Learning Bridges 自学习桥接器 自学习桥接器，又称为自适应桥接器（Adaptive Bridges），具有知道哪个网络地址在网桥的这一端，哪个在另一端的“知识”。所以，它知道如何将收到的分组转发。如果有多个网桥，一个网桥可能会将一个分组转发到另一个网桥，并且这个网桥可能再将分组转发进另一个网桥或目的地。当网桥第一次开通，它将消息在网络上广播，并等待返回帧。利用这些返回帧，它得到与它的每个口相连的工作站的地址，并为以后引用建立一张表。当一个分组到达，但却没在表中列出时，网桥再向网络广播（除了原网络），以确定这个新地址在哪里。

    目前市场的大多数网桥都是自学习桥接器。在自学习桥接器出现之前，必须由桥解器安装人员或管理人员在网桥上建立一个网络地址表。自学习桥接器又称为“透明（transparent）网桥”，它们使用遍历树算法，它是IEEE802．1标准。它提供多厂商网桥通信，并为建立没有回路的桥网提供了途径。回路能导致分组在网络上回转和产生错误。

    相关条目：Bridging 桥接。


  • Leased line 专线

    专线，通过专线提供给用户接入公共网络的桥梁。一般的专线有电话专线、分组网专线、DDN专线、ISDN专线、帧中继专线。


  • 租用线路 Leased Line

    Leased Line 租用线路 租用线路是电信公司为某一机构建造的永久性通信电路。租用线路旁路了本地交换电信局（LEC）上的交换设备，所以在每次数据传输之前无需起始阶段，它们总是连通的。如果线路是长距的（LATA间），那么将需要一个长途电信公司，就象联路的另一端的LEC。另外一些电信局，如MCI，在不同的城市区域内也能提供LEC的旁路设施。由于机构将根据合同为线路交付固定的租金，所以称为“租用线路”。

    租用线路的优点是它的质量经过检验并有保证。线路围绕着连接商业与LEC的线路的本地回路，这条线路是可调节的以确保通信质量。所以，在这条线路上有可能使用较高数据传输率。

    租用线路用于建造私用网，在这种情况，一个机构用它自己的交换设备建立自己的远程互连，以充分利用租用线路不受干扰和带宽的优势。使用租用线路和私用交换设备，机构可以保证其安全性和对线路通信的控制管理。然而，与使用X．25和帧中继等公共网络相比，建造和管理私用网是很昂贵的。私用网络需要在每个地点之间都有特定的线路，在每端都有桥接器和／或路由器，所以要互连四个点，就需要六条租用线路。使用公共网络，对每个点只需要一条连到电信局交换网络的线路。

    租用线路既可以是模拟电路，也可以是数据电路：

    模拟电路需要在每个点有MODEM，除非顾客和电信局有合同保证当需要时可立即提供线路使用，一般提供象拨号线相同的数据速率。这种线路比拨号线的质量好。

    数字线路是可调节线路，它可提供比模拟线路更高的数据传输速率。如果需要，传输率可高达45Mbps（对T3线路）。

    标准的数字线路服务是T1信道，它提供1．544Mbps的传输率。T1线路可通过多路选择器传载声音和数据，所以它们常用于在一个机构的远程地点之间进行音频电话连接。一条T1线路可以为音频提供24个信道或为数据提供64Kbps的带宽。不需要全部带宽的顾客可以选择T1的一部分，它可以提供64Kbps的数字服务。相应地，一条T3线路为需要更高带宽的用户提供相当于28条T1线路的能力。

    虽然租用线路通常意味着具有高速的专用数据连通能力，但许多电信局还提供非专用的交换数字电路，以使顾客在需要时才连通不同的场所。例如，一种称为“56交换”的服务为远程场所提供冗余或后援的连接。如果基本线路出现故障或需要增加带宽处理严重阻塞，这条后援线路会被立即接通，进行服务。56交换还为偶尔使用数字服务的用户提供廉价的服务，例如，月末文件传输。一种策略是，将在需要时才拨号连通的基于需求的多条低速数字线路技术与倒置多路复用技术相结合。

    评价租用线路使用情况的网络管理员需要根据传输量的要求，来确定租用线路的价格，并参考是否需要在任何时候都保证线路的不中断连接。如果传输量少，或只在每天的特定时间需要线路，那么使用拨号线路由于价廉而显得更加实际。如果电子函件是发送的唯一一种信息形式，那么拨号线就比较合适，因为只有在电子函件的数据多到值得传送时，才建立连接。

    租用线路通过与本地交换电信局联系租定。如果线路是长途的，你可以与LEC、长途电信局或线路另一端的LEC联系。

    相关条目：Carrier Services 电信服务；Circuit－Switching Services 电路交换服务；Digital Circuits and Services 数字电路和服务；Integrated Services Digital Network综合业务数字网；Local Accessand Transport Area本地访问和传输区域；Public Data Networks 公用数据网；Switched－56 Services 56交换服务；Switched Services 交换服务；和Wide Area Networks 广域网。


  • 保留系统 Legacy Systems

    Legacy Systems 保留系统 保留系统是指某家公司经过很长一段时间使用，并具有多年软件开发和数据积累的大型计算机系统。它们提供不能抛弃的已有服务。建立新的客户机服务器系统以替代现存的保留系统是一种耗资巨大的举动，所以目前存在继续保留现用系统的趋势。然而，现在商务的发展和市场要求公司迅速适应，所以保留系统常常成为阻止公司快速进入市场或获得、整理他们所需信息的障碍。这些信息常常存储在许多系统的组合中，包括保留系统。一些信息可能存储在台式机中，其他一些信息可能存储在远地或公司之外的地方。

    分布式企业计算系统的开发为用户访问多厂商、多协议环境的数据提供了途径。这些系统使用新的软件设计，利用其他应用程序的优点来产生和访问数据。一种策略是保持保留系统，并提供利用用户喜欢的台式机应用程序来获取数据的途径。其他技术包括使用象大型信息仓库那样的系统。

    相关条目：Database Connectivity APIs and Middleware数据库连接应用程序编程接口和中间件；Distributed Computing 分布式计算；Distributed Database 分布式数据库；Information Warehouse信息仓库。


  • 许可证服务器 API Licensing Server API

    Licensing Server API（LS API） 许可证服务器 API（LS API） 许可证服务器API（LS API）是Microsoft、Lotus、Novell和许多其他厂商，为定义应用程序和NetLS许可证服务器如何共同工作以跟踪软件的使用和许可而建议的许可证标准。服务器从根本上赋于了应用程序为客户运行的能力。然而，LS API仍需要和其他许可证服务器标准协同工作。

    相关条目：Electronic Software Distribution and Licensing电子软件分发和许可。


 Light Cabel 光缆
：光缆是一种光束传输的介质。数字化的声音及数据沿着直径只有微米级的细细的玻璃光缆，以光束而非电子脉冲的形式进行传输。在理论上，光缆的传输速度可达到光速。具有高带宽，允许每秒传输45兆位。


  • 线路调节 Line Conditioning

    Line Conditioning 线路调节 一条可调节线路是指经过性能改进处理可高速传送数据的电话电路。T1线路就是一种可调节线路。

    相关条目：Digital Circuits and Services 数字电路和服务；Leased Line 租用线路；T1／T3 Services T1／T3服务。


  • 链路访问规程 Link Access Procedure

    Link Access Procedure（LAP） 链路访问规程（LAP） 链路访问规程首先是CCITT为使用X．25分组交换网络建议的一种数据链路层协议。LAP是高级数据链路控制（HDLC）的一个子集。后来，CCITT建议采用LAP－B（B：平衡）协议。

    LAP－B是为点对点连接而设计的，所以它的地址域无需确定第二个站点。它为异步平衡模式数据传输会话提供了帧结构、出错处理和流控机制。在X．25分组交换网络中，为中继链路到链路（link－by－link）出错处理和流控设置了多虚电路，它优于LAP－B，LAP－B是当分组到达网络的每个链路都需要发回确认信息的电路。

    链路访问规程D－信道（LAP－D）是CCITT建议的I系列的一部分。它是为综合业务数字网络（ISDN）连接的D信道而设计的。D信道是一种ISDN的信号传载信道。它与传输音频和数据的B信道共存。D信道也能传输分组交换数据。LAP－D为建立复杂信道，并在两点之间获得多逻辑链路提供了途径。帧结构是典型的，它包括标志、地址信息、控制信息、数据、帧检测序列和结束标志。地址能够确定服务的类型，例如是音频和数据，并终止服务。相关条目：High－level Data Link Control高级数据链路控制；Link Access Procedure链路访问规程；Logical Links 逻辑链路；Synchronous Communications 同步通信；Synchronous Data Link Control同步数据链路控制。


  • 链路层 Link Layer

    Link Layer 链路层 参见Data－Link Layer数据链路层；OSI Model OSI模型；Logical Links 逻辑链路。


  • NetWare的链路服务协议 Link Services Protocol，NetWare

    Link Services Protocol，NetWare NetWare的链路服务协议 Novell的网间分组交换（IPX）协议的后继是NetWare的链路服务协议（NLSP）。它通过用链路状态路由选择算法（link－state routing algorithm）替换服务广告协议SAP（Service Advertising Protocol）和路由选择信息协议RIP（Routing Information Protocol），从而改进了网间性能。链路状态路由选择方法比路由搜寻过程提供了更多的控制，使得在路由失效时，可以很快地建立起新的路由。路由选择可以基于避免拥挤的区域、线路的速度、使用线路的成本或其他特征。NLSP基于开放最短路径优先（OSPF）和中间系统对中间系统（IS－IS）算法。

    相关条目：Internetwork Packet Exchange 网间分组交换；Routing，NetWare NetWare的路由选择；和Routing Protocols路由选择协议。


  • 链路状态路由选择 Link State Routing

    Link State Routing 链路状态路由选择 链路状态路由选择为控制路由选择过程，并使路由器对网络的变化反应迅速（如链路断开或增加新的路由器和网络等）提供了途径。路由选择可以基于避免拥挤的区域、线路的速度、使用线路的成本和其他特征。Dijkstra算法用于计算到目的地的最短路径。最通用的链路状态路由选择法是优先开放最短路径（OSPF）法。

    相关条目：Routing Protocol 路由选择协议。


  • 负载平衡桥接器，负载平衡网桥 Load－Balancing Bridges

    Load－Balancing Bridges 负载平衡桥接器，负载平衡网桥 负载平衡网桥通过增加线路并根据线路的通信量进行负载平衡，为提高两点间的通信带宽提供了途径。例如，使两条长途线路看上去象一条具有上述两条线路带宽的电路。当进行桥接和合并线路时，需要使用负载平衡网桥。

    相关条目：Bridging 桥接。


  • 本地访问和传输区域 Local Access and Transport Area

    Local Access and Transport Area（LATA） 本地访问和传输区域 （LATA） 地方贝尔运营公司（RBOC）根据特定地理区域进行工作，这些区域分别称为“本地访问和传输区域（LATA）”的服务区域。LATA是在1984年AT＆T重组时提出的，它们总共有近200个。独立电信局（ITC），不属于Bell，但也在LATA区域内提供服务。它们的服务通称为“LATA间”服务，并在LATA内提供所有服务和收入。电信公司，无论是RBOC或ITC ，都被看为本地交换电信局（LEC）。

    LATA之外的任何服务都是LATA间服务，这些服务由交换电信公司IXC（interexchange carriers）提供；有许多IXC，如MCI、US Sprint、ITT和AT＆T等。所有的LEC都必须对他们的LATA区域提供称为“访问点POP”（point－of－presence）的交换公司。

    相关条目：AT＆T；Local Exchange Carrier 本地交换电信局；Local Loops 本地回路；RegionalBe1l Operating Companies地方贝尔运营公司；WideArea Networks 广域网。


  • 局域网 Local Area NetWorks

    Local Area NetWorks（LANs） 局域网（LANs） 局域网将工作小组、部门或建筑物内的计算机连接在一起。和此相反，Internet是建筑物内的多个LAN，或多个建筑物的LAN，以及校园内的LAN的集合；广域网是网络互联，它覆盖很大的地理区域，并需要利用公共或个人通信把每个区域连接在一起。

    相关条目：Networks 网络。


  • 局域传输协议 Local Area Transport

    Local Area Transport（LAT） 局域传输协议（LAT） 局域传输协议是数字设备公司DEC为在DECnet环境通过连接LAN终端服务器将终端连接到主机系统而设计的DEC协议。终端服务器是一种连接到网络（如以太网络），并为ASCII终端的连接提供一些端口的设备。终端通过RS－232电缆连接到终端服务器。LAT软件可以有效地在一条物理线路上对多个终端的访问请求进行多路选择。

    使用LAT的一个典型设备是DECserver 90TL，它为高速地异步连接到UNIX、ULTRIX、VMS、DOS和多厂商网络设备提供了途径。这种设备具有多会话终端连接，可提供高达57．6Kbps的带宽。它支持LAT、TCP／IP、Telnet和串行链路网间互联协议SLIP等协议。

    LAT不承认相应于开放系统互联OSI的网络层，所以它不能被路由选择。协议的设计人员假设分组只能穿过一个网络。他们并没有将此协议设计成可用于广域网，虽然一些公司提供可以这样做的设备。分组不携带进行路由选择所需的足够信息。它没有域来指明信息分组在传送到目的地的过程中可能需要的逻辑网络。

    相关条目：DECnet DECnet网。


  • 本地交换电信局 Local Exchange Carrier

    Local Exchange Carrier（LEC） 本地交换电信局（LEC） 地方贝尔运营公司（RBOC）是一家LEC，它在定义为局部访问和传输区域（LATA）的区限内进行工作。在LATA之外的服务被认为是长途的，可以公开竞争。

    相关条目：AT＆T；Local Accessand Transport Area本地访问和传输区域；Regional Bell Operating Companies 地方贝尔运营公司。


  • 本地组 Local Groups

    Local Groups 本地组 本地组是在Windows NT环境中定义的。所有的网络操作系统提供组管理特征以简化对大量用户授权和许可的任务。你创见了一个用户帐号，然后将这个帐号加到一个组。Windows NT包括一些具有预先定义访问权限的预定义组，使它们的成员具有在系统中执行不同任务和动作的能力。

    有两种类型的组：本地组和全局组。本地组只在组定义的工作站上有权限。注意这里假设在本地计算机上有多个用户。一个典型的本地组是特权用户组（power user group），它包括一些具有某些管理本地计算机的能力，但却没有管理人员权限大的用户。全局组包括当前计算机之外的用户。典型的全局组是网络，它包括网络上通过其他计算机访问服务器的任何人。

    相关条目：Users and Groups 用户和组；Windows NT，Microsoft Microsoft公司的Windows NT。


  • 局部环路 Local Loops

    Local Loops 局部环路 该术语定义为用户场所到本地电信局的铜质电话线。它是目前通信系统的主要瓶颈，因为现在电信局之间的线路都是高速光缆。

    相关条目：AT＆T；Local Accessand Transport Area本地访问和传输区域；Regional Bell Operating Companies 地方贝尔运营公司。


  • 本地过程调用 Local Procedure Calls

    Local Procedure Calls 本地过程调用 参见Interprocess Communication进程间通信。


  • LocalTalk网 LocalTalk

    LocalTalk LocalTalk网 它是一种定义AppleTalk分组在超过230．4Kbps的电缆系统上传输的局域网（LAN）协议。LocalTalk原来称为AppleTalk，但Apple公司在1989将名称改为LocalTalk。现在Apple计算机网络体系结构称为AppleTa1k，它包括在LocalTalk网络上操作的协议。

    如图L－8所示，原始的LocalTalk系统基本上是为将一些Macintosh计算机连到Apple Laser Writer打印机上而设计的。注意Laser Writer打印机可直接连接到网络上。当用户准备好要打印时，打印机作为一个可选项自动在接连的Macintosh工作站的菜单上出现。

    LocalTalk网络具有如下特征：

    LocalTalk是一种用菊花链形式的双绞电话线相联的物理总线拓扑结构，如图L－8所示。

    网络的总长度不能超过1000英尺，但附加的网络可以通过中继器、网桥或路由器和它相连。

    传输速度是230．4Kbps。

    在一个网络段可以连接多达32个结点，但对20个以上结点的忙碌网络，性能下降很快。

    可以在避免全部系统停止的情况下增加一个站点到网络。

    每一台Macintosh机器都内置有对LocalTalk的支持，所以用户可以无需特殊软件就能访问连接的象打印机这样的外设。

    可选象Apple Share这样的共享文件服务，但Macintosh系统7中现已有文件服务，所以用户就可以在他们的系统上与其他用户共享文件了。

    LocalTalk可以很容易地与象EtherTalk或TokenTalk这样的其他网段相连。

    除非使用第三家的设备，否则不支持用IPX和TCP／IP这样的其他协议。

    对于象基于Intel系统这样的非Macintosh机器，也可以得到LocalTalk网卡，从而使这些计算机通过安装适当的软件也能访问与网络相连的外设和加入文件共享。

    许多Macintosh的电缆是现成的，可以是屏蔽或非屏蔽的双绞线电缆。当然，你也可以建立你自己的电缆。有时也选用红外线连接方式。

    使用内置LocalTalk支持，用户仅仅需要将他的计算机和外设用合适的电缆和连接器连接在一起。象Farallon这样的公司生产的产品可以利用现有电话线和连接器。也就是说，你可以使用电话电缆中的一些额外的电线作为网络电缆，然后将每个计算机和外设连接到和电话相连的特殊插头上。需要为LocalTalk网络布缆的读者可以从Black Box公司（4112／／746－550）免费得到称为“Connectivity for Macintosh”的产品目录。

    AppleShare是一种在专用或非专用计算机上提供集中式文件服务的可选软件包。Macintosh的系统7同时还包括了共享文件软件。没有这些服务，LocalTa1k用户只能访问连接到网络的外围设备。使用共享文件服务，用户可以在一个中心地（Appleshare）共享文件，也可以使其它用户在他们的系统上就能访问这些文件（系统7）。这两个系统都有安全性特征，可以排除一些用户或提供不同级别的文件访问，如可以限制为可修改一个文件或只能阅读。

    Setting Up the Network 建立网络

    建立一个LocalTalk网络的基本原因是为了共享象激光打印机这样的昂贵设备。另外，用户往往需要共享文件。还有一个基本原因就是为交换电子函件。用LocalTalk，这些要求是比较容易满足的。这是一种既廉价又容易安装的解决方式。由于时间的原因，许多LocalTalk网络只是简单地用地毯下的电线连在一起。在多数情况下这样做没有什么问题，但如果网络本身对商务活动非常重要，将电缆安全地布在墙内以防止扯拉电缆或损坏也许是一个好主意。专业的电缆安装人员会将主干电缆布在墙内，而提供一个表面插板用于联入网络。

    另一种方式是使用现成的电话电缆。在电缆上通常有一对额外的电线可以使你用于传输数据。如图L－9所示，这些线连到用于放电话设备的柜子。来自墙上连接器的引线连接到分线盒（punchdown block）。然后，将另一根线从分线盒连接计算机的引线连接到一个集线器上。象在“布缆”中讨论的那样，可以用接插板或50线电缆完成这一工作。集线器就象一个中继器一样，集线器的每一个分支都可以被看为是它自己的网络。这意味着每个分支都能达到最大长度，并能有多达32个工作站。另外注意，在每个分支都可以连接多个设备。

    在电缆的每一端都需要一个终结器，以防止信号回馈。终结器内置于Apple原来提供的连接器模块。如果连接器没有使用，它们自行终止。新的设计要求你在电缆或菊花链线的端点插上终结器。

    集线器是一种使你能象上述讨论的那样和一些LocalTalk分支连接的设备。这些集线器被称为“多端口集线器”，集线器上的每个端口可提供到网络独立分支的一种连接。每个分支自身可是 个支持最大距离和特定工作站数目的网络。多端口集线器中继从一个端口到另一个端口的信号。同样，你也可以使用过滤和孤立通信量的网桥，这样通信信息就会继续停留在它们所处的网络，而不是向每个网络广播。用这种孤立通信量方式有利于防止过量的通信量降低每个独立的LocalTalk分支的性能。象Black Box等公司生产不同的设备来扩展LocalTalk网络的能力。这些产品包括：

    以太网到LocalTalk的多协议路由器。

    从LocalTalk工作站访问Sun NFS主机的设备。

    诊断软件和为LocalTalk网络归档的管理软件。

    相关条目：AppleTalk AppleTalk网；Cabling 布缆，Networks 网络。


  • 逻辑链路 Logical Links

    Logical Links 逻辑链路 逻辑链路是实际电路或逻辑电路上交换通信信息的两个端系统之间的一种协议驱动通信会话。协议栈定义了两个系统在某种介质上的通信。在协议栈低层定义可用的多种不同类型的通信协议，如局域网络（LAN）、城域网（MAN）和象X．25或帧中继这样的分组交换网络。逻辑链路在物理链路（可以是铜线、光纤或其他介质）上的两个通信系统之间形成。根据OSI协议模型，这些逻辑链路只在物理层以上存在。你可以认为逻辑链路是存在于网络两个末断系统间的线路。

    面向连接的服务 为了保证可靠的通信，需要建立逻辑线路，但在两个端系统间要维持会话。

    面向需要应答连接的服务 分组传输并有返回信号的逻辑线路。这种服务产生更大的开销，但更加可靠。

    无应答不连接服务 无需应答和预先的传送。在端系统间没有会话。

    OSI协议栈中的数据链路层可进一步细分为较低的介质访问控制（MAC）子层和较高的逻辑链路控制（LLC）子层。当它接收到一个分组后，它从MAC子层向上传送。如果有多个网络和设备相连，LLC层可能将分组送给另一个网络。例如，在一个NetWare服务器上，你可能既安装了以太网络适配器又安装了令牌网络适配器，NetWare自动地在连接到适配器的网络间桥接，这样原来在以太网上的分组就可以传送到令牌网上的目的地了，LLC层就象网络段间的交换或链路中继，它将以太网的帧重装成令牌环网的帧。

    相关条目：Connection－Oriented and Connectionless Protocols面向连接和无连接协议；Data－Link Layer OSI Model OSI模型的数据链路层；Layered Architecture分层体系结构；Open Systems Interconnection Model 开放式系统互联模型；Protocol Stack协议栈。


  • 逻辑单元 Logical Units

    Logical Units（LUS） 逻辑单元（LU） 逻辑单元（LU）是进入IBM系统网络体系结构（SNA）的网络端口，通过它用户可以访问网络资源，或一个程序员与另一个程序员通信。

    相关条目：Advanced Peer－to－Peer Networking 高级对等联网；Advanced Program－to－Program Communications 高级程序对程序通信；IBM Mainframe Environment IBM的大型计算机环境；Systems Network Architecture，IBM IBM系统网络体系结构。


  • 登录原语 Login Scripts

    Login Scripts 登录原语 登录原语对建立网络用户环境是很关键的。登录原语是用户登录时执行的一串命令。在登录原语中的命令能够为用户映射网络驱动程序，将它们切换到特定驱动程序、显示菜单，并启动应用程序。NetWare服务器的登录原语有许多扩展的特征，所以在下面它将作为例子讨论。

    在许多网络操作系统，如Windows NT和Novell NetWare，为每个用户都有一个登录原语与登录帐号相连。当用户登录时，这个原语执行。在NetWare 4．x，有三种登录原语，当一个用户登录时，它们中的任何一个都可能执行：

    系统登录原语第一种是系统登录原语，它为每个属于特定单位（这里单位指特定的目录或子目录）的用户执行。单位就象部门或公司的分支。例如，如果用户属于销售部，为销售单位对象的登录原语执行。

    描述登录原语第二种是描述登录原语，它能够属于不一定在同一单位，但在同一组的用户。例如，一个描述登录原语能够专为经理们执行命令。

    个人登录原语每个用户都有自己的个人登录原语。超级用户可以产生原语，用户可以创建或修改他自己的个人登录原语。

    注意：如果没有创建个人登录原语，就运行省缺的登录原语。即使在系统和描述登录原语执行时，也是如此。

    当用户登录时，系统登录原语首先执行，接着执行任何一个描述登录原语，最后执行个人登录原语。

    The Default Login Script 省缺登录原语

    新的NetWare 4．x网络，存在一个简单的省缺登录原语。多数管理人员可以通过创见新的登录原语来忽略这个省缺登录原语。下面为你列出了一个省缺登录原语，作为例子来帮助你了解登录原语，注意这个登录原语中的多数命令是MAP命令，这是一条典型命令。每一行的开始数字并不属于登录原语；后面解释了它们的含义。

    1．WRITE“Good％GREETING－TIME，％LOGIN－NAME．”

    2．MAP DISPLAY OFF

    3．MAP ERRORS OFF

    4．MAP *1：SYS：

    5．MAP *1：＝SYS：％LOGIN －NAME

    6．IF“％1”＝“ADMIN”THEN MAP ＊1：＝SYS：SYSTEM

    7．MAP *2：＝SYS：PUBLIC＼OS2

    8．MAP INS S1：＝SYS：PUBLIC；

    INS S2：＝SYS：PUBLIC＼％MACHINE＼％OS＼％OS－VERSION

    9．MAP DISPLAY ON

    10．MAP

    带百分号的参数表示用户环境中变量的登录原语指示符，例如在登录时提供的名字，或系统上运行的DOS版本号。下面逐行对登录原语进行解释：

    1．本行显示象“Good morning，JONES”这样的欢迎消息。指示符变量％GREETING－TIME的值依赖于当前时间，％LOGIN－NAME是用户用LOGIN命令键入的名字。

    2．本行阻止MAP命令显示信息。使用它们是为了美观。

    3．第三行阻止错误显示。

    4．第四行将第一个驱动映射到SYS：卷宗。这种映射只在用户没有起始目录时才使用，否则下一命令将忽略这一命令。

    5．本行将第一个驱动映射到用户的起始目录。如果该目录不存在，上一行的映射将保留。

    6．如果用户的登录是ADMIN（NetWare 3．x的SUPERVISOR），本行命令将第一个驱动映射到SYS：SYSTEM目录。

    7．如果用户从一个OS／2工作站登录，才在登录原语中包括本行命令。它将第二个驱动映射到SYS：卷宗的PUBLIC目录的OS／2实用子目录。

    8．本行是一个多命令行，分号分离了两个独立的映射命令。如果用户在DOS或Windows工作站上工作，该行才执行。

    9．本行恢复映射信息的显示。

    10．本行显示被映射驱动的表。

    在最后一条命令执行之后，用户可以与被映射的驱动表一起，看见命令提示符。

    Login Script Command Listing 登录原语命令表

    下面是NetWare 4．x中可用的登录原语命令的简明清单：

    ＃（外部程序命令）从登录原语中执行外部命令。在＃号后放置命令和它的路径。

    ATTACH 用ATTACH与一个基于装配（bindery-based）的NetWare文件服务器连接。在命令之后键入

    服务器名和用户名，或在命令执行时由用户指明服务器名和用户名。

    CLS 清屏幕

    COMSPEC 指明DOS COMMAND．COM文件存在的目录。

    COONTEXT 在NetWare 4中，本命令显示在目录服务层次树中用户的现行文本。

    DISPLAYAND FDISPLAY显示辅助文本文件的内容。这个文件可以包含文本信息或消息。

    DOS BREAK 指明当使用CTRL+BREAK或CTRL＋C键时，DOS可被中断。

    DRIVE 使用本命令交换到其他驱动程序。在命令之后指明驱动程序的字母。

    EXIT 使用本命令停止登录原语中的命令执行。通常在一种状态被评价是真或假之后，与IF．．THEN语句一起使用。

    FIRE PHASER 用声音提醒用户注意屏幕信息或其他状态。

    GOTO 转移到登录原语中的不同部分，通常在IF．．THEN语句之后使用。在GOTO命令之后指明一个与登录原语中的标志匹配的标志。

    IF．．THEN 根据前提为真或相等，确定指令的执行。如果为真，命令被执行，或在IF．．THEN语句之后并在END语句之前的所有命令被执行。

    INCLUDE 使登录原语执行一个外部登录原语中的一组命令。

    LASTLOGINTIME 显示用户最后登录的时间。

    MACHINE 指明用户登录的机器名字。

    MAP 将驱动程序号赋于目录，为用户简化访问。

    NO－DEFAULT 在NetWare 4中，在系统或描述登录原语中使用本命令，可阻止省缺个人登录原语的执行。

    NOSWAP 在NetWare 4中，使用本命令可阻止在工作站缺少内存时，LOGIN被从基本内存移动到高端内存或硬盘上。

    PAUSE 暂停登录原语的执行。

    REMARK 使用本命令在登录原语内包含注释。当登录原语执行时，不出现注释。在REMARK后键入注释。

    SET 使用本命令创建可以在登录原语执行后的批处理文件中使用的变量。

    SET－TIME 将工作站的时间设置为和用户登录的服务器一样的时间。

    SWAP 将LOGIN命令移动到高端内存，以空出基本内存让＃命令能够执行。

    WRITE 显示信息和其他文本。在WRITE命令后键入文本。

    相关条目：NetWare；Novell。


  • 用户登录和登录帐号 Logons and Logon Accounts

    Logons and Logon Accounts 用户登录和登录帐号 登录是指用户为访问特权系统而进行的过程，特权系统如文件服务器、数据库或实际网络。用户首先执行将工作站连接到网络的软件，与网络服务器建立通信信道，这个过程通常在开启工作站时自动进行。接着，用户键入LOGON或LOGIN。然后，登录进程询问用户帐号和密码，如果用户有一项内容输入得不对，通常登录进程还会给用户继续登录的机会，但如果在输入相应信息时，连续若干次错误，登录进程就假定用户是非法侵入者，从而拒绝用户继续试图登录。

    当用户登录成功后，就成了网络的合法成员，就获得了预定的对网络资源的使用权限。例如，NetWare 4．x服务器能够对用户鉴别，在鉴别之后，可以向其他服务器证实用户的身份。利用这种方法，用户只需登录一次，而不是在每次访问资源时都必须登录。

    用户为进行登录必须在系统上有一个帐号。这个帐号有用户的登录名称、访问权限和当用户登录时可以执行多条命令的登录原语。例如，登录原语可以设置不同路径的映射和显示为用户专门设计的菜单。特权用户可以对用户帐号附加登录限制。

    登录限制可以限定用户能够登录的时间，在若干小时后阻止用户进行登录。

    登录限制可以指明用户进行登录的工作站，防止用户从不受监控的工作站上进行登录。

    登录限制可以要求特殊的密码，进而强迫用户创建一个和用户现在使用的密码不同的密码。

    登录限制可以为帐号定义终止日期，在一定的时间之后就对用户关闭。

    相关条目：Account 帐号；User Network 用户网络；Authentication and Authorization鉴别和授权；Usersand Groups用户和组。


  • Lotus的Notes软件 Lotus Notes

    Lotus Notes Lotus的Notes软件 Lotus Notes是一种企业级的、基于客户机／服务器的工作小组应用程序，目前还没有类似的产品。它是为在大型网络环境集成信息，产生表格和文件流而设计的。这一产品非常昂贵。Notes常被称为工作流软件，这是因为它可以自动整理一个机构内的文档流，并帮助单位机构更好地处理项目管理、帐目处理，以及其他一些需要许多人参加的事务活动。它是一种帮助一个小组内的人（即使这些人在不同的地方）共同工作的协作软件。虽然对用户，Notes可以被比为一个数据库管理系统，但这两者有严格区别。Notes对非结构数据非常合适，并能很好地支持多媒体数据类型。根据用户定义的准则，它的消息系统在需要的时候告诉用户何时，如何协作。最近的估测表明，至少有300，000 Notes软件的用户。

    Notes软件包括一个用户可以建立、发送、接收消息的电子函件消息系统。它还包括一个地址薄和为组织接收到的信息和管理储备信息的管理功能。Notes消息提供复合文档特征，所以消息可以包括文本、图和多媒体信息。Notes包括允许用户在域内存储信息，再根据其他域安放信息的表格管理特征。分布式文档部件为分布式网络环境的代理们提供了一条轻易共享文档的途径。下面描述了Notes的其他一些特征：

    Notes可被许多网络支持，如AppleTalk、Novell NetWare、Banyan VINES、IBM APPC、TCP／IP和X．25。

    用户可以从工作前端应用程序访问Notes系统，如字处理器、数据库和电子表格应用程序等。

    支持Microsoft的对象链接和嵌入（OLE），所以用户可以创建和交换包括文本、图、电子表格数据，以及其他用户创建的连接到文件的信息等的复合文档。

    文档按一定的方式建立索引，使得用户可以基于作者、日期、部门，或任何关于文档内容的信息来对文档进行访问。

    安全性特征包括RSA加密和鉴别系统。

    Lotus Notes使用域（domain）的概念来建立管理区域和用户组。域包括一个或多个共享公共名和地址薄的数据库的Notes服务器。数据库包括关于每个域中的用户信息，例如它们的函件地址、函件加密信息和关于域中的其他Notes服务器的信息。域还提供对其他产品的引入集成服务。

    最新版本的Notes已经指明是为在分布式企业级环境的应用软件开发而设计的。现在，它具有高级编程能力和表格处理特征。用户能够通过这些功能来自己设计基于Notes的应用程序，而这种任务对许多机构来说都是由专业程序员来完成的。编程语言是基于Lotus 1－2－3中的宏语言的。

    相关条目：Compound Documents 复合文档；Groupware 群件；Object Linking and Embedding对象链接和嵌入；Workflow Software 工作流软件。


  • LPT 打印终端

    打印终端(line print terminal)，LPT是用于使用打印机或其它设备的。大多数计算机都有一个或两个LPT，通常称为LPT1和LPT2，有些计算机支持三个LPT，称为LPT3，但无论它们有几个，名字如何，LPT1是默认的LPT。当用户需要增加新的设备时，可以加入一个并行口适配器即可。这里需要注意的是，不要以为LPT只能用于输出，它也可以用于输入。


  • LPT 打印终端接口

    Line Print Terminal。打印终端接口。在PC机上，最常用的连接打印机、扫描仪或者数字照相机的并行端口。LPT端口局限在LPT1、LPT2、LPT3等等，但是每台计算机至少拥有一个LPT端口。如果需要更多的，可以通过安装并口卡来增加。


  • LU 6．2协议 LU 6．2

    LU 6．2 LU 6．2协议 参见Advanced Program－to－Program Communications高级程序对程序通信。


  • Mac OS Mac操作系统

    Mac 操作系统，Macintosh operating system 的缩写。从1994年9月的7.5版开始，Apple向其他计算机厂商发布软件时，对 Macintosh 操作系统使用的名字。


  • Mainboard 主板

    主板是电脑系统中最大的一块电路板。主板上市满了各种电子元件、插槽、接口等。它们各司其责，将各种周边设备紧密地联系在一起。如果把CPU比作人的心脏，那么主板就可比作血管神经等循环系统等。有了主板，CPU才可以控制诸如硬盘、软驱、键盘、鼠标、内存等周边设备。目前的主板结构主要有AT和ATX结构，不同结构的CPU所用的主板不一定相同。


  • Mainbus 系统总线

    系统总线是连接扩充插槽的信息通路。目前ISA和PCI总线是目前PC机常用系统总线。ISA的总线频率一般为8MHZ，而PCI的一般则为33-66MHZ，目前由于PCI结构总线速度快成本低。所以已经基本代替ISA。现在的主板PCI插槽一般在4个以上，而ISA插槽则在3个以下。


  • MAN 城域网

    城域网(Metropolitan Area Network)。城市范围内的，传输速度可以达到200Mbit/s或者更快的网络。传输距离一般在75公里以内。一个城域网可以包括一个或者多个局域网(LAN)。其传输的距离和速度介于局域网和广域网(WAN)之间。


  • MCSE 微软认证系统工程师

    微软认证系统工程师(Microsoft Certified Systems Engineer)，这是一个微软办的考试，主要内容就是NT操作系统的内容，还有一些网络的内容。或许因为我们太会考试了，我们说它不难，可是要学会其中的知识，还是要费许多力气。


  • Memory Stick 存储棒 Memory Stick

    Memory Stick 存储棒

    “存储棒”是由索尼公司开发出来的一种数字式数据存储技术，存储容量等于一片3.5英寸软盘的10倍。索尼公司正在市场上大力推广“存储棒”技术，有意使该技术成为一种在不同种类小型电子设备（如数字相机和便携式数字摄像机等）之间共享和传输图片，声音以及其它数据的新方法。“存储棒”的体积相当于一节普通的AA电池，存储容量分别有4MB，8MB，16MB，32MB和64MB。“存储棒”的体积要比较存储容量相当的其它数据存储设备小，这些数据存储设备包括“智能媒体”和小型闪速内存等。

    在2000年中旬之前，索尼公司生产的Vaio系列笔记本电脑是世界上唯一一种拥有一个“存储棒”插槽的笔记本电脑。不过，任何一种拥有一个PC卡插槽的笔记本电脑都可以通过安装一种适配器来使用“存储棒”。和以前的软盘一样，“存储棒”拥有锁住机制，可以防止存储的数据被以外删除。“存储棒”拥有一个10针的连接器。

    为了使“存储棒”成为一种通用的便携式存储媒介，索尼公司已经向Adobe公司，先锋公司，卡西欧公司和夏普公司等企业发放了“存储棒”技术的使用许可证。最近，索尼公司还推出了采用“存储棒”技术的Walkman随身听和数字式录音机。


  • IBM的消息排队接口 Message Queuing Interface（MAI），IBM

    Message Queuing Interface（MAI），IBMIBM的消息排队接口（MAI） IBM的消息排队接口（MAI）是一个基于消息的应用程序接口，它监督在不同平台上的应用程序之间传送消息。它在IBM联网方案中定义。

    相关条目：Application Program Interface应用程序编程接口；IBM Networking Blueprint IBM的联网方案；Messaging API，Inter－Application 应用程序间的消息传送API。


  • 消息传送代理 Message Transfer Agent

    Message Transfer Agent（MTA） 消息传送代理（MTA） 在国际电信联盟（ITU）的国际电报电话咨询委员会（CCITT）开发的X．400信报处理系统中，一个信报传送代理（MTA）就象一个邮电局，通过它在系统间交换消息。MTA提供存储转发服务。参见“X．400信报处理系统”。

    Microsoft的信报传送代理（MTA）代替了Microsoft的邮件网关。MTA链路在Windows for Work Group和其他Microsoft产品间创建了一个电子函件系统。


  • E－mail的消息传递 API Messaging API，E－mail

    Messaging API，E－mail E－mail的消息传递 API 使用信报传递应用程序编程接口（API），可以在不同的邮件系统上直接从用户应用程序提供企业电子函件交换。在这里列出的API为用户的前端应用程序访问不同的后端消息传递系统提供了途径。这些API帮助开发人员将电子函件支持集成到他们的应用程序中。它们在消息传递服务和应用程序间定义了一种接口，另外提供象文件附件和编址这样的服务。

    信报传递API（MAPI）一条为应用程序访问象Microsoft Mail、Lotus Development的cc：MAIL、Novell的信报处理服务（MHS）这样的应用程序的途径。MAPI定义程序员可以使用的调用过程，以将电子函件接口建到他们的应用程序中去。例如，用户可以通过使用菜单上的电子函件选项，来在使用Windows字处理程序的同时，编址、发送和接收电子消息。用户可以在程序中写一个便条，并将它包含在一个发送的电子函件消息中。

    厂商无关消息传递（VIM）一种Lotus控制的电子函件API，它被Apple、Borland、IBM、MCI、Novell、Oracle、Word Perfect等电子函件开发商和厂商支持。象MAPI一样，VIM是一种跨平台的API，它使得开发商能够建立可在多种不同平台上工作的邮件激活应用程序，并允许在这些不同的平台上共享邮件。

    公用邮件调用（CMC）这种电子函件API，是工业范围的电子函件软件开发商组织建议的，由X．400应用程序编程接口协会（XAPIA）开发，以解决MAPI和VIM之间的不同。CMC得到了工业界的强烈支持，有望成为一种工业标准。

    Apple开放协作环境（AOCE）它是集成到Apple系统7中的电子函件API。这种Apple技术是为联合电子和工作组通信而设计的，如语音邮件、电子函件和传真等。AOCE包括PowerTalk和PowerShare。Power Talk提供了一个国际性的信箱，拉放（drag and drop）文件邮递、数字签名等，并驻留在Macintosh和PowerBook计算机上。Power Share驻留在AppleTalk服务器上。它为PowerTalk用户在使用电子函件时具有存储转发特征，它的鉴别部件支持网络安全性，它还具有集中管理功能。

    标准消息格式（SMF）它是Novell消息管理服务（MHS）中的消息传递接口。象其他API一样，它允许用户不离开工作地的应用就可以发送消息。SMP与NetWare全局消息传递一起工作，后来简单邮件传递协议（SMIP）、IBMSNA分布服务（SNADS）和X．400信报处理系统等也对它提供支持。相关条目：Electronic Mail 电子函件；Message－Enable Application 消息激活应用程序。


  • 应用程序间的消息传递 API Messaging API，Inter－Application

    Messaging API，Inter－Application 应用程序间的消息传递 API 虽然消息传递在对等层环境也可以实现，应用程序间的消息传递则是一种在前端应用和后端服务器间的客户机／服务器环境下实现的典型技术。虽然也可以使用实时模式，但消息传递使得应用以非实时、先存储再传送的方式交换命令和信息。首先创建一个消息，然后将它传送到目的地，在目的地对它进行处理之前，它可能会先存储。另外，消息可能存储在能够处理过程间消息传递的一个独立的地方，不要将消息传递与电子函件系统混淆。虽然它们有相似之处，但电子函件系统是为在用户间交换消息而设计的。

    一种面向消息的事务，是使用存储再转发技术的无连接事务。一个应用程序以消息的方式发送一个请求或命令，然后等待回答。在这两个系统之间没有同步，发送方可以将消息广播给任意多的其他系统。它的一个重要特色是，在客户机和服务器之间没有通信“会话”或连接。服务器可以在很长时间之后再有反应。由于消息传递系统不是实时工作的，所以对于实时任务关键的应用程序使用它是不现实的。然而，对于较慢传输率的广域网连接的分散系统，采用消息传递系统的工作却是很合适的。首先，广域网链路的延迟就使实时应用不合适。

    相反，远程过程调用（RPC）是用于进程间通信的面向连接的机制。在客户和服务器间建立了一个会话，它保持到进程或事务处理完毕。这种连接需要一个建立期，具有一定开销，但提供了请求回答式的可靠、有效的传输。

    一个消息传递模式需要在数据交换的两端都有队列管理。一个消息在源端创建，再分送到和目的地相关的队列中。管理队列通常是异步的，在另一个事件出现之前，前一个必须处理完毕。然而，消息可以被分配到多个处理器，这样它们每个都能并行处理一个任务。通常采用双向队列，这样两个系统就可以同时发送消息了。

    消息传递系统可以对应用程序隐藏下面的通信协议，这样，一个在网络间分组交换（IPX）环境运行的应用程序，就可以和一个在传输控制协议／Internet协议（TCP／IP）环境运行的应用传递消息了。由于应用程序只需简单地识别消息格式和命令，所以应用程序接口间的差异也就很小。和此相对，信报传送系统是一种“中间件（middleware）”。中间件产品是程序员和开发人员在制作应用产品时隐藏下面的操作系统、通信协议和多厂商产品的复杂性时使用的工具。它使得无需开发人员将大量时间花在使应用程序产品适应它可以运行的每一种系统。中间件提供它们的全部互联，开发人员只需简单地实现应用程序产品和中间件间的接口。

    在不同的网络操作系统上，已经安装了许多著名的消息转发系统，但必须牢记，这些系统并没有考虑中间件产品，因为它们的设计没有为多厂商和多协议提供接口。它们依赖于操作系统内置的服务和通信协议。

    Microsoft的邮件传递系统 是Microsoft LAN管理器和IBM LAN服务器环境的一种消息传递接口，它是OS／2的网络扩充版本。邮件传递系统是一种存储再转发消息系统，它允许网络结点共享数据，而无需与其他结点同步（建立联系）。与此相反，命名管道（named pipe）在两个网络结点间同步交换。

    Novell的信报处理服务（MHS）是一种开始只用于电子函件的消息转发系统，但也具有在应用程序间转发消息的能力。Novell最近通过增加对OSI协议、IBM SNA和TCP／IP的支持，改进了MHS的协同工作能力。

    IBM的消息排队接口（MQI） 是一种能观测不同平台上应用程序间转发消息的基于消息的应用程序接口。它在IBM联网方案中定义。

    一些厂商正在推进面向消息的中间件。下面作为例子讨论两种消息转发系统。有些能与SQL或非SQL数据库一起工作。

    通信集成器由Covia技术公司（Rosemout，Illinois）提供。这种消息转发系统在IBM、DEC、UNIX、OS／2、DOS和Windows环境下工作。而服务器和主机通过面向连接的链路通信。对消息进行优先分级以保证时间敏感性信息通过。

    DECmessage Q由数字设备公司DEC（Maynard，Massachusetts）提供。这个系统是DECnet结构的一部分，它在客户机／服务器和对等层环境下工作。它支持VAX／VMS、ULTRISI、OS／2、DOS、Windows和Macintosh。DECmessage Q在许多不同类型的前端和后端应用程序之间充当消息总线的角色。应用程序可以建立一些优先的和正常的消息队列。

    消息传递技术在面向对象领域也是很重要的。在一个面向对象的系统中，对象请求代理（ORB）为在应用、服务和系统的其他设备之间进行消息分布提供了一种关键通信设备。可以将一个ORB想象成一种软件总线、支柱，它提供了一种通用的消息转发接口，通过这个接口许多不同类的对象可以以对等层策略进行通信。一个对象提出一个请求，并将它送到ORB，然后，ORB放置一个对象用于为这个请求服务、格式化消息，并将它发到对象。然后，这个响应通过ORB送回原来的请求者。在这种模式中，对象只需简单地描述要操作的任务。它们并不需要知道细节和能够为这个任务服务的对象在那里。ORB处理所有的放置对象、格式化消息并分发这些消息的细节。ORB是所有分布式环境的一种通用接口。

    相关条目：Common Object Request Broker Architecture 公用对象请求代管器结构；Connectionless andConnection－Oriented Transactions无连接和面向连接的事务；IBM Networking Blueprint IBM联网方案；Mail Slots 邮件传递系统；Message Handling System 信报处理系统；Middleware 中间件；Object Request Broker 对象请求代管器；Remote Procedure Call远程过程调用。


  • 消息应用程序编程接口 Messaging Application Programming Interface

    Messaging Application Programming Interface（MAPI） 消息应用程序编程接口（MAPI） MAPI为应用提供了一种访问不同类型的消息传递系统的途径，如Microsoft邮件，Lotus Development的cc：MAIL和Novell的信报处理服务（MHS）。MAPI定义了程序员可以使用的所有过程，以在Windows应用中建立电子函件接口。例如，一个用户在使用Windows的字处理程序时，通过从他的菜单上选择电子函件选项，就能编址，发送和接收电子函件消息。用户还可以在程序中写一个便签，并将它包含在一个发送出的电子函件消息中。

    现在，有两种不同类型的MAPI。简单MAPI只与Microsoft邮件一起工作，它提供一条从不同Windows应用访问电子函件功能的途径。扩展MAPI对许多其他邮件系统提供了接口，包括它们的地址薄、消息存储区域和邮件传送功能。

    相关条目：Electronic Mail电子函件；Message－Enabled Application 消息激活应用程序；Middleware 中间件；Windows Open System Architecture Windows开放式系统结构。


  • 城域网 Metropolitan Area Networks

    Metropolitan Area Networks（MAN） 城域网（MAN） 城域网是一种主干网络，它覆盖一个城市区域，并且由地方或国家来管理。电信局、电缆服务公司和其他提供商，对需要在城市范围内建造跨越公共可通行区域网络的公司，提供MAN服务。本书中MAN定义为城市区域的光纤网络IEEE 802．6标准。电信局建造IEEE 802．6MAN，为顾客提供可交换多兆位的数据服务（SMDS）。IEEE802．6MAN可以提供面向连接和无连接的服务，使得顾客在城区内建造逻辑网络，以使用户像用局域网络一样使用。最后，MAN将引出将来的宽带ISDN和异步传输模式（ATM）技术。

    MAN是一种基本的LATA内服务的，它局限在本地呼叫区域，是在LATA之间的区域，而不是长途的。一个MAN和它提供的服务，可以覆盖几百平方公里。通过网桥和路由器在T1、ISDN、或相似的链路上为MAN连接附件。一些公司提供跨越本地电讯公司的线路。

    MAN是建立在拨号总线结构上的，这意味着两条光纤电缆为同时从相反方向进行传输提供了可能。一个连接在拨号总线上的结点可以向两个方向传送数据。拨号总线按图M－5所示的环型拓朴建造。注意，在（A）中总线两端是没有连接的。然而，如果在LAN中的任何一个地方出现了错误，总线自动按（B）所示进行重构。当有两个地方断了时，网络变成两个独立工作的网络，直到修复为止。

    对IEEE 802．6MAN的访问标准是分布队列双总线（DQDB）技术。DQDB 定义了一种双总线结构和访问方法。在总线末端的一个槽产生器中继固定体积的槽，站将网络上传输的数据放置在这些槽中。这些槽（slots）在连续流（stream）中流动，就象在一个轨道上的许多货车。槽的体积是53个字节，这和异步传输模式（ATM）以及将来的集成宽带综合业务数字网络（B－ISDN）中实现的信元体积兼容。这两种类型的网络提供了在光纤传送媒介上可行的可扩展传输率。所以，以后的WAN技术都会实现固定大小的信元。

    固定体积页槽提供了快速分组交换和可预测的递送，而不象帧中继和X．25网络中实现的可变长度分组交换那样。页槽可以为象实时视频这样的等时数据给予高优先级。这保证了可以得到一定数量的经常再现的槽，从而使数据可以按时分送。每个等时数据槽都按这种方式被页槽生成器加上标志。

    MAN可以提供一些服务，例如LAN对LAN连接、PBX连接、直接工作站连接和大型计算机连接等。这也就是说，MAN是一种集成音频和数据的网络。它还具有下述其他特征：

    MAN既可提供分组交换也可提供电路交换设备。

    MAN能够提供帧体积达9，188字节的无连接服务，它可以在53－字节槽上传送。

    MAN能够在基于虚电路连接的总线上的结点间提供传送53字节段的面向连接服务。

    MAM能够提供等时服务，它保证了在逻辑连接上固定传输时间敏感数据。

    DQDB层和物理层是相互无关的，所以可以使用许多不同的物理层。例如，物理媒介支持44．736Mbps的ANSI DS3和155．52 Mbps的SONET。

    MAN标准和其他IEEE LAN标准是兼容的，支持802．2逻辑链路控制（LLC）标准的通信。

    相关条目：Asynchronous Transfer Mode异步传送模式；Connection－Oriented and Connectionless Protocol面向连接和无连接协议；Fast Packet Switching 快速分组交换；Switched Multimegabit Data Service可交换多兆位数据服务；Virtual Circuits 虚电路。


  • 微通道体系结构（MCA）总线 MicroChannel Architecture（MCA）Bus

    MicroChannel Architecture（MCA）Bus 微通道体系结构（MCA）总线 MCA总线是IBM为帮助解决快速微处理器和相对慢的工业标准系统结构（ISA）总线之间的差异而开发的。虽然MCA总线不接收ISA型的主板，但它们提供的32位接口却比ISA更快，也可以更好地适应80386和80486微处理器的要求。

    MCA总线采用单总线设计，通过使用多路复用器来处理存储器和输入／输出（I／0）接口的传输。多路复用器将总线分成多个不同的通道，每个通道可以处理不同的处理需求。这种设计没有多总线设计快，但在大多数情况下，却可以满足中等大小网络的服务器要求。如果在服务器上运行微处理器集中式应用程序，选择一个超级服务器也许是明智的，因为它具有超级吞吐率和多处理器能力。

    MAC受专利和许可协议保护，这限制了它发展为一种标准。另外，IBM还对MCA施加了一些限制，以防止和它的小型计算机系统竞争。由于这些原因，许多厂商使用了扩展工业标准体系结构（EISA）或开发专用的总线标准。

    相关条目：Extended Industry Standard Architecture Bus 扩展工业标准体系结构（EISA）总线。


  • Microcom的联网协议 Microcom Networking Protocol（MNP）

    Microcom Networking Protocol（MNP） Microcom的联网协议（MNP） MNP是Microcom公司（Norvood，Massachusetts）为调制解调器数据通信而制定的协议，Microcom是一家调制解调器的生产厂家。这些协议通过采用纠错和压缩技术，来提供高可靠性的数据传送。它们被认为是一种实际上的标准，许多厂商已经被授权在他们的调制解调器上使用这些协议。今天，调制解调器通常采用CCITT（ITU）V系列标准，因为它们已在世界范围接受。然而，一些调制解调器既使用V系列又使用MNP。下面列出了一些主要的MNP协议，没有列出的都是没有使用的或在调制解调器通信领域并不重要的。

    第2类 全双工异步传输模式。

    第3类 生成帧式HDLC流的全双工异步传输模式。

    第4类 当信道无错时，为增加帧体积来改进吞吐率提供了一条途径。这种方式是可适应的，可以根据线路的质量来将帧的大小调高或低。

    第5类 提供两倍数据压缩，提供2400bps，4800bps的调制解调能力。例如，压缩技术可以根据数据情况来适应以达到最大的吞吐率。

    第6类 和CCITT（ITU）V．29调制解调器类似，但增加了第5类的数据压缩技术。使用MNP第6类的9，600带宽调制解调器可达到19．2K位／秒的吞吐率。

    第7类 提供增强数据压缩，以能减少42％的数据。其他方面类似于第5类。

    第8类 包括第7类的特征，并增加了CCITT（ITU）V．29技术，以增加半双工设备能象全双工设备那样工作。

    第9类 和CCITT（ITU）V．32调制解调器标准类似，并可以通过使用第7类的数据压缩技术来增加两倍的吞吐率。

    注意：CCITT（ITU）V．32和V．42建议为纠错而采用链路访问规程－调制解调器（LAP－M），但第7类MNP支持它。许多厂商在他们的调制解调器上提供了这两种选择。

    相关条目：Asynchronous Communication 异步通信；Bell Modem Standards Be1l调制解调器标准；Dialup Line 拨号线路；Modems；Modulation Techniques调制技术；Serial Communication串行通信；Syn－chronous Communication同步通信；“V－dot”Standards，CCITT CCITT的“V－点”标准。


  • 微内核 Microkernel

    Microkernel 微内核 内核提供操作系统的核心功能。微内核是内核的精简版本，它设计成在很小的内存空间内增加移植性，提供模块化设计，以使用户安装不同的接口，如UNIX、DOS、Windows、Workplace OS、Workp1ace UNIX等。IBM、Microaoft、开放软件基金会（OSF）和UNIX系统实验室（USL）等新操作系统都采用了这一研究成果的优点。下面列出了两种著名的微内核操作系统：

    Mach Carnegie－Mellon大学设计。

    Nucleus Chorus系统公司（Beaverton，oregon）设计，该公司总部设在法国。

    如上所述，微内核是内核的一种精简形式通常与内核集成在一起的系统服务层被分离出来，变成可以根据需求加入的选件，这样就可提供更好的可扩展性和更加有效的应用环境。使用微内核设计，对系统进行升级，只要用新模块替换旧模块，不需要改变整个操作系统。

    我们可以用商业对比来解释微内核的模块概念。考虑一个过度忙碌的商务经理。通过将工作分给其他人，这位经理可以将他的能力更有效地用于重要的商务工作中去，并集中于其他一些任务，例如开辟新的商务分支等。可以雇佣一些新人来支持增长的商务活动。经理协调这些工作，但由其他的人做好雇佣他们时说好要做的事。与此类似，微内核操作系统支持执行少量核心任务，并管理可安装模块的活动。用这种方式，微内核对于它能做的工作是非常有效的，并是可移植的，这是指它可以被设计成在不同的处理器上运行。

    基于微内核的操作系统如图M－6所示进行分层，并具有如下特征：

    微内核提供一组“最基本”的服务，如进程调度、进程间通信、存储管理、处理I／O设备。其他服务，如文件管理、网络支持等通过接口连到微内核。与此相反，内核是集成的，比微内核更大。

    微内核具有很好的扩展性，并可简化应用程序开发。用户只运行他们需要的服务，这有利于减少磁盘空间和存储器需求。

    厂商可以很容易地将微内核移植到其他处理器平台，并在上面增加适合其他平台需要的模块化部件。

    （这指文件服务器、工程应用等等）。

    微内核和硬件部件有接口，并向可安装模块提供一个接口。在微内核中，进程通过传递消息或运行“线程”来发生相互作用。线程为将一个任务分解为多个子任务提供了途径，在多处理器环境下，线程可以在不同的处理器上独立运行。

    下面列出一些重要的微内核操作系统：

    Windows NT 这种操作系统是围绕着Microsoft设计的微内核而设计的，它紧跟在Mach设计之后。它提供线程调度、中断和意外事件管理、多处理器同步和系统恢复（在掉电之后）。它永远不会被存储器管理程序调出内存，而且它的执行也永远不能被其它进程中断。

    OSF／1MK 这是开放式系统基金会的OSF／1UNIX操作系统使用微内核研究的最新版本。它实现了Mach内核，并提供虚拟存储管理、进程间通信和设备驱动程序管理。

    UNIX SVR4 UNIX系统实验室公司推出了一个微内核的UNIX SVR4（系统V版本4）。它实现了Nucleus微内核。它提供前面讨论的所有微内核特征；然而，在微内核中不管理驱动程序。

    WorkPlace OS IBM的微内核是基于Mach微内核的。这种微内核在Motorola PowerPC处理器上运行，它是Intel 80486和Pentium处理器的直接竞争者

    口WorkPlace操作系统上的用户可以选择不同的运行于操作系统上的接口，如DOS、OS／2、Windows、U－NIX等。IBM微内核的体积很小（约40K），可处理基本的任务，如存储器管理、线程管理、中断管理和消息传递。

    象Mach和Nucleus这样的微内核操作系统，使用户可以自己选择操作系统的接口和特性。它们十分适合可以选择多处理器和多操作系统的变化的计算机市场，开发商也可从中受益。它们能够很快地从一个系统向另一个系统移植他们的产品，使最终用户可以得到许多应用产品。这种模块化的设计也保证了可以得到大量的可选服务。

    相关条目：IBM Operating SystemsIBM的操作系统；Mach，Carnegie－Mellon Microkernel Carnegie－Mellon的微内核Mach；OSF／1 Open Software Foundation开放软件基金会的OSF／1；Remote Procedure Call 远程过程调用；UNIX；Windows NT，Microsoft Microsoft的Windows NT；Workplace OS。


  • 微分段 Microsegmentation

    Microsegmentation 微分段 微分段是一种减少LAN网络段上站的数目以改进性能的技术。让我们回顾以太网使用的广播技术，在那里每一时刻只有一个站能够使用电缆。如果两个站同时访问电缆就会出现一个冲突，从而导致延迟和性能降低。这个问题随着更多的站加入网络而变得更严重。

    解决上述问题的一条有效途径是，通过将网络分解为两个或多个网络段，并用网桥或路由器将它们连接起来，从而减少访问网络的站数目。这样，只有那些与每个网络段直接连接的工作站才会争用网络。网桥过滤技术可以防止一个网络段的通信扩展到其他网络段。通过限制每个局域网段只能有一台工作站，微分段对上述概念极端化发挥。这时，对网络没有争用。一个站才就不用等待另一个站完成传输。LAN本身连接到交换式集线器（hub），集线器在需要通信的站的LAN网络段间桥接，建立一个直接专用的信道。这个信道通常称为“专用LAN”。

    微分段需要具有足够端口以支持对每个工作站的LAN网络段的新交换设备。吞吐率可以达到网络带宽的极限。例如，连接到一个以太LAN网络段的工作站可以达到10Mbps吞吐率，这远高于共享以太LAN的吞吐率。

    相关条目：Ethernet以太网；Switching Hubs 交换式集线器。


  • Microsoft At Work体系结构 Microsoft At Work Architecture

    Microsoft At Work Architecture Microsoft At Work体系结构 Microsoft At Work是一种将网络环境中的计算机和办公设备连接在一起的体系结构，这时的网络环境使用户和管理人员在他们的台式系统上就能访问和控制办公设备，比如传真机、复印机、打印机、手持计算机、电话系统、网络设备，以及内置传真和调制解调器卡这样的PC机外设。60家以上的公司支持AtWork的举措，它的对象创建一种任何用户都能从他们的工作地点访问信息和办公设备的环境。下面列出一些厂商和他们的产品：

    Cannon USA，Hewellet－Packard和Xerox的复印机和打印机。

    Castelle，Delrina，Intel和Ricoh的传真服务器和适配器。

    Rolm／Siemens，Ericsson Communications和McCaw Cecllular电话设备。

    Microsoft At Work体系结构的设计使得人们可以很容易地使用个人化的产品。办公机器将可以和基于Windows的计算机、打印机和其他外设共同协作工作。Windows At Work提供的一些办公自动化的例子是：

    Microsoft At Work使得用户可以使用点击（pointand－click）或触摸屏技术，通过他们计算机上的图形用户界面操作一部电话。

    图形用户界面使得建立会话呼叫、操作呼叫传输、或发送和接收电子函件更加简单。

    利用Microsoft At Work，一个用户可以使用基于Windows的字处理器来创建一个文档，然后再将这个文档送给传真机。可以对传送进行调度，以等待呼叫费用便宜时再进行实际传送。

    支持Microsoft At Work的网络连接，为连有复印机的用户提供转发拷贝到一个或多个用户文档的电子图象成为可能。

    Microsoft At Work利用了不断增长的在办公机器上应用数字电子信息的优势。许多传真机、复印机和电话已经具有和计算机设备相连的接口。Microsoft At Work将提供一种推动这些设备发展的通用办公接口。它将办公设备的界面扩展到用户计算机上运行的图形界面。

    下面讨论这种结构的部件。这些部件是融合入办公设备中的组成块，使它们相互间兼容，并和PC运行的Microsoft Windows兼容。

    Microsoft At Work操作系统 是一种实时的、可抢先的、多任务操作系统，它是为在办公自动化和通信设备中使用而设计的。

    通信（communications）这种设备在设备和网络服务器之间提供网络连接和Windows消息传递。这个部件提供安全群件，并与Windows信报传送API和Windnnows Telephony API（Windows开放式系统结构WOSA的一部分）兼容。

    翻译（Rendering） 这种部件提供向设备，如打印机、复印机、传真机进行文档互换和传送。如果需要，文档中的字体和格式将保持不变以便在目的地进行进一步编辑。

    图形用户接口（Graphical UserInterface）这个部件提供诸如在触摸屏上显示菜单、按纽和对话框这样的用户界面。办公设备将具有带320×240点／英寸的5×7英寸的LCD触感显示器。

    台式系统的软件（Desktop Software） 这种部件为基于Windows的PC应用程序提供了在任何基于Microsoft At Work的产品上控制、访问和交换信息的能力。台式系统的软件是PC结构的一部分。所有Microsoft At Work设备都是可从集中地点使用管理软件进行配制的。可以使用现存的电话网络在办公设备间共享信息。Microsoft At Work向人们提供了人们以前不能或不方便使用的办公设备的新功能。


  • 微型计算机到大型计算机的互联性 Micro－to－Mainframe Connectivity

    Micro－to－Mainframe Connectivity 微型计算机到大型计算机的互联性 参见Maintrame and Minicomputer Connectivity大型计算机和微型计算机的互联性。


  • 微波通信 Microwave Communication

    Microwave Communication 微波通信 许多人想到通信介质时，他们就联想到铜线或光缆。但微波通信并不需要固体介质，而且是美国广泛使用的“长途（long－haul）”传送方式。当两点间直线距离内无障碍时就可以使用微波传送，例如：

    卫星到地面。

    城市两个建筑物之间。

    很大的无法实际布设电缆的开阔区域，如沙漠、草地和湖泽等。

    微波传输系统有一些双向天线，它们以点到点方式聚集其他点发出的电磁波或无线电波能量，如图M－7所示。这些天线需要无障碍路径，最大范围可达30公里。天线通常安装在高塔上，以扩展它们的工作距离，并避免引起反射信号的障碍物。各地的无线电发射接收器通过天线发送信号。

    不象无线电广播那样从一个地点向许多地点发送信号，微波通信是一个点到点的通信系统。使用配备了信号放大器的中继站以扩展微波通信的范围。一个中继站有两个天线，分别用于指向远方不同方向的天线。传输频率为2到25千兆赫，比短距离的专用网具有更大的带宽。

    微波是和金属或光缆系统相应的。安装一个小微波系统是很简单的。例如，可以在两个建筑物的墙上分别安装一个天线，并将这两个天线指向相对，就建立了这两个建筑物之间的微波通信。由于绕过了本地信息交换公司，所以系统相当便宜。在校园环境，微波系统比铺设电缆更加实际。

    相关条目：Satellite Telecommunication卫星远程通信；Telecommunication远程通信。


  • 中间件 Middleware

    Middleware 中间件 中间件是一类软件，它对应用程序隐藏了实际网络和通信协议的细节。高级编程接口帮助开发人员在不同的环境创建应用程序，而不需要对将使用的网络和通信协议有更多的了解。

    正常情况下，中间件在使用不同网络通信协议的客户机／服务器环境实现。它可以对客户机／服务器应用隐藏协议，从而使开发人员集中精力于改进应用程序，而不是开发通信接口。

    一般而主，中间件产品隐藏了前端应用程序和后端应用程序的区别。中间件层包括通用应用程序和流行应用程序的应用程序编程接口（API）之间的翻译功能。例如，Microsoft的开放式数据库连接（ODBC）标准提供后端数据库系统操作的通用功能。前端应用程序写入ODBC，并利用它的功能。ODBC 隐藏了不同厂商的SQL实现的区别。Microsoft以一组Microsoft Windows驱动程序的形式提供ODBC，以提供对Microsoft Access、Microsoft Excel、Microsoft SQL Server、FoxPro、Btrieve，dBASE，Borland Paradox、IBM DB2、DECRdb和Oracle等格式产生的数据的访问。ODBC是为了使Windows成为客户访问后端数据库的标准而设计的。

    中间件产品是许多机构希望将他们的不同计算资源和企业级网络相连而作出的努力。

    用户需要访问许多不同的后端服务器上的服务。

    后端服务器可以使用不同的操作系统，并需要不同的通信协议。

    后端数据库服务器有不兼容的SQL命令集，它使用户和程序员很难从一个系统转到另一个系统。

    限制用户只能使用某种特定的访问后端服务的应用程序现在已经不现实。用户需要从不同的应用程序来访问服务。

    新的模型是为了使用户在多厂商环境使用多种协议在任何前端来访问任何后端服务。

    在多协议、多厂商环境，通常一个程序员需要编写应用程序，来与每个协议和支持系统进行工作。使用中间件，程序员只需简单地编写到中间件的接口，而由中间件处理所有多协议、多厂商问题。有三种类型的中间件：远程过程调用（RPC）、会晤（conversations）和消息传递系统。它们都能很好地隐藏通信过程，以及与它们进行操作的系统差异。

    Remote Procedure CallS（RPC） 远程过程i调用（RPC）

    一个远程过程调用是在网络上一个机器对另一个机器的请求。RPC保持了中间件在不同网络平台和通信协议上工作的性质。基本上，一个RPC就是一台计算机向另一台计算机发出的直接请求。它是一种请求／回答过程，这时请求方等待一个回答，这意味着RPC通常是在面向连接界面上发生的一种实时呼叫。

    开放软件基金会（OSF）的分布式计算环境（DCE）是一组“启动激活”软件，它隐藏了多厂商产品、技术和标准之间的差异，使开发人员开发能够在分布客户机／服务器环境的应用产品。DEC独立于具有开放开发环境的操作系统和网络。

    DEC实现的RPC提供了一些创建客户机／服务器应用程序的工具，这些应用程序可在网络上连接的其它计算机上运行过程。OSF的RPC，通过支持调用远程计算机上的过程，而扩展了本地过程模式，使得程序员可以象开发传统的单系统程序那样开发分布应用产品。RPC的表示服务屏蔽了不同机器上数据表示之间的差异，从而允许程序员在异构系统上进行工作。OSF的RPC包括RPC部件和一个编译器。

    RPC使客户能在多个服务器上相互工作，并允许服务器们同时处理多个客户。例如，一个客户能够使用网络上的多台计算机协同完成一个处理任务。RPC帮助将一个任务分解为能够在不同系统上运行的小部分，从而利用分布式运算环境的优势。线程是这种能力的一个重要部分。一个支持线程的操作系统和应用能够同时处理多个进程，而不是一个进程接一个进程地处理。对于相关信息，可以参见“0SF的分布式计算环境”，“进程间通信”和“远程过程调用”。

    Conversations 会晤

    会晤是逻辑连接的两个或多个系统之间的连续谈话。不象RPC，在分布式环境，会晤可能会重叠执行。出于这个原因，对需要在多个地方必须完全同步地完成，修改分布式数据库的工作，会晤是非常必要和有益的。IBM的高级程序对程序通信（APPC）实现了会晤。用于实现会晤的OSI标准也已出现。Covia Technologies（Rosemont，Illinois）的通信集成器（CI，Communication Integrator）是具有会晤的中间件的另一个例子、它可以在大型计算机、中型机和台式机上运行。许多厂商正在许可CI为他们使用。参见“高级程序对程序通信”和“IBM联网方案”。

    Messaging Systems 消息传递系统

    应用程序间的消息传递，使应用程序可以以非实时、存储再转发的方式交换命令和信息，当然也可以使用实时模式。一个消息先被格式化，然后发往目的地，在目的地它可能被存储直到目的地能够处理它。另外，消息可能被存储在能够处理进程间消息传递的单独地方。不要将消息传递和电子函件系统混淆，虽然它们有相似之处，但电子函件系统是为用户间交换消息而设计的。

    一种面向消息的事务是使用存储再传送技术的无连接事务。应用程序以消息的方式发送一个请求或命令，然后等待回答。在收发系统之间没有同步，发送方可以将消息广播给任意多的其他系统。它的一个重要特色是在客户机和服务器之间没有通信“会晤”或联系，服务器可以在很长时间之后再有反应。由于消息传递系统不是实时工作的，所以关键的实时任务应用程序使用它是不现实的。然而，对于较慢传输率广域网连接的分散系统，消息传递系统的工作却是不错的。首先，广域网链路的延迟就使实时应用程序不合适。

    Novell的信报处理服务（MHS）是一种开始只用干电子函件的消息传递系统，但也具有在应用程序间传递消息的能力。Novel1最近通过增加对OSI协议、IBM SNA和TCP／IP的支持，改进了MHS的协作工作能力。IBM的消息排队接口（MQI），是一种能观测不同平台上应用程序间传递消息的基于消息的应用接口，它在IBM联网方案中定义。在不同的网络操作系统上，已经安装了许多著名的消息传递系统，但必须牢记，这些系统并没有考虑中间件产品，因为它们的设计没有为不同的多厂商和多协议提供接口。它们依赖于操作系统内置的服务和通信协议。许多厂商推崇面向消息的中间件。要了解这方面的信息，参见“IBM联网方案”和“应用程序间的消息传递API”。

    消息传递技术在面向对象领域也是很重要的。在面向对象的系统中，对象请求代管器（ORB）为在应用、服务和系统的其他设施之间进行消息分布，提供了一种关键通信设施。可以将ORB想象成一种软件总线、支柱，它提供了一种通用的消息传递接口，通过这个接口，许多不同类的对象可以以对等层策略进行通信。一个对象提出一个请求，并将它送到ORB。然后，ORB定位一个对象，用于为上个请求服务，格式化消息，并将它发到出现请求的对象。然后，这个响应通过ORB送回原来的请求者。在这种模式中，对象只需简单地描述要操作的任务。它们并不需要知道细节和能够为这个任务服务的对象在那里。ORB处理所有的对象定位、格式化消息并分发这些消息的细节。ORB是所有分布式环境的一种通用接口。要了解这方面的信息，参见“公用对象请求代管器结构”；“对象请求代管器”。

    Trends 趋势

    在中间件领域，最新发展趋势操作系统厂商在其系统中直接提供RPC机制Novell Net Ware和Windows NT融合了RPC技术。另外，操作系统中还开发了通过电子函件和群件（groupware）来提高工作组活动的中间件。这些系统为前端和后端服务、允许用户和应用通信的消息传递服务、电子函件激活应用、目录命名服务，和象鉴别和电子签名这样的安全部件等，提供了通用的接口。Microsoft、Apple和开放软件基金会在这一方向是领先的。中间件有助于解决网络环境不同协议产生的问题。文档互换标准正在改进，对象链接标准为应用程序间共享文本、图形、多媒体提供了途径。

    相关条目：Apple Open Collaborative Environment Apple的开放协作环境；Distributed Computing Environment，OSF OSF的分布式计算环境;Open Database Connectivity，Microsoft Microsoft的开放式数据库连接；STREAMS；Transport Layers Interface运输层接口;Windows Open System Architecture Windows的开放式体系结构。


  • 镜像 Mirroring

    Mirroring 镜像 镜像是将存储的数据实时备份到另一个存储设备的过程，从而使两个设备都有相同的信息。镜像是一种保护数据因设备失效而丢失的容错技术。下面介绍镜像可能发生的三个级别，如图M－8所示。

    镜像（mirroring） 数据从一个磁盘控制器（信道）复制到两个磁盘驱动器。如果一个驱动程序坏了，另一个仍可操作。

    复置（duplexing） 数据通过两个磁盘信道复制到两个磁盘驱动器。这种方法将容错功能扩展到了磁盘控制器。

    服务器复置（server duplexing） 种方式通过设置两个完整的服务器，提供了最高级别的容错能力。

    如果一个服务器坏了，另一个服务器仍可向用户提供不间断的服务。

    Novell的系统容错级别Ⅲ提供服务器复制。系统间需要高带宽的光纤链路，以保证数据被同时复制。

    相关条目：Data Protecting 数据保护；Disaster Recovery 灾难恢复;Disk Mirroring and Duplication 磁盘镜像和复制（置）；Duplexed Systems 复置系统;FaultManagement错误管理；FaultTolerance 容错；Net Ware SFT Level ⅢNetWareSFT级别Ⅲ；System Fault Tolerance 系统容错。


  • MO 磁光盘

    磁光盘（Magneto-Optical），MO是一种采用激光和磁场共同作用的磁光方式存储技术，MO磁光盘兼具硬盘的大容量和可读写功能，又有软盘的便携特性，同时具有光盘防磁、抗湿和可靠的特征，因而受到业界注目。它的外形与90mm（3．5英寸）软盘差不多，只不过略厚一些，塑料外壳内是一片类似CD-ROM的光盘，但是与CDROM不同的是MO上覆盖着磁性物质，在激光照射下可进行数据读写，工作时激光束和磁头在盘面两边相对应的位置。在写入时，激光束照射到垂直磁化记录层上，在800ns的时间内使照射部分温度升到150℃，同时磁头使加热部分磁场发生变化，从而记录了所写入的数据，这种方式称为热磁写入；当读出数据时，使用不会使磁场发生变化的弱激光束，反射光经分光棱镜，根据反射光折射方向的不同而读取数据。擦除数据的过程是用激光束照射垂直磁性膜使之加热，同时磁头将磁场恢复到初始状态。


 MO 磁性光盘
：磁性光盘(Magneto Optical)。是一种储存资料的媒体，外观和3.5寸软盘相似，而内部圆盘则是和光盘有点类似。原本MO的设计是用来取代硬盘的，MO分为3.5寸和5.25寸两种，3.5寸的使用较为普遍，而容量也有230MB、640MB以及1.3GB等不同的规格，目前市面上常见的是640MB。


  • 移动计算 Mobile Computing

    Mobile Computing 移动计算 移动计算使用各种无线电射频（RF）技术或蜂窝通信技术，使用户携带他们的移动计算机、个人数字助手（pDA）、BP机和其他电讯设备自由漫游。使用调制解调器的移动计算机用户也应该属于这一范畴，但他们侧重于无线远程用户。移动计算机用户依赖于电子信报传送服务，使他们无论走到那里都能和办公室保持联系。一些厂商，Microsoft，正在制造支持移动用户的特殊接口。例如，当移动用户从一个地方到另一个地方时，将恢复桌面排列和在最后会谈中打开的文件，就象计算机从来都不关闭一样。

    移动计算是消息传递技术和无线通信的融合。象RAM Mobile Data这样的公司也已加入，不仅具有通信的一面，而且还具有用户接口的支持。典型的用户包括需要技术信息的领域服务专家、进行估算的保险代表和需要信息以决定投资的销售人员。获得信息的一种方式是与公司数据库简单相连，并进行实时查询，信报传送减少，电话费用。移动用户只需通过一个数据库查询发送一个电子函件消息到数据库服务器，然后，服务器产生一个响应，并将响应放置在用户以后进行查取的信箱里。

    有两种用于移动数据通信的基本方法：

    分组交换帧中继网络（packet－switched RF network） 对顾客根据分组来收费。

    蜂窝电路交换产品（cellular circuit－switched products） 它围绕着现有蜂窝网络建造，根据连通时间收费。

    分组交换无线网络只有在传输时间较短时才具有优势，这是因为它对每出现一个分组都要收费。电路交换网络对传输长文件或其他较长的传输时才具有优势，这是因为它根据使用网络的时间长短来对顾客收费。

    分组无线电通信公司包括Ardisi（Lincolnshire，illinois），RAM Mobile Data（Woodbridge，New Jersey）和Nextel（Lafayette，California）。Ardis是IBM和Motorola的一个联合企业。Ardis的信号穿透能力是专门为有很多建筑物的大城市设计的。RAM Mobile Data是BellSouth和RAM广播公司之间的一个合作体。硬件产品包括Ericsson GE Mobile通信公司的一些产品，如RF激活调制解调器。

    蜂窝数字分组数据（CDPD）是无线市场的一个竞争者，它使用蜂窝系统的空闲时间来传输数字数据，速度可达19．2Kbps，它比其他无线服务要快四倍。DCPD是由蜂窝电讯公司和计算机公司组成的国际联盟定义的，包括九个地方Be11运营公司（RBOCs）中的八个公司、McCaw Cellular Data公司、Contel Cellular公司和GTE Mobilnet公司。

    Support Products 支持产品

    Apple、IBM、Intel、Hewlett－Packard、Novell和其他公司与许多无线通信公司共同合作，以向移动用户提供全面支持，如数据加密、用户鉴别，以及能够发现移动用户位置的定位系统。

    NetWare的Connect是一个远程通信平台，它提供支持32个移动用户进入NetWare网络的一个连接点。用户可以使用不同的远程控制包拨通并访问他们的台式机或NetWare服务器。如果需要，这种服务提供使用电子函件、传真，和当用户登录后软件能够自动升级的电子软件分发系统。Connect与老的NetWare异步通信服务（NACS）分组类似。

    网络的“即插即用”能力被许多厂家实现，这些厂家包括Microsoft、Intel等等。这种特性使得用户能切断（但并不毁坏）和网络的连接，并在以后或其他地方再和网络重新连接。当用户重新连入后，设备自动根据新的地点进行重配制，并恢复用户的台式系统环境，包括打开的应用和工作。它消除了关闭文件和下载系统的需求。另一个特色是，当系统重连时，系统将自动检查用户的电子函件。

    相关条目：Cellular Digital Packet Data 蜂窝数字分组数据:Packet－Radio Communications 分组无线电通信；Wireless Mobile Communication 无线移动通信。


  • 调制解调器 Modems

    Modems 调制解调器 调制解调器是一种提供将计算机连接到公共交换电话网络（PSTN）上的数据通信设备（DCE）。它们将计算机的数字系统转换（调制）成能够在电话线路上传送的模拟信号。在另一端的调制解调器又将信号解调回数字位。

    图M－9示意了一个典型的调制解调器安装情况。两个调制解调器必须使用满足一些标准的兼容的通信技术，如著名的CCITT（ITU）V系列标准。其他调制解调器标准包括Microcom联网协议（MNP）。从计算机到调制解调器的典型连接是通过RS－232，从调制解调器到电话墙壁插座的连接是通过RJ－11C。计算机的调制解调器有内置和外接两种模式。内置调制解调器是插在计算机插槽里的一块电路板或叫适配器。外接调制解调器放在计算机外的一个小盒子里，它通过串口和计算机相连。

    当一个调制解调器“呼叫”另一个调制解调器时，目的调制解调器应答并进行信号变换以建立通信会话时所需的参数。这个应答过程决定两个调制解调器间可用的最大信号通信率，以及是否使用数据压缩方式。用电话线路时对数据传输率，增加了一些限制，讨论如下：

    电话通信电路最大可有3，300Hz的带宽，限制在300到3，300Hz的范围内。这个范围对于音频是合适的，但却对数据通信增加了一些限制。

    由于电话连接有可能不好，所以不可能为数据使用全部的音频带宽。保护带将一个线路与另一个线路

    分离开来。

    一个频带被分成两个信道以支持双工，所以调制解调器在不同的信道接收和发送。为达到这个目的，在带宽范围内有两个调制载波信号。

    使用保护频带来分离两个双工信道，以防止串音和干扰。

    图M－10示意了信号通过的“管道”。保护频带将两个双工信道分离，并且还有一个保护信道用于分离双工信道。一旦配制了所有参数，有效的波特率是2，400波特或1，200波特。使用编码和压缩技术可以提高吞吐率到28，800bps。

    使用正交调幅（QAM）可以获得大约2，400bps的传输率。例如，通过把4位码编码到16个可能的相位和振幅变化可以获得9，600bps的传输率。格式编码算法（trellins encoding algorithm）是另一种获得高通信率的技术。它是QAM的扩展，并具有更好的抗噪声能力。

    High－Speed Modems 高速调制解调器

    高速调制解调器是指2，400bps以上通信率的调制解调器。如果希望达到更高的通信率，就需要采用编码技术和压缩技术。下面列出一些最重要的CCITT（ITU）标准：

    V．221，200bps全双工调制解调器标准。

    V．22bis 2，400bps全双工调制解调器标准。

    V．28定义在RS 232接口的电路。

    V．32异步和同步4，800／9，600bps标准。

    V．32bis 高于14，400bps以上的异步和同步标准。

    V．35定义组合线路上的高数据传输率。

    V．43定义查错标准。

    V．42bis 定义使用Lempel Ziv方法的调制解调器压缩技术。

    V．32terbo 提供19．2Kbps传输率的临时标准。

    V．3428Kbps传输率的标准。

    V．32terbo是一种19．2Kbps标准，它是V．32bis和V．34中间的过度性临时标准。注意下文：

    V．32bis使用在一个信号群（signal constellation）有128点的两维格式编码技术。

    V．32terbo使用在一个信号群（signal constellation）有256点到512点的两维格式编码技术。

    V．34（正规名称为V．fast）使用在一个信号群（signal constellation）有768点的四维格式编码技术。

    相关条目：Asynchronous Communications 异步通信；Bell Modem Standard Bell的调制解调器标准；Dialup Line 拨号线；Microcom Networking Microcom联网协议；Modulation Techniques调制技术；Serial;Communication 串行通信;Synchronous Communications 同步通信；“V－dot”Standard，CCITT CCITT的“V－点”标准。


 Mosaic 摩塞克浏览器
：Mosaic可说是浏览器的始祖，Mosaic是在1993年由美国伊利诺大学所发展出来的一套免费软件，可用来显示网页文件的内容。但是随着Netscape和Internet Explorer的出现，现在Mosaic已经很少人使用了。


  • 工具 Motif Motif

    Motif Motif 工具 开放软件基金会（OSF）采用X Windows系统，它为用户屏幕上操作网络上的不同应用程序提供了一条途径。麻省理工学院开发了X Windows系统。Motif是一种于X Windows系统的开发人员的工具箱，用于定义图形用户界面标准部件，如菜单条、边框和窗口背景。

    相关条目：Open Software Foundation 开放软件基金会；X Window。


  • MOTIS（面向消息的文本交换系统） MOTIS（Message Oriented Text Interchange System）

    MOTIS（Message Oriented Text Interchange System） MOTIS（面向消息的文本交换系统） 参见X．400 Message Handling System X．400消息处理系统。


  • MSI 微星科技 MSI

    MSI 微星科技

    台湾地区著名的电脑板卡制造商，主要生产电脑主板和各种附加卡。经过多年的努力，该公司已经发展成为全球十大电脑主板制造商之一，以及台湾地区三大电脑主板制造商之一。


  • MUD 分配角色的游戏环境

    一种分配角色的游戏环境，让网上的所有人能在一起玩如交互文本历险一类的游戏。MUD的其它名字包括MOO，MUSE，Muck，Mush，Fugue，Tiny Fugue和Tiny MUD。据说MUD有许多附加节目，似乎只有大学学生才足够的时间将它探索完。它现在也用于会议和辅助教育。


  • 多点连接 Multidrop（Multipoint）Connection

    Multidrop（Multipoint）Connection 多点连接 参见Point－to－Pointand Multipoint Connection 点对点和多点连接。


  • 多媒体 Multimedia

    Multimedia 多媒体 多媒体以大文件的形式将音频，视频和图象引入网络，这种文件需要很大的磁盘空间和很大的传输带宽。目前将多媒体集成到台式操作系统和流行应用软件的趋势暗示着多媒体的发展壮大。经理们通过安装大容量存储设备，增加网络带宽，将高带宽用户和低带宽用户分离出来等方式，来满足不断增长的适应多媒体的需求。

    当讨论多媒体产生的网络通信量时，区分先存储再转发和实时多媒体的需求是非常重要的。例如，一个用户可以先将一个音频录音或视频剪辑与一个电子函件消息相连，然后在发送给其他用户。由于存储再转发消息不要求立即进行传送，所以采用高的传输率并不是太重要的。实时视频在传输过程中必须具有专用的带宽和很快的传输率，以保证分组按可接受的方式抵达。如果没有足够的带宽，帧就会丢失，从而产生令人头痛的抖动现象（chopping effect）。给实时视频传输赋于高优先级，可保证可用信号具有足够的带宽，以保证传递的质量。交换式微分段以太网、异步传输模式（ATM）和新的100Mbps的快速以太网技术，能够提供所需的带宽。

    以太LAN的分段，减少了共享多媒体的冲突，并为以合理的速率传输视频信号提供了足够的带宽。将视频用户和其他用户隔离开也许是必要的。以太网交换式集线器提供了网络的微分段，从而使在每个网络段只有一个用户。每个用户都得到了一个没有其他用户共享的“专用LAN”网络段。这使得网络段的全部10Mbps的带宽都可被用户使用。交换式集线器可在需要交换信息的网络段之间桥接。然而，这个交换可以以非常快的速度对这个信息进行中继，而不是使用传统网桥的存储再传递的方式。

    当配制多媒体网络时，必须牢记下面事情：

    多媒体将“融入”机关和企业。现在，在Macintosh、Windows、OS／2等操作系统上已经包含了多媒体应用产品。

    用户无法抵挡使用廉价的语音板、图形软件包和电子函件等多媒体的诱惑。磁盘的需求和带宽的使用也将增加。

    任何多媒体计划都必须包括压缩技术。它可减少磁盘空间和带宽的需求。可以利用软件完成压缩，而Intel和其他厂商已经生产可以进行快速压缩和解压的硬件产品。

    需要使用多媒体和视频服务器来执行一些任务，如视频文件（例如，教学电影等）的压缩和存储，电视会议的管理和多媒体事件的定序。

    微分段以太网或100Mbps以太网对实时视频或需要增加的网络通信量的环境是很合适的。

    无闪烁视频需要每秒30帧的发送速度。使用压缩技术，在高速网络上这是可能的，但在低速网络上，却可能丢失帧。最低可接受的帧速是10到15帧／秒。

    视频通信并不能直接通过路由器。尽量保证视频用户在同一区域或网络段内。

    有许多厂商国际联盟和生产商定义多媒体的描述。公用开放软件环境（COSE）是一些开发服务和工具，在它之上，开发人员可以制作在不同平台和网络上工作的多媒体产品。COSE是多厂商国际联盟（包括IBM、Hewlett－Packard、SunSoft和Novell）共同合作开发的可以和Microsoft Windows竞争的UNIX通用台式系统环境。

    Novell、Microsoft、Apple和IBM有他们自己的描述，以定义如何制作客户机／服务器多媒体应用软件和硬件产品。Apple的Quicktime是一种多媒体操作系统扩展，它能够以可接受的速率同步传送音频和视频信息。它和Macintosh系统7操作系统一起出现，并且不需要特殊的硬件支持。

    相关条目：Bandwidth 带宽；Common Open Software Environment 公用开放软件环境；Compression Techniques 压缩技术；Ethernet 以太网；Microsegmentation 微分段；Switching Hubs 交换式集线器；Videoconferencing and Desktop Video 电视会议和台式视频系统。


  • 多路复用技术 Multiplexing

    Multiplexing 多路复用技术 为了了解多路复用（至少是分时多路复用），设想拥挤在高速公路上的汽车必须通过一座桥梁，这座桥只能单向行驶，即在某一时刻只能通过一个方向的车队。交通指示灯首先指示高速路第一道上的汽车通过桥梁，然后再指示第二道上的汽车通过，然后是第三道上的汽车，如此类推。在最后一个道上的汽车通过之后，这个过程又从头开始。按这种方法，在每个道上的汽车都可以平等地通过桥梁。多路复用使用类似的技术以使多个用户可以共享单一的通信线路连到远方的设施。这种线路通常是两点间的T1、T3或部分T1租用专线，来自每个用户的数据分组就象桥梁上的汽车。

    每个在多路复用线路上传输的设备被预分一个时间片或一个频率。即使设备没有进行传输，槽或频率仍然分配给它，并保持不使用状态。这导致了一些频带浪费。继续使用我们的高速公路作比方，这就象桥梁交通指示灯为每个航道在交通流中分配了一个空闲时间，即使在这个航道上没有汽车也进行这种分配。统计多路复用技术利用动态地为需要传输的设备分配槽来解决这个问题。

    多路复用向许多在单一共享线路上与远方设施进行通信的用户提供了一条经济实用的途径。多路复用设备就象桥梁上的交通指示灯，而桥梁就象互连远方两地的电路。它不是为每个用户设立一条和远方设施相连的个人数据连接。电信局提供高速数字线路，它为多个用户处理音频和视频通信提供了足够频带。多路复用器为使用这个频带提供了途径。

    必须认真评价频带需求。长距离的租用线路是很昂贵的，浪费频带会很快地消耗公司的财政收入。一个相应的解决方式是使用公用交换网络，这是每个用户通过只在需要向多用户传输信息时才建立的暂时性电路或分组交换网络。从顾客地址到公共网络也需要多路复用线路，但通常是短途的。

    多路复用将多个信号结合到一个线路上进行传输。在接收端，信号被进行分离。一个多路复用器是一种能够合并和分解信号的设备。使用时分多路复用（TDM）或频分多路复用能够保证信号间的分离。如图M－12所示。

    频分多路复用（FDM） FDM是一种频带模拟传输技术，使用它可以在一系电缆上同时传输多个信号，如图M－12（A）所示。每个数据或音频信号都被调制成不同频率的载波。在无线电和TV广播中可以发现类似的情况。多个电台通过空气或电缆同时广播。你可以将收音机调到你想听的频率上。信道的频率范围被进一步细分为窄的频道，每个频道都能传送不同的信号。保护频带分开细分的传输频道以减少干扰。

    时分多路复用（TDM） TDM是一种基带技术，不同的电路（数据或音频）由它们具有固定时间间隔的帧流位置来标识，如图M－12（B）所示。通过脉码调制对模拟输入进行数字化，数字化信息插入传输的时间段。每个信道得到一个重叠的时间段，从而使所有信道平等地共享用于传送的介质。参见前面介绍的桥梁交通的比拟。

    反逆多路复用 反逆多路复用是将单个高速数据流分解成多个低速数据流，而在多个低速连接的通路上传输的技术，如图M－12（C）所示。它能够节省租用高速线路的费用，并能更好地利用线路。

    统计分时多路（STDM） 复用如前所述，将时间片预分给并不总是进行传输的站，就不能很好地利用传输线路，这些预分的时间片可能会被浪费。统计多路复用通过动态分配时间片来解决这一问题，从而更有效地利用线路。统计多路复用是昂贵的，这是因为它包含一些处理器，并使用缓冲技术来有效地利用信道缓冲可能增加延迟，处理器和其他电路必须具有高性能的设计，以提供高通信速度。

    当然，还有其他技术用于改进多路复用器的性能。包括压缩技术，它在高性能设备上是很实用的。

    More About TDM TDM的其他情况

    帧是数据信道的时间段序列。例如，如果有24个输入信道，一帧就由24段组成，每段分别包含对各个信道进行的采样。在帧后跟有一个同步位，以使接收设备同步。新的帧含有新的采样，这个过程在传输介质上可以以很高的速度继续。

    在T1型多路复用中，一帧包括24个时间片，每秒有8，000帧。每个时间片有64，000位信息，每秒对模拟信号进行8，000次采样，每个采样8位（8，000×8＝64，000，或64K位／秒）。传输设备每秒传输的位数称为信道率（channel rate）或比特率（bits rate）。所以，T1传输就具有1．544Mbps的信道率，它是如下计算的：24帧×64，000位／帧＝1．536Mbps

    加入8，000bps（8Kbps或0．008Mbps）同步帧位，计算最终的传输率，如下：

    1．536Mbps+0．008 Mbps＝1．544Mbps

    Multiplexer Configurarions 多路复用器配制

    多路复用器能够混合音频和数据，并在高速线路上对它们进行传送，如图M－13所示。模拟电话信号必须通过编码解码（codec）器进行数字化，并发送到多路复用部件。然后，经过多路复用的信号和来自其他设备的数据一起在T1线路上传输。注意，在T1线路和多路复用器之间连接了信道服务部件／数据服务部件（DSU／CSU）。

    机构可使用多路复用设备和T1高速线路建立专用网，如图M－14所示。这种主干线路对不同工作地点之间提供音频和数据传输。注意，电话可以直接输入到多路复用器，也可以通过专用自动分支交换（PABx）设备输入。三向连接器的优点是如果一个线路失效了，可以把通信分发到另一个能到达目的地的线路（假设使用了可以对通信路由进行重组的路由器）。

    相关条目：Channel Service Unit／Data Service Unit信道服务部件／数据服务部件（CSU／DSU）；Dedicated Circuits 专用电路；T1／T3 Services T1／T3服务；Telecommunication 远程通信。


  • 多处理器处理 Multiprocessing

    Multiprocessing 多处理器处理 多处理器系统是一个含有多个处理器的计算机。许多超级服务器，如NetFrame开发的，就是为支持多处理器而特别设计的。超级服务器包括高性能总线、几十兆字节的可纠错存储器、廉价磁盘冗余阵列（RAID）和其他象多电源支持的冗余特征。

    多处理器系统的设计有两种类型：对称的和非对称的。每种类型都有不同的特点和优势。

    在对称式多处理器系统中，系统资源，如存储器和磁盘输入／输出（I／O）被系统中的所有微处理器共享，工作负载被均匀地分配到所有可用处理器上，从而避免对某些特定任务，一些处理器忙不过来，而另一些处理器却闲着。当加入微处理器时，对所有的任务，对称式多处理器系统的性能都会提高。虽然，Windows NT和其他“微内核”操作系统支持对称式多处理，但对称式多处理器系统的一个缺陷是，可利用对称式多处理器系统优势的操作系统是很难开发的。

    在非对称式多处理器系统中，任务和系统资源由不同的微处理器进行管理。例如，一个处理器处理I／O，而另一个处理器处理网络操作系统任务。非对称式多处理器系统不进行负载平衡。一个微处理器可能忙碌不堪，而另一个处理器却可能空闲无事。而对称式多处理器系统可以均匀地分配工作负载。

    许多厂商的注意点是，对在多个局域网段上的多网络用户提高系统吞吐率。超级服务器支持多网卡，增加可能的网络段数目。服务器上的高速总线在网络段间提供快速信息传输。

    相关条目：Mach，Carnegie－Mellon Microkernel Carnegie－Mellon的微内核Mach；Multiprocessor Systems

    多处理器系统；Windows NT，Microsoft Microsoft的Windows NT。


  • 多处理器系统 Multiprocessor Systems

    Multiprocessor Systems 多处理器系统 多处理器系统包括多个处理器，它是为高端工作站或文件服务器而设计的。由于市场上有多种多处理器系统，所以读者要提防许多系统中存在的输入／输出（I／O）瓶颈。虽然这些多处理器可以提供“大型计算机”那样的处理功能，但它们却通常采用象微通道和扩展工业标准结构（EISA）这样的标准总线设计，这些总线跟不上处理器的性能或网络的要求。超级服务器系统采用专门的总线设计，能够很好地支持多用户网络的输入／输出要求。

    相关条目：Multiprocessing 多处理。


  • 多协议网络 Multiprotocol Networks

    Multiprotocol Networks 多协议网络 多协议网络支持多种协议，如传输控制协议／Internet协议（TCP／IP）、网间分组交换协议（IPX）、AppleTALK、DECnet等等。使用运行多协议的多厂商计算机系统的单位，可将这些系统连接到一个网络平台上，而不是为每个协议建立一个网络。简单的想法是，电缆和网络设备可为单位使用的任何一种协议传输数据分组。例如，TCP／IP分组通过网络抵达目的地，而无需知道是否可还有IPX或其他分组也正在使用同一网络通向它们的目的地。

    多协议路由器将两个或多个局域网（LAN）段互连在一起形成广域连接。大多数基于LAN的协议并不是为在广域网上使用而设计的。这些协议进行错误检查和服务宣传，它们在广域网链路上产生开销。由于使用广域网很昂贵，而且和LAN相比响应也很慢，所以当这些协议用于广域网时就会增加费用并增加错误。多协议路由器通过将分组再次打包以使可有效地通过广域网来解决这些问题。这通常称为“封装（encapsulation）”。

    企业级网络的构成决定了它应该支持多协议。以前，孤立的部门和工作小组用他们各自喜欢厂商的设备和通信协议建立了他们自己的网络。当这些网络将集成为一个企业级网络时，需要向用户提供通过网络访问公司资源的协议。这也许意味着，增加TCP／IP以支持Net Ware IPX LAN，或增加IPX以支持Microsoft LAN。

    最终的目标是建立一个开放的网络，在此之上，支持许多不同产品。一种折衷的解决方法，是支持一些不同的协议，但最终，经理们还是需要选择最广泛使用的并被支持的那种协议，而放弃那些已经不再重要的协议。多协议网络研究提供了一条无需破坏现有网络结构就可以走向开放式系统的途径。多协议网络包括：

    工作站软件 它允许用户安装多个协议栈，从而使它们可以与不同系统通话。Novell开放数据链路接

    （ODI）和Microsoft网络驱动程序接口标准（NDIS）提供这种支持。

    网络服务器 它支持多协议。利用Nove11开放数据链路接口（ODI）和Microsoft网络驱动程序接口标准（NDIS），同样可以获得这种支持。

    多协议路由器 它支持多个不同类型协议栈的传输。

    下列协议是为工作组和802．X访问方式进行优化了的。它们一般都不适用于广域网。

    Microsoft Server Message Block（SMB）和Net BO1S。

    Apple Talk。

    Nove11 Net Ware IPX。

    下面列出了适合于企业级网络和广域网的一些协议：

    IBM Advanced Peer－to－Peer Networking（APPN）。

    TCP／IP。

    Open Systems InterConnection（OSI）。

    多协议路由器可以减少在广域使用这些协议时出现的一些问题。多协议路由器能够再次对“不可路由选择（non－routable）”的协议打包，并使用封装技术在其他网络上分发它们。

    相关条目：Encapsulation 封装；Enterprise Networks企业级网络；Middleware 中间件；Multiprotocol Router 多协议路由器。


  • 多协议路由器 Multiprotocol Router

    Multiprotocol Router 多协议路由器 多协议路由器是为处理多种通信协议而不是独立的一种协议而设计的。例如,Net Ware多协议路由器（Multiprotocol Router）支持开放式系统互联（OSI）、网络互联分组交换（IPX）、Internet协议（IP）、Novell Net－BIOS和Apple Talk等协议，所以用户可以和以太网络、令牌环网络、LocalTalk，以及ARCNET网络连接在一起，并从Net Ware工作站、Apple Macintosh、UNIX系统和OSI系统路由通信。

    相关条目：Routers 路由器；Routing Protocol 路由选择协议。


  • IBM的多协议传输网络 Multiprotocol Transport Network（MPTN），IBM

    Multiprotocol Transport Network（MPTN），IBM IBM的多协议传输网络（MPTN） MPTN软件将应用程序与下面的运输协议相分离，而无需使用多协议路由器。使用MPTN，为一种协议编写的应用程序，可以在另一个MPTN制定协议的网络上运行。从根本上说，MPTN改变了分组上的传输头，以适应另一种协议。这些协议是，传输控制协议／Internet协议（TCP／IP）、开放式系统互联（OSI）和系统网络体系结构（SNA）。其优点是，用户可以从大量的应用程序中进行选择，而不需关心它们下面使用的通信协议。

    MPTN是依据IBM网络方案中公用运输语义（CTS）层的描述进行设计的，在本书的许多地方对此都有介绍。IBM已经将MPTN技术用于X／开放国际联盟，其动机是，开辟一条通向多运输协议的标准途径。就象将叙述的那样，MPTN实现在SMA和TCP／IP系列协议之上支持多虚拟存储（MVS）大型计算机应用程序和OS／2应用程序。

    图M－15示意了MPTN软件的安装。在这种情况下，MPTN网关对运行TCP／IP的工作站提供进入IBM SNA服务器的连接。注意，MPTN为分组穿越网络充当了交换层的角色。

    IBM AnyNet是基于MPTN结构的多协议传输服务，在SNA网关上的AnyNet套接字允许使用文件运输协议（FTP）、网络文件系统（NFS）或X－Windows的套接字（Sockets）应用程序与类似的IBM SNA主机上的应用程序进行通信。将来的产品将支持IBM AIX、RS／6000和OS／400操作系统。AnyNet／2是一个为在TCP／IP网络上运行高级程序对程序通信（APPC）应用程序的OS／2程序。IBM也将为逻辑部件（Logical Unit：LU）0、1、2、3协议开发AnyNet产品，以对TCP／IP网络上的SNA提供进一步的支持。

    相关条目：Advanced Peer－to－Peer Networking 高级对等联网；IBM；IBM Networking Blueprint IBM联网方案；Routing，IBM IBM的路由选择；Routing Protocol 路由选择协议。


  • Internet多功能邮件传递扩展标准 Multipurpose Internet Mail Extension

    Multipurpose Internet Mail Extension（MIME） Internet多功能邮件传递扩展标准（MIME） Internet多功能邮件传递扩展标准（MIME）是Internet环境的一个复合消息传递标准。使用MIME，用户可以发送多媒体电子函件消息（它包括音频、视频、图形和文本）到任何一个TCP／IP网络上的用户。Richtext信息也能合并到消息中。Richtext定义字体、格式和一个文件的排板特征等，于是文档就能轻易地在许多不同类型的系统上再现。

    相关条目：Compound Document复合文档；Document Interchange Standards文档互换标准；Internet；Simple Mail Transfer Protocol 简单邮件运输协议。


  • 多站访问部件 Multistation Access Unit

    Multistation Access Unit（MAU） 多站访问部件（MAU） MAU是令牌环网络上的集线器设备，它提供多个计算机之间的连接。包括一个内部环，当工作站连入后，它又扩展成为一个外部环，如图M－16所示。

    如果有一个网卡失效了，MAU将自动旁路它，以保持环的连通。为了扩展网络以连接到MAU的设备上，从第一个MAU的环外口引出一条电缆，连到第二个MAU的环内口。然后，从第二个MAU的环外口引出另一条电缆，再连接到第一个MAU的环内口。这样，在允许环增长的同时，还保持了环的配制。

    相关条目：Token Ring Network 令牌环网络。


 NAT 网址解析
：Network Address Translation的首字母缩略词。Intranet或其他专用网络（stub 域）中使用的IP地址和Internet IP地址之间的转换过程。这种方法能够使用大量 stub 域地址，而无须占用有限的 Internet IP 地址。


 NAT　网址解析
：NAT是Network Address Translation的首字母缩略词。Intranet或其他专用网络（stub 域）中使用的IP地址和Internet IP地址之间的转换过程。这种方法能够使用大量stub域地址，而无须占用有限的Internet IP地址。


  • NAT 网址转换

    网址转换（Network Address Translation），是一种服务。通过转换和修改数据包来反映正确的地址信息，从而允许多个LAN客户共享单一的公共IP地址和Internet连接。


 NDIS 网络驱动程序接口
：NDIS是用于Windows和Windows NT操作系统的网络驱动程序接口。按照NDIS提供的接口标准，任何与NDIS兼容的传输驱动程序都能够和与NDIS兼容的网络适配器驱动程序进行信息交流。


  • NetBIOS 网络基本输入/输出系统

    网络基本输入/输出系统，(Network Basic Input/Output System) 。NetBIOS使运行在不同计算机上的应用程序通过局域网通信，它由IBM公司为它早期的PC网络而设计，后来它由Microsoft公司采用，已经变成实际上的工业标准。NetBIOS用于以太网、令牌环网和Windows NT网络。由于它不支持路由机制，所以它必须使用另外一种基于路由的传输机制（如TCP）加以补充。


  • NetLS（网络许可权服务器） NetLS（Network License Server）

    NetLS（Network License Server） NetLS（网络许可权服务器） NetLS是Gradient Technologies公司开发的一种网络许可系统，它是根据软件的许可拷贝次数来限制对软件的访问的。许可证的使用是为了保证一个公司的操作是在它对软件的合法权限之内的。这种软件还提供软件版本跟踪、库存和使用情况的跟踪。跟踪对于确定谁正在使用软件，和在什么条件下需要许可证是很重要的。NetLS被一些台式系统管理软件应用的厂商支持。

    相关条目：Electronic Software Distribution and Licensing 电子软件分发和许可。


  • IBM的NetView网络管理系统 NetView，IBM

    NetView，IBM IBM的NetView网络管理系统 NetView是IBM推向市场的一种网络管理系统。它是基于Hewlett－Packard的Open View管理系统的，但是IBM进一步发展了它。NetView被普遍认为是当今销售的最先进的网络管理产品。IBM NetView的原始动机是，对系统网络体系结构（SNA）网络进行管理，但是它现在已经成为支持开放式系统互联（OSI），以及传输控制协议／Internet协议（TCP／IP）的公用局域网（LAN）管理系统。

    IBM NetView对被管理的网络定义了三个部件，如图N－3所示。IBM NetView是接收来自网络上被管理设备警报的聚焦点。入口是在被管理设备上的代理，例如主机系统、前端处理器、控制器和LAN部件。服务点向非SNA协议系统提供了一个进入的途径，并支持简单网络管理协议（SNMP）和公用管理信息协议（CMIP）。

    这里介绍IBM NetView的一些主要部件：

    命令设备 基本命令和对IBM NetView的控制中心。它建议在一些情况下如何采取行动。

    硬件监督器 负责管理网络警告，包括为今后引用而存储它们。

    会话监督器 收集关于网络会话的信息，例如它们的状态、配置响应时间、失效情况和出错代码。

    状态监督器 收集SNA网络上资源的信息。这些信息对图形监督器是可用的。

    图形监督器 运行在OS／2上的软件，它可以提供网络和其资源的图形化显示，用户可以通过点击获得关于LAN网络段、结点或设备的信息。

    浏览设备 提供了一种观看IBM NetView收集信息的途径。

    IBM Net View可以被需要收集和显示网络特定信息的用户个人化。可以使用C语言，再构可执行外部语言REXX（Restructured Executive External Language）和命令表（CLIST）等编程工具来个人化这一系统。

    相关条目：Management Standards and Tools 管理标准与工具。


  • NetWare的核心协议 NetWare Core Protocol

    NetWare Core Protocol（NCP） NetWare的核心协议（NCP） NetWare的核心协议（NCP）是在NetWare服务器和它的客户机间传输信息的基本协议。NCP处理登录请求和多种对文件系统和打印系统的请求。网间分组交换（IPX）是传载NCP消息的底层协议。NCP是一种客户机／服务器局域网（LAN）协议。工作站形成NCP请求并对它们进行打包以在使用IPX的网络上进行传送。在服务器上，NCP请求被接收、拆包和解释。理解NCP消息，并且将它们与协议分析器一起看待，有助于你确定那种服务是最经常对服务器提出请求的。从这一信息中，你可以确定是否有特定的服务器工作超载了或存在问题。

    NCP提供的服务对Novell Net Ware网络的用户是可用的。这些服务可以归为下面类别：

    文件访问（打开和关闭文件，从文件中读出或写入数据）。

    文件锁定。

    安全性。

    资源分配跟踪。

    事件确定（event notification）。

    NetWare目录服务和与其他用户的同步。

    连接和通信。

    打印服务和队列管理。

    网络管理。

    NCP对用户和旁边的工作站应用程序都是透明的。例如，一个用户可以从网络服务器请求一个文件，这个服务器以一个本地驱动程序的形式出现。工作站上的重定向功能确定这个文件请求是对本地驱动程序的还是对网络驱动的，然后再对它进行合适的路由选择。从这个意义上讲，工作站上的重定向软件和NCP共同工作来提供对用户的服务。

    NCP是一个LAN协议，它的原始设计是基于假设服务器和工作站相对较近。当加入一个路由器，并且连接覆盖到一个广域网链接时，NCP就导致了通信过度密集。它使用请求／响应策略来管理服务器／工作站通信。如果一个工作站产生了一个请求，在产生另一个请求之前，它必须等待从服务器来的响应。这种所需的确认过程增加了额外的通信量，但Novell已经开发了协议策略来解决这一问题。参见“网间分组交换”。

    通过使用协议分析器，可以对NCP进行分析，以跟踪用户在网络上作什么。每个NCP分组包含一个确定服务请求或被服务类型的代码。这些代码可以很容易地被大多数协议分析器确定，并且可以使用过滤器来观察一个特定类型的服务或来自一个工作站的通信。下面列出了一些请求的简明描述：

    登录和退出登录请求。

    目录处理请求（例如创建，列出，改名，删除等等）。

    文件处理请求（例如打开，关闭，创建，删除等等）。

    服务器请求（清除连接，下载文件服务器，获得磁盘信息，获得文件服务器信息，发送消息等等）。

    消息管理服务（发送或接收消息）。

    打印机和排队服务。

    文件加锁和解锁服务。

    这里列出的只是服务请求和响应的普通类别。总共有上百种调用（call），每种都有特殊的目的和代码。例如，“创建目录”请求有一个特定的类型数（2222）、一个功能代码（22）和一个子功能代码（10）。在协议分析期间，这些代码出现在分组的列表中。从这里讨论的目的上来看，这些代码并不重要。然而它们确实指出了工作站和服务器是如何通信的，以及你使用协议分析器如何跟踪事件。

    例如，由于你怀疑用户可能进行了非授权活动，你可以跟踪用户活动；或你希望跟踪用户进行了被禁止的活动等。Novel1的LANalyzer可以过滤掉为某一用户的工作站产生的分组，或过滤掉产生这个用户请求的某个服务的登录。

    通过跟踪NCP在服务器和某客户之间的请求和响应流，可以看到用户登录和退出登录，启动应用程序，访问在服务器上的文件，与其他用户的通信，以及进行了一些其他活动。然而，对多数部分情况，对分组流进行跟踪只是为发现问题的原因或通信中的瓶颈。

    相关条目：Internetwork Packet Exchange网间分组交换；NetWare；NetWareShell NetWare外壳：Protocol Analyzers 协议分析器。


  • NetWare的磁盘、分区和卷宗 NetWare Disks，Partitions，and Volumes

    NetWare Disks，Partitions，and Volumes NetWare的磁盘、分区和卷宗 参见Disks，Partitions，and Volumes Under NetWare NetWare下的磁盘、分区和卷宗。


  • NetWare的电子软件分发 NetWare Electronic Software Distribution

    NetWare Electronic Software Distribution NetWare的电子软件分发 电子软件分发向网络管理人员提供了一条自动修改操作系统、驱动程序、应用程序和用户网络上的网络协议的途径。Novell的网络导航器电子软件分发（Network Navigator Electronic Software Distribution）产品系列实现了NetLS和许可证服务APSP（LSAPI）许可系统。网络导航器提供关于网络库存、配置和修改活动的报告。它可在IBM大型计算机系统和Tandem计算机上运行，但是软件分发可以下载到NetWare、Microsoft，和Banyan服务器。

    相关条目：Electronic Software Distribution and Licensing电子软件分发和许可。


  • NetWare的链路服务协议 NetWare Link Service Protocol

    NetWare Link Service Protocol（NLSP） NetWare的链路服务协议（NLSP） NetWare链路服务协议（NLSP）是一种新的NetWare网络路由选择协议，它提供改进的网络互联能力和当使用广域网时可以帮助减少费用。NLSP可以减少路由选择的开销和允许顾客从不同的支持协议的多厂商路由器间进行选择。而且目前为建广域网使用的是一种扩展的网间分组交换（IPX）协议，称它为IPXWAN。IPXWAN的工作比点对点协议（PPP）、X．25帧中继和综合业务数字网络（ISDN）广域连接要好，并且它的设计提供在广域网安装时使用的多厂商路由器之间的互操作性。

    NLSP是一种基于中间系统对中间系统的路由选择保持协议的链路状态路由选择协议。中间系统对中间系统的路由选择，保持协议是开放式系统互联（OSI）协议组中的一个部分。最通用的链路状态路由选择方法是开放最短路径优先（OSPF）方法。链路状态路由选择提供了一条控制路由选择过程和路由器对网络中的变化（如链路断开或增加一个新的路由器或网络）进行较快适应的途径。路由的确定可以根据回避拥挤区域、线路的速度、使用线路的费用或其他特性。协议描述出在中间区域的路由器。网络配置的改变很快就可以获得，并且路由器不需要经常交换关于它们服务的网络的信息。Dijkstra算法用于计算到目的地的最短路径。

    相关条目：Internetwork Packet Exchange 网间分组交换；Link State Routing链路状态路由选择；Open Shortest Path First Protocol 开放最短路径优先协议Routing，NetWare NetWare路由选择；Routing，OS1 OSI的路由选择；Routing Protocols路由选择协议；Wide Area Networks 广域网。


  • NetWare的可装入模块 NetWare Loadable Module

    NetWare Loadable Module（NLM） NetWare的可装入模块（NLM） NetWare 3．x和NetWare 4．x操作系统是模块化的可扩展的。可以通过在服务器上安装NetWare可装入模块，对操作系统增加功能，或进行改变、升级和增加。NLM提供的一些服务是：

    支持对除DOS之外的操作系统存储文件。

    通信服务。

    数据库服务。

    管理服务。

    归档和备份服务。

    网络管理服务。

    可以在任何时候对服务器控制台装入或下载任何模块而无需打断服务器的工作。每个模块使用一些附加的内存，所以必须确信服务器具有足够的内存来处理计划安装的NLM。由于这些模块在服务器中的存放位置是和操作系统在一起的，它们和操作系统是紧密耦合的，并且有对服务的固定访问。

    相关条目：NetWare；NetWare 4．x Enhanced Features NetWare 4．X增强特征；Novell。


  • NetWare网络操作系统 NetWare

    NetWare NetWare网络操作系统 Novell在NetWare的名称下提供许多不同的网络操作系统，从简单和廉价的NetWare Lite到NetWare 4．x，NetWare 4．x是专门为企业级网络设计的操作系统。下面简要地介绍这些操作系统产品系列。NetWare 3．x和NetWare 4．x产品的总体特征将进一步介绍。

    NetWare Lite 支持2到25个用户的一种对等层网络操作系统。它在DOS操作系统上运行，并与Microsoft Windows兼容。只要具有很少的联网知识，用户就可以建立一个网络，来共享文件、应用程序和打印机。

    NetWare 2．x为大公司中的小型和中型商务和工作小组设计的网络操作系统。这种操作系统在特定型号或非特定型号的基于Intel 80286、80386、80486的计算机上运行。它提供局部和远程网络互联支持，并向网络管理人员提供一些工具。

    NetWare 3．x一种为在单一专用服务器上支持上百个用户而设计的网络操作系统。它提供许多本节要讨论的高级特征，包括模块设计和集成不同系统（包括小型计算机）的功能。

    NetWare 4．x继承NetWare 3．x所有功能的Novell企业级操作系统，它还增加了一些由它自己就可以生成的支持目录服务和企业级网络的分布多服务器环境的一些新特征。

    如果需要了解更多的信息，参见“NetWare4．x的增强特性”。

    下面讨论NetWare操作系统的主要结构部件。一些特征并不是在所有软件版本中都可以看到的。

    NetWare操作系统驻留在网络服务器上。网络服务器通常是基于Intel的计算机。它提供到工作站的网络连接和服务。图N－4示意了服务器和工作站之间的关系。在客户端的重要部件是重定向软件，它通常是在工作站引导时装入的。重定向是NetWare服务器解释命令，并在网络上发送它们。非网络命令被送到本地操作系统。

    NetWare服务器提供的核心功能是文件系统管理、存储管理和对处理任务进行调度（参见“NetWare的核心协议”）。注意，服务器和工作站之间的关系是基于客户机／服务器模式的，这意味着工作站处理许多处理负载，使服务器解放出来，从而使服务器能够高效地处理它自己的任务。

    网络支持软件将网络硬件和电缆系统连接到操作系统上。这个软件使用指定的驱动程序以支持安装在服务器和在工作站的多种类型的网卡。

    NetWare Architecture NetWare体系结构

    NetWare 3．x和NetWare 4．x是全32位的操作系统，它使用单一地址空间，而没有分段（DOS系统的个问题）。这使得程序能高效地处理。这种操作系统能够处理上千个中断，并且每秒能够处理上千个客户请求。

    NetWare 3．x和NetWare 4．x是模块化的、可扩展的。对网络进行改变、升级和增加都是可能的。可以在服务器中装入NetWare的可装入模块（NLM），与服务器的操作系统相连，以提供如下服务：

    支持非DOS文件的存储。

    通信服务。

    数据库服务。

    信报传送服务。

    归档和备份服务。

    网络管理服务。

    这些模块如图N－5所示地加入操作系统中。可以在任何时候，无需关闭服务器，就装入任何模块，或从服务器控制台上卸载任何模块。每个模块都使用附加存储器，所以需要确信服务器具有足够的存储器以处理计划装入的NLM。由于模块在服务器上是和操作系统放在一起的，所以它们与操作系统紧密耦合，并对服务具有固定访问。

    NetWare对服务器应用是一个理想的平台。它通过在介质级、服务协议级和文件系统级，并发地处理多种协议和标准，解决了连接性问题。如图N－6所示。

    Protocol Independence 协议无关

    NetWare的一个最重要的特征是，它对其他操作系统的支持。它可以和运行DOS、Windows、OS／2和UNIX的工作站进行连接。DOS、Windows和OS／2工作站的支持是与NetWare联系在一起的，就象使用Windows界面的许多管理实用程序一样。提供NetWare的NetWare OS／2工作站软件，能够提供对OS／2工作站到NetWare服务器的通信需求的支持。NetWare允许OS／2的扩展属性和长文件名，并且允许OS／2基于服务器的应用在网络上的运行。作为可选产品，对Apple Macintosh、基于UNIX的NFS和OSI文件传输访问和管理（FTAM），必须加入一个NetWare网络。

    NetWare使用协议无关结构，就是人们所知的开放数据链路接口（ODI），它对在网络上的不同协议提供同时支持。图N－6示意了在服务器上提供多协议支持的ODI接口。注意，允许多种不同的接口卡，这些卡的驱动程序将它们连接到开放数据链路层。分组被指向ODI层上的合适的协议栈，如TCP／IP、IPX或AppleTalk。在图N－6接近顶部的部分，服务协议对安装在NetWare服务器上的不同操作系统提供文件和系统支持。

    在工作站上使用一种类似策略，以允许用户和使用不同通信协议的网络进行连接，如TCP／IP等。将需要Novell的LAN WorkPlace产品或其他厂商的类似产品，以对工作站提供TCP／IP支持。

    如果需要将工作站连接到NetWareLAN或其他类型的网络，如Microsoft LAN管理器的IBM LAN服务器和3Com 3+Share网络，可以在NetWare分组中安装提供开放数据链路接口支持（ODINSUP）的驱动程序。ODINSUP允许ODI网络驱动程序接口和网络驱动程序接口规范（NDIS）共存，NDIS是Microsoft为支持多驱动程序的规范。

    Name Space Support 命名空间支持

    NetWare文件系统通过命名空间支持，提供对不同操作系统间文件命名转换的支持，命名空间支持安装在服务器控制台上。命名空间支持允许在NetWare服务器上存储的文件具有不同的名字长度，具有合法字符，对大小写区别等。对Macintosh的命名空间支持是一种安装在服务器上的模块。

    Performance Features 性能特征

    NetWare在LAN环境十分流行的一个原因是它的性能。在很早以前，Novel1就走出了在DOS下运行网络操作系统的限制，并设计出NetWare，以直接访问服务器CPU的高级特征。NetWare386是在台式计算机领域的第一个32位网络操作系统。NetWare操作系统的内核既是多任务的，又是多线程的，这意味着它具有在服务器上提供多用户操作的能力，并且当在系统上有很重的负载时，它具有高性能。下一小节讨论它的性能改进情况。

    Dynamic Configuration 动态配置

    NetWare对它自己进行动态配置，以和网络上的现行使用情况匹配。下面各项是可以动态配置的：

    存储器的使用。

    目录快速缓冲存储。

    卷宗目录表项的数目。

    打开文件表的大小。

    路由选择缓冲器。

    Turbo FAT索引。

    服务进程。

    活跃事务跟踪系统（TTS）的事务。

    可以改变这些限制和最大值，而不限制NetWare。还能调整操作系统对自身进行配置的速度，并且可以设置最大使用资源的数量。

    Memory Management 存储管理

    NetWare在服务器上支持多达4GB（兆字节）的RAM。NetWare 4．x的存储管理是为提高有效性而设计的。NetWare v．3．11为不同的使用将存储器再分配成5个以上的存储池（pool）。这会导致一些应用程序的运行超出存储器，这是因为当一个进程使用内存处理完毕后，管理例程没有将内存再分配给其他进程使用。Net－Ware4．x以单一存储池的形式管理内存，这对从一个操作到另一个操作，再分配内存是非常有效的。

    The File System 文件系统

    NetWare的通用文件系统（Universal File System）提供许多增强性能特征：

    电梯式查找 磁盘系统的这一特征根据如何被磁盘的读取头最好地访问，对进来的读请求分配优先级，给定它的目前位置。电梯式查找的操作可以类比为一个建筑物内电梯的工作情况。电梯是根据谁是第一个请求，而在楼层间随机地上、下；它在上下移动过程中，寻找路过楼层需要乘座的乘客。电梯式查找减少了磁盘头的移动，从而改进访问时间和减少硬件损失。

    文件高速缓冲存储 文件高速缓冲存储减少必须访问磁盘的次数。最经常读的文件被存放在高速缓冲存储器中，如果需要，在这里就可能访问到所需的文件。这减少了到磁盘查找所需信息的要求，在高速缓冲存储器中的文件是优先分级的，这样，最少使用的文件将从高速缓冲存储器中清除，以为新的文件腾出空间。

    后台写（Background writes） 在NetWare中，磁盘写是和磁盘读分别进行处理的。这种分离允许在用户的磁盘请求减少的过程中，操作系统向磁盘写入数据。后台写策略需要以用户最高的优先权来读数据，这改进了用户感受到的性能。

    重叠查找 如果有两个以上的硬盘，并且它们每个都和它们自己的控制器（磁盘通道）相连，那么就可以使用NetWare的这个特征。NetWare可以同时访问所有的控制器。如果两个磁盘连接到一个控制器，那么在一个时刻只能访问其中的一个控制器。

    Turbo FAT 这个特征就是大家知道的索引文件分配表。Turbo FAT可以对超过2MB文件的文件分配表进行索引，因而它们的段位置就可立即被操作系统获得，而不需要读FAT。

    文件压缩 NetWare4．x使用它的压缩功能可以增加高达63％的磁盘空间。NetWare在后台管理压缩。管理人员和用户可以用标志指示哪些文件在使用之后必须被压缩，或它们必须永远不被压缩。

    块的再分配（Block suballocation） 这一NetWare特性使磁盘具有最大空间。如果存在任何只部分使用的磁盘块（通常一个块的大小为8KB），NetWare为存储小文件或文件的片，将它们分成512字节的再分配块。

    允许文件的大小达4GB，而且文件系统支持在每个卷宗中有超过2百万个的目录和文件及100，000个打开的文件。卷宗可以覆盖多个磁盘驱动程序，并且卷宗的大小可以通过增加新的驱动程序而被动态增加。

    NetWare的可支配文件系统允许修复被删除的文件。可以为删除文件保持为可恢复状态而设置一个最短时间，也可以将一个文件标志为立即物理删除。还可以保持所有的已删除文件直到卷宗超过磁盘空间为止，然后，将移出最老的已删文件以为新的文件腾出空间。当文件恢复后，保留文件的信任权，并可为谁能支配文件设置权力。甚至一个目录被删除了，还可以保持被删除的文件。

    Data Protection Features 数据保护特征

    NetWare网络操作系统包含许多特征来保证数据的安全性和可靠性。安全性特征保护数据不被非授权用户使用并防御病毒的攻击。NetWare支持提供冗余的硬件可靠性特征，以保证数据被正确写入，当部分系统失效时这些数据仍然可用。

    Security 安全性

    NetWare的安全性特征对于大公司广域网环境是很关键的。NetWare的文件系统和DOS文件系统是很不同的。用户通过使用DOS磁盘或简单地自举磁盘来启动服务器是不能访问NetWare的文件系统的。当然，这不能防止有人偷走或毁坏磁盘，你还是需要保存一个备份以防止灾难性事件的发生，但是一个小偷在不知道正确口令和访问权力时是无法访问数据的。

    可以在不同级别提供安全性：

    登录／口令安全性 用户键入LOGIN命令以获得对文件系统的访问。用户要首先输入他们的用户名称，然后再输入口令。没有口令是不允许进行任何访问的。在用户登录之后，根据网络管理人员授予用户的访问权限，可以访问一个互联网络中的计算机。

    帐号限制 在NetWare下面，每个用户有一个由网络管理人员管理的帐户。可以对帐户加上一些限制以控制何时用户可以登录，他们能够在哪些工作站上登录，以及何时他们的帐户被废弃。也可以固定时间地强迫用户更改他们的口令，并需要一个和经常使用的口令不类似的独特的口令。

    对象和文件安全性 在NetWare 4．x中，网络管理人员授予用户对象、目录以及文件的信任权力（trustee rights）。这些权力准确地确定用户如何才能访问系统的资源。管理器通常被授予对象用户帐户和服务器权力。用户被授予对目录和文件的权力，所以他们能够访问文件系统。

    互联网络安全性 NetWare目录服务（NDS）跟踪互联网络上的所有对象，包括用户对象和他们的访问权力。网络管理人员通过使用NDS来创建和管理用户帐户，跟踪网络资源，授权用户对网络资源进行访问。一旦用户登录，他们就获得了对NDS系统授予他们的所有网络资源的访问权力。

    除了实现这些安全性特征之外，NetWare还进行幕后（behind-the－scenes）安全性检查。它对服务器上的所有口令进行加密，并对用户口令传输到服务器过程中的用户口令进行加密。最后这种特征防止电子窃贼通过窃听电缆来获得口令，从而可以正常用户的身份访问系统。

    Reliability Features 可靠性特征

    NetWare网络操作系统提供一些重要的特征，以确保生命力（survivablity）及快速恢复服务器上的数据。

    写后读检验 这种特征是，当每次向磁盘上写数据时，都对它们再进行读操作，以检验写操作是否正确。如果出现了错误，当数据还在cache中时就将它们再次写入。一次错误可以指示一个坏区，它可以被热定位（HOT FIX）特征标记为不可用。

    复制目录 NetWare复制根目录结构，以在主目录结构被毁坏时，提供一个备份。

    复制FAT 保持一份文件分配表的复制件，作为后援备份。如果原始的FAT丢失了，通过这份复制的FAT仍然保持磁盘的可访问性。

    热定位 这一特征在系统的运行过程中，检测并纠正磁盘错误。将坏区的数据移动到磁盘上好的区域，并将坏区标记为不可用。

    系统容错（SFT）这一特征允许为系统的硬件提供冗余。可以在系统中安装两个硬盘，然后将主硬盘的内容镜像到第二个磁盘上（参见“磁盘镜像和复置”）。如果主硬盘失效了，第二个硬盘将接替工作。磁盘控制器也可以被复置，以进一步防止硬件失效的损失。SFT级别Ⅲ（可选）通过复置整个服务器，将冗余又推进了一步。如果主服务器失效了，第二个服务器可以不中断地接替过来工作。

    事务跟踪系统（TTS） 事务跟踪系统在未完成写时保护数据不受损坏。这可能在用户正在编辑数据库中的记录时，服务器停止工作时出现这种情况。当服务器重新启动时，在它返回到未完成事务之前，文件就恢复到这次事务之前的状态了。在这种系统中，事务要么完全完成了，要么完全被放弃。

    UPS镜像 NetWare监督不间断电源（UPS）的状态，以确定服务器是否正在利用后备电源进行工作。

    NetWare兼容UPS可以向NetWare提供这种信号。如果出现了电源失效，NetWare警告用户（他必须在失效范围之外或使用他自己的UPS），然后开始保存每一个打开的信息（cache中的数据）并安全地下载系统。

    Built－in Internetwork Routing 嵌入式互联网络路由选择

    NetWare提供内置互联网络路由选择服务。对用户来说，互联的网络就象一个网络一样。创建路由器简单得就象在NetWare服务器上安装多个接口卡，然后在安装时或安装后的维护中，为这些卡选择驱动程序。也可以在外部系统上安装路由选择服务，以便从服务器上移走额外的工作负载，从而改进它的性能。

    Communication Services 通信服务

    NetWare销售一个完整的支持通信的分组系列，称为NetWare通信服务，它在NetWare V．3．11和NetWare 4服务器上运行。这些产品提供LAN到主机，LAN到LAN，和远程到LAN的连接。NetWare通信服务集中于LAN到主机，具有大型系统网络体系结构（SNA）的网络管理需求。这些产品包括NetWare for SAA、NetWare 3270 LAN Workstation Packages for DOS、Macintosh、Windows、NetWare通信服务管理器，它是一个基于Windows的管理程序。

    Print Services 打印服务

    NetWare 4．x包括一个打印服务分组，它允许网络上共享多达256个打印机。一个打印服务器管理打印队列和用户访问打印机的方式。这个打印服务器可以被安装在NetWare文件服务器上，或作为工作站上的一个专用任务。可以将打印机连接到打印服务器或连到网络上的任何工作站。用户可以访问这些在打印服务器内被共享的打印机。

    Distributed Directory Services 分布式目录服务

    NetWare的分布式目录服务，是在NetWare 4．x上作为NetWare目录服务（NDS）而实现的。NDS是基于x．500目录服务描述的。这个服务保持对所有网络用户、服务器、互联网络资源进行跟踪。信息保存在一个数据库中。管理人员和用户可访问这个数据库来放置用户和资源，而不需要关心它们的位置。

    NDS的设计是很关心大型互联网络的。它通过一个公共命名服务，提供了整个网络目录的集中管理。用户和资源的这个目录数据库是被以固定时间间隔修改的。这一服务为其他目录服务提供了一个信关，包括Apple名字联编协议、Sun Microsystems的黄页（Yellow Pages）（NFS支持）和TCP／IP域名服务。

    Management Features 管理特征

    NetWare为监督网络状态提供了一些实用程序，并且Novell销售的管理软件包还提供一些增强功能。这些特征将在后继部分进行讨论。

    NetWare Administrator NetWare管理器

    NetWare 4．x包括NetWare管理器，它是一种基于Windows的应用程序，用于管理NetWare目录服务对象，如用户、网络资源、磁盘目录和文件。图N－7示意了NetWare管理器的屏幕显示。NetWare管理器的一个基于文本的版本称为NETADMIN，它也与NetWare 4．x一起提供，但是NETADMIN不提供对目录和文件管理的支持。NetWare管理器能够用于替代许多命令执行实用程序。它易于使用，并提供更多的功能。NetWare管理器需要一个运行Microsoft Windows环境的Inter 80386或更高系统。

    注意图中的目录树。在顶端是一个机构名称。从它分支的是它的东部分支（DivEast）和它的西部分支（Di－vWest）。DivEast分支目录被关闭了，所以你看不到它的用户或资源，但是DivWest是展开的。你可以单击DivWest下的任何用户或资源，然后从Object菜单选择Detail，以改变这个对象的性质。例如，你可以选择AColgan对象，它是一个用户帐户，并且打开它以改变用户的登录限制或对文件系统的权力。

    管理人员使用NetWare管理器，基本上是为创建用户对象（帐户）和管理用户如何访问网络、它的资源和它的文件。一种浏览功能使你能够快速定位相似的对象。例如，你可以列出生活在某一特定邮政编码区域内的所有用户，或对某个特定服务器卷宗有权力的所有用户。一旦你定位并选择了一个对象，你就能够使用NetWare管理器来改变安全性权力、特性和对象的其他方面的情况。可将NetWare管理器用于：

    创建附加对象，如用户和打印机对象。

    改变用户的登录限制。

    改变用户对资源的访问。

    改变用户对目录和文件的访问。

    改变对象的受托者（受托者是能够使用特定对象的用户）。

    授予其他用户对网络上某一对象的操纵权力。

    指定用户的组和对这些用户创建登录开工（profile）文件。

    创建和编辑系统范围和个人用户登录原语。

    安排和组织NetWare目录服务树的结构和它的分区。

    MONITOR 监控器

    监控器是一个NetWare可装入模块，它可在文件服务器控制台上运行，或者在远程管理设备（Remote Management Facility，后面将讨论）上运行，也可在一个远程站上运行。监控器使你可以在控制台上执行下述任务：

    为NetWare控制台设置口令。

    观察服务器的使用情况。

    观察快速缓冲存储器的状态。

    观察工作站的连接。

    看被用户打开的文件。

    清除连接。

    观察磁盘启动器的状态。

    观察卷宗的状态。

    为磁盘写设置检验级别。

    激活或关闭卷宗和硬盘驱动程序。

    列出当前LAN驱动程序。

    列出当前安装模块。

    观察文件锁状态。

    观察内存使用情况。

    Remote Management 远程管理

    NetWare和NetWare远程管理设备（RMF）密切相连，它允许网络管理人员对NetWare进行安装和升级、设置网络服务和从远程工作站维护NetWare。

    SERVMAN

    SERVMAN是NetWare 4．x中包括的一个新的实用程序。它在控制台上运行，并允许超级用户观察和修改服务器配置。

    对原来的NetWare版本熟悉的人对SET命令也一定很熟悉，它用于改变操作系统的一些情况。SERV－MAN通过为每个设置选项显示帮助信息和通过显示建议设置，来自动使用这一命令。如果改变了一个设置，SERVMEN自动修改服务器启动文件。

    Requirements for Running NetWare 运行NetWare的要求

    下面列出了安装和运行NetWare版本3。11和NetWare版本4所需的硬件：

    一个80386或更高的系统。支持这些系统的SX和DX版本。

    最少5MB内存，但建议16MB作为起始点，这是因为存储器已经很便宜，并且它对服务器的性能影响很大。在一个大网络上的服务器可能需要32MB的内存，这依赖于安装的软件模块和将要访问服务器的用户数目。

    一个至少有30MB的硬盘。为DOS分区需要5MB，为NetWare磁盘分区需要25MB。如果要为OS／2运行NetWare，那么需要一个至少有120MB存储的硬盘。为了提供容错，需要复置硬盘设备和控制器，甚至如果使用SFT级别Ⅲ，就需要复置服务器。

    为每个希望在服务器内建立网桥或路由器的网络，加一个或多个网络卡

    相关条目：Client－Server Computing 客户机／服务器计算；Disks，Partitions，and Volumes under NetWare在NetWare下的磁盘、分区和卷宗；DOS Requester，NetWare NetWare的DOS请求解释器；Internetwork Packet Exchange 网间分组交换；LAN Workplace Products Novell的LAN Workplace产品；Large Internet Packet Exchange 大型Internet分组交换；NetWare4．x Enhanced Features NetWare 4．x的增强特征；NetWare Core Protocol NetWare的核心协；NetWare Loadable Module NetWare可装入模块；NetWare SFT Level Ⅲ NetWare SFT级别Ⅲ；NetWare Shell NetWare外壳；NetWare Volumes NetWare卷宗；Novell。


  • NetWare软件产品 NetWare Products

    NetWare Products NetWare软件产品 可以从Novell获得如下在NetWare 3．x和NetWare 4．x服务器上运行的操作系统产品。

    NETWAR EFLEX／IP Novell FLeX／IP产品是一种NetWare可装入模块（NLM），它解决在NetWare UNIX环境中的一些基本文件、打印和管理问题。FLeX／IP包括三种独立的产品，它们用字母F、L和X来代表。F用于表示运输协议（FTP），它们可以提供文件传输的能力。L表示线路打印守护程序，它提供标准UNIX打印实用功能，可使得打印机的访问在UNIX和NetWare系统之间透明。没有L使用程序，NetWare打印共享和UNIX打印共享在一个互联网络上将是每家一个的方式。X表示X-Windows协议支持。当这种协议被安装后，可在UNIX系统上的NetWare控制台上运行一个网络管理器，并且这个管理器可以从远地来对NetWare网络进行管理。

    NETWARE FOR SYSTEMS APPLICATION ARCHITECTURE（SAA） NetWare for SAA使得NetWare工作站可以访问IBM大型计算机和AS／400主系统。NetWare的安全性、名称服务，和管理将被保留。可以同时使用多达506个显示、打印、和高级程序对程序通信（APPC）会话。对AS／400工作站的访问对NetWare工作站来说是透明的。NetWareforSAA是一个NetWare可装入模块，它安装在一个NetWare文件服务器上，对网络用户提供了一个信关服务（gateway services）。另外，当使用NetWare Runtime应用时，这一产品可以在一个专用的通信服务器上运行。NetWare Runtime是和NetWare for SAA联系在一起的。

    NETWARE FOR UNIX NetWare for UNIX使得NetWare服务可以在许多不同计算机系统上运行。它已经被移植到NetWare for UNIX的合伙商生产的系统中，这些合伙商包括Data General、Hewlett－Packard、IBM，MIPS／Silicon Graphics、Sequent、SunConnect和Unisys。一个运行NetWare for UNIX的主机系统在功能上等效于NetWare文件服务器，它可以对运行在OS／2、DOS、Microsoft Windows或Apple Macintosh操作系统的网络客户提供文件、打印和备份服务。

    NETWARE NETWORK FILING SYSTEM（NFS） NFS是一个为UNIX环境的分布式文件系统。NetWare NFS是安装在NetWare服务器上的，它使文件、打印机和其他网络资源可以被UNIX用户共享。需要传输控制协议／因特网协议（TCP／IP）通信运输协议来支持NetWare NFS。

    相关条目：Distributed File Systems 分布文件系统；NetWare；Novell；Systems Application Architecture系统应用体系结构；Transmission Control Protocol／Internet Protocol 传输控制协议／因特网协议；UNIX。


  • NetWare的三级系统容错 NetWare SFT Level Ⅲ

    NetWare SFT Level Ⅲ NetWare的三级系统容错 NetWare的三级系统容错是一种可选的Novell软件产品，它可以提供真正的容错功能。它保证关键任务的应用程序可以连续不断地被用户所用。一个SFTⅢ配置包括两个用高速数据链路连接在一起的服务器。一个服务器镜像另一个服务器中的数据，如果主服务器坏了，它可以立即投入使用。对用户来说没有任何服务损失。SFTIII是一种在服务器硬件之外工作的纯软件解决方式。

    SFT Ⅲ可防止以下机器失效带来的损失：随机存储器（RAM）的失效、磁盘的失效、局域网适配器的失效。它允许将服务器放置到不同的地方，以防止局部性的灾难事件或电源故障，但在复置系统需要使用高速链路来保持紧密同步。另外，由于服务器是镜像的，所以当一台服务器继续工作时，可在另一台上进行例程服务和升级。当升级后的服务器又接连回后，它的文件系统需要和另一台服务器进行同步处理。

    为了改进在SFT Ⅲ下的工作性能，Novell建议使用双处理器系统。一个微处理器执行所有与硬件相关的输入／输出（I／O）和进行镜像的同步，另一个微处理器处理文件服务和运行其他服务器应用。还需要在每个服务器上具有兼容的高性能镜像服务器链路MSL（Mirrored Server Links）。MSL通常是100Mbps的以太网或光纤链路，它们可以从Standard Micros ystems和Thomas－Conarad等厂商获得。

    相关条目：Data Protection 数据保护；Disaster Recovery灾难恢复；Disk Mirroring and Duplexing Systems磁盘镜像和复置系统；Duplexing Systems复置系统；Fault Management失效管理；Mirroring镜像；Redundant Arrays of Inexpensive Disks廉价磁盘冗余阵列；System Fault Tolerance 系统容错。


  • NetWare工作站外壳程序 NetWare Shell

    NetWare Shell NetWare工作站外壳程序 基本上，NetWare是一个客户机／服务器操作系统。NetWare外壳软件是一个客户程序，它使得一个工作站和NetWare服务器相连。外壳，有时也成为请求者软件（required software）中途截获网络服务的请求，并将它们发往NetWare服务器。这些请求包括一个打开文件或在共享打印机上打印一个文件的请求。存在两个版本的外壳。虽然，在许多局域网络（LAN）中还使用着老的IPX／NETX，但是所有NetWare的现行版本都使用开放数据链路接口（ODI）外壳，它提供对多协议栈和多网络接口卡的支持。

    请求者软件确定用户或应用请求是向局部操作系统的还是向NetWare服务器的。如果这些命令是向NetWare的，它就指导它们通过网络。局部命令被送到工作站的操作系统。虽然在NetWare网络上的标准通信协议是网间分组交换（IPX）协议，但使用ODI，也可以安装传输控制协议／因特网协议（TCP／IP）、Apple Talk和其他协议，从而使用户可以访问其他类型的系统和网络。

    IPX／NETx Shell IPX／NETx外壳

    在IPX／NETx外壳中有两个主要部件，它们都是典型的在工作站自举时装入的“终止并等待驻留”TSR（terminate-and-stay－resident）型软件模块。首先装入IPX．COM以初始化网络接口卡，并在工作站和服务器间建立基本连接。然后，装入NETx以提供对指定版本的DOS支持。注意NETx中的x是指DOS的版本号，例如DOS版本3或DOS版本5。

    必须根据网络接口卡的类型，将IPx．COM对每个工作站进行配置。一个与网络驱动程序链接的称为IPx．OBJ的文件是专门为网络接口卡设计的，以通过使用NetWare提供的一个实用程序产生IPx．COM文件。使用相同接口卡的工作站，如果具有同样的板设置，就可以使用同样的IPx．COM文件，但是如果有任何工作站使用不同的板或卡，或一个有不同中断或I／O设置的卡，那么就必须生成一个特有的IPx．COM文件以和板匹配。

    和NetWare工作站软件一起提供不同版本的NETx．COM，以匹配不同版本的DOS。NETx．COM必须在IPx．COM文件之后再被装入。一旦这个外壳软件被装入，对NetWare服务器的访问就变成了对驱动程序F：或下一个可用驱动程序的访问，具体的驱动程序号决定于在本地工作站上的驱动程序数。你可以交换到这个驱动程序，再执行LOGIN命令以访问服务器。

    可以生成一个称为NENT．CFG的文件，以为每个独立的工作站包含特殊的启动参数和配置信息。

    NetWare DOS Requester NetWare DOS请求解释器

    NetWare DOS请求解释器是一组替换IPX／NETx外壳的模块。它们在最新的NetWare版本中可以得\到。安装实用程序可以自动装入这些模块和对工作站进行配置。它请求安装者指定网络接口卡类型和对卡的设置。然后，这个软件被安装到目录NWCLIENT中。下面按照请求解释器软件对这些模块的安装顺序对这些模块进行介绍。

    链路支持层（LSL）LSL是一个软件驱动程序，它在多协议栈，如IPX和TCP／IP（如果安装了它们）之间指导信息的流动。

    LAN驱动器 这是一个特定的驱动器，它和安装在工作站上的一个或多个网络接口卡相匹配。例如，这个驱动器可能被称为NE2000，表示为Novell标准以太网络适配器

    IPXODI这是装入IPX协议栈的驱动程序。这里可以指定另外一些驱动程序，例如装入TCP／IP协议栈的驱动程序。

    VLM 它是装入DOS请求解释器支持软件的一个可执行文件。VLM实际上装入所有处理网络连接的模块、目录服务或约束（NetWare 4．X之前）支持、加密和鉴别支持以及文件输入和输出支持。

    相关条目：Client－Server Computing客户机／服务器运算；DOS Requester，NetWare NetWare DOS请求解释器；Internetwork Packet Exchange 网间分组交换；LAN Workplace Products LAN Workplace产品；Large Internet Packet Exchange 大型因特网分组交换；NetworkDriverStandards 网络驱动程序标准；Novell；Open Data－Link Interface 开放数据链路接口。


  • NetWare的（文件）卷宗 NetWare Volumes

    NetWare Volumes NetWare的（文件）卷宗 NetWare文件系统包含可以有一个或多个卷宗的服务器。每个服务器的第一个卷宗总是称为SYS。其他卷宗的缺省名称是VOL1、VOL2等，但是你可以给它们一些专用的名称，例如OS2VOL、MACVOL、USERS或EMAIL，以描述在这些卷宗中存储了什么内容和谁可能使用它。每个卷宗都有它自己的目录结构。

    当NetWare服务器自举时，卷宗被装入。SYS卷宗是被自动装入的；其他卷宗是通过使用服务器启动文件AUTOEXEC．NCF来装入的。你也可以在NetWare控制台上使用MOUNT或DISMOUNT命令来装入或下载一个卷宗。由于每个卷宗总要使用0．5MB到2MB的内存，具体的数目依赖于卷宗的体积和类型（DOS命名空间、UNIX命名空间或Macintosh命名空间），所以使不使用的或较少使用的卷宗保持下载状态是有益的。

    可以通过对系统增加硬盘来扩展卷宗，并使用NetWare INSTALL实用程序来将磁盘集成到现有的卷宗中，这在一些情况是不影响服务器继续工作的。卷宗在物理上被分为可以覆盖一个或多个磁盘的段。一个卷宗能够有多达32个卷宗段，它们可以跨越不同的磁盘，但每个磁盘仅仅能包含8个卷宗段。将卷宗的段扩展到不同的磁盘可以改进性能，这是因为它允许对卷宗段同时进行读或写。它的不好的一面是，如果有一个磁盘关闭了，那么整个卷宗就不能装入。建议你总是对分段的卷宗进行镜像。

    卷宗是在NetWare文件系统的最高层次。一个卷宗有一个根目录和分出的子目录。就象已经提过的，服务器上的第一个NetWare卷宗称为SYS，并且它包含NetWare系统和公共文件，除非它们被移动到别处。

    通过使用MAP命令，将卷宗的名称映射到一个驱动字母，可以访问其他的卷宗。NetWare允许在每个服务器上有多达64个卷宗。例如，可以将APPS卷宗上的BUDGDOCS目录映射到驱动程序字母R：然后，通过敲驱动器字母R：就可以交换到这个卷宗和目录。对这个目录上的文件进行列表或进行工作的用户，他们必须对这个目录有工作权限。

    NetWare Directories NetWare目录

    NetWare目录系统类似于DOS的目录系统。每一个卷宗都有一个根目录。可以从根目录分出一些子目录，从这些子目录又可以分化出子目录。NetWare的安装程序创立SYS卷宗的目录结构，如图N－8所示，并将在下面介绍。

    SYS：SYSTEM SYSTEM目录包含NetWare可执行文件和其他正常情况下只能由超级用户访问的模块。

    SYS：PUBLIC PUBLIC目录包含NetWare实用程序，它们通常可被所有的用户访问。

    SYS：LOGIN LOGIN目录包括LOGIN命令和其他将用户登录进系统的文件。在登录进之前，它被映射成工作站上的第一个网络驱动。

    SYS：MAIL MAIL目录是以前NetWare版本剩余下来的。NetWare用于在MAIL中为每个用户创立一个子目录，并在这些子目录中存储他们的登录原语。现在，登录原语在NetWare目录服务系统中被作为用户对象的一部分来存储。然而，MAIL还为需要它的应用而被保留。

    Directory Naming and Mapping 目录命名和映射

    引用NetWare卷宗上的目录，就和通过使用路径引用DOS目录。可对一个目录加上卷宗名就可以引用其他卷宗，并且可以加上服务器名称来引用服务器。例如，在SYS卷宗上SYSTEM目录的全名是SYS：SYS－TEM。如果这个目录有一个称为UTILS的子目录，它的全名就是SYS：SYSTEM＼UTILS。如果你正在这个卷宗内工作，那么你就不需要指明卷宗名了。如果这个卷宗在一个称为ACCTG的服务器上，你就可以用AC－CTG＼SYS：SYSTEM＼UTILS来引用它。

    用户常常为他们的个人文件和程序而需要硬盘空间。多数NetWare超级用户为用户创建主目录（home directories），它从一个称为SYS：HOME或SYS：USERS的目录分支出。（注意，这个父目录并不需要在SYS卷宗上）。

    相关条目：Disks，Partitions，and Volumes under NetWare NetWare下的磁盘、分区和卷宗；NetWare；NetWare 4．x Enhanced Features NetWare 4．X增强特征；Volume，NetWare NetWare卷宗。


 Network Architecture 网络体系结构
：用来建立通信、确保可靠的信息传输的计算机网络基础结构，包括硬件接口和功能层协议。网络体系设计的目的是对于建立网络连接和无冲突地传输信息的复杂性提供哲学上和物理上的标准。存在有不同的网络体系，包括国际上已经接受的七层 ISO/OSI 模型。


  • 网络体系结构 Network Architecture

    Network Architecture 网络体系结构 网络体系结构定义计算机设备和其他设备如何连接在一起以形成一个允许用户共享信息和资源的通信系统。存在专用网络体系结构，如IBM的系统网络系统结构（SNA）和DEC的数字网络体系结构（DNA），也存在开放体系结构，如国际标准化组织（ISO）定义的开放式系统互联（OSI）模型。网络体系结构在层中定义（参见“分层体系结构”）。如果这个标准是开放的，它就向厂商们提供了设计与其他厂商产品具有协作能力的软件和硬件的途径。然而，OSI模型还保持在模型阶段，它并不是一个已经被完全接受的国际标准。考虑到大量的现存事实上的标准，许多厂商只能简单地决定提供支持许多在工业界使用的不同协议，而不是仅仅接受一个标准。

    分层在一个“协议栈”的不同级别说明不同的功能。这些协议定义通信如何发生，例如在系统之间的数据流、错误检测和纠错、数据的格式、数据的打包和其它特征。基本结构如图N－9所示。

    通信是任何网络体系结构的基本目标。在过去，一个厂商需要非常关心它自己的产品可以相互之间进行通信，并且如果它公开这种体系结构，那么其它厂商就也可以生产和此竞争的产品了，这样就使得这些产品之间的兼容通常是很困难的。在任何情况下，协议都是定义通信如何在不同操作的级别发生的一组规则和过程。一些层定义物理连接，例如电缆类型、访问方式、网络拓朴，以及数据是如何在网络之上进行传输的。向上是一些关于在系统之间建立连接和进行通信的协议，再向上就是定义应用如何访问低层的网络通信功能，以及如何连接到这个网络的其它应用

    如上所述，OSI模型已经成为所有其它网络体系结构和协议进行比较的一个模型。这种OSI模型的目的就是协调不同厂商之间的通信标准。虽然一些厂商还在继续追求他们自己的标准，但是象DEC和IBM这样的一些公司已经将OSI和象TCP／IP这样的Internet标准一起集成到他们的联网策略中了。

    当许多LAN被连接成企业网时，互操作性是很重要的。可以使用许多不同的技术来达到这一目的，其中包括在单一系统中使用多种协议或使用可以隐藏协议的“中间件”的技术。中间件还可以提供一个接口来允许在不同平台上的应用交换信息。使用这些技术，用户就可以从他们的台式应用来访问不同的多厂商产品了。

    相关条目：AppleTalk；Client－Server Computing 客户机／服务器计算；Digital Network Architecture数字网络体系结构；Distributed Computing Environment 分布式计算环境；Layered Architecture 分层体系结构；Middleware中间件；Open System Interconnection 开放式系统互联；System Application Architecture系统应用体系结构；System Network Architecture 系统网络体系结构。


  • 网络控制程序 NetWork Control Program

    NetWork Control Program（NCP） 网络控制程序（NCP） NCP是在IBM前端处理器（FEP）上运行的控制软件。FEP是一个专用的计算机，它控制IBM主机与通信终端间的通信。IBM 3725和IBM 3745是运行NCP软件的前端处理器，这些NCP软件和运行在物理单元（PU）上的程序进行通信。PEP连接到IBM 3270主机。

    NCP基本上是一种扮演输入／输出操作系统的应用程序。它管理所有来自一个网络和发往一个网络的数据。NCP实际上是大型计算机产生的一个模块，它在FEP启动时装入到FEP上。

    相关条目：Cluster Controllers，IBM IBM的机群控制器；Communication Controller 通信控制器；IBM；IBM Mainframe Environment IBM大型计算机环境；IBM Networking Blueprint IBM的联网方案；Systems Network Architecture 系统网络体系结构。


  • 网络驱动程序接口规范 Network Driver Interface Specification

    Network Driver Interface Specification（NDIS） 网络驱动程序接口规范（NDIS） Microsoft网络驱动程序接口规范（NDIS）的设计是通过将不同的协议从网络接口卡上拆除，使得用户可以访问不同的协议。在设计过程中，协议并不需要关于网络卡的任何情况。没有网卡规范接口，只有一个对协议的通用接口，如图N－10所示。为了使用NDIS卡，需要安装卡和它的驱动程序，装入希望使用的所有协议并通过使用一个称为NETBIND的命令将它们连在一起。

    NDISI的基本目的是在一个服务器或一个工作站上安装多个协议栈，从而使用户能够与不同的协议进行通信。在NDIS之前（或可比较的Novel1开放数据链路结构或ODI），必须先下载一个协议栈，然后再装入下一个协议栈。NDIS使得多个协议栈对一个网络接口卡（NIC）寻址，连接后的网络上的系统如图N－11左边所示；或使每个协议栈寻址它自己的NIC，如图N－11右边所示。NDIS允许一个工作站至多拥有四个NIC，并且每个NIC支持四个协议栈。 例如，一个用户希望既和Novell NetWare服务器相连（网间分组交换协议IPX），又与一个基于UNIX的系统相连（传输控制协议／Internet协议，TCP／IP），他只需简单地将IPX和TCP／IP协议栈装入在一起即可。NDIS在两个协议栈之间进行仲裁，并保证从NetWare服务器来的消息被送到IPX栈，而将TCP／IP消息指引到TCP／IP协议栈。NDIS既提供对网络接口卡访问的协议，又提供对介质访问的协议。如果NetWare服务器和UNIX系统是在分离的网络上，工作站就需要两个接口卡，并且必须为每个卡都装入一个协议栈，如图N－11所示。

    同样，Novell NetWare服务器和Microsoft Windows NT高级服务器也可以运行多协议栈，因而在不同类型工作站（DOS，UNIX，Macintosh等）的用户都可以访问服务器。

    当NDISI在Windows NT自举期间内置入时，它读取一个称为PROT（OCOL．INI的文件内容这个文件描述安装在工作站和协议站的NIC并和每个卡相连。

    为提供对NDIS和ODI一起的支持，Novell开发了开放数据链路接口网络支持规范，或ODINSUP（SUP源于“support”）。它允许ODI和NDIS网络驱动程序接口共存，因而工作站就可以和任何ODI系统相连，例如一个IPX服务器和任何NDIS系统（如一个NDISLAN管理器服务器）相连。

    相关条目：Client Software客户机软件；DOS Requester DOS请求解释器；LAN Drivers LAN驱动程序；NetWare Shell NetWare的外壳程序；OpenData－link Interface 开放数据链路接口。


  • 网络驱动程序标准 Network Driver Standards

    Network Driver Standards 网络驱动程序标准 在过去，每个网络操作系统提供一个标准驱动程序接口和网络通信协议。例如，Novell NetWare网络在许多不同的网络接口卡（NIC）上支持网间分组交换（IPx）通信协议。今天，必须将许多运行不同协议的不同类型的系统连接到网络上。这是由于企业级网络的产生，它将以前独立的工作小组的网络连接在一起，或将使用不同网络的公司连接在一起。

    有两种主要的允许多协议支持的网络驱动程序标准：Microsoft网络驱动程序接口规范（NDIS）和Novell开放数据链路接口（ODI），它们为将多种协议栈装入到计算机内存并支持一个或多个网络接口卡提供了一条途径。这些标准的每一个都将在相应的标题下进行讨论。

    相关条目：Client Software 客户机软件；DOS Requester DOS请求解释器；LAN Drivers LAN驱动程序；NetWare Shell 网络驱动程序接口规范；NetWare Shell NetWare的外壳程序；Open Data－link Interface开放数据链路接口。


  • 网络动态数据交换 Network Dynamic Data Exchange

    Network Dynamic Data Exchange（NetDDE） 网络动态数据交换（NetDDE） 参见NetDDE。


  • 网络文件系统 Network File System

    Network File System（NFS） 网络文件系统（NFS） 参见Distributed File Systems分布式文件系统；File Systems in the Network Environment 网络环境中的文件系统。


  • Network interface card 网卡

    网卡（或网络接口卡）是安装在电脑中的一种集成电路板或者板卡，用来帮助电脑接入网络。在一个局域网（LAN）中使用的个人电脑和工作站，一般都安装有一块特别针对局域网传输技术设计的网卡。这些局域网传输技术包括以太网（Ethernet）和令牌网（Token Ring）等。网卡可以使电脑和一个网络始终处于连接状态。


  • 网络接口卡 Network Interface Card

    Network Interface Card 网络接口卡 网络接口卡是安装在计算机上的适配器，它们提供对网络的连接点。每个NIC的设计都是为了一种特定的网络，例如以太网络、令牌环网络、FDDI、ARCNENT等等。它们在和开放式系统互联（OSI）协议栈相应的物理层进行操作，并向特定的电缆提供一个连接点，如同轴电缆、双绞线电缆、光缆。无线局域网的NIC有一个天线以与一个基地站进行通信。

    物理层协议定义网络接口卡。这些协议定义机械和电接口规范。机械规范定义对电缆的物理连接方式。电气规范定义在电缆上传输位流的方式和提供数据穿越网络的定时控制信号。根据网络接口卡的类型，依照IEEE 802．X标准或其他标准可以使用一种特定电缆访问方式。IEEE 802．X标准定义载波监听多路访问／冲突检测（CSMA／CD）、令牌传递和其他访问方式。IEEE 802．X网络，例如以太网络、令牌网络和FDDI使用这些访问方式。

    网卡上的电路实现多种网络通信功能。为对数据传输作准备，在两个网站之间进行一个握手过程。这个握手建立通信参数，例如传输速度、分组的大小、超时参数、缓冲器的大小等等。一旦建立了通信参数，数据分组的传输就开始了。在数据被放到电缆上进行传输之前，数据被按两种方式进行转换。第一种，一个并行到串行的转换，将数据变换成可以在网络上进行传输的电子信号的位流。第二种，数据被编码和压缩，以改进在一些情况下的传输速度。

    可获得的网络接口卡可以分成两类：跟随标准规范的接口卡；跟随标准规范协议但却具有附件以提高性能的接口卡。这里提到的一些特征将在后面讨论。记住，网络上接口卡硬件设计的差异可能会降低性能。例如，一个有16位接口的网络卡向一个8位的卡发送数据，通常发送的速度高于这个8位卡能处理的速度。为解决这一瓶颈，可以使用存储缓冲器以抓住并保存传送来的数据，防止数据溢出并允许16位卡完成它的传送，即使是8位卡处理收集缓冲器中的数据也是如此。

    在网络接口卡和计算机的存储器之间可能出现另一类瓶颈。一旦网络接口卡接收到信息，有四种方法从网络接口卡移出信息到计算机，这些方法将在下面介绍，它们大都应用于基于Intel系统的直接存储器。

    直接存储器访问（DMA） 当使用直接存储器访问（DMA）方式时，在PC上的DMA控制器从网络接口卡的缓冲器中直接控制总线和传输数据到PC机的指定内存位置。这减少了CPU的一些工作，增进了它的性能。在传输数据期间，CPU还可以处理其他任务，但是不能访问存储器。

    共享适配器存储器 使用共享适配器存储器技术，网卡拥有系统处理器可以直接访问的存储器。这些存储器被映射到DOS系统（约640KB）的高端内存地址。也就是说，处理器认为网卡上的存储器是系统存储器的一部分，并相应地访问它们。如果不能保证分配给网络接口卡的存储区域是未被其他卡或进程（例如，一个驱动程序或应用程序）使用的，那么就会导致一些问题。

    注释：当你设立一个共享内存的网卡时，应设置网卡上的开关或设置它的启动命令，以指定网卡将使用的内存区域。“适配器手册”象基本存储器地址那样引用它们。共享存储在基本存储地址开始，并扩展共享存储器的长度，它可能是8KB，或16KB，或32KB。你需要确信没有其他卡或进程使用这个存储区域。如果有，你必须改变网络接口卡基本存储地址或与它冲突的适配器的地址。

    共享系统存储器 共享系统存储器技术使用系统上的（而不是卡上的）一个共享系统存储块（通常为8KB到32KB），它被网络接口卡上的一个特殊处理器控制。NIC将信息放置在一个共享存储器区域，系统处理器可以对它直接进行访问。就象使用共享适配器存储器技术一样，你必须确信共享系统存储器区域没有被其他卡或进程使用。

    总线主宰（BUS MASTERING）使用总线主宰技术，网络适配器能够直接传输信息到系统存储器中，而不中断系统处理器的工作。使用这种方式的网卡提供一种增强DMA方式，这时，适配器认可系统总线的控制，并将信息直接写到计算机的存储器中，而不从处理器请求许可。总线主宰在MCA和EISA机器上是可行的，这是因为它们的高级总线设计。虽然使用总线主宰技术可以提高性能20％到70％，但它们对于通用工作站而言却过于昂贵。对于高性能计算机，它却是被特别推荐的。

    Global Addressing 全局编址

    全局编址保证每个网络接口卡都有一个特有的表示身份的结点地址。令牌网和以太网卡的地址是在卡上硬联线的。ARCNET地址是可以被用户开关选择的。

    电子电气工程师协会（IEEE）负责对令牌卡和以太卡赋予地址。每个生产商都被授予一个特有的代码和一个地址块。当安装一个卡时，确定卡地址，并将它记录下来以备以后参考，这是一个好主意。在你已经在一个系统中安装了卡后，你也可以使用和卡一起带的诊断实用程序，来确定它的地址，也可以以相连卡的标志上查看到地址。

    Remote－Boot PROMs 远程自举PROM

    许多网络卡配备了一个远程自举可编程只读存储器（PROM）的插口。你可以在无盘工作站上使用远程自举PROM，无盘工作站不能自己自举，而需要从网络服务器来替它自举。无盘工作站比具有软盘驱动器和硬盘驱动器的系统要便宜许多；另外，由于用户使用无盘工作站时，不能下载有价值的数据到软盘上，或装入病毒和非授权软件，所以它还很安全。

    What to Look For 选择的目标

    可以获得适合8位或16位工业标准体系结构（ISA）总线槽的AT系列系统的NetWare接口卡，可以提供更好性能的16位卡的价格也比较高。另外，还可以得到支持微通道体系结构（MCA）系统的接口卡，如IBMOS／2系列，和支持扩展工业标准体系结构（EISA）总线系统接口卡，如Compaq DESKPRO 486和Compaq SYSTEMPRO。

    尽可能地为服务器使用高性能（基于EISA、基于MCA或基于PCI）的计算机和网络接口卡。这些接口卡可使服务器获得处理网络通信和管理所需要的性能。你可以在一个不产生太多网络通信的工作站（例如文字处理系统）上使用不太昂贵的NIC。然而，高性能的图形或工程性工作站将需要高性能的卡。

    伴随着不断增加的使用图形用户界面（如Windows、多媒体，以及实时视频）的潜在发展趋势，很有必要安装高性能网络，如100Mbps的以太网络。另外一种策略是将服务器连接到一个独立的局域网。许多厂商生产为工作站提供以太网或令牌网的端口，和为服务器提供FDDI端口。

    相关条目：Access Method，Network网络的访问方式；Extended Industry Standard Architecture Bus扩展工业标准体系结构总线；IEEE 802 Standards IEEE 802标准；Microchannel Architecture Bus 微通道体系结构总线；Open Systems Interconnection Model 开放式系统互联模型；Peripheral Component Interconnect外设部件的互联；Wireless LAN Communication 无线LAN通信。


  • OSI模型的网络层 Network Layer，OSI Model

    Network Layer，OSI Model OSI模型的网络层 开放式系统互联（OSI）模型是由国际标准化组织定义的标准。它定义了一种分层体系结构，其中，每一层定义了对不同通信级别的协议。每一层包含一个和其他系统的同等层的“会话”。将进行转换的消息，传送到协议栈中的较低层，从而在网络上被传输。最底层称为“物理层”，它负责将这些消息以位流的形式在物理介质上进行传输。在物理层之上的层，定义数据如何被打包以在物理层上进行传输。再上的一层处理错误检测和纠正、会话的建立以及保持通信会话继续的方式。每一层向较高层提供一些功能。最后，最高的层定义应用和网络的接口。OSI模型帮助开发人员创造能够在大量不同平台和操作系统上工作的产品。

    网络层是协议栈的第三层，处在物理层和数据链路层之上。它负责对较高层协议组装的消息进行路由选择，并处理通信错误。有趣的是，网络层提供的出错控制机制在局域网（LAN）环境很少使用。原因很简单，LAN相对来讲基本上是不会出错的，所以无连接的数据报通常被用于传输数据。无连接服务用可靠提交（它没有成功提交的返回信息）来换取效率。接着，较高的运输层服务进行检查，以确信所有的分组都到达了，并请求对任何没有抵达的分组进行重发。

    当LAN进行互联时，网络层的工作就很突出了。在一个复杂网络中，源系统的分组可能需要穿越复杂的互联路径才能抵达目的地。网络层提供的路由选择功能，使分组沿着最少步的路径通过网络。

    相关条目：Layered Architecture 分层体系结构；Open Systems Interconnection Model 开放式系统互联模型；Protocol Stack 协议栈；Routing，OSI OSI路由选择。


  • 网络管理 NetWork Management

    NetWork Management 网络管理 参见Management Standards and Tools 管理标准与工具。


  • DEC网络服务协议 Network Service Protocol，DEC

    Network Service Protocol，DEC DEC网络服务协议 在DECnet网络上，管理两个结点间逻辑网络链路的运输层协议，它控制数据流，并处理出错。这种协议提供握手服务，因而连接的结点可以进行双向通信会话。它在通信中对信息分段，并顺序处理它，以保证按正确的次序进行发送。

    相关条目：DEC；DECnet。


  • 网络故障诊断与维修 Network Troubleshooting

    Network Troubleshooting 网络故障诊断与维修 参见Testing Equipment and Techniques 测试设备和技术。


  • 联网方案 Networking Blueprint

    Networking Blueprint 联网方案 参见IBM Networking Blueprint IBM的联网方案。


  • 网络 Networks

    Networks 网络 计算机网络是一个连接两个或多个计算机和外设的数据通信系统，如图N－12所示。网络包含一条和每个设备的网络接口卡（NIC）相连的电缆。图N－13示意了一个网络通信系统的逻辑配置结构。在这个配置中，应用使用下面的网络通信软件以和其他应用或服务器交换信息。

    在图N－14左边示意了基本的部门级局域网（LAN）。在右边，一些部门级LAN被连接在一起以形成一个互联网络，它允许多个用户进行通信并与其他用户共享资源。图中的互联网络还是一个LAN，因为它只占据了局部区域。事实上，术语“互联网络”的定义是很松的。它可以用于描述两个使用不同网络操作系统和通信协议的LAN的互联，也可以描述被建筑物或地理区域分离的LAN的互联。其中，后一种情况构成了一个广域网（WAN），如图N－15所示。一个WAN是一个互联网络，它可以通过使用公共交换电话网络（PSTN）或一些公共服务来在城市、州、或国界内连接成网络。

    下面介绍网络的范围。一个网络可以开始很小，然后扩展到一个机构。

    网段或子网络 网络段通常由硬件或一个特定网络地址定义。例如，在NetWare环境，一个网段包括所有连接到一个服务器的一个网络接口卡上的工作站，每个段都有它自己的网络地址。所有连接到一个以太网段的计算机接收相同的信号广播。

    局域网（LAN）一个有连接工作站和服务器的网络段，或一个互联网络段的集合，它们总是在相同的区域，例如一个建筑物内。

    校园网 一个扩展到一个校园或工业园区内其他建筑物的网络。在每个建筑物内的不同段或LAN通常使用主干电缆（backbone cable）进行连接。机构通常拥有自己的场地，可以自由地根据需要来布缆。

    城域网（MAN） 一个覆盖一个城市或区县的网络，并且它的互连使用本地交换电信公司提供的MAN设施。

    广域网（WAN）和全局网络 跨越国家间、州间或国际范围的网络。它们的连接使用公共或专用远程通信设施，以及微波和卫星链路。

    企业级网络 企业级网络互联一个机构内的所有计算机系统，而无论使用什么样的操作系统、通信协议以及应用的差异，或地理位置的差异。因而，它可能是一个LAN、MAN或WAN。这个网络本身被视为一个平台，在它之上，可以连接许多不同类型的设备。使用了不同的技术来隐藏系统之间的不同，因而用户可以以透明的方式访问任何资源。例如，中间件产品隐藏通信协议和应用的差异。

    企业级网络通常是一个分布式计算系统，它们的资源和数据的放置可以遍布整个机构。在这种环境，需目录服务，以使用户得到关于其他用户、资源和数据的位置信息。安全性也是很重要的。一旦网络将整个公司都连接起来，部门和工作小组的经理们必须非常注意对访问数据的限制。数据库可能是被分区的和分布到远方地区的，以使数据对在这些地方的用户是非常容易和快速访问的，并可以减少在昂贵的WAN链路上访问数据的开销。这种方式需要重复（replication）或同步技术，以保证数据库具有相同的信息。

    如果需要相关信息，可以参见“主干网络”、“分布式计算”、“城域网”、“安全性”，和“广域网”

    Why Establish a Computer Network？ 为什么要建立计算机网络？

    为什么要建立计算机网络？这也许看起来是很显然的，但是这样做的原因，正如下面将讲述的，阐明什么是网络，和它能够为机构做些什么。

    程序和文件共享 许多可得的流行软件包的网络化版本，和购买独立的许可拷贝相比，可以节省相当的资金。程序和它的数据文件可以存储在文件服务器上，并可被多个网络用户访问。

    网络资源共享 网络资源包括打印机、绘图仪、存储设备。网络提供了一个通信链路，它允许用户共享这些设备。

    数据库共享 数据库管理系统是网络上的理想应用。一种称为“记录－锁定”（record－locking）的网络特征使得多个用户可以同时访问一个文件，而不会破坏数据。记录－锁定保证没有两个用户会同时对一个相同的记录进行编辑。

    PC的经济扩展 网络提供了一条经济地扩展一个机构的计算机数目的途径。你可以将一些便宜的无盘工作站连接到网络中，这些无盘工作站使用服务器的硬盘驱动程序来进行自举和存储。

    工作组 网络提供了一条创建用户工作小组（而不强求他们必须在同一部门之内）的途径。工作组使这种新的“平坦式（flat）”合作结构工作起来很便利，使用它，来自不同和远方部门的人们可以为一个特殊计划，很方便地组成一个小组。

    电子函件 电子函件（E－mail）使得用户可以很容易地与其他用户进行通信。消息被放在“信箱”中，以供收信方在方便的时候阅读。

    群件和工作流软件 群件和工作流软件是为网络而专门设计的，它们可以利用电子函件系统的优点来帮助用户在一些规划、调度和文件处理中进行相互协作。

    集中管理 网络提供了一条集中服务器和它们的数据，以及其他资源的途径。当设备放置在一个地方时，就可以很容易地处理硬件升级、软件备份、系统维护、系统保护。

    增强企业结构 网络可以改变一个机构的结构和它的管理方式。在一个特定部门工作的用户和为一个特定经理工作的用户不再需要在同一物理区域。他们的办公可以在他们的专家们最需要的地点进行。网络将他们和他们的部门经理和同事连接在一起。这种组织对一些特殊计划是很有益的，例如，不同部门（如研究、生产、市场）的人们需要相互之间紧密合作。

    Network Environments 网络环境

    网络环境是由网络操作系统和提供通信和网络服务的协议来定义的。存在两种基本类型的网络操作系统：

    对等层 这是一种允许用户共享他们计算机的资源和访问其他计算机上的共享资源的操作系统。对等层，意味着所有的系统在网络上具有相同的地位。没有一个系统是另一个系统的“奴隶”。

    专用服务器 在一个专用服务器操作系统中，例如Novell NetWare，一个或多个计算机扮演着专用服务器的角色，它们不执行其它任务。

    下面列出了一些通用网络操作系统环境，但是必须牢记，现在许多厂商提供不同的操作系统和通信协议选择，它们允许机构建造异构网络。

    IBM运行APPC／APPN协议的对等层SNA网络。

    UNIX运行TCP／IP的对等层操作系统。

    Novell NetWare运行SPX／IPX通信协议的专用服务器操作系统。

    运行NetBIOS／NetBEUI或TCP／IP通信协议的Windows NT和Windows for Workgroups的对等层环境。

    为理解网络操作系统，将它们和集中式的小型计算机和大型计算机处理环境进行比较是有益的。在一个网络中，客户机访问在中央服务器或对等服务器上的程序和文件，但却在他们自己的内存运行这些程序。一个小型计算机或大型计算机系统，处理和它相连的终端的处理任务，这些终端通常被称为哑终端（dumb terminals），这是因为它们自己并没有处理器或存储器，每个新的登录到集中系统的用户可以共享集中系统的处理，于是它的性能就下降了。

    网络是分布式处理系统，其中多个服务器和工作站执行操作。这也就是说，这个网络可以被看为一个处理设备的集合。服务器通常是网络的最强大的处理设备。网络在“前端”工作站和“后端”服务器间分解处理的应用，建立客户机／服务器式的关系。服务器提供如文件存储和提取、管理、打印机共享、安全性这样的任务。

    Components of a Network 网络部件

    计算机网络既包括硬件又包括软件。硬件包括网络接口卡和将它们连接在一起的电缆。软件包括服务器操作系统、通信协议和网络接口卡驱动程序。

    网络操作系统 在对等层网络中，网络上的每个结点运行一个具有允许用户共享他们的文件和外设的内置联网支持的操作系统，通常还包括安全性和管理特征。而专用网络的网络操作系统，在独立的服务器和工作站上运行，工作站运行和服务器通信的客户机软件。

    服务器 服务器向网络的用户提供如下服务。模块化网络操作系统，例如Novell NetWare，可以在一个或多个服务器上提供一些或所有这些服务，这要取决于管理员选择安装的模块化部件。

    文件服务器 提供文件存储和提取服务，包括控制文件访问权力的安全性特征。

    电子函件服务或信关途径 提供局部或企业范围的电子函件服务和不同邮件系统间的转换。

    通信服务器 向大型计算机或小型计算机系统提供连接服务；或通过广域链路，向远程计算机系统和网络提供连接服务。

    数据库服务器 处理用户数据库请求和响应的一种专用系统。

    档案服务器 一种专用于对网络文档进行备份或归档的系统。

    客户机系统（结点或工作站）客户机系统通过网络接口卡和网络相连。在工作站上运行的操作系统可能包括支持网卡的内置软件，或它也可能必须安装客户机软件。客户机软件将来自用户或应用的请求重定向到服务器。参见“客户机软件”、“NetWare DOS请求解释器”和“网络驱动程序标准”。

    网络接口卡（NIC） 连接到以太网、令牌网、ARCNET或其他网络的计算机工作站，通常需要安装一个网络接口卡。只有少数计算机具有这些内置接口。网络电缆连接到NIC的后面。参见“网络接口卡”。

    布缆系统 网络布缆系统是一种将服务器和工作站连接在一起的介质。在无线网络的情况，使用无线电或红外线，就不需要电缆了。参见“布缆”，“无线LAN通信”，和“无线移动通信”。

    共享资源和外设 共享资源和外设包括连接到服务器的存储设备、光盘驱动程序、打印机、绘图仪和其他可以被网络上的授权用户使用的设备。

    Network Connection Methods 网络连接方式

    为连接一个网络，需要有网络接口卡和电缆（除非使用无线方式）。存在多种不同类型的接口卡和布缆策略。

    网络的类型 网络可以用电缆的类型、电缆的布局或拓扑、数据传输率、通信协议、结点访问和使用网络的方式（访问方式）等来定义。可以使用网桥、路由器和网关来将不同的网络连接在一起，从而建立一个互联网络。

    最流行的网络类型是以太网（同轴电缆或双绞线电缆）、令牌网、ARCNET网和光纤分布式数据接口（FDDI）网。网络的数据传输率通常是一个决定性因素。ARCNET网以2Mbps的传输率进行操作，令牌网在4到16Mbps进行操作，以太网在10到100Mbps操作，FDDI网在100Mbps进行操作。在过去，网络使用的电缆类型通常是一个因素，但是在今天，大多数系统都在廉价、并且适应性强的双绞线电缆上进行操作。FDDI使用光纤缆，提供了一条到高速网络吞吐率的途径。

    网桥和路由器提供了一条联合相同或不同网络类型网络段的途径。Novell NetWare、Windows NT、Banyan VINES和其他的服务器操作系统具有内置桥接和路由选择功能。每个安装在服务器上的NIC创建一个分离的网段，并且由操作系统处理网络间的通信传输。

    Cable 电缆

    用于在网络结点间传输信号的介质通常是绝缘金属电缆，但是光纤缆线和无线通信方式（如无线电和红外线）也可供选择。

    同轴电缆，在构造上类似于TV电缆，是一种首先在网络上使用的电缆类型。它提供了相对的高数据传输率（10到20Mvbps）、低价格和对外部干扰的屏蔽。

    双绞线铜质电缆，由于它的低价格和易于安装，而变得非常流行。新的数据一梯度（data－grade）标准将数据传输率提高到100Mbps。

    光导纤维缆线也变得越来越流行，这是因为它的高传输率（100Mbps或更高）、对外部干扰的绝缘和安全性（它不外泄信号，线路窃听可以被检测出）。

    无线方式，根据使用的方式，既允许户内又允许户外的移动运算。虽然传输率不高，地点间必须没有障碍（红外方式），但是无线方式由于在一些情况下不需要铺设电缆，所以它可能是既方便又省钱的。通过使用分组无线电和蜂窝技术，对远程用户的移动网络连接正变得越来越流行。

    如果需要相关信息，可以参阅“布缆”、“光纤缆线”、“传输介质、方式和设备”、“无线LAN通信”、“无线移动通信”。

    Network Architecture 网络体系结构

    网络的体系结构是由它的拓扑和电缆访问方式，以及使用的通信协议来定义的。在任何工作站可以访问电缆之前，它必须为网络的每个结点建立通信会话。一个网络的电缆访问方法定义一个工作站如何获得对共享的介质的访问，以使它能传输信息。协议是系统用来在网络上和其他系统通信的规则和过程。

    Topology 拓扑

    你可以将一个网络的拓扑想象为它的电缆布局的一张地图。拓扑定义如何布缆到独立的工作站，这在作电缆的决定时是非常重要。如图N－16所示，一个网络可以具有线状、环状或星状拓扑。当你在决定安装什么类型的网络时，你必须考虑网络的拓扑结构。如下所述，拓扑结构决定了你如何将电缆穿越墙壁、地板和建筑物的天花板。

    线状拓扑 一个线状拓扑包括一个以菊花链的形式，从一台计算机扩展出，并连到下一台计算机的单独电缆。以太网同轴网络使用线状拓扑结构。虽然这种方式易于安装，但是电缆上任何一处的断开都将导致整个系统的瘫痪。

    星状拓扑 在一个星状拓扑结构中，所有的电线都从单一地点分支出来，例如一个文件服务器，或一个中央电线柜。星状拓扑需要对每个工作站都有一根电缆，但是一根断裂的电缆只会切断连接到它的工作站。虽然，从本质上讲，令牌网是一个环状网络，但以太网10Base－T和令牌网络使用星状拓扑。

    环状拓扑 在一个环状拓扑结构中，网络电缆连接回它自己，信号在一个环上运行。物理的环状拓扑是很少的。令牌环网络和ARCNET是逻辑环状网络。

    Cable Access Method 电缆访问方式

    电缆访问方式描述一个工作站如何获得对电缆系统的访问。当一个网络接口卡获得对电缆的访问时，它就开始在网络上以一种帧格式（如位流）发送信息的分组。线状电缆系统（例如以太网）使用载波监听多址访问无冲突网络（CSMA／CD）方式，在这种方式中，进行载波检测，期望进行发送的数据站点首先发出一个阻塞信号，在等待足够的时间使得网络中其他站点收到这个阻塞信号之后，它才开始发送一帧传输报文；如果在该发送过程中，它检测到另外一个站点的阻塞信号，则停止发送，等待预定的一段时间后，再进行下一次发送尝试。当网络传输拥挤时，由于它们的冲突并进行重发，性能将下降。

    环状网络通常使用令牌传送方式，这时，一个站点只有当它拥有一个令牌时才能进行发送。可以将令牌想象成使用网络的一个临时票据或通行证。当一个站点准备好要进行传输时，它必须等待一个可用的令牌，然后再拥有这个令牌。这防止了两台机器同时使用电缆。

    如果需要相关信息，可以参阅“网络访问方式”、“载波监听多址访问”、和“令牌和令牌传递访问方式”。

    Communication Protocols 通信协议

    通信协议是网络上使用的，是电缆系统访问结点间通信的规则和过程。协议控制两个不同级别的通信：高级协议定义应用如何通信，低级协议定义信号如何在一条电缆上传输。在这些级别间还有一些协议，它们建立和维持计算机间的通信会话，监督通信传输是否出错。通信协议可以比拟成外交协议，不同级别的外交人员和另一个使馆的同等级别的外交人员进行会谈。当定义好并公布了网络协议后，厂商就可以轻易地设计和制造可以在多厂商系统上工作的网络产品了。

    如果需要相关信息，可以参阅“分层体系结构”、“开放式系统”、“开放式系统互联模型“、“协议、通信”、和“协议栈”。

    Networking Devices 联网设备

    由于信号丢失和其他电气特性，网络布缆系统有距离上的限制。可以通过增加一个中继器，来扩展网络段的距离。中继器再生电气信号，可加倍电缆许可的长度。一个中继器可能不允许你增加超过网络描述中定义的更多的工作站到扩展的网络。通常用中继器将在后端办公室或仓库的工作站连接到前端的办公室。

    你可以通过一个网桥将分离的网络段连接在一起。网桥可以是一种单独的设备，也可以在网络服务器上。例如，你可以通过安装两个网络卡，在一个NetWare服务器上创立一个网桥。网桥具有将本地传输量保持在本地，而仅将指定到其他段的分组通过链路进行传输的能力。这有助于减少额外的网络传输量。

    路由器提供了比网桥稍高一步的这一级别的互联性。路由器可以读取分组上的编址信息，当网络有许多不同的链路或网关时，这些信息可以帮助它决定到达目的地的最佳可能路径。

    可以使用集线器（hubs）和布线中心（wiring center）来建立结构化的布线系统。集线器是一个可以构成星形配置线路铺设策略的中心集中器。集线器有一条总线，通常它可以按受插入的以太网、令牌环网、FDDI或其他类型的模块。这些模块为网络工作站具有多个端口。集线器通常安装在一个部门，并且将这个部门的所有计算机和另一个部门的计算机相连。然后，部门集线器再连到企业集线器，以形成一个层次式线路铺设策略。

    如果需要相关信息，可以参阅“主干网络”、“桥接”、“布缆”、“EIA／TIA568商用建筑布缆标准”、“集线器”、“中继器”，“路由器”。

    MAN and WAN Connection Methods MAN和WAN连接方式

    城域网（MAN）和广域网（WAN）在地理位置不同的地点之间提供了连接。MAN通常是高速、光纤网络，它在一个城市区域将LAN段连接在一起。另一种相应的方式是使用专用网连接策略，如微波系统。微波天线安装在建筑物的顶部，相互之间互相指向，以建立一个互联链路。

    WAN通过使用电话线路和卫星提供国家区域或全球范围的连接。具有区域性或世界范围办公事务的大型公司通过使用WAN来将许多网络互联在一起。从长途电信局租用专用线路以提供系统间的全时间连接。相应，可以采用线路交换或分组交换连接，它们可以根据使用和连接点的具体情况，以较低的成本进行操作，并提供更好的灵活性。

    Networking in the 1990s 九十年代的联网情况

    目前的网络变化趋势是多厂商、多协议（异构）网络，而不是长期渴望的所有厂商生产兼容设备的开放式系统环境。异构网络已经在企业范围的级别建立起来，它们连接不同区域的系统，包括部门和工作小组的LAN，以及公司的大型计算机和小型计算机系统。在这种环境中，网络管理人员面临着使不同的系统相互协作的任务。通过支持许多通信协议，或使用将协议对用户和应用隐藏起来的中间件，来达到这一目的。

    虽然网络的物理计算资源是分布在部门和不同的公司的，但是通常却由一个企业级网络管理员来负责和管理这些资源。这是因为企业级网络的设计是为了帮助整个机构达到它的目标，这包括对机构内的任何地方的用户可共享数据和资源。部门的LAN还仍然保持自治，因而局部管理员可以定义安全权限和保护局部数据不被未授权用户访问。然而，企业管理员指导部门以达到公司的共同目标。

    新的网络通过集线器、结构化布线系统、折叠（collapsed）的多协议主干、允许用户从远方以短延迟访问公司网络的高速广域网连接来建立。可以获得具有每秒一亿次指令的操作性能，并具有上百兆内存和上千兆硬盘存储容量的工作站。增加服务器的吞吐率以达到用户的高要求。普遍使用多个处理器的超高速服务器可以在高达200Hz的主频工作，并提供300MIPS或更高的性能。现在，大型计算机和小型计算机被看成可以直接连接入网的强大服务器。

    通过连接在网的计算机上支持多通信协议，可以解决许多低级通信的差异。现在，管理人员更关心相应于OSI协议模型的应用层，增加互操作性的级别。它的目标是在不同的平台上运行不同的应用以通过企业级网络访问数据，而无需关心结构、翻译和变换。中间件使得应用开发人员易于为这些新的环境开发软件。中间件提供了一种标准的编程层，它对程序员隐藏了网络的复杂性和多厂商协议。这些层提供了高级应用程序编程接口（API）。

    开放软件基金会开发的分布式计算环境（DCE）提供帮助管理人员进入异构环境的工具。Apple的开放协作环境和Microsoft Windows的开放式系统体系结构是建造企业级网络的策略。面向对象的环境，如Microsoft的Cairo正在通过对象技术为达到提供数据访问的目标而工作。在一个面向对象环境，数据和对数据进行加工的方法被结合成一个单一的对象。由于可以使用跨越软件和硬件平台的对象，所以对象是重要的。通过使用不同的应用接口，用户可以在其他地方访问另一些地方的对象。这种总体趋势使得开发人员可以很容易地为访问分布数据库开发应用产品。

    在这些计算环境，集中式的管理平台是必须的。它们可以减少必须重新学习的管理实用程序和软件包的数量，并且集中管理有助于减少所需的管理人员的数量。

    相关条目：Apple Open Collaborative Environment Apple开放协作环境；Cairo；Distributed Computing Environment分布式计算环境；Enterprise Networks 企业级网络；Middleware 中间件；Object－Oriented Environments 面向对象环境；Object－Oriented Interface and Operating Systems面向对象接口和操作系统；Windows Open System Architecture Windows开放式系统体系结构。


 NFS 网络文件系统
：NFS(Network File System)是一种分布式文件系统，允许网络中的计算机象本地机一样的使用另一台联网计算机的文件和外设。它主要用在UNIX平台上，但有些重要的部分也移到了PC机上。


 NOC　网络操作中心
：NOC(network operations center)是远程网络通讯的管理、监视和维护中心，是网络问题解决、软件分发和修改、路由、域名管理、性能监视的焦点。


 NOC　网络操作中心
：NOC(Network Operations Center)是远程网络通讯的管理、监视和维护中心。有大型网络的企业和网络服务提供商，通常有一个网络操作中心，一个有可视网络的房间，可以从工作站上看到网络状态的细节。网络操作中心是网络问题解决、软件分发和修改、路由、域名管理、性能监视的焦点。


  • 节点，结点，网点 Node

    Node 节点，结点，网点 节点可以是工作站、客户、网络用户或个人计算机，还可以是服务器、打印机和其他网络连接的设备。


  • Novell公司 Novell

    Novell Novell公司 Novell公司对微机的成长有重大的影响。它在七十年代开发了基于Z－80的微机，在八十年代初创造了它的第一个网络连接产品。在个人计算机出现的那段时间，Novell的主要产品是一种基于Motorola 6800的文件共享设备。在1983年，当IBM宣布具有一个硬盘的IBM个人计算机XT时，Novell对此作出了一种快速反应，即提供了一种将这种硬盘系统转变为一个文件共享系统的产品。使用众所周知的S－网来连接工作站。S－网是一种星形结构布缆的系统。

    几年以后，Novell宣布了提供文件服务器功能的NetWare／86。这种新的网络操作系统不仅仅允许用户共享文件，它还通过一种安全性系统提供对这些文件的访问，并且帮助管理其他的网络功能。伴随着NetWare变得非常流行，它的设计者们改进了它的与硬件独立的特性。Novell已经停止推进它自己的局域网（LAN）硬件，开始提供对许多厂商的产品的支持。这对NetWare变成工业标准的进展中是最重要的策略之一。在1986年，一种称为高级NetWare的新NetWare版本，通过在文件服务器或外部工作站之间建立不同网络类型的网桥，提供了对LAN硬件更多的支持。例如，可以在一台服务器上既安装一个以太卡，又安装一个令牌环网卡。

    为利用基于Inter 80286系统的优势，开发了高级NetWare 286。在如OS／2和Microsoft Windows存在的很早之前，高级NetWare就提供了多任务能力。另外，它在80286的保护模式运行，保护模式允许它提供只在DOS下运行时所不具备的高级特征，并且它没有DOS的640KB内存存储的限制。许多用户在访问NetWare服务器上的文件时，获得了比访问他们自己的硬盘上文件还要好的性能！在一个高级NetWare 286服务器上可以安装多达4个不同类型的网络接口卡。

    最后，Novell开始分解它的产品类别。在低端，它提供NetWare初级系统ELS（NetWare Entry Level System），它支持小数目的用户。在高端，它宣布了NetWare 系统容错（SFT）。NetWareSFT通过镜像，或复置硬盘系统，提供对硬盘失效的保护。在这种安排中，两个硬盘记录相同的信息，如果其中一个失效了，另一个可以马上投入使用。Novell还开始对NetWare服务器上的Apple Macintosh计算机提供文件存储。

    在1989年，Novell宣布了NetWare 386 V．3．0，它是一种经过完全重写以利用Inter 80386处理器的新的功能的网络操作系统。NetWare 386是一种全32位的操作系统，它是为需要处理大量数据的大型网络而设计的。它还提供增强的安全性，性能，和灵活性。（操作系统的改变是非常容易的）在1990年六月，Novell提出了V．3．1版本，它提供了增强的性能、可靠性和系统管理功能。然后，在1991年，Novell宣布了NetWare V．3．11，它支持DOS、Macintosh、Windows、OS／2和UNIX文件和打印服务。

    现行的Novell操作系统产品系列包括NetWare Lite，一个基于DOS的对等层操作系统；NetWare V．2．2，一个运行在Intel 80286或更高处理器上的专用或非专用服务器操作系统；NetWare 386 V．3．11，一个全32位专用服务器操作系统；NetWare 4．x，一个Novell企业范围网络操作系统。这些产品在本书NetWare的标题下有进一步的介绍。

    The Novell Product Strategy Novell的产品策略

    Novell是网络工业界的主要力量。调查和估测表明，现有网络地点的60％左右是使用Novell NetWare的。

    Novell已经采纳了一种侧重于企业级网络的网络操作系统策略，企业级网络连接一个机构内的所有计算机资源。可将网络本身想象成一个平台，你可以将任何类型的计算机系统连接其上，从而达到对任何用户都提供网络服务的目标。互联的网络提供通信平台，Novell NetWare提供将它连到一起的软件部件。这些部件可能是NetWare提供的，也可能是作为可选产品的。

    在Novell的企业联网策略之后的推动力量是，使NetWare尽可能开放，以与其他系统或其他厂商的产品集成在一起。


 NSR 渲染引擎
：NSR（NVIDIA Shading Rasterizer）。这个渲染引擎的特点在于：每条渲染引擎的标准填充率为175Megapixels/s，在只需要单纹理填充的游戏中，由于其每条渲染引擎在一个时钟周期内可以渲染两个纹理。


  • NTFS（新技术文件系统） NTFS（New Technology File System）

    NTFS（New Technology File System） NTFS（新技术文件系统） NTFS是Windows NT操作环境和Windows NT高级服务器网络操作系统环境的文件系统。NTFS的目标是提供：

    可靠性，通过可恢复能力（事件跟踪）和热定位的容错特征实现。

    增加功能性的一个平台。

    对POSIX需求的支持。

    消除FAT和HPFS文件系统中的限制。

    NTFS提供长文件名、数据保护和恢复，并通过目录和文件许可实现安全性。NTFS支持大硬盘和在多个硬盘上存储文件（称为跨越卷宗）。例如，一个大公司的数据库可能大得必须跨越不同的硬盘。

    NTFS提供内置安全性特征，它控制文件的隶属关系和访问。从DOS或其他操作系统上不能访问NTFS卷宗上的文件。这是Windows NT安全性系统的一部分，但是，只有在使用NTFS时才是这样。

    NTFS允许文件名的长度可达256个字符。虽然DOS用户不能访问NTFS卷宗，但是NTFS文件可以拷贝到DOS卷宗。每个NTFS文件包含一个可被DOS文件名格式认可的DOS可读文件名。这个文件名是NTFS从长文件名的开始字符中产生的。

    相关条目：Microsoft Windows NT Microsoft的Windows NT操作系统。


  • NWLink IPX/SPX协议微软执行部分

    (IPX/SPX) 是Novell NetWare的核心。IPX/SPX协议的微软执行部分称为NWLINK。NWLink是Novell中的IPX/SPX协议的NDIS4.0可兼容协议，可用于NT计算机和MS－DOS，OS/2，Windows for workgroup和其他NT计算机间通过多种通信机制建立联接。


 OA 办公自动化
：OA是Office Automation的缩写，指办公室自动化或自动化办公。


 OAW 光学辅助温式技术
：希捷公司正在开发的OAW是未来磁头技术发展的方向。OAW技术可以在1英寸宽内写入105000以上的磁道，单碟容量有望突破36GB。单碟容量的提高不仅可以提高硬盘总容量、降低平均寻道时间，还可以降低成本、提高性能。


  • DEC的对象代理者软件，DEC的Object Broker软件 Object Broker，DEC

    数字设备公司的ObjectBroker是一种分层软件产品，它允许软件开发者对独立开发的应用程序运用一种面向对象的研究和跨越多种厂商环境的服务。Object Broker V．25全面实现了对象管理组织描述的公用对象请求代管者体系结构（CORBA）。Object Broker通过在操作系统级网络级消除集成代码的开发，简化了客户机／服务器应用程序的开发。

    Object Broker扩展了在多厂商网络环境内实现Microsoft的对象链接嵌入（OLE）或动态数据交换（DDE）接口的应用能力。DEC和Microsoft联合起来为基于对象的客户机／服务器开发和展开，提供一种开放体系结构。这一行动导致了公用对象模型（COM），它是为允许Windows应用访问其他平台的应用而设计的一组基于对象的分布式联网接口。这里说的其他平台包括DEC Open VMS环境、Macintosh系统和不同的UNIX变种。

    Object Broker的特征包括：

    允许应用程序在多平台上进行处理，并以透明的方式在应用之间发送请求、控制和相互协作。

    通过在操作系统和网络传输级上的连续，基于标准的应用程序编程接口，提供应用命名、能力登记、定位、活动、请求／数据分发。

    在不修改原代码的前提下，对现有（合法）的应用和数据进行加密，因而现有的应用可以融合进新的客户机／服务器结构

    COM的出现是Microsoft的一个重要举措。它通过允许Windows应用和与Object Broker兼容的系统交换信息，开放了Windows环境。在环境之间使用的通信方式是基于在开放软件基金会的分布式计算环境中使用的远程过程调用（RPC）的。由于Object Broker是基于OMG的CORBA，所以Microsoft可以无需和OMG捆绑在一起，就能对CORBA进行访问了。

    相关条目：Common Object Model 公用对象模型；Common Object Request Broker Archtecture公用对象请求代管者体系结构；Object Linkingand Embedding 对象链接和嵌入；Object Management Group 对象管理组织。


  • 对象链接与嵌入 Object Linkingand Embedding

    对象链接和嵌入（OLE）提供了一条集成不同应用对象的途径。一个对象可以是一个电子表格的信息块、一个绘图程序的图形、或从一个声音程序剪切的音频块，每个对象都是它的服务器应用生成和维护的。但是通过OLE，可以集成不同服务器应用的服务。这意味着用户不需要交换到其他应用来编辑现行文档中的对象。他们可以通过使用从服务器应用“生出”的功能，来简单地在本地（OLE2．0）对对象进行编辑。

    每个对象都有它自己的数据类型定义。例如，一个电子表格对象具有包含格式化代码的信息单元，而一个图形图像包含位映射数据或重新绘制图像的命令。OLE允许任何与OLE兼容的应用来显示其他应用的对象，和在数据之间建立关联。OLE应用可以识别很丰富的下面的文件结构，并且即使对象是在其他任何地方产生的，它也能够显示这些对象和提供编辑功能。

    一个复合文档是包含不同应用程序生成的对象文档，如图O－1所示。这种文档是一种可以存放对象的所有者。图中点亮的窗口（Microsoft Word）是包含一个电子表格程序和一个绘图程序的复合文档。用户可以集中精力于复合文档，而不是每个用于生成文档中对象的应用；然而，当需要时可以使用这些应用程序的功能，而无需用户实际切换到另一个应用程序。

    对象既可以嵌入到复合文档中，也可以链接到复合文档中。下文将对这两种情况分别介绍，但是复合文档可以同时包含这两种类型的对象。

    链接的对象 不象嵌入的对象那样，一个链接对象并不实际存在于一个复合文档中。复合文档包含一个到对象的引用，这个对象是作为单独的磁盘文件存在的。保持一个到这个文件的链接，因而如果这个文件有任何变化，这种变化就会在包含对它的链接的复合文档中反映出来。链接具有如下特征：

    链接的对象存在于复合文档之外的文件中。如果这些文件被删除了，连接就丢失了。如果它们被移动了，就必须建立新的链接。

    由于复合文档中只包含对链接的对象的引用，所以复合文档本身体积是很小的。

    链接可以跨越网络而存在——一个复合文档可能存在于一个计算机上，而一个链接文件却可能存在于另一台计算机上，如对象服务器上。

    如果一个复合文档被移动到另一个系统上，那么所有链接的文件也必须随之移动。

    嵌入的对象 不象链接的对象那样，一个嵌入的对象是直接存储在复合文档中的。一个嵌入的对象保持和创造它的应用之间的联系。用鼠标器双击对象，就可以打开这个应用，从而对对象进行编辑。嵌入具有如下特征：

    嵌入的对象可以在本地进行编辑，所以用户从来就不需要离开复合文档。

    对嵌入的对象的改变不会影响到原始文件（如果这个原始文件是存在的，这里的意思是嵌入的对象可能是这个对象的唯一存在形式）。

    这个对象并不需要以一个单独文件的形式存在。

    这个对象是和复合文档存储在一起的。

    由于所有的元素存储在一个文件中，所以嵌入简化了文档的管理。

    嵌入的对象和包含它的文档一起移动，从而使用户可以轻易地改变文档。

    包含嵌入对象的复合文档是很大的，这是因为复合文档包含构成对象的所有数据，而不象链接引用外部的对象。

    OLE 2．0对嵌入对象使用本地活动（in－place activities）。如果用户双击复合文档中的对象，所有的交互工作都在复合文档内发生。和对象进行交互操作所需的菜单、工具条、调色板和其他控制，暂时替代了活跃窗口的现存菜单和控制。当用户进行完编辑后，返回到正常的控制，并且对象以改变后的形式存在。在多媒体对象的情况下，说进行“编辑”可能是一种不当的说法。用户通过“播放（playing）”和这种对象进行交互操作，而不是“编辑（editing）”，虽然编辑有时也是可以的。

    链接的对象也可以是一些操作，被在本地激活，如重现和显示，但是它们不能在本地被编辑，而是为进行编辑打开一个独立的窗口。

    从用户的角度来看，OLE为所有在Windows环境的OLE兼容的应用，提供了一种通用集成的策略。应用这时更象用户组装不同应用对象的工作场地。OLE通过允许用户共享对象，使得工作小组可在一个网络上协作工作。例如，项目经理可以将协作者创作的连接对象插入到复合文档中。这些合作者为项目进展而对这些对象进行的变动将在这个复合文档中反映出来。

    复合文档可以被看成是有关所有将进入报告（report）的元素的中央仓库。它既可以直接包含这些元素（嵌入对象），也可以生成到包含这些元素文件的一个引用关系。在旧的组装文档的方式中，你首先需要写下所有构成一个复合文档或报告的相联文件的名字，然后在打印之后对它们进行组合。在OLE环境，你可以将所有这些部件组装成一个复合文档，这个复合文档保持对每个元素的位置的跟踪，并在打印时将它们组合在一起。

    在Windows for Workgroup和Windows NT环境，一个称为ClipBook的实用功能，提供在一个网络上进行工作的先切再贴（cut－and－paste）特征。你可以将希望和其他用户共享的对象放置在ClipBook中。然后，其他用户可以在他们的计算机上打开ClipBook，并将这些对象贴到他们的文档中去。这些对象保持一个到你的计算机上的文件连接，因而如果你对这个文件进行了修改，在其他用户的文档中的拷贝也将作相应的改变。然而，如果你的计算机没有打开，其他用户就不能从你的计算机上获得这些修改。

    Other OLE Features 其他OLE特征

    OLE还实现了一些其他有趣的特征。2．0版本对早期的OLE中的特征进行了较大的扩展，例如，那些与Windows for Workplace V3．1和Windows NT V3．1合并的特征。下面讨论版本2．0的一些特征。

    Draw and Drop拉放

    在Windows环境，剪切板（Clipboard）是在应用之间传送数据的一个通用的实用功能。以前，为达到这一目的，必须在源部分首先执行复制（Copy）命令，然后在目的地执行贴上（Paste）命令。拉放研究为达到相同的结果提供了更加自然的途径。用户首先描述出需要复制的对象，然后点击这个对象，并同时按住鼠标器的按纽，拖拉这个对象到目的文档。拉放特征消除了应用之间的障碍。窗口框架已经不再是分离应用的一堵墙壁。用户可以自由地从一个应用拖拉信息到另一个应用，从而简化了创建复合文档的过程。拉放功能还可以和源图标（source icon），例如打印机和信箱等，一起工作。拉放一个对象到打印机的图标上，可以使这个对象被打印出来。

    性质继承（Property Inheritance）

    当对象嵌入到复合文档中时，它可能具有和文档其他部分不一致的性质。例如，嵌入的对象中的字体就 能和这个文档中使用的字体不一样。为了使嵌入的对象和复合文档的形式保持一致，OLE允许文档向对象送性质。然后，这个对象就可以继承这些性质，并将它的外观变化得和文档的其他部分保持一致。

    对象类型转换和仿真（Object Type Converston and Emulation）

    如前所述，对象具有定义数据的格式和对象其他性质类型的特征。这些类型是由生得这个对象的应用定义的。在一些情况下，用户可能喜欢将对象转变为另一种不同的类型，从而他们可以和具有一些特殊特征的应用一起编辑和管理这个对象。

    OLE提供了一种机制，通过这种机制，应用可以执行类型转换和仿真。类型转换导致对象的永久改变。而类型仿真生成具有其他类型对象特性的对象，当时还保持它自己原始的名字和数据格式。当原始应用已经不再使用时，类型转换是有用的。类型仿真为用户使用相同服务器应用程序对复合文档进行协同工作，提供了一条临时性途径。

    查寻和拼写（Searching and Spelling）

    由于复合文档包含许多应用生成的对象，并且用户希望将复合文档当成一个单一的实体来对待，因而OLE对整个文档进行查寻和进行拼写检查，提供了一条途径。它使用了一种隧道技术（tunnelling techniques），以在嵌入对象内部进行串查寻和拼写检查。这避免了唤醒多个应用以进行相同任务的要求。

    OLE Implementations OLE实现

    就象可以在Microsoft office产品组中看到的那样，Microsoft的计划是围绕OLE建立它的工作组应用程序。Microsoft office产品集包括Microsoft Word、Excel、Power Point、Mail和Schedule十工作组调度软件。这些应用可以轻易地在同一系统或其他系统的用户之间共享信息。Windows for Workgroups使用网络数据交换，并包括Mail和Schedule十产品。Microsoft视窗开放式系统体系结构（WOSA）策略为集成消息、数据库、跨越企业范围网络的其他应用等提供了结构。

    OLE在所有Microsoft Windows产品中实现，包括1995年将推出的Cairo面向对象操作系统和象Microsoft Office这样的应用。DEC和Microsoft联合力量，为基于对象的客户机／服务器开发和展开提供一种开放的称为“公用对象模型（COM）”的体系结构。COM是一组为允许Windows OLE应用访问DEC的Object－Broker技术支持的平台上的应用程序而设计的。这些平台包括DEC Open VMS环境、Macintosh系统和不同的UNIX变种。

    然而，有许多对象模型和OLE竞争。这些模型列出如下，它们在本书的其他地方都有介绍。

    Sun的全分布式对象模型（Distributed Objects Everywhere：DOE）。

    OpenDoc，一种Apple、IBM、Novell和Word Perfect为与OLE 2．0一起工作而设计的对象标准。

    Hewlett－Packard的分布式对象管理设施模型（Distributed Object Management Facility，DOMF）。

    对象管理组织（Object Management Group，（OMG）的公用对象请求代理体系结构（Common Object Request Broker Architecture，CORBA）。

    DOEHE和DOMF是围绕CORBA环境设计的。还要注意，Hewlett－Packard、IBM和Sun Microsystems同意在1993的中期共享他们的对象技术。虽然CORBA和Microsoft的OLE和Cairo计划竞争，但是OLEL是一种在Windows环境的对象共享系统，而CORBA是为在异构网络环境提供对象共享而设计的，该环境包括跨越不同的互操作平台的通信。如果需要了解在分布式环境的对象共享技术，可以参阅“对象请求代管者”。

    相关条目：Common ObjectModel 公用对象模型；Compound Documents 复合文档；Dynamic Data Exchange 动态数据交换；NetDDE；Object Broker，DEC DEC的Object Broker；Microsoft Windows for Workgroups；Microsoft Windows NT。


  • 对象管理体系结构 Object Management Architecture

    对象管理组织（OMG）最开始的任务是创立一种体系结构，在这种体系结构上，它的成员可以标准化地开发包含不同的多厂商产品和操作环境的分布式网络上的应用。OMG创造的体系结构包括四个主要部件，如图O－2所示。

    应用程序对象 这一级别包含可以根据需要安装和移去的可选应用。通常的应用程序包括字处理器、电子表格和图形程序。

    公用设备 这一级别包含在大多数应用中通常使用的对象，例如，电子函件系统、拼写检查器、I／O接口、和代理器等。它们这样分离出来是为了避免在一些应用程序中代码的重复。在公用设备区域的对象是可以被所有应用程序进行访问的。

    对象请求代管器（ORB）这是对象和其他对象进行通信的公用接口。它是由公用对象请求代管器体系结构定义的，并在本书的这一标题下进行讨论。还可以参见“对象请求代管器”。

    对象服务 这一级别提供实现对象技术的重要服务。

    其中的关键部件是对象请求代管器（ORB），它提供了基本的对象通信、格式化和对象间的管理服务。下面继续介绍使用OMA模型的一些优点：

    它支持模块化、即插即用软件。

    对用户和网络管理人员，安装系统和软件都很容易。打印机、屏幕和其他设备的驱动程序驻留在公用设备区域，在那里它们可以被多个应用所共享。对所有用户都可以立即获得修改的消息。

    用户和管理人员都可以很容易地利用分布式环境的优势。例如，ORB可以将对象放置在高性能或为服务请求而闲置的系统，从而充分利用企业资源。用传统的远程过程调用（RPC）来实现这种功能是较困难的。

    相关条目：Common Object Request Broker Architecture 公用对象请求代管器体系结构；Object Management Group对象管理组织；Object Request Broker对象请求代管器。


  • 对象管理组织 Object Management Group

    对象管理组织（OMG）是拥有约300家机构的国际联盟，它开发了对象管理体系结构（OMA）。OMA是一种描述OMG希望为面向对象的应用和环境开发的标准模型。对OMG提供了主要技术的OMG成员包括，数字设备公司、Hewlett－Packard、Hyper Desk Corporation和SunSoft。这种体系结构还被X／Open Group（它也具有开发多厂商通用应用环境的共同对象）和开放软件基金会（OSF）采纳。OSF正在开发称为“分布式计算环境（DCE）”和“分布式管理环境（DCE）”的可移植系统软件。注意，OMG对象标准和Microsoft在它的对象链接和嵌入（OLE）2．0 Cairo所做的工作类似。然而，OMG描述的设计是为不兼容的系统之间搭架桥梁的，而Microsoft的产品却是为在Windows环境下工作的。

    OMG最初关心开发厂商们可以用于创造在多厂商环境进行操作的应用的一组语言、接 口和协议标准。OMG的设计中接受工业标准，因而参加成员和其他厂商可以生产承认他们的产品。然后，OMG将验证在接受标准下设计的产品对标准的接受情况。

    事务处理，在分布式系统上的事务处理，这种情况下可以在不同地点写入修改。

    并发执行，在分布式环境下相同系统或不同系统上的对象方式的并发执行。

    事件通知，可以报告在分布式系统中任何地方发生事件的对象。

    变化报告，报告对象结构的变化，可以保证对象引用总是使用合适的版本。

    国际化，它提供了处理指定国家格式的途径。

    OMG工作的一个有趣特点是它建立在一些已经使用或正在被许多厂商开发的标准和接口之上。面向对象技术之所以被使用，是因为它为模块化和可扩展系统提供了好处。

    基本体系结构是以对象请求代管器（ORB）为核心的。在这种模型中，对象请求服务器。这个请求被传到ORB，它寻找一个合适的“提供者”对这个请求服务，接着，对请求进行格式化，并将它送给提供者。然后，这个 供者再将它的响应送给ORB，ORB对这个响应进行格式化，再进一步送给原来的请求者。

    OMG提出的第一个基于OMA的技术规范，称为公用对象请求代管器结构（CORBA）。OMG还定义了接口定义语言（IDL），它是其它对象看到的一种接口对象，其中包括用于与其它对象交互的过程函数。

    下面的公司支持OMG开发面向对象技术方面的努力，并在他们的产品中实现了这些技术。

    Hewlett－Packard的分布式计算环境，它包括OMG CORBA部件，以及开放软件基金会（OSF）的分布式计算环境（DCE）和OSF Motif图形用户界面的部件。

    全分布式对象（或Project DOE）是SunSoft为它的Solaris操作系统而开发的一种全分布对象环境的尝试。DO E的设计是基于CORBA的。

    开放软件基金会（OSF）已经在它的分布式管理环境（DME）规范中采纳了CORBA。

    以前，Hewlett－Packard、IBM和SunMicrosystems独立开发面向对象的接口技术，但是已经同意在1993年中期共享他们的技术。这些面向对象技术是IBM的系统对象模型（SOM），Sun的全分布式对象模型（DOE）和HP的分布式对象管理设施（DOMF）。通过共享和标准化他们的技术，用户和开发商将从一个更加开放的环境获益。这一认同产生了对Microsoft的Cairo计划更大的竞争力。

    相关条目：Common Object Request Broker Architecture公用对象请求代管器体系结构；Object Management Architecture 对象管理体系结构；Object－Oriented Interfaces and Operating Systems面向对象接口和操作系统；Object－Oriented Technology面向对象技术；Object Request Broker对象请求代管器；Objects 对象。


  • 对象请求代管者 Object Request Broker

    在一个面向对象的分布式计算环境，一个对象请求代管者（ORB）可以为应用程序、服务器、网络设施之间分发消息提供关键通信设施。可以将ORB想象成一组软件总线、支柱，它提供了一个公用消息传递接口通过这个接口，许多不同类型的对象可以以对等层策略进行通信。

    对象产生一个请求，并将这个请求发送给ORB。然后，ORB再放置一个可以对请求服务、格式化消息和把它发送到对象的对象。然后，这个接收对象对这个请求作出响应，并向ORB返回一个响应，ORB格式化并转发这个响应到请求者。

    在这个模型中，对象只简单地描述要操作的任务。它们不需要知道更多的细节或能够为这个任务服务的那个对象在哪里。ORB处理所有的细节工作，包括放置对象、格式化消息和传递这些消息。在分布式环境，ORB是所有对象的一个公用接口。

    ORB处理类似于远程过程调用，但是ORB自身就有能力找到能够对请求提供服务的其他对象。

    公用对象请求代管者体系结构（CORBA）是一个基本的消息传递技术规范，它是对象管理组织（OMG）在其对象管理体系结构（OMA）中定义的。CORBA已经被许多公司实现，这些公司包括Hewlett－Packard、SunSoft（Sun Microsystem 的一个分支机构）和其他公司，介绍如下：

    Hewlett－Packard的分布式计算环境包括OMGCORBA部件，以及一些来自开放软件基金会（OSF）的部件，如分布式计算环境（DCE）和OSF Motif图象用户界面。

    全分布式对象（或ProjectDOE）是SunSoft为它的Solaris操作系统开发的一个全分布式对象环境的初始产品。

    开放软件基金会在它的分布式管理环境（DME）规范中采纳了CORBA。

    开放软件基金会的分布式计算环境（DCE）和分布式管理环境（DME）使用ORB概念，因而这些对象可以对其他对象产生请求。

    相关条目：Common Object Request Broker Architecture公用对象请求代管器体系结构；Compound Document复合文档；distributed Computing Environment 分布式计算环境；Distributed Objects Everywhere，SunSoft SunSoft的全分布式对象；Object Management Architecture 对象管理体系结构；Object－Oriented Interfaces and Operating Systems面向对象接口和操作系统；Workplace OS Workplace操作系统；Objects。


  • 面向对象数据库 Object－Oriented Database

    参见Distributed Database 分布式数据库。


  • 面向对象技术 Object－Oriented echnology

    面向对象技术使软件的开发超越了过程式编程，而进入了简化应用程序开发的可重用编程世界。不象旧的编程方式，当程序的体积增长时，程序维护和调试并不变得更复杂。对象技术在两个级别发挥作用：

    在数据级别，对象技术可以集成一个机构中的许多不同类型的信息，过去的信息已经不再兼容了。

    在程序开发级别，对象技术提供模块化程序构造，这时，程序员在现有对象的基础之上进行开发。对象可以被其他对象再使用，以利用它们的过程，从而消除了当再次需要它们的时候，必须每次都重写这些代码。

    由于无需改变或分解整个系统，所以再设计或扩展系统是很容易的。实际上，是放弃或修改这些模块，并且增加新的模块以提供增强的功能。

    一个对象是一个完整的数据分组，它包括对数据进行处理的功能。在一个面向对象的环境，对象的数目是数不清的。它们可能包括一个数据库的记录、一个文件、一个物理资源、甚至是一个用户（它是用户的登录帐户）。为了使开发人员使用面向对象编程语言工作，对象是一个自满足模块，它包含数据、以及数据的结构、和处理数据的功能。

    对象可以是下面情况的任何之一：

    在一个面向对象操作系统中实现一个进程的代码，例如验证安全权限。

    程序员和开发人员用于汇编程序的预定义代码模块。

    来自一个应用程序的数据块，如一个绘图程序、电子表格或多媒体工具。

    在一个数据库中的对象，例如库存条目或顾客。

    在一个面向对象的数据库中，对象可以代表跟踪的商务中的实际实体，例如生产的产品、库存、顾客和厂商。相应地，在面向对象的操作系统中，对象也是一些实体，如文件、设备和用户，或构成一个复合文档的实体数据块。在面向对象的环境，首先定义基本的对象，然后围绕这些对象建造系统。

    有许多潜在对象，并且它们可以归化到定义不同类型对象的层次化类（hierarchical classes）。父类可以对子类传递特性。让我们来考虑一个类“people”，它拥有两个子类“male”和“female”。这些子类又可以拥有它们自己的子类，如图O－3所示。每个子类都有从它的父亲处继承来的综合特征，以及它们自己的专有特征。另外，一些继承来的特征由于它们对子类不合适，而会被阻挡。

    这和计算机如何关联昵？记住，现在我们在讨论存储许多不同数据类型，和访问许多不同类型应用程序数据的途径。通过按这种方式对数据分类，我们可以在一个对象内，直接包括进行抽取、显示、合并和打印的过程数据。如果需要，对数据进行分类，可以简化构造过程和改造（revision）过程。例如，一个数据块对象可能包括一个对这些数据按特定的方式进行排序的过程，它可以被许多不同的使用这个数据的应用程序所激活。

    下面是对象类和对象实例：

    对象类 一个类定义了一组对象。类具有行为（be－havoir），它描述一个对象能够做什么以及做的方法（method），它们是可以对这个对象进行操作的程序和过程。

    对象实例 一个对象是一个类的一个实例，它代表一个现实物理“事件”，例如在一个财物系统数据库中的一个顾客或一个库存部分。类的继承（class inheritance）是一个重要的概念，它为一个子类继承它的父类的内置描述提供了途径。在父类中使用的代码被向下传给这个类指定的一个类（子类）。

    例如，一个面向对象的数据库可以有一个称为“client”的类，这个类有两个子类，分别称为“company”和“individual”。首先，创立称为“client”的对象。它包含一个结构和一些过程，这些过程处理数据和从对象之外获得信息。然后，company和individual对象作为client的子类进行定义。作为一个子类，它们继承client对象的结构和特征，但是这些特征中的一些可能被屏蔽，或可以增加一些附加特征。例如，company子类可以具有一个特定的折算，而individua1子类却不具有。如果你需要一个关于客户的列表，你可以请求client对象进行列表。然而，如果你希望知道客户的帐目平衡，你就需要从每个包含客户平衡的子类对象获得信息。

    对象包含数据和过程，并且当被请求时提供信息。想象一个包含数据的箱子，它有一些按钮，你可以按这些按钮来对数据运行过程。方法是，一些对对象进行操作的过程或程序，它们可以使对象根据对象的内部代码和结构来以特定的形式进行动作。相似地，可以对对象的不同的类进行操作。有一个概念称为多态性（poly－morphism）或重载（overloading）。使用多态性，一组通用的方法可以在很大范围的类上进行操作。然而，具有相同名字和称呼的方式却可能诱发不同的事情。例如，在文本数据的“next”导致光标跳到下一个工作，而在电子表格的“next”却导致光标跳到下一个单元。

    对象通过发送消息与另一个对象对话。这些消息在本质上是通过按下对象上的“按钮”从对象请求过程。在一个网络环境，你可以查看和消息总线相连的对象，如图O－4所示。消息传递为对象在一个面向对象的分布式计算环境进行通信提供了一条有效途径。消息传递是一种存储再转发方式，就象在电子函件系统中使用的那样。消息被从一台计算机传送到另一台计算机，直到它们抵达目的地。

    所有这些都加到软件中，它们易于维护，并且在连续的基础之上改进，即无需对整个系统进行重新设计。

    对象是可重用的，使得系统增长时，它易于加入系统，这是因为在现有对象中的代码对创造新的对象是可重用的。

    对象系统是可扩展的，开发人员增加模块，而模块重用内置数据结构，无需重编译操作系统。

    易于建造系统，这是因为面向对象对设计系统和实现系统提供了一条很自然的途径。

    对象可以提供了一种通用接口，因而许多不同应用程序能够访问数据。

    也有许多不利的方面，包括大量增加了前端设计的时间，减低了性能和技术的不成熟。然而，随着系统的成长和硬件的不断强大，这些不利可以减退。这些缺陷，在对象系统可以在遍布分布网络上的许多不同类型的系统上向用户提供数据这一事实面前，也会减少。

    Objects in Distributed Environments 分布式环境中的对象

    对象技术被认为对实现未来的分布式系统是很有生命力的。这样，系统的复杂性可以通过实现消息传递服务（如对象请求代管器）的模型而简化。对象只是简单地请求服务，并且其他对象提供这些服务。开发人员不需要更多地知道对象将在上面通信的系统情况。事实上，对象技术为局部使用、将来扩展到异构分布式环境、设计应用提供了途径。

    在这一领域的发展包括：

    对象管理组织（OMG）的公用对象请求代管器体系结构（CORBA）是一种规范，它的设计是为对象产生和接收请求提供了途径。

    Microsoft的对象链接和嵌入（OLE），为在单一台式系统或一个网络上的应用程序共享数据提供了一条途径。

    IBM的系统对象模型（SOM）和分布式系统对象模型（DSOM）提供了低级对象语言

    OpenDoc是一种为共享文本、图形和多媒体对象，而由Apple、Borland、IBM、Novel1和WordPerfect等公司开发的开发环境。

    相关条目：Cario；Common Object Model 公用对象模型；Common Object Request Broker Architecture 公用对象请求代管器体系结构；Compound Documents 复合文档；Object Broker，DEC DEC的Object Broker；Object Linking and Embedding对象链接和嵌入；Object Management Architecture对象管理体系结构；Object－Oriented Interfaces and Operating Systems面向对象的接口和操作系统；Object Request Broker 对象请求代管器；Workplace OS。


  • 面向对象接口和操作系统 Object－Oriented Interfaces and Operating Systems

    面向对象技术在软件开发、用户界面和数据库设计等领域带来了一场革命。在一个面向对象的环境，数据和对数据进行加工的方法被合并为一个对象。一个面向对象的操作系统包括一组小的实用程序（也称为工具（tools）、附件（accessories）或applets），它们可用于编写、编辑、绘图、做图表、编译或做其他一些专用任务。这些实用工具对结构化的数据进行操作，因而，任何一种实用工具加入操作系统都既能处理数据也可以显示它，就象创造复合文档时那样。在旧的模型中，一个应用程序生成的文件并不总是可以被其他应用程序访问的。对象还可以包括一些象文本、电子表格、图形、声音和视频的信息，这些信息可以被一个应用程序生成，并插入另一个应用程序中。

    对象系统是模块化的。当增加一个新的模块时，它可以使用现存的数据结构，因而整个操作系统无需再编译。模块只需简单地插入现存结构。想象一个建筑物，它的一些部分框架是为了允许将来扩展而暴露的。虽然这个建筑物可能看上去并不吸引人，但是它却具有很好的可扩展性。这方面的内容将在“面向对象技术”中进一步讨论。

    面向对象的操作系统正变得越来越通用。大多数主要的厂商，如IBM、Microsoft、Apple、Sun Microsystems等等都开始转向面向对象系统。下面讨论一些这样的计划。

    TALIGENT的PINK Pink是Apple Computer和IBM为开发一种企业计算平台而联合开发的产品的代码名称。它是一种完全的面向对象的32位操作系统，它的设计是为了在不同的硬件平台上运行不同的操作系统（DOS、OS／2、Windows）。直到1995年才有可能完全地提供它。

    MICROSOFT CAIRO Cairo是Microsoft正在开发的一种分布式操作系统，它可能在1995年投入市场。它在WindowsNT之上建造，并且增加了许多新的功能，例如，一个面向对象文件系统、Kerberos安全性和重复服务、目录服务、单代码支持和一个可安装文件系统。从目前的情况来看，Cairo使自己看起来有些类似Windows的一个图形用户界面。Cairo完全实现了对象链接和嵌入（OLE）。

    IBM的WORKPLACE环境IBM的Workplace操作系统使用与Apple Computer在它的Taligent基地共同开发的技术。这种操作系统可在精简指令系统计算机（RISC）处理器、Motorola的PowerPC处理器和基于Intel系统上工作。WorkplaceOS是一种高性能的基于微内核的操作系统。虽然它也使用和OS／2相同的Workplace Shell图形用户界面，但是它可以运行64位内核，64位内核是为一些现存的操作系统设计的应用。这些现存的操作系统包括DOS、Windows、UNIX，当然还有OS／2。

    对象管理组织 推动转向面向对象系统的主要力量是对象管理组织（OMG）。IMG是一组专门定义面向对象技术之间互操作性的厂商们。OMG已经定义了公用对象请求代管器体系结构（CORBA），CORBA为跨越多厂商产品建造面向对象系统提供了一个平台。

    OPENDOC OpenDoc Alliance，它是Apple Computer首先倡导的，它目前正在开发OpenDoc规范。OpenDoc规范的设计是为了帮助开发人员在网络环境建立对象共享应用。它是为创建复合文档的一种规范。OpenDoc类似于Microsoft的OLE，并且被许多公司支持，这些公司包括IBM、Novell、Borland、WordPerfect和其他一些不愿意完全依赖于Microsoft对象技术的公司。

    相关条目：Cario；Common Object Model 公用对象模型；Common Object Request Broker Architecture 公用对象请求代管器体系结构；Compound Document复合文档；DEC Object Broker；Object Linking and Embedding对象链接和嵌入；Object Management Architecture 对象管理体系结构；Object－Oriented Technology面向对象技术；Object RequestBroker对象请求代管器；Workplace OS。


  • 对象，目标，实体 Objects

    面向对象系统为创建应用程序，建造操作系统，以及存储数据提供了一种独特的解决途径。面向对象系统具有如下特征：

    在一个数据库系统，对象是现实世界的实体抽象，如在一个顾客数据库中的人们，在一个财务系统中的发票，或在一个网络目录服务数据库中的打印机和服务器。

    对象包含数据，并包括一组过程，激活这些过程可以处理或报告这个对象内的数据。

    存在对象的类和子类。首先定义一个类，它就象在这个类中创立的对象的一个样本。例如，一个计算机仓库的一个库存可以具有一个称为“计算机”的类。

    子类是以一种层次结构对一个类的特例化。在一个仓库的库存中，一个称为“膝上型”的子类可以在“计算机”类之下定义。

    继承是类层次的一个重要的方面。任何在一个类下定义的子类将继承它的父类的特性，并且能够具有一些它自己的特殊性质。继承通过增进可重用对象而易于开发。

    对象通过发送可以激活对象过程的消息，来实现相互间的协作。

    对象是多态的，即一个消息可以被不同的对象以不同的方式激活。例如，可以为一个顾客对象打印一个名称和地址而激活一个打印命令，也可以为一个发票对象激活打印命令来打印发票。用户执行打印命令而不需要知道如何打印对象的细节情况。

    在一个对象中的信息是加密的，并且只能通过激活属于这个对象的过程来进行改变。一个外部的实体不能旁路这些过程，不能改变这个对象的内部数据。这创立了一种高度可控制的环境，并易于围绕它来维护和建立应用程序。

    由于对象以类似域表项的形式包含数据，所以你可以将一个对象与数据库中的一个记录进行比较，但是这是它们之间唯一的相似点。对象具有为其包含的数据进行加工的内部过程，而对关系数据库的任何操作都是由外部过程进行处理的。这给予了对象一定的独立性。如果你移动一个对象，这些过程需要抽取与这个对象一起移动的这些过程的信息。

    现在，已经有一些面向对象的编程语言、面向对象的操作系统和面向对象的数据库。下面列出了一些例子。

    一个对象是一个面向对象编程语言的一个模块，它包含其他对象可以用于简化程序开发的代码。

    一个对象是在一个层次命名系统中的一些信息的集合。例如X．500目录信息库（DIB）或Novell Net Ware 4．x目录服务（NDS）。NDS目录树包括包容器和叶对象。包容器包含其他小包容器或叶对象，叶对象代表实际生命的实体，如用户、打印机、服务器、数据卷宗。

    复合文档包括其他应用创造的对象，如文本和图形对象。Microsoft Windows的对象链接和嵌入（OLE）提供了一种复合文档功能的例子。

    相关条目：Compound Document复合文档；Directory Services，NetWare NetWare目录服务；Object Linking and Embedding 对象链接和嵌入；Object－Oriented Technology 面向对象技术。


  • NetWare目录服务中的对象 Objects，NetWare Directory Services

    在NetWare 4．x中NetWare目录服务（NDS）的功能适用于X．500的命名服务，其中，用户帐户和网络中的资源是以对象的形式进行管理的。一个用户对象包括名称、计算机结点地址、登录原语和其他关于一个网络用户的有生命力的管理信息。资源，如服务器、打印机、卷宗，也表示为对象。这些对象具有描述谁能使用和改变它们的性质。

    对象存储在NetWare目录数据库（NDB）中，并且以层次树的结构进行组织。“包容器对象”通常表示一个机构的分支机构或部门。包容器对象包含其他对象，如用户对象、服务器对象和打印机对象。树的组织形式是重要的。由于一个对象表示一个分支机构或部门，因而管理人员可以授予一位经理或超级用户对一个包容器对象的不同权力，即授予这位经理或超级用户对这个包容器对象内所有对象的管理权限。

    相关条目：Directory Services，NetWare NetWare目录服务；X．500 Director yServices X．500目录服务。


 OCR　光学字符识别
：OCR(Optical Character Recognition)是指电子设备（例如扫描仪或阅读器）检查纸上打印的字符，通过检测暗、亮的模式确定其形状，然后用字符识别方法将形状翻译成计算机文字的过程。


 OEM　原装备生产厂商
：OEM（Original Equipment Manufacturer）指某个设备的制造者。在制造计算机极其相关设备的过程中，原装备生产商通常从其他原装备生产商购买元件，将它们集成为自己的产品，然后提供给公众出售。


 OH　调制解调器连线
：OH（Off Hook）是调制解调器上面的一个灯号。当电脑使用调制解调器连上Internet的时候，这个灯号会亮，表示目前是处于连线的状态。反之，离线之后这个灯号就不会亮。


  • 联机（在线）事务处理 On－line Transaction Processing

    通常在一个数据库系统中，一个事务是工作的一个离散单位。例如，一个数据库事务是一个修改一个用户的帐户平衡或修改一个库存项的写操作。联机事务处理以实时的方式发生。民航定票系统和银行ATM机器是联机事务处理系统的一些例子。

    传统上，大多数联机事务处理系统在大型计算机系统上实现，这是由于业务处理操作的复杂性，需要快速输入／输出、禁止和管理。一些系统每秒处理400到500个或更多的事务。如果一个事务必须在多个场地进行修改，那么就需要一个管理机制以防止重写数据并提供同步。其他的需求包括具有卷回失效事务的能力、提供安全性特征、如果需要提供数据恢复的能力。这是通过一个事务处理监督器来处理的。这个监督器保证了事务是完全完成的，或进行卷回，因而数据库保证它的每个事件发生前的状态。

    在一个分布式环境，写操作经常并行地在多个数据库服务器上发生。这样的并发事务处理需要一个“卷回”机制，以保证在一次写操作中系统失效的情况下，数据库的完整性。事务要么一起确认，要么放弃。如果一个或多个和事务有关的系统响应不一致，这意味着系统可能出现故障或通信出现了故障，因而就会放弃一个事务。

    下面，列出了一些通用的事务处理（TP）监督器：

    IBM顾客控制系统（CICS）是一种在IBM主机系统上运行的TP监督器。

    Tuxedo 是一种分布式TP监督器，它是AT＆T开发的，并由Novell的UNIX系统组推向市场。它在许多不同的计算机系统上运行，并被一些客户支持，这些客户包括DOS、OS／2以及Windows。

    Encina TP监督器 是一种基于开放软件基金会的分布式计算环境的监督器。主要厂商，如IBM和Hewlett－Packard计划使用Encina。

    相关条目：Encina；Transaction Processing事务处理；Tuxedo，UNIXS ystem Laboratories UNIX系统实验室的Tuxedo；Two－Phase Commit 两阶段提交。


  • Apple的开放协作环境 Open Collaborative Environment（OCE），Apple

    Apple OCE（AOCE）是一组服务和工具，它可以帮助软件开发人员为网络环境快速开发合作应用产品，如工作组和工作流软件。这种环境的实现就象一组应用程序编程接口（API）、允许应用使用消息传递服务、电子激活应用、和目录命名进行通信的软件模块。还包括安全性特征。

    用户将能够操作网络并从他们的应用程序之内使用通信服务，以及为一些项目与其他用户进行合作。组调度、文档流、组间通信是由AOCE认同的应用程序来处理的。有三种类型的应用程序加入了这个环境：

    集成个人通信应用 它能自动进行电子函件、传真和语音消息传递。

    工作流自动化 它模仿在网络计算环境中的纸张路由选择过程。

    小组（team）应用程序在广域提供工作组通信。

    相关条目：Apple Open Collaborative Environment Apple的开放协作环境。


  • Microsoft的开放式数据库互联性 Open Database Connectivity（ODBC），Microsoft

    为使Microsoft Windows用户能够访问多种台式数据库和文件格式，设计了开放式数据库连接（ODBC）描述。ODBC 使得Windows用户可以访问存储在公司大型计算机上的数据，以及通过使用数据库程序或其他在Windows环境上运行的应用程序，来访问存放在基于LAN的数据库服务器的数据。

    ODBC是IBM的Windows开放式系统体系结构（WOSA）策略的一部分，WOSA策略是一个为在Win－dows环境上的不同平台进行应用程序开发的计划。WOSA包括模块化应用程序编程接口（API），它提供了一种任何开发商创造的应用程序都可以访问网络服务（如电子函件、数据库、主机连接）的途径。WOSA还提供了一条“插入”任何开发商创造的后端服务的途径。WOSA是一种所谓的“中间件”策略，它直接建造在操作系统中，以激发允许用户在网络上相互协作的工作组应用的增长或对数据库提供通用接口。

    WOSA扎根于从应用程序中分离打印机驱动程序的Microsoft的策略。在Windows环境，一个打印机驱动程序是在最初的安装时装入的，并且可以在以后的任何时间通过一个简单的过程进行升级或改变。Windows应用程序不需要任何特殊的配置就可以使用安装的打印机驱动程序。Windows应用程序自动地接口到打印机驱动程序，并且利用打印机驱动程序的特定特征和可用字体。ODBC 使用类似的策略以象Windows客户应用提供对后端数据库系统的通用访问。没有ODBC，后端开发人员必须为每个前端应用编写驱动程序，或前端开发人员必须为每个后端服务器系统编写驱动程序。

    0DBC提供被多数后端数据库系统操作的通用功能。它使用结构化查询语言（SQL）来操纵后端系统，并为不同的数据库管理器和不同的SQL实现方式，提供到帐户的独立接口。前端应用是为ODBC接口和利用它的功能而编写的。然而，这种研究可能仅仅提供一组最通用的功能，可能不能利用在每个后端系统可用的一些特殊特征。独立的实现将需要测试。ODBC是走向互操作性的一个步骤，它将允许用户访问以前不能访问的后端数据。

    Microsoft以一组驱动程序的形式提供ODBC，它们可以在一些前端应用上运行，如Microsoft Excel、Microsoft Access、FoxPro、Btrieve、dBASE和Paradoc。后端系统支持是向IBM、Oracle、Paradox和其他数据库系统提供的。这些驱动程序可以为软件厂商们再分发，也可以与一些应用程序打包。ODBC研究赋于Microsoft为在企业环境访问工业标准数据库领域，在提供Windows和Windows应用程序作为基本客户平台上以主要优势。

    相关条目：Client－Server Computing客户机／服务器计算；Database Connectivity API sand Middleware数据库连接性的API和中间件；Database Management System 数据库管理系统；Distributed Database 分布式数据库；Enterprise Network 企业级网络；Interoperability互操作性；Middleware中间件；Structured Query Language 结构化查询语言；Windows Open System Architecture Windows开放式系统体系结构。


  • 开放DECconnect结构化布线系统 OPEN DECconnect Structured Wiring

    一种紧跟EIA／TIA 568商务建筑布线标准的结构化布线系统。

    相关条目：Cabling 布缆；Digital Equipment Corporation 数字设备公司；EIA／TIA 568 Commercial Building Wiring Standard EIA／TIA 568商务建筑布线标准。


  • 开放文档体系结构 Open Document Architecture

    参见Document Interchange Standards文档互换标准。


  • 开放消息传递接口 Open Messaging Interface（OMI）

    OMI最早是由cc：Mail开发的，cc：Mail是一个电子函件软件开发商。它的设计是为了帮助程序通信，而不管是什么样的网络连接环境。Lotus购买了cc：Mail，并使它与Lotus、IBM、Apple及其他厂商提供的软件兼容。现在OMI被称为厂商无关消息传递（VIM）。VIM和Microsoft的邮件应用程序编程接口（MAPI）进行竞争，MAPI是Windows开放式系统体系结构（WOSA）的一部分。

    相关条目：Vendor Independent Messaging，Lotus Lotus的厂商无关消息传递。


  • SunSoft的开放式 网络计算环境 Open Network Computing（ONC），SunSoft

    SunSoft的ONC技术是一组联网协议，可用于建立一个异构分布式计算环境的分布式服务。ONC和它的下一代产品ONC+，是为独立于操作系统、计算机体系结构和网络运输协议而设计的，它还提供到基于网络的数据和计算资源的透明访问。它们为程序员提供开发和实现分布式应用的积木，并可以简化小型和大型网络的管理。

    150多家公司在不同的硬件平台和操作系统上开发实现ONC。NetWare文件系统（NFS）是著名的ONC服务系统。Sun Microsystems最初以NFS的名称开拓ONC市场，并且许多许可继续描述它们的产品是NFS，虽然它们支持完全的ONC平台。ONC包括如下核心协议，如图O6所示。

    Remote Procedure Cal1（RPC） 远程过程调用（RPC）

    RPC是通过网络在远程系统上执行过程的独立于操作系统的一组操作。RPC基于程序员通常使用的过程调用机制，提供了一种处理低级进程间通信的客户机／服务器通信结构，因而程序员可以开发在异构网络上运行的分布式应用程序。

    External Data Representation（XDR） 外部数据表示（XDR）

    XDR是SunSoft的开放网络计算环境的一种功能。XDR提供了一种与体系结构无关的表示数据，解决了数据字节排序的差异、数据字节大小、数据表示和数据对准的方式。使用XDR的应用程序，可以在异构硬件系统上交换数据。从SunSoft使得可以免费获得RPC／XDR规范和源代码。

    Transport Layer Interface（TLI） 运输层接口（TLI）

    在AT＆TUNIX系统V版本4中，TLI是ONC底下的一层，它是一个编程接口库，它使得RPC具有与协议无关的性质，并允许RPC程序在多协议网络传输，如TCP／IP和OSI上运行。为TLI编写的增强型RPC就是传输独立RPC（TI－RPC）。TI－RPC是在UNIX系统V版本4中的标准，并且它与现存的ONCRPC协议兼容。另外，Novell也提供TI－RPC技术。

    Distributed Services NFS 分布式服务NFS

    于1985年宣布的网络文件系统（NFS），是一种允许用户在网络区域系统共享信息的开放式系统技术。NFS提供对远程文件系统的透明访问。存储在和网络相连的任何系统的文件可以被任何用户访问。访问是基于管理人员和文件所有人所授予的权限的。下面讨论的模块是分布式服务的组成部分。

    网络信息服务（NIS）NIS是一种网络范围的数据管理设备。它提供了一个扩展的数据库，以存储系统信息，如主机名称、网络地址、用户名称和网络等。NIS的正式名称是黄页YP（Yellow Pages）。

    锁定管理器（LM）LN通过支持一个网络上的文件和记录锁定，而允许用户对访问信息进行协调和控制。它阻止两个或多个用户同时修改同一个文件或记录（从而可能破坏有用数据）。

    远程执行（REX）服务 REX用于在远程系统上运行用户命令或程序。它提供在本地计算机上不能获得的计算能力的访问。

    网盘（NETDISK） 这个模块允许无盘工作站从支持ONC／NETdisk协议的服务器中得到自举能力。

    自动装入器（AUTOMOUNTER） 自动装入器根据是否需要的原则，自动地装入或卸载远程目录。这提供了NFS文件系统增加的透明性和可用性。它通过允许将远程装入指向一组服务器而不是一个服务器，来支持对经常读并很少写的文件的复制，例如，系统二进制代码的复制。

    PC－NFS守护程序 这个在基于ONC的服务器上运行的小程序，对在实现ONC的DOS上运行的PC提供鉴别和打印池服务。

    ONC+and Federated Services ONC+和联合服务

    ONC+是ONC的下一个阶段，联合服务将允许ONC和其他分布式计算环境共存，如NetWare、开放软件基金会的分布式计算环境（DCE）和开放式系统互联（OSI）。新的特征包括多线程和一个命名服务。下面将介绍这方面的内容。

    修改的NFS特征 新的NFS包括多线程和新增的Kerberos鉴别服务（参见“Kerberos 鉴别”）。其他一些计划增强的特征包括对面向连接的传输支持，如传输控制协议（TCP），以及书写簇（write clustering）和一个新的高速缓冲文件系统，以改进性能。

    NIS十命名服务器 NIS+是替代NIS的。它为大型网络提供了一种层次式的企业命名服务。它比NIS具有更好的可扩展性和安全性，并且易于管理。NIS+对NIS客户具有互操作性。

    TI－RPC ONC+将包括以前讨论过的TI－PRC和远程异步调用设施，它保证了对远程过程调用的无阻塞性。其他增强包括多线程能力、共享存储器特征和改进的连接管理设施。

    安全性 除了Kerberos安全性特征之外，还提供RSA数据安全性。可以从SunSoft获得ONC许可，从而有权使用RSA认同的RSA技术。

    联合服务 SunSoft的动机是，使它的Solaris操作系统用户，能够在支持多厂商分布式服务的一个异构网络上访问资源。这些服务当然是可以共存的。联合服务是对Solaris分布式计算环境的扩展。

    Solaris操作环境提供标准化的联合服务接口（FSI），它允许厂商们以良好的集成方式，将他们的分布式服务加入Solaris中，从而这些服务在Solaris内的ONC十核心服务中的地位是对等的。

    相关条目：Distributed Computing 分布式计算；Distributed File Systems分布式文件系统；Enterprise Networks 企业级网络；Remote Procedure Ca11远程过程调用；Security安全性；SunSoft Solaris；Sun Microsystems，Inc．Sun Microsystems公司；SunSoft SunOS；Transport Layer Interface运输层接口。


  • 优先开放最短路径（OSPF）协议 Open Shortest Path First（OSPF）Protocol

    优先开放最短路径（OSPF）是一种链路状态路由选择算法，它来自开放式系统互联（OSI）的中间系统对中间系统（IS－IS）域内路由选择协议方面的工作。与距离向量路由选择相比，链路状态路由选择需要的更多处理性能，但是却提供了对路由选择过程的更多控制和对改变情况更快的反应。根据下面的数据，采用Dijkstra算法来计算路由：

    分组为了达到目的地而必须经过的路由器数目。这个数目通常被称为步数（hops），在大多数情况下，步数越少越好。

    LAN间传输线路的速度。有一些路由可能会使用慢速的异步连接，而其它一些路由可能使用高速的数字连接。

    由于传输拥挤而产生的延迟。可变长度帧可以保持住路由器上的通信量。一个路由器可能为了避免拥挤而将分组沿另外一条路由发送出去。

    路由的费用。这是由管理人员定义的一个指标，通常它是依赖于传输介质的。便宜的介质可能不是太快，但是却对一些类型的通信传输非常合适。

    OSPF路由选择表只有在需要时，才进行修改，而不是每隔固定间隔就发生一次。这十分明显地减少了通信量，并且节省了网络带宽。穿越网络的路径是基于上面列出的原则来选择的。一个网管人员可以根据通信的类型来规划穿越网络的路径。例如，如果线路具有较高的传输率，那么用较多步数来穿越网络可能是比较合适的。相应地，如果线路是低速的，并且是低费用的，就可能在规划时较少考虑通信量。

    相关条目：Link State Routing链路状态路由选择；NetWare Link Service Protocol NetWare链路服务协议；Routing Protocol 路由选择协议。


  • 开放软件基金会（OSF） Open Software Foundation（OSF）

    开放软件基金会是一个会员式机构，它从其它厂商处获得技术来建立计算环境。它定义需要什么，然后向任何人提供这些定义，称为“为技术而请求（RFT）”。OSF实际创造的技术只是那些获得技术的组合。

    OSF开放式系统软件环境是一组开放式系统技术的集合，这些技术使用户能够在虚拟无缝的环境，对来自多厂商的软硬件进行融合和匹配。厂商无需考虑的软件环境包括如下：

    分布式计算环境?DCE）一种平台或基础设施，它可以简化异构环境中的产品开发。

    分布式管理环境（DME）为分布式混合厂商环境中的系统和网络管理人员提供工具。

    开放软件基金／1（OSF／1）开放环境的UNIX操作系统，它支持对称多处理机工作，增强的安全性功能，和动态配制。它是围绕Carnegie Mellon大学的Mach操作系统微内核建造的。

    OSF／Motif 一种图形化的用户接口，它具有与Microsoft Windows和Apple Macintosh操作系统相似的界面，提供一种通用的外观和感觉。它在IBM系统上广泛使用，并且和IBM的通用用户访问（CUA）有关系。

    OSF体系结构无关分布格式（ANDF）它使得开发人员可以生产和包装一个应用成为在不同的硬件体系结构上使用的一个版本，它为大市场开放式系统软件开辟了一个市场。

    OSF在开放式系统和互操作产品标准开发中扮演着关键角色。通过OSF的分布式计算环境，向开发人员提供了可以隐藏不同技术和产品间差异的软件。DCE使得开发人员可以建造在分布式客户机／服务器环境工作的应用产品。图O－7示意了一个分布式环境。它是一种许多不同服务器向客户提供服务和数据的环境。这些系统可以是放在统一地点的，也可以是分散在广阔地理区域的。

    典型的分布式环境是异构的，他们包括许多不同厂商的产品、操作系统、应用和数据库。OSFDCE通过提供可以隐藏操作系统、通信协议和多厂商产品差异的一种公共基础设施，来简化在分布式客户机／服务器环境的产品开发。

    在过去，可以从IBM、DEC等厂商处获得公共基础设施，但是他们都是专有的。OSFDCE的基本目标是提供一个开放环境。它定义了一种客户可以与后端服务器进行交互的客户机－服务器体系结构。然而，在分布式环境，服务器可能是分散放置的，并且是通过广域网（WAN）链路连接的。由于这种网络可能是范围很广的，而且数据访问速度也是可变的（WAN连接的结果），数据同步和其它问题将出现，从而导致了创建分布式应用的复杂性。由于在创建这样的应用时的复杂性，OSFDCE，以及类似产品，已经变得至关重要，并且被许多厂商支持，如IBM、DEC、Hewlett－Packard等厂商。

    厂商无关DCE平台提供如下核心服务。这些服务在“OSF分布式计算环境”下讨论得更细致。

    分布式目录服务，源于DEC的DECdns目录服务。

    基于Andrew文件系统（AFS）的分布式文件系统。

    源于Apollo（现在的Hewllet－Packard）开发的网络计算系统的远程过程调用。

    安全性服务，如鉴别、数据完整性，和Kerberos提供的数据个人性（它是在麻省理工学院发明的）。

    一些主要厂商将OSFDCE集成到了他们的产品中。Novell将要把DCE以可装入模块的形式集成到NetWare中，它还在一些大学资助了一些与DCE相关的计划。IBM为它的OS／2产品增加了DCE客户机软件，因而用户可以在包括运行DCE的OS／2在内的IBMDCE服务器上访问DCE文件和目录服务。Hewllet Packard也加入了DCE，它提供联机事物处理（OLTP）产品、对象管理系统和其它基于DEC的产品。

    相关条目：Directory Service目录服务；Distributed Computing 分布式计算；Distributed Computing Environment分布式计算环境；Distributed Database 分布式数据库；Distributed File Systems分布式文件系统；Mach，Carnegie－Mellon Microkernel Carnegie－Mellon大学的微内核Mach；Microkernel 微内核；OSF／1，Open Software Foundation开放软件基金OSF／1；Remote Procedure Call远程过程调用；Security安全性。


  • Open Source 开放源代码

    一个用来指免费软件的术语。对于一个开放源代码的应用程序来说，允许公众获得该应用程序的源程序代码，并可以对获得的源程序代码进行修改和发放。


  • 开放式系统互联（OSI）模型 Open Systems Interconnection（OSI）Model

    OSI模型是国际标准化组织创建的一种标准。它为开放式系统环境定义了一种分层模型，其中，如果两个系统采用了相同的OSI层通信协议，那么，在一台计算机上运行的一个进程就可以和另一台计算机上的类似进程通信。图O－8示意了OSI模型。在一次通信会话期间，在各个计算机的每个层运行的进程相互通信。最底层定义了实际的物理部件，如连接器和电缆，以及系统间的数据位的电子传输。在此之上的一些层定义数据包装和寻址方式。再向上的层定义保持通信会话生存的方式。最后，最高的层描述应用如何利用下面的通信系统来和其它系统上的应用进行交互。

    OSI模型的设计是为了帮助开发人员创造可以与多厂商产品系列兼容的应用程序，以及增进开放和互操作的联网系统。虽然OSI还没有摆脱只是一种计划的局面，但是它的模型仍然被用于描述和定义不同厂商的产品如何通信。图O－9示意了OSI协议栈和其它协议栈之间的比较情况。

    协议是以软件驱动程序的形式被装载到计算机中的。协议栈的每一层都定义一些特定的功能。当最高层的应用程序需要发送消息到网络上的其它系统时，这个应用程序就和下面的层进行交互。这个请求是在一个层进行包装，并向下传送到下一个层的，它将增加一些和这个层处理功能相应的信息，在一个分组内产生一个新的分组的应用程序需要发送消息到网络上的其它系统时，这个应用程序就和下面的层进行交互。这个请求是在一个层进行包装，并向下传送到下一个层的，它将增加一些和这个层处理功能相应的信息，在一个分组内产生一个新的分组。然后，这个分组被向下传递到下一个层，并且这个过程将继续，如图O－10所示。每个层都向这个消息分组增加信息，并且这个信息将被接收系统的协议栈的相应层进行读取。按照这个方式，每个协议层与它对应的协议层进行通信以完成通信。

    每个层定义通信子系统必须遵守的规则和规程，以达到和其它系统对等进程进行通信的目的。下面列出了通信子系统处理进程的一些例子：

    在应用程序之间相互协作和交互，以及对语法和数据表示的差异进行翻译。

    在全双工或半双工模式下的数据交换管理。

    面向连接的会话管理（这是指监控和维护两个系统间的通信通道）。

    网络路由选择和寻址过程。

    网络驱动程序（这是指为传输做准备而将数据编帧）。

    网络接口卡功能（这是指在网络介质上传输电子、光或无线电信号）。

    产品开发人员利用协议标准来创造能够和其它厂商的产品进行相互操作的产品。例如，底层的一些层定义了硬件接口技术，一个在这一层次设计硬件驱动程序的开发人员，将遵守在这一层定义的规则。

    在一次实际的通信会话中，在协议栈中的每个层和在其它系统的对等层进行通信，但这是通过对被传送到下一较低协议层的分组加上它需要通信的信息来实现的。如前所述，这个过程在“分层体系结构”中有更详细的介绍。

    下面介绍网络协议。在进行任何通信层的工作之前，你必须安装了网络硬件——物理层，因而物理层被首先介绍。

    物理层 物理层定义接口的物理特性，例如机械部件和连接器，电器特性，如表示二进制值的电压级，和功能性特性，如建立、维护和拆除物理链路。用于数据通信的著名物理层接口包括EIARS－232和RS－449，RS449是RS232的后继，它允许更长的电缆距离。著名的局域网（LAN）系统是以太网、令牌网和光纤分布式数据接口（FDDI）网。

    数据链路层 数据链路层定义在两个系统的物理连接之间发送和接收信息的规则。这一层为进行传输，对数据进行编码和编帧，另外还提供出错检测和控制。由于数据链路层已经能够提供对出错的控制，所以更高的层就不再需要处理这种服务了。然而，当使用可靠传输介质时，在这一层不进行出错控制，而是在更高的层执行这种工作，这将可以提供更高的性能。网桥在协议栈的这一层进行操作。下面是一些用于数据链路层的通用协议：

    高级数据链路控制规程（HDLC）和相应的同步、面向位的协议。

    LAN驱动程序和访问方式，例如以太网和令牌环。

    快速分组广域网，例如帧中继和异步传输模式（ATM）。

    Microsoft的网络驱动程序接口规范（NDIS）。

    Novell的开放数据链路接口（ODI）。

    网络层 网络层定义为在系统之间开辟和维护网络路径的协议。它和数据传输和交换过程有关，而对上面的层隐藏了这些过程。路由器在网络层进行操作。网络层可以查看分组地址以确定路由选择的方式。如果一个分组是被编址到一个本地网络上的工作站的，那么它就被直接送到那里。如果它是被编址到其它段的一个网络的，那么这个分组就被送到一个路由选择服务那里，再在网络上被转发。下面是一些用于网络层的通用协议：

    因特网协议（IP）。

    X．25协议。

    Novell的网间分组交换（IPX）。

    Banyan的VINES网间互联协议（VIP）。

    运输层 运输层为在系统间移动信息提供了一种高级控制，包括更加复杂的出错处理、优先分级和安全性特征。运输层通过在两个端系统间提供面向连接的服务，提供了高质量的服务和准确的传递。它控制分组的次序、节制通信流和识别重分组。运输层对编址分组的信息赋予一个跟踪号，这个跟踪号在目的地将被检查。如果分组丢失了数据，在接收端的运输层协议和在发送系统的运输层联系，对这个分组进行重发。这一层保证了所有数据都接收，并且是按正确的次序被接收。一个逻辑电路（Logical Circuit）就象一个专用连接，可以建立逻辑电路来在系统间提供可靠的传输。下面列出了可以提供面向连接服务的非OSI运输层协议：

    网间传输控制协议（TCP）。

    Internet用户数据报协议（UDP）。

    Nove1l串行分组交换（SPX）。

    Banyan VINES进程间通信协议（VIPC）。

    口Microsoft NetBIOS／NetBEUI。

    会话层 会话层通过使用会话技术或对话，协调系统间的信息交换。并不总是需要对话，但是一些应用程序在一个连接暂时失效时，可能需要知道从哪里重新开始传送数据，或可能需要一个固定间隔的对话以确定一组数据已经发送完毕，可以开始发送新的数据了。

    表示层 表示层上的协议是工作站上运行的操作系统和应用程序的一部分。为了显示或打印信息，在这一层对信息格式化。数据内的代码（例如标签或特定的图形序列）将被解释。在这一层还进行数据加密和其它字符集的翻译。

    应用层 应用层用于定义一系列应用程序，这些应用程序处理文件传输、终止会话和消息交换（例如电子函件）。应用使用这一层定义的过程来访问下面的网络服务。下面列出OSI应用层协议：

    虚拟终止。

    文件传输访问和管理（FTAM）。

    分布式事务处理（DTP）。

    信报处理系统（X．400）。

    目录服务（X．500）。

    图O－11示意了数据从一个系统到另一个系统的过程中，如何流过协议栈和传输介质的。数据从应用层和表示层开始，在这里一个用户使用一个网络应用，例如电子函件系统。对服务的请求，穿越表示层到达会话层，在这里开始对信息编分组的过程。在两个系统间可以开辟一个面向连接的通信会话，以提供可靠的传输。一旦会话被建立，协议层开始以合适的方式交换信息。

    相关条目：Connection－Oriented and Connectionless Protocols面向连接和无连接协议；Layered Architecture 分层体系结构；Packet 分组；Protocol Data Unit协议数据单元；Protocols，Communication通信协议；ProtocolStack 协议栈。


  • 开放式系统 Open Systems

    开放式系统是在计算机体系结构、计算机系统、计算机软件和通信系统等领域广泛使用的一种术语。开放式系统鼓励开发兼容的厂商产品。顾客可以从开放式系统中获益，这是因为他们可以在很广范围的、可与系统一起工作的产品中进行选择，更为重要的是，易于和其它厂商的产品互联。一个开放环境提供标准通信设施和协议，或提供一条使用不同协议的途径。计算机社会给要开放的厂商施加了更多的压力，这是因为他们在销售产品时必须公开承诺这些设备将能和现有的系统一起工作。

    开放式系统是由厂商、厂商的国际联盟、政府部门和世界范围的标准化组织进行定义的。典型情况是，发起厂商、国际联盟或标准化机构控制规范，但是他们是在公共会议上，与其它厂商和用户一起来定义规范的。最近的趋势已经开始偏离了拼命地追求完全的开放，而转向了接受正在使用的标准。例如，传输控制协议／因特网协议（TCP／IP）被证明比开放式系统互联（OSI）协议更加流行，这是因为Internet将永远把TCP／IP协议作为它的基本协议。大多数厂商现在支持TCP／IP，然而还有少数厂商支持OSI协议。

    如下所述，一些机构加入了标准化进程，包括一些支持使用和集成正在使用的标准，如开放软件基金会。

    开放式系统互联（OSI）模型 是由国际标准化组织在八十年代初开发的。它为计算机和网络设备的互联定义标准和协议。

    开放软件基金会（OSF）是一个会员式机构，它从其它厂商处获得技术来建立计算环境。OSF实际创造的技术仅仅是那些获得技术的组合。OSF开放式系统软件环境是一组开放式系统技术的集合，这些技术使用户能够在虚拟无缝环境，对来自多厂商的软便件进行融合和匹配。它的环境包括分布式计算环境（DCE），可以简化在异构环境的产品的开发；它还包括开放软件基金／1（OSF／1），一种为开放环境的UNIX操作系统，它支持对称多处理机工作、增强的安全性特征和动态配制。它是围绕Carnegie Mellon大学的Mach内核建造的。另外还有OSF／Motif，一种图形化的用户接口，它具有Microsoft Windows和Apple Macintosh的特征，提供一种通用的外观和感觉，它在IBM系统上广泛使用，并且和IBM的公用用户访问（CUA）有关系。

    公用开放软件环境（COSE）是一些厂商组成的国际联盟，这些厂商包括IBM、Hewlett－Packard、SunSoft，Novell，他们共同合作以开发一种可以和Microsoft Windows竞争的UNIX通用台式系统环境（CDE）。

    对象管理组织（OMG）开发了一组厂商可以用于开发在多厂商环境操作应用的面向对象语言、接口和协议标准。OMG验证根据标准设计的产品的可接受性。

    SQL访问组（SAG）SAG是一个数据库管理系统（DBMS）厂商小组，他们的目标是，建立互操作的结构化查询语言（SQL）数据库标准。SAG和ISO，以及ANSI（美国国家标准局）协商以达到这一目标。

    X／Open公司 一个为建立互操作应用而倡导开放的、多厂商环境的厂商构成的小组。它出版信息并提供确认服务。

    计算机厂商，如IBM、DEC、Hewlett－Packard，以及其它厂商，现在已经开始偏离他们在七十年代和八十年代提倡的专用结构和系统，而开始提供新的开放式环境。例如，IBM支持它的现有的用户对系统应用体系结构（SAA）、高级对等联网（APPN）和其它标准的需求，同时，通过定义联网方案支持新的顾客对开放环境的需求，它具有如下特征：

    隐藏下面的联网部件，因而顾客可以有选择地使用应用产品。它是通过使用OSFDCE和OSI标准来达到目的的。

    允许使用多种通信协议，例如APPN、TCP／IP和OSI。

    为通信使用高带宽技术。

    数字设备公司在1987年宣布的DEDnet阶段V中支持OSI协议。它提供对OSI模型的完全兼容和对阶段IV的向后兼容。然而，在1991年，DEC宣布了ADVANTAGE－NETWORKS，这是一种增加对其它协议支持的策略，如支持TCP／IP。为此，DEC从它在阶段V中对OSI的全部接受中退出。更重要的是，DEC提供对TCP／IP的支持，并且有能力建立多种协议支持，它们可以传输DECnet、TCP／IP和OSI数据。例如，用户使用OSI运输协议可以在TCP／IP应用之间传送数据，或使用TCP 协议在OSI应用之间传输数据。

    Moveto Interoperability 走向互操作性

    在过去的十年里，OSI协议就象是对开放式系统设计的模型，虽然对这个协议的一般性接受还是很慢的。甚至使用TCP／IP协议的因特网，也已经开始为集成OSI协议而工作。在缓慢地接受OSI的同时，厂商们开始设计专用的产品，并致力于他们自己的联网体系结构。然而，最近，TCP／IP已经成为通向互操作的一个驱动力量，这主要是因为它有能力处理网络互联，以及它在因特网中被广泛使用。

    开放式系统的运动已经从需要开发一种承认协议模型，如OSI，转移到接受多种不同协议。在公司进入到将他们的部门级计算机集成为企业级系统的时期，需要将IPX、TCP／IP、AppleTalk、NetBIOS和许多其它协议集成到将所有东西都能紧密相连的网络平台中。处理能力、多协议路由器和中间件的发展，使得这种多协议支持是可行的。

    这里的中间件是一个基本术语，它指对应用程序隐藏下面系统，允许应用程序和其它应用程序进行接口的软件平台。例如，一个在Novell网络Windows应用运行的用户，可以访问一个传统上不兼容的和TCP／IP网络相连的UNIX计算机系统上的数据库。中间件产品处理所有的通信和接口需求。

    对多种不同协议的接受和处理这些协议的产品的可获得性，导致了互操作产品市场的扩展。现在，网络管理人员和用户具有更大的选择权，并且可以在他们的网络上使用更多的可用资源。另外，产品的生产商可以将精力集中于设计独特产品，并且对兼容性很少关心。

    相关条目：Distributed Computing Environment 分布式计算环境；Enterprise Networks 企业级网络；Government OSI Profile政府OSI描述；IBM Networking Blueprint IBM联网方案；Interoperability互操作性；Middleware 中间件；Open Systems Interconnection Model 开放软件基金会；Open Systems Interconnection Model 开放式系统互联模型；Windows Open System Architecture Windows开放式系统体系结构。


  • HP的Open VieW管理系统 Open View Management System，Hewlett－Packard

    Sun Microsystem的SunNet管理器和Hewlett－Packard的OpenView使用一种平台体系结构，其中一个是设计处理网络管理系统所有核心功能所需的平台。这些功能包括通信协议接口、数据定义和其它管理特征。然后，其他厂商设计的产品可以插入或接口到平台厂商所设计的平台上，从而获得所有它的内置功能，如访问多协议网络、多厂商系统和数据管理策略。

    相关条目：Management Standard sand Tools管理标准与工具。


  • 开放数据链路接口 OpenData－link Interface

    NetWare使用众所周知的与协议无关的开放数据链路接口结构，来对网络上的不同协议同时提供支持。如图O－5所示，网络驱动程序将它们自己连接到ODI层。分组被指向ODI层之上的相应的协议栈，例如网间分组交换（IPX），传输控制协议／因特网协议（TCP／IP），或App leTalk。接近顶端，服务协议对可以在NetWare服务器上安装的不同操作系统提供文件和系统支持。

    在工作站使用类似的策略，以允许用户使用不同通信协议（如基于UNIX的TCP／IP）的网络相连。将需要Novell的LAN Work Placefor DOS，以提供对DOS和Windows工作站的TCP／IP支持。另外，Novell的 LAN Work Place for Macintosh，向Apple Macintosh用户提供在NetWare LAN上的很大范围的主机、服务器和工作组的透明访问，例如，对VAX小型计算机、IBM大型计算机和UNIX工作站。其他厂商也提供类似的产品。

    如果需要将工作站连接到NetWare，以及其他类型的网络，如Microsoft LAN管理器、IBM LAN服务器和3Com 3＋共享网络，就可以安装NetWare软件包中提供的ODI网络驱动程序接口规范支持（ODINSUP）驱动程序。ODINSUP允许ODI网络驱动程序接口和Microsoft网络驱动程序接口规范（NDIS）共存．这通常是Microsoft产品使用的，如LAN管理器和Windows NT。

    ODI为那些需要和其他一些不同的系统进行互联的用户，提供如下好处：

    单一的网络卡，它是与不同协议栈接口的一个单一的网络卡。

    产生一个处理来自不同系统的分组的逻辑网络板。这些分组可以在相同网络接缆系统上发送，而该系统是与单一网卡相连的。

    这种工作站可以使用不同的协议栈，而不需要被重启。

    ODI允许NetWare服务器和工作站与其他不同的系统进行通信，这些系统包括使用不同协议栈的大型计算机。

    ODI标准化了网络接口卡驱动程序的开发，厂商们不再需要担心他们的驱动程序是否适合一种特定的协议栈。事实上，驱动程序是为和链路支持层（LSL）连接而编写的。LSL就象一种交换板，它分组被指定到相应的协议栈。

    可以在图O－5中看到ODI的一些部件层，在底部是对不同类型网络接口卡的接口，在顶部是和NetWare操作系统接口的协议，在中间是链路支持层，它在部件间指导通信传输。

    多链路接口（MLI） 多链路接口（MLI）层是为连接网络接口卡设备驱动程序的一个接口。这些设备驱动程序是由和Novell链路支持层的规范匹配的厂商编写的。这些驱动程序被以多链路接口驱动程序（NLID）的形式引用。

    链路支持层（LSL） LSL为在底层的驱动程序和在顶部的协议提供一个链路。它象一个交换板那样工作，从MLID指导网络通信到相应的协议，或者相反方向进行。

    多协议接口（MPI）多协议接口（MPI）对协议栈的连接提供了一个接口，例如IPX、TCP／IP和AppleTalk。其他协议栈，如OSI和SNA，将在未来可以获得。

    当一个分组抵达一个网络接口卡时，它被卡的MLID进行处理，并送到LSL。LSL决定这个分组将到那个协议栈，并将它送到这个协议。这个分组以正常的方式向上通过协议栈，在那里它被较高级别的协议进行处理。

    相关条目：DOS Requester，NetWare NetWare DOS请求解释器；Internetwo rk Packet Exchange 网间分组交换；LAN Workplace Products，Novell NetWare LAN Workplace产品；Large Internet Packet Exchange大型网间分组交换；NetWare；Network Driver Standards网络驱动程序标准；NetWare。


  • Apple的OpenDoc联盟 OpenDoc Alliance，Apple

    OpenDoc联盟它最早是由Apple Computer公司发起的，它目前正在定义OpenDoc规范。OpenDoc规范将帮助开发人员在网络环境创立对象共享应用程序。OpenDOC将在1994年末或1995年初开始提供。对象是信息的分组，这些信息可以是由一个应用产生的并可插入其他应用的文本、电子表格、图象、声音和视频信息。它是为创立复合文档的一种规范（参见“复合文档”）。OpenDoc和Microsoft的对象链接和嵌入（OLE）的概念类似，但是它提供更多的网络支持和与OLE对象兼容。它得到了许多公司的支持，这些公司包括IBM、Novell、Borland、Word Perfect和其他不愿意完全依赖于Microsoft实现的公司。

    对复合文档进行引用的技术称为包容器（container），放置在包容器内的对象是成份（parts），成份编辑器（parteditors）是引用操纵这些成份的工具。成份可以存在于网络的任何地方，并且可以被连接到包容器内。这种技术是部分地基于IBM的系统对象模型（SOM）和分布式系统对象模型（DSOM）的。SOM在对象之间提供呼叫机制，DSOM提供了在一个网络之上分布对象的途径。

    OpenDoc的一个重要特征是它的认证规程（certification procedure），它保证了应用程序一起工作和在不同的平台上工作，这些平台包括Apple系统7、DOS、OS／2和Windows。至今为止，Microsoft还没有为它的OLE提供这样的过程。OpenDoc提供对如下系统的兼容性：Apple的QuickDraw、QiuckTime和开放协作环境（AOCE），并且它是围绕IBM／Apple／Lotus Bento对象互换体系结构建造的。它还提供和Microsoft的OLE对象的兼容性。

    相关条目：Compound Document复合文档；Distributed System Object Model分布式系统对象模型；Object Linking and Embedding对象链接和嵌入；Object－Oriented Technology面向对象技术；Objects 对象；System Object Model，IBM IBM系统对象模型。


  • 光纤 Optical Fiber

    参见Fiber－Optic Cable光缆。


  • 光盘库，光盘存储库 Optical Libraries

    光盘库系统的设计是为了将通常存储在微缩胶卷或纸张上的数据存储到可以被网络用户快速访问的联机设备上。一个光盘库也可以提供磁带后援系统，或在一个层次式管理系统（HMS）中作为将文件迁移到磁带上的中间存储设备。在一个HMS系统中，较少使用的文件，或已经标记为迁移的文件将从磁盘上移动到可以继续被用户使用的光盘上。在这种策略中，光盘有时被称为近线存储（near－line storage），如图O－12所示。最终，为了进行归档，它们将被移动到磁带上。虽然磁带提供了方便、可移动和经济的存储手段，但是由于它的串行访问方法，它不适于提取联机数据。

    光盘库适合作为高速的磁盘存储和低速的磁带存储的中间层次。他们提供了一种增长计算机数据保持为联机时间的方式。正常情况，不使用的文件将被送回磁带或磁盘，但是一个近线光盘设备可以存储上百兆字节的信息，并且能够很长时间地为用户保持这些文件是可用的。在一些分层存储系统中，当用户需要时，光盘上的文件被暂时移到磁盘上。这为编辑提供了快速的文件访问，并且如果一个远程用户要访问这个文件，还可以减少网络的通信量。除了当它们被从近线存储移到联机存储时会增加一点延迟之外，用户通常是不知道文件是来自光盘的。一个层次式管理系统，为了使近线文件可以被用户联机使用，保持一个目录的备份。

    联机光盘库提供了许多好处，并且使用户可以使用许多新类型的联网服务：

    光盘库在廉价的介质和适合小空间的方式提供了很大的数据存储能力。

    数据可以很长一段时间保持对用户是可用的。

    光盘设备使得可以使用迁移系统，其中，可以扫描纸张文档，并为以后使用而将扫描结果存储在光盘。

    通过使用迁移系统，本地用户或远程用户通过网络都可以很方便地访问文档。

    光盘库和迁移系统使得可以使用工作流应用，其中，文档可以从一个用户流动到其它用户，进行进一步编辑或征求意见。

    光盘库为多媒体信息提供了合适的存储，例如音频、图形和视频文件。

    一个象IBM 3995光盘库数据服务器型号153这样的光盘库，可以存储多达178兆字节的信息。型号153使用了IBM的新的双容量光盘驱动。由于具有178兆字节的可用存储，它可以作为联机存储：

    等价于460，800个微缩胶卷图象。

    超过550个四抽屉的文件柜中的文件架。

    超过160，000，000页计算机的打印输出和报告。

    如果一个月3兆字节，那么就是10年的月事务历史文件。

    为2，000个具有160MB硬盘的工作站的档案数据。

    IBM 3995系列是为了以太网和令牌环局域网（LAN）环境和OS／2LAN服务器、IBM PC LAN、网络文件系统（NFS）服务器进行工作而设计的。它们还可以在一个局域网中与NetWare文件服务器共同存在。还可以获得IBM AS／400计算机和MVS／ESA大型计算机环境的驱动程序。

    大多数光盘库设备使用工业标准51／4英寸光盘介质。自动换盘器或类似自动唱机的设备提供光盘栈和存储能力，并且在需要时提供跟踪光盘的内容和访问这些光盘的服务。例如，IBM型号153在一个单独的库中，可以包含多达144个光盘。它在每个自动换盘器中包含四个驱动器。型号153使用的光技术是磁光的，这是一种允许对数据进行存储和删除的可再写技术。光盘的删除部分可以被再次使用。

    在一个基于LAN的图象处理系统中，光盘库是很大系统中的一个典型部分，这个系统包括图形处理服务器、扫描器、打印机、传真系统和其它一些相关设备。这个图形处理系统应该在一个分离的局域网上，以将它的通信量和网络的其它部分隔离开来，这主要是因为图象文件在传输过程中可能会和网络连接很长一段时间。当然，需要图象文件的其它网络用户可以在需要的时候访问这个局域网。相应地，一个分离的局域网可以将光盘服务器连接到文件服务器上，于是请求图象文件的用户就可以在文件服务器上进行请求，并且文件服务器通过这个分离的局域网直接从光盘服务器上提取图象文件。这样可以使主服务器有时间处理正常的网络通信。

    Novell NetWare 4．x在局域网环境提供了第一个层次式管理系统。Novell与Kodak在开发可以进行图形图象处理和对数据进行归档方面密切合作。

    相关条目：Archiving 归档；Backupand Data Archiving 备份和数据归档；Hierarchical Storage Management Systems分层存储管理系统；High Capacity Storage System，Novell NetWare 大容量存储系统；Novell NetWare；Jubebox Optical Storage Devices自动换盘光盘存储设备。


  • 机构包容器对象 Organization Containers

    机构包容器对象是NetWare 4．x的NetWare目录服务（NDS）设施中的一个对象。它构成了层次式目录树中的一个分枝，它表示一个公司的部门或分支，并且包含其它一些对象，例如用户帐户对象、打印机对象、服务器对象，甚至可以包含其它包容器对象。

    相关条目：Directory Services，NetWare NetWare的目录服务。


  • OS／2操作系统 OS／2

    OS／2是IBM对台式计算机系统的客户机－服务器策略的奠基石。它在对等层环境既是一个客户机又是一个服务器。OS／2可以同时运行Windows3．1、DOS、和OS／2的应用软件。之所以能够达到这一目标，是因为它采用了操作系统的32位抢先多任务体系结构。

    OS／2的图形用户界面称为WorkPlace Shell。它使用面向对象的标记和拖放界面。用户可以对工具和文件夹进行个人化以简化对重要信息的访问。

    未来的OS／2微内核版本计划在Motorola PowerPC上运行。这个微内核将支持不同操作系统上的程序，如DOS、OS／2、Windows、UNIX和对等的OS／2，用户可以以对等层的形式进行通信，并且可以在运行这些操作系统的应用程序之间建立动态链路。

    相关条目：IBM；IBM LAN Server IBM LAN服务器；IBM Operation Systems IBM 操作系统；Mach，Carnegie－Mellon Microkernel，Carnegie－Mellon微内核Mach；微内核；Microsoft LAN Manager Microsoft LAN管理器；Object－Oriented Interface and Operating Systems面向对象接口和操作系统；Workplace OS Workplace操作系统。


 OSD 屏幕视控系统
：屏幕视控系统（On-Screen Display）。早期的屏幕要调整设定，必须使用屏幕下方的旋转钮，可调整的功能较少。但是随着技术的进步，厂商发展出一项新的OSD功能，可在屏幕上显示屏幕的相关设定，操作的功能也比较多。


  • 开放软件基金会 OSF／1操作系统 OSF／1，Open Software Foundation

    OSF／1是一种UNIX操作系统，它在维持和当前的操作系统实现标准兼容的情况下，还提供了一些创造性的功能。它提供内核支持对称多处理、增强的安全性和动态系统配置。

    开放软件基金会采纳了许多不同单位提出的技术，这些包括Carnegie Mellon大学、Encore Computer公司、IBM、Meta、SecreWare和美国加州大学。生产的产品是一个开放式系统平台，它具有如下特征：

    基于Mach的操作系统内核，它是模块化的、可扩展的，可以通过模块升级来降低系统维护。

    对称多处理可以在具有多处理器的系统上处理并行任务。

    磁盘镜像和逻辑卷宗管理，所以文件可以跨越多个物理存储设备，从而消除了对文件大小的限制。

    增强的安全性特征，控制对系统和其文件的访问，并且可以跟踪和安全性相关的事件。OSF／1实现了C2或B1级别（这是由美国国家计算机安全性中心信任计算机安全性评价标准）。

    国际化，通过增加扩展UNIX代码（EUC）允许命令、实用程序和应用程序，可以在不同的代码集上运行。

    通过虚拟文件系统（VFS），可以使用多种文件类型。这个接口使得可以透明地使用多种类型的文件系统。OSF／1应用可以通过VFS接口而到达UNIX文件系统（UFS）、系统V文件系统或网络文件系统（NFS）的分布式文件系统。

    OSF／1具有联网功能，它提供了和现有应用程序的兼容性，以及利用多处理器系统性能的能力。使用了一些广泛使用的网络协议和框架，包括传输控制协议／因特网协议（TCP／IP）。

    OSF／1操作系统的将来发展趋势是，由于它的模块化设计而被简化。长期的OSF／1体系结构策略是，将许多操作系统内核服务从内核中移出来加入到用户空间，从而提高系统的可维护性、可扩展性和灵活性。将来的发展方向会受到OSF成员和OSF协会的影响。

    OSF／1是基于Carnegie Mellon大学的Mach微内核的。UNIX系统实验室计划开发的竞争产品使用Chorus Systems公司的微内核。

    相关条目：Distributed File Systems分布式文件系统；Mach，Carnegie－Mellon Microkernel Carnegie－Mellon微内核Mach；Microkernel微内核；Mirroring镜像；Multiprocessing多处理；Open Software Foundation开放软件基金会；Security安全性；UNIX。


 Packet level filtering　包级过滤
：在路由器上最流行的一种防火墙技术。包级过滤能监视每个TCP/IP包，审查地址和端口号，并确保获通信特许以及为其进行路径选择。


 Packetsniffer　包嗅探器
：一种帮助维护、故障检测和微调局域网和广域网的软件工具。这种工具观察网络段的通信量，学习掌握网络配置，对协议进行译码，提交统计数字，自动识别许多网络常见问题，并能够生成管理报告。


 PAP 密码验证协议
：密码验证协议，Password Authentication Protocol 的首字母缩略词。它是一种用于对试图登录到点对点协议服务器上的用户进行身份验证的方法。


 Path 路径、通路
：（1）在发送者和接收者之间E-mail消息所经过的路线；（2）信号通过的信道；（3）对一个目录或文件完全指定的从根目录开始的位置。


  • PCI 周边元件扩展接口

    周边元件扩展接口(Peripheral Component Interconnection)，PCI局部总线是高性能的32位或64位总线，它是专为高度集成的外围部件、扩充插板和处理器/存储器系统而设计的互联机制。PCI一经推出就成为目前高性能微机普遍支持的总线。目前PC机上的PCI是32位的，它的数据传输率最高可达132Mbytes/s，而其未来版本使用64位总线传输时，将达到264Mbytes/s的传输率。


  • PCL 打印机指令语言

    Printer Command Language(PCL)，打印机指令语言 (PCL)是由 HP 公司开发的用于其自己的打印机系列的一种语言。 PCL 实质上是一种面向文本的语言，已扩展到能提供图形功能。


  • PDS 个人数字系统

    Personal Digital System，个人数字系统，由IBM推出的、具有PCMCIA内存和智能卡插槽以及一台蜂窝式电话的个人数字助理。智能卡使 PDS 的功能扩展到可发送传真、听收音机甚至拍照。


  • PHP 服务器端编程语言

    Professional Hypertext Preprocessor。他是一种服务器端的动态脚本编程语言。他支持几乎所有的操作系统（Linux、Unix、Windows 95/98/NT、Macintosh）和web服务器（Apache、Netscape servers、WebSite Pro、Microsoft Internet Information Server），另外它还支持大部分的数据库，例如：Oracle, Sybase, Solid, MySQ, mSQL, 和 PostgreSQL。PHP和ASP一样是嵌入在HTML代码中的语言，他们的功能也大致相似，都可以读取数据库中的信息并生成动态的页面。


 PHP4　嵌入式脚本描述语言
：PHP4是一种服务器端HTML-嵌入式脚本描述语言。它最强大和最重要的特征是萍乡的数据库集成层，使用它完成一个含有数据库功能能的网页是不可置信的简单，并且支持绝大多数的数据库。


 PIN　个人识别号
：PIN(Personal Identification Number)是指一种常用四位数表示的口令，基本上就等同于密码的作用。


 PKI 公开密钥基础设施
：PKI(Public Key Infrastructure）是近几年涌现的一种新的安全技术，它是由公开密钥密码技术、数字证书、证书发行机构（Certificate Authority，CA）和关于公开密钥的安全策略等基本成分共同组成的。MS Windows NT 4.0及其后续者Windows 2000，提供了Windows环境下的PKI。特别是Win2000 的PKI，可以使企业网络管理员为企业网络建立完善的、适合企业应用需求的PKI。


  • Plasma Display 等离子显示器 Plasma Display

    Plasma Display 等离子显示器

    等离子显示器是一种视频显示器。等离子显示器屏幕上的每一个像素都由少量的等离子或者充电气体照亮，有点像微弱的霓虹灯光。等离子显示器的体积比较阴极射线管（CRT）显示器小，色彩要比液晶显示器鲜艳，明亮。等离子显示器有时也被称为平板显示器，即可以用来显示模拟视频信号，也可以用来显示VGA数字信号。

    除了具有“体格苗条”这一优势之外，等离子显示器的屏幕要比阴极射线管显示器更平展，因此，显示的图像不会出现扭曲变形的情况。而和许多液晶显示器不同，等离子显示器提供了很大的观察视角。等离子显示器的显示尺寸即可和传统电脑显示器的大小一样，也可以达到60英寸，用于家庭影院和高清晰度电视。


  • PnP 即插即用

    即插即用(Plug and Play)是在计算机内插入一个装置并使计算机确认此装置的存在，而用户不必通知计算机。


  • POP3 高级网络协议

    POP3是一种高级网络协议，全称为Post Office Protocol Version 3。使用该协议，用户使用客户端软件能够动态地、有效地访问服务器上的邮件。简单言之POP3是一种能够让客户端软件提取驻留于服务器的邮件的协议。


  • 规整化布线系统 Premises Distribution System

    规整化布线系统（PDS）是一种为在建筑物或校园环境内提前计划好的网络进行布缆的系统，它的设计是为了传输音频和数据。PDS为外部通信提供了一个连接点，并且提供了到公共电话网络的链路。PDS是一种典型的结构化布线系统，它的设计力求保证实现将来的服务和增长的需求，并可以适应将来的移动和重新配置。电子工业协会（EIA）和电报电信工业协会（TIA）开发了一种布线标准，称为EIA／TIA 568商用建筑布线标准。这个标准提供了一种统一的布线标准，并支持多厂商产品和环境。

    描述的范围包括电讯布线的水平布线（电话和计算机穿线过墙到一个建筑物中的布线设备房间）和主干布线（设备房间到设备或校园环境中建筑物之间）。根据EIA／TIA 568文档，布线标准是为提供下述特征和功能而设计的：

    对商用建筑的一般性远程通信布线系统。

    支持多产品、多厂商环境。

    指明商业企业远程通信产品的未来设计方向。

    有能力为一个商业建筑规划和安装远程通信布线，而不需要任何将用于布线产品的先验知识。

    这个描述构划出了布线的拓扑结构和距离。最大距离是3，000米，覆盖的办公空间为一百万平方米（大约为一千万平方英尺），和多达50，000个独立用户。

    相关条目：Cabling 布缆；EIA／TIA 568 Commercial Building Wiring Standard EIA／TIA 568商用建筑布线标准。

    p

    P

    OSI模型的表示层

    Presentation Layer，OSI Model

    开放式系统互联（OSI）模型是国际标准化组织（ISO）定义的一种标准。它定义了一种分层体系结构，对在系统间建立通信会话所需的协议进行分类。每个机器的协议栈中的某层，通过在系统间传输分组中放置信息，来与它的对等层进行通信。这些消息提供控制、出错检查、回执和请求。这些消息仅仅和其对等的层有关。

    OSI协议模型包括七层。总的来说，最底部的层是关于系统间实际位传输的。中间的层是关于系统间的传输和信息的可靠传递的。顶层提供应用程序访问较低层的接口。当一个在后端服务器上运行的应用程序（例如一个用户数据库程序）需要给在另外一台计算机（例如数据库管理系统，或DBMS）上运行的应用程序发送一个消息时，它首先准备一个消息，并将它发送到较低的协议层。每个层在这个消息上增加自己的信息，完成的分组被传送到另一个站。这个过程在接收站重复（除非这个消息没有打包）并上传到应用程序。

    OSI模型的设计是为了帮助开发人员开发与多厂商产品环境兼容的应用程序，并且提倡开放、互操作的联网系统。虽然OSI还没有完全实现它的计划，但是这一模型还是被用于描述和定义不同厂商的产品如何进行通信。通用的协议栈包括IBM系统网络体系结构（SNA）DEC网络体系结构（DNA）和Apple Computer的Apple Talk。可以和协议栈的层匹配的通信协议（但这不一定是任何特定结构规划的组成部分）是TCP／IP（In－ternet／UNIX）、Microsoft NetBIOS／NetBEUI和Novell SPX／IPX．

    表示层在协议栈的第六层，在应用层之下和会话层之上。表示层提供了数据翻译、定义数据格式和提供语义。表示层为应用层准备数据，应用层用户可以查看这个数据。对于送出的数据，表示层将来自应用层的数据翻译成适合网络输送的方式。在表示层中装有许多编码规则，以处理所有的数据翻译。

    相关条目：Layered Architecture分层体系结构；Open Systems Interconnection Model 开放式系统互联模型；Protocol Stack协议栈。

    p

    P

    AppleTalk的打印机访问协议

    Printer Access Protocol（PAP），Apple Talk

    PAP

    AppleTalk的打印机访问协议（PAP）打印机访问协议（PAP）是一种在AppleTalk环境的协议，它负责维护一个工作站和一台打印机，或者一个工作站和一个打印服务器之间的通信会话。这个连接是双向的，这是因为打印机需要向工作站发送控制信息，以管理数据的传输。例如，这个打印机的缓冲器可能变满，必须告诉工作站停止发送数据。

    相关条目：AppleTalk。


  • 打印服务器 Print Server

    它是网络上管理打印工作的计算机。打印服务器接受来自多个不同用户的打印工作，并且按序或按预先定义好的优先级对它们进行打印。打印队列在内存或磁盘上保存打印工作，直到它们准备打印为止。打印队列也可能管理和工作站相连网络上的打印机，为满足用户的请求，将打印工作送到这些打印机，例如，一个工作站可能有一台相连的彩色打印机。打印服务器知道哪些打印机具有这些特征，并且将工作发送到合适的工作站和相连的打印机。

    相关条目：Networks 网络。


  • NetWare网上打印（服务） Printingon NetWare Networks

    许多NetWare可装入模块、菜单驱动实用程序和命令行NetWare打印服务。在NetWare 4．x打印环境，虽然基本的打印选择项和以前的NetWare版本中的情况相同，但是NetWare目录服务（NDS）和基于Windows的实用程序却提供了新的打印管理方式。

    如图P－15所示，NetWare打印服务使用文件服务器上运行的中央服务器，作为打印服务器管理网络上的共享打印机。共享打印机包括连接到打印服务器上的打印机、连接到其它文件服务器的打印机、连接到网络工作站的打印机。

    基本上，打印服务器利用了网络上所有打印机端口的优势，而无论这些端口是在打印服务器上、文件服务器上还是工作站上。还可以支持直接网络连接（例如它们自己的以太网端口）的打印机。打印系统包括以下部件：

    打印队列 打印队列是保存网络用户打印工作组的缓冲器，它保存这些打印工作直到它们被打印为止。打印队列存在于网络目录。当一个用户将一个打印工作送到一台打印机时，NetWare就将这个工作发送到与这台打印机相应的一个队列中。NetWare 4．x的NetWare目录服务允许用户在他们可以查看的目录范围内查找打印机。

    打印机 每个网络共享打印机必须进行配置，并且被赋予一个名字。打印机可以直接连接到打印服务器，或连接到这个网络上的独立工作站。一台打印机服务器管理打印工作流，通过打印对列送到打印机。许多队列可能将它们的打印工作送到一台打印机上，或者多台打印机为一个打印队列服务。首先，你为每台你希望在网络上共享的打印机创立一个打印机对象，然后你把它赋给一个打印服务器，并把一个队列赋给它。

    打印服务器 PSERVER．NLM模块，把队列和打印机连接到打印服务器。它就象一些连续进程那样在这个服务器上运行。如果卸载，打印机共享停止。一个单独的打印服务器可以处理多达256个网络打印机，包括五个本地打印机（三个并行，两个串行）。Novell建议为了易于管理，应该每个打印机一个打印队列。每个打印队列可以同时包含多达1，000个打印工作，然而，队列管理器只能看见前面的255个打印工作。

    相关条目：NetWare；NetWare 4．x Enhanced Features NetWare 4．x增强特征。


  • 增强安全的私人函件 Privacy Enhanced Mail

    Internet的电子函件力求达到如下发送者和接收者之间关系目标：

    在无连接模式下的信任度。

    消息争端的鉴别。

    消息的完整性，以向接收者保证消息没有被改变或损坏。

    不可否认，或发送者一旦发送了消息就不能取消这个消息了。

    增强安全的私人函件（PEM）协议提供这些服务。PEM的验证系统采用公开密钥鉴别机制。发送者利用其专用密钥对消息加上数字签名。这个数字签名还提供不可否认的特征。发送者可以使用接收者的公开密钥对整个消息进行加密以使这个消息具有信任度。然后，只有指定的接收者才能阅读这个消息。PEM的未来版本也将支持多功能Internet函件扩展标准（MIME）。

    相关条目：Authentication and Authorization 鉴别和授权；Certification Systems验证系统；Key Encryption 密钥加密；Multipurpose Internet Mail Extension多功能Internet邮件扩展标准；Security 安全性。


  • 私用密钥密码学 Private Key Cryptography

    参见Key Encryption Technology 密钥加密技术。


  • 私用网，专用网 Private Network

    参见Leased Line 租用线路；Public Data Networks 公用数据网；T1／T3Services T1／T3服务；Wide Area Networks 广域网。


  • 企业（工程）DOE（全分布式对象） Project DOE（Distributed Objects Everywhere）

    Project DOE（Distributed Objects Everywhere） 企业（工程）DOE（全分布式对象） 参见Distributed Objects Everywhere，SunSoft SunSoft的全分布式对象。


  • 传播延迟 Propagation Delay

    将信息从一个地点传送到另一个地点的时间延迟。在卫星传送的情况下，在音频和视频传送中，这种延迟通常是很值得注意的。


  • 对象的性质，对象的特性 Properties of Objects

    在目录命名系统，如Novell NetWare目录服务，对象表示现实的实体。目录服务是在网络上运行的跟踪网络上的用户和资源的程序。当一个用户希望访问网络资源（如一台打印机）或向另外一个用户发送电子函件消息时，他将和目录服务进行协商。一个目录服务可以比喻成一本电话簿。

    在目录服务中的对象包含一些描述这个对象的属性。最重要的一个属性就是对象的名字。对象的这些属性是在这个对象被创建时，或者是在这之后的一次改变中被定义的。用户帐户对象的典型属性如下：

    用户的名字、电话号和传真号。

    帐户信息，例如平衡数量。

    登录限制，例如允许时间、允许的工作站所需的口令。

    用户的身份号。

    下面列出资源对象（例如一个服务器）的属性。虽然操作系统可能会使用这些信息，但是其中的一些行为是出于文档管理和查询目的的。

    服务器的描述，它只用于引用访问。

    服务器的位置，它只用于引用访问。

    服务器的网络地址。

    可以修改这个服务器对象性质的用户名单。

    服务器操作员的名单。

    关于这个服务器操作的身份信息。

    相关条目：Directory Services 目录服务；NetWare。


  • （受）保护模式 Protected Mode

    一种允许多个程序在其被保护区域内同时运行的处理模式。程序请求内存分配，并且这种分配将防止被其它程序侵占。


  • 数据的保护 Protected of Data

    参见Data Protection 数据保护


  • 协议分析器（程序） Protocol Analyzers

    协议分析器是一种用于监督和跟踪网络活动的诊断工具。它们可以是计算机上运行的软件，也可以是包含特殊线路板和软件的特殊单元设备。协议分析器通常是可以被网络技术人员携带到不同地点的便携式设备。下面列出它们可以处理的一些任务：

    显示网络上传输信息分组的类型信息。你可以监督这些分组以监督安全性，确定失效情况，或监督和优化一个网络。

    在一个互联网络上查询所有结点，或在任何一个特定结点与所有其它结点之间进行点对点通信检测。

    确定整个互联网络的配置。

    从一个或所有结点分析关键数据，或根据预先定义的一组阈值报告不正常的活动。

    显示性能数据，例如通信量和被服务的分组。

    提供关于网络有效性、网络性能、可能的硬件错误、噪音问题和应用软件问题的一些有用信息。

    许多厂商都提供协议分析器，包括Gateway Communications（EtherStat），电话800／367—6555；Triticom（LANdecoder），电话612／937—0772；Inter（Net Sight Analyst）电话800／538—3373。

    相关条目：Testing Equipment and Techniques测试设备和技术。


  • 协议转换器 Protocol Converters

    协议转换是一个通信系统为向另一系统进行传输而进行的电子信号或数据格式的转化过程。可能需要不同级别的转换。例如，在一台台式计算机和一个IBM大型计算机系统间，需要使用一个协议转换器，来将美国信息交换标准代码（ASCII）中的字符转换成扩展二进制编码十进制互换代码（EBCDIC）的格式。有可以将异步数据流转换为同步数据流的转换器，因而为与数字转换服务连接，PC串口数据可以被送到数据服务单元（DSU）。

    在网络环境，一个协议转换器可以将一个网络的分组，例如传输控制协议／因特网协议（TCP／IP），进行翻译以便在另外一个网络上使用，例如网间分组交换（IPX）。这个协议转换器就象是一个网关设备，而不象一个路由器，这是因为除了协议栈的最高层应用层外，所有的层在进行分组转换的过程中都被牵连进去了。

    封装（encapsulation）是一种在中间网络上发送一个协议类型的分组到另外一个具有相同类型网络的技术。这个原始分组跟在一个中间网络分组的后面，在网络上传输到目的网络，因而不需要任何转换。例如，一个TCP／IP网络（如Internet）可能和两个NetWare IPX网络互联。来自源网络的IPX分组将被放在TCP／IP分组内在Internet上进行传输，然后在目的网络被拆包，并分发到网络上的正确结点。

    相关条目：Encapsulation 封装；Gateway 网关；Packets分组；Protocol Stack 协议栈。


  • 协议数据单元 Protocol Data Unit

    在分层网络结构，例如开放式系统互联（OSI）模型中，在传输系统的每一层都将建立协议数据单元（PDU）。PDU包含来自上层的信息，以及当前层的实体附加的信息。然后，这个PDU被传送到下一较低的层。物理层实际以一种编帧的位流形式传输这些PDU，但是由协议栈的较高层建造这些PDU。接收系统自下而上传送这些分组通过协议栈，并在协议栈的每一层分离出PDU中的相关信息。重要的一点是，每一层附加到PDU上的信息，是指定给另一个系统的同等层的。这就是对等层如何进行一次通信会话协调的。

    相关条目：Layered Architecture分层体系结构Open Systems Interconnection Model 开放式系统互联模型；Packets 分组，Protocol Stack 协议栈。


  • 协议栈 Protocol Stack

    如果不参考下面进行数据交换的协议或通信过程的讨论，那么就不可能讨论计算机的互联。对协议的任何讨论通常都会牵涉到与开放式系统互联（OSI）协议栈的比较。OSI协议栈定义了厂商们如何才能生产可以与其它厂商的产品一起工作的产品。然而，由于缺乏工业界的承认，今天，OSI更象是一个模型，而不是一个被接受的标准。这是因为许多公司已经在他们的产品中实现了另外一些协议。

    协议定义与其它系统通信的方式。它描述信号的时序和通信数据的结构。在协议栈的较低层定义了厂商们可以遵循规则以使他们的设备可以与其它厂商的设备进行互联。较高层定义如何管理不同类型的通信会话，用户应用程序如何才能相互操作。你在协议栈中走得越高，协议也越复杂。

    让我们利用OSI标准来比较厂商的操作系统及产品间网络互联和互操作性。在这个OSI模型中，在协议栈中有七层，每个都在不同的硬件和软件级别进行工作。你可以检查协议栈的每一层来观察系统是怎样在局域网（LAN）上进行通信的。互联或协议栈的OSI模型如图P－17所示。

    如以前所述，许多厂商并不完全跟随OSI协议栈。他们使用很接近OSI协议栈的其它协议栈，或者将一些独立的协议组合成一个协议组。图P－18对一些最流行的协议栈进行了比较。使用一种协议栈的产品不能与使用另外一种协议栈的产品直接相连或相互操作。然而，使用不同的“封装”技术和协议转换，是可能在它们之间做到一些级别的互操作性的。下面列出了一些主要的协议栈：

    OSI协议栈 OSI协议栈是由国际标准化组织（ISO）

    为提倡世界范围的互操作性而定义的。它通常被用与其它协议栈进行比较的标准。

    NetWare SPX／IPX协议 NetWare串行分组交换／网间分组交换（SPX／IPX）协议，是由NovellNetWare使用的一种本质性协议（nativeprotocol）。它源于Xerox网络系统（XNS）协议栈。

    TCP／IP协议组 传输控制协议／因特网协议（TCP／IP）是最早的网络协议栈之一。它最初是由美国国防部为将多厂商网络产品连接在一起而实现的。其中IP部分提供了一种对互联网络连接的最好定义，并且被许多厂商用于在局域或广域互联产品。

    AppleTalk协议 AppleTalk协议是由Apple Computer为互联Apple Macintosh系统而定义的。

    IBM／Microsoft协议组IBM和Microsoft进行互联的产品通常是结合在一起的，这是因为这两个公司联合起来开发使用他们的产品，例如，L管理器和OS／2。

    相关条目：Layered Architecture 分层体系结构；Open Systems Interconnection Model 开放式系统互联模型；Packets分组。


  • 通信协议 Protocols，Communication

    通信协议是在分层网络体系结构的现场（context）中进行定义的。每一层指定通信过程中处理一种功能或一个子系统的协议。下面列出一些通用的工业界网络协议栈，它们在本书的其它地方也有介绍。

    ISO的开放式系统互联（OSI）模型。

    IBM的系统网络体系结构。

    DEC的DECnet。

    Apple的AppleTalk。

    Internet组，包括TCP／IP。

    协议存在于每一层，以执行系统之间完成通信的任务，但要求两个操作系统具有类似的协议。虽然协议栈通常有七层，但是为了方便，将这些层组织成如下分类，如图P－16所示。

    应用协议 应用协议包含了应用、表示和会话层协议，这三种协议基本上是网络通信服务的用户，并且应用协议提供了应用程序对应用程序的相互协作和数据交换。通用的应用协议包括下面列出的一些协议，以及远程过程调用（RPC）、事务处理系统和消息传递系统。

    IBM应用和高级程序对程序通信（APPC），通常称为LU 6．2。

    OSI虚拟终端，文件传送访问和管理（FTAM），分布式事务处理（DTP），信报处理系统（X．400），目录服务（X．500）。

    Internet和UNIX网络文件系统、简单邮件运送协议（SMTP）、文件运输协议（FTP）、TelNet和简单网络管理协议（SNMP）。

    Novell NetWare网络核心协议（NCP）和客户外壳或重定向。

    Microsoft服务器消息块、NetBIOS和客户外壳或重定向。

    AppleTalk AppleShare、AppleTalk文件编整协议（AFP）和会话级协议，例如AppleTalk数据流协议（ADSP）、AppleTalk会话协议（ASP）、打印机访问协议（PAP）和邮政区域信息协议（ZIP）。运输协议 运输协议在网络上提供面向连接的数据分发服务。基本上，运输协议提供端点对端点数据交换，其中，系统为了进行可靠的连续数据交换，要维护一个会话及与其它系统的连接。运输协议包括下面列出的一些协议：

    IBM高级对等层网络互联（APPN）。

    OSI面向连接传输服务（COTS）和无连接传输服务（CLTS）。

    Internet中的传输控制协议（TCP）部分和UNIX TCP／IP协议组。

    Novell的SPX／IPX协议组中的SPX部分。

    Microsoft NetBIOS和NetBEUI接口。

    AppleTalk路由选择表维护协议（RTMP）、AppleTalk回音协议（AEP）、AppleTalk事务协议（ATP）、名称联编协议（NBP）。

    网络协议 网络层协议为通信系统提供链路服务。它们处理寻址和路由选择信息、出错检查和重发请求。它们还提供用于访问网络的一些调用过程，这些过程是在使用的特定网络（例如以太网，令牌网，等等）中指定的。网络协议包括：

    IBM高级对等层网络互联（APPN）。

    OSI面向连接网络服务（CONS）和无连接网络服务（CLNS）。

    Internet中的因特网协议（IP）和UNIXTCP／IP协议组。

    Novell的SPX／IPX协议组中的IPX部分。

    Microsoft NetBEUI接口。

    AppleTalk数据报分发协议（DDP）。

    通信系统并不需要运行特定协议组中所有层的上述协议；然而，实现了全部协议组的系统可以在应用层进行所有方式的通信。

    在这种分层体系结构模型中，计算机协议栈的每一层都建立一个协议数据单元（PDU），它向希望进行通信的那台计算机的同等层发送信息。物理层实际上以编帧数据位的方式将PDU传输给另一个系统，但是较高的协议层创建PDU，然后将它们发送到较低层以进行进一步打包直到它们抵达物理层。接收系统自下而上在它自己的协议栈中传送这个分组，并在协议栈的每一层提取PDU。提取的PDU信息包含来自同等协议层的信息。

    下面列出了协议层对话中包含的消息和活动：

    产生请求和发送数据。

    接收请求和信息。

    拒绝请求或数据。

    应答接收。

    处理新来数据的缓冲。

    暂停和重启传输。

    设置传输优先级。

    处理出错检查、纠正和重发。

    维护面向连接的会话。

    分组编号和序列化。

    处理寻址和路由选择。

    协议层的实体交换控制信息以完成上面列出的任务。一旦建立了一次会话，就进行数据交换。在数据交换期间，每个系统偶尔发送描述系统状态的控制信息送到另外的系统。如果使用了流控，那么流控防止在接收系统的缓冲器中出现数据溢出。在一个网络互联环境，数据被协议层以分组的形式进行传输，然后在物理层上以编帧位流的形式进行传输。将信息按照这种方式进行划分有两个重要原因：第一个原因是，网络上的任何出错仅仅影响单独的一些分组，它们是很容易进行重发的；第二个原因是，一个长时间的传送占据中继器和交换，从而延迟了其它的传送任务，分组细分了这个传送，并且允许其它通信量也可以通过。信元（cel1）是一个固定体积的信息帧，从上面的情况来看，它可以提供最好的性能，这是因为交换是稳定的和可预测的。

    一个无连接传输在将分组从源地发送到目的地时，不需要首先在网络上建立一条特定的路径。如果有多条到达目的地的路径，分组可能选择不同的路由，并以乱序的方式抵达目的地。必须在这些分组上加上序列号，于是当在网络上有一些延迟的情况下，接收站点可以将它们再排列成以前的顺序。这些序列号还可以指明丢失的分组，于是接收站点就可以请求重发。

    相关条目：Acknowledgements确认，应答；Advanced Peer－to－Peer Networking 高级对等联网；Advanced Program－to－Program Communication高级程序对程序通信；AppleTalk；Connection－Oriernted and Connectionless Protocols面向连接和无连接协议；Flow Control Methods流控方式；Internet；Internetwork Packet Exchange网间分组交换；Layered Architecture分层体系结构；NetBIOS／NetBEUI；Open Systems Interconnection开放式系统互联；Packets分组；Protocol Stack协议栈；Routing Protocols路由选择协议；Transmission Control Protocol／Internet Protocol 传输控制协议／因特协议（TCP／IP）。


  • 物理单元（PU）2．1 PU2．1

    参见Systems Network Architecture，IBM IBM的系统网络体系结构。


  • 公用数据网（PDN） Public Data NetWorks（PDNs）

    一个机构在公共区域建造跨越很广区域的网络时，它可以有三种选择：建造自己的专用网；使用现存的公共网络；或使用以上两者结合的网络。建立专用网是有点被误导的，它通常是指一个利用公共设施建立的网络，除非顾客提供所有的交换转换设备，并在不同的地点之间建立了租用线路。专用则更精确这一事实：这个机构可以全面利用这些线路，并且不与其它任何人共享这些线路。建立专用网的另外一条途径是使用微波安装或使用除了LEC之外的其它公司提供的城域网设施。许多公司为广域网使用公用数据网提供的服务，但却为连接局部设施建立专用网设施，例如在一个校园环境内建筑物之间布缆是比较容易的。

    公用数据网（PDN）是由局域或长途电信局提供的一种分组交换或电路交换服务，这些电信局包括MCI、US Sprint和AT＆T，另外上述服务也可以由另外一些机构提供，这些机构首先为自己使用而建造了网络，然后又使得其它用户也可以使用这些网络。提供的分组交换服务通常包括X．25、帧中继、交换式多兆位数据服务（SMDS）或异步传送模式。电路交换服务包括拨号线、交换56线路和综合业务数字网络（ISDN）。

    分组交换和电路交换服务的提供商包括：

    US Sprint在它的全数字光纤网络上提供电路交换服务、X．25、帧中继、Internet协议（IP）、视频服务和ATM。

    AT＆T提供一系列电路交换和分组交换服务。它的ACCUNET电路交换服务，例如交换56，多年来一直得到使用。AT＆T还提供帧中继、分组交换服务和ATM。

    CompuServe信息服务在遍布美国的上百个地点提供对X．25和帧中继服务的访问点。

    GE信息服务提供分组交换和高速服务、瞬间异步和同步服务。

    Infonet服务公司提供国际服务的阵列。

    Tymenet全球网络公司有接近5，000个全球访问点。

    这些服务可以在租用线路（按月交费）或拨号线上获得。一个典型的PDN网络在PDN的交换设备之间形成了一种全球性连接。使用电路包括PDN自己的专用线路或从主要电信公司，如AT＆T租用来的线路。

    如图P－19所示，对服务的访问是由在本地访问传输区域（LATA）内的本地电信局（LEC）提供的。在顾客地点和LEC交换设施之间通常需要安装一条线路。这条线路可以是一条拨号线路，也可以是一条专用数字线路。PDN服务提供商在称为访问点（POP）的位置连进本地电信局。POP是他们访问顾客线路的地方。LEC必须根据政府的指定提供POP设施。

    使用PDN可以减少成本，并减少为建造专用网所需的租用昂贵的长途专用数字线路的需求。PDN自己处理交换服务和网络的任何问题。它还可以以较低的价格保证较好的数据分发。

    相关条目：Carrier Services 电信服务；Circuit－Switching Services 电路交换服务，Packet Switching Networks 分组交换网络。


  • 公开密钥加密系统 Public Key Cryptographic Systems

    参见Key Encryption Technology 密钥加密技术。


  • 公共交换数据网 Public Switched Data NetWork

    参见Public Data Networks公用数据网。


 Pull-down Menu 下拉菜单
：下拉菜单，一种屏幕上的命令选项菜单，当用户在菜单条选择命令名后便出现菜单。下拉一词来自 Macintosh 对这种方法的实现，即如果不将屏幕上鼠标指针拖出菜单按下并按住鼠标键，菜单就不会停留在屏幕上。然而在 MS-DOS 和微软的 Windows 程序中，在击菜单名后，菜单便停留在屏幕上。


 Pull-down menu　下拉菜单
：一种屏幕上的命令选项菜单，当用户在菜单条选择命令名后便出现菜单。下拉一词来自 Macintosh 对这种方法的实现，即如果不将屏幕上鼠标指针拖出菜单按下并按住鼠标键，菜单就不会停留在屏幕上。


  • 脉码调制，脉冲代码调制 Pulse－Code Modulation

    脉码调制（PCM）是一种模／数转换技术。它被用于在数字设施上对音频信号进行转换。它与综合业务数字网络（ISDN）一起使用。ISDN将许多家庭和办公室的模拟线路替换为全数字线路。于是，一部电话的连接将需要PCM技术，以在数字线路上携带音频信号进行传输。PCM还用于将音频模拟数据转换成数字数据，以便在T1或其它数字电路上的音频和数据流的多路复用器上传输。

    数字音频信道需要64Kbps的传输率（和模拟线路相比，需要4kHz的带宽）。调制过程包括以特定数目的bps速度对音频信号进行采样，以确定它的振幅。然后，采样信号转换成表示这个信号强度的二进制数据。

    相关条目：Integrated Services Digital Network综合业务数字网；Multiplexing 多路复用；T1／T3 Services T1／T3服务。


  • 穿孔板，分线盒 Punchdown Block

    如图P－20所示，分线盒为音频和数据系统提供连接点和穿越连接。来自工作站的电缆穿过墙壁连到分线盒。这个分线盒采集所有与它相连的工作站的信号，并且通过50针Telco电缆将它们连接到接插板（patchpanel）。然后，接插板分发连接到集线器（hub），集线器作为网络上站点之间的中继设备和连接点。这个接插板也提供了一条易于移动连接的途径。


 Push Technology　推技术
：在客户机/服务器的应用程序中，推技术能够向客户机传送数据而无需其发出请求，例如发送电子邮件。相比较而言，万维网却是基于拉技术（Pull Technology），因此客户机浏览器必须事先向网页发出请求，所需信息才能被传送过来。传播媒介都属于推技术的应用范畴，因为不管是否有人接收，他们的信息都照发不误。


 PVM　并行虚拟机
：PVM(Parallel Virtual Machine)并行虚拟机是一个软件包，使用这个软件包可以让不同构的UNIX计算机由网络联结成一个大型并行计算机，使得大型计算在花费较少的情况下得以实现。


  • 正交振幅调制，正交调幅 Quadrature Amplitude Modulation

    参见Modulation Techniques调制技术。


 |龙哥救急呀，我的Win2k（professional）中了“红色代码III”病毒，该如何手动清除？
：该立即关闭所有 80 端口的 web 服务，避免病毒继续传播。清除web服务器中的两个后门文件：C:\\inetpub\\scripts\\root.exe 以及C:\\progra~1\\common~1\\system\\MSADC\\root.exe ，然后清除本地硬盘中：c:\\explorer.exe 和 d:\\explorer.exe，再清除病毒在注册表中添加的项目；最后重新启动系统，以确保CodeRed.v3 彻底清除。如果要确保清除病毒后不再次被感染，请安装微软发布的补丁。


  • 无线电网络 Radio Networks

    无线电通讯为无线联网和移动计算提供支持。无线网中不需要用线缆互连工作站，代替线缆的是安装在电信局的中心发送器／接收器（或叫收发器），通过它把信号广播给各工作站。

    Radio Networks 无线电网络

    无线局域网设备是一个收发器，它通过以太网电缆连向服务器或其它网段。有两种无线电技术用于构成无线网：

    窄带无线电通信（Narrow－Band Radio） 这种技术类似于无线电台的广播，必须把发送器和接收器都调拨到同一频带。无线电信号可以穿越墙物，在一个很广的域内传播，所以不必把它调聚成束。然而，窄带射频发送有无线电波反射的问题，并受联邦通信委员会管制，它们必须准确地进行调谐，以防其它频率的干扰。

    扩频无线电通信（Spread Spectrum Radio） 这种技术是在一个很宽的频率范围内广播信号，避免在窄带无线电通信中遇到的问题。用一种编码来传播信号，接收站用同一编码来恢复信号。用这种方法，扩频无线电信号能工作在其它信号所占据的频率范围内。扩频无线电信号不会干涉常规的无线电广播，这是因为它的能量十分微弱。

    Mobile Radio Networks 移动无线电网

    有两种相互竞争的移动式无线电技术。第一种基于分组无线电技术和上联卫星的链路，第二种是使用现有的蜂窝式电话系统。移动无线电网正逐步成熟起来。服务公司为流行的通信服务和网络提供信关，如AT＆ T Mail、MCI Mail、CompuServe和因特网。像Microsoft（微软）这样的操作系统和软件供应商正在为移动用户专门设计软件包。

    分组无线电通信（Packet－Radio Communication）分组无线电通信把（PRC）发送的信息分成若干数字分组，每一个分组都包括源地址、目的地址和纠错信息。这些分组被链接发送给卫星，然后进行广播，各接收设备只接收目的地址是自己的分组，由于传送是双向的，所以可以使用检错和纠错方法。从事分组无线电通信的公司有位于依利诺州Linco lnshire的Ardis、新泽西州Woodbridge的RAM Mobile Data和加州Lafayette的Nextel等。

    蜂窝数字分组通信（Cellular Digital Packte Communication）蜂窝数字分组数据（CDPD）是一个允许顾客通过现行蜂窝网络发送计算机数据的蜂窝无线网规范。CDPD中定义的分组方法为突发方式的计算机数据传送提供了有效的方法，典型的象E－mail交换和数据库查询。由于设备具有双向传送性能，所以传送过程中还可以进行检错和纠错。CDPD是一个由蜂窝电信局和计算机公司组成的国际性组织定义的。其中包括九个地方贝尔运营公司中的八个、IBM公司、McCaw Data公司、Contel Cellular公司和GTE Mobilnet公司。

    相关条目：Advanced National Radio Data Service高级国家无线电数据服务；Cellular Digital Packet Data蜂窝数字分组数据；Mobile Computing移动计算；Packet－Ratio Communication 分组无线电通信；Wireless LAN Communication无线局域网通信；Wireless Mobile Communication无线移动通信。


 RAID 冗余独立磁盘阵列
：Redundant Array of Independent Disks 的首字母缩略词（以前称做 redundant array of inexpensive disks）。为提高性能和可靠性将数据和用于纠错的信息分别存放于两个或多个硬盘驱动器的一种数据存储方式。磁盘阵列由阵列管理软件和控制纠错的磁盘控制器管理。RAID 通常用于网络服务器。


  • 移动数据公司 RAM Mobile Data RAM

    RAM移动数据公司和其搭档Ericsson GE移动通信公司，为移动式计算机用户提供双向无线通信服务。服务覆盖了美国大部分地区，与其竞争对手Ardis相比，它使用了相对较低的8Kbps的传输速率。然而，该项服务不贵，原本就是面向顾客市场设计的。

    相关条目：Advanced National Radio Data Service 高级国家无线电数据服务；Mobile Computing 移动计算；Packet－Radio Communication 分组无线电通信；Radio Networks无线网；Wireless LAN Communication 无线局域网通信；Wireless Mobile Communication无线移动信。


  • RDRAM Rambus动态随机存取内存

    RDRAM Rambus动态随机存取内存

    美国Rambus公司开发的一种动态随机存取内存芯片技术。基本RDRAM（Base RDRAM）在1995年推出，数据传输速度为600MB/秒。协同RDRAM（Concurrent RDRAM）在1997年推出，数据传输速度提高到700MB/秒。1998年，直接RDRAM（Direct RDRAM）再次把数据传输速度提高到1.6GB/秒。协同RDRAM一直被用于电子游戏机，而直接RDRAM则被用于个人电脑。

    Rambus公司自己并不直接生产RDRAM芯片，而是通过发放许可证让其他内存芯片制造商生产这种内存芯片产品。英特尔公司对Rambus公司进行了投资，并参入了RDRAM芯片的设计工作。


 RDRAM　高频DRAM
：RDRAM是由美国的Rambus设计生产的高频DRAM(Dynamic Random Access Memory，动态随机存取记忆体)，具有1000 Mbps。英特尔(INTEL)与RAMBUS合作发展运作时脉达1600 MHZ的NDRAM。


  • 重定向器（程序） Redirector

    重定向程序是运行在联网工作站上的一个程序，它截获对网络资源和服务的访问请求，把它们转向到网络服务器或对等网工作站上。例如，如果一个工作站用户请求访问本地文件，重定向程序引导请求到本地操作系统，如果请求访问网络服务器文件，重定向程序则引导请求到网上相应的服务器。请求被放在一个包含服务器地址的数据分组里。

    在NetWare和其它PC网上，重定向软件是随着安装在计算机中网络接口适配器的设备驱动软件一起分别安装到每一个工作站上的。

    相关条目：Client Software客户机软件；DOS Requester，NetWare NetWare的DOS请求解释器；LAN Work Place Products，Novell Novell的LAN Workplace软件产品；Network Driver Standards网络驱动程序标准。


  • 精简指令系统（集）计算机 Reduced Instruction Set Computer

    微处理器有套叫做微码（microcode）的指令集，程序员可使用它生成低级语言计算机程序。这套指令集完成多种任务，如移一个值到寄存器中或运行对寄存器中的值求和的指令。微码可以很简单也可以很复杂，这依赖于微处理器生产商的选择和芯片的使用目的。微码可以分为两类：

    复杂指令集计算机（CICS）设计 包含一个庞大的微码集，可以简化处理器上运行程序的生成。

    精简指令系统计算机（RISC）设计 正如其名，有着一套精简的指令集，无疑能提高处理机效率，但是需要更多复杂的外部编程。

    RISC设计基于由John Cocke在IBM所作的工作。他发现20％的计算机指令做了80％的工作，他的80％规则导致了RISC体系结构的发展。这种结构仅包含使用得最多的指令，减少了指令数量。其它的指令必须用外部软件实现。

    CISC微处理器在八十年代垄断了微型计算机市场，但是当用户需要更高速度时，RISC设计将更具持久的竞争力。而且模块程序设计方法和高级编程接口使得编程更容易了，这样减少了RISC设计的编程复杂性。基于RISC的处理器有MIPS芯片、DEC的Alpha芯片，IBM的RS芯片族。当今和未来的处理机设计似乎更倾向于RISC。


  • 廉价磁盘冗余阵列 Redundant Arrays of Inexpensive Disks（RAID）

    RAID是一个驱动器阵列，作为一个单驱动器使用。数据通过一种“分拆（striping）”技术均匀地写在每一个驱动器上，分拆技术把数据分别放在两个或多个驱动器上，如图R－1粗略例示。数据分拆可在位级或扇区级进行，一个扇区是一个磁盘数据块。分拆提高了吞吐量并且提供了一种冗余的形式，可以保证磁盘阵列中一个磁盘出现故障时不影响系统正常工作，这是通过把分散的数据编码到一个称为奇偶驱动器的备份驱动器来实现的。

    在RAID系统中，磁盘控制器是很重要的硬件部份，因为它影响性能和容错。常用几个控制器来预防控制器故障。小型计算机系统接口（SCSI）适配器具有非常好的读写性能，所以在RAID系统中几乎都使用SCSI。一个驱动器发出读写命令后，SCSI控制器便能与它断连而转向其它驱动器操作，而这个驱动器继续自己的操作。

    RAID提供了与磁盘镜象和磁盘双工类似的冗余。冗余的级别取决于所使用的RAID级，（下面介绍了“RAID级”）。在一般的磁盘镜象配置中，一个备份驱动器对应一个主驱动器。在三级RAID中一个奇偶驱动器为两个或多个主驱动器提供镜象，使用一个编码方案向奇偶驱动器写入信息，这些信息与写在其它驱动器上的数据有某种联系。若一个驱动器出故障，奇偶码和其它驱动器一起用来生成丢失的数据部分。

    购买一个奇偶驱动器比为每一个主驱动器都配置一个备份镜像驱动器便宜得多。然而，奇偶驱动器仅在每次只有一个驱动器出现故障时起作用。若两个或多个主驱动器故障，奇偶驱动器无法提供足够的信息重构数据。但是，只要防止了电源浪涌电压发生，两个驱动器同时出故障几乎不可能。

    许多RAID系统允许磁盘的热更换，也就是说在系统运行时磁盘能更换。当磁盘更换后，用奇偶信息来重构磁盘的数据。重构发生在操作系统正处理其它操作时，所以在重构操作期间，性能会有些损失。

    RAID Levels RAID级别

    RAID有多级，当购买使用RAID系统时，需要检查一下RAID的级别是否符合系统需要。

    0级RAID（RAI Dlevelo） 数据被分拆至多个驱动器，但无冗余驱动器，不提供数据保护功能。

    1级RAID（RAI Dlevel1） 数据被分拆到一个驱动器阵列上，每个驱动器与一个备份驱动器形成镜象。在4个驱动器的阵列中，2个用作主驱动器，2个用作镜像驱动器。1级RAID同时具有分拆的优点和最高级别的数据保护功能，因为所有主驱动器都有镜像。

    2级RAID（RAID level 2） 这一级一般不采用。它把数据按位分拆至阵列中各驱动器上。3级RAID与之类似，但使用得更广。

    3级RAID（RAID leve1 3）数据按位或按字节（可选择）分拆至阵列中的各个驱动器（除了一个作为奇偶驱动器的驱动器以外）。在4个驱动器的阵列中，数据分拆在3个驱动器上，奇偶信息写在第4个驱动器上，此级提供良好的读性能，但写操作相对较慢。因为每次写操作时都要写奇偶驱动器。

    4级RAID（RAID level 4） 此级与3级RAID相似，但数据是按扇区不是按位或字节分拆的。读的次数减少了，因为每个驱动器能读一整个磁盘扇区。

    5级RAID（RAID level 5） 数据以扇区为单位写到驱动器阵列中所有的驱动器上，同时纠错码也写入所有的驱动器。这一级写操作较快，因为奇偶信息写到各驱动器上的而不是象3级RAID写到一个驱动器上，磁盘读性能也提高了。因为每驱动器可以以磁盘块读取。

    市场上为服务器设计的RAID系统大部分是4级RAID或5级RAID。Compaq SYSTEMPRO使用4级RAID，但提供了在5级RAID上使用的升级软件驱动程序，能获得更好的性能。这种磁盘阵列较贵，你需要在价格和你对持续联机数据保护的需要中权衡。你还必须考虑的是RAID系统的性能和价格与很多网络0S提供的标准磁盘镜象和磁盘双工技术孰优孰劣，另外要考虑的是RAID系统一般是有专利的，所以你必须和制造商经常联系以获得未来的支持和服务。

    相关条目：Disaster Recovery灾害恢复；Disk Mirroringand Duplexing磁盘镜像和双工；DiskStorage Systenm磁盘存储系统；Fau1t Management故障管理。


  • 地方贝尔运营公司 Regional Bell Operating Companies（RBOC）

    地方贝尔运营公司（RBOC）是在AT＆T公司分解后，于1984年按照重建协议建立的。总共有22个RBOC，最后的重建协议是美国地方法庭的最终判决修正案（MFJ）。这个最终判决修正案结束了司法部对AT＆T的指控。

    RBOCs组成7个地方贝尔控股公司。每个RBOC在某个地理区域内工作，每个区域分为叫做本地访问和传输区域（LATA）的服务区域。LATA在重建时被规定，现有近200个。LATA划分了本地服务和长途服务的界限。

    Ameritech包括中西部各州：伊利诺伊、密歇根、印第安纳、俄亥俄和威斯康星州。RBOC包括伊利诺伊贝尔公司、密歇根贝尔公司、印第安纳贝尔公司、俄亥俄贝尔公司和威斯康星电话公司。

    Bell Atlantic包括大西洋中部各州：康涅狄格、特拉华、马里兰、新泽西、宾夕法尼亚、西弗吉尼亚和弗吉尼亚州。RBOC包括宾夕法尼亚贝尔公司、Diamond州电话公司、新泽西贝尔公司和4个Chesa－peake和Potomac（C＆P）公司（马里兰、弗吉尼亚、西弗吉尼亚和华盛顿特区的C＆P）。

    Be11 South包括南方各州：亚拉巴马、佛罗里达、佐治亚、肯塔基、路易斯安纳、密西西比、北卡罗来纳、南卡罗来纳和田纳西州。RBOC包括中南贝尔公司和南方贝尔公司。

    Nynex包括东北各州：缅因、新罕布什尔、纽约、罗得岛和佛蒙特。RBOC包括新英格兰电话公司和纽约电话公司。

    Pacific Telesis包括西部各州：加利福尼亚和内华达州。RBOC包括太平洋贝尔公司和内华达贝尔公司。

    Southwestern Be11包括阿肯色、堪萨斯、密苏里、俄克拉荷马和得克萨斯州。这个区域只有一个RBOC，称为西南贝尔公司。

    US West包括西部各州：亚里桑那、科罗拉多、爱达荷、明尼苏达、蒙大拿、内布拉斯加、新墨西哥、北达科他、俄勒冈、南达科他、犹他、华盛顿和怀俄明州。RBOC包括高山贝尔公司、西北贝尔公司和太平洋西北贝尔公司。

    不属于贝尔公司的独立电话公司（ITC）也在LATA区域内提供服务。所有在LATA内的服务称为LA－TA内服务。在LATA外部的服务称为LATA间服务，由长途交换局（IXC）提供服务。有许多长途交换局，例如MCI、US Sprint和AT ＆ T。

    司法部最终判决修正案（MFJ）规定了RBOC能提供的商务类型。例如有权提供LATA内交换服务，提供访问LATA的长途交换局和转销，但不能生产将属于顾客资产的设备。主要的是，RBOC不能提供局间交换服务，并需交纳文件税，它们提供的服务价格是固定的。

    相关条目：AT＆T 美国电报电话公司；Carries电信局；Carrier Services 电信服务（业务）；Local Access and Transport Area本地访问和传输区域（LATA）；Local Exchange Carrier 本地交换（电信）局。


  • Registry 注册表

    在Microsoft Windows 95/98/NT系统中我们会经常听到什么注册表之类的东西。注册表就是保存计算机内所有软件/硬件信息的地方，而且是唯一的地方。以前的Windows系统会以.ini文件保存这些信息。但是因为安装的应用程序越来越多，文件数目越来越多，无法管理。如果用户改变了这个文件的内容，就会使系统变得极不稳定，所以有必要将这些信息统一存储，而且不能让用户随便加以改变。这就产生了注册表。在Windows95/98/NT系统中我们还可以看到.ini文件，那是为了兼容的考虑。


  • 远程访问软件 Remote Access Software

    远程访问软件用于远程工作站或移动用户拨号入网和访问网络资源。通常采用带Modem的拨号线路连接，因此，传送速度较直接连到局域网低。要提高性能，必须减少远程用户和网络间的通信量。远程访问软件把远程用户的计算机看作一台哑终端，而在LAN站点上执行所有计算任务。在这种方式下，在线路上仅仅传输屏幕和键盘信息。但是，必须配置一台专用计算机来满足每个用户拨号的需要，如图R－2所示。远程访问软件有以下优点：

    远程工作站用户好象在使用连在LAN上的工作站。

    因为文件没有在线路上传输，所以延迟时间很短，用户便可实时访问数据库文件。

    访问文件和数据库的速度与LAN上速度一样，因为局域网工作站执行所有操作，仅有键盘输入和屏幕显示从本地PC机传送到远程工作站。

    因为远程工作站不执行任务处理，所以哑终端常用作远程工作站。

    远程访问替换的办法是将所有信息通过电话线直接传给用户。若用户正在操作数据库或文件，则用户所需的所有信息必须传给用户以在远程系统中进行处理，这不仅影响了效率，而且带来了安全保密问题。用户需要在本机而不是网络上装入和运行大量软件。例如，用户必须在本地磁盘上运行Windows，仅从远程连接的LAN上获得数据。

    一些远程访问产品适用于Windows和客户机／服务器应用。如Techsmith（位于密歇根的Lansing）的Remote NB确保了只有数据请求和这些请求的响应在远程工作站和LAN之间传递，因而有效地支持Windows应用程序。客户机／服务器请求适合于远程访问。LAN的网关（连到LAN的专用工作站）截获和处理远程工作站客户机的网络协议辅助操作，尽可能地减少远程连接的通信量。一般RemoteNB工作在协议栈的较高层以减少通信量。

    远程访问服务器产品十分实用，因为可使多个用户访问网络而只需较少的硬件设备。在此系统中，在一个多任务计算机上运行多重拨号会话，使得多个远程用户可通过各自的调制解调器拨进同一台计算机，如图R－3。例如Novell的NetWare访问服务器软件（NAS）运行在专用通信服务器上，可为15台PC机提供会话。在服务器上运行每一个会话就象一台有640K内存的Intel 8086计算机在作用。每一个远程访问连接需要一个串端口和一个调制解调器。

    另一类远程服务是电子函件。电子函件程序可拨号到中央邮局系统，它交付用户的函件并收集未取走的函件。这些系统能高效地使用电话连接。建立连接后，函件被传送并收取，然后系统挂断连接。电子函件系统提供的用户到用户的非实时通信较语音邮件或对话更方便和有效。电子函件的存储－转发方式不仅有利于消息传递，也适用于文件和数据传送。用户甚至能用电子函件消息申请数据库资源，然后可在另一个时间通过另一个电子函件消息得到应答。

    许多供应商正在加速为远程用户开发特定的支持远程用户的附加软件包或应用程序。Microsoft开发了Windows的另一特性，使Windows能自动保存用户的工作环境，从而使用户能在一个场点断连而在另一场点重连时，仍保存自己的设置和工作。Novell的NetWareConnect是一个远程通信平台，可让移动用户连到NetWare网。它提供远程节点、远程控制、拨入／拨出服务和安全管理功能。NetWare Connect的前驱是NetWare异步通信服务软件（NACS）。以后的增强还包括对Macintosh的拨出和支持UNIX－TCP／IP用户的点对点协议。

    虽然配置一台专用PC或访问服务器对远程用户来说比较贵，但远程访问在网络环境中还是占有一席之地。当远程用户需要进行大量的磁盘访问时，在本地机器间传送数据，而后在远程系统上显示结果是非常经济的。网络管理员需估算远程用户的电话费用和时间。远程控制软件可减少这些费用。

    相关条目：Dialup Line拨号线；Mobile Computing移动计算；Modems调制解调器；Wide Area Networks广域网。


  • 远程过程调用 Remote Procedure Call

    进程间通信（IPC）是在多任务操作系统或联网的计算机之间运行的程序和进程所用的通信技术。有两种类型的进程间通信（IPC）。

    本地过程调用（LPC）LPC用在多任务操作系统中，使得同时运行的任务能互相会话。这些任务共享内存空间使任务同步和互相发送信息。

    远程过程调用（RPC）RPC类似于LPC，只是在网上工作。RPC开始是出现在Sun微系统公司和HP公司的运行UNIX操作系统的计算机中。

    通过IPC和RPC，程序能利用其它程序或计算机处理的进程。客户机／服务器模式计算把远程过程调用与其它技术如消息传递一道，作为系统间通信的一种机制。客户机执行自己的任务，但靠服务器提供后端文件服务。RPC为客户机提供向后端服务器申请服务的通信机制，如图R－4所示。如果你把客户机／服务器应用程序想作是一个分离的程序，服务器能运行数据访问部分，因为它离数据最近，客户机能运行数据表示和与用户交互的前端部分。这样，远程过程调用可看作是把分割的程序通过网络重组的部件。LPC有时也称耦合（Coupling）机制。

    用这种方式分割程序，当用户要访问数据时就无需每次拷贝整个数据库或它的大部分程序到用户系统。其实，服务器只处理请求，甚至只执行一些数据计算，把得出的结果再发送给用户。因为当数据存放在一个地方时，数据库同步很容易实现，所以多个用户可同时访问相同的数据。

    分布式计算环境是由一个通信系统——网络连接的计算机集群。很容易把这个网络看成一个计算平台，若是对等方式，其中任何一台计算机都能成为客户机或服务器。一些处理任务可被分成独立运行程序在不同的网络计算机上并行处理，而独立的程序被交给最适合这个任务的计算机处理。这种策略可利用计算机空闲资源，提高网络的效益。一个典型的企业网包括许多运行着不同操作系统的异构计算机系统。

    随着企业网的产生，开发商必须编制可在各种计算机和网络通信协议中都能运行的程序。现在人们正努力使得远程过程调用独立，这意味着开发商就不用考虑底层的网络和网络上数据传输所用的协议，下面介绍RPC在开放式软件基金（OSF）的分布式计算环境（DCC）中实现的相关方法。RPC工作于多种分布式计算环境。

    SunSoft的开放网络计算（ONC）的远过程调用／外部数据表示（RPC／XDR）协议被广泛采用。在三百一十万个运行网络文件系统（NFS）的系统中，有二百八十万个使用ONCRPC库，并在分布式应用中作为客户机或服务器。ONCRPC被IBM的所有操作系统所支持（除了OS／400）。UNIX系统实验室把RPC／XDR当作是UNIX System V Release 4的一个标准部分。Novell支持下一代ONC+传输自立远程过程调用（TI－RPC）技术．TI－RPC 使用运输层接口（TLI）实现传输自立。TLI提供了一种访问面向连接或非连接传输服务的通用方法（这在“STERAMS环境”中有所叙述）。

    Open Software Foundation（OSF）RPC 开放软件基金会（OSF）的RPC

    RPC工具提供了一种编程语言和编译器，它们使用可看作是本地过程的可运行于客户机和服务器上的模块开发分布式应用程序。运行时设施（run－timefacility）使得分布式应用程序能在多机种异构系统上运行，这样使得底层体系结构和运输协议对于应用程序是透明的。

    程序员用接口定义语言（IDL）建立接口定义（interface definition）。IDL是程序员用来设计远程运行的过程的工具。IDL编译器把IDL接口定义转换成与客户机和服务器相连的占位程序（stub）。客户机上的占位程序可加入到服务器的过程，而服务器上的占位程序也可加入到客户机过程。位于客户机服务器的RPC运行时设施与占位程序合作，来提供RPC操作。

    异构环境中使用RPC的一个问题在于，不同的机器有不同的数据表示，OSFRPC通过具有调用机器的基本数据表示的特征调用来解决这个问题。当收到调用时，若根据特征知道两台机器数据表示不同的话，接收器就进行数据转换。

    RPC运行时设施提供把客户机请求传送给服务器和在网上发送和接收响应的功能。DCERPC运行时设施也和网络上其它DCE服务相互作用，这些DCE服务有命名、安全和定时服务。运行时设施有下列特征：

    可在多种网络上运行。开发者无需为每个网络编写特定的应用程序。

    提供客户机或服务器或网络上的故障恢复。它支持文件系统、数据库和其它传输可变长数据的服务。

    提供独立于任何一个目录服务的基于名字定位服务器的方法。

    提供安全工具的接口，以防RPC通信遭受破坏。安全服务保证机密信息的保密性和提供鉴别来保护通信完备性。

    支持网上并发或并行处理的多线程调度，于是一个应用程序就能同时执行多个操作

    提供多供应商提供的系统环境的可移植性和相互操作性。

    相关条目：Application Program Interface应用程序编程接口；Connectionless and Connection－Oriented Transaction无连接和面向连接事务；Distributed Computing Environment，OSF OSF的分布式计算环境（DCE）；Enterprise Networks企业网；Interprocess Communication进程间通信；Middleware中间件。


  • 中继器，重复器 Repeater

    电信号在电缆中传播，它们随电缆伸长而成比例减弱。这种现象称为衰减（attenuation）。中继器就是网络中简单的添加设备，使得电缆中信号增强，这样网络的长度就可以扩大了。中继器除在扩展的电缆段增强了传输信号，一般不改变信号的其它特性。也有些中继器过滤噪声。中继器一般来说是哑设备，具有以下特征 ：

    中继器再生信号使得信号能传播更远。

    中继器一般用于如以太网的线性电缆系统。

    中继器用于协议栈的最底层——物理层。高层协议不使用中继器。

    用中继器连接的网络段都必须使用同样的介质访问方法。

    用中继器相连的网络段成为同一网络的一部分，具有相同的网络地址。

    中继器一般在单座建筑中使用。

    网段中的每个节点有自己的地址。扩展段中的节点地址和已有的网段节点地址必须相同，因为它们已成为同一网络段上的一部分。

    中继器传输分组的速度和所在网络相同，在以太网上大约是10Mbps，桥接器大约是每秒可传15，000个分组。路由器传输分组的速度比桥接器慢5倍，配置中继器一般是由于距离原因（以太网上粗缆是500米［1，650英尺］配一个电继器，细缆是185米［610英尺］配一个）。中继器重建分组的前置域（preamble）。前置域使得接收器在使用分组中信息之前达到位同步。

    扩展局域网和加入更多的工作站会增加局部网的拥塞。一般的规则是每个局域网段不能超过50个工作站。若拥塞度很高，就需考虑通过桥接器把局域网分成2个或多个网段，一般认为，中继器适用于远地工作站的连接，而不是作为增加工作站的手段。

    相关条目：Bridging桥接；Networks网络；Routers路由器。


 Repeater　中继器
：中继器是实现网络与网络连接的设备。它的作用是从物理链路层连接两个网，在网络间传递比特（bit）信息，用于延伸同型局域网，使两个网如同一个网。


  • 复制 Replication

    复制是拷贝整个或部分数据库到另一个地方备份和（或）对数据库提供最新修改的技术。复制仅仅是一个保持分布式数据同步的技术。另外一种经常使用的方法是双阶段提交，下面介绍这两种方法的简单比较。

    两阶段提交（Two－Phase Commit）用在同时向多个分离的数据库写信息的联机事务处理中。要修改分理处数据库的银行事务就是一个例子。在双阶段提交中，所有涉及的数据库首先必须应答监控程序，表明它们准备好写数据，然后当它们写完之后还必须告知监控程序。如果其中任何一个系统不能应答，所有的系统都异常终止写操作。详见“Transaction Processing事务处理”条目。

    复制包括每隔一段时间或在一次重大修改之后拷贝整个或部分数据库，从远程站点拷贝到主数据库或从主数据库拷贝到远程站点。

    复制适用于那些并不是所有的数据库修改都对时间敏感的场合。例如，一个目录服务包括网络上的用户和资源名字。将这个数据库（或它的分区）拷贝到远程站点，这样远地用户可在本地访问到主站的数据，而无需使用广域网连接。数据库的变化，例如新用户的增加不是那么紧要，远程用户并不是急迫地需要新修改的信息。所以远程数据库可定期复制，或在晚上复制，以利于减少昂贵的广域网链路费用。

    相关条目：Directory Services目录服务；Directory Services，NetWare NetWare的目录服务；Directory Services，Open Software Foundation开放软件基金会的目录服务；Disaster Recovery灾害恢复；Distributed Computing分布式计算；Distributed Database分布式数据库；Distributed File System分布式文件系统；Partition Management（数据库的）分区管理；Transaction Processing事务处理。


  • RG－58同轴电缆 RG－58 Coaxial Cable

    一种类似于电视同轴电缆的两导体屏蔽电缆，它主要用于以太网。RG58通常称为“细同轴电缆”，它的特性阻抗是50欧姆。

    相关条目：BNC Connector BNC连接器；Cabling（电缆）布线；Ethernet 10Base－2 10 Base－2以太网；Tranamission Media，Methodsand Equipment传输介质、方法和设备。


  • RG－62同轴电缆 RG－62 Coaxial Cable

    一种类似于电视同轴电缆的两导体屏蔽电缆，它用于ARCNET网拓扑结构。这种电缆具有93欧姆特性阻抗。

    相关条目：ARCNET ARCNET网；BNC Connector BNC连接器；Cabling（电缆）布线；Transmission Media，Methods，and Equipment传输介质、方法和设备。


  • Windows NT权限（准许权限） Rights（Permissions）in Windows NT

    参见“Windows NT中的准许权限”和“Microsoft的Windows NT”条目。


  • Novell NetWare中的权限 Rightsin Novell NetWare

    在网络操作系统中访问权和安全性是至关重要的。正确地实行安全措施可避免由非法用户造成的数据损坏和丢失及维护数据的保密性。登录鉴别和限制是防止非法用户入侵的第一道防线，而访问权限可防止已登录用户窥探文件系统，获得敏感信息，如工资单文件。而且访问权限也可控制网络中各种资源的使用者。

    获准访问文件、目录或对象的用户称为受托者（trustee），NetWare的访问权限被分组，如下所述：

    目录权限控制用户访问磁盘上的目录和目录中的文件。

    文件权限基于一个文件一个文件地控制用户对目录中文件的访问。

    在NetWare 4．x中，对象权限控制用户建立和管理用户帐户对象和NetWare目录服务（NDS）系统中资源（如服务器、文件卷宗、打印机）对象。

    NetWare 4．x中，特性权限控制用户可否察看和修改NetWare目录服务（NDS）系统中对象的特性。

    NetWare中，SMS权限控制用户对存储管理系统（SMS）应用程序中对象的访问。

    委托权给予用户访问目录和文件以及管理对象的能力。

    NetWare目录服务对象的受托者有权察看、删除和重新命名NetWare目录服务树中的对象。如果它是所有者对象，受托者可在它内部建立其它对象。受托者也被赋予观察和改变对象特性的权限。

    一个目录的受托者能被给予观察、改变、删除和建立目录中文件的权力。一个受托者也能被赋予改变文件属性、名字、委托指派和目录的继承权筛选。

    若用户获准对对象、目录或文件的监管（Supervisor）权限，那么用户拥有对对象、目录或文件的所有权限。

    下面将列出NetWare 4．x中目录、文件、对象和特性权限。

    Directory Rights 目录权限

    监管（Supervisor） 拥有对目录、目录中的文件和子目录的所有权限。监管权不能被继承权筛选程序阻断。拥有此权限的用户可授权给其他用户对此目录、它的文件和它的子目录的权限。

    读（Read） 有权在目录中运行程序、打开目录中文件和读其内容。

    写（Write） 有权打开和改变目录中文件的内容。

    建立（Create） 有权在目录中建立新文件和子目录。

    删除（Erase）有权删除目录、目录中文件和子目录。

    修改（Modify） 有权改变目录及此目录的文件和子目录属性或名字，但无权改变内容。

    文件浏览（File Scan）有权使用DIR和NDIR命令察看目录和其中文件。

    访问控制（Access Control） 有权改变目录、目录中文件和子目录的受托者分派和继承权筛选程序。

    File Rights 文件权限

    监管（Supervisor） 拥有文件的所有权限，不受继承权筛选程序的阻断。有此权限的用户可以授权其他用户对文件的任何限权和可改变文件的继承权筛选程序。

    读（Read） 打开且读文件的权限。

    建立（Create）文件被删除后抢救重建的权限。

    写（Write） 打开和写一个现存文件的权限。

    删除（Erase）删除文件的权限。

    修改（Modify） 有权改变文件属性和名字，但不能改变其内容。

    文件浏览（FileScan） 有权使用DIR和NDIR命令看文件的权限，包括察看从文件到根目录的目录结构。

    访问控制（Access Control）有权改变受托者分派和文件继承权筛选程序。

    Object Rights，NetWare 4．x NetWare 4．x的对象权限

    监管（Supervisor） 有对对象的所有访问特权，包括访问所有的对象特性。对象的监管权能被对象的继承权筛选程序所阻断，对象在那里被赋予监管权和单个特性权限。

    浏览（Browse）看索引树中对象的权限。当找到匹配的对象时，返回对象的名字。

    建立（Create）在索引树中建立从属于对象的新对象，新对象的权限没有定义。仅仅所有者（Container）对象可采用建立（Create）权限，因为非所有者对象不能有下级。

    删除（Delete） 从索引树中删除对象的权限。已有附属对象的对象不能被删除，除非先删除了其所属对象。

    重命名（Renarne）改变对象名字的权限，实际上改变命名特性，这就改变了对象的全名。

    Object Property Rights，NetWare 4．x NetWare 4．x的对象特性权限

    监管（Supervisor） 有对对象特性的所有权限，特性监管权限能被对象的继承权过滤所阻断。

    比较（Compare）把任意值与特性的值作比较的权限。比较操作返回真或假，但不能看到特性的值。读权限包括比较权限。

    读（Read）读对象特性的值的权限，比较是读权限的子集。如有读权限，也可进行比较操作。

    写（Write） 增加、修改或删除特性的任何值的权限，写权限包括自增及管理权限。

    自增（AddSelf）拥有自增权限的受托者可将自己作为特性值进行增加或删除，受托者不能影响特性的任何其它值，这个权限仅对包含对象名作为值的特性是有意义的，如象组中所有成员清单和邮件清单。

    继承权筛选程序（IRF）控制用户可以从父目录或NetWare 4．x的所有者对象中继承哪些权限。例如，如果用户在父目录中有读和写权限，那么可以使用IRF去禁止子目录中的写权限。你可使用IRF移去一个用户从父目录或对象中继承（或能够继承）的某些或全部权限。

    对于目录或文件（或NetWare 4．x中的对象）的用户有效权限（users effective rights）基于下述参数计算：

    用户对目录、文件或对象的受托分派。

    用户对父目录或所有者对象的受托分派。

    用户在它所属组原先列出的两组参数之一中的受托分派。

    用户的安全等价。

    对目录、文件或对象的继承权筛选程序。

    在约定状态，除了用户的私人目录和公共目录之外，用户没有被授于任何权限。

    相关条目：Access Rights 访问［访问］权限；NetWare NetWare操作系统；Novell Novell公司。


  • Windows for Workgroups中的权限 Rightsin Windows for Workgroups

    在Microsoft Windows for Workgroups环境中，用户可在系统上与其它用户共享文件，并能访问其它系统上的共享文件。安全特性在两个级别上限制对目录的访问：

    只读（Read－Only） 有只读访问权限的用户可以观察在共享目录中的文件，但不能改变或删除文件。

    完全访问（Full－Access）对共享目录有完全访问权限的用户可以改变现存的文件，增加新文件和删除文件。

    相关条目：Windows for Workgroups，Microsoft Microsoft的Windows for Workgroups环境。


  • 环网拓扑结构 Ring Network Topology 环网拓扑结构

    环形网拓扑结构是不需要终结器的封闭形拓扑结构。令牌环拓扑结构形成一个逻辑环，但由中央集线器相连。它在物理上呈星形拓朴的电缆配置，实际上在集线器内形成环。当工作站连到集线器时，电缆从集线器连到工作站，然后返回到集线器，使环延伸到工作站。当加入另一集线器时，电缆从第一个集线器的出环连接器到第二个集线器的入环连接器，再从第二个集线器出环连接器返回到第一个集线器的入环连接器，依然维持了环形结构。

    实际中真正的环形拓扑网是很少见的。规划和安装一个星形配置网更容易一些，在星形配置网上的故障也容易定位。环网本身由Hub来维护，当工作站出故障时，Hub会简单地旁路出故障的工作站，使网络的其它部分能继续工作。光纤分布式数据接口（FDDI）和IEEEMAN（域域网）标准使用双环。如果在某个位置上电缆被切断，就发生一个回送（loop－back），到达断点的信号向相反方向上重新发送，这样保障网络通信。

    相关条目：Access Method，Network网络访问［访问］方法；Multistation Access Unit多站访问［访问］单元；Tokenand Token Passing Access Method令牌和令牌传递访问方法；Token Bus Network 令牌总线网；TokenRingNetwork 令牌环网；Topology拓扑结构。


  • RISC CPU 精简指令集CPU

    高档微机中所采用的一种带有精简指令集的CPU。它的特点是：指令系统 小，一个时钟周期内可以执行一条或者多条指令；采用标准长度指令；存储器访问只使用加载和存储两个指令等。


  • RJ－11和RJ－45连接 RJ－11and RJ－45 Connections

    在10－Base T 以太网和其它双绞线电缆网系统中使用的电话型插座，有两种规格：

    RJ－11是用于电话的四线组合式接插件。

    RJ－45是用于网络和某些电话系统的八线组合式接插件。

    相关条目：Cabling（电缆）布线；Ethernet以太网；Ethernet 10Base－T 10Base－T以太网；Transmission Media，Method，and Equipment传输介质、方法和设备。


  • 路由器 Routers

    路由器是开放系统互连（OSI）协议模型的网络层中的分组交换设备（或网络层中继设备）。路中器可互连局域网和广域网，并且当网络上两端点间存在好几条通路时，路由器还可提供交通控制和筛选功能选择通路，如图R－5。在大型互联网和使用远程通信链路的广域网中路由器非常重要。他们在对一个目的站的冗余路径所组成的网状网络中沿着最有效或最经济的路径传送数据分组。

    HOW Routers Work 路由器的工作原理

    路由器检查分组中的地址信息并沿着预定的路径将分组传到目的站地。路由器维持网络中邻近路由器和局域网的表，当一个路由器收到一个分组后，它查看这些表，看是否能直接把分组转到目的站地。若不能，则找出能将分组转发到目的地的一个路由器的位置。

    转发过程需要一些处理。路由器必须完全接收一个分组，查看HS地址信息，而后继续传送。因此，路由器的部件和体系结构不同，吞吐量也不同。有的网络操作系统，例如Novell NetWare服务器中支持路由选择，这是通过安装2个或多个网络接口卡来完成的。然而，路由选择任务可使服务器速度下降，这样的话，外部路由就十分必要，它可把服务器解脱，使之只执行与文件相关的任务。

    路由器可处理单个协议如TCP／IP，或多个协议，如SPX／IPX和TCP／IP。注意并不是所有的协议都被路由器支持，有些协议不能进行路由选择。但是，这些不可路由的协议可使用封装（encapsulation）技术携带通过互联网络。

    路由器使得一个网络被分段成单独可编址网络段，这些段较易管理。每个局域网段有各自特定的局域网号，且网段上每台工作站都有自己的地址。这些是网络层协议放在分组中的信息。

    Router Racket Processing 路由器的数据分组处理

    路由器可处理有相同网络地址的分组。当一个路由器收到一个分组后，它启动一个处理过程先打开分组，然后决定分组应该送往哪里。分组的内容以及每一个网络协议层加入的信息将在“Packet分组”条日中讨论。下面是路由器的分组处理过程：

    1．使用分组中的检查和对分组进行错误检查。

    2．由发送设备的物理层和数据链路层协议加入的信息，被分拆成如图R6所示的形式。

    3．鉴定在源计算机中由网络层协议加入的信息。

    网络层协议信息包含目的地址和在使用TCP／IP源路由选择网中的一个路由中继（跳跃）表，路由中继（hop）定义了通过网络的预定最佳路径。下面，路由器也许要做下述几项工作之一：

    分组或许寻址到路由器本身，则路由器测定出分组中剩下的全部信息。

    若分组中目的地址是同一网中，路由器仅将分组向前传送。

    若有筛选表被采用，路由器对照表检查分组的地址，若有必要，可将分组排出，这为安全起见，使得分组位于网络内或排出网外。

    若分组中包含有源路由选择信息，它标出了到目的站的下一个路由器，那么分组就将传给那个路由器。

    一个路由器维持一个分组通过互联网的路径表。

    若路由器不知道一条路径或在它的路由选择表中找不到一个分组的目的地址，它就将分组废弃并可能返回一个错误信息到源站。

    有的分组（TCP／IP）包含它在网上已通过的跳跃数（路由中继数）。若一个分组超过一定的跳跃数，路由器就假定分组在循环，于是将其废弃。然后路由器可以返回错误信息给源站。

    Choosing the Best Path 选择最佳路径

    一个互联网通常被认为是带有容错功能的，在路由器之间建有几条路径以便在一条链路出故障时提供备份路径。其中一些路径可以使用高速网络，如在校园或都市范围内的光纤分布式数据接口（FDDI）或广域网的直通数字线路（T1）。路由器能在这些路径中选择一条最佳路径进行数据发送，最佳路径的选择取决于那一条路径最便宜、最快速、最直接，或由管理员指定一条路径。

    路由选择协议（参见“路由选择协议”条目）选择通过一个网络的最佳路径，这是基于一些准则，如象一个分组经过路由器网络到达其目的站必须经过的路由中继（hop）数。一条最佳路径也可以是绕过拥塞局域段的路径。传输能被优化，例如，高优先级的分组能在56Kbps数字通信链路上发送，低优先级的分组能在19．2Kbps远程通信链路上发送。网络管理员能够确定一个网络中的最佳路径，或者在某些情况下，由路由器来选择最佳路径。

    一个专用网络由租用或拨号线路和在图R－5中所示的路由器来构成。如果洛杉矶想发送一条消息给圣路易斯，路由器可以使用19．2Kbps的直通线路或通过休斯敦连到圣路易斯的56Kbps线路。在另一种情况下，如果纽约城想发一条消息给洛杉矶，这消息可以通过芝加哥和丹佛，或通过圣路易斯。路由器作出抉择是基于芝加哥或亚特兰大的拥塞程度或“路由中继（hop）数”。纽约城到洛杉机的连结如果通过圣路易斯则是2个hop；如果通过芝加哥和丹佛则将有3个hop。注意网状网络是有冗余链路的，如果芝加哥到丹佛的线路出了故障，从纽约城到洛杉矶的消息还可经过圣路易斯或孟菲斯传递。

    路由器也用于将网络连至主干网，如图R－7所示。在这种情况下，本地通信在本地局域网上传输，而互联网或广域网通信经过FDDI光纤主干网到达它的目的站。注意FDDI主干网象一个交通环路，在这种环路上它沿着分支节点传送信息。

    Router Specification 路由器规范

    如果你用的是一个小型网络或者只是在一幢建筑内，那么使用桥接器就足够了。桥接器能帮助把繁忙的局域网分段。注意图R－7的右边有几个子网通过桥接器连接，而这组网通过路由器连到FDDI主干网。

    用桥接器将多于10个子网互连会引起过量的互联网交通和造成分组循环现象。路由器可互连不同类型的网络，如以太网连到FDDI主干网或与广域网上链路相连。若一个网由多种协议组成，那么就需要配置多协议路由器。路由器使得网络负载平衡到多条线路上，并在通过复杂的互连路由器网（mesh）时提供路径控制。若一条链路失败，路由器还可重新配置路径。

    当评价或购买路由器时，确保网络中所有的路由器都使用相同的路由选择方法，并使用相同的协议。路由器使用数据压缩方法来提高数据分组的吞吐率。为了避免出现问题，在所有地方总是试图使用同一种路由器。尽管路由选择方法通常都是标准化的，但失配也会导致性能下降。

    现在高性能系统中提供了多种容错技术，如冗余电源供给和“现场”模板替换。路由器设置常常比较困难，因为许多特性如多种协议、冗余路径、性能和安全性都必须对设备编程。一个好的安装程序能使这些事情很容易做。Novel的多协议路由器（MDR）通过设置分组大小和其他适合于NetWare网特性的默认值，简化了设置过程。

    路由器的价格有几种。高档的是完全布线Hub，它把所有的网络端口、桥接器、路由器都集成在一个位置的一个单元中，这种路由器的起价是20，000美元，它们一般有16个端口，对广域连接如FDDI和T1有可选支持。中档的价格是从10，000美元到20，000美元，这些单元一般只含少数端口，但是它们提供了集中式布线方案和管理。低档的是单纯的路由器，用于各种互联网的场点，价格低于10，000美元。”

    路由器可分为本地路由器和远程路由器两类。本地路由器作为局域网设备连接令牌环网、以太网和FD－DI网段。远程路由器可连到广域网如T1、X．25、帧中继、卫星、微波等。

    速度评估

    让我们来看看速度指标，从而得出桥接器和路由器的速度到底有多快是很有益的。桥接器和路由器的速度单位是每秒传输的分组数（PPS）。若所有分组是64字节的话，以太网（10Mbps）在自己电缆上可传输14，880PPS，以太网上的桥接器一般筛选14，000PPS和向前传送10，000PPS。路由器一般每秒发送8，000至15，000个分组。桥接器和路由器的存储转发等待时间在某种程度上降低了吞吐量。Novell的MPR（多协议路由器）每秒可传送3，000至4，000个分组。

    桥接器和路由器每秒可传输的分组数不需高于它们所在的局域网传输能力，还要注意的是，通过桥接器的通信量较本地通信量要少一些。虽然由高性能系统送出的突发数据可使得一般的以太网线路带宽饱和，但以太电缆访问方法的竞争机制增加了足够大量的开销，使得桥接器或路由器的传输量较低。在算进这种额外开销时，每秒可处理5000个64字节分组的桥接器或路由器对于10Mbps网来说是足够了。令牌环网有类似的饱和点。其实线缆本身比桥接器更限制带宽。每秒可传输2，000至3，000个分组的桥接器或路由器就完全能够满足令牌环网的分组传送。对于广域网，高传输率并不那么重要，因为广域网本身比局域网的吞吐量要低，如广域网仅为1Mbps，而以太局域网为10Mpbs。

    Multiprotocol Routers 多协议路由器

    多协议网络支持多种协议，例如TCP／IP、IPX、AppleTalk、DECnet和其它协议。多协议路由器使得正在联合它们网络资源的机构有能力将网络资源都联到同一网络平台。多协议路由器可运行软件处理来自每一个网络支持的协议的分组，这取决于路由器的能力。

    多协议网络提供了一种方案，使许多协议转换减至少数几个协议。管理员可逐渐使用户转向公司支持的协议上，当所有的用户都转成新协议后，旧协议就被取消了。

    Novell 的多协议路由器

    Novell多协议路由器是一组NetWare可装入模块，这些模块可装在网络文件服务器或一个单独的系统中。这种路由器程序配有NetWare的NetWare Runtime运行版，以便你可在某一系统中运行它，而不局限于NetWare文件服务器。这种软件可以在以太网、令牌环网、ARCNET网和AppleTalk局域网段上为SPX／IPX、TCP／IP、AppleTalk和Novell NetBIOS的分组选择路径。它还可通过X．25（64Kbps）或T1线路支持广域连接。对使用SPX／IPX协议的用户，NetWare链路服务协议（NLSP）是一个取代SPX／IPX的路由选择信息协议（RIP）的链路状态路由选择协议。对使用TCP／IP协议的用户，使用的是优先开放最短路径（OSPT）协议。两者都在局域网段间提供较快的数据传输。

    多协议路由器（MPR）必须运行在80386或更好的计算机系统中。它是和NetWare Hub Services（NetWare的Hub服务）捆绑在一起的，那是一个把Hub集成到NetWare平台的监控和管理系统。通过NetWare的Hub服务，可建立路由器和集线器连接系统。多协议路由器还包括为广域网路由选择的广域网链接。

    相关条目：Carrierservices电信服务；Hubs Hub，集线器，集中器；Layered Architecture 分层体系结构；Networks网络；Open System Interconnection Model开放系统互连模型；Packets（报文）分组，包；Protocols，Communication通信协议；Protocol Stack协议栈；Routing Protocols路由选择协议；Wide Area Network广域网。


  • 路由选择信息协议 Routing Information Protocol

    路由选择信息协议是一个使用距离向量路由选择算法的内部或域内路由选择协议。IP作为两个路由器之间路由选择信息交换的基本方法，用于TCP／IP网，XNS网和NetWare SPX／IPX网。RIP是当前最普遍的互联网Internet的内部网关（路由）协议。Internet标准OSPF（优先开放最短路径）支持IP网络层协议，并且是RIP的未来后继者。

    基于RIP的路由器，执行下列任务，以确保自己使用最新的网间信息：

    依据来自其它路由器的请求路由选择信息，修改RIP路由器的内部表格。

    响应其它路由器的路由请求。

    周期性地广播RIP路由器的存在，确保其它路由器识别网间配置。

    广播任何时候检测到的网间配置改变。

    距离向量算法（DVA）的路由选定是，到一个目的站的最少“路由中继（hop）”数或到那个目的站路径的费用，而费用是根据指定的路由器和相邻的路由器的预赋值来计算的。如果一个分组经历了15个以上的hop，它的目的站被认为是不可到达的，并且这个分组被取消。

    RIP路由表与其它路由器的交换大约每30秒一次，并且路由器根据接收到的新广播信息重建路由表。路由器通过广播RIP消息，即路由器可达到的网络列表通告他们的路由。假如一个路由器不能在180秒内广播RIP消息，那么它的路径被认为是不通的。

    假如一个路由器来不及重建路由表就可能出问题，问题出在路由器连接在一条慢速广域网链路上。另外，交换路由表可能对一个局域网增加大量的系统开销，它使信息更加拥塞，更加推迟路由表的更新。如果一个路由失败，为重建路由表所需的延迟可能推迟一个新的路由迅速地建立。

    相关条目：Routing Protocols路由选择协议。


  • 路由选择协议 Routing Protocols

    当两台非直接连接的计算机需要经过几个网络通信时（如图R－9），通常就需要路由器。路由器提供一种方法来开辟通过一个网状联结的路径。在图R－9中标示了几条存在于洛杉矶和纽约办公室的路径。这种网状网络提供了冗余路径以调整通信负载或倒行链路，通常有一条路径由于费用、速度或避开拥挤等理由优选于其它路径。路由选择协议的任务是，为路由器提供他们建立通过网状网络最佳路径所需要的相互共享的路由信息。

    当一个计算机发送一个分组时，在网络上网络协议栈的每一层都附加一些信息给它。在接收方的对等层协议可以读出这些信息。这些信息类似于通信会话的某些部分。网络层的协议附加路由选择信息，这可能是通过一个网络的完整的路径或是一些指示分组应该采用那条路径的优先值。发送方添加的网络层信息只能由路由器或接收方的网络层协议读取。中继器和桥接器不能识别网络层信息，只能传送和转发分组。

    Routing Algorithms 路由选择算法

    一个路由器设备可能有两个或多个可以发送数据分组的端口。它必须有一张转发表（forwarding table）为每一个端口标明一个特定地址。早期路由器不和其它路由器交换网络上有关路由器的信息，因此，一个路由器通常沿着每条路径发送数据分组，分组充满网络，并且发送的一些分组在网络上无休止地循环。

    为了避免这些问题，路由器可以依赖人工编程把选择的路径输进设备。这被称为静态路由选择。动态路由选择是一个更好的方式，它依靠路由器收集网络信息和建立自己的路由表。路由器相互交换路由表，并且归并这些路由信息建立更新的路由表。从其它路由器上获得的信息，提供到网络上目的站点的路由中继（hop）数或与路径相关的费用。同时，每个路由选择设备上的路由表，应该包含大体上一致的路由选择信息。

    在使用远程通信链路的广域网中，规整化路由选择是基本的，但是必须在远程通讯链路迅速改变（例如，线路断）时，很快地调整到新的路径拓扑。一个典型的Internet可能由2个、10个甚至50个路由器组成，这些路由器可以通过拨号异步链路或专用高速数字线路（如T1）互相连接。对于一个在网络上传送的数据分组，它们到达路由器时由路由器查看目的地址，并沿着最佳或非常合适的路由将分组发送到接收站。这样一条路由取决于所用的路由选择算法类型。

    路由选择协议基本上有两类：距离向量和链路状态，将在下面用两段文字介绍这两类协议。

    距离向量路由选择协议

    距离向量路由选择协议的分组传送路由是根据到接收站的hop数或费用决定的，这些信息由各相邻的路由器提供。技术上通常都遵循Bellman－Ford算法。

    一个路由器（如图R－10）有几个端口，每个端口都有指定的价值，这些价值是由网络管理员设定的。用使用一条线路实际费用的多少，作为一种衡量手段表明一条线路比另一条好或坏。此外，相邻的那些路由器告诉它们把分组送往目的站要花费的代价。路由器将端口的价值加到相邻路由器的价值上，如下面的例子：

    端口1价值10 + 相邻路由器价值17＝27。

    端口2价值20 + 相邻路由器价值5＝25。

    端口3价值30 + 相邻路由器价值7＝37。

    在这种情况下，路由器将通过端口2传送分组，因为它表明到接收站的代价最少。假如有必要，用邻接端口2的路由器再计算到下一个路由器的路径价值。

    路由信息，如下一个hop的地址等都存在表中，并且路由器大约每隔30秒互相交换表。初始时，每一个网络只知道直接相连的路由器。当一个路由器得到一张表，它将表项与自己的表进行比较。根据这些信息，它用新增路由或删除路由来修改表。表中信息包含：

    网络号；

    端口号；

    价值度量；

    下一个hop的地址。

    价值度量是路由器向前传送分组到网中下一个路由器时选择路径所用的量值。通用距离向量路由选择协议有：

    路由选择信息协议（RIP）是一个首先在Xerox网络系统（XNS）中实现，而后又在Novell的NetWare中实现的距离向量路由选择协议。

    内部网关路由选择协议（IGRP）是由Cisco开发的距离向量路由选择协议。

    路由选择表维护协议（RTMP）是一个在两个AppleTalk区中选取最佳路径的Apple协议，大约每10秒广播一次。

    距离向量路由选择不适合于有几百个路由器的大型网或经常要更新的网。在大型网中，表的更新过程可能过长，以至于最远的路由器的选择表不大可能与其它表同步更新。在这种情况下，链路状态路由选择更可取些。另外，链路状态协议能够为安全起见把机密信息隔离在特殊区域，或避开网上正在进行计算机辅助设计（CAD）、多媒体通讯等拥挤区域。并且，路由选择信息表在必要时进行交换而不是规律性地交换，这样可以减少网络上的信息流量。

    链路状态路由选择协议

    链路状态路由选择比距离向量路由选择需要更强的处理能力，但它可以对路由选择过程提供更多的控制和对变化响应更快。路由选择可以基于避开拥塞区、线路的速度、线路的费用或各种优先级别。Dijkstra算法用于计算路由，根据如下：

    分组到达目的站经过的路由器数量，这叫做路由中继（hop），并且hop数越少越好。

    局域网间传输线路的速度。有些路由使用低速异步连接，而另一些路由使用高速数字链路。

    信息拥塞将造成延迟。如果一台工作站传送一个大文件，路由器可以通过不同的路径发送分组以避免交通阻塞。

    路由的费用，网络管理员定义的一个度量，通常是根据传输介质确定的。最便宜的路径可能不是最快的，但对某些类型的传输却更为可取。

    最常用的链路状态路由选择协议是优先开放最短路径（OSPF），它和OSI的中间系统到中间系统（IS－IS）是类似的。OSPF的原型是Proten开发的，是从OSIIS－IS的一个早期版本中派生出来的。OSPF在Internet和TCP／IP网上IP通信的路由选择中使用。IS－IS既可在IP通信中使用，也可在OSI通信中使用。

    OPSF路由选择表仅当在需要时更新，而不是定时更换。这有效地减少了通信流量和节省了网络带宽。通过网络的路径由上述标准选定。一个网络管理员可以根据信息传送的类型编制通过网络的路径。例如，当线路有较高数据传输率时，即使通过网络的那条路径有较多的hop数也是很可取的；另一方面，对于不大重要的信息将安排在低速低值的线路上传送。

    Autonomous Environments 自治环境

    Internet路由选择（TCP／IP）和OSI路由选择使用了一个自治系统（AS）或管理区域（AD）的概念，可以简单地理解成区域（domains）。一个区域是一些使用相同路由选择协议的主机和路由器的集合，如图R－11中所示，它们使用相同的路由选择协议和由单一机构管理。换句话说，一个区域可以是一所大学或其它机构管理的一个互联网。例如Internet是一个由教育部门、政府机关和各个公司管理的自治系统链接起来的互联网络。

    每个机构都有自己的内部网络，通过外部网关与Internet网连接（注：Internet网以前把路由器称作网关，但现在已把它们叫做路由器了）。Internet有内部网关协议和外部网关协议。OSI协议也使用了自治系统的概念，但在一个区域内的路由选择称为域内路由选择，区域之间的路由选择称为域间路由选择。

    实践中并非所有路由器对网上每一个其它系统都进行联络，所以可以有不同的协议、划分不同的区域。在Internet网上有几百万个地址！路由选择信息的组织是层次结构的，所以每个路由选择设备只需要有足够的信息就可以引导信息分组到下一个重要的路由器。

    内部／域内协议

    有许多种内部网关协议，并有几种在Internet网上常用，这些协议已在条目“AppleTalk路由选择”，“Internet路由选择”和“OSI的路由选择”中讨论。

    地址解析协议（ARP）是一个Internet（TCP／IP）协议，它为内部路由器传递数据报提供了一种方法。

    路由选择信息协议（RIP）是一种距离向量路由选择协议。

    优先开放最短路径（OSPF）是一种链路状态路由选择协议，它优于RIP。OSPF是Internet网中最常用的内部网关协议，但OSI IS－IS协议也用于Internet。

    端系统到中间系统（ES－IS）是OSI公布的一种协议，它帮助端系统（如用户的计算机）寻找定位路由器，并提供一种方法使路由器告知端系统（ES）它们的存在。

    中间系统到中间系统（IS－IS）也是OSI的一种路由选择协议，它为一个域内两个路由器之间传送信息分组提供动态路由。IS－IS是一种链接状态协议。

    内部网关路由选择协议（IGRP）是Cisco开发的一种距离向量路由选择协议。

    外部／域间协议

    在自治域的边界是路由器（以前在Internet网上被称为网关）。这些路由器和其它路由器用外部协议或Internet术语的外部网关协议（EGP）交换信息。

    外部网关协议（EGP）是Internet上最初的域间路由选择协议。现在它已被周边网关协议（BGP）取代了。支持EGP的路由器也必须支持BGP。

    周边网关协议（BGP）提供有关相邻点可达性信息。BGP可以减低带宽需求，这是因为路由选择信息是增量交换的，而不是在路由器间发送路由选择数据库信息。BGP也提供了基于策略的算法，使网络管理者对路由选择有较多的控制权，例如对某些信息传输实行优化的能力。

    域间路由选择协议（IDRP）是一种OSI无连接分组（CLNP）的OSI路由选择协议。IDRP包含路由选择的策略，但它不大可能在Internet上代替BGP。IDRP可用一种协议进行IP和CLNP的域间路由选择来增加对IP的支持。

    相关条目：Carrier Services电信服务；Layered Architecture分层体系结构；Networks 网络；OpenSystem Interconnection Model开放系统互连模型；Packets（报文）分组，包；Protocols，Communication通信协议；Protocol Stack协议栈；Routing，AppleTalk AppleTalk的路由选择；Routing，IBM IBM的路由选择；Routing，Internet Internet的路由选择；Routing，NetWare NetWare的路由选择；Routing，OSI OSI的路由选择；Routing Information Protocol路由选择信息协议；Routing Protocols路由选择协议；Wide Area Networks广域网。


  • AppleTalk路由选择 Routing，AppleTalk AppleTalk路由选择

    注意：对于路由选择技术的一般讨论请见“路由选择协议”条目。

    AppleTalk协议起初是为LocalTalk网——速度较低的传输介质设计的，后来增加了对以太网和令牌环网的支持。多个独立的Loca1Talk局域网可通过路由互连，形成互联网。对于以太网和令牌环网的支持以后被加到AppleTalk协议中。

    AppleTalk使用一个地址系统来唯一标识每个节点，以便实现局域网段间数据分组的路由选择。AppleTalk包括原来的地址技术及在1989年AppleTalk Phase2引入的新的扩展地址技术。原来的方案使用8位地址，每个网络允许254个站点，AppleTalk Phase2可支持1600万个节点，运行于大型网络上的增强AP－pleTalk。

    路由选择表维护协议（RTMP）负责维护地址表状态和与其它路由器进行有关网络状态信息的通信。这个协议在广域网上不适用，因为它需要在广域网上传送整个表。RTMP每10秒发送全部路由选择信息表（常有将近1M字节）。若网络中的设备不多的话，这种策略还可行，但在大型互联网中，这种额外开销严重影响了性能。

    在1992年，Apple公司提供一个AppleTalk基于更新的路由选择协议（AURP）改善了RTMP性能。RTMP在小型LAN上是允许的，但不适合于广域网。AURP不是取代了RTMP，而是完善了RTMP。两种协议的主要区别是，在互联网很稳定的情况下，在AURP链路上只有很少或没有路由选择交通量。对于AURP，仅在互联网中发生了变化时发送路由选择信息，而且仅发送变化的部分。当两个AppleTalk网并接时，AURP还自动映射地址并取消重复地址。

    在一个互联网中，AppleTalk路由选择是基于一个分组到达它的目的站所必须经过的最少路由中继（hop）数。AURP提供了一种改进的路由选择技术并把AppleTalk数据分组封装成TCP／IP或OSI分组的方法。Apple公司可能用链路状态路由选择算法，如优先开放最短路径（OSPF）或OSI的中间系统对中间系统（IS－IS）来代替AURP。

    AppleTalk网可分成称为区（zone）的逻辑网群，每个区都有区名，这使得用户很容易找到用户组或网络设备。区信息协议（ZIP）和RTMP、AURP一起工作维持与区名相配的网络号。这些信息由区信息表（ZIT）保持。当一个AppleTalk分组到达一个路由器后，分组内的区名与工作表相比较，这样路由器就能把分组转发给与接收站网络相连的端口。

    相关条目：AppleTalk AppleTalk协议；Layered Architecture分层体系结构；Networks网络；Packets（报文）分组；Protocols，Communication通信协议；Protocol Stack协议栈；Routing路由选择；Routing Protocols路由选择协议；Wide Area Networks广域网。


  • IBM路由选择 Routing，IBM

    参见Advanced Peer－to－Peer Networking高级对等联网（APPN）；High Performance Routing，IBM IBM的高性能路由选择；Layered Architecture分层体系结构；Packets（报文）分组，包；Protocols协议；Protocol Stack协议栈；Routing路由选择；Routing Protocols路由选择协议；Wide Area Networks广域网。


  • Internet路由选择 Routing，Internet

    注意：对于路由选择技术的一般讨论请见“路由选择协议”条目。

    Internet网（TCP／IP）路由选择体系结构与开放系统互连（OSI）体系结构类似。有一个层次系统，它由连接主机（用户计算机、服务器等）的子网组成。这些子网通过路由器与自治系统中的其它子网相连。通常，使用相同的路由选择协议和在同一管理机构控制下的子网和路由器组成一个自治系统（Autonomous System），也称内部系统或域。图R－11图示了自治系统。

    内部网关协议（Interior Gateway Protocols，IGP）用在一个域中交换路由选择信息，如路由选择信息协议（RIP）和优先开放最短路径（OSPF）协议。OSPF是与OSI的IS－IS协议十分相似的内部路由选择协议。在区域的边界，周边路由器将一个域与其它域相连。这些路由器使用外部路由选择协议（Exterior Routing Proto－cols）交换路由选择。外部网关协议（Exterior Gateway Protocol，EGP）为位于自治域边界的两个相邻的周边路由器提供一种交换消息和信息的方法。对于EGP的替代是周边网关协议（Border Gateway Protocol，BGP），它被用于提供改进性能，如指定路由选择策略的能力。

    Interior Gatewey Protocols 内部网关协议

    内部网关协议用于域内交换路由选择信息。下面是几种常用的路由选择协议：

    地址解析协议（ARP）ARP用于Internet和TCP／IP网，是一种邻居发现协议，它与OSI端系统对中间系统（ES－IS）协议相似。路由器和主机（用户计算机、服务器等）都使用ARP来相互通告。路由器把包含一个IP地址的分组广播出去。网络上有这个IP地址的计算机或设备回送自己的LAN地址。这些地址被存入路由选择表中，以备将来使用。另一个与ARR相似的协议，称为逆ARP（RARP），执行相反的任务，它根据已知的网络地址获得IP地址。

    路由选择信息协议（RIP） RIP使用距离向量算法（DVA）计算路由选择路径。在DVA中，路由选择的确是基于到一个目的站中最少路由中继（hop）数或到一个相邻路由器路径的费用计算出来的一个总的费用。RIP路由选择表与其它路由器大约每30秒钟交换一次，路由器就是基于新的消息来重新生成它们的路由选择信息表。如果一个路由器连到低吞吐量的WAN链路，那么它在重新生成路由选择表时就会落后。另外，交换路由选择信息表要增加网络额外开销，它会引起许多拥塞，进一步推迟路由选择表的更新。如果一条路由失败了，重新建立路由选择表所需的延迟将会推迟一条新的路由尽快地建立。

    优先开放最短路径（OSPF） OSPF是一个链路状态路由选择算法，它是由开放系统互连（OSI）中间系统对中间系统（IS－IS）域内路由选择协议所做的工作派生出来的。链路状态路由选择与距离向量路由选择相比，需要更强的处理能力，但提供更多路由选择处理控制和更快的变化响应，Dijkstra算法用于计算路由是基于分组必须跳跃（hop）过的路由器数、传输线路的速度、交通拥塞延迟和根据某种度量的路由器费用。OSPF路由选择表只在必要时更新和仅更新有效（变化）的信息。

    Exterior Gateway Pratocol（EGP） 外部网关协议（EGP）

    外部网关协议（EGP）提供一种方法，为两个位于它们各自域边界的相邻路由器交换信息和消息。外部网关协议还提供一种方法，为路由器相互交换路由选择信息。每一个域有一个或多个路由器被选作EGP协议路由器。

    每一个EGP使用内部网关协议和同一域内部的网关交换路由选择信息，以便它知道局域内端系统（主机）的地址。EGP与其它域内的EGP相连和交换有关各自域内端系统的路由选择信息。有了这些信息，网关就知道发送信息到域外其它系统的最佳路径。

    EGP的主要功能如下：

    执行相邻网关连接过程使两个外部网关相连和决定交换信息。

    通过发送一条消息周期性地核实相邻的路由器和等待一个响应，这将确保一个外部网关仍可采用。

    周期性地交换路由选择信息。

    路由器的EGP例行程序能够轮询相邻的路由器以获得更新的信息。通常要维持两张表，用内部协议如RIP和OSPF获得一张内部路由表，用EGP获得一张外部路由表。然而，EGP有下述周边网关协议（BGP）试图解决的缺点。EGP是在Internet组成单个主干网时设计的，它对于今天的多主干网不是有效的。路由器是用显式定义那些路由器能够连接的静态路由选择表设置的，这避免环路和提供安全性，但不支持一个可扩展的网络。

    Interdomain Policy Routing Protocols 域间策略路由选择协议

    几个新的域间路由选择协议被推荐在Internet网上使用。随着Internet网规模的扩大，现行的外部协议不能提供足够的扩展能力。实现基于策略路由选择的新协议比EGP更具有可扩展性（Internet的要求）。基于策略路由选择给管理员更多的网络控制、允许优化交通流量和实现安全特性以及服务收费。

    周边网关协议（BGP） 周边网关协议（Border Gateway Protocol，BGP）作为一种中间解决方法提供了一些有限的策略特性，但它没有解决可扩展的需求。路由器属性如一条路径的费用和安全性也被加入BGP。由于BGP的路由选择信息交换只传送增加的部分而不是整个数据库，所以它所需的带宽降低了。

    域间路由选择协议（IDRP） 域间路由选择协议（Inter Domain Routing Protocol，IDRP）是一个类似于In－ternet周边网关协议（BGP）的基于策略路由选择协议。策略路由选择提供了以预定方式路由传输的方法，它是一种距离向量路由选择协议，其中的每一种路由器为一个分组通过网络定义了一条路径。注意，IDRP是一个基于OSI的协议。

    域间策略路由选择（IDPR）域间策略路由选择（Interdomain Policy Routing，IDPR）是一个在域间实现源路由选择和基于策略的路由选择的链路状态路由选择协议。源路由选择由于分组本身保持路径信息而提供一些有用的增强特性。这对于初始发现路径是很必要的，但后继的分组只是简单地把路径放入自己的头部。

    相关条目：Domain域；Internet Internet网；Layered Architecture分层体系结构；Networks 网络；Packets（报文）分组，包；Protocols，Communication通信协议；Protocols Stack协议栈；Routing路由选择；Routing Protocols路由选择协议；Transmission Control Protocol／Internet Protocol传输控制协议／互联网协议（TCP／IP）；Wide Area Networks广域网。


  • NetWare的路由选择 Routing，NetWare

    注意：对于路由选择技术的一般讨论请见“路由选择”条目。

    Novell的NetWare网络操作系统使用网络层网间分组交换（IPX）数据报服务和顺序分组交换（SPX）面向连接的服务提供通信系统间的信息交换。下面的协议由路由器用于交换有关网点拓扑结构的信息：

    路由选择信息协议（RIP）RIP起初是为Xerox网络系统（XNS）开发的，现在为SPX／IPX和TCP／IP所用。RIP是一个距离向量协议，它对于广域网不是有效的。

    NetWare链路服务协议（NLSP）NLSP协议是Novell公司设计用于替换SPX／IPX使用的RIP协议，它改善了不同LAN段用户间的分组传送。每一个路由器都知道网络拓扑结构，路由选择表的广播通信量降低了。

    相关条目：Internetwork Packet Exchange网间分组交换；Layered Architecture分层体系结构；NetWare NetWare网络操作系统；Packets（报文）分组，包；Protoco1s，Communication 通信协议；Protocol Stack协议栈；Routing路由选择；Routing Protocols路由选择协议；Wide Area Networks广域网。


  • OSI的路由选择 Routing，OSI

    注意：对于路由选择技术的一般讨论请见“路由选择协议”条目。

    开放系统互连（OSI）环境由包括端系统（用户计算机或主机）和路由器的管理域组成。一个管理域通常使用相同的协议和由同一个中心机构管理。所有在域内的路由选择叫做域内（Intradomain）路由选择，所有在域外连接其它域的路由选择叫做域间（Interdomain）路由选择。域间路由选择涉及连到“不大可信”的环境，可是管理员宁愿手工设置通路，而不愿依靠路由选择协议自动构造域间通路。

    如图R－8所示，OSI路由选择体系结构是分层次的，它的组成如下：

    端系统对中间系统（ES－IS） 端系统（ES）在一个部门或工作组内，通过网络与其它部门或工作组相互通信。中间系统连到这个网上以形成一个路由选择域（routing domain）。

    域内中间系统对中间系统 中间系统可连到同一管理域内的其它中间系统，形成一种域内（intradomain）连接。

    域间中间系统对中间系统 管理域链接到其它管理域，形成一个互联网（internetwork）。

    ES－IS和IS－IS是用于交换路由选择信息的协议，不要把它们与OSI的数据传送协议：无连接网络服务（CLNS）和面向连接网络服务（CONS）相混淆。CLNS是工作在网络层的数据服务，可与互联网协议（IP）或NetWare的网间分组交换（IPX）协议类比。CONS提供会话（面向连接）服务并工作在运输层，可与Internet网的传输控制协议（TCP）或NetWare的顺序分组交换（SPX）类比。用于交换路由选择信息的实际协议是ES－IS和IS－IS。

    End System－to－Intermediate System（ES－IS）Protocol 端系统对中间系统（ESIS）协议端系统对中间系统协议是端系统用于找出同一网上其它节点网络地址的“邻居发现（neighbor discovery）协议”，这个协议仅用在端系统和路由器之间。重要的一点是，端系统只能看到它和需要与它通信的任何系统之间的一个路由中继（hop）。为发送一条消息给另一个路由选择域中的一个端系统（ES），ES先发送分组给它的本地IS，然后IS处理域内或域间的所有路由选择。

    ES－IS配置中ES的工作是相当简单的，它仅跟踪它能直接与之通信的其它系统的网络地址。这包括同－网上的其它ES系统，或是用发送消息给其它系统来提供地址的路由器。

    Intermediate System－to－Intermediate System（IS－IS） 中间系统对中间系统（IS-IS）

    中间系统对中间系统协议是一种将操作局限于某一管理域内的链路状态路由选择协议。在OSI路由选择层次结构中，这一级主要关心的是交换路由选择信息，并根据指明通过网络最佳路径的信息生成路由选择表。可能仅用一个路由器作为广播路由选择信息的路由器。

    IS－IS协议定义了一个区域，它是一组物理网络和连向网络的设备。在一个区域内互联网络的路由器叫做1级路由器，互连一个区域和另一个区域的路由器叫做2级路由器，一个路由选择域（routing domain）是由工作在一个行政管理单位的2级路由器连接的区域集合。路由选择用下述步骤进行：

    1．一个端系统发送一个分组给它的区域内任何直接连接的1级路由器。

    2．路由器确定目的站地址并沿着最佳路径发送分组。

    3．如果目的站地址是在另一个区域，1级路由器将把分组发送到最近的2级路由器。

    4．2级路由器朝前发送分组到另一个2级路由器，依此类推直到分组到达目的区域。

    5．在目的区域的1级路由器最后处理转发分组到端系统。

    Interdomain IS－IS Routing 域间IS－IS路由选择

    它在OSI路由选择层次结构的域间级，域间IS－IS路由选择处理管理域之间的通信。这一级的一个有趣的方面是，自动路由配置和最佳路由选择通常并不是必须用，因为在互连的域间可能存在着安全问题。也有费用问题，如谁为链路付款。还有授权问题，如允许不熟悉的用户进入网络。在这一级上自动交换路径通常不被推荐。网络管理员通常人工编制路由。

    域间路由选择协议（Inter－Domain Routing Protocol，IDRP）是一个在域间环境为无连接分组选择路由的OSI链路状态路由选择协议。它类似于Internet周边网关协议（BGP），并且很适应拓扑结构的变化，如关闭的线路或重配置的连结。

    IDPR原是为Internet设计的，因而很少用于进行网内路由选择。它依赖到它连接的域内端节点的可信赖的稳定路径。增加到IP协议的支持，IDPR可用一个协议进行IP和CLNP的域间路由选择。

    相关条目：Domain域；Layered Architecture分层体系结构；NetWare NetWare网络操作系统；Open System Interconnection Model开放系统互连模型；Packets（报文）分组，包；Protocol，Communication 通信协议；protocol Stack协议栈；Routing路由选择；Routing Protocols路由选择协议；WideArea Networks广域网。


  • RSA数据安全性 RSA Data Security RSA数据安全性

    位于加利福利尼州红杉市的RSA数据安全有限公司，是由公开密钥加密的发明者（Rivest、Shamir和Adleman）为开发和改进加密技术组建的公司。这家公司作为Internet上的验证权威，可为许多机构提供有关验证、公开密钥加密和其它信息安全服务。RSA公司的鉴别与加密方法在工业界应用很广。RSA公司的电话号码是415／592－8792。

    实现RSA公开密钥加密和数字签名的产品于1994年问世。例如国家半导体公司发布了一种适用于便携机PCMCIA插槽的“令牌（token）”卡，当卡插进计算机后，它保持着用户的私人密钥，并让用户在安全方式下操作。利用“令牌”卡，用户能够译码私人电子函件，对输出文件进行数字签名和在其它系统上进行自我鉴别。

    相关条目：Digital Signatures数字签名；Key Encryption Technology密钥加密技术；Security安全性。


 SAA　系统应用架构
：SAA(System Application Architecture)指IBM 的跨平台程式发展架构标准, 依据此架构开发的程式可在数种符合SAA标准的平台 (PLATFORM) 与作业系统 (OS) 上执行。


  • Scanner 扫描仪

    一种光学输入设备，它使用感光设备来捕获纸张上的图像或其他物件。图像被转变成可以被光学字符识别软件或图形软件所操作的数字信号。


  • Screen Saver 屏幕保护程序

    一种延长监视器使用寿命的实用程序，当你在某一段时间内不使用计算机时，屏幕自动变为显示一幅不断变化的图象。显示器随着不断的使用，性能会降低，特别是当一幅图象持续地显示时，这一图象就会“烧烛”屏幕的荧光粉，导致若隐若现的图象显示效果。长时间的使用也会降低屏幕的清晰度。Green PC监视器不需要屏幕保护程序，因为在不使用计算机时屏幕会自动变黑。


  • SCSI 小型计算机系统接口

    小型计算机系统接口(Small Computer System Interface)，现在这种接口已经不再局限于将各种设备与小型计算机直接联结起来，它已经成为各种计算机，包括工作站、小型机、中型机甚至大型计算机的系统接口。从八十年代初出现SCSI产品后，它一鸣惊人，迅速发展成为一种高性能的普遍采用的接口技术。从SCSI-I到SCSI-II技术不断成熟，从磁盘、磁带机、光盘等外围存储设备接口到各种外围设备，如打印机、扫描仪、计算机网络服务器、图象处理设备和工控设备等，应用范围不断扩大。采用SCSI接口比采用IDE接口的优点在于，它能明显提高I/O速度，而且比IDE容易联结更多的设备。但它需要专用的SCSI接口卡，整个系统的价格也要贵得多。


  • SDRAM 同步动态随机存取内存

    一种从90年代末期开始被广泛使用的动态随机存取内存。SDRAM以标准的动态随机存取内存为基础，但拥有可使数据传输速度更快的高级功能。首先，SDRAM的数据传输速度可以快到和CPU的时钟频率同步，其次，SDRAM可以被分为两个单元块，数据可以在两个单元块之间交叉存取，这样一来，当一个比特的数据在一个单元块中被存取的时候，另一个比特的数据可以在另外一个单元块中做好准备。

    SDRAM的数据传输速度最高可达1.1GB/秒，DDR SDRAM（双倍速率SDRAM）的数据传输速度可达2.2GB/秒。DDR SDRAM又被称为DSDRAM（倍速DRAM）和DDR DRAM（双倍速率DRAM）。


  • Search Engine 搜索引擎

    搜索引擎，在网络上进行检索的程序。它可以根据你提供的题目、内容、关键字等在整个网络或指定范围内检索到相关的网点名称、URL地址和摘要等信息。搜索引擎本身存在于提供这一引擎的公司网点上，比如IT垂直搜索引擎http://itsearch.ccidnet.com。


  • Serial Interface 串行接口

    一种数据传输模型，该模型中数据和控制位在一条通道上顺序发送。在串行输入/输出连接中，此术语通常表明使用 RS-232 或RS-422 接口。


  • Server 服务器

    是指任何在网络上允许用户文件访问，打印，通讯及其他服务的计算机。服务器一般拥有比单用户工作站更高的处理器，更大的存储空间，常配有大容量电源，UPS（不间断电源），采用了容错技术。


 SET 安全电子商务协议
：安全电子商务协议（Secure Electronics Transactions protocol），在Internet上进行安全商务行为的协议。它是GTE、IBM、MasterCard、Microsoft、Netscape、SAIC、Terisa Systems、VeriSign 及 Visa 努力合作的结晶。


  • SGRAM 同步图形动态随机存取内存

    一种和SDRAM非常相似的动态随机存取内存，不过，它拥有用于显示适配器，经过加强的图形处理功能。SGRAM拥有的Block Write和Mask Write功能，可使画面缓冲器更快的清除，并以更快的速度选择要改变的像素。


 SHTML　服务器解析HTML语言
：SHTML是Server-parsed HTML的首字母缩略词。包含有嵌入式服务器方包含命令的 HTML文本在被传送给浏览器之前，服务器会对SHTML文档进行完全地读取、分析以及修改。


 Smart Terminal　智能终端
：在多用户系统中，一个包含了自身处理电路的终端，不仅可以从主机检索数据，还可进行其它处理操作，并运行主机传送来的程序。


 SMP 对称多处理结构
：SMP（Symmetric Multi-Processing），对称多处理结构的简称，在高性能服务器和工作站级主板架构中比较常见。可以简单的理解为多CPU的系统。构建一套SMP系统的必要条件是：支持SMP的硬件包括主板和CPU；支持SMP的系统平台，如WINNT、LINUX、以及UNIX等等32位操作系统；再就是支持SMP的应用软件。


  • SMP 对称式多处理器

    Symmetric Multi-Processor的缩写。就是可以让几个CPU同时工作，交替运行技术。这样就提高了CPU的工作频率，相对也就提高了服务器的整机性能。


  • SMTP 简单邮件传送协议

    简单邮件传送协议(Simple Mail Transfer Protocol)，它就是TCP/IP电子邮件交换协议，用于电子邮件的发送。


 SNA 系统网络结构
：SNA(Systems Network Architecture)，计算机网络结构协议，可在网络节点和路由器之间建立高效的路径。SAN使用SDLC协议，这是异步和二进制同步设备访问SNA的唯一途径。


  • Socket 7 接口结构

    它是一种接口结构。计算机从486开始普遍采用Socket插座来安装CPU，从Socket 4、Socket 5一直延续到现在的Socket 7。Socket 7是方形多针脚ZIF（零插拔力）插座，插座上有一根拉杆，在安装和更换CPU时只要将拉杆向上拉出，就可以轻易地插进或取出CPU芯片了。Socket 7插座不但可以安装Intel公司的Pentium系列产品，还能安装AMD公司的K5、K6和K6－2，Cyrix公司的6x86、6x86MMX和6x86 MⅡ和IDT公司的Winchip C6也可以安装。适用范围非常广。


  • SOHO 小型办公与家庭办公

    SOHO(Small Office/Home Office)小型办公室与家庭办公，在小型办公室和家庭办公室中的计算机、办公设备和服务市场划为一组。目前流行的SOHO一族一般指在家庭办公的人。


  • SONET 同步光纤网

    它是连接光纤传输系统的标准，是美国国家标准化组织在80年代中期开发的。它是一个全球的物理网络，非常象局域网中的以太网双绞线电缆。SONET可以使用1Gbps以上的速度发送数据，而且能够发送数据、语音和图像。


 SSL　安全套层
：SSL是由Netscape公司提议的Internet上的安全标准，并用于该公司的Netscape Navigator浏览器和Netscape商务服务软件。


  • SSL 安全套接层协议

    SSL协议（Secure Socket Layer，安全套接层）是由网景（Netscape）公司推出的一种安全通信协议，它能够对信用卡和个人信息提供较强的保护。SSL是对计算机之间整个会话进行加密的协议。在SSL中，采用了公开密钥和私有密钥两种加密方法。


 Subnet 子网
：网络的一部分。它是物理上独立的网络段，与网络其它部分共享网络地址，并用子网号区分。


  • Sun公司的 SunNet Manager SunNet Manager，Sun Microsystems，Inc．

    Sun微系统公司的SunNet Manager是一个使用平台体系结构方法的网络管理系统。SunNet Manager平台处理网络管理系统的所有核心功能，如通信协议接口、数据定义和其它的管理功能。其它的产品可通过插入或与平台接口而获得所有其内置的功能。这些功能包括访问多协议网、多供应商系统和数据管理系统。

    SunNet Manager是一个管理应用程序的开发平台，这个平台提供了一个OSI管理代理模式，并且通过Sun开放网络计算（ONC）策略和简单网络管理协议（SNMP）以及其它协议提供对第三方产品的支持。这些产品在TCP／IP通信协议上运行。OPENLOOK图形用户接口使网络管理员可察看网络情况，并简化了系统和事务的管理。

    相关条目：Distributed Computing 分布式计算；Enterprise Networks 企业网；Management Standards and Tools管理标准与工具；Open Network Computing，SunSoft SunSoft的开放网络计算；Simple Network Management Protocol 简单网络管理协议；Sun Microsystems，Inc．Sun微系统公司。


  • SunSoft的SunOS操作系统 SunOS，SunSoft

    SunSoft是Sun微系统公司的商业部门，并且SunSoft的SunOS是一个包括UNIX SystemV版本4（SVR4）的软件环境。这个软件包含ONC并且是Solaris操作环境的基础。

    基于UNIX SystemV版本4（SVR4）的SunOS 5．0，由SunSoft增加了下列扩展功能：

    带有多线程的（multithread）对称多处理。

    实时扩充。

    增强的安全性。

    改进的系统管理。

    SunOS5．0借助一个多线程操作系统内核来支持对称多处理。多个线程可以在操作系统中并发地执行，并且多个处理器也可以在同一个操作系统内核部件如文件系统或一个设备驱动程序内并行处理。SunOS5．0操作系统内核也支持应用程序级的多线程，这样独立的应用程序可以在多个处理器上并发运行。

    SunOS还有以下特点：

    增强了安全性，如能够从低级到中级或到高级增加安全级别和能够使口令过期和控制登录。

    提供Kerberos服务进行鉴别。

    一个面向对象管理系统的框架。

    网络信息服务加（NIS+），一个对网络的分布式命名服务，为简化管理提供了一个分层命名空间。

    全局操作的国际化。

    相关条目：Distributed Computing 分布式计算；Distributed Objects Everywhere，SunSoft SunSoft的全分布式对象；Enterprise Networks 企业网；Open Network Computing，SunSoft SunSoft的开放网络计算；Security安全性；Sun Microsystems，Inc． Sun微系统公司。


  • 超级用户，监管员 Supervisor

    超级用户是一个负责管理和维护网络的用户。这个术语在NetWare网上有特殊的含义。超级用户对所有的文件卷宗、目录和文件有完全的访问权，它是安装后第一个登录到服务器上的用户。然后超级用户立即改变口令，于是没有其它用户能够访问服务器和获得超级用户无限的访问权。

    在NetWare4．x中，系统管理员对整个企业网有完全的控制权。典型地，管理员是安装网上第一台服务器的用户并定义这个组织的NetWare搜索服务（NDS）结构。其它服务器可以加到网上和成为初始结构的一部分。网络管理员可以建立类似超级用户的用户控制网上某特定的区域，如某一部门或部门的服务器。

    相关条目：Administrators，NetWare 4．x NetWare 4．x的管理员；Directory Services，NetWare NetWare的搜索服务。


  • 浪涌电压抑制器，电涌抑制器 Surge Suppressors

    浪涌电压抑制器的主要功能是保护系统免受浪涌高压的损害。不间断电源（UPS）用来防止电压下降和电源断开，大部分台式系统的电源可以处理高达800伏的浪涌电压。浪涌抑制器可以阻止高于这个级别的电压。现在出售的大多数浪涌抑制器将浪涌电压转移到地线，但在有些建筑物的布线中，浪涌电压可能会重新出现在其它计算机系统中。有的浪涌抑制器使用线圈和电解电容来吸收过剩的能量，而不是将能量分散到地下。地线分散法主要用来保护浪涌抑制器本身不被烧坏。现在很多抑制器还采用这种技术，但是将来更有效的抑制器将避免采用它。

    浪涌保护额定电压应该高达6000伏。保护装置都配备了电磁干扰（EMI）和射频干扰（RFI）噪声过滤电路。然而大多数台式系统的电源中已经有这种过滤器，所以你应当用怀疑的态度来看强调EMI／RFI噪声过滤器的广告。

    必须谨慎使用瞬间电压浪涌抑制器（TTSS）技术的浪涌抑制设备。这种抑制器可以防止大的瞬间高压，如闪电雷击，但是对低到一定程度而对电子设备仍然有害的瞬间电压无抑制作用。况且它把瞬间高压引到地下，而它们有可能返回其它设备。当网络有多个接地点时，情况就恶化了。

    相关条目：Power and Grounding Problems and Solutions 电源和接地问题及解决办法。


  • 交换式多兆位数据服务 Switched Multimegabit Data Service

    交换式多兆位数据服务（SMDS）是一项本地交换电信局（LEC）在城域范围内提供一种扩展局域网服务的方法。SMDS是由Bellcore公司开发的并在许多大都市区由本地交换电信局提供的服务。注意，SMDS象ATM一样使用了定长信元中继技术，电信局提供的SMDS服务运行在异步传输模式（ATM）之上。

    作为交换技术，SMDS优于用专用数字线路建造专用网（如T1）的技术。客户愿意建立一条适当带宽的线路到本地交换电信局的SMDS网，而不愿意在他们所有需要互连的站点间建立多条线路。SMDS是一种无连接、基于信元的传送服务，它能在许多站点之间提供任何点对点的联系，而无需呼叫建立和撤消过程。所以SMDS具有在大都市区扩展LAN类型通信技术的能力。一旦信息传到了SMDS交换网，它就可以连接到网中任何站点。

    SMDS交换技术提供客户多种联结选择以适应变化着的事务需要。服务的费用通常要按月收费，这对在许多站点之间需要交换联结的用户来说是非常理想的。由于本地交换电信局是SMDS服务的主要提供者。一般在那些地区没有服务竞争。不过客户或许想权衡一下是用SMDS还是如帧中继之类的其它交换服务。

    SMDS是一种“快速分组”技术，由终节点来进行检错和流控过程。如果一个分组丢失了，接收的节点请求重发。网络本身不承担这种检错任务，由端系统从事更多的工作，这是利用了现代通信设备很少有错误的优势。下面叙述三种快速分组技术：

    SMDS是一项在大都市区采用的定长信元技术。交换电路或专用电路提供客户站点到SMDS网络的联结。传输速度范围从1Mbps到16Mbps或将来更高。

    帧中继是一个广泛应用于实现本地与全球联结的变长分组技术。它的速率是56Kbps至1．544Mbps。

    ATM 是一项崭露头角的高带宽技术，它将在全球范围内提供优质的定长信元中继技术。

    图S－13展示了客户连到电话公司的SMDS网的基本配置。

    SMDS与IEEE 802．6城域网（MAN）标准和宽带ISDN（B－ISDN）网兼容，然而SMDS提供了MAN标准中没有规定的管理和记帐服务。SMDS使用分布式队列双总线（DQDB）作为网络的接口和访问方法。SMDS网是一种双总线结构，形成一个不封闭的环。物理上，它看上去是一个星形网，就象令牌环网那样所有的电缆都连到一个中心结点。如果总线出了故障，原先未封闭的部分将自动连结起来以维持环路。DQDB总线上充满了时间片，任何连接的设备和站点均可以把数据放入时间片进行传送。想象一下挂满车箱的火车，把数据装进车箱中可运行到另外的地方。

    DQDB提供了真正的多路访问总线技术，因为任何节点在需要时都可以访问总线直至网络饱和了。DQDB总线允许多至512个节点、距离扩展到160公里和工作在150Mbps的速率。时间片访问能被控制以防止某些节点占用太多的槽。槽的大小是53个字节，5个字节用于标头信息，48个字节用于数据。一个发送节点可以发送多至9，188个字节的分组，它们被分成较小的48个字节的数据块以适合SMDS槽，在接收端被重新装配。标头信息与槽中数据组成一个信元整体。

    大多数电信局为顺应ATM的发展，或者安装SMDS作为步向ATM的台阶，或者提供大部分ATM服务。MCI和GTE公司正在使用SMDS，但是AT＆T正在推进ATM。SMDS 由于增强了许多服务而不同于ATM，例如SMDS提供了依据使用记帐和一些有益的网络管理功能。它把分组建在信元结构的顶层，充分发挥分组特性和快速信元交换两者的优势。分组特性包括特殊组或屏幕数据分组编址能力。客户必要时能够通过SMDS 网建造一个逻辑专用网。

    许多工业分析家认为，由于帧中继和ATM技术的发展，SMDS将不会流行。电信局已较慢地采用SMDS，它并不是在每一个大都市区都被采用。现在，帧中继连结设备差不多是相应的SMDS设备价格的六分之一。

    SMDS利益集团（SIG），一个本地与远程电信局、SMDS户品供应商、服务提供者和终端用户的联合组织，位于加州Mountain View（电话415／962－2590）。SIG由许多用户组和工作组组成，工作组致力于宣传SMDS、从事改进标准和促进兼容性的规范制定。有一个技术工作组专门开发一些新的规范，提供对传输控制协议／因特网协议（TCP／IP）、系统网络体系结构（SNA）、互联网络分组交换（IPX）、AppleTalk、DECnet等协议的支持。这个技术工作组也从事帧中继封装方法的研究。一个局间工作组（intercarrier working group）由规定局间SMDS的互连和管理的电信局组成。一个公共关系组和一个用户组负责组织研讨会、教育会议和统计SMDS被普通采用的信息。

    相关条目：Asynchronous Transfer Mode异步传输模式；Carriers电信局，通信公司；Carrier Services电信服务；Frame Relay 帧中继；Local Exchange Carrier本地交换电信局；Packet－Switching Networks分组交换网；Switched Services 交换式服务；T1／T3 Services T1／T3服务。


  • 交换式服务 Switched Services

    交换式服务是一种远程通信业务，它提供给客户更加灵活的广域网选择，而不是使用专用的租用数字线路来建造专用网通信。在图S－14左面显示的专用网中，客户要安装自己的交换设备，然后从本地交换电信局和／或长途交换局租用专用线路与所有远程站点互连。客户完全占用专用线路。利用公共交换服务的客户有两种服务选择，这就是下面将讨论的电路交换服务和分组交换服务：

    电路交换服务（circuit－switched services）在暂时联系的两个站点之间提供高质量的数字线路，给那些不需要所有时间专线服务的客户仅当需要时获得高速专用数字线路提供了经济选择。

    分组交换服务（packet－switching services）为网状分组交换网中的同时发送者提供任何点对点的连结。分组交换网与专用网的比较见图S－14所示。

    记住，客户仍然需要交换线路或专用线路访问分组交换网，但是连接线路的距离通常较短和费用较低，并且只需要一条线路连到网，而不是一条线路连一个站点。

    为了克服专线的某些问题和为客户提供更经济的服务，电信局既可提供电路交换服务，也可提供分组交换服务。这些交换服务有三个重要的特点：

    交换服务能够提供任何点对点连结。客户能够改变链路的端点以适应变化着的事务需要，象一个办公室的搬迁和增加新的客户。

    交换服务能够提供按需的带宽。在通信高峰期间，可采用更多的带宽。

    费用是根据客户实际使用计算的，不象租用线路，客户必须按期付费，即使线路有部分时间没有使用。

    Circuit－Switched Services 电路交换服务

    电路交换网设法在呼叫设备和被呼叫设备之间建立物理信道。这种线路的特性包括两个站点必须以同样的固定的数据速率进行操作。它需要一个建立阶段，但是现在由AT＆T这样的交换局使用的数字交换设备把建立时间降低到几个毫秒。综合业务数字网（ISDN）把数据传输的所有方法都提供给客户，以高至64Kbps的速率传送，不需要调制解调器。其它的电路交换服务包括Switched－56和拨号线。

    数字交换电路为许多交换局使用，如Ameritech和Bell Atlantic这样的地方Bell运营公司（RBOCs）和象US Sprint、MCI、AT＆T这样的长途交换局。这些服务适合于互联网以及图象和视频的传送，它们也用于传真机的连接和作为备用线路。Switched T1是一项AT＆T在1962年首次推出的基于T1技术的相当新的服务。

    Switched－56

    Switched－56服务作为电视会议的经济链路、局域网之间的连结、Group4传真机互连和为远程交换机（telecommunicaters）的高速服务等流行起来。传统上，它的快速建立和交换特性用作备用线路处理来自其它连结的超载通信。费用通常比固定的租用线路便宜，但需要特殊的连结设备。参见“Switched－56服务”。

    综合业务数字网（ISDN）

    ISDN在家庭或事务用户之间的本地环路上提供全数字服务。ISDN有三条信道，2条64Kbps的数据信道和1条16Kbps的信令信道。详细叙述参见“综合业务数字网”。

    AT＆T交换式数字服务

    AT＆T提供一套电路交换数字服务，许多服务已经采用了多年。

    ACCUNET Switched－56、64、384、1536Kbps服务。Switched－384和Switched－1536服务仅在ISDN链路上实施。

    软件定义数据网（SDDN）是一项速率为56、64、386Kbps的服务，它具有容量折扣价格、专用编号图表等功能以及象呼叫方筛选（屏蔽、隔离Calling-party screening）这样的ISDN所具有的较高特性。

    交换数字国际（SDD在20个国家提供56Kbps和64Kbps速率的交换服务。电视会议和Group 4传真机互连通常使用这些线路。

    全球事务视频服务（GBVS）提供多点式电视会议。

    专用线的价格是固定的，交换线的价格基于使用情况。图S－15表明AT＆T关于Switched－56Mbps线路和专用56Mbps线路价格交叉点的测算。

    MCI通信公司虚拟专用数据服务

    MCI通信公司通过它的虚拟专用数据服务提供Switched T2和Switched T3服务。价格根据距离和连结时间计算。SwitchedT1开始时第一个30秒内为2．50美元，然后对于55英里范围内每延长6秒钟就增加20美分；对于超过1，910英里的通信收费差不多就翻倍了。Switched T3开始时第一个30秒内为37．50美元，然后对于55英里范围内每延长6秒钟就增加3．00美元；对于超过1，910英里的通信收费也差不多是翻倍。

    Packet－Switched Services 分组交换服务

    分组交换网通过一个网络把标有地址的数据分组从一个地方发送到另一个地方，网络中不是一条单一的线路，而是一个网状的线路。与一个分组交换网连结的局域网的许多用户能够同时发送数据分组到分组交换网上许多不同的目的站点。这种服务是无连接的，意味着没有必要建立一条专用线路，许多逻辑线路能够通过网络建立，网络可提供面向连接的服务，如分组确认和流控。虚拟线路在分组交换网上可提供专用线路或电路交换的全部好处。

    一个分组交换公共数据网（PSPDN）由于许多可能的连结常常被画成一朵云，就如图S－14右边所示的那样。这种类型的网络提供任何点对点的连结，相对于电路交换网，它在两个系统之间提供一个暂时的专用连结。PSPDN是由交换局组成的。交换网负责检验数据分组并且从一个特指的端口发送，然后分组沿着选择的最佳路由到达各自的目的站点，这很象铁路上火车转运站或是商业区的汽车交叉路口。分组被限制一定的长度，防止极长的分组阻塞交换局和防碍其它分组通过。

    象异步传输模式（ATM）这样的分组交换网正崭露头角，它们可提供每秒兆位级的传输速率。“快速分组”服务正在提供一些新的方法在广域网上通信。参见“分级交换网”条目。

    相关条目：Cell Relay 信元中继；Circuit－Switching Services 电路交换服务；Frame Relay 帧中继；Packet－Switching Networks分组交换网；Switched Multimegabit Data Service交换式多兆位数据服务；X．25 X．25协议。


  • 交换式虚电路 Switched Virtual Circuit

    虚电路是一条通过网状分组交换网的通路，它作为一条专用线路出现。交换虚电路（Switched virtual circuit－SVC）则是在端站点间建立的会话连结，需保持一段会话时间，在会话结束时断开连结。永久虚电路（Per－manent virtual circuit－PVC）是一条由网络分配和维护的固定线路。线路总是畅通的，不需要建立和断开的时间。一般，在路由器间建立一条PVC，因为为了在一个动态网络环境中传输路由信息必须维持一条不间断的连结。

    相关条目：Virtual Circuits虚电路。


  • Switched－56服务，交换式56服务 Switched－56 Services

    Switched－56是一种数字传输技术，在交换式同步线路上传输率是56Kbps，在交换式异步线路上速率是57．6Kbps，但是使用压缩技术可使带宽增加4倍。通过拨号建立通道，所以只有客户需要时才使用服务，或建立一条链路来处理另一条线路的数据传输溢出。Switched－56可用于电视会议、局域网到网的连接、Group4传真互连和用作远程交换机的快速服务。Switched－56和综合业务数字网（ISDN）使用同一类面向电路服务。但ISDN提供两条64Kbps信道（一条信道处理语音通话的同时另一条信道处理数据）。Switched－56只提供了一条56Kbps的信道，并且它使用更广。

    Switched－56的客户会认为选择它是明智的，因为它基于拨号模拟线路之上。而比租用线路如T1或部分T1（Fractional T1）便宜得多，而且Switched－56也可作为这些线路的补充。Switched－56线路的建立费用比模拟电话线路高，然而通话费用与普通的拨号电话通话费用差不多。太平洋贝尔运营公司最近宣布对使用线路时间长于两年的专用户，将不收装置费（大约500美元加一个月服务费）。

    Switched－56线路是数字线路，不需要调制解调器。替代的是需要一个CSU／DSU设备将局域网上的路由器连到电话公司安装的Switched－56电话线。图S－11是一个典型的两个局域网之间的Switched－56连接，连接的每一边都需要一个CSU／DSU。一般路由器与CSU／DSU之间的接口是一个V．35串行电缆，一旦设置完毕，这条线作为拨出线路。这条线也有一个电话号码，你可从远程场点拨号。

    Switched－56适用于低传输量的局域网环境，在这个环境中，信息传输是以突发方式或电子函件定期地传送到其它场点。Switched－56在早期使用9600bps的调制解调器来处理任务的站点上扩大流行。它也对快速数字线路如T1提供备份支持。例如，在传输量超出了T1线路的负载能力情况下，Switched－56线路可自动拨号来处理超载，如下描述。

    配有相应的客户资产设备（CPE），Switched－56可以提供有求必应的拨号连接来满足需要的带宽。CPE有很多端口，每一个端口都与一条Switched－56线路连接，如图S－12。逆向多路复用器用来将客户信号分布在多线路上输出。在接收端，有一个类似的设备重新组合这些信号。这种设备根据需要自动建立线路，并随着通信量降低自动关闭线路。这在一天中某些时候通信量增加而用户又不想租用部分时间不使用的专用线路的情况下，对局域网环境是一个理想的安排。 门提供的服务使用多

    电信局正在推销Switched－56服务作为低价传输、语音、数据和视频图象的产品。他们种叫法。例如太平洋贝尔运营公司称之为交换式数字服务集成系统（SDS－56），传输率也可变。太平洋贝尔公司收取一次性安装费、每月服务费和每条通道的使用费。前面已提到过，这个公司将对使用期超过2年的用户免收一些费用。

    相关条目：Carrier Services 电信服务；Channel Service Unit／Data Service Unit通道服务单元／数据服务单元；Circuit－Switching Services 电路交换服务；Wide Area Networks广域网。


  • 交换式集线器 Switching Hubs

    交换式集线器是一个能在共享网络拓扑结构中减少竞争访问的设备，其采用的技术是用微分段的方法来减少一个段上的节点数。在一个经微分段后的网上，一个局域网络段上的节点可能少至只有一个。这时，交换式集线器处理那些不同网络段上需进行通信的节点间的所有连接。注意这里所述的交换技术不同于前面所讨论的端口交换技术，端口交换实质上是一个管理功能，借助这个功能，管理者可使用一个管理程序而不是物理地移动集线器的电缆来把工作站在逻辑段之间进行移动。有了交换技术，LAN可被分段，类似于一个桥接器，交换式集线器处理段之间的数据传送，但交换式集线器的吞吐率不会低于桥接器的吞吐率。最初，交换式集线器是为部门使用设计的，并且建在其自己的底板上。而最新的交换式集线器是一些模块化单元，它们位于企业集线器之中。

    如果你有一个由20个用户组成的网，因为信息传输量超载而停止运行，你可以将其分拆成两个段并桥接它们，这样就会减少整个系统的数据传输负载，并减少每一个新网络段上的竞争访问。位于同一网段上的所有用户或设备彼此之间能正常通信，只有这样才会减少段之间的通信量。如果通信量仍有问题，你还可以将LAN分成4段、6段等等。交换式集线器可恰到好处地完成这种分段。一个集线器上有很多端口，每一个端口是一个专用LAN段。

    交换集线器通过一个内部矩阵开关处理网段之间的通信。所有的交换都在介质访问控制（MAC）层处理。当一个分组到达一个交换器，它的目的地址很快被识别，并且建立一条到相应终端网段的通路，后继分组通过交换器中继，而不需要存储转发分组。存储转发是桥接器必须要的。

    多数交换集线器适用于以太网，所以连接到端口的一个单独的工作站可达10Mbps的吞吐率。因为没有其它的工作站共享这个端口，也就没有竞争产生，这个工作站就获得了这个网段上的整个带宽。一些厂商同时还在生产令牌环交换式集线器。高速交换式集线器也适用于异步传输模式（ATM）交换式底板。

    交换式集线器的设想最早是Kalpana公司在它的EtherSwitch中提出来的。EtherSwitch技术也用在其他厂商的产品中。例如HP公司将其集成到它的EtherTwist集线器上，并且SynOptics通信公司也在LattisSwitch 3000系列集线器中使用EtherSwitch技术。


  • 对称多处理 Symmetrical Multiprocessing

    参见“Multiprocessing 多处理”条目。


  • 同步通信 Synchronous Communication

    当两台设备交换数据时，它们之间存在一个信息流，叫位流（bit－stream）。任何一种数据传输中，发送者和接收者都必须有一个可从传输的位流中抽取出独立的字符或块（帧）的方法。假设我们位于一条数据管道的末端，而字符是以连续的位流的形式出现的，因此你需要用某种方法来分隔位流中的数据块。在异步通信中 ，字符是以标志分隔的，所以你可精确地知道一个字符的开始和结束，发送者将标志放在两个字符中间。在同步通信中，发送者和接收者用时钟来控制彼此之间的同步。例如，每秒钟你取下并获得一块数据位。

    同步通讯中的关键问题是发送者和接收者必须使它们的时钟同步，这样接收者才能精确地知道新的字符从哪儿开始，为了维持长期的时钟同步，一个特定的位转换（bit－transition）模式被嵌入数字信号帮助维持发送者和接收者之间的定时。一个嵌入定时信息的方法被称为双极性编码（bipolar encoding），如图S－16所示。在这种方法中，如图S－16中上部的位流与图中部的时钟脉冲结合产生图下部的传输信号。注意位流与时钟脉冲组合后值的变化，根据位的值建立了一个正值或负值的时钟信号。

    同步通信有面向字符和面向位两种。面向字符传输是用于发送字符块的。如ASCII码文件每一块必须有一个开始标志，类似于异步通信，这样接收系统可以初始化位流同步和确定字符块的开始。两个或多个控制字符作为同步空位（Synchronous idle－SYN）字符可被发送者插在位流前部，这些字符是用来使一块信息同步。一旦发送者和接收者间确实同步了，接收者将接收的块以字符形式放在一个内存缓冲区内。

    面向位的同步通信主要用于二进制数据的传输。它不限于任何特殊字符集并且帧内容不需要包括多个八位标志。一个唯一的8位模式（01111110）是作为一个帧的开始标志使用的。

    相关条目：Synchronous Data Link Control 同步数据链路控制（规程）。


  • 同步数据链路控制（规程） Synchronous Data Link Control

    SDLC是七十年代开发的IBM定义的数据链路控制协议，其目的是通过广域链路与SNA环境中的IBM主机系统进行通信。SDLC基于面向位的同步操作，与之对应的是面向字节的协议如Bisync。IBM向标准委员会提交了SDLC，使之新增了如下标准，而SDLC仍然是SNA中主要的串行链路协议。

    ANSI从SDLC建立了高级数据通信控制规程（ADCCP）。

    ISO建立了高级数据链路控制规程（HDLC）。

    CCITT修改HDLC建立了链路访问规程（LAP）和平衡式链路访问规程（LAP－B）。

    在SDLC中，一个主站控制其它辅站的操作，主站轮询辅站是否有数据要发送。如果一个辅站有数据要发送，当它被主站识别后开始传送。主站负责建立和维护链路。有四种基本连接方式：

    点对点（Point－to－point）一个主站与一个从属站直接连接。

    多点（Multipoint）一个主站与多个辅站连接。

    环路（Loop） 一个主站通过环形配置与多个辅站连接，这种结构中，消息从一个站传到下一个站。

    集线前进（Hub Go－Ahead）这是一种很少使用的环形配置，它用菊花链电缆从主站连到辅站，然后返回主站。

    SDLC在分离帧时使用了一个典型的有界限标志信息的帧格式。一个地址域（address field）包括辅站的地址，一个控制域（Control field）说明帧类型，并且一个帧检测序列（Frame Check Sequence－TCS）包含错误检查值。

    一个典型的SDLC配置是多个位于远地点处的3270哑终端构成的。而这些哑终端均连向如 IBM 3270型的簇控制器。簇控制器通过一条租用的56Kbps线路与主机系统连接。许多公司如Cisco等改进了这个连接方案。Cisco路由器可以在点对点串行链路上进行纯粹的SDLC传输，并且可在这些链路上多路复用其它的协议数据。为在非SDLC网上传输，我们可以在IP数据分组中封装SDLC帧，这种方法通过使用路由选择协议（如Cisco的内部网关路由选择协议IGRP）向用户提供了路由选择而不是桥接功能。

    相关条目：High-Level Data Link Control高级数据链路控制（规程）。


  • 同步光纤网 Synchronous Optical Network

    SONET是Bellcore于八十年代中期首先提出的用光导纤维传输的物理层标准。它被ANSI标准化并被CCITT推荐在全世界推广。我们可以用看待Ethernet双绞线局域网作为机构网通信系统的同样观点，来看待SONET作为一个全球性通信系统的物理网。这是一种潜在的全球性网络，在光纤上具有标准的数据传输率，并在世界范围内被广泛接受。SONET使世界各电话公司融为一体。

    SONET定义了同步和等时（时间敏感数据，如实时视频）信息的传输。用SONET，电信局就可以为客户提供一种方法——开始在城市级最终在全球级建造快速网络。这是因为SONET为电信局提供了一种途径——在全球范围内互连它们的通信设备。因为国际性数字信息传输率各不相同，这阻碍了全球通信系统的发展。例如美国的DSI使用1．544Mbps，而欧洲的对应系统E1使用2．048Mbps。SONET规定了不同级别的数字传输率，如表S－1所示。

    SONET制定了传输信号的光导纤维网，广域网技术如SMDS和ATM可在其上运行。由于采用了信元中继技术，而不是变长帧技术，因此很容易提高SONET网上的传输率，详见“Cell Relay 信元中继”条目。

    SONET有如下规定：

    传输率、光纤接口、操作和维护。

    表S－1所示的全球一致的分级光信号传输率。

    同步电路上的多路复用通道。这种结构提供了一个方法能准确地知道帧被定位在哪一个具体的通道上并且可以取出这些帧，而不用分路全部的多路传送信号。这样，网上有不同类型的通道（低速和高速），用户可进行多种路由选择。

    光导纤维传输标准允许不同厂商产品和通信公司的系统互连。

    组成SONET的电缆铺设于SONET多路复用设备之间。SONET规定了光纤电缆和发生光的规范，另外还包括数据的多路传送和帧的生成。SONET信号 以同步数据流形式运载数据和控制信息。控制信息被嵌入信号中并被看作是辅助操作（OVERHEAD）。SONET信号的辅助操作包括下面几部分：

    分段（section）辅助操作处理帧生成和差错监控。线路上的所有设备都将使用这个特性。

    线路（line）辅助操作用于监控线路状态。

    路径（path）辅助操作用于控制网上端点（路径终端设备）间的信号传送和差错监控。

    SONET规范也规定了低速信号如T1／E1和T3／E3是如何被插入同步传输的。SONET服务突破了T3（45Mbps）的限制。其基本的光导传输率51．8Mbps相当于一个T3线路或28个T1线路。高档OC－48光导载波可相当于1344个T1或48个T3线路。最初，OC－3传输率将提供客户对电信局的服务，九十年代高传输率的应用将会增长。

    光缆提供极大的带宽，这将使广域网的价格下降到人们可承受的范围内。很多公司将建网使得远程用户与本地用户拥有同样的数据访问速度，以增强远程用户通信和竞争的能力。铜线不能提供光缆那样的可扩充性，因为提供同样的带宽需要太多的铜线。

    相关条目：Asynchronous Transfer Mode异步传输模式；Carrier电信局，通信公司；Cell Relay 信元中继；Fiber－Optic Cable光（纤电）缆；Telecommunication电信，远程通信；Wide Area Network广域网。


  • 系统容错 System Fault Tolerance

    这个特性允许你为一个系统提供硬件冗余。容错是更一般的术语。Novell公司用SFT来描述NetWare中的容错特征。SFT允许你安装两个硬盘，并且在辅硬盘上的内容是主硬盘内容的镜像（参见“磁盘镜像和磁盘双工”）。如果主硬盘发生故障，辅硬盘就接替它的工作。磁盘控制器也可以双份，或双工工作以进一步防止硬件发生故障。SFT Level Ⅲ（可选）通过双工整个服务器而进一步提供了冗余性。假如主服务器停机时，辅服务器无间断地接替它的工作。

    相关条目：Fault Tolerance 容错。


  • IBM的系统对象模型（SOM） System Object Model（SOM），IBM

    IBM的SOM是一种面向对象的技术，目的在于通过面向对象技术来改进现在的结构化程序设计。它是一种自然语言技术，允许以不同语言写的类能一起工作，前提条件是他们支持SOM约束。分布式SOM（DSOM）是工作在分布式网上的一个SOM扩充。系统可以使用一个对象请求代管者来共享对象和管理对象间的通信。相应的产品应用在TCP／IP网和NetWare的IPX网上。

    为了提高与Microsoft的Cairo操作系统中对象技术的竞争力，IBM、Sun微系统和HP公司决定共享对象技术。Sun的对象技术是DOE，HP的技术是DOMF。SOM也是OpenDOC的一部分，OpenDOC是帮助开发者在网络环境中创建共享对象应用程序的一个规范。OpenDOC是由OpenDOC联盟制定的，开始是由苹果公司提出，并得到了IBM、Novell、Borland、Wordperfect及其它不愿他们自己的对象技术完全依靠Microsoft公司的对象链接和嵌入技术的公司的支持。

    IBM正努力使SOM和DSOM成为工业标准。他们联合了一些标准化组织并鼓励那些程序语言开发商们使用这些技术。IBM已经为OS／22．0的Workplace Shell建立了一个SOM库。另外IBM的VisualAge也是一个用来操作SOM和DSOM对象的面向对象的开发工具，VisualAge可以用来创建在多种平台上运行的应用程序，而把开发者从编程细节中解脱出来。应用程序可用图形接口实现，并可共享网络资源，还可访问IBM保留系统的后台数据库，记录可被映射入对象。

    相关条目：Compound Documents复合文档；Distributed Object Management Facility分布式对象管理设施；Distributed Objects Everywhere，SunSoft SunSoft的全分布式对象；Distributed System Object Model分布式系统对象模型；Object Linking and Embedding对象链接与嵌入；Object－Oriented Technology面向对象技术；Objects 对象。


  • 系统应用体系结构 Systems Application Architecture

    IBM的SAA是一套应用程序、通信和用户接口规范，它专门服务于IBM大型计算机操作系统如VM、MVS，中型机操作系统如OS／400（为IBMAS／400系列机）和台式机系统的OS／2操作系统。SAA定义了公共应用程序（Common Applications），这些应用程序可在任何一个SAA平台上运行。因此为SAA写的应用程序可以在多种系统上运行。这种体系结构包括以下三个主要部件：

    公共编程接口（Common programming Interface，CPI）为在跨SAA平台执行程序提供了一个公共环境。CPI中的API提供数据库、通信、表示和其它服务。CPI－C（通信）是IBM网络方案中的一部分。

    公共用户访问（Common User Access，CUI）定义了怎样用不同平台上公用的接口为用户表示信息。

    公共通信支持（Common Communication Support，CCS） 定义SAA系统的互连和用于通信及数据交换的协议。

    一些工业分析家认为SAA是一种失败的策略，因为它只连接IBM系统，并且产品也不足以使其成为一个独立标准。Networking Blueprint（联网方案）是IBM的最新的技术，它能支持多个应用程序接口、多种联网协议（TCP／IP，OSI，SNA和NetBIOS），并支持多种传输方式如快速分组帧中继和异步传输方式（ATM）。

    相关条目：IBM IBM公司；IBM Networking Blueprint IBM联网方案（蓝图）。


  • IBM 系统网络体系结构 Systems Network Architecture（SNA），IBM

    早在1974年首次公布的SNA是IBM为了连接他的3270系列产品而推出的方案。SNA包括一套联网协议。SNA这个体系结构中，包括大型计算机系统（主机）、中型机计算机系统、3270终端和台式计算机，并有一个使这些系统与主机系统通信或系统间相互对等通信的策略。

    简单的历史回顾有助于我们认识到集中、分层的SNA是如何适应今天的对等通信、客户机／服务器模式的。SNA设计在与IBM主机系统相连的大多数终端是不可编程终端的年代。SNA在互连的主机之间提供了静态路由选择，所以用户在一个终端上可以访问其它任何互连的主机。在SNA出台之前，用户对要访问每一台主机必须登录到一个单独的终端上。与此同时，TCP／IP正朝着将多种大小不等的计算机互连而努力，而不仅仅是主机系统，还包括个人计算机。这是SNA与TCP／IP的主要不同之处。后者主要是为我们今天占主导地位的对等环境设计的。

    因为SNA只是针对集中化的IBM主机计算环境设计的，所以它不适合于现在对等、客户机／服务器、多供应商产品和多协议的环境。一般这些环境建立在部门级，每个管理者设计和建立自己的局域网。而一个企业网由多个这样的局域网互连而成，所以要处理多个供应商的产品和协议。当客户添加一个局域网并将其加入SNA环境时，IBM的SNA策略就显然无能为力了。

    为了提供程序间通讯，IBM引进了高级程序对程序通信（APPC），并且为了对抗TCP／IP的威胁，IBM推出了高级对等自治网（APPN）。APPN在保持主机系统的多样性同时提供了一个企业范围内的非集中网络计算。在APPN网上，大小型系统相互对等操作。IBM的最新策略是，在包容工业标准协议如TCP／IP和OSI协议的同时继续支持APPN。这个思想已在联网方案中表示出来了，并且我们已经见到遵守该标准的产品。MPTN（多协议传输网）就是一个例子，它使应用程序从基层网络协议解脱开，允许编写与一种特定协议一起工作的应用程序使用其它协议。

    下面还将具体介绍SNA。你可参阅“高级对等联网”（通常称为“新SNA”）的进一步论述。SNA

    图S－17是SNA协议栈与OSI协议栈的比较。有趣的是，ISO 使用IBM的SNA协议栈作为它的OSI的原始模型。

    物理层（Physical layer）允许多种不同类型的物理连接。

    数据链路层（Data－link）定义了同步数据链路控制规程（SDLC）和局域网协议，如Token Ring。

    路径控制层（Path Control）控制路由选择，并可以细分数据报以及重装数据报以适应传输设施。

    运输层（Transmission）提供了面向连接的服务，在两端点之间建立一条监视数据流和确保传送的链路。

    数据流层（Data－Flow）监视数据流并处理两个端点间的会话以防止数据溢出。

    表示层（Presentation）执行数据转换，并提供应用程序接口。

    事务层（Transaction）为应用程序提供了到网络服务的接口。

    正如在“IBM大型计算机环境”中讨论的一样，一个IBMSNA网包括主机系统、终端或运行了仿真程序的PC机、打印机、簇控制器、通信控制器和其它部件。终端和打印机连在簇控器上，而这些簇控制器连向主机或通信控制器（如果它们远离主机）。这些硬件部件和运行在其上的软件称为“节点（node）”，它们之间用数据链路（datalinks）互连。网络上的节点是端点或网络上的连结点，如下所述：

    类型2节点基本上是外部节点，如中型计算机、个人计算机、终端和打印机。

    类型4节点是通信控制器，它提供了到主机系统的远程终端链路。它使大型计算机解脱了从终端来的繁忙的中断。它们发送和接收信息，检测和校正错误，并集中了大量终端的连接。

    类型5节点是控制和管理网络的主机系统。

    节点互连的介质有铜线、光纤电缆或微波。数据链路由同步数据链路控制（SDLC）规程、二进制同步通信（BISYNC）协议、令牌环、X．25和最新的以太网（Ethernet）、帧中继（Frame Relay）和光纤分布式数据接口（FD－DI）管理。另外，一个通道链路是主机之间或主机与它们的前端处理器之间的直接连接。这些链路可以是慢速的铜缆或高速的光缆（可扩充到许多千米）。

    这里介绍的节点和链路是物理实体。用户通过会话（Sessions）运行一个应用程序。一个会话是一个到网络上可寻址单元（Network addressable units）的通信信道。SNA网包括逻辑和物理单元：

    逻辑单元（Logical Units，LU）LU是用户访问网络资源的端口。LU相当于会话，有下面几个类型：

    类型1提供交互的批量传输的会话。

    类型2IBM 3270显示终端。

    类型3IBM 3270打印机会话。

    类型6．2 一个程序与程序的通信会话。

    类型7通过525x型终端的IBM中型计算机会话。

    物理单元（Physicalunits，PU）PU驻留在与主机通信的节点。PU管理和控制通信链路。目前有三种

    类型：

    类型2在簇控制器上实现。

    类型4在前端处理器上实现。

    类型5在主机通信软件上实现。

    SNA网有两个主要的软件部件：

    系统服务控制点（System Services Control Point，SSCP）这个软件在主机上运行并管理主机域内的所有资源。实际上主机系统运行的虚拟远程通信访问方法（VTAM）软件中包含SSCP。

    网络控制程序（Network Control Program，NCP） 这个软件在通信控制器（或前端处理机）上运行。它缓解了主机的通信处理，如路由选择、会话管理、输入输出数据的缓冲、通信中检错与纠错和其它任务。

    SNA网中不同的部件如图S－18所示。一个SNA网络互连（SNI）特性提供了两个单独主机系统之间的互连方式，单独的主机系统位于叫做子域（Subareas）或域（domains）的分开地方。SNI将连在系统中的网络资源归并，并且将其名字与地址建立了映射，并提供了别名来避免冲突。SNI有时在供应厂商和生产厂家之间或当两个公司合并时的电子数据交换（EDI）应用中使用。

    当内部网络在八十年代迅速扩展时，机构对台式计算机系统互连的对等模式越来越感兴趣。这个模式不同于SNA的集中控制模式。作为相应的反应，IBM发表了高级程序对程序通信（APPC）和LU6．2，APPC 提供了编程接口和协议来实现LU6．2，LU6．2提供了两个独立应用程序之间的通信会话。从此BM开发了高级对等联网（APPN），一个对等的路由选择协议。

    为了管理SNA环境，IBM在1986年公布了NetView。它为管理网上节点提供了监视和控制特性。

    相关条目：Advanced Peer－to－Peer Networking 高级对等联网；Distributed Relational Database Architecture分布式关系数据库体系结构；IBM IBM公司；IBM Mainframe Environment IBM大型计算机环境；IBM Networking Blueprint IBM联网方案；Information Warehouse信息仓库；Multiprotocol Transport Networks，IBM IBM的多协议传输网。


  • IBM的SystemView网络管理系统 SystemView，IBM

    SystemView是一种用于在异构环境识别和管理多个系统的企业级网络管理系统，它是IBM最早认可的工业标准协议产品之一。这些工业标准包括传输控制协议／因特网协议（TCP／IP）和开放式系统互联（OSI）协议，而不仅仅是它自己的系统网络体系结构（SNA）协议。

    SystemView建造于系统应用体系结构（SAA）环境。

    它使用OSI公用管理信息协议（CMIP）。

    网络上的资源的信息存储于对象数据库。

    虽然SystemView是一种侧重于对IBM设备进行管理的IBM产品，它仍然包括了OSI标准，从而可以胜任管理企业级网络的工作。

    相关条目：IBM；IBM Networking Blueprint IBM联网方案；Management Standards and Tools管理标准与工具。


  • T1／T3服务 T1／T3 Services

    T－电信服务以45Mbps的传输率在局域或广域范围提供数字数据和音频的传输。这种电路通常是专用的，但是也可为阶段性地需要高带宽服务的用户提供交换服务。用户可以利用T1或T3线路建造他们自己的专用网，如图T－1左边所示。顾客首先从电信局在每个地点之间租用一条专用线路，然后安装管理这些地点间的分组通信流动的交换设备。它之所以被称为专用网，是因为用户的设备直接控制着每个租用线路地点的通信情况。

    与此相反，分组交换技术，例如帧中继、交换式多兆位数据服务（SMDS）和异步传输模式（ATM），在散列技术的支持下，提供任何地点对任何地点的连接，如图T－1右边所示。这时，一个分组是一个完整的、被编址的数据包，它被转发通过分组交换散列网络上的中继器，直到抵达它的目的地。用户可以利用分组交换服务建造虚拟网络，并可避免使用昂贵的长途T1线路。在多数连接到分组交换服务的情况仍然需要T1或其它数字服务，但是这时干线的距离很短，并且用户可以从交换网络中受益。然而，一些用户将仍然需要T1／T3服务提供的专用和专用线路服务，特别是如果在两个点之间需要传送较大通信量的时候。

    使用T1，本地电信局在一个特定的地理区域，就象每个网络的集线器（hub）那样提供服务。在由这家电信局提供服务的这个区域（通常是一个城市区域）内的不同公司地点的网络，被连接到由这个电信局提供的集线器上。本地电信局在局部访问和传输区域（LATA）内进行操作，LATA等价于一个电话区域代码覆盖的地理区域。如果T1线路需要与位于另外LATA的地点进行连接，就必须包括这个本地电信局、远方的另一地点的电信局以及能够提供长途连接的长途电信局（interexchange carrier）。

    T电信电路通常是以按月付费的原则进行租用的，并且包括一次初装费用。这些电路的距离决定了它们的费用，特别是它们跨越了LATA间的边界，并且包含了两家或多家电信局的情况。T1通常是每公里的价格加上每月的服务收费。价格（译者注：美国）变化范围从短途的每月＄3，000，到跨越美国多州连接的可能每个月费用超过＄20，000。T1的典型使用例子是，外地的办公室对公司的数据库进行实时访问。T电信服务提供下列传输率：

    最通用的T1数字租用电路服务，它提供的带宽为1．544Mbps。

    部分T1是一种允许用户不用全部租用T1线路的服务。它提供24个64Kbps带宽的信道，其中，用户可以根据自己的需要选择租用线路的数目。它产生1．536Mbps的带宽。另外需要64Kbps用作开销，总共是1．544Mbps。

    T2不对公众提供服务。它是一种内部载波描述，它等价于四条T1线路（6．3Mbps）。

    T3等价于28条T1电路，可以提供44．736Mbps的总带宽。这种服务最早是用于微波站点间进行传输的。

    部分T3是一种允许用户不用全部租用T3线路的服务。他们可以根据自己的需要选择具体租用线路的数目。

    在美国，使用一种数字信号层次体系，如下表所示。T1服务适于这个层次，一个T1信号等价于DS－1信号率。注意，欧洲的信号率和美国的情况不同。基本的欧洲载波是E－1，它的数据率是2．048Mbps。同步光纤网络（SONET）将在世界范围提供一种标准化的新的信号层次体系，它的目标是允许电话系统的全球性互联。参见“同步光纤网络”。

    部分服务开始只具有低带宽，但为以后较高频带需求的用户提供了一个起步点。T1的1．544Mbps的带宽可以被分成24个64Kbps的信道，每个都可以传载一个音频或数据传输。既使已经安装了一个T1连接，增加附加的信道也是一件非常简单的事情，只需给电信局去个电话就行。

    T1电路是一种可调节的电话线路，这意味着为减少噪音，在用户和电信局的线路中，每隔很近的间隔就需要安装一个信号再生器。T1连接在用户的地点是由双绞线开始的。这些双绞线连接到由电讯公司建立的调节线路上。为将一个局域网（LAN）连接到一条T1线路，将需要下列设备：

    信道服务部件（CSU）CSU是T1电路的第一个连接点。它诊断、并为LAN在这条线路上准备信号，而且如果LAN连接设备有问题，它保持这条线路的存活。

    数据服务部件（DSU）DSU和CSU连接。它将LAN信号转换成T1信号的格式。

    多路选择器 为将多个音频或数据信道装入一条单一数字线路提供了一条途径。

    网桥或路由器 为局域网和T1线路之间提供了连接点。

    音频和数据都可以多路复用到T1线路的24个信道上。在这种配置中，一个公司可以租用一条T1线路，在其公司的多个地点之间传输数据并为频繁的音频呼叫提供信道。音频数字化，每秒采样8，000次，每个采样用8位数值来表示，这样每个音频呼叫需要64Kbps的带宽。图T－2表示一种典型的配置。

    用户和电信局的数字设施接口是信道服务部件／数据服务部件（CSU／DSU）。它产生可以在T1干线上传输的数字信号。如果是在一个LATA内连接，就只包括本地电信局（LEC），但是在LATA间的连接将使情况复杂化。需要与本地和远程LEC相联系，以及和长途电信局（IXC）相联系。而且，长途连接的两端，每个LATA的本地回路，都需要单独付费。

    T1线路可以满足超过X．25分组交换网络或56Kbps数字数据服务（DDS）的带宽需求。另外，它有能力在同一条线路上对音频进行多路复用并降低电话呼叫费，这一能力也促使这种线路的使用得到迅速普及。然而，租用专用线路是有限制的。第一个限制是它们是租用的，并且需要较高的初装费。其次，带宽是固定的，这就不适用于局域网瞬间增大的通信量。用户可能会发现，除了在高峰传输时间，他们所付的带宽费用通常没有被利用，而到高峰期却没有足够的带宽。但建造专用网又是一条过于昂贵的途径，特别是和帧中继服务相比较时情况更是如此。

    在当今的商务环境，在市场改变时，以及当工作小组成立或取消时，或当公司迁移时，公司都需要改变他们的广域网连接。快速分组交换服务，例如帧中继、交换式多兆位数据服务（SMDS）和异步传输模式（ATM）可以解决这些问题。它们可以根据需要提供带宽，并且有能力切换连接。另外，如果需要，它们通过“虚电路”的能力可以模仿专用电路。但是，请牢记，象T1这样的专用服务也需要将用户地点和服务的访问点进行连接。

    新的技术不断增大本地回路的传输率，本地回路是用户的地点和本地电信局之间的连接。现在，综合业务数字网络（ISDN）在许多区域安装了，并且可以提供交换数据链路到电信局的服务。信号编码技术的改进也正在进行。例如，高位速率数字用户专用线（HDSL）允许在现有的铜质线路上以786Kbps到1．544Mbps的T1传输率进行传输。相关的产品包括非对称数字用户线路（ADSL）这样提供甚高位速率的数字用户专用线（VHDSL）。这些情况在本书的其它地方还有讨论。

    相关条目：Carrier Services电信服务；Channel Service Unit／Data Service Unit信道服务单元／数据服务单元；Circuit－Switching Services电路交换服务；Multiplexing多路复用；Networks网络；Packet－Switching Networks 分组交换网络；Wide Area Networks广域网。


  • Taligent公司 Taligent

    Taligent是由IBM和AppleComputer为开发并市场化面向对象操作系统和产品而成立的一家独立的公司。正在开发的操作系统产品的代码“名字”是“Pink”。Pink是在Macintosh计算机及其它平台上运行的IBM的WorkplaceOS操作系统和Apple的新操作系统上实现的。Pink操作系统将和其它面向对象的操作系统进行竞争，这些操作系统包括Microsoft的Cairo。同时，Taligent还集中开发面向对象的开发工具。

    Pink是一种完全的面向对象的操作系统，它将在1994年到1995年期间投入市场。Taligent对Pink的一个目标就是使它能够运行已经编写的应用程序，包括那些在DOS、Windows、Macintosh和UNIX下运行的应用程序。但是面向对象操作系统的真正效力是编制新的应用程序时的可重用模块。用户将可以为一些应用程序购买核心模块，然后根据需要增加附加功能的模块。Pink的通用接口允许用户用其它厂商提供的更好功能或更适合的操作方式的模块产品来更替与软件一起提供的的模块，例如拼写检查器、绘图实用工具或图表模块。Microsoft的对象链接和嵌入在Windows环境实现了类似的特征。

    但是，Pink的能力并不局限在应用程序级别增添模块，它在操作系统级也是模块化的。因而用户可以在以后适当的时候增加网络功能，或改变到另外一种不同的文件系统，甚至如果需要，用户还可以运行多个文件系统。Pink将在围绕Motorola PowerPC处理器建造的系统、基于Motorola 68060的Macintosh机器，以及基于Intel Pentium的系统上运行。IBM正在它的Workplace OS操作系统中实现Taligent的部分工作。HewlettPackard也正在和Taligent一起工作，并且将在它的即将问世的面向对象的应用程序中实现一些Taligent的面向对象技术。

    相关条目：Cario；Common Object Model公用对象模型；Common Object Request Broker Architecture公用对象请求代管者体系结构；Compound Document复合文档；ObjectBroker；Object Linking and Embedding对象链接和嵌入；Object Management Architecture 对象管理体系结构；Object－Oriented Technology面向对象技术；Object Request Broker对象请求代理；Object对象；Workplace OS。


  • Taskbar 任务条

    在微软的Windows中，一种应用程序发射器和任务切换器，( 通过缺省方法 ) 仍可在屏幕底部看到。在发射带有 Start 菜单的程序后，该程序的任务按钮便出现在任务条上，可使用户通过点击按钮切换到这一程序上。


  • DEC的群件 TeamLinks TeamLinks，DEC

    TeamLinks TeamLinks是一种为在DEC的PATHWORKS网络上操作的Microsoft Windows环境设计的分布式群件产品。它集成了个人使用的实用工具（例如字处理器）以及其它一些应用程序（如电子函件、工作流自动化、文档路由选择、电子会议、参考库、数据库访问、文档管理和其它在工作小组内处理信息流的工具）。

    相关条目：Client－Server Computing 客户机／服务器计算；DEC PATHWORKS；Digital Equipment Corporation数字设备公司。


  • 技术办公系统协议 Technical Office Protocol

    技术办公系统协议（TOP） TOP（技术办公系统协议）是一种为办公室系统通信定义局域网的一些规范和协议的开放式系统互联（OSI）协议。它最初是由波音计算机服务公司开发的，但现在与生产自动化协议（MAP）相连。MAP是关于生产设备的网络互联标准，这些生产设备包括工业设备、机器人、计算机、终端和其它可编程设备。这个标准现在处于MAP／TOP用户小组（译者注：机构名称）的控制之下。MAP／TOP用户小组是由生产工程师协会管理的。

    MAP和TOP都使用以太网，并且通常联合使用。MAP为生产厂房中终端、生产设备和机器人等定义局域网，而TOP定义前端办公室的连接。

    相关条目：Manufacturing Automation Protocol生产自动化协议；Open Systems Interconnection Model开放式系统互联模型。


  • 电信，远程通信 Telecommunication

    Telecommunication这一单词源于希腊语“远程”（Greek tele）（遥远的）和通信（communicare）（共享）。在现代术语中，远程通信是指，在连接的系统间，通过使用模拟或数字信号调制技术进行的声音、数据、传真、图象、音频、视频和其它信息的电子传输。在美国，远程通信是由联邦政府来有系统地管理的。这种管理以1866年的邮路法案（PostRoadsAct）为标志，它使美国邮政总局（U．S．Postmaster General）可以控制电报工业。现在，联邦通信委员会（FCC）控制美国国内和国际远程通信。FCC 是在1934年的通信法案（Communication Act）中形成的。

    美国电话电报（AT＆T）公司在美国远程通信系统的形成中起了重要的作用，成立了许多反托拉斯组织（antitrust suite）在很长一段时间起来反对它。1913年，AT＆T被迫从西部联盟（Western Union）中退出，并允许一些独立公司使用它的长途网络。长期以来，美国政府采取了许多行动来拆散AT＆T，1984年，司法部（Justice Department）迫使AT＆T拆散成许多地方性的公司，这些公司通称为地方Be1l运营公司（RBOC），另外，其研究分部称为Bellcore。今天，许多本地通信都要包括一个RBOC，并且长途通信要包括一个本地和远程RBOC，以及一个长途电信局，例如AT＆T、MCI或US Sprint。参见“地方Bell运营公司”。

    公共远程通信网络（通常称为公共交换电话网络或PSTN）包括传输部件和交换部件：

    传输部件（链路）定义用于传送数据的实际介质、编码、多路复用以及传送技术。

    交换部件（结点）包括使用电路交换或分组交换技术的用于音频和数据路径选择的发送器和接收器。

    图T－3表示电话网络的服务区域和设施。顾客预置设备（customer premises equipment）包括电话机、开关、电缆以及在顾客地点的其它硬件。这种设备通过局部环路（local loop）连接到本地电信局（LEC）中央办公室（CO）。局部环路通常是双线或四线铜质电缆，并且构成了这家电信局的最大访问之一。LEC在一个局部访问和传输区域（LATA）内进行操作。LATA是RBOC进行操作的七个区域中的一些。例如，洛杉矶盆地是太平洋Be11运营区域内的11 LATAs中的一个。一个LATA通常包括许多提供本地化服务的互联的中央办公室交换设施。注意，一些非RBOC的独立电信局也可以在一个LATA内进行工作，并可以提供与AT＆T竞争的服务。

    任何超出一个LATA区域的通信都被认为是长途通信，并且由长途电信局（IXC）处理。长途电信局包括AT＆T、MCI和US Sprint等公司。法律要求LEC必须为IXC提供一个访问点（point－of－present，一种接口）。IxC拥有的通信设备包括光纤缆线、基于地面的微波塔和基于卫星的微波系统。

    在模拟电话系统上的声音会话带宽是3kHz。在七十年代和八十年代，电讯公司开始提供数字服务，例如T1，以适应音频和数据等时传输的需求。为了在这些线路上传输声音，使用了数字化技术，以将3kHz的声音信号转变成64Kbps的数字数据信号。一条1．544Mbps的T1线路可以提供24个这样的64Kbps的音频信道，但是一些这样的信道通常是用于数据的。如果一家公司需要向它的分支办公室进行一定的语音呼叫和数据传输，那么T1线路是比较合适的。需要使用多路复用技术将语音和数据信号合并到一条单一的线路上在电话网络上进行传输。

    Transmission Methods传输方式

    在模拟电话线路上传输数字计算机信息，需要使用一个调制解调器，它将数字信号转换成模拟信号。另外，下面将讨论的同步机制也将在发送和接收站点使用，以确保信号被正确地解释。

    同步传输 信息以与时钟信号同步的数据位的块（帧）的形式进行传输。使用特殊字符来开始同步并周期性地检查它的正确性。参见“同步通信”。

    异步传输 信息以一组位的形式每次一个字符地进行发送。每个字符通过一个“开始”位和一个“停止”位进行分离。使用一个校验位进行错误检查和纠错。调制解调器通常使用异步方式进行工作。参见“异步通信”和“调制解调器”。

    如上所述，为在模拟电话设备上传输，调制解调器将数字信号转换成模拟信号。调制解调器连接于数字终端设备（DTE），如一个台式计算机系统。Bell公司、电子工业联合会（EIA）和国际远程通信联合会（ITU）的标准决定着调制解调器的设计和操作参数，以确保使用的两个调制解调器可以相互通信。一些生产厂商为改进性能而进行特殊设计，但通常要求通信会话的两端使用相同类型的调制解调器。

    国际标准提供的modem最大传输率是2，400bps；然而，大多数当今的调制解调器都采用不同的压缩技术，从而可以提高传输率达200％。与数字线路、专用或租用线路相比，这一传输率使得廉价的电话线路也成为一种可用的选择。

    下面介绍在单向单路或双向双路中的信号：

    单工（simplex）电路 一种单向传输电路，例如无线电广播。

    半双工（half－duplex）电路 一种双向传输电路，它一个时间只能进行一个方向的传输。

    全双工（full－duplex）电路 一种同时双向的传输电路，例如电话系统。

    Available ServiceS可用服务

    为建造数据网络，可以使用许多连接方式。下面介绍的服务是由本地电信局、长途电信局和增值电信商（VAC）提供的。

    拨号电话连接 在用户和网络或两个网络间的模拟电话线路上的一种暂时性连接。需要在两端使用调制解调器。在当前的标准下，使用压缩技术时传输率可达28．8Kbps。

    专用模拟电路 这种电路类似于拨号线，只是它总是连接的（不需要先拨号再建立），并且电信局可能会提供较高级的服务（例如无错线路）。 常按月收费，并且

    专用数字电路 专用数字电路总是连接着的，例如T1、T3或部分T1。这种线路通常建立在两个固定地点间。 信时才连接的数

    交换数字电路 这种电路是可以通过交换技术，以提供到任何地点，并且只在需要通信时才连接的数字电路。顾客仅仅需要根据他们的使用情况来付费。虽然这种选择比以前的方式提供了更大的灵活性，但是在通话期间只有两个点被连接。许多不同的电讯公司提供了这些电路服务。AT＆T的ACCUNET服务就是一个例子。．一

    分组交换网络 分组交换网络是一种提供任何地点之间连接的网络。来自许多用户的网络分组被传送到分组交换网络，在这个网络上，它们可以被传递到和网络相连的任何遥远的地点。X．25服务在八十年代是很流行的，但是远程数据访问、多媒体和电视会议的需求导致了对快速分组服务的需求，这些快速分组服务包括交换式多兆位数据服务（SMDS）、帧中继和异步传输模式（ATM）。

    在远程通信链路上，图形和视频图形的传输已经成为一种现实，这是因为压缩技术可以减少信息的大小，而且电讯公司正在提供适应它们的快速传输服务。如果可以得到一个能够按可担付的收费标准分发信息的系统，就可以使用这些服务。一导线的模拟线路。

    目前，发展较快速传输服务的一个障碍是，用户和电讯公司间的局部环路仍然是铜质为在局部环路上提供T1服务，必须在每606米（2，000英尺）就加入一个信号中继器。在一些区域建立了综合业务数字网络（ISDN），以提供到家庭的数字连接。ISDN线路包括两条64Kbps的音频或数据线路，以及一条16Kbps的信号发送线路。下面列出提供更高数字吞吐率的计划：一．

    非对称数字用户专线（ADSL）使用现有的线路在单一方向提供1．544Mbps（T1）的传输率。ADSL和综合业务数字网络（ISDN）相联系。

    高位速率的数字用户专线（HDSL）提供双向通信，并允许跨越12，000英尺的T1传输。

    甚高位速率的数字用户专线（VHDSL） 它可以在双绞线上提供3到6Mbps的服务。

    这些服务为许多新的服务提供了可能性，如视频、交互性信息、远程通信和电信教育等。

    Other Developments其它发展

    在远程通信市场正在进行的其它发展情况包括对远程和移动用户的支持。与本地电信局竞争的许多公司正在积极在许多地区建造基于光纤的城域网。另外，有线电视公司也正在开发网络服务，这种服务可利用超过60％的美国家庭中安装的同轴电缆。

    分组无线电通信 分组无线电将传输分解为小的数字分组，并且以高达9，600bps的传输率将它们传输给移动用户。接受者的设备仅仅接收编址到他的分组。提供分组无线电通信的公司包括Ardis（Lincolnshire，Illinois）、RAM移动数据（Woodbridge，New Jersey）和Nextel（Laffayette，California）。参见“无线LAN通信”。

    蜂窝数字分组通信 蜂窝通信器是在用户和他们的家庭、办公室或网络之间提供双向传输的移动计算设备。这些设备提供电子函件能力，以及发送和接收文件和其它信息的能力。蜂窝数字分组数据（CDPD）是一种由蜂窝电信局和计算机公司组成的国际联盟定义的蜂窝无线电网络规范。它允许顾客在蜂窝网络上发送计算机数据。参见“无线LAN通信”。

    光纤城域网（MAN） 城域网向顾客提供穿越一个城市的公共区域的传输。MAN常是和IEEE802．6MAN标准联系在一起的，这个标准定义了用拨号总线建造的光纤网络，它的传输率在T1速率（1．544Mbps）到T3速率45Mbps之间。这种网络的范围是160公里（96英里）。一些电话电信局正在建设MAN，它们将与交换式兆位数据服务（SMDS）相兼容。在一个城市区域，FCC还允许非电讯公司建造和电讯公司竞争的基于光纤的网络。这些公司正在提供具有竞争性的传输率和在许多情况下优异的服务。顾客可以在城市区域连接进入任何这些网络以建造他们自己的专用网。

    有线公司网络 有线公司传统上依赖于向他们的用户完全提供同轴铜质电缆。然而，在一个大城域网中对这种信号不断增长的需求已经限制了这种系统的带宽。一些有线监督局现在需要安装光缆作为主干线路，以较少信号衰减和对放大器的需求。完成这一工作之后，有线公司将在很大程度上增加他们的带宽，并且将提供超过现在数目的两倍信道。事实上，有线公司计划安装足够的光纤容量，以供他们将线路销售给其它服务提供商。

    虽然有线公司可能比电讯公司更好地向家庭用户提供同轴电缆链路，但是他们却没有电讯公司所有的交换服务，这些交换服务建立了为创建网络或建立电视会议所需的顾客地点间的连接。另外，FCC允许电讯公司在他们的网络上提供视频编程，虽然他们可能不具有或没被许可使用在他们服务区域内的程序。还有一些关于取消施加到RBOC上的限制的说法，例如，对提供长途服务的禁止令。

    电信局为了将来的服务，开始在家庭的几百英尺的范围内布缆。由于还没有将光缆完全铺设到家庭的计划，所以将采用双绞线电缆来传输光纤外的音频信号，并采用同轴电缆来传输视频信号。通过增加带宽，将会出现一种偏离现有层次结构的变化。在层次式结构中，程序被广播到许多程序。这种变化将转向双向通信，此时，用户可以和其它用户或服务提供商进行交互协作。

    相关条目：Asynchronous Communication异步通信；AT＆T；Carrier Services 电信服务；Local Access and Transport Area本地访问和传输区域；Regional Bell Operating Companies地方Bell运营公司；Signal，Analog and Digital Synchronous Communication模拟和数字信号；Synchronous Communication同步通信；Transmission Media，Methods，and Equipment 传输介质、方式和设备。


  • Telenet网 Telenet

    这是第一个美国商业分组交换网络。现在称为Sprint Net。不要与Telnet混淆，Telnet是传输控制协议／因特网协议（TCP／IP）网络系统（例如Internet）的登录命令。


  • Telnet程序 Telnet

    Telnet是传输控制协议／因特网协议（TCP／IP）网络（例如Internet）的登录和仿真程序。它最初是由ARPANET开发的，但是现在它主要用于Internet会话。它的基本功能是，允许用户登录进入远程主机系统。以前，Telnet是一个将所有用户输入送到远方主机进行处理的简单的终端程序。它的一些较新的版本在本地执行更多的处理，于是可以提供更好的响应，并且减少了通过链路发送到远程主机的信息数量。

    Telnet是一种客户机／服务器处理方式，其中，用户在本地系统生成Telnet应用，并和远程主机上运行的Telnet进程建立一条链路。这个用户在他的键盘上发出请求，这个请求被传送到系统上运行的Telnet客户。然后，Telnet将这个请求传送给远程的Telnet服务器。通过这个过程，用户就能启动远程程序，并且就象他们直接与这个远程主机相连接那样，从他们自己的系统上就可以运行这些程序。大多数进程是在远程主机上运行的，它从用户的系统接收请求，并在它的工作空间内处理它们，从而减少了在这条链路上的通信量。

    相关条目：Internet。


  • 终端服务器 Terminal Servers

    终端服务器用在局域网（LAN）上将很多终端连接到IBM主机系统或小型计算机系统。终端是通过RS－232串行端口连接到终端服务器的，并且这个终端服务器与一个以太网或一个令牌网相连。然后，这个网络就象主机系统和终端之间的链路那样提供服务。终端服务器基本上是一个异步多路复用器，它不仅仅将终端，而且将计算机、调制解调器、打印机和其它外设，连接到这个主机系统。终端服务器有一些串行端口和相应的网络接口。

    终端服务器并不是网关，这是因为被连接的终端设备要使用一个与主机兼容的通信协议。当个人计算机通过终端服务器连接到主机时，它运行一个终端访真程序来模仿一个终端上的通信协议。然而需要注意，终端服务器为了在网络上向主机系统发送数据，必须对从终端来的要发送的数据进行封装。


  • 终端 Terminal

    终端通常是指那些与集中式主机系统（例如IBM大型计算机）相连的“哑”用户设备。终端从用户接收键盘输入，并且将这些输入发送给主机系统。主机系统处理这个用户的键盘输入和命令，然后输出返回并显示在这个终端的屏幕上。个人计算机可以运行称为终端仿真器的一些程序来模仿一个哑终端的工作。

    在IBM环境，终端是端点用户用于和主机通信的设备。这种设备可以是监视器、键盘设备或打印设备。它们用同轴电缆和一个群控器（cluster controller）相连，这个群控器可以直接连接到一台主机，也可以通过一个通信控制器连接到这台主机。多达32个终端可以连接到一个单一的群控器上，具体数字要视这个群控器的型号而定。每个终端可以使用一条独立的电缆连接到这个群控器，也可以为了节省电缆，将它连接到一个附近的多路复用器，而这个多路复用器通过一条电缆连接到远方的群控器上。

    在IBM网络体系结构（SNA）环境，群控器被称为物理部件（PU）型号2设备，与这个群控器连接的终端被称为逻辑部件（LU）2设备。连接到PU型号2的打印设备可以是LU型号1，也可以是LU型号3，具体情况要视打印机的类型而定。

    有两种类型的IBM 3270终端设备。型号A设备提供对一些扩展属性的支持，这些扩展属性包括颜色、高亮度、反视和特殊字符集。型号B是不具有这些特殊属性的老式设备。

    还可以将ASCII终端，如IBM的3100系列、DEC的VT－52和VT100系列、Televideo的900系列和其它终端，通过电缆连接IBM 3708、3710或7171协议转换器，连接到一台IBM主机，详细介绍参见“IBM大型计算机环境”。所有的ASCII终端使用RS－232－C（或RS－422－A）接口，而不是同轴电缆连接。

    可以将终端和个人计算机连接，并可以使用个人计算机运行主机应用程序。一种方式是增加一个特殊适配器卡和3270仿真软件的组合。这个适配器提供一个同轴电缆连接器，所以这个人计算机就可以连接到一个群控器，并且这个软件使得这个终端仿真IBM终端。在仿真模式，PC可以与这个大型计算机具有多个并发的会话。

    相关条目：IBM；IBM Mainframe Environment IBM大型计算机环境；Mainframe大型计算机；Multiplexing多路复用；Systems Network Architecture系统网络体系结构。


  • 终端器，终结器，终止器 Terminator

    终结器是一个反射电缆信号的电阻。在同轴电缆上要安装两个终结器，每个电缆端点一个。一个终结器（而不是两个），需要一个接地连接。终结器必须具有特定的电阻数值，具体情况要视网络而定：

    网络类型 数值

    以太网RG－58A／U（细网） 50欧姆

    以太网RG－59／U（粗网） 75欧姆

    ARCNETRG－62／U 93欧姆

    相关条目：ARCNET；Cabling布缆；Ethernet以太网；Networks网络；Topology拓扑结构；Transmission Media，Methods and Equipment传输介质、方式和设备。


  • 测试设备和技术 Testing Equipment and Techniques

    进行网络测试的基本设备包括电缆测试器和协议分析产品。电缆测试器用于测试或确定物理电缆产品，而协议分析器在协议栈的较高层次进行工作。协议分析器可以通过查看分组来确定哪个站点产生通信量，监督哪里出现了错误，并寻找网络上的不寻常事件，例如通信和资源使用的高峰期等。

    Network Cable Testers 网络电缆测试器

    通常，网络上的故障源是电缆。可以使用许多设备来检测电缆。一些设备非常便宜，它们常常放在网络管理人员的工具箱中。例外，可以租用非常昂贵的设备，或可以依赖于顾问们和专业电缆安装人员提供的服务。然而，现在，新一代的电缆测试器包含了全范围的测试功能，包括协议分析，但它们需要上千美元。大多数测试器的体积象移动电话那么大。一些电缆检测的目的只是简单地检测现有的电缆或验证电缆是否是按照顾客、厂商或工业标准对信噪比、性能和完整性的要求进行安装的。电缆测试器可以进行如下测试：

    连通性 测试能够确定电缆（可以是在安装中的，也可以是已经安装的）是否能够从一个地点正确地

    传输电子到另一地点。电缆测试设备包括电缆端点为进行测试而安装的设备。

    噪音 电缆测试器可以测试电气噪音。低于150kHz的噪音来源于电气传输线路和日光灯。高于150kHz的噪音来源电气设备，如计算机和复印机。脉冲噪音是瞬间出现的并且只维持很短的时间，所以必须进行一段时间的测试才能确定是否有噪音源在网络上导致了连续的脉冲式噪音问题。

    串音 是从相临电线中传输的数字信号中泄漏出的噪音。许多测试设备可以通过在一个电路对中插入一个信号，并且测量粗临电线对中信号感应的能量，来测量串音。这种测试对正在建设（spool）中的电缆不是很有效的，它对已经安装好的电缆有效。对所有连到集线器的绞线进行维护可以减小串音。

    衰减 衰减是通过在电缆上发送一个信号，然后在这条电缆的另一端测量这个信号而进行测试的。衰减是电缆的自然特性，非自然性的衰减可能显示了电缆的超载或部分断裂。

    电容 电容测试可以指明电缆是否被拉长了或出现了纽结。电缆的电容数值是以每英尺的皮法（pF）来测量的。对线缆的测试（包括建设中的或已经建成的电缆）将指示出现的损坏情况。

    如果没有特定的电缆测试设备，简单的电压表可以用做测试连通性的工具。可以设置这个电压表到它的欧姆或电阻档，并且测量通过中心线缆的情况，然后再测量通地的情况，或用尖嘴钳在电缆的一端弯一个回路返回。如果这条电缆是已经安装好的，也可以测量它的连通性。对于同轴电缆，在电缆的一端放置一个终端电阻，然后将电阻的一个脚接地，将中心线连接到另一个脚。对于双绞线，用尖嘴钳连接电缆的一端线对，然后在另一端进行测试。

    Cable Tracers 电缆跟踪器

    可以用跟踪器跟踪一条电缆，以确定它在墙壁或天花板内的路径，或它的源目地点。如果需要确定一束电线中的某条线的目的地，就要使用电缆跟踪器。在电缆的一端连接一个音调发生器，在另一端用一台放大器来监听这个音频，它通常是一个双绞线电缆的分线盒。这个放大器指示何时它接近了产生这个信号的电线。

    一种流行的产品是Microtest跟踪器。使用它，可以定位任何同轴电缆、双绞线电缆、或其它隐藏在地板里、墙壁内和天花板里的电缆。这个跟踪器的发送部件连接到这条电线或电缆，使其接收单元在怀疑区域的电线上运行。当这个跟踪器的接收单元通过这条电线时，一个提醒声音响起；当接近这条电线时，这个声音变得更响。

    Time Domain Reflectometers（TDR） 时域反射表

    TDR能确定电缆上断开或短路的位置。它在电缆一端上发送一个高频脉冲，然后测试这个信号被反射回来的时间。在短路和断开的地方会发生反射，并且反射的时间和振幅反应了出现问题的距离。另外，极性指出是短路还是开路。现在，从许多厂商，例如BlackBox，可以获得低于＄1，000的一些TDR。注意，还可以获得激光TDR来测试光纤线缆。

    Microtest电缆扫描器（大约＄1，500）是一种独立的手持式TDR。它的32字符显示可以用简单的英语描述失效问题，例如“Short at 306 ft（在306英尺处出现短路）”。这种电缆扫描器可以在任何串行打印机上打印出硬拷贝，并且可以将测试结果存储在存储器中以备查阅。可以测试同轴或双绞线电缆的以太网、ARCNET和令牌网。这种电缆扫描器还提供对局域网活动的实时监督，以助确定何时需要增加网桥或中继器。可以将这种电缆扫描器连接到示波器以分析波形。以前介绍的跟踪器产品包括在这个电缆扫描器中。

    Protocol Analyzers 协议分析器

    通常，当一个网络增大时，它的性能降低。当然，可以扩展更多的内存来对网络进行升级。实际的做法是改变设置并查找瓶颈。需要找到配置不合适的设备或工作过重的服务器，还需要观察超过广域网（WAN）的通信量。电缆测试器和局域网（LAN）分析产品可以帮助你确定问题的来源。假如有一个超过50个结点的LAN，这些产品是可信赖的，特别是这些结点跨越了很广的范围时也如此。它们可以帮助你从你的办公室分析这个网络，并且对潜在问题的区域进行定位。下面列出使用协议分析器可以完成的任务：

    确定哪个网络站点是网络中最活跃的。如果一个工作站正在使用一个LAN段的很多带宽，可以将这些任务移动一些到另外一个LAN段，从而对产生错误的工作站进行定位。也许需要更换这个工作站的网络适配器。

    过滤和查看指定类型的分组，例如路由选择信息分组。可以使用这个信息来调节服务器和路由器的广播频率，以减小网络通信量。

    通过分组的协议类型（IPX，TCP／IP，AppleTalk，等等）来过滤分组，以确定通过一个LAN段的网络通信量的类型。

    获得关于网络性能的短期和长期趋势。对使用高峰期了解得越多，越能够合适地预测网络负载和对网络进行配置。

    设置警铃当不正常的网络事件出现时提醒你，例如在一个特定类型的分组上的电涌或增加了出错。

    通过发送诊断分组来对网络进行检测。检测有助于你检查网络的布缆，监督通信延迟或测试结点适配器。

    当然，这只是协议分析器的很少一些活动。不同的产品，能力也不同，所以你需要与生产厂商进行商量，并阅读商业期刊上的产品评价。协议分析产品可以从以下公司获得：网关通信（电话：800／367－6555），Triticom（电话：612／937-0772），Intel（电话：800／538－3373）。

    The LANalyzer LANalyzer协议分析器

    在NetWare环境，可以使用一种称为LANalyzer for Windows的产品来帮助管理人员监督网络操作和分析使用IPX、TCP／IP和AppleTalk协议的以太网和令牌环网上的分组通信量。下面把LANayzer作为一种典型协议分析器来介绍。它在一个管理站点以软件的形式运行。

    可用LANalyzer对网络进行每天或周期性的监督。周期性的监督可以帮助你观察网络通信量变化的长期趋势。这些趋势可能会指出潜在的问题或确定请求过多网络服务的用户。使用LANalyzer，可以在出现问题之前纠正或调整网络的设置。还可以发现导致网络响应变慢连接失效和过多网络通信量问题的产生源。

    图T－4示意了LANalyzer窗口。它有显示网络当前和长期统计情况的表板和一些域。

    表板显示网络的实时信息，例如每秒钟发送的分组数目、网络的使用情况以及每秒钟的出错数目。如果你指定要过滤掉特定类型的分组，就出现两个探针。

    注释：在这个例子中使用情况是指网络的带宽，或它的分组传输能力。

    站点窗口监视器显示一个活动站点的表和它们的当前统计情况。

    这个窗口较低的部分显示一个闹钟和一个消息窗口，它提醒你网络上出现了不平常的事件。

    分组获取域用于获取一系列用于分析的分组

    图T－5表示了一个典型的分组获取窗口。在此，字处理文档文件传输到这个服务器。统计窗口显示被传输分组的列表。可以点击任何分组查看它的细节信息，信息出现在中间译码窗口。在底部是一个以十六进制数表示的窗口，它显示分组的内容。LANalyzer具有过滤功能，它允许你指定一个特定的工作站来进行分析，观察希望的分组类型。还可以根据指定的协议，如NetWare IPX、AppleTalk，或TCP／IP，进行过滤。

    LANalyzer还具有图形功能。图形可以显示实时事件，或为进行趋势分析显示历史数据。还可以打印站点监督数据、分组获取数据和图形，或为专用分析，将数据输出到一个电子表格上。

    相关条目：Cabling 布缆；Packets分组；Protocol，Communication 通信协议；Transmission Media，Methods，and Equipment传输介质，方式，和设备。


 TFT 有源矩阵彩色显示器
：简称TFT显示器，专用于笔记本电脑。TFT显示器具有刷新速度快、色彩逼真、亮度鲜明等优点。此外，它还具有无闪烁、无辐射、无静电等“绿色电脑”所必需的特点。


  • TFTP 小文件传输协议

    TFTP(Trivial File Transfer Protocol)是网络应用程序，它比FTP简单也比FTP功能少。它在不需要用户权限或目录可见的情况下使用。它使用UDP协议而不是TCP协议，它在RFC 1350内得到详细说明。


  • 线程 Threads

    线程是在多任务操作系统上运行的进程。一个多任务操作系统可以同时运行多个程序或进程。每个进程都包括一定的需要完成的工作，并且这个工作可以分解成一个或多个部分或单元，它们可以象线程那样运行。如果这个系统只有一个处理器，那么每个线程就将轮流执行，一个接着一个。一个单一的线程并不能独占这个处理器，而是用一点时间来完成它的一些或全部任务，这时用户就会产生程序在同时执行的错觉。

    多处理器系统有助于改进多任务操作系统的性能。每个线程可以在独立的处理器上同时运行。进程执行得更快，这是因为多个处理器一起来完成这些任务。线程是有用的，这是因为它们消除了对操作系统不断地对存储器进行装入或取出信息的要求。每个线程所需的信息存放在存储器。这减小了开销，不仅减小了内存空间，还减少了它在内存中创建信息的时间。每个线程都可能和这个系统的不同部分发生协作，例如磁盘系统、网络输入／输出（I／O）或用户。线程被调度执行，这是因为一些线程可能需要等待一些事件的出现或另外一个线程的任务的完成。

    Microsoft Windows NT和NetWare都是多处理和多线程操作系统。对NetWare4．x的线程调度器可以进一步改进性能。微内核操作系统（如Carnegie－Mellon大学的Mach）通过使用线程也利用了多处理和多处理器系统的优势。Mach，作为一个新的UNIX系统的核心，将提供多线程能力。

    相关条目：Mach，Carnegie－Mellon Microkernel Carnegie－Mellon大学的微内核Mach；Multiprocessing多处理；Multiprocessor Systems多处理器系统；Microsoft Windows NT Microsoft的Windows NT操作系统。


  • 吞吐率，处理能力 Throughput

    吞吐率是一种关于计算机或数据通信系统（如网桥、路由器、网关或广域网连接等）数据传输率的测度。吞吐率通常是对一个系统和它的部件处理传输数据请求能力的总体评价。例如，一个服务器的吞吐率依赖于它的处理器类型、网络接口卡的类型、数据传输总线的大小、磁盘速度、内存缓冲器的体积，以及软件对这些部件进行管理的有效程度。在通信系统中，这个测度通常基于每秒能处理的数据位数或分组的数目，它依赖于网络的带宽和交换部件（如路由器或集线器）的速度。网络上两个端点设备间的吞吐率依赖于计算机、网络接口卡和连接它们的网络。


  • 时域反射计（仪，器） Time Domain Reflectometer

    时域反射计是一种用于测试通信网络上物理部件的设备。它在电缆上发送一个信号，这个信号可以对短路和断路进行定位，并对由于电缆的失效（如发生卷曲）导致的阻容不匹配进行检测。在这条电缆上发送一个脉冲，它就会在对应的另一端被反射回来。对这个反射的时间进行测量就可以判断电缆的另一端的距离（或已知问题点的距离），而极性的改变说明出现了断路。

    相关条目：Testing Equipment and Techniques 测试设备和技术。


  • 时间同步服务 Time Synchronization Services

    在分布式计算环境中的系统，时间同步服务为它们的时钟进行同步提供了一条途径，于是事务事件和其它数据库的修改可以被定时地正确执行。下面给出两个例子：

    NOVELL NETWARE 4中的时间服务 NetWare目录服务必须保证多个机器是时间同步的，以对遍布互联网络的目录信息进行正确的修改。时间同步有助于建立和维护事件的顺序。有两种时间同步策略。第一种策略是对地理位置接近的网络使用一个单一的引用时间服务器，这个时间服务器是这个网络中时间的唯一来源，时间的任何改变都在这个服务器上进行设置，然后其它的服务器与它进行同步；另外一种方式是对地理分布很广的网络使用的，它包括下面几种时间服务器：

    在地理分布网络上使用的基本服务器，和其它基本时间服务器或一个参考时间服务器进行时间同步，并且对高层时间服务器提供正确的时间。如果在一个网络上存在多个基本服务器，它们“投票”决定使用哪个通用网络时间。

    参考服务器 参考服务器从外部资源（例如收音机报时）获得时间，并且它还是一种确定外部世界应该是什么时间的联络员。参考服务器不使用，或改变它的内部时钟。参考服务器通过“投票”过程帮助基本时间服务器设置公共时间。最后，所有的时间服务器都设置到由参考服务器的外部时间来源指示的时间。

    高层服务器 网络上的所有其它服务器都可以是高级时间服务器。它们或参考时间服务器那里获得时间，并不参予网络上的公共时间的建立。

    可根据长途广域网（WAN）链路的费用决定使用那种类型的时间服务器。高级服务器将从一个本地基本的或参考的服务器那里获得它们的时间，而不是通过使用WAN链路来访问一个远程的时间服务器。在跨越很广的地理区域的互联网络上，需要使用多个基本时间服务器。

    OSF的分布式计算环境（DCE）中的时间服务 OSF时间服务是一个DCE的构件，它允许应用程序对活动进行调度并确定事件的顺序和持续时间。这种服务跟踪多个网络上的时间，并确定用作同步时间的每个时钟的准确性。这个服务为本地和广域网的系统都提供容错时钟同步。也就是说，能够确定具有错误时钟的服务器，并且它们的时间在进行同步的期间不使用。为支持使用网络时间协议（NTP）的分布地点，OSF时间服务还允许使用来自外部资源的时间数值。

    相关条目：Distributed Computing Environment 分布式计算环境；NetWare Directory Services NetWare目录服务。


  • 令牌和令牌传递访问方式 Token and Token Passing Access Methods

    令牌是在令牌环、令牌总线和光纤分布式数据接口（FDDI）网络中控制网络访问的特殊分组。获得对令牌分组控制的网络结点有权在网络上进行通信。不象基于连接的网络（如以太网），工作站不会试图同时访问这个网络。只有获得了可用令牌的站点才能发送。在以太网环境，当两个或更多的工作站试图访问这条电缆时就会出现冲突，它们必须都撤消并且在以后重试，这就降低了性能，特别是当连接到一个网络段的工作站的数目增加时情况更严重。

    在令牌环网络中，一个站点拥有一个令牌，并改变一位，就将这个令牌转变成一个帧的开始序列（SFS）。在这个令牌中有一个域，用于工作站指定传输所需的优先级的类型。这个优先级的设置基本上是为了满足其它站点以后继续使用这个令牌的需求。其它工作站将一个工作站的优先级请求和它们自己的优先级进行比较。如果这个工作站的优先级高，那么其它工作站就将授予这个工作站在下一段时间访问这个令牌。

    相关条目：Access Method，Network网络访问方式；Fiber Distributed Data Interface光纤分布式数据接口；Token Ring Network令牌环网。


  • 令牌总线网 Token Bus NetWork

    令牌总线网络类似于令牌环网络，其中，站点可与在网络上进行发送之前，必须拥有一个令牌。但是，它们的拓扑结构和令牌传递方式是不同的。电气电子工程师协会（IEEE）802．4委员会已经定义了令牌总线标准是宽带网络标准，以与以太网的基带传输技术区别。令牌总线网络通过总线拓扑结构，使用75欧姆CATV同轴电缆构造。802．4标准的宽带特性，支持在不同的信道上同时进行传输。宽带电缆有较长的传输能力，传输率可达10Mbps。在生产厂房的网络中，令牌总线网有时采用生产自动化协议来实现。

    令牌按照站点地址的序列号，从一个站点传送到另外一个站点。这样，这个令牌实际上是按照逻辑环而不是物理环进行传递。在数字序列的最后一个站点将令牌返回到第一个站点。这个令牌并不遵照连接到这条电缆的工作站的物理顺序进行传递。可能站点1在一条电缆的一端，而站点2在这条电缆的另外一端，站点3却在这条电缆的中间。

    电缆的拓扑结构可以包括被长干线电缆连接的工作站的一些组。这些工作站从一种星形配置的集线器中分支出来，所以这个网络既是一个总线拓扑又是一个星形拓扑的网络。ARCNET是一个令牌总线网络，但是它不承认IEEE802．4标准。令牌总线拓扑结构的例子有“ARCNET”。令牌总线拓扑对于组织分离在较远地点的用户是很适合的。虽然在一些生产环境使用令牌总线结构，但是以太网和令牌环标准却已经在办公室环境起着决定性的作用。


  • 令牌环网 Token Ring NetWork

    令牌环是针对令牌传递环形网络制定的电气电子工程师协会（IEEE）802．5标准，它可以按照一种星形拓扑进行配置。IBM在八十年代中期将第一个4Mbps的令牌环网络推向市场，于是就可以使用这种标准了。虽然这种网络在物理上看似一种星形结构，信号在网络上的传输却是从一个站点到下一个站点的。因而，布缆的配置和设备的增加或减少必须保持逻辑环。

    连接到中央集线器的工作站被称为多站点访问单元（MAU）。将多个集线器连接在一起，可以建立大型多站点网络。这个集线器本身包含一个“折叠环（collapsed ring）”，如图T－6所示。如果一个工作站失效了，MAU立即旁路这个站点，就可以维持这个网络的环。注意，没有连接的站点是被旁路的。

    图T－7示意了对附加MAU的安装情况。为与其它MAU进行连接，在每个MAU上提供了一个环内和一个环外电容。当一个MAU按照这种方式进行连接时，就保持了这个环的模式。由于这条电缆包括多个电线对，于是如果这条电缆在某处被切断，就导致这个环在自身上返回，如图T－8所示。信号将简单地在反方向再进行路由选择，产生了一个回路返回电缆配置。使用中继器以扩展令牌环网络的距离。图T－9示意了如何在一个大的办公室或多层建筑物中进行令牌环网配置。主环以一种圆圈的形状将所有的MAU连接在一起。

    可以使用的IBM令牌环卡有4Mbps和16Mbps两种版本。16Mbps版本采用了增加帧长度的技术，它传输相同数量的数据只需要较少的时间。现在可以从许多厂商处获得跟随IEEE802．5标准，并使用在IBM设计上进一步扩展的连接方式的令牌环网。无屏蔽双绞线电缆与16端口的MAU现在很普及。另外，可以从一些厂商处获得两端口和四端口集线器。这些集线器从八端口MAU处分支出来，并向一个机群中的两个或多个工作站提供连接。非IBM厂商也生产包括附加端口、失效检查功能和管理功能的MAU设备。在小型计算机和大型计算机系统中也可以使用令牌环连接。

    图T－8如果MAU的一条电缆切断了，这个网络通过使用电缆中的一组冗余电线形成一个回路返回，从而保证这个网络可以继续工作。图T－9中，大型令牌环网络包括一个可以跨越整个机构的环。

    IBM令牌环允许下列电缆类型：

    类型1一种双绞线22AWG电线的屏蔽电缆。

    类型2一种音频／数据屏蔽电缆。对数据，需要双绞线22AWG电线；对音频需要26AWG电线的四双绞线，外加屏蔽保护。

    类型3包括四个实心非屏蔽双绞线22或24AWG电缆。为在令牌环网络上使用，需要一个介质过滤器。

    类型5光纤（100／140micron）缆线（两股）。

    类型6可弯曲的屏蔽双绞线26AWG线路的插线电缆（patch cable）。限制距离为类型1的三分之二距离。插线电缆将一台PC连接到另外一台设备或一个墙壁插口上。

    类型8为在地毯下使用的屏蔽双绞线26AWG缆线。限制距离为类型1的一半。

    类型9屏蔽双绞线26AWG通风防火电缆。限制距离为类型1的三分之二距离。

    虽然类型1屏蔽电缆是最经常使用的电缆，但是类型3也常使用。虽然类型3不用于16Mbps的令牌环卡，但是已经实现了一种规范可以使它用于这个工作。下面介绍使用类型1的标准令牌环网络的部件。

    令牌环适配器 可获得的令牌环卡有4Mbps和16Mbps两种型号。如果在4Mbps的网络上使用了16Mbps的卡，它就转换到4Mbps进行操作。在16Mbps网络上必须运行16Mbps波特率的网卡。用于无盘工作站的令牌环卡将需要一个远程自举芯片。

    多站点访问单元（MAU）MAU使用网络适配器连接八个或更多的工作站。它可以互联多达12个MAU设备。可以从一些厂商获得具有一定数目端口和诊断功能的MAU。

    令牌环适配器电缆 令牌环电缆通常在网络接口卡的一端有一个九针连接器和一个插进MAU的特殊类型A数据连接器。适配器电缆通常仅有8英尺长，但是可以使用插线电缆将它们扩展到150英尺。也可以从一些厂商获得电话型电缆和适配器。

    插线电缆 插线电缆扩展MAU到工作站的距离，或将两个或多个MAU设备连接在一起。在IBM系统，它们必须是150英尺范围内的任何长度的类型6电缆，并且在使用时，它们将工作站对MAU的距离减少一半。

    连接器（或称为接插件）类型1电缆使用IBM布缆系统类型A数据连接器，它们是同时性连接器。可以通过轻轻一插就将一个类型A接插件与另外一个接插件直接相连。

    介质过滤器 当使用类型3电话绞线电缆时，需要在工作站上使用一个介质过滤器，它对电缆接插件进行转换并减少线缆噪音。

    接插板 在MAU和与电话接插块之间连接电缆时，接插板是很有用的。可以使用标准的电话接插件将这个接插板连接到这个接插块。另外一种方法是，直接用电线将MAU连接到接插块。

    在一个令牌环上的最大站点的数目是：对屏蔽电缆为260，对非屏蔽电话绞线电缆是72。当使用类型1电缆时，从工作站到MAU的最大距离是101米（330英尺）。这里假设这条电缆是一个连续的段。如果使用插线电缆将多个电缆段联合在一起工作站对MAU最大的距离是45米（150英尺）。

    如果使用多个MAU，它们必须连接在一起，并在一个地方用电缆连接。令牌环网的本质决定了计算它的最大长度是一件非常复杂的事情。这个局域网的总长度可能因为每个站点的登录情况而改变。例如，如果通过一条8英尺插线电缆相连的站点进行登录，那么就在总的环距离上增加了16英尺。这是因为从MAU输出到这个工作站的信号，然后还返回这个MAU再到下一个站点。

    任何人如果希望在很广的区域为IBM令牌环网布缆，他就需要进一步参考IBM在这个问题方面的出版物。这些出版物可以从IBM的销售商那里获得。如果使用了其它厂商的产品，就需要参考他们的说明书。Black Box、Andrews，Star－Tek、和Nevada－Western是提供非IBM令牌环产品的厂商，他们都有非常好的说明书和规划指南。

    Token Ring Frames 令牌环帧

    图T－10示意了两种令牌环帧的格式。上面的帧用于令牌，下面的帧用于传输数据或控制信息。下面介绍这些帧中域的情况。

    起始符 说明数据的开始。它是一个独用的代码，以示与其它数据的区别。

    访问控制 包含这个帧的优先级，以及需要保留的一些令牌信息。如果还有其它的帧具有较低的优先级，其它的站点就会赋予这些保留信息。

    帧控制 定义帧的类型，可以是介质访问控制（MAC）信息，也可以是终点站点的信息。如果这个帧是一个MAC帧，那么所有这个令牌环上的站点都阅读这个信息。如果这个帧包含信息，它就仅被目的站点阅读。

    目的地址 将接收这个帧的站点的地址。这个帧可以被编址送到这个令牌环上的所有站点。

    源地址 发送这个帧的站点的地址。

    数据 包括数据的“原样（playload）”。如果这个帧是一个MAC帧，这个域可能包含附加控制信息。

    帧检查序列 包括错误检查信息，以保证接收方的接收帧的完整性。

    结束区分符 指示这个帧的结束。

    帧的身份 提供是否一个或多个令牌环的站点识别了这个帧，是否这个帧被复制了，或是否不可抵达目的站点等的指示信息。

    在令牌环网络，一个站点拥有了一个令牌并改变一位，将这个令牌转变为一个帧的开始序列（SFS）。在这个令牌上，有一个域被工作站指明为进行传输所需的优先级类型。这种优先级的设置基本上是一次对将使用这个令牌的站点的请求。其它站点将这个站的优先级级别与自己的优先级级别进行比较。如果这个工作站的优先级比它们高，它们就允许这个工作站继续使用这个令牌一段时间。如果可能，其它工作站可以获取更高的优先级别。

    连接在这个令牌环上的工作站，将分组传送给它们下游的邻居。于是，每个工作站都象一个中继器。当一个新的站点连进这个网络时，它通过一个起始过程就成为了这个令牌环的一部分。这个过程需要检查是否有重复地址，并且它的存在告知它的邻居。

    活跃监督器（active monitor）的地位被授于这个网络中的工作站之一。通常在这个局域网建立时，授予为第一个工作站。这个活跃监督器观察整个网络，并检查问题，例如提交帧时的错误，或由于一个工作站的失效，需要在MAU中旁路这个工作站。这个活跃监督器基本上保证了网络有效无错地运行。如果这个活跃监督器失效了，可以用另外一个工作站顶替它，并通过传送“宣布令牌”来开始它的工作。

    相关条目：Network网络；Token and Token Passing Access Methods令牌和令牌传递访问方式；Topology 拓扑结构。


  • 拓扑结构 Topology

    网络的拓扑结构描述网络的物理布局。根据网络是一个局域网（LAN），或是用路由器连接的互联网络以及广域网（WAN）连接，可以将拓扑结构设计分为两类。下面将分别讨论这两种分类情况。

    Local Area Network Topologies局域网拓扑结构

    局域网拓扑基本上是互联网络的分支子网络。它们包括下面的设计，如图T－11所示。

    总线 一条单一干线电缆，以菊花链拓扑连接每个工作站。信号被广播到所有站点，但是分组只被编址指定的站点接收。IEEE 802．3以太网是基本的总线标准。

    星形 工作站连接到集线器，并且信号被广播到所有站点，或一个接一个地传递。

    星形配置环 是一个环形网络，其中信号按照一个圆圈从一个站点传递到另一个站点。它的物理拓扑是星形的，其中，工作站从集线器分支出来。IEEE802．5令牌环是它的基本标准。

    星形／总线配置 用长线总线干线连接起来的星形配置的工作站组的网络。

    如果所有的工作站排成行，就象从教室或办公大楼走下大厅的楼梯，一个总线拓扑结构是比较容易安装和管理的。如果这条电缆出现了断路，那么这个网络就会崩溃。以太网10BASE－T是一种星形／总线拓扑结构，它将工作站连接到中央集线器盒。一条电缆的断路仅仅影响连接到这条电缆段的那些工作站。使用广播方式来将信号传输给所有的工作站，但是站点仅仅接收送给它们的广播。一个新的需求优先级访问方式加到了这个集线器，用于控制和管理电缆的访问和降低冲突问题。

    星形拓扑提供了对电缆断开的保护。如果一条到工作站的电缆断开了，整个LAN段并不会崩溃。而且还很容易诊断连接问题，这是由于每个工作站都是单独连接到这个集线器的。大多数星形配置的网络使用廉价的双绞线电缆，并且为了诊断和测试，所有的线头都放置在一个位置。

    Internetw0rk Topologies 互联网络拓扑结构

    互联网络是用网桥和路由器互联的部门或工作站的局域网。在局部环境，例如一座建筑物中，通常使用一个主干电缆，但是建造城市或广域网就需要使用象电信局提供的公共服务。下面将讨论三种主要的拓扑结构，如图T－12所示。

    主干网络 在办公室或校园环境中，通常可以发现多个部门或建筑物在主干电缆上进行互联。网桥或路由器管理子网络和主干电缆间的通信流。

    散列网络 路由器与其它路由器进行互联。这种拓扑结构可能在本地配置，但是通常用在城市或广域网，通过远程通信链路将远程的办公室连接起来。路由器用于选择从起始地到目的地穿越散列（网目）的最佳或最有效的路径。通过选择散列中的其它路径来旁路失效的链路。

    链路间星形（interlinked star）结构 这是一种为在建筑物或校园环境构造布线系统的新型拓扑类型。部门的星形配置的集线器，连接到处理集线器间通信量的中央集线器。

    相关条目：ARCNET；Cabling布缆；Ethernet以太网；Networks 网络；Token Ring Network令牌环网；Wide Area Networks广域网。


  • 事务处理 Transaction Processing

    通常在数据库系统中，事务是工作的离散单位。例如，一个数据库事务可以是修改一个用户的帐户平衡或库存项的写操作。联机事务处理系统（OLTP）实时地采集处理与事务相连的数据以及共享数据库和其它文件的地位的变化。在联机事务处理中，事务是被立即执行的，这与批处理相反，一批事务被存储一段时间，然后再被执行。大多数批处理（例如帐目交换）是在夜间进行的。OLTP的结果可以在这个数据库中立即获得，这里假设这些事务可以完成。联机事务处理以实时的方式发生。民航定票系统和银行ATM机是联机事务处理系统的例子。

    数据库管理系统使用一些语言（如结构化查询语言（SQL））中的语句执行事务。IBM已经定义了如下事务类型：

    语句 它在某时完成对一个数据库进行的处理。

    工作单元 它包括在一个数据库上执行的多条语句。

    工作分布式单元 它包括在多个数据库上执行的多条语句，其中在一个时间，每个数据库上执行一条语句。

    分布式请求 在多个数据库上执行的多条语句，其中，在一个时间，每个数据库上有多条语句执行。

    在单一用户、单一数据库环境下执行事务是简单的，这是因为没有冲突问题或对数据库间同步的需求。在分布式环境下，维护多个数据库的完整性是另外一种问题。传统上，大多数联机事务处理系统在大型计算机系统上实现，这是由于它的操作的复杂性，以及需要快速输入／输出、禁止和管理的原因。如果一个事务必须在多个场地进行修改，那么就需要管理机制来防止重写数据并提供同步。其他的需求包括具有卷回失效事务的能力、提供安全性特征，以及如果需要，提供数据恢复的能力。这是通过一个事务处理监督器来处理的。这个监督器保证了事务是完全完成的或是进行卷回的，因而就可以保证数据库状态的正确性。

    在一个分布式环境下，写操作经常并行地在多个数据库服务器上发生。这样的并发事务处理需要一个“卷回”机制，以保证在一次写操作中系统失效的情况下，仍保证数据库的完整性。事务要么一起确认，要么放弃。如果一个或多个与事务有关的系统响应不一致，这意味着系统或通信可能出现了故障，因而就会放弃一个事务。

    可以看出，当多个用户试图同时改变数据的同一块时，就出现了冲突问题。另外，对多个数据库的写入操作必须进行同步处理，并且必须保证这个写入已经确实被所有的数据库处理完毕了。需要一个监督程序来保证数据的完整性。对在分布式环境下的事务处理有四种需求，联合起来称为“ACID”。

    原子性（atomicity）定义工作的独立单元。如果一个事务是分布的，所有影响分离地点数据的子事务都必须象一个事务那样被一起执行。为了保持在多个地点数据的一致性，需要使用下面就将介绍的双阶段认可过程。

    一致性（consistency） 一致性基本上是一种数据库从一个状态变到同等的另一个状态的需求。事务监督器必须检验所有被影响的数据都是一致的。

    孤立性（isolation） 事务必须被孤立地执行直到完成，执行期间不受到其它事务的影响。

    持续性（durability） 这个性质是与事务的最终确认一起进行的。一旦一个事务被检验为对所有受影响的系统都是正确的，它就被认可并且不再需要卷回。

    Two－Phase Commit双阶段提交

    事务处理的特征是，当事务没有完成时（例如，由于没有足够的资金或缺少担保，或由于电源失效或通信链路失效而没有完成时），具有卷回这个事务的能力。一个事务要么被全执行完毕，要么被卷回，于是在被卷回时它又返回了这个事务前的状态。事务监督器是一个监督执行过程的程序。当用户执行一个事务时，就对数据库进行了一些改变。如果这个用户想放弃这个事务，事务监督器保证所有被影响的数据库返回它们在这个事务前的状态。

    在分布式环境，事务处理导致了许多复杂性。用户可能需要访问多个不同地点的数据库，并且同时对多个数据库进行修改。这些修改必须是相互一致的。例如，如果在一个银行的多个支行保持了这个银行的帐户平衡，而出纳对一个顾客的帐户进行了修改，那么就必须同时在所有地点进行这一改变。如果在这个事务期间，到任何一个支行办公室的计算机链路失效了，这个事务监督器必须知道这一情况，并通知所有其它支行这个事务没有完成，并且要求卷回。用双阶段提交完成这个任务。

    双阶段提交是将对数据的写入分解为两个阶段，每个阶段结束都有一个完成的验证。在下面的步骤中假设在这个事务中不出现故障：

    1．卷入这个事务的数据库系统保留数据，以对内存中的数据进行验证。

    2．事务监督器发送一个“预验证”命令到这个数据库系统。

    3．数据库系统应答它们已经准备好了进行验证。

    4．在接听到每个数据库系统的应答后，事务监督器发送一个“验证”命令。

    5．数据库系统应答它们成功地对数据进行了验证。

    6．当事务监督器从所有数据库系统接收到数据已经被成功地验证的响应后，它完成这个事务。

    如果这个事务监督器在步骤3和5，从所有数据库系统没有听到所需响应，这个事务监督器警告系统卷回它们的事务。

    Common Transaction Processing Systems公用事务处理系统

    下面是一些事务监督器产品，它们可用于不同的分布式环境中：

    Encina，它是Transarc公司（Pittsburgh，Pennsylvania）的产品，是一种通过提供事务起始和终止、双阶段提交、意外事件处理、恢复和放弃操作，来保证穿越多个平台的数据和数据库的完整性的联机事务监督器。EncinaTP监督器是一种基于开放软件基金会的分布式计算环境的监督器。主要厂商如IBM和Hewlett－Packard计划使用Encina。

    Tuxedo，它是UNIX系统实验室（Summit，New Jersey）的产品，可以用于协调网络上的修改。它可以在不同系统上并发运行进程，它可以分布工作负载，并且如果一个系统失效了，还可以保证这个处理进行下去。它最初是AT＆T开发的，并由Novell的UNIX系统组推向市场。它在许多不同的计算机系统上运行，并被一些客户支持，这些客户包括DOS、OS／2，以及Windows操作系统。

    IBM顾客控制系统（CICS），是一种在IBM主机系统上运行的TP监督器。这是一种得到广泛使用的事务处理系统。它支持分布式环境，并包括一个事务管理器和事务监督器。CICS为它的AIX／6000实现使用Encina功能。

    相关条目：Connectionless and Connection－Oriented Transactions无连接和面向连接事务；Encina；Tuxedo。


  • 以太网收发器，以太网的接收发送器 Transceiver，Ethernet

    接收发送器为标准粗缆网（Thicknet）802．3以太网电缆提供了物理和电气连接。接收发送器通常是一个监听设备，这是说，这种设备将无需切断电缆就连入它，并可以在任何时候被增加或移去。


  • 传输率 Transfer Rates

    参见Data Transfer Rates 数据传输率。


  • 传输控制协议／Internet协议 Transmission Control Protocol／Internet Protocol

    传输控制协议／Internet协议（TCP／IP） TCP／IP协议组的发展目标是，允许在许多独立的多厂商系统间进行通信。在1983年，TCP／IP成为国防部Internet的官方运输机制，它融进了一个跨越全球的互联网络的系统。它具有很强的网络互联能力，并且正在不断地变得更加流行，这是因为它的开发是开放的，并且受到美国政府的支持。这种协议经过很好的测试，并具有很好的文档。

    注意：这里引用的历史信息来源于Vinton Cerf（他是TCP／IP协议组的顾问）和DanielC．Lynch（Interop公司的总裁和创始人）的报告。这些报告出现在Internet System Handbook（Greenwich，connecticut：AddisonWesley，1993）。

    在六十年代末和七十年代初，因特网开始以称为ARPANET的广域网形式渐现雏形。ARPANET是由美国国防部高级研究规划局（DARPA）出资建设的。从1969年开始，它包括用实验性的分组交换系统建立和连接的计算机。开始，这个系统采用了一种客户机／服务器关系，但后来决定采用主机对主机协议会好一些。这种协议称为网络控制协议（NCP）。

    到1972年，进行了一些验试，其中，许多终端在不同的远程链路上被连接到不同的主机上。随着这种实验的继续，有一种不断增加的需求，就是必须对许多不同类型计算机进行互联的过程进行简化。那时每个计算机厂商都使用不同的硬件和软件来互联它们的系统。它的目标就是开发一种互联方式，使得能够在不同类型的传输方式上（包括低速、高速和无线连接）支持不同类型的计算机。

    传输控制协议（TCP）的开发始于1973年，由DARPA和Vinton Cerf进行，然后在斯坦福大学进行。到1978年，它已经基本完成了，并在此之后被称为传输控制协议／Internet协议（TCP／IP），这时因为需要将TCP协议分解成顺序的、面向连接的协议（TCP）和一种高效的、端点对端点无连接协议（IP）。

    在七十年代末的某个时候，有一种将TCP／IP协议组集成到开放式系统互联（OSI）协议的努力，但是这个努力失败了。DARPA已经资助UC Berkeley将TCP／IP集成到它的UNIX版本中。这个集成后的产品取得了巨大的商业成功，并推助TCP／IP成为在美国选择的网络互联标准。

    在1975年，ARPANET成为了一个运营实体，而不仅仅是一个实验，于是用了6个月时间将它转交给国防部（DOD）防御通信局（DCA）。DCA然后就开始管理这个网络。在1985年，国家科学基金会（NSF）开始资助一些将许多大学和协会连接起来的主干线缆的研究工作。这个主干已经创立，并称为NSFnet，它替代ARPANET，而成为了因特网的支柱。

    同时，TCP／IP协议组也在继续改进。TCP／IP开发的一个最重要的方面是，经过测试的程序和政府的认可，它们保证了开发人员可以得到出版的TCP／IP标准。这保证了开发人员不必为适合他们的需要而改变协议标准，以及可能在TCP／IP的其它部分出现混淆。今天，TCP／IP协议的使用基本保证了使用它进行通信的系统之间的互联性，并且在一些情况的具有一定互操作性。

    The TCP Protocol TCP协议，传输控制协议

    最初，TCP协议是为互联使用多种不同类型的传输方式的网络而开发的。为了适应这些介质的差异，创建了网关（有时称为路由器）的概念，它是指对来自一个网络的分组进行封装，变成一个包括另一个网关的地址的分组。在这个分组抵达它的最终目的地之前，它可能还会被再次打包和编址到一些网关。如图T－13所示。采用这种封装方式是有一些原因的，但其中最重要的原因是：设计人员不希望这些不同网络的主人通过改变自己以适应网络互联的网内策略。它假设每个网络都要实现它自己的通信技术。

    TCP协议采用sockets接口在两个系统间建立双向（双工）连接。sockets是描述计算机通信地址的端点和正在运行通信应用的计算机内的一个“端口”。你可以将这种安排想象为你想打通建筑物中的电话，这个建筑物有一个地址，并且这个电话就象一个将你与一个特定的人连接在一起的位于这个建筑物的一个端口。同样，一个sockets就是到一个计算机内的应用程序或进程的连接。

    TCP通信会话是面向连接的并且具有如下特征：

    流控为两个系统提供了在分组通信中的实际协调，以防止溢出和丢失分组。

    分组接收的应答使得发送方知道接收方已经接收到分组。

    端点对端点的序列化可以保证分组按顺序到达，所以目的地不再需要对它们重新进行组织。

    口检验和特征，用于保证分组的完整性。

    分组损坏或丢失，导致分组重发，以按时并有效的方式来处理。

    面向连接的会话需要一个建立阶段、一个切断阶段和一些监督功能，以及一些不是数据运输所必须的额外通信开销。在开发TCP的过程中，USC的Denny Cohen为适应“追求及时而不是精确”的目标，建议分解TCP协议。他说，所有的流控和错误检查，以及建议面向连接的会话的开销，并不总是必须的。所需的途径是，尽快地将数据发送到另外一个系统，然后由这个系统自己进行错误检查和数据排列工作。这样，TCP就变成了TCP和因特网协议（IP）。用户数据报协议（UDP）的创立，也为应用访问IP的无连接特征提供了一条途径。TCP和UDP都使用IP。下面先进行简单的介绍，然后再进行细节性的介绍。

    TCP通过使用面向连接的技术，提供了从一个结点到另外一个结点的可靠数据传输。

    UDP为应用提供了数据报服务。UDP的基本作用是，将一个应用程序进程的端口地址加到一个IP分组上。

    IP是一种提供基本数据报传递服务的无连接服务。

    下面将详细讨论IP和TCP协议。IP将首先讨论，这是因为TCP使用IP在网络上传输信息。下面不讨论另外两种在TCP／IP网络中使用的协议：

    网间控制消息协议（ICMP）提供一条报告网络中错误的途径。ICMP分组使用IP协议传送，并且提供数据报产生错误的信息，或提供查询远程地点情况的途径。

    网间组消息协议（IGMP）提供使用IP协议将消息发送给一组用户的途径。这种功能称为多址（multicasting）发送。

    Internet Protocol（IP） Internet协议（IP） ，因特网协议（IP）

    IP是提供数据报服务的一种无连接通信协议。数据报是分组交换中的一种完整分组。它独立于其它分组，并且携带足够的信息，用于选择从源DTE数据终端设备到目的数据终端设备的路由，这种选择不依赖于原来在各个数据设备和网络之间的交换。它是根据它们的地址、以及在这个路由器中的路由选择信息表、被路由器进行转发的。数据报可以被编址到一个单一结点或多个结点。其中没有流控、接收应答、错误检查和序列化。数据报可能通过不同的路径到达目的地，于是可能是乱序抵达的。接收站点负责进行顺序排列并检查是否有分组丢失了。IP通过简单地抛弃一些分组来处理通信拥挤。重新排序和错误处理有更高层协议负责处理，而不是由IP进行处理的。因而，IP是快速有效的，并且非常适合已经提供了相对可靠服务的现代网络和远程通信系统。

    IP在一些局域网和广域网上工作。例如，当IP运行在以太网上的局域网环境时，在以太网帧中的数据域存放IP分组，并且在这个帧中有一个特定的域说明包含了IP信息。IP使用一个独立于网络编址策略之外的编址策略。例如，每个以太网适配器都有一个生产厂商赋予的硬件地址。IP不使用这个地址，如下所述，它实际上对每个结点使用一个授予的地址。

    IP编址

    TCP／IP网络中的每个结点都需要一个4字节（32位）数字地址，它用于辨别是一个网络、一个局部主机、还是这个网络中的结点。这个地址被写成由小点隔开的四个数字，例如，191．31．140．115。在大多数情况下，网络管理人员安装一个新的工作站时，建立这些地址；然而，在另一些情况下，也可能是工作站在自举时向工作站查询以被动地授予地址。

    这些地址的授予是由一个公司或机构专断的，但是如果这个公司计划在最近的什么时候要与Internet相连，就必须从防御数据网络（DDN）的网络信息中心（NIC）获得一个注册地址，防御数据网络的网络信息中心是由在Vairginia的Chantilly的网络裁决局（Network Solution）管理的。随着因特网越来越流行，建议所有的机构都获得一个注册地址，以避免将来出现地址冲突。

    存在三种Internet地址：A类、B类和C类：

    A类 支持16，000，000个主机（连接的计算机），但只有127个可赋的网络号。

    B类 支持65，000台主机和16，000个网络号。

    C类 支持254台主机和2，000，000个网络号。

    由于Internet地址是主机和网络号的结合，所以多个主机可以共享这个网络号的主机部分，但是每个主机必须具有它自己独特的号码。例如，在C类号码中，第一组数字是主机号，最后三组数字是网络号。

    IP编址支持上百万个地址，但最近，也出现了潜在的短缺危机。伴随着Internet的不断流行，短缺可赋予的地址是不可避免的。

    预计在1995年，Internet将用完它的地址。一种称为简单Internet协议（SIP）将改善这种局面。SIP将使用64位地址而不是IP的32位地址，从而加倍了可能的地址数目。SIP将对IP向后兼容。

    IP数据报结构

    IP数据报包含地址、路由选择信息和其它为将数据的分组从源地发送到目的地的分组头信息。下面将介绍IP数据报域的情况。注意：鉴别、标志和段偏址域，是为在不能处理大的数据报的子网络上传输，而将分组的片段分解为两个或多个数据报时所需的。

    版本（version）说明IP协议的版本，允许从一个协议版本变为另一个版本。

    长度（length） 描述分组头的长度。

    服务类型（Type of service：TOS）用于指示数据报所需的服务类型或“质量”。处理数据报的路由器阅读这个域，如果需要，将提供优先服务。以前，这个域指示军事急件或关键事件所要的优先处理。根据在Internet Engineering Task Force（IETF）最近的讨论看出，现在，TOS的定义已经改变为减少延迟、减少金钱开销、增大吞吐率，或增加可靠性的需要。

    总长度（Total length） 说明数据报的总长度，最大长度为65，536个字节。

    鉴别（Identification）提供连接独立分段数据报的信息，于是目的站点就可以将它们组装成一个完整的分组。

    标志（flags） 有两个标志位。第一个标志位指定一个分组不允许被分段，所以必须在能将处理分组当前长度的子网络上传输。第二个标志位指定一个数据报是一个分段分组的最后。

    段偏址（Fragment offset） 对于分段数据报，这个域指出这个数据在分组中的原来位置，在重新组装的过程中将用到这个信息。

    存活时间（Time－to－live）这个时间以秒为单位，它是数据报可以生存的时间。在传输中，如果超过了这个时间，这个数据报就被认为丢失了，或在一个循环内并且被废弃。

    协议（protocol）标识数据报的协议类型，这样就可以允许非TCP／IP协议工作。

    分组头检验和（header checksum）提供一个错误检查数值，以保证一个被分发分组的完整性。

    源／目地址 这是数据报源地和这个数据报目的地的地址。

    选择（option）这个域是可选的，它提供了记录通过网络的一条路径或指定一条路径（源地路由选择）。

    Transmission Control Protocol（TCP）传输控制协议（TCP）

    TCP提供了一条为可靠地传送消息和数据，而在端系统间建立一条连接的途径。TCP连接具有前面介绍的所有面向连接的特征，例如流控、应答、序列化、进行校验和检测和重发等。当一个应用使用TCP时，就需要一个连接建立阶段，但是一旦这个连接建立好了，它就可以在端系统间提供可靠有效的数据传递。对于长期的数据交换，或当需要一种相对永久的连接时，面向连接的会话是有用的。

    为建立TCP连接，活动站点向另一个站点发送一个消息。这个站点回告这个活动站点，它已经准备好建立一个通信会话了。然后，第一个站点也回告确认这个连接，并且进行一次起始数据传送，以建立数据传输控制。下面介绍TCP分组中域的情况：

    源／目端口（source／destination port） 使用TCP服务的应用进程的端口号。

    序列号（sequence number） 提供接收方对分组进行排序和确认是否有分组丢失的信息。

    应答号（acknowledgement number） 提供接收到字节的指示，返回给发送方，于是如果需要就可重发丢失的分组。

    长度或偏址（offset or length） 说明分组头的长度。

    代码（codes）这个域包括：指示紧急需要的分组或这个分组是数据尾的代码。

    滑动窗口（sliding window）提供一种增加分组体积的途径，从而改进数据传输的有效性。

    分组头检验和（header checksum）提供一种错误检查的数值，以确保被发送分组的完整性。

    紧急指针（urgent pointer）指示放置紧急数据的位置。

    选择（option）一个为将来或特殊选择准备的可变域。

    注意，为了提供可靠的功能，TCP层在端系统上运行时，可以使用IP在网络结点间传输数据。IP分组包含端点结点的地址，而TCP分组包含源地和目的地端口号。比如，你与一个朋友进行了一次会谈，却通过另外一条电话线路向这个朋友传送信息，你使用“语音会话”为“数据通信会话”建立参数，然后，讨论交换的过程，最后应答，完成了全部数据的接收。

    Application Protocols 应用程序协议

    已经在TCP／IP协议组的上面建造了下面的应用程序，并且在许多TCP／IP安装中都可以获得这些应用程序，其中包括Internet。这些应用在本书的其它地方也有讨论。

    网络文件系统（NFS） 针对UNIX主机的一种文件系统，它是可共享的并且是分布的。它最早是由Sun Microsystems公司开发的。

    简单网络管理协议（SNMP）一种网络管理协议，它采集网络的信息，并且将它报告给管理人员。

    文件传送协议（FTP）使得可以在工作站与UNIX主机或Novell NetWareNFS之间传输文件的协议。

    简单邮件运输协议（SMTP） 一种能够进行电子消息传递的协议。

    Telnet DEC VT100和VT 330终端仿真。

    相关条目：Advanced Research Projects Agency Network 高级研究规划局网络（ARPAN）；Connection－Oriented and Connectionless Protocols面向连接和无连接协议；DARPA（Defense Advanced Research Projects Agency）DARPA（国防部高级研究规划局）；Datagram Network Services 数据报网络服务；Domain Name Service域名服务；Encapsulation封装；Internet；Routing Internet路由选择Internet；Routing Protocols路由选择协议；Sockets嵌套字，套节字。


  • 传输介质、方法和设备 Transmission Media，Methods，and Equipment

    传输介质可以支持声波、电磁波和光波信号的传播。这些介质通常能够将这些信号限制在它们内部的金属电线或光纤线缆内。无线电传输是通过直线型的微波和卫星通信提供的。介质的类型、它的屏蔽情况，甚至在铜质电线对中绞线的数目，决定了这个电缆上可能的数据传输率。

    传输线路可以是“平衡的”或“不平衡的”。平衡的线缆通常是包含两个导体的双绞线或双股电缆。非平衡线缆通常是一个同轴电缆。在平衡线路中，两根电线都连接到发生器（发送方）和接收方，并且它们都有相同的电流，但是电流是反方向的。在非平衡线缆中，电流通过导体流过去，并通过大地返回。

    Cable Types电缆类型

    下面介绍网络通信系统中通用的电缆类型，如图T－14所示。

    直线电缆 直线对电缆包括用绝缘体包裹的铜质电线。这些电线可以是一束的，或象扁平电缆那样的，用于连接短距离或低比特率的外围设备。用于连接调制解调器或串行打印机的串行电缆使用这种类型的电线。在相临的电线间会出现串音现象，但是纽绞这些电线可以减小串音，如下所述。

    双绞线 双绞线电缆用绝缘体包裹的一对铜芯电线，两根电线绞绕在一起，形成了一个平衡电路。这种纽绞避免了干扰问题。双绞线通常用于音频电话系统和计算机网络。通过使用高级电缆（类别5），并确保到连接点的所有双绞线的连通性可以获得高数据传输率（100Mbps）。如果需要，可以使用多股双绞线带屏蔽的电缆。

    同轴电缆 同轴电缆是被绝缘体、接地组合屏蔽网包裹的固体铜芯线，带有外部护套。使用同轴电缆可以获得高数据传输率，但是新近的一些用于双绞线电缆的额定传输技术可以提供相同或接近于同轴电缆的数据传输率。然而，同轴电缆的额定传输距离仍然高于双绞线电缆。

    光纤线缆 光纤线缆包括一个用于进行光波传播的中央玻璃芯。这个芯有一层反射内部玻璃芯光线回这个芯的玻璃外衣。一层厚塑料外套和用于增加强度的特殊纤维包围了它们。如果需要跨越很大的距离，可以使用增大强度的具有金属芯的光导电缆。光纤线缆通过干净的玻璃传输光子。其中，没有信号干扰，也没有任何信号辐射。光纤线缆还可以跨越比铜质电缆更长的距离。参见“光纤线缆”。

    开阔空间传输 这种类型的传输采用红外线和无线电波来实现。

    参见Microware Communication 微波通信，Satallite Telecommunication 卫星远程通信，Wireless LAN Communication无线LAN通信，Wireless Mobile Communication无线移动通信。

    Transmission Methods 传输方式

    用电子、无线电波，或光产生信号，是为了传输编码的信息。在介质上可以采用两种方式来传输信号，即模拟信号传输和数字信号传输。

    模拟信号 表示设备内无限连续变化的电压或波，这个设备产生、测量、记录或传输这个信号。例如，电话厅中的电话产生的一段波形是模拟信号。

    数字信号 是通过信道中的电平在高低状态之间进行变化来传输的。其基本任务是将信息编码表示为二进制数1和0的传输信号。

    模拟传输

    模拟信号是传导能量的一种方式，例如声波通过振动空气来传播。一个音调和音量变化的声波，可以在纸张上被映射出来，如图T－15所示。

    电话机是一个将模拟声波转变为相应电气信号的转换设备。在电话或音频系统的接收端，接收到说话人振动信号的振幅（音量）和音调。音调反映扭波的振动频率。频率通常用每秒的周期数（cps）或赫兹（Hz）来测量。一赫兹是一个cps。1kHz（千赫）是1，000Hz，1MHz（兆赫）是1，000kHz，1GHz是1，000MHz。人类可以听到的范围在20Hz到20，000Hz之间，并且这也是高保真音响设备的工作范围。

    模拟波形可以是非常简单的，也可以是非常复杂的。由单一钢琴定音器产生的一个声波仅仅包括一个单一频率。一个复杂波形——例如人类的声音或管风琴的声音——包含了许多不同频率的组合，如图T－16所示。

    电话系统使用模拟交换线路来进行音频通信。总的来说，在模拟线路上进行数据通信存在一些限制其有用性的问题。需要进行调制来将数字信号转变为模拟信号，并且由于音频线路的频带较窄，于是传输率就受到了限制。而且，模拟信号在长途中必须一级级放大，因而这些信号中的畸变也将放大。为一些需求传输大量信息的应用（例如图形处理和语音处理）需要超过模拟服务能力的更大带宽。

    数字传输

    音频、视频、数据和其它“信息”，可以被编码成二进制数值，就可以被有效地传输，并且这些数值是以电脉冲的形式进行传输的。线缆中的电压是在高低状态之间进行变化的。因而，二进制1是通过产生一个正电压来传输的，而二进制0是通过产生一个负电压来传输的。数字服务可以比模拟服务提供更高的可靠性，特别是对于长途情况更是如此。如果这个信号需要放大，数字信号只需要简单地再生就行了，如图T－17所示。与此相反，模拟信号在长途情况下需要一级级放大，而且还会放大电缆中的各种噪音。

    模／数转换，或叫数字化，是将现实世界中连续变化的波形转变成可以在计算机中存储和处理的数字信号的过程。这种模／数转换过程（通常称为脉码调制，PCM）包括对信号以固定时间间隔进行采样，并以二进制的形式采集它的振幅和频率信息。这个数值的精确性依赖于用于保存这个数值的位数。如果一个模拟波以每秒1000次的速度进行采样，就可以获得1，000个分离的数字数值用于存储或传输。当语音为了在数字线路上进行传输而进行转换时，它每秒被采样8，000次，并且每个采样样本被转换成8位二进制数值 于是一个数字化音频信道需要每秒64，000位的带宽。

    Transmission Modes传输模式

    数据可以按面向位或面向字符（也称为面向字节）的方式进行传输。在面向位的传输中，这些位表示数据的连续流（就象图象数据），它们除了表示帧开始的一个特定标志位外，对于发送方或接收方并没有什么特殊意义。在通用面向字符协议中，8位序列表示控制代码和字母数字字符。面向字符协议包含许多传输模式，它们将在下面讨论。

    单工电路 一种单向连接，就象无线电广播一样，其中，接收方不能应答。在数据通信中，在主从配置中使用单工电路，其中，一个设备控制其它设备，并且不需要被控制设备进行应答。当在被控制站点需要人们的交互工作时，通常不使用单工电路。

    半双工电路 一种双工传输，但是在一个时间仅仅能进行一个方向的通信。最好的例子是公民波段（CB：CITIZEN BAND）无线电通信，其中在一个时间只能有一个操作者讲话。当一个操作者讲话完毕时，他或她说“结束”，于是另一个操作者才能讲话。同样，半双工电路用一个信号发送系统指示何时一个设备完成了发送或接收，于是其它的设备就可以访问这条线路了。半双工通信可以使用单线、双线电缆和双绞线。

    全双工电路 是一种双向同时的通信。在数字网络，应该使用两对电线来完成这个电路。被调制解调器连接的模拟电路仅仅需要一个电线对。这个电路的带宽被分成两个频率，它允许数据同时在两个方向流动。

    当以半双工模式连接终端时，在终端上打入的字符将被显示和传输。然而，在全双工模式下的终端，在它从接收系统传回“回音”后才显示。如果通信系统没有使用同样的模式，就会出现问题。例如，如果一个终端是处于半双工模式，它立即显示打入的字符。如果接收系统或主机处于全双工模式，它还返回一个字符到这个终端，于是导致了在终端上打入一个字符却在屏幕上出现两个显示。如果这个终端处于全双工模式，而主机却处于半双工模式，那么终端将不显示任何字符，这是因为它的全双工模式需要等待来自主机的一个回音，但由于主机处于半双工模式，它并不向终端发送回音。

    Data Communication Equipment（DCE）数据通信设备（DCE）

    大量的数据通信设备，都以DTE／DCE中的DCE命名（参见“数据通信设备”）。DCE处于数据终端设备（DTE）和传输电路或信道之间。它为将DTE连接到通信网络或将通信网络连到DTE，提供了二种连接。另外，它通常终结一个电路，并为这个电路提供时钟。下面讨论一些类型的传输设备。

    调制解调器 调制解调器（调制器／解调器）将数字信号转变为模拟信号，并将这个信号在音频电话网络上进行传输。表示二进制0和1的数字电脉冲在传输的一个端点被转换成模拟波形，并且在另外二个端点被另外一个调制解调器转换回数字信号。这个调制解调器是由数据通信分组的命令进行控制的，它处理拨号和电话的回答，它也控制传输率，传输率的变化范围是300bps到9，600bps。如果使用了压缩技术，采用最新标准可以达到28，800bps，而且更高的速率正在开发中。

    信道服务单元（CSU）这种设备用于连接数字通信线路（例如T1）。它不仅廉价，而且为数字信号提供了一种终结。CSU 提供线路上的不同回路，如果连接到它的其它通信设备失效了，还可以保持这条线路的连接。CSU通常与DSU一起合并使用。

    数据服务单元（DSU）上的数据数据服务单元是在数字信道上传输数字数据时采用的硬件设备。这种设备把网桥、路由器和多路选择器上的数据转化到数字线路上使用的双极性数字信号。

    中继器和电路驱动器 在长途线路中出现的信号畸变可能使得数字信号变得不可辨识。为了克服这个问题并增加传输距离，可以在线路中引进中继器来阅读畸变的脉冲，并再生它们。在电话系统中，每1，818米（6，000英尺）就需要一个中继器。从计算机到外围设备的串行连接大约每15米（50英尺）需要一个线路驱动器。一些线路驱动器可以将这个距离限制扩展到5，000英尺。

    网桥 网桥连接两个相似或不相似的面向分组的局域网。它在开放式系统互联（OSI）参考模型的数据链路层进行工作。网桥可将分组前递到其它局域网或对分组进行过滤以减少互联网络通信量。

    路由器 路由器将局域网（LAN）和其它LAN互联到主干电缆或到广域网。路由器就象网桥，但是却提供了高级功能。它可以知道结点的目的地和到达那里的路由，然后选择最佳路由传递分组到目的地。

    Transmission Services传输服务

    传输服务是由电讯公司或其它已经建立城域网的公司提供的。这些服务在“电信服务”中详细的介绍。

    相关条目：Asynchronous Communication 异步通信；Bandwidth带宽；Cabling布缆；Carrier Services电信服务；Data Transfer Rates数据传输率；Synchronous Communication同步通信；Wide Area Networks广域网。


  • 运输层接口 Transport Layer Interface

    运输层接口（TLI）是一个调用库和在STREAMS环境上面的运行时（run－time）模块。STREAMS和TLI原来是AT＆T为在UNIX环境中使用而定义的。

    相关条目：STREAMS STREAMS环境。


  • Transport layer 传输层

    ISO/OSI 七层模型的第四层，用于计算机间的标准化通信。传输层在网络层之上，负责信息的服务质量以及准确传送。在该层上所执行的任务包括检错和纠错。


  • OSI模型的运输层 Transport Layer，OSI Model

    开放式系统互联（OSI）模型是国际标准化组织（ISO）定义的标准。此标准定义了端系统间用于通信的协议的分层体系结构。在通信会话中，在每个计算机上的每一层运行的进程，相互之间进行通信。它的七层协议一般可分类成三层：

    在底层定义：实际的物理部件（例如，连接器和电缆）、数据如何在系统间进行交换、网络接口的类型和访问方式。

    运输层关心系统间的可靠数据传输。

    应用层为用户应用程序和网络通信系统提供接口。

    OSI模型的设计，是为了帮助开发人员创建可以在多厂商产品系列都兼容的产品，并且提倡开放的互操作联网系统。

    运输层处于OSI协议栈的第4层。它在物理层、数据链路层和网络层之上，刚好在会话层之下。它为会话层提供消息传递服务，并对更高的层隐匿下面的网络。

    运输层提供可靠的端点对端点的数据传输。错误检查和其它可靠性功能如果没有在下面的网络层进行处理，那么就会被运输层的协议进行处理。帧中继和异步传输模式（ATM）网络有这种情况，这两种传输网络在传递分组时，不进行错误检查。事实上，它们假设错误检查是运输层协议处理的，这些协议检查分组中的信息，以确信它们是无错传递的。

    运输层可以提供面向连接和无连接的服务。在面向连接的会话中将建立分组流动到目的地的电路。在这种安排中，分组是按照顺序抵达的，因而不需要全地址或其它信息，这是因为这条电路保证它们被传递到正确的目的地。这种类型的安排用于长传输，或用于一个系统将长期访问另一个系统的资源的连接。无连接会话不建立电路或可靠数据传递。分组被全编址，并分发到网络上。每个分组可以智能地按照不同的路径，最终乱序抵达目的地。在目的地的运输层协议将重新把这个分组排列成以前的次序，并对丢失或损坏的分组发出重发请求。

    相关条目：Layered Architecture分层体系结构；Open Systems Interconnection Model开放式系统互联模型；Protocol Stacks协议栈。


  • 传输协议 Transport Protocol

    参见Protocol，Communication 通信协议。


  • 普通文件运输协议 Trivial File Transfer Protocol

    参见File Transfer Protocol 文件运输协议。


  • 故障诊断与维修，排错 Troubleshooting

    参见Testing Equipment and Techniques 测试设备与技术。


  • 受托者 Trustees

    在NetWare环境，受托者是被授予使用一个资源或访问这个文件系统权力的用户。授予这个受托者的权力，被称为受托者授予。在NetWare 4.X中，“受托者授予”还可以包括管理NetWare目录服务中对象的权力。

    相关条目：Access Rights访问权力；Administrators, Novell NetWare Novell NetWare管理人员；File and Directory Rights, NetWare NetWare文件和目录权限；Rights in Novell NetWare 在Novell NetWare中的权力；Users and Groups用户和组。


  • 管道传送，隧道，管道传输 Tunneling

    参见Encapsulation封装。


  • UNIX系统实验室的 Tuxedo中间件 Tuxedo，UNIX System Laboratories

    Tuxedo是一个客户机／服务器的“中间件”产品，它在客户机和服务器之间进行调节，以保证正确地处理事务。Tuxedo是一个事务处理（TP）监督器，它管理联机事务处理（OLTP）系统（参见“事务处理”）操作的事务。客户通过结构化查询语言（SQL）调用，或其它类型的请求，产生对服务器的请求。这个事务处理监督器确信，正确地进行了修改，以保证数据的完整性。这在一个事务可以改变多个位置的数据库的分布式数据库环境是非常重要的。这个事务处理监督器使用双阶段提交，以保证所有的数据库都已经接收和认可了这些数据的正确性。否则，这个数据库返回它的事务前状态。

    事务监督器从前都是与大的大型计算机系统联系在一起的，但是Tuxedo的设计是为了在不昂贵的基于UNIX的系统上运行。AT＆T最初是作为它自己使用的联机事务处理开发Tuxedo的。虽然Tuxedo必须在U－NIX系统上运行，但是它可以与DOS、OS／2、Windows和UNIX客户一起工作。它还使用通用的通信协议，如传输控制协议／因特网协议（TCP／IP）和网络基本输入输出系统（NetBIOS），并且可以在这些环境提供分布式处理支持。例如，它可以根据请求的类型，服务请求从一个客户选择路由到一个特定的服务器。Tuxedo的基本特征是它的联机事务处理系统，但是，Tuxedo也工作于集成关系型的平面文件，以及层次数据库系统。

    相关条目：Connectionless and Connection－Oriented Transactions无连接和面向连接事务；Transaction Processing 事务处理。


  • 双绞线，双绞线电缆 Twisted－Pair Cable

    双绞线电缆包括两个绝缘的铜质电线，它们相互纽绞在一起。这种纽绞避免了相临电缆产生的串音现象。可以获得以下一些双绞线电缆：

    类别1语音级双绞电话线，不适合数组传输。

    类别2数据传输率可达4Mbps。

    类别3数据传输率可达10Mbps，通常用于以太网10BaseT网络。

    类别4传输率适用于16Mbps的令牌环网络。

    类别5传输率适用于100Mbps到150Mbps的新网络。这些网络包括快速以太网、100BaseVG和铜质分布式数字接口（CDDI）。CDDI是光纤分布式数字接口（FDDI）的铜线版本。

    相关条目：Cabling 布缆，铺设电缆。

    Two－Phase Commit两阶段提交

    两阶段提交是一种策略，当写入事务涉及到多个地点的分布式数据库时，它可以保证数据的完整性。每个涉及的数据库，都必须在这个事务实际认可前监督它。如果这个事务成功了，它就被认可；否则，这个事务就被卷回。

    就象容错系统一样，双阶段提交，在事务进行写入操作时，对系统出现失效提供了保护。它还允许操作员取消事务并返回数据库到它以前的状态。当事务影响到存储在多个位置的数据时，必须保证在认可这个事务处理完毕之前，所有的系统都正确地完成了写入工作。如果其中的一个系统失效了，其它的系统都必须得知这个失效，从而它们可以将这个事务卷回。

    相关条目：Transaction Processing 事务处理。


 UDA　统一数据读取
：UDA( Universal Data Access)是微软所发展的资料库 (DATABASE) 存取方式，主要使用ADO作为存取界面。


  • Ultra DMA 33 同步DMA协定

    Ultra DMA 33是一种新的同步DMA(synchronous DMA)协定，由Intel所设计。该功能已经包含在Intel的PIIX4芯片中。传统IDE的传输只会使用数据触发信号的单边来传输数据。而Ultra DMA 33当在传输数据时使用数据触发信号的两边，因此在ATA-2设备上，数据传送的速度可以由16MB/s提升至33MB/s。Ultra DMA 33有以下优点：CPU不需要处理数据传输的工作，因此CPU可以专注于计算的工作而提升系统整体的效率；将ATA-2设备的传输速度从16MB/s提升至33MB/s；於IDE连接头上并不需要加额外的信号接脚，与以前旧的ATA设备完全兼容。


 UML 统一建模语言
：UML(Unified Modeling Language)是一种用于描述、构造软件系统以及商业建模的语言，综合了在大型、复杂系统的建模领域得到认可的优秀的软件工程方法。UML是大多数公司采用的标准，是ANSI和OMG等部门采用的标准。


  • AT＆T的统一网络管理体系结构 Unified Network Management Architecture（UNMA），AT＆T

    AT＆T的统一网络管理体系结构（UNMA），是承认OSI协议的企业级网络管理系统的一个模型。它定义分布式计算环境和本地电信局设备及长途电信局设施之上的系统。这个体系结构包括五级：

    网络元素 这是局域网、通信设备、PBX和其它在顾客地点和电信局设施的部件。

    元素管理系统（EMS） 处理网络的不同设备的管理系统。

    网络管理集成层 将EMS连接在一起的管理系统。

    网络管理协议 一组管理配置、性能、帐户、安全性、操作和网络其它功能的标准。

    统一用户界面 简化网络管理的图形用户界面。

    AT＆T的Accumaster Integrator是在UNMA体系结构之上建立的。这种产品最初缺少简单网络管理协议（SNMP）支持，而AT＆T现在支持NCR StarSENTRY网络管理系统。

    相关条目：Accumaster Integrator；AT＆T；Management Standards and Tools管理标准与工具。


  • 不间断电源 Uninterruptible Power Supply

    不间断电源（UPS），在停电时，为计算机或其它设备继续提供电源。UPS可以是下面的一种：

    电池系统。

    旋转UPS，它利用一个大飞轮的惯性来为计算机提供短暂电源。

    运行AC发电机的内燃马达。

    UPS设备有两种类型：联机和旁置。旁置设备只在电源没电时才启动。因此，它必须有可在5微秒内启动它做后援电源的电路。联机设备固定地为计算机提供电源。由于这一特点，它不需要在没电时才打开。如果外面的电源坏了，这个部件内的电池还继续向计算机提供电力。虽然联机UPS是最好的选择，但比旁置UPS要昂贵得多。然而由于联机部件对计算机提供恒定的电力，所以这种电力总是稳定的。

    当购买电池后援系统时，需要对下面设备有些了解：

    这个UPS电池可以提供电力的时间。

    当UPS是在后缓电力操作时，UPS是否向服务器提供警告系统。

    这个UPS有无消除外来瞬变嗓音的电力调节功能。

    电池的寿命和它随着时间如何降级。

    电池不再提供后援电力时，这个设备能否警告你。

    这些电池是否可换。

    还需知道准备安装UPS的设备电力需求情况。对于服务器，可能安装CPU（和其它附加设备）、监视器、外部路由器、集线器和布线中心。可以通过查看这些设备的后板来发现它们的电力需求。UPS的性能主要用伏安（VA）来衡量，它是指线路的电压乘以电流（安培）。需要把所有连接到这个UPS的设备的电力需求加在一起，然后购买一个可以处理负载的UPS。首先查得这个设备后板上的安培数，并乘以电压值（在美国通常是120伏特），然后将每个设备的这个数字加在一起，并选择一个合适的UPS。

    连接到文件服务器的UPS通常需要一条附加电缆，当UPS在后缓电力工作时，通过这条电缆警告文件服务器。然后，服务器就必须在一定时间内进行下载过程。这个监督器电缆的一端需要有一个立体声插头（为插进旁边的UPS监督器板或一个非PS／2文件服务器的SS键卡）或一个4针鼠标插头（为插入一个PS／2文件服务器的鼠标端口）。这个监督器电缆的另一端需要具有选择的特定UPS所需类型的连接器。

    一些厂商已经为他们的电力保护设备开发了一些高级功能。美国电力转换公司的Smart－UPS系列，通过一种称为PowerChute的软件控制程序，向网络管理人员提供了诊断信息。这个软件是安装在服务器上的，并通过一条电缆与该UPS进行通信。然后，管理人员就可以跟踪电力质量、UPS操作温度、线路频率、UPS输出电压、最大和最小线路电力、电池强度、线路电压和UPS负载。美国电力转换公司（American Power Conversion）在Kingston，Rhode Island，电话：401／789－5753。

    相关条目：Data Protection 数据保护；Fault Management失效管理；Fault Tolerance 容错；Power Grounding Problems and Solutions电源接地问题和解决；Surge Suppressors 电涌抑制器。


  • 作业单元，工作单元 Unit of Work

    参见Transaction Processing事务处理


  • UNIX 32位操作系统

    一个32位，多用户，多任务的操作系统，通常运行在Internet的工作站和中心计算机上。它1969年由贝尔实验室开发，现在由Novell公司所有，拥有许多版本和兼容系统。对大多数Internet上初学者来，使用UNIX是一件非常棘手的事情，因为它的任意命令缩写，大小写不同的规定，缺乏删除恢复功能等。幸运的是，在Internet上可以使用另一种不需要UNIX的方法，这种方式正在不断发展。


  • UNIX国际 UNIX International

    UNIX国际是一种不追求利润的具有公开会员关系的国际机构，它致力于UNIX系统V操作系统以及相关软件的评价。UNIX国际成立于1988年，发起单位有AT＆T、Sun Microsystems，以及NCR、Unisys和其它上百个成员单位。它原先是为了开放软件基金会的要求而成立的，但是在1993年就解散了，因为它的成员认为这一机构已经不再需要。

    相关条目：UNIX。


  • UNIX系统实验室 UNIX System Laboratories

    参见UNIX UNIX操作系统。


  • UNIX操作系统 UNIX

    UNIX操作系统是在1969年和七十年代出现的，由Ken Thompson和Dennis Ritchie在AT＆TBell实验室开发的。它是一种多用户系统，它支持联网和分布式文件系统，例如Sun Microsystem的网络文件系统（NFS），或Andrew文件系统（AFS）的开放软件基金会（OSF）实现版本。在AT＆T将这种操作系统公开提供给大学和学院，并在研究计划和计算机科学程序中使用之后，这一操作系统就有了许多不同的应用版本。当前的版本是UNIX系统V版本4．2（SvR4．2），它包括Berkeley软件机构的增强功能和其它一些机构的增强功能。

    下面列出在UNIX环境的一些主要发展情况。

    在八十年代初，为创立一种工业标准UNIX型系统，以及一组为开发可移植应用程序的应用程序编程接口，电气电子工程师协会（IEEE）和美国国家标准协会（ANSI）定义了对UNIX的可移植操作系统接口（POSIX）。在IEEE内的不同工作组还在继续定义这一标准。在1988年，国际标准化组织（ISO）采纳了这个原始规范。

    1984年，Bull、Nixdorf、Philips、Siemens和其它一些公司，通过测试产品对UNIX的遵守情况，并为提倡开放UNIX标准，而成立了X／Open小组。

    开放软件基金会是在1988年形成的，它的发起单位有IBM、DEC、Hewlett－Packard、Nixdorf、Siemens和上百个其它成员，它的目的是开发OSF／1 UNIX分布式操作系统，以及分布式计算环境（DCE）．

    UNIX国际成立于1988年，它的发起单位有AT＆T的UNIX系统实验室（USL）、ControlData、Data General、Informix、Intel、Motorola、NCR、O1ivetti、Texas Instruments和上百个其它公司，它是通过向公司提供可以获得的文档，来推进开放UNIX的。在达到了它们的目的后，这个组织于1993年解散。

    通用开放软件环境（COSE）成立于1993年，由IBM、Hewlett－Packard、SunSoft、Novell和其它一些公司，它的目标是提供一种可以与MicrosoftWindows竞争的面向UNIX的通用台式系统环境（图形用户界面）。

    在1991年，Novell和AT＆T的UNIX系统实验室（USL）联合创建了Unive11公司，它的目标是开发UnixWareUnixWare是一种具有内置Novell NetWare支持的台式UNIX系统。在1993年，Novell购买了USL，并成立了UNIX系统组（USG），对UnixWare进行管理。Univell将最终消失。

    由于购买了USL，Novell获得了对UNIX SVR4的控制权，从而剥夺了其它厂商的生产的权力。然而，为了巩固在通用UNIX操作系统上的工业，Novell将UNIX商标给予了X／Open机构。X／Open将把UNIX商标授于那些与COSE小组定义的一组相兼容的UNIX实现产品。这一组称为COSE Spec 1170 APIs的规范定义了推进操作系统间应用程序的可移植性的编程。

    UNIX的一个重要的发展是，它作为一种开发平台和台式操作系统而获得广泛使用。如前所述，AT＆T使得校园环境可以获得UNIX的源代码，于是促发了它在许多平台上都可以使用，并且促进了一些独特应用产品的开发。这些工作中有许多是美国加州大学Berkeley分校完成的，它创作的一些版本称为Berkeley软件分发（BSD）。UC Berkeley负责增加传输控制协议／因特网协议（TCP／IP）联网协议以及向DEC VAX移植UNIX。现有一些UNIX变种，包括Microsoft的XENIX，DEC的ULTRIX和IBM的高级交互执行操作系统（AIX）。

    这种操作系统开始在工程应用、计算机辅助设计和科学计算中十分流行。最终，它终于进入了商务、医药和许多其它环境。另外一个对UNIX成为流行操作系统起到贡献性作用的因素是，它是用C语言编写的。这样，UNIX就具有了很好的移植性，并且其系统部件采用通用、著名编程语言来编写，这些系统可以很容易地通过重新编译就能在其它不同的系统上工作。

    今天，UNIX的主要发展和开发是在较小的系统（例如基于Inter80x86处理器的系统）和廉价的基于精简指令系统计算机（RISC）芯片的工作站上进行的。一些UNIX版本已经被工业界接受，但是Windows NT的不断发展，已经刺激UNIX厂商为改进UNIX环境而创造可竞争的产品和通用的图形用户界面。

    UNIX Kernel and File System UNIX内核和文件系统

    UNIX包括一个运行进程的小操作系统内核，这些进程包括用户应用程序和服务。虽然进程是根据用户的意愿进行加或减的，但是内核是一种稳定的核心，它从一个系统到另外一个系统变化很小。这种设计方式使得可以比较容易地为用户增加新的服务和减去一些没有必要的服务。另外这样做还使得可以比较容易地进行升级，这是因为整个操作系统不需要被重新编译。用户通过一个外壳（shell）和操作系统进行交互，外壳也是一个接收用户输入和处理一些任务的进程。由于外壳是一种可替换的进程，它就存在许多变种，例如B外壳，C外壳和Korm 外壳。

    它的文件系统是层次式的，它有一个根目录和分支的子目录，并且每个目录都可以具有它自己的一组子目录。文件是存储在目录（或子目录）中的，并且文件的全部名字包括这个目录树的路径名，虽然如果在当前目录下工作时，并不需要指出这个完全的路径。一些设备（例如显示器和打印机），也具有与处理文件类似的设备名称。例如，一个用户可以在一个命令中使用这个显示器或打印机的名称，来将一个进程的输出或列出文件指向这个显示器或打印机。管道功能为将一个命令（例如一次排序）的输出定向到另外一个命令提供了一条途径。

    UNIX in the Network Environment 网络环境中的UNIX

    UNIX和TCP／IP协议是紧密相连的。现在，大多数UNIX实现包括TCP／IP，并提供对以太网的支持，这极大地简化了在这个环境上的联网。另外，Sun Microsystem的网络文件系统（NFS）是一个包括UNIX的通用分布式文件共享系统。OSF正在实现Andrew文件系统（AFS），它在某些方面具有更强的功能。这样，UNIX在一个软件包内，就提供了在一个计算机上安装一个强大的操作系统的能力，它通过一种在工业界最通用的和最强大的联网协议，允许用户共享文件，并在其它用户的计算机上运行程序。

    TCP／IP是一种特别实用和通用的网络互联协议。它是美国国防部为连接不同的计算机系统而设计实现的。TCP／IP具有一些应用来完成在系统间进行文件传输和访问，例如Telnet和文件运输协议（FTP）。Telnet是一种允许用户控制在主机系统上运行程序的一个远程终端程序。NFS允许用户访问远程系统上的文件，就象这些远程系统是它们自己系统的一部分一样。并不需要特殊外部命令或过程来对文件列表、显示它们的内容、创立新文件或把文件复制到本地硬盘。这个远程文件系统是“映射的”，因而它就象一个本地驱动器一样。

    UNIX Implementations UNIX实现

    下面产品作为代表UNIX操作系统实现情况的一个例子。

    DECULTRIX Ultrix是数字设备公司自己实现的UNIX操作系统，它用于虚拟地址扩展（VAX）、MivroVAX、VAXstation，和基于RISC的DECstation系统。TCP／IP和NFS是与Ultrix联系在一起的。它包括下面这些功能：

    提供集中文件管理的电话码式的（黄页）的功能。

    可从远程系统激活的后援和恢复系统。

    无盘工作站支持。

    POSIX兼容文件和记录锁定。

    基于Apollo的NCS V1．5的远程过程调用（RPC）。

    在UDP和TCP传输上的X／OPEN传输接口库。

    简单网络管理协议（SNMP）模型代理。

    约束LAT和LAT／Telnet网关支持。后种产品允许从使用LAT协议的DECnet工作站来访问TCP／IP网络。

    NOVELL UNIXWARE UnixWare包括来自UNIX系统V、NetWare和DR DOS的功能，它的设计是为了向企业计算提供一个集成平台，它允许DOS、Microsoft Windows、NetWare和UNIX系统之间的互操作性。它包括下列特征：

    一个图形用户界面。

    支持上千种不同的UNIX应用。

    一个容错文件系统。

    Novell的UnixWare应用服务器是UnixWare的一种多用户版本，它提供对UNIX、DOS和Microsoft Windows应用的分布式访问。用户使用NetWare互联网络分组交换／序列化分组交换（IPS／SPX）或TCP／IP，可以在多会话下进行登录。UnixWare包括两种配置：一个客户版本和一个服务器版本。下面介绍这两种配置的情况：

    UnixWare个人编辑向NetWare中增加了一个UNIX台式系统环境。它包括支持Motif和Open Look（公开）界面。

    UnixWare应用服务器是一个将NetWare IPX／SPX、TCP／IP协议与UNIX系统V版本4．2集成在一起的应用平台。UnixWare应用服务器使得DOS、UNIX和其它PC操作系统客户可以充分利用基于UNIX客户机／服务器应用的优势，并且同时保持对NetWare和LAN资源的访问。它可以选择服务器，如一个传统的TCP／IP网络服务器，并且支持NFS，以及Internet实用工具的标准。另外，它提供对多个X终端在一个图形台式上的支持。

    Univell UnixWare产品系列与SCO的Open Desktop以及SunSoft的Solaris2．0竞争。所有这些产品都是针对Intel处理器基于UNIX的操作系统，它们运行上百个现存应用程序。UnixWare产品包括NetWare功能的集成。UnixWare还与Microsoft NT和OS／2竞争，这两个产品不是UNIX产品，但是它们的设计却是为与UNIX竞争的一种多任务客户机／服务器系统。然而，Microsoft NT毕竟是一种新产品，它没有象UNIX所具有的那么多应用程序。

    相关条目：Common Open Software Environment公用开放软件环境；Digital Equipment Corporation数字设备公司；Distributed File Systems分布式文件系统；Kernel操作系统内核；Novell；Open Software Foundation开放软件基金会；OSF／1；POSIX；Transmission Control Protocol／Internet Protocol 传输控制协议／因特网协议；X／Open。


  • UNIX 操作系统

    一个32位、多用户、多任务的操作系统，通常运行在Internet的工作站和中心计算机上。它1969年由贝尔实验室开发，现在由Novell公司所有，拥有许多版本和兼容系统。对大多数Internet上初学者来，使用UNIX是一件非常棘手的事情，因为它的任意命令缩写，大小写不同的规定，缺乏删除恢复功能等。幸运的是，在Internet上可以使用另一种不需要UNIX的方法，这种方式正在不断发展。


  • UNIX系统间文件拷贝程序 UNIX－to－UNIX Copy Program

    UNIX系统间文件拷贝程序 （UUCP），UNIX到 UNIX复制程序（UUCP）

    UUCP是一种在单一连接的两个UNIX系统之间提供文件复制服务的UNIX应用程序。许多UNIX电子函件应用程序使用UUCP。


  • 非屏蔽双绞线 Unshielded Twisted Pair

    参见Cabling布缆；Transmission Media，Methods，and Equipment传输介质，方法和设备。


  • UPS 不间断电源

    为Uninterruptible Power Supply(不间断电源)的英文缩写。它是伴随着计算机的诞生而出现的，是电脑的重要外围设备之一。UPS是一种含有储能装置，以逆变器为主要组成的恒压恒频的不间断电源，用以保护电脑在突然断电时不会丢失重要的数据。


  • URL 统一资源定位格式

    （Uniform Resource Locator）统一资源定位格式。是Web 的地址编码。Web 上所能访问的资源都有一个唯一的URL。URL 包括：所用的传输协议、服务器名称、文件的完整路径。例如：在浏览器URL处键入：http://www.ccidnet.com，就可以访问赛迪网的主页。


  • USB 通用串行总线

    Universal Serial Bus中文名为通用串行总线。它是由IBM、Intel及Microsoft等多家公司共同开发的新型外设连接技术，这一技术解决了目前串行设备和并行设备的连接复杂性，大大简化计算机与外设的连接过程，同时连接设备可以达到127个。它安装简单支持即插即用、热插拔、多设备并联，可提供较大的带宽，同时耗电量较低，因而支持厂商多，前景十分光明。


  • USENET网 USENET

    USENET新闻是Internet将信息分布到所有主机的广播新闻服务，通常是关于因特网的新闻服务。USENET网络包括所有获得USENET新闻的计算机。如果获得了使用Internet函件的服务，就获得了访问这种服务的机会。它对所有Internet上的用户提供了阅读和邮寄新闻的途径。这个环境是不经过审核删节的，USENET组织努力来保持它的这一特征。

    相关条目：Internet。


  • 用户代理 User Agent

    在X．400电子系统中，用户代理是一种对数据打包、创造分组头，以及编址、传递消息的部件。

    相关条目：X．400 Message Handling System X．400 信报处理系统。


  • 用户数据报协议 User Datagram Protocol

    用户数据报协议（UDP）是TCP／IP协议组的一个组成部分。它的创立是为了向应用程序提供一条访问IP的无连接功能的途径。TCP和UDP都使用IP。UDP的设计允许应用程序创建数据报，以及将它们编址到访问应用程序或进程的端口。UDP的基本作用就是向一个IP分组增加一个应用程序进程的端口地址。

    相关条目：Internet；Internet Protocol 因特网协议；和Transmission Control Protocol／Internet Protocol传输控制协议／因特网协议。


  • 用户和（小）组 Users and Groups

    网络操作系统通过要求所有用户键入他们的帐户名字和一个口令来提供安全性。一旦一个用户被认可或鉴别（参见“鉴别和授权”），这个用户就可以根据他们被赋予的访问网络的权力，来访问网络资源。一些网络操作系统要求用户如果要访问不同网络地点的资源，就必须每次都要进行登录。这方面最近的发展趋势是，增加使用户只需在网络上进行一次正确登录，就可访问网络上所有权限之内的网络资源的鉴别机制。建立了信任关系，因而“信任”另一个服务器的服务器就授权予一个用户。 一

    用户帐户包括有关这个用户的信息，包括他们在网络上的任何限制。例如，一个用户可以被限制在一个特定工作站上或在一段特定时间内进行登录。组是网络管理人员创立的，用于简化对用户进行管理的二组用户。将一些用户包括在一个组内是较容易的，然后就可以对这个组赋予一些网络访问权限，而不再需要对每个用户都单独地赋予这些网络访问权限。组还可以简化消息传递。例如，可以较容易地发送由子函件到一个称为“经理们”的组，而不需要对这个组中的每个用户都单独进行发送。经理们可以在规划和建立这个网络时，为用户、项目和管理目的建立组，然后在用户加入这个网络时，将这个用户的帐户加入到这些组中。

    User Accounts in NetWareNetWare中的用户帐户

    一旦网络管理人员或一个超级用户使用管理实用工具（如SYSCON或NetWare 4．x NETADMIN）为一些用户创建了一个用户对象后，这些用户就获得了对这个网络的访问权。在创立一个用户的帐户后，对文件系统和网络资源的权限就被赋予了这个帐户。相应地，这个帐户被加入一个组，于是就获得了这个组的所有权限和特权。下面将讨论对用户帐户的限制。

    帐户平衡限制 可以通过信用极限说明来限制一个用户对这个系统和其资源的访问。信用极限（creditlimit）是一种在帐户用完规定时间和使用的资源时，对这个帐户进行的一次平衡。一旦用完了，这个用户就不能登录这个系统了，除非增加更多的信用。 就不

    终止限制 可以对一个用户帐户设置终止日期和时间。这个帐户将在指定时间关闭。可以对暂时顾员使用这种限制。

    口令限制 管理人员和超级用户可以指定登录口令的长度和独特性。可以强迫用户以固定的间隔改变它们的口令，并使用他们最近没有使用过的口令。一

    磁盘空间限制 磁盘空间限制防止用户装入没有必要的程序或文件，而占用过多的服务器磁盘空间。

    连接限制 连接限制可以限制用户同时登录的工作站数目。

    时间限制 时间限制为用户登录进系统，限定了具体时间（以半个小时为单位）。

    站点限制 站点限制防止用户在特定工作站之外的其它任何站点进行登录。这一功能防止了用户从一个非超级工作站进行登录，从而使得对他们的活动不可进行监督。在NetWare中，这些限制可以被独立地赋缺省设置，每当创立了一个新用户时，就赋予它一些限制。

    相关条目：Access Control访问控制；Access Rights 访问权力；Account，User Network 用户网络的帐户；File and Directory Right文件和目录权限；Groups组；Home Directory 主目录；Permissions in Windows NT Windows NT操作系统中的准许权限；Workgroup工作组。


 UTP 无屏蔽双绞线
：UTP(unshielded twisted pair)UTP是最普通的一种铜质电话线。双绞线是用于连接家庭，公司和电话公司之间的普通铜线。为避免串线和电磁干扰，两个绝缘的铜线相互缠绕在一起。


  • CCITT（ITU）的“V点”标准 “V dot”Standards，CCITT

    国际电报电话咨询委员会（CCITT）是国际远程通信联合会（ITU）的联合国机构的一个委员会。ITU由不同国家的成员组成，它的任务是为远程通信进行研究、建议，并且对技术和操作问题进行标准化。CCITT的“V点”调制解调器标准，已被世界范围的调制解调器通信所接受。这些标准基于AT＆T以前开发的一些标准，以及在Microcom联网协议（MNP）中流行的一些特征。下表列出了最重要的一些CCITT标准，并且将在后面对它们进行讨论。

    V．24 V．24是与电子工业协会（EIA）RS－232C标准相同的标准。它们定义了数据终端设备（DTE）（例如终端和计算机）接口到数据通信设备（DCE）（例如调制解调器）的方式。

    V．35 这种标准定义将DET连接到高速异步调制解调器的接口。其物理定义描述了一个34针连接器和对调制解调器进行同步的时钟信号。

    下面的V．32、V．32bis和V．32terbo标准使用网格编码技术来表示信号。网格编码是一种通过信号的相位和幅度变化来表示数据位的技术。这些信号的变化映射到一个由许多点构成的星座（群），这些点表示很复杂的标号。

    V．32 是一种通过使用正交振幅调制技术可提供2，400bps吞吐率，以及通过使用网格编码提供9，600bps吞吐率的双线双工调制解调器标准。

    V．32bis 使用一种在每个信号群具有128个点的二维网格编码技术。它提供的v传输率从4，800到14，400bps。

    V．32terbo 使用一种在每个信号群具有512或256个点的二维网格编码技术。它提供的数据传输率可到19，200bps，并且它可以设计作为14，400bps的V．32bis和V．34的中间过渡，V．34是一种将出现的28，800bps的标准。

    V．42 V．42定义的错误检查标准设计，是为了减少由于有噪声的电话线路而导致的数据错误，它使用循环冗余校验（CRC）方式来验证传输数据的完整性。对一个块的数据计算一个CRC值，把这个值与这个数据块一起发送。当接收系统接收到这个数据块后，计算它自己的CRC数值，并且将计算结果与来自发送者的CTC数值进行比较，如果这两个CTC不同，将重发数据。V．42对数据块进行实际打包，减小了对起始位和结束位的需求，并且减少了传输的信息量，因此可以增加吞吐率20％左右。

    V．42bis 这是一种可提供四到一压缩率的数据压缩标准。如果数据已经被象PKZIP这样的使用工具进行了压缩，就不能再使用V．42bis压缩标准了，如果再次使用，只会增加一些没有必要的传输开销。然而，对于非压缩数据，这种标准可以把一个2，400bps的调制解调器的吞吐率加倍到4，800bps。

    V．34（正式称呼为V．FAST） V．34是一种预计在1994年中期宣布的建议标准。它使用一个信号群具有768个点的四维网格编码技术。它提供的传输率高达28，800bps。通过压缩，吞吐率可达100，000bps。然而，大多数个人计算机与Macintosh系统的串行端口不能处理这么高的数据传输率，因而一些厂商正在设计通过并口或使用增强串口来进行传输的产品。

    相关条目：Asynchronous Communication 异步通信；Bell Modem Standards Bell调制解调器标准；Dialup Line 拨号线路；Microcom Networking Protocol Microcom联网协议；Modems调制解调器；Modulation Techniques调制技术；Serial Communication串行通信；Synchronous Communications 同步通信。


  • 增值网 Value－Added Carrier

    VAC（或称为公用数据网）是为需要建立国内或国际专用或虚拟网络的顾客提供远途通信服务的完整服务提供商。VAC提供顾客所需的所有数据链路，顾客只需付一张帐单。这些连接通常是分组交换网络二提供给顾客的网络服务在最初可能是为了自己使用而建立的。虽然它也可能从其它电信局租用一些下面的网络连接，但是通常它们使用光纤、微波和卫星链路建立自己的专用线路。、信局（如AT＆T）租用顾客进行数据处理和协议转换。通常通过一条模拟电话线或数字线缆连接进入VAC的网络。 可以为它们的顾客进行数据处理和协议转换。通常通过一条模拟电话线或数字线缆连接进入VAC 的网络。提供的典型服务包括X．25、帧中继和异步传输模式（ATM）。下面列出主要的VAC：

    CompuServe信息服务公司 它在全美国上百个地点提供了对X．25和帧中继服务的访问点。

    GE信息服务 提供分组交换和高速服务，以及异步和同步服务。

    Infonet服务公司 提供一个国际服务的阵列。

    Tymenet全球网络 具有接近5，000个全球访问点。

    使用PND，避免为这些线路而与电讯公司进行协商，也减少了建立交换设备的一些问题。这些提供商本身处理网络中的所有问题，并且保证数据通过交换线缆的一个巨大的网目（mesh）进行发送。

    相关条目：Packet－Switching Networks 分组交换网络；Public Data Networks 公用数据网；PublicSwitched Data Network 公共交换数据网络；Switched Services 交换服务；Wide Area Networks广域网。


  • 数字设备公司（DEC）的 VAX VAX，Digital Equipment Corporation（DEC）

    VAX计算机系统系列是在1977年首次宣布的。第一个系统VAX780与IBM系统进行竞争，并且为DEC 已有的用户提供升级途径。VAX 11／780具有一种兼容模式，它可以运行针对DEC的PDP－11小型计算机系统编写的软件程序。它还具有一条兼容的总线，于是DEC的顾客就可以使用他们已有的一些外设。

    虚拟存储系统（VMS）是与VAX系列一起宣布的。VMS是为利用VAX系统32位体系结构的优势而设计的操作系统。VMS提供了一种真正的多任务／多用户环境。另外，与VAX一起宣布的还有DECnet，它是一种使用并行电缆互联不同计算机系统的联网系统。在1980年，DEC、Intel和Xerox一起宣布了以太网，它成为新一代DECnet产品和互联性的通信系统。

    相关条目：Digital Equipment Corporation（DEC）数字设备公司（DEC）。


  • Lotus 的厂商无关消息传递应用程序编程接口 Vendor Independent Messaging （VIM），Lotus

    VIM是一种由Lotus控制的电子函件应用程序编程接口（API），它得到了许多公司的支持，例如，Apple、Borland、IBM、MCI、Novel1、Oracle、WordPerfect和其它一些电子函件开发商和厂商。它最初被它的开发商cc：Mail称为开放消息传递接口（OMI），Lotus购买了cc：Mail，并通过增加了兼容性来修改了OMI，并且将它的名字改为了VIM。厂商们使用电子函件API来增加对网络操作系统的互联性。竞争的标准包括Novell的NetWare全球消息传递和标准消息格式（SMF）、Microsoft的消息传递应用程序编程接口（MAPI）、Apple Computer的开放协作环境（AOCE），以及Lotus的厂商无关消息传递（VIM）。

    VIM是跨平台的，它允许开发人员创立能够在许多不同的平台上工作的邮件激活应用程序，并且允许用户在这些不同的平台上共享函件。VIM使得开发人员和用户可以访问在一些不同的协议上进行操作的信报传送设备。这些接口允许VIM激活应用程序（例如电子函件程序和群件）来与一个VIM兼容操作系统一起工作。

    应用程序之间的信息交换采用存储再传发的方式进行，因而相连的函件系统必须具有这种能力。交换的信息被看成是一种能够包括任何文本、数据（电子制表软件）、图形、音频和视频信息组合的对象。用户可以从他们的应用程序中发送基本信息，或者他们也可以发送象电子制表软件文件或图象文件这样的复合文档。VIM还有一些服务进行创建、阅读和发送消息，以及有能力保持一个地址簿。

    VIM的一个重要的特征是，它有能力和其它消息传递API进行链接，包括Apple的AOCE、Microsoft的MAPI，和Novell的信报处理服务（MHS）中实现的标准信报格式（SMF）。

    相关条目：Document Interchange Standards文档交换标准；Electronic Mail电子函件；Groupware 群件；LotusNotes；Message－Enable Applications 消息激活应用程序；Messaging API，E－mail电子函件消息传递API；Workflow Software工作流软件。


  • 垂直布线系统 Vertical Wiring

    在一个结构化布线系统中，垂直布线是从建筑物的每层布线柜中延伸到这个建筑物的地下室或第一层的主设备室的那条电缆。与此相反，水平布线是从一个远程布线柜到一个建筑物的某一层的每个工作站的电缆。

    相关条目：Cabling布缆；EIA／TIA 568 Commercial Building Wiring Standard EIA／TIA 568商用建筑布线标准。


  • 卫星小站电路设备 Very Small Aperture Terminals（VSATs）

    参见Satellite Telecommunication 卫星远程通信。


  • VESA 视频电子标准

    视频电子标准(Vedio Electronic Standard Association)，VESA总线是一个32位标准的计算机局部总线，是针对多媒体PC要求高速传送活动图象的大量数据应运而生的。它的数据传输率最高可达132Mbytes/s。它的许多引线引自CPU，因而负载能力相对较差。随着Pentium级计算机的不断普及，PCI总线产品所占的市场份额日渐提高，VESA总线产品将面临被淘汰的趋势。


  • VESA 视频电子标准协会

    VESA总线(Vedio Electronic Standard Association)是一个32位标准的计算机局部总线，是针对多媒体PC要求高速传送活动图象的大量数据应运而生的。它的数据传输率最高可达132Mbytes/s。它的许多引线引自CPU，因而负载能力相对较差。随着Pentium级计算机的不断普及，PCI总线产品所占的市场份额日渐提高，VESA总线产品将面临被淘汰的趋势。


 Video Compression 视频压缩
：对以数字形式存储的视频图像文件进行压缩，以减小其大小。在没有压缩的情况下，640×480 象素分辨率下的 24 位颜色的视频信号每帧将占用近 1 兆字节，或每分钟十亿字节。视频压缩是有损的，但不影响观看的图像的质量。


  • 电视会议和台式（桌面）视频系统 Videoconferencing and Desktop Video

    在网络环境，视频应用变得越来越重要。现今正在以新的台式方式实现多媒体和视频传输，以帮助网络用户进行通信和共享信息。电视会议为不同遥远地区的人们，不用实际地到一起就可以召开会议提供了一条途径。在网络环境，电视会议不仅仅让人们可以相互看见对方，而且视频屏幕可以有多个窗口，允许用户查看绘图、图表、电子表格和其它协作信息。电视会议系统将基于计算机的信息与实际视频信息相结合，电视会议在局域网或广域网上进行传输。

    网络环境具有四种视频传递方式：

    存储在视频服务器上的预录制视频，例如教育片段、计算机辅助训练和视频函件片段，可以在任何需要的时候通过网络传递给用户。

    预录制视频，如公司简报、新产品信息、会议简报，以及其它具有新闻价值的信息，按照调度的时间，或者是多用户小组需要它时，广播到多个用户。

    运动视频在网络上以单向方式广播到多个用户，交互性很小。

    电视会议技术融合了在多个用户之间广播生动的、双向交互的视频。电视会议是时间敏感的，并需要能够按时传送大量数据的分发系统。

    上述四种应用可以归结为本地分发系统和电视会议系统。在本地环境，经理们需要确信视频传输没有超出网络带宽。共享局域网（LAN）系统（如以太网）并不是为传输视频而设计的，但是如果使用了微分段技术和交换式集线器，做到了每个局域网段只有一个用户，它们也可以提供相应的非实时视频性能。这种方式减少了LAN的冲突，并且可以为每个用户提供以太网的全部10Mbps的带宽。

    Local Video Delivery Systems本地视频分发系统

    在局域网环境的视频（多媒体系统），通常包括存储视频、音频和图形文件的一些多媒体服务器。压缩软件或特殊的压缩板有助于减少这些文件的大小。端点用户系统运行软件来请求和显示服务器的视频，例如训练或帮助图片。一个完全的视频录像和重放系统，在端点用户系统（如图V－1所示）使用视频摄像机、麦克风和扩音器。Lotus开发公司的Video Notes是一种面向视频的电子函件系统。

    在局域网环境，预录制视频和实时视频之间的差异是很大的。对于预录制视频的观察者，传递延迟并不重要。当用户请求要观察视频文件或视频电子函件片段时，首先这些文件或片段被传送并组装，然后再重放。延迟或丢失分组的问题已被解决，这时用户很难察觉存在这些问题。

    与此相反，实时电视会议需要具有足够的带宽来按时传送视频到所有用户，并且不能丢失分组。如果因为带宽不够或冲突而导致了丢失或丢弃分组，那么视频就出现“抖动”。一些帧的丢弃是可以接受的，但必须是在被控制的情况下进行的。帧丢弃技术常用于在带宽不足的计算机或网络上传输视频。任何低于10帧1秒（fps）的视频看起来都象一些静止图片的序列，虽然15fps是可以接受的，但此时还是有很明显的不自然感觉。高于15fps的帧率才适合传输视频。

    象快速以太网或光纤分布式数据接口（FDDI）网，这样的高速网络，通常是为局域网台式电视会议而建立的。异步传输模式（ATM）是一种正在出现的网络标准，它能满足实时视频的要求。它的高数据传输率和固定体积单元，提供对实时视频非常理想的可预估的数据传输服务。通过压缩和微分段交换技术，10Mbps的以太局域网可以传输相对较高质量的视频。新的100Mbps的高速以太网标准是为支持视频而设计的。

    Videoconferencing电视会议

    电视会议为在遥远地点的用户，通过局域计算机网络，或广域电信电讯公司辅助服务，来“召开会议”。在每个地点，通常需要一个视频摄像机、扩音器和一台计算机。虽然一些厂商生产完全集成化的电视会议系统，但是也可以在计算机上安装提供视频和音频输出的特殊PC板，来自己建造电视会议系统。电视会议软件管理这些设备和会话，并且通常为每个人都提供可以观察的图象和图表。这种软件是交互的，允许会议代表生成其它代表可以看见的一些变化信息。一种典型的电视会议系统，例如Picture Tel Live PCS 100，使用Windows图形用户界面，于是用户可以看见在一个窗口中的摄像机获得的图象，并在另一个窗口看见从文件中提取的或由其它应用程序产生的计算机图形。一些高级系统具有观察摄像机图形和计算机生成图象的多个监视器。

    现在流行的工业电视会议标准是由CCITT定义的并统称为Px64。这个标准之所以称为Px64，是因为它定义多倍64Kbps的压缩。H．320是Px64中最后一种规范。它定义了多点电视会议（在多个地点同时进行会面）和相关要求，例如加密、远程摄像机控制、音频／视频压缩。这些标准定义编码解码器（codecs）（编码器／解码器）的一些功能。编码解码器负责视频压缩和解压缩。这些标准还提供和其它国家电视显示格式相兼容的一些功能。

    由H．320系列标准定义的其它一些特征和功能包括：

    高达16Kbps的语音和高保真音频压缩。

    为传输压缩信息的帧格式。

    用于在多个会议地点之间建立通信会话的过程，以及在编码解码器之间控制信息的交换。

    使用一个多点控制部件（MCU），建立一个多点会议（三个或多个会议系统）。

    保证公开的加密技术。

    H．320编码解码器正在被一些具有领先性的芯片厂商制造，例如Texas Instruments和AT＆T。这一标准刺激了电视会议产品的市场。AT＆T个人视频系统（产品名称）是一种台式的基于PC的视频系统，它允许用户使用Microsoft Windows界面来相互观看和共享信息。这个系统在112到128Kbps的传输线路上，以10到15帧／秒进行操作。使用一个多点控制部件，可以将多达24个地点，连接到一个电视会议系统。

    目前，电信公司也加入了这一领域，这是因为电视会议连接要通过他们的设施来建立。例如，US Sprint为建立电视会议连接提供一揽子服务，而不论你使用或包括了哪家公司的编码解码器、本地电信局或长途电信局。

    相关条目：Asynchronous Transfer Mode异步传输模式；Carrier Services电信服务；Compression Techniques压缩技术；Fast Ethernet快速以太网；Fiber Distributed Data Interface 光纤分布式数据接口；Multi－media 多媒体；Security 安全性。


  • Banyan的VINES操作系统 VINES，Banyan

    参见Banyan VINES．


  • 虚电路 Virtual Circuit

    虚电路是在分组交换散列网络上的两个或多个端点站点间的链路。它为两个端点间提供临时或专用面向连接的会话。它的固有特点是，有一条通过多路径网络的预定路径。提前定义好一条路径，可以改进性能，并且消除了帧和分组对头的需求，从而增加了吞吐率。从技术上看，可以通过分组交换网络的物理路径进行改变，以避免拥挤和失效线路，但是两个端系统要保持一条连接，并根据需要改变路径描述。图V－2示意了局域网用户和远程地点之间的虚电路。注意，这个虚电路如何为用户A跨越这个局域网连接、网桥／路由器间的多路复用链路、分组交换网络以及穿越分组交换网络的链路。

    具有永久性和交换型的虚电路如下所述：

    永久性虚电路（PVC）是一种提前定义好的，基本上不需要任何建立时间的端点站点间的连接。在公共－长途电信服务，例如异步传输模式（ATM）或帧中继中，顾客提前和这些电信局签订关于PVC的端点合同，并且如果这些顾客需要重新配置这些PVC的端点时，他们就必须和电信局联系。

    交换型虚电路（SVC）是端点站点之间的一种临时性连接。这些连接只持续所需的时间，并且当会话结束时就取消这种连接。虚电路必须在数据传送之前建立。一些电信局提供的分组交换服务允许用户根据自己的需要动态定义SVC。

    SVC和PVC通常在有关公用数据网的文章中进行讨论，虽然有围绕一些技术（例如ATM）建立了室内交换网络的机构可以提前定义PVC以减少网络开销。对于电信服务，顾客通常需要为PVC交付初装费用，然后按月或按分组进行交费。SVC和拨号电话呼叫相比，PVC对应为两点之间的专用租用电话线路。

    在ATM环境，在端点站点之间的逻辑连接称为虚拟信道（VC）。虚拟路径（VP）是一个或多个VC通过一个散列网络到达相同目的地的一条定义好的路径，虽然每个VC可以连接到不同的端系统或在这个目的地的应用处理。可以将VP想象为包含一束电线的电缆，如图V－3所示。在这个比喻中，该电缆将两点和此电缆连接端系统内的独立电路相连。它的优点是，共享穿越网络的相同路径的连接被组织在一起，并使用相同的管理功能。如果已经建立了VP，就可以很轻易地增加新的VC，这时因为已经完成了定义穿越这个网络路径的工作。另外，如果这个网络为了避免拥挤或失效的线路而需要改变一条路径时，所有为这个VP建立的VC都被定向到这个新的路径。

    PVC是在帧中继环境中传统的连接方式，虽然1993年末SVC被支持加入这个规范。PVC具有特定服务特点。在与提供商建立了服务时，就定义PVC和这里列出的服务特点。这个链路的服务特点：承约信息大小（committed burst size）、承约信息率（committed information rate）、过量信息大小（excess burst size）和帧大小（frame size）。它们是在协商时定义的。

    承约信息大小（CBS）是网络提供商同意在时间间隔内的正常网络状态进行传输的最大数据（按位）的数量。

    承约信息率（CIR）是网络提供商同意的在一个PVC的正常网络状态期间传输CBS承约数据的传输率。

    过量信息大小（EBS）是最大允许的超出CBS的未承约数据（按位）的数量，这个网络将试图在一个时间间隔期间传送它们。EBS数据将在网络拥挤期间被网络按照可抛弃数据对待。

    帧大小是传送顾客数据穿越分组交换网络的帧的体积。

    相关条目：Carrier Services 电信服务；Connection－Oriented and Connectionless Protocols面向连接和无连接协议；Packet－Switching Networks 分组交换网络；和Wide Area Networks广域网。


  • 虚拟数据网 Virtual Data Networks

    电信领域正在推广一些许多机构需要在远程地点之间用于建立虚拟数据网络的技术，这些技术主要用于校园环境、城市区域、广域、或全球区域。虚拟数据网络为机构内所有地点所有系统进行全互联提供了比租用专用线路和建立专用网的费用低很多的途径。它的目标是在广域网上提供局域网的速度。

    分组交换服务，例如帧中继和交换式多兆位数据服务（SMDS，正在提供虚拟数据网络能力和对专用线路的替换需求。这些服务提供具有微秒交换能力的带宽。顾客只需为他们使用的服务进行付费。这些服务由长途电信局，例如AT＆T、MCI、和USSprint，以及增值网（VAC），例如CompuServe、Infonet和Tymenet等提供。电路交换服务，例如交换－56，交换－384K（AT＆T）、交换T1和交换T3，现在与这些电信服务一样也很流行使用较少的开销，现在一些很小的地点也可以被包括在一个很大的企业数据网络中。

    另外，个人需求现在并不高，这是因为这些电信服务处理了交换元素。通过分组交换服务，一个单一“数据管道”将数据从顾客地点发送到电信局，然后再从这个电信局传送到其它地点。然而，网络管理人员考虑在将许多网络管理赋予一个公共电信局时所产生的失去控制的问题，虽然这些电信局也能提供关于这些服务的适当的管理信息。

    相关条目：Carrier Services 电信服务；Circuit－Switching Services 电路－交换服务；Packet－Switching Networks 分组交换网络。


 Virtual Desktop　虚拟桌面
：使用较低解析度的画面来当作高解析度画面的方法。如果一个画面只有 640X480 的分辨率，系统使用虚拟桌面的方式设定桌面为1280X960，使用者同时只能看到 640X480的画面。但可藉着移动滑鼠或键盘操作的方式来移动桌面，或者说是移动使用者的视线到1280X960的其他部分上。


  • 虚拟文件系统 Virtual File Systems

    虚拟文件系统（VFS）是由Sun icrosystems公司在定义网络文件系统（NFS）时创造的。它是一种用于网络环境的分布式文件系统，是允许和操作系统使用不同的文件系统实现的接口。

    相关条目：Distributed File Systems分布式文件系统。


  • Virtual reality 虚拟现实

    一种广泛使用的名词，指用计算机模拟三维环境，用户常常借助手套和眼睛就能直接交互操作，从类比的角度看，象MUD那样的角色扮演游戏有时被认为是虚拟现实的例子。


  • 虚拟远程通信访问方法 Virtual Telecommunication Access Method

    VTAM是为用户提供对网络资源和信息访问的一种IBM系统网络体系结构（SNA）的应用产品。

    相关条目：IBM IBM公司；Systems Network Architecture，IBM IBM系统网络体系结构。


  • 虚拟终端 Virtual Terminal（VT）

    虚拟终端（VT）是一种提供类似于Internet的Telnet协议的远程终端仿真的国际标准化组织（ISO）协议。在远程终端的用户，可以在远程计算机上运行应用程序，就象他们是坐在这台计算机前面一样。


  • 虚拟集成技术体系结构生命周期 Virtually Integrated Technical Architecture Lifecycle

    VITAL是Apple将台式计算机集成到企业级系统环境中的方案。它的技术主线是，定义了如何创造能够增强服务的、稳定的、共享的和可重用的软件模块。用户可以从台式系统激活这些服务。这种策略包括多厂商个人计算设备，而不仅仅是Apple计算机系统。VITAL将用户视为软件服务的焦点，而不是计算系统中的端点。它的主要目标是，提供简单的用户对平台设备无关的信息访问，它们可以适应技术的快速改变和集成现有的技术。

    VITAL将企业级系统分为四个（被一个系统基础设施连接在一起的相关的）逻辑环境，如图V－4所示，它们将在下面介绍。牢记，客户机／服务器模型将数据放在后端服务器系统，并反应在前端工作站的客户机上。这个系统是分布式的，这意味着数据是存放在多个不同的服务器上的，客户访问这些数据时无需知道数据放在哪个服务器上。还需注意，后端服务通常由SQL－兼容数据库系统提供。VITAL用与“仓库（warehousing）”相关的术语来定义后端数据存储。仓库数据库存储大量信息，但是用户并不直接访问它。事实上，仓库将用户所需的数据移到本地访问服务器（LAS），如图V－5所示。可以将LAS想象为仓库信息的“零售点”。这样就可以对多LAS访问仓库服务器进行优化。

    台式集成环境（Desktop　integration environment）提供人机接口、应用程序支持、导航，并通过称为对象的台式服务互联到企业级网络。对象在综合服务管理器的管理下进行路由选择、通信和企业计算功能的操作。

    数据获取环境（Data capture environment）关心所有的采集和存储信息的工作。它使用一种面向变化的事务系统，并且管理其它的到数据访问环境的跨功能共享数据。

    数据访问环境（Data access environment）管理获取、库存，并分布共享数据到独立应用和其它用户使用的本地访问数据库。

    库存环境（Repository environment）提供一个元数据的百科全书，元数据是关于整个环境的设备数据。库存环境维护这个环境的一致性。

    系统基础设施环境，这个环境包括在此之上可以建造其它部件的实用软件、硬件、网络、组成、安全性、标准和原则。

    将数据获取从数据访问中分离出来是有原因的。首先，它保证了在事务系统之间跨功能的一致数据。它还避免了相关和流线（streamlines）事务处理。事务处理系统操作有两个基本功能：第一个是，它们提取、修改和再插入少量数据；其次，它们管理记录冲突，保证没有用户重写另外一个用户写的信息。VITAL分离了这两种环境，因而任务可以在许多平台上进行操作。

    The Desktop Integration Environment 台式集成环境

    台式集成环境提供用户支持。它将用户既视为数据生产者，又视为数据消费者。用户操作的活动是一个无缝台式系统环境的组成部分，它无需用户关心数据存放的位置、结构和它的完整性。这个环境提供了一个一致界面，它允许用户快速查到在这个企业任何地方的数据，然后准备、获得、观察、分析、综合、报告，分配它。综合服务提供这些功能。

    综合服务分为三个逻辑组，介绍如下。

    系统基础设施和协作服务

    鉴别、被鉴别和加密／解密服务。

    软件许可证管理。

    版本控制和同步。

    元数据同步。

    时间同步。

    目录接口。

    函件和消息传递服务。

    文件运输服务。

    打印机服务。

    网络连接服务。

    信息消费服务

    数据同步，它保证在单独计算机上的本地数据库和数据库服务器上的备份间的同步。

    查询使用服务，允许用户在数据获取环境和数据访问环境使用数据库中查询的数据。用户可以从任何后台服务（它们可以是Sybase，Oracle或其它服务）查询数据。查询的输出可以按照台式系统环境使用的任何格式提供。

    外部数据分发，使得用户可以按照需求或者以一种固定的调度方式获得来自不同来源的信息。这可以集成来自许多来源的数据，并且按照用户设计的格式提供。

    多媒体访问服务，通过处理压缩／解压缩、格式翻译和提取丰富数据形式（例如声音和视频）来提供一种较丰富形式的信息。

    数据生产服务

    外观处理，提供电子显示和输入服务。它可以从一个服务器定位外观和它们相连的编辑说明，并对用户显示它。

    事务使用服务，向具有事务处理能力的服务器提供处理插入／修改事务的操作。它对联机事务处理（OLTP）事务提供无缝和一致的记录－锁定、冲突管理、优先级检测和修改－认可控制。

    The Data Capture and Access Environments数据获取和访问环境

    数据获取和数据访问环境都是基于客户机／服务器计算原理的，它是和主机进行交互的改进方式。台式计算机提供一种对信息的图形观察方式。那里有可能，数据就在那个台式环境有效，从而将主机从这些服务中解放出来。数据获取服务将用户抓获的信息移到数据仓库，数据访问服务将这些数据提供给用户。共享仓库的数据在格式、定义、结构和使用它的多个系统上的数值是一致的。

    数据获取服务

    访问和写例程 为孤立文件访问和写入。

    数据获取服务 为存储设备抓获数据。

    有效化服务 保证数据的外观一致。

    分发方事务 保证数据的接收。

    创建和发送快照 数据提取和查询例程。

    初始事件处理 工作调度例程。

    事务管理 提供事务监督。

    数据访问服务

    管理对采集数据的访问 辅助用户发现数据并对发现数据的请求进行调度。

    为采集数据安排命令 在数据仓库网络上放置数据请求。

    提供直接仓库访问 提供一组存储的过程，通常是标准查询。

    管理仓库详细目录 以最低的可能系统费用，优化用户请求服务。

    接收数据和建立收集 验证提取是正确的。

    收集实现命令 帮助发送数据到本地访问数据库。

    The Repository Environment库存环境

    库存环境处理元数据的管理和经营，支持数据获取、数据访问和台式集成环境的控制服务。稳定的库存环境于开发跨越不同系统、不同地理空间和不同硬件平台的信息一致性观察结果是十分重要的。

    库存环境的目标是，对所有用户、开发人员、应用程序、服务和数据库保持元数据引用的单一来源。当数据在形式上和管理上是分区分布时，它提供对数据的一致性观察。最后，库存环境对元数据提供扩展的视觉管理。

    这个库存为共享数据仓库分布共享数据，为信息消费者提供基本访问控制、路由选择和同步数据。它包括一个引用元数据的数据目录，它指定和定义下面内容：

    查询和其它过程。

    数据库结构定义和描述。

    标准检验有效性准则。

    定义收集、提取和事务的数据仓库描述。

    授权和鉴别规则和描述。

    库存环境为Apple和它的商业伙伴共同工作提供了一条途径。虽然Apple并不希望开发它自己的库存产品，但是Apple现在正致力于将VITIAL服务与在IBM、DEC、Tandem和UNIX环境出现的技术进行集成。

    相关条目：Apple Computer；Apple Open Collaborative Environment Apple开放协作环境；AppleTalk．

    V

    V

    虚拟存储器系统

    Virtual Memory System

    VMS

    VMS是数字设备公司的VAX计算机系统的独用操作系统。VMS最初是与DEC的VAX11／780一起在1977年宣布的。VMS是一种可以利用VAX系统32位体系结构的优势，并且可以真正提供多任务多用户能力的操作系统。


  • VOD 视频传播系统

    (Video On Demand) 视频传播系统，伴随着视音频处理及计算机网络技术的发展而迅速兴起的一门综合性技术。VOD系统由节目提供者、业务提供者（服务器）、网络以及终端构成，能在用户需要时提供高质量、简便、快捷的视频服务业务。


  • 卷宗的跨越 Volume Spanning

    使用卷宗跨越，一个卷宗的体积就不再受一个磁盘驱动器存储容量的限制了。这时的卷宗可以跨越多个磁盘驱动器，并且提供多兆字节的存储。这对于一些数据库文件是很重要的。

    在NetWare环境，卷宗是存储的基本部件。可以将一个单一磁盘分为两个或多个卷宗，或者也可以将一个卷宗跨越不同的磁盘。将一个卷宗跨越不同的磁盘提供一些性能增强，它可以是一个控制器与多个驱动器，也可以是一些控制器与多个驱动器。可以简单地通过增加另外一个驱动器和使得这个驱动器的一部分成为一个卷宗的附件，来增加卷宗的体积。这不需要对原来的卷宗进行重新格式化，这时因为NetWare只需简单地将新的卷宗附件增加给它。

    虽然卷宗跨越可以改进性能，但也增加了冒险，除非为此采取了预防措施。如果卷宗跨越的一个驱动器失效了，NetWare就不能使用整个卷宗了。在这种配置中应该使用一些容错功能，例如磁盘镜像和复置等。

    相关条目：Disks，Partitions，and Volumes Under NetWare NetWare下的磁盘、分区和卷宗；NetWare Volumes NetWare卷宗。


  • NetWare的卷宗 Volumes，NetWare

    参见Disks，Partitions，and Volumes Under NetWare NetWare的磁盘、分区和卷宗；NetWare Volumes NetWare卷宗。


 VoxML　语音标记语言
：VoxMl(Voice Markup Language)是Motorola提出的技术，它让用户可以通过电话呼叫一个网站，通过语音识别软件的帮助可以完成相应的功能。


  • VRML 虚拟现实建模语言

    虚拟现实建模语言(Virtual Reality Modeling Language)，是用于描述3D图形序列及可能的用户交换的语言。使用VRML，可以让图形序列和用户进行交互。例如用户可以象在真实的房间中一样进行转动，上下观察，所显示的图形就是它应该在真实房间中看到的一样。只有通过VRML浏览器才能浏览VRML文件，这个文件是浏览器的一个插件。


 VxD　虚拟设备驱动程序
：VxD是一个管理例如硬件设备或者已安装软件等系统资源的32位可执行程序，使得几个应用程序可以同时使用这些资源。


  • WAP 无线应用协议

    无线应用协议，应用在无线传输网络上的一个全球应用发展标准。我们现在所熟知的WAP手机即是使用的这种协议。


  • Wavetable 波表合成

    它通过对乐器声音进行取样，并将之保存下来，重播时靠声卡上的微处理器或PC系统内的CPU经过处理来发声。根据取样文件放置位置和由专用微处理器或CPU来处理的不同，波表合成又常被分为软波表和硬波表。


 WEB VOD WEB视频点播
：通过一根电话线，可以在家用电视（配机顶盒）或直接用PC（高速接入）来收看我们的交互的多媒体节目，并且是自己选择，随心所欲。


  • WHOIS数据库 WHOIS（“Who Is”）

    WHOIS是一种由防御数据网（DDN）信息中心（NIC）维护的关于用户、主机系统、网络和域的Internet数据库。该数据库的信息只包括已经通过NIC在因特网上注册的用户和主机系统的信息。可以查找这个数据库，以确定用户的电子函件地址。该处理过程是首先在nic．ddn．mil的WHOIS数据库进行登录，然后用WHOIS命令进行查询。在提示符下键入HELP可以得到更多的信息。

    相关条目：Internet。


  • 广域网 Wide Area Networks

    广域网是互联地理位置遥远的计算机系统的通信系统。它可以连接超过一个机构权限（多个建筑物或校园环境）之外的计算机，并且穿越由本地、国家、或国际管理组织控制的公共区域。通常，公共电话网络形成远程地点之间的链路，但是一个机构也可以通过安装微波、卫星和其它通信技术来建立自己的WAN链路。网络的范围介绍如下：

    局域网（LAN）局限于单一部门、工作小组或一个建筑物的网络。

    校园网 在校园或工业园区内不同建筑物中的局域网的互联网络。它们的传输设施和穿越设施通常是专用的。

    城域网（MAN）跨越城市区域公共场地的网络，它通常是由本地交换电信公司、电缆公司或其它向公众提供服务的供应商建造的。这种网络通常是采用微波系统和／或光纤缆线来建立的。

    广域网（WAN）是一种全球范围的网络。如果使用了公共设施，WAN就涉及了本地电信局（LEC）、长途电信局（IXC）和远程电信局。

    企业网是一种广域网，它互联本机构在本地或广域的计算资源，而不论它们的操作系统、通信协议或平台如何。它通常由一个中央权威机关来管理的。

    Private Network专用网

    不同机构可以建立专用网或公共网。专用网包括机构所有的交换和通信设备，它与租用线路或所有的专用通信线路（例如微波系统）相互联。专用线路帮助这个机构维护安全性和控制这条线路上传输的通信量，并且和提供商签订服务等级以保证线路质量和可用性。使用租用T1（1．544Mbps）或T3（45Mbps）建造的专用网，在一些情况下是可行的，这依赖于预算、传输需求和地点间的距离，如下所述：

    租用线路的费用随着距离的增长而增加，因而它们只有在一定的地理区域内才可行。

    在两个地点之间每天进行4小时或更多的WAN通信就比较适合租用一条专用线路，但是距离费用可能影响这方面的计算。

    当互联较少的地点时，用租用线路来建立专用网是比较可行的，但是却不适用于互联相对来说较少通信量的多个不同地点。

    音频呼叫和数据传输可以多路复用到同一租用线路，因而如果在地点之间存在一些音频和数据传输量时，一些机构就常常选择这样的线路。

    如图W－1所示，一个专用网连接了四个不同的地点。这些点可以在本地访问和传输区域（LATA）内，其中，租用线路是由本地电信局（LEC）提供的。如果它们穿越了LATA的边界，就包括了本地和远程地点的LEC，以及一个长途电信局（IXC）。

    Public Facilities公共设施

    公用数据网（PDN）是由电信局或增值网（VAC）进行操作的。交换是在这家电信局的网络中进行的。公共网络对于连接许多远程地点，以及当在任何两个地点间的通信量都不足以使用专用租用线路时的不同地点间的连接，都是最好的选择。另外，如果顾客的地点由于很遥远而不能使用租用线路时，选择公共分组交换网络也是最好的。一个PDN，既可以提供分组交换服务，又可以提供电路交换服务，如下所述：

    Circuit－Switching Services电路交换服务

    电路－交换服务提供一条在信息交换之前提前建立的两点之间的固定路径。

    电路－交换服务提供可以预知和有保证的带宽的专用电路。

    在建立电路时需要一定的延迟。

    这种带宽是固定的，不适应通信量的急剧增加的情况。

    一旦建立了这条电路之后数据传输就可以开始。两个端系统都必须可用以建立一条链路，就象在语音电话连接那样。

    线路的失效将终止所有的传输，或需要用户干涉来选择回避这个问题的路由。

    Packet－Switching Services分组交换服务

    根据分组头中的目的地址，信息分组选择路由通过一个散列网络。

    分组通过共享的端口时，会出现一个较小的延迟，特别当分组具有可变长度时，情况更是如此。

    没有由于要建立一条电路而产生延迟，但是必须提前定义逻辑的、面向连接的电路。

    可变带宽的能力支持通信量的急剧增加。

    发送源可以在任何时间进行传输，没有必要提前建立会话。

    网络自动完成回避失效线路或结点的路由选择。在公共网络，具有许多“可变”路由来处理来自失效路径的通信量。

    确定使用哪种方式（是电路－交换，还是分组交换）是根据可以接受的在发送方与接收方之间的延迟大小来决定的。在一个发送电子函件和数据文件的面向消息的系统中，数秒、数分钟，甚至几个小时的延迟都是可以接受的，这时分组交换系统可以提供最经济的服务。对于实时应用，例如联机事务处理和其它交互需求，电路－交换系统是很重要的，而且具体的电路类型决定于通信量的多少和必须进行连接的地点的数量。如果只有一个用户，一条高速的拨号线路是可以接受的，但是如果多个用户需要同时访问一个中央地点，并且是实时的，那么就需要建立一个专用网，或使用提供多个地点间的小间隔连接的电路－交换设施。

    象CompuServe信息服务公司、GE信息服务公司、Infonet服务公司和Tymenet全球网络公司这样的VAC，向他们的顾客提供一揽子WAN服务和交费。VAC还可以为它的顾客提供一些数据处理和协议转换。使用一个PDN可以使你避免为这些线路进行协商和建立你自己的交换设备的烦恼。PDN自己处理这个网络的任何问题，并且确保数据通过一个巨大交换线路的网目（mesh）进行传递。

    图W－2表示一个广域连接的拓扑结构。一个本地访问和传输区域（LATA）通常是与一个电话区域号码相联系的一个地理区域。一个本地电信局（LEC）是一个地方Be11运营公司（RBOC），它在LATA区域内进行操作。其它非－Be11通信公司也可以在一个LATA内进行操作。一个LEC需要为长途电信局（IXC）提供一个访问点（POP）设施，这些长途电信局可以是AT＆T、MCI、US和Sprint等等，因而顾客可以选择它们希望选择的IXC。一些长途电信局提供旁路设施，于是顾客可以直接连接到他们的长途服务，而不是通过IFC 例如MCI最近宣布了一个计划，它将在20个美国主要城市建立旁路LEC相应的长途访问设施。这将对顾客提供相当的经费节省。

    图W－3示意了WAN连接的物理设备。网桥或路由器在广域网上滤出来自本地网络的WAN通信量。对于模拟线路，连接到网桥和路由器的是调制解调器，对于数字线路是信道服务部件／数据服务部件（CSU／DSU）。在（A）中，在模拟电话线路上调制解调器连接两个LAN。在（B）中，在一条数字线路上一个CSU／DSU连接两个远程线路，在（C）中，多个地点在分离的T1数字线路上进行互联。在（D）中，一个进入公共帧中继网络的单一连接，使用电信局的交换设施和帧中继分组服务，提供多个远程地点的连接。注意，在（C）和（D）中，也可以使用语音／数据多路复用器在相同的线路上传输语音和数据。

    Carrier Services for WAN Connections WAN连接电信服务

    电信服务包括：拨号电话线路、专用线路、电路－交换或分组交换服务。拨号模拟线路传输率的范围是1，200到28，800bps（在现有标准下），专用交换数字服务的范围是56Kbps到45Mbps，异步传输模式等具有信元中继的服务现在提供45Mbps的T3速率的服务。下面列出典型的应用：

    电子函件传输需要2，400到9，600bps的传输率。

    远程控制程序需要9，600到56，000bps的传输率。

    基于LAN应用的远程交互需要9，600到384，000bps的传输率。

    为获得所需吞吐率的大致情况，需要将这些传输率乘以同时访问一条链路的用户的数目。

    拨号模拟服务

    拨号电路使用可以在交换线路提供高达28，000bps传输率的调制解调器（使用新的ITU／CCITT V．34调制解调器标准）。由于这些线路是交换的，所以只对连通时间进行收费。

    拨号服务对于偶尔连接的链路是很理想的。它们可以为公司不同地点之间传输电子函件提供链路，并且使得家庭或移动用户有能力拨号到这个公司的数据库。在远程－控制连接的情况下，用户拨号到公司的网络，并且可以控制到这个LAN计算机的连接。该连接到LAN的计算机进行所需处理，并可将屏幕输出发送给远程用户，且从这个远程用户接收键盘输入。这种技术减少了通过远程链路的传输通信量。

    专用线路

    可以从电信局获得各种形式的数字线路，这些线路通常都是按月收费的。其中，包括初装费用，这一费用是与距离有关的。如果这个线路连接了两个不同地点的LATA，就包括了本地访问和传输区域（LATA）的本地电信局（LEC），以及长途电信局。如前所述，这种情况可由长管电信局（如MCI）来改变顾客的长途链路，而不需要LEC来完成这些工作。

    AT＆T和RBOC提供数据电话数字服务（DDS），它的数据传输率范围是2，400到56，000bps。AT＆T提供的服务用于创建LATA之间的专用线路，而RBOC提供的服务用于LATA内部创建专用线路。

    T1线路、部分T1线路和T3线路在兆位数量级提供数据传输服务。T1电路的数据传输率是11．544Mbps。部分T1是为现在不使用完整的T1线路，但将来却可能需要使用完整的T1线路的用户准备的，它提供24个信道，每个信道64Kbps。用户可以开始时只使用一定数目的部分T1线路，并且根据需要增加到使用一条完整的T1线路。电信局建立完整的T1线路，但只允许使用商定的带宽直到需要使用更多的带宽为止。一条T3线路等价于28条T1线路。

    专用数字线路通常用于传输音频、视频和数据。数字化音频转换需要64Kbps的带宽，因而许多T1用户使用数字化和多路复用技术来合并音频和数据的信号到相同的数字线路上。按照相同的方式，一个用户可以租用一条完整的T1线路，并将其中一些信道用于公司不同地点之间的语音呼叫，其它剩余的带宽用于数据传输。为在一条T1线路上，以一个单一数据流的形式传输音频、视频和数据源的信号，需要使用一个多路复用器来对这些信号进行合并，然后，在另外一端需要一个“一到多”的转换器来对每个独立信道进行分离。

    并不是所有的租用线路都是专用的，机构可以为偶尔使用而临时租用高速线路，例如月末文件运输或一个星期一次的电视会议，这些服务通常都是提前与电信局预订的。下面讨论的交换服务将减少对这些类型的线路需求。

    电路－交换服务

    基本上，电路－交换服务和音频电话呼叫没有太多区别。为延续呼叫，在两个地点之间建立专用信道，在呼叫期间提供一定的带宽。用户只需为连通的时间付费，并且可以呼叫许多不同的地点，这些服务通常被称为按需拨号（dial－on－demand）服务。通常这些服务需要呼叫建立延迟时间。新的交换设备已经可以将这种延迟时间降低到微秒数量级。在多数情况下，较短的建立时间是不会有什么问题的。

    下面，电路－交换线路通常做高速专用线路的后援线路。

    当租用专用线路失效时，一条或多条电路－交换线路被连接起来以处理不同地点之间的通信，直到这条专用线路被重新连接好为止。

    当专用线路上的通信量已经饱和时，电路－交换线路被连接起来以处理超出的通信量。这种策略为网络管理人员对一些地点进行连接而不需要增加更多的专用服务数量提供了一条经济的途径。

    一种将电路－交换线路与反向多路复用器相结合的技术可以根据需求提供带宽。在这种技术中，当带宽增加时，就增加附加的链路。每个端点的反向多路复用器分解并且重组多个低速线路上的信号。

    一种通用的服务是交换－56，它以56Kbps的传输率进行操作，并且在每个地点需要一个特定的交换－56CSU／DSU。交换－56服务最初是想为象T1这样的高速租用线路提供一条相应的后援路由。如果一条租用线路失效了，一个交换－56电路就可以很快建立一条相应连接。交换－56现在还可以按照这种方式使用，但是它还用于处理高峰期的传输、传真传输、后援会话、大量电子函件传输和LAN对LAN连接。费用通常是按照分钟计算的。

    对于更高的数据传输率，象AT＆T这样的电信局提供其它一些服务，如交换384K和交换T1。用户需要安装基本综合服务数字网络（ISDN）服务，如下所述：

    综合业务数字网络（ISDN）

    ISDN是一种在局部环路上提供全－数字服务的网络。局部环路是家庭或商务用户和本地电信局的交换室之间运行的电缆，这种回路现在仍然支持模拟传输铜质双绞线电线。ISDN在选择的区域提供，以拨号服务方式使用，在顾客和电信局之间提供高速数字电路－交换服务，和一系列集成语音和数据服务，在此之上可以建立许多其它服务。例如，AT＆T系统的两种服务：交换384K和交换T1，均需要在用户和电信局之间建立ISDN接口。另外，帧中继是一种特殊的ISDN，它将在下面介绍。

    称为基本速率接口（RBI）的基本ISDN有三个信道：两个提供64Kbps，第三个提供16Kbps的信号发送ISDN主要速率接口（primary rate intertace）为需要它的用户提供扩充服务，它包括23个语音或数据信道，每个信道64Kbps，另外还有一个64Kbps的信号发送信道。信号发送信道提供建立呼叫的重要功能，它提供微秒数量级的建立速度和不同频道信号传输的（out－of－band）信号发送，它可以保持数据信道只进行数据传输。

    分组交换服务

    分组交换网络提供网目连接，通过这个网目连接，数据分组传输到达目的地。来自源系统的数据被分离，并被放进预定大小的分组。有两种分发分组的服务：

    无连接服务，其中，每个分组都是一个独立实体，它们按照自己的路径通过网络，这些路径是根据可用的最佳路径或由这条路径上的交换决定来选择的。由于分组可能按照不同的路径进行传输，所以它们就可能乱序到达目的地，因而在目的系统就需要进行重新排序。

    面向电路的服务，它建立穿越网络的逻辑连接或路径。路径是预定义的，它改进了性能和分组的开销。由于分组按照预定的路径进行传输，因而它们将按序到达，不需要重新进行排序。

    X．25是一种定义分组交换公用数据网（PSPDN）连接的协议。物理网络连接和数据－链路连接在这个协议中被定义。X．25网络以64Kbps的速度进行工作。它们在每个结点进行扩充的错误检查，以保证在不可靠的电话线路上进行数据传送。在发达国家，线路现在是非常可靠的，因而取消了结点错误检查的快速服务变得越来越流行。帧中继就是一种这样的服务。

    帧中继服务

    帧中继是从ISDN规范中演化出来的一种先进技术。它是一种面向电路的服务，虽然它通常在快速分组服务中进行讨论。帧中继是一种取消了X．25的网络层处理的分组交换技术。帧中继通常以1．544M bps的数据传输率传递数据，现在正在实现更高速率的技术。

    X．25的开销比帧中继要高许多。例如，在X．25中，在分组路径的每个结点必须完全接收一个分组，并且在继续传递它之前需要完成对这个分组的错误检查。帧中继结点只是简单地查看分组头中目的地信息，并且立即转发这个分组，在一些情况下，甚至在它完全完成接收一个分组之前就进行转发。帧中继没有X．25中为进行管理、流控和错误检查而必须的每个中间结点的状态表。端点结点必须检查丢失的帧和请求进行重发。

    获得交换服务的访问

    任何交换服务的问题就是获得对服务电信局设施访问的问题。公用数据网在客户地点不提供从本地LAN用户到远程LAN用户的任意点对任意点的连接。但是在电信局的交换设备中却提供。客户必须租用象T1或T3这样具有足够容量的专用线路，将多路复用的本地数据通信量传输到电信局的交换设施，或使用象交换－56这样的交换线路或ISDN接口来到达这些设施。

    首先，租用专用线路来到达电信局的设施，看起来这与使用交换设施的目的相矛盾，但是请牢记，到达电信局的网络距离通常是较短的。交换设施提供长途的任意点对任意点的连接，它的费用要远远小于在长途建立专用网的费用。

    现行WAN服务的问题和费用高的主要原因是，需要客户在他们的区域内通过本地长途电信局（LELC）的设施来传输通信量，这些信息被长途电信局在访问点（POP）取出。如前所述，MCI和其它长途电信局计划通过在许多主要城市区域建立旁路设施来改善这种局面。

    其它趋势

    现在国内和国际电话系统，都不能为需要高带宽的计算和多媒体提供所需的兆位数据传输需求。考察一些将支持全球数据、语音和视频网络的技术和服务是有价值的。随着计算系统能力和速度的改进，网络上的数据通信量也将增长。伴随着需求的增长，数据网络将变得和语音网络一样流行和透明。同步光纤网络（SONET）就是一种能够达到这一目标的传输网络，它为数据传输率在51Mbps到2，488Mbps范围的光缆传输定义了一种多路复用标准。

    异步传输模式（ATM）在SONET上传输数据。它对物理网络（即SONET）上的不同来源的数据信元（固定体积的分组）进行多路选择。ATM提供通过SONET的虚拟通信路径。在两点间的面向连接的虚拟通信路径可以达到45Mbps到622Mbps的数据传输率，虽然45Mbps是现在载波的极限。在布线集线器中，ATM在LAN级别交换是很有用的。并且它作为对国际和全球远程通信网络的一种交换技术也是有用的。

    上述ATM是一种宽带综合业务数字网（B－ISDN）。ATM是推进B－ISDN的动力。B－ISDN是ISDN的一个后继产品，ISDN定义如何向家庭和办公室提供高于64Kbps的电路－交换通信。B－ISDN使用ATM技术SONET物理网络和其它顾客服务一起提供从155Mbps到622Mbps的数据传输率。另外提供的一种服务是交换式多兆位数据服务（SMDS），它是由地方Bell运营公司的一个分支研究机构Bellcore开发的。SMDS的设计是为了在城市区域提供公共和专用数据网络。

    相关条目：AT＆T；Circuit－Switching Services 电路交换服务；Leased Line 租用线路；Local Access and Transport Area本地访问和传输区域；Networks 网络；Packet－Switching Networks 分组交换网络；Public Data Networks 公用数据网；Public Switched Data Network 公共交换数据网络；Regional Bell Operating Companies地方Bell运营公司；T1／T3 Services T1／T3服务；Telecommunication 远程通信。


  • Microsoft的Windows for Workgroups操作系统 Windows for Workgroups，Microsoft

    Microsoft for Workgroups是流行的Windows操作系统的一种对等层联网版本。它使得用户可以容易地连接他们的计算机、共享信息以及协同工作。用户可以向同事们发送电子函件、调度小组会议、共享文件和打印机、管理日历和为小组的一些项目一起工作。

    使用Windows for Workgroups，任何80386或后续型号的系统都可以作为服务器，并在这个网络上和其它用户一起共享网络资源（文件和打印机）。任何其它连接到这个网络并且运行Windows for Workgroups的系统都能象一个客户那样共享资源。可以在已经连接到现有网络的系统上运行这个程序，或通过增加网络接口卡（NIC），并用电缆将它们连接在一起来建立新的网络。一种称为Workgroup Connection for MS－DOS的类似产品，包括所有需要将一台基于MS－DOS的PC作为客户机连接到一个Windows for Workgroups服务器的软件。

    Microsoft的首席行政长官CEO和主席Bill Gates曾说：“将联网和工作组特征集成到Windows是一种重要的，具有革命性的举措。无论一家公司是小还是大，人们需要在小组内部协同工作、共享信息，在决策中快速地征求相互间的意见和协调调度以及商务活动。这些日常活动将被建入Windows for Workgroups 的服务器所支持，并且被可以利用操作系统的工作组扩充的现有的和新的应用所支持。Windows for Workgroups使得小组计算很容易进行。”

    Windows for Workgroups向开发人员提供编写可利用工作组能力优势的基于Windows应用程序时所需的功能和工具。这保证了将可以使用许多网络－兼容的应用产品。在Windows for Workgroups中，应用程序可以很容易地扩展到支持电子函件功能。例如，电子表格、字处理的文档或甚至是语音动画的消息，可以通过将它们连接到邮件消息，来发送它们到其它用户。应用正在被增强，以利用联网功能的优势。例如，Microsoft Excel和Microsoft Word for Windows自动升级通用工作组活动，如文档组装和调度跟踪，外观路径选择和注释，信息共享，和应用指定的工作组任务。

    已有网络的公司，可以象客户一样，使用Windows for Workgroups，来向他们的局域网（LAN）用户，例如工作组——激活应用程序、调度和网络动态数据交换（DDE），提供新的服务和能力。这一产品是与其它Microsoft产品（例如Windows NT）兼容的。它还将与Novell NetWare网络兼容，并包括串行分组交换／进程间分组交换（SPX／IPX）通信协议支持。用户可以同时访问Microsoft和NetWare网络。MIS管理人员和用户可以通过一个鼠标拖拉操作来为这两种流行的网络安装和配置Windows for Workgroups。这节省了时间和麻烦，并减少了台式支持的问题。另外，Windows for Workgroups还能和其它网络一起工作，例如Banyan VINES。

    Windows for Workgroups Features Windows for Workgroups操作系统的特征

    Windows for Workgroups提供一些网络应用程序和实用工具，因而一旦安装了网络，就可以与其它用户一起工作了。当然，Windows for Workgroups还包括Windows3．1产品中的所有的台式附件和使用工具。下面是将计算机连接到Windows for Workgroups网络的一些优点：

    网络上的计算机之间可以快速容易地传输文件。

    集中式文件存储和备份。

    支持对象链接和嵌入（OLE），可以自动修改所连接文件中的信息。

    传递电子函件和消息。

    共享打印机、硬盘驱动器、CD－ROM驱动器和其它外设设备。

    应用工作组。

    Windows for Workgroups包括一个随手可得的聊天（CHAT）实用程序工具，因而你可以键入消息发送给其它用户，并且阅读他们的回音。它还包括一些网络实用工具序，所以你可以监视其它网络用户使用你的系统的情况，并改变你的网络配置。下面的特征和实用工 具也是Windows for Workgroups软件包的一 部分：

    MICROSOFT邮件 邮件（Mail）是一种允许用户阅读、编辑、转发和回答的电子函件消息，以及管理它们收到的消息的一种电子函件服务。可以将一个完整的文档连接到一个邮件消息。和Windows for Workgroups包装在一起的Microsoft Mail的版本，只支持一个工作小组的工作。如果你需要和在这个网络上的其它工作组邮局连接或连接到其它电子函件系统，你将需要Microsoft Mail和Schedule+Extensions for Windows for Workgroups的支持。

    SCHEDULE+ 它是一个全功能的图形化调度应用程序，它允许人们调度小组会议和管理它们的电子化的日常日历和任务表。你可以建立小组会议和观察其它用户的调度安排。它对于为小组项目而共同工作，并且必须面对不同的截止期限的人们是非常完美的。

    网络DDE 网络DDE为用户创建在网络上共享数据的复合文档提供了一条途径。你可以从其它用户所有的文档中向你的文档插入信息，甚至这些文档可以驻留在其它网络计算机上。网络DDE 保证在原始文档中改变也将改变这个信息粘贴处的文档。例如，一位小组领导可以创建一个包括来自财会部的信息、来自艺术部的图形和来自市场部文本的复合文档。每个部门都可以根据需要改变这个复合文档中他们部门的信息。这位小组领导任何时候打开这个复合文档来进行观察或改变它的内容时，各部门从事过的任何修改都将自动反映在这位领导的复合文档中。

    安全性 Windows for Workgroups提供安全性功能，可以将非授权用户锁在使用网络的共享资源之外。用户可以在两个级别上和其它用户共享文件和打印机。网络上其他用户要么可以具有对一个目录的全权访问，要么只允许阅读文件，而不允许以任何形式来修改文件。访问是通过相对于它们应该具有的安全性级别，发给用户特定口令来控制的。如果需要更加复杂的安全性，建议使用Microsoft Windows NT或Novell NetWare。

    Windows for Workgroups Packaging Windows for Workgroups的包装

    甚至对于非技术人员用户，Windows for Workgroups也包括了用户可以快速、容易安装这个产品所需的所有功能。一些纯软件配置提供了对Windows 3．0、Windows 3．1和MS－DOS的升级。其它配置包括软件、网络卡和电缆，如下所述：

    初学者工具箱 包括将两台PC连接成一个完整的基于Windows的网络所需的全部软件、网络卡和电缆。建议没有网络的用户采用一个初学者工具箱。这个工具箱包括一个向你循序渐进地讲述安装过程的15分钟的录像带。为扩展这个网络，你可以购买一个用户工具箱。

    用户工具箱 包括为将一个附加PC 连接到网络所需的所有硬件和软件。

    纯软件包 是给那些为已经联网的PC上安装操作系统的用户，或为希望购买他们自己的网络卡的用户准备的。

    还可以以对现行Windows 3．1用户的升级软件包的形式获得这个初学者工具箱。纯软件（Soltware－only）版本是以对现有Windows3．1的用户的升级的形式提供的。

    相关条目：Client－Server Computing客户机／服务器计算；Groupware 群件；Networks网络；Object Linking and Embedding对象链接和嵌入；Peer－to－Peer Communication 对等层通信。


  • Microsoft的 Windows NT高级服务器操作系统 Windows NT Advanced Server，Microsoft

    Microsoft Windows NT高级服务器操作系统，在一种象网络服务器那样进行操作的设计中，提供所有的Windows NT的功能，例如32位操作、抢先多任务、对称多任务、兆字节存储编址能力、联网和安全性等等。这个系统还提供网络管理功能和高级容错的数据保护功能。

    在Windows NT高级服务器中具有的，而Windows NT不具有的功能，其中包括对管理区域更强的控制能力和高级容错特征，它包括了对RAID级别5的支持。远程访问服务器特征为管理人员访问和控制使用异步电话线路、综合业务数字网（ISDN）和X．25网络的远程系统提供了能力。

    相关条目：Windows NT，Microsoft。


  • Microsoft的Windows NT操作系统 Windows NT，Microsoft

    Microsoft Windows NT的设计是为了利用一个、允许软件厂商来设计其它应用程序而利用强大的新的台式系统的优势，这些台式系统包括围绕Intel、DEC和其它处理器设计的系统。Windows NT扩展了Windows3．1中的功能，并且提供了使它在操作系统领域突出出来的许多特征。Windows NT具有很广的目标用户：

    需要高性能和在多种应用之间进行交换的能力的用户。

    需要与其它用户共享他们的系统，以及其它共享计算机进行连接，交换电子函件，和调度小组会议和约会的用户。

    需要创立在Windows NT支持的系统上运行应用软件的开发人员。

    需要可以利用新的多处理器计算机系统的优势的一种安全（政府－认可）网络的网络管理人员。

    最后一点是非常重要的。Windows NT并不局限于Intel系统、DOS和Windows。它在下列处理器上运行，并且已经计划支持其它处理器，例如Motorola PowerPC。

    Intel 80386、80486和Pentium处理器系统。

    MIPS R4000 64位精简指令系统计算机（RISC）系统。

    DEC基于alpha 64位RISC系统。

    使用一些处理器的组合和特定专有总线设计的“超级服务器”。

    IBM正在致力于在它的超级服务器系统上也可以使用Windows NT的工作，其中包括了一些功能，例如容错、廉价磁盘冗余阵列（RAID）系统、纠错存储器和硬件错误登录等。PS／2服务器195和服务器295将运行适当的Windows NT版本。Windows NT的另外一个平台是Intergraph公司的Intergraph Ultra SPARC系统，这种Ultra SPARC是一种SPARC芯片的高性能版本，它是Sun Microsystems公司和Intergraph联合开发的。基于SPARC的Windows NT系统是为高性能工作站和多处理服务器设计的。

    Windows NT是一个具有抢先多任务和存储器保护，以及支持对称多处理和联网的32位操作系统，全部都具有图形化用户前端。Windows NT对全部32位处理器的访问能力，允许它对更大数字的存储器地址和指令进行工作。总体吞吐率（它是处理器性能、数据传输和存储器访问的一个组合）得到了改进。

    多任务意味着这种操作系统可以同时处理不同的事情。占先是指用户或其它任务如果需要可以中断一个任务，而不需要等待到它完全执行完毕。随着处理速度变得更快，相关硬件的活动（例如对磁盘的访问）就显得非常慢了。当一个不可占先的操作系统访问这个磁盘时，在机械磁盘被访问时处理器处于等待状态，从而浪费了处理周期。在Windows NT中，多个任务可以同时存在，因而如果一个任务由于访问一个慢速设备（例如磁盘）而挂起这个处理器可以将它的注意力转移到其它任务。基本上来说，不会浪费处理周期。

    存储保护保证多个程序在它们自己的存储区域内运行，不会占用其它应用程序使用的存储空间。如果一个应用程序出错了，其它应用程序和操作系统还可以继续工作，因而用户可以关闭工作，并正常退出。

    对称式多处理使得Windows NT可以利用多处理器的优势。多处理器系统已经存在了一段时间了，这些系统通常为每个处理器指定任务，例如网络输入／输出。这时非对称多处理——对一个任务指定一个处理器这意味着当每个处理器完成了它的指定工作后就空闲等待。而对称多处理将任务分配到任何处理器，如果一个处理器在其它处理器之前完成了工作，操作系统就向它分配其它任务。对称式多处理难于实现，但是可以提供更高的性能。

    Windows NT的联网功能允许你与其它网络用户共享你的系统上的文件，并且与其它系统上的共享目录相连。运行Windows for Workgroups的计算机可以加入这个网络。另外，Windows NT携带的软件和驱动程序支持到其它操作系统的连接，例如UNIX和IBM大型计算机。

    Windows NT高级服务器产品是一种Windows NT的增强版本，它为大型网络环境提供复杂的文件服务器特征。它包括对数据保护的附加功能，例如将数据自动复制到二级磁盘。

    Windows NT User Interface Windows NT的用户界面

    Windows NT操作系统的用户界面类似于微软公司的WINDOWS3．1操作系统的用户界面。它使用同样的用户熟悉的图形界面，在应用程序的运行方面提供一致的观感和操作方式。它还可以运行上千种WINDOW3．1和MS－DOS的应用程序。

    How Windows NT Presents ItselfWindows NT如何表现它自己

    当第一次自举WindowsNT并且登录后，就可以看见如图W－4所示的程序管理器窗口。你的计算机名字和登录名称就出现在这个窗口的标题条的顶部。

    可以通过双击你希望启动的程序的图标来从程序管理器来起始这个程序。你可以看见当前打开的窗口是主窗口。在图W－4的屏幕的底部的“组”图标，例如主群（Main）、附件（Accessories）、管理工具（Adiministrative Tools）和其它图标，帮助组织程序的图标。你可以在命令提示符（Command Prompt）下来执行DOS命令或运行不是专门为Windows NT设计的应用程序，例如POSIX－兼容程序。

    Mail、Schedule+和ClipBook Viewer是允许你与其他网络用户进行通信和共享文件或图形对象的网络兼容程序。

    可以使用文件管理器（File Manager）来观察和管理文件，与其他网络用户共享你的系统上的目录，或与其它计算机上的共享驱动程序连接。在Windows NT中，网络管理人员可以使用安全性设施来保护目录和文件不被非授权使用。可以使用下面实用程序来管理这个网络：

    用户管理器（User Manager） 用于创建其它用户可以登录的帐户和提供系统安全性的组。

    磁盘管理器（Disk Administrator）用于准备和管理系统上的磁盘。

    性能监督器（Performance Monitor）用户跟踪系统使用情况，监督性能，执行故障诊断和规划系统扩展。

    后援（Backup） 用于备份系统上的目录和文件。

    事件观察器（Event Viewer）用于观察显示系统的登录情况、安全性和为故障诊断和检修目的的应用事件。

    Support for Other Environments 对其它环境的支持

    在Windows NT中建立的是支持32位NT应用的Win32环境。另外，NT中包括一些其它环境子系统。这些子系统允许为其它在WindowsNT之下运行的其它操作系统设计应用程序。可以通过在程序管理组中启动命令提示符来访问环境子系统。NT提供下面子系统：

    虚拟DOS机器（VDM）子系统 仿真MS－DOS环境，于是就可以运行DOS应用。

    Win16虚拟DOS机器子系统 仿真Windows（16位）环境，这样就可以运行Windows3．1应用程序。应用程序以80286仿真模式运行。

    OS／2子系统 允许运行基于字符的MS OS／21．x应用程序。这个子系统在MIPS和DECa1pha计算机上不支持。

    POSIX子系统 运行满足POSIX的应用。对计算环境的可移殖操作系统接口（POSIX）标准是由电气电子协会（IEEE）定义的。

    Virtual Memory虚拟存储

    虚拟存储提供了向操作系统和应用程序分配比计算机中实际物理存储器更多的内存途径。当内存开始变得较少时，它的一部分内容被转存到磁盘存储，以腾出空间为其它进程使用。例如，如果一个进行具有一些现在不使用的却放在内存中的信息，这些信息就可以移到磁盘，于是另外一个进程就可以使用这个内存空间了。

    File System Support in Windows NT Windows NT支持的文件系统

    Windows NT的主要文件系统是新的NT文件系统（NTFS），但是Windows NT还支持老的文件系统，介绍如下：

    文件分配表文件系统（FAT）这是DO3的文件系统。它使用八个字符的文件名和三字符的扩展名的文件编名格式。Windows NT可以访问FAT驱动程序，但是如果用DOS自举这个系统，就不能访问NTFS驱动程序了。

    高性能文件系统（HPFS） 这是为OS／2设计的文件系统，它具有长文件名称。它具有FAT不具有的性能增强特征。Windows NT可以访问HPFS驱动程序。

    口NTFS 它是新的WindowsNT文件系统。它提供长文件名称、数据保护和恢复以及通过目录和文件许可的安全性。

    如果在一个新系统上安装Windows NT，很可能将整个磁盘按照NTFS进行格式化。在现有系统，可能希望保持现有文件系统的部分。这时有一些安装选项：

    可以为另外一个操作系统保持一个选译分区，而将NTFS安装在一个单独的分区。当自举这个系统时，出现一个屏幕让你来选择你希望启动的系统。

    可以将现有自举分区转变为一个NTFS卷宗。

    可以将现有分区再格式化成NTFS。并删除在这个分区中的文件。

    File and System Protection文件和系统保护

    Windows NT具有保护文件系统中的数据、防止非授权用户访问、避免文件被损坏的功能。为防止这个文件系统被非授权访问，所有的用户必须通过键入一个帐户名称和口令来进行登录。例如，这个系统管理器可以对这些帐户增加一些不同的登录限制，它可以在一定时间之后废弃这个帐户，或强制用户改变他们的口令。

    Windows NT还提供文件系统保护机制，它检测和废弃坏的磁盘块，并且恢复由于电源失效而没有完全写入的事务。重要的文件系统信息也是在这个磁盘上复置的，以防止磁盘块失效。这个安装程序还创立一个修复盘，如果自举信息被毁坏了，可以使用这个修复盘来恢复Windows NT操作系统。

    Windows NT还支持不间断电源（UPS），当AC电源失效时，它对这个系统提供后援电池电力。这个系统可以继续操作指定的一段时间，以允许用户可以正常关闭系统和将所有内存信息写入磁盘。

    Networking联网

    Windows NT中的联网服务，与Microsoft Windows for Workgroups、Microsoft LAN管理器和Windows NT高级服务器中的联网服务是兼容的。运行任何这些操作系统的计算机，可以共享目录、文件和资源。包括共享网络基本输入输出系统（NetBIOS）／NetBIOS扩展用户接口（NetBEUI）和传输控制协议／因特网协议（TCP／IP）。还可以获得顺序分组交换／进程间分组交换（SPX／IPX）协议的连接支持。

    Windows NT使用Microsoft网络驱动程序接口规范（NDIS）作为它的网络适配器接口。使用NDIS，网络卡厂商只需简单地生产和NDIS－兼容的驱动卡。然后，端点用户购买NDDIS－兼容卡就可以保证和Windows NT一起工作。NDIS支持在同一个系统中的多个网络接口卡，因而就向这个系统提供了一条访问不同类型网络的途径。

    Security and User Hierarchy 安全性和用户层次

    Windows NT满足美国国防部C2控制访问保护安全性要求。这个C2限制要求计算机不仅对网络用户的访问，还是局部用户的访问必须实现一种安全性策略和对事件的查核，在Windows NT中的C2级别安全性提供如下：

    要求用户具有用口令鉴别进行登录的特定帐户。这个帐户为了查核的目的跟踪用户操作的不同的活动，例如登录、退出登录和文件访问。管理任务，例如改变用户帐户或服务器设置也被跟踪。

    管理人员和用户可以控制访问他们自己系统的文件、目录和资源（打印机）。

    系统管理人员可以跟踪和观察可核查的事件。

    禁止用户检查存储器的内容。

    由于Windows NT提供文件－和资源的共享能力，因而如果这个计算机要被多个用户访问，就必须关心安全性。管理人员和用户必须能够保护他们在他们的系统上共享的文件不被非授权使用。然而，安全性必定要求一定程度的管理。必须对共享的目录加上许可，并且管理人员必须创建需要登录口令和提供登录限制的用户帐户。

    登录帐户信息被存储在每个Windows NT系统的一个主数据库（称为安全性帐户管理器或SAM）中。当用户进行登录时，他们的用户名称和口令在他们登录进的系统的SAM中被检查。

    Trust Relationships信任关系

    SAM数据库向本地Windows NT系统提供适应的安全性时，它为网络上的其它文件和资源共享的计算机，也引入了一些安全性和维护性问题。例如，你可以为网络用户的组定义访问权限，但却不能为需要从网络上的另外一个计算机访问你的系统的单独用户定义访问权限。这就是Windows NT高级服务器投入使用的原因。

    Windows NT高级服务器产品可以和网络上的其它计算机建立信任关系。这意味着一个计算机可以授权一个用户并对其它计算机提供关于这个用户的访问信息。然后，用户登录进一个计算机，并且不需要分别登录进每个计算机就可以访问其它计算机。

    这个安全性系统的一个有趣的特征是，赋予文件的保护信息可以和文件一起移动。例如，如果你授于一个用户有能力打开和阅读一个文件，但不能修改它，即使这个存储设备被移到了另外一个系统，这个相同的权限也将被继续赋予。

    Printing 打印

    如果你的Windows NT系统被连接到一个网络，你就可以与其它网络用户一起共享它的打印机或访问这个网络上的共享打印机，在Windows NT中的打印管理器，具有安装、配置、共享和其它管理打印机的所有特征和功能。具有Windows3．1的用户，可以通过控制板（Control Panel）中的打印机实用工具来安装打印机。在Windows NT中，选择该选项，打开打印机管理器其中包括所有打印机管理选项。

    一些授权机制控制用户对打印机的访问类型。例如，管理人员可以禁止或允许用户访问一台打印机，并授权一些用户具有能力来控制打印管理器队列中的文档。管理人员具有对打印机的全面控制权力。

    Logon and Startup Options 登录和初始化选择

    在计算机上安装Windows NT的人指定管理器口令后，就可以获得对系统的全面控制。这个具有管理能力的用户可以创建具有口令保护的帐户，于是其它用户就可以登录进这个系统了。另外，可以对每个用户帐户授予权限和认可，来授权或禁止对这个系统和它的文件的访问。如果你登录进了Windows NT系统，但是不能访问某些特定文件，这是因为你的登录帐户具有这些限制。

    每位用自己的帐户进行登录的用户，可以根据自己的需要对程序管理器进行个人化设置。例如，当John登录时，他可以重新组织程序管理器窗口，并为他想使用的程序增加一些图标。当Jane在同一台计算机进行登录时，她看不到John的改变，并且可以创立John也看不见的她自己的私人设置。然而，管理人员可以创建所有用户都能看见的通用设置。

    相关条目：Alpha AXP，DEC；Authentication and Authorization 鉴别和授权；Client-Server Computing 客户机／服务器计算；File and Directory Permissions，Windows NT文件和目录认可；Windows NT Windows NT操作系统；Groupware 群件；Multiprocessing多处理；Networks网络；Object Linking and Embedding

    对象链接和嵌入；Peer－to-Peer Communication对等层通信；Permissions in Windows NT在Windows NT中的准许权限；Security 安全性。


  • Windows开放式系统体系结构（WOSA） Windows Open System Architecture（WOSA）

    WOSA是Microsoft在Windows环境为跨越不同平台的应用程序而开发的体系结构规划。它制定允许信息在企业内部自由流动的标准。WOSA包括模块化应用程序编程接口（API），它向任何开发人员开发的应用程序提供访问网络服务的能力。这些网络服务可以包括：电子函件、数据库和主机连接。WOSA还提供插入任何开发人员开发的后端服务的能力。WOSA就是通常称为的“中间件”策略，它直接在操作系统中建立，试图刺激允许用户在网络上进行协作的工作组应用程序的增长。Windows将对消息传递系统以及允许用户快速定位网络上的其它用户或资源的目录服务提供了一个通用接口。WOSA还提供公用数据访问服务和安全性增强附件。WOSA策略类似于Apple开放协作环境（AOCE）策略。

    Windows for Workgroups具有它自己的内置Mail和Schedulel十群件产品，它实现了WO3A体系结构部件。WOSA还被用于实现OLE（对象链接和嵌入）2．0和新的Cario面向对象操作系统。

    WOSA为客户应用实现了一个标准API，并为服务器应用实现了一个服务提供商接口（SPI），如图W－5所示。使用SPI，数据库厂商可以为Windows环境创造一个WOSA兼容的数据库启动程序。然后客户的应用开发人员就可以创造接口，这些接口可以访问这个数据库启动程序，而不需要专门为访问这个数据库编写特殊代码。

    下面部件已在本书的相应标题下进行了定义，并进行了单独讨论。

    消息传递应用程序编程接口（MAPI），在其它应用（例如字处理器或调度程序）工作期间，提供对电子函件功能的访问。它与厂商无关消息传递应用程序接口（VIM）进行竞争。VIM是由Lotus、IBM、Apple、Novell和Borland支持的。

    开放式数据库互联性（ODBC）定义Windows操作系统部件到前端和后端（客户机／服务器）数据库服务的连接。它的思想是，创立到异构网络上任何服务器中存储数据的访问。数据库厂商使用ODBC来在他们的产品中提供互操作性，于是用户就可以使用他们希望使用的任何前端接口来访问数据。

    Windows嵌套字 API传输控制协议／因特网协议（TCP／IP），是一个用于连接不同计算机的网络通信标准。Windows嵌套字API（也称为网络运输协议）的设计是为了解决在Windows中存在的许多不同的TCP／IP之间的不兼容性。

    远程过程调用（RPC）WOSA实现由开放软件基金会（OSF）的分布式计算环境（DCE）定义的RPC。RPC为将一个应用程序的处理任务分布到网络上的多个计算机提供了一条途径。RPC开辟了一条真正的分布式处理的途径。

    系统网络体系结构（SNA）API 定义了Windows应用程序访问IBM主机的途径。

    许可证服务器API（LSAPI） 帮助管理人员监督和控制许可软件的使用，并帮助公司遵守法律。

    WOSA基于Microsoft的从应用程序中分离出打印机驱动程序的策略。在Windows环境，在初始化期间安装的打印机驱动程序，可以在以后的任何时间，通过使用一个简单的过程就被升级或修改。Windows应用程序使用安装的不具有任何特殊配置的打印机驱动程序。它们自动接口，并利用打印机的特殊特征和可用的字体。类似地，WOSA兼容服务器，应用程序自动接口使得它们自己的功能对WOSA兼容的客户应用程序也是可用的。这种研究极大地简化了应用程序开发，以及减轻了希望集成网络上的所有不同应用程序和可用数据的网络管理人员的任务。

    相关条目：Cario；Electronic Software Distribution and Licensing 电子软件分发和许可；Messaging Application Programming Interface 消息传递应用程序编程接口；Middleware中间件；Object Linkingand Embedding对象链接和嵌入；Open Database Connectivity，Microsoft Microsoft开放数据库连接性；Remote Procedure Call远程过程调用；Windows for Workgroups，Microsoft；Windows NT，Microsoft；Windows SocketsAPI Windows嵌套字API。


  • Windows套节字（嵌套字）API Windows Sockets API

    Windows嵌套字是由软件厂商和传输控制协议／因特网协议（TCP／IP）厂商（如Microsoft和Sun Microsystems）组成的一个工作组开发的，它是作为一种可以将市场上的基于PC的不一致性的TCP／IP产品连在一起的标准。这个规范也称为Windows传输协议（Windows Transmit Protocol）。它允许Windows应用程序可以不论下面是什么协议都可以进行通信。这个规范是在1992年宣布的，后来对开发人员免费提供。它的设计是为了保证任何联网厂商的TCP／IP软件，以及任何访问底层协议栈的Windows或Windows NT应用程序之间都具有互操作性。

    已经出现了对Windows嵌套字的需求，这是因为许多厂商使用它们自己的应用程序编程接口（API）为PC环境开发TCP／IP协议栈。由于可以使用许多不同的TCP／IPAPI，产品开发人员在他们的产品中就不得不选择一种API，或以很高的代价支持所有可用的API。Windows嵌套字是围绕著名的Berkeley嵌套字来开发的，Berkeley嵌套字是由California大学（Berkeley）的Berkeley软件分发机构（BSD）开发的。由于Windows是PC世界的一种主要的软件开发环境，因此有必要对它增加这种嵌套字扩展。

    使用Windows嵌套字，在一个厂商的TCP／IP协议栈实现的应用将可以与其它厂商的协议栈一起工作。这就极大地简化了开发人员的工作，并促进了软件的开发。Windows嵌套字承认Berkeley系统分发版本4．3，并且提供流类型、面向连接的TCP服务，以及用户数据报协议（UDP）的数据报服务。

    相关条目：Transmission Control Protocol／Internet Protocol 传输控制协议／因特网协议（TCP／IP）；Windows Open System Architecture Windows开放式系统体系结构。


  • Windows 电话应用程序接口 Windows Telephony Application Interface

    Windows电话应用程序接口，是为帮助开发人员集成计算机与电话应用，产品而设计的一种应用程序编程接口（API）。特别是基于Windows的PC，用它来执行类似PBX的功能，例如召开会议、呼叫传输和语音录音。它还包括用于集成传真、电子函件和语音的一些工具。


  • WindowsCE 操作系统

    Windows CE这个名字一看就让人立刻明白了，这又是微软公司生产的另一种操作系统。它主要用于便携式空间受限的设备中，这些设备包括掌上型电脑或机顶盒。它是多任务多线种的操作系统，其主要竞争对手是EPOC。微软希望它在台式机操作系统上的统治地位在掌上型电脑上也发挥作用，它提醒用户使用Windows CE使熟悉其它Windows操作系统的用户觉得特别亲切。


 WINS　IP解析
：WINS用来登记NetBIOS计算机名，并在需要时将它解析成为IP地址。WINS数据库是动态更新的。


  • 无线局域网通信 Wireless LAN Communication

    无线通信可以分为两类：无线局域网（LAN）通信（将在下面介绍）和无线移动通信（在“无线移动通信”中介绍）。它们的传输设施是根本不同的。无线局域网通信使用发射器和接收器，它们都是放在公司希望的地方，并且属于这家公司所有。无线移动通信，需要电话电信局或其它公共服务，来为“离开办公室”或“正在旅途中”的用户提供设施，使用分组无线电、蜂窝网络和卫星站来传输和接收信号。

    无线LAN的发射接收器（发送器／接收器）通常放在办公室内。带移动计算机的用户可以移动，他们通常在发射接收器的中间区域之内。无线LAN不用布缆，特别是如果这个LAN的地点是临时的，或为不远将来就将取消的工作小组服务的，那么就更需要使用无线局域网。使用无线局域网可以免除布缆和安装的费用，在一些场合，还免除了对特殊建筑物布线的需求。

    一种典型的无线局域网配置包括使用标准以太网电缆连接到服务器和其它设备的一台发射接收器。这台发射接收器广播信号，并从周围的工作站接收信号，如图W－6所示。

    无线数据传输有三种技术，它们将在下面讨论：

    红外线 红外线以光速宽带方式发送信号。红外线的传输是成直线的，所以发射器和接收器必须相互瞄准，类似于电视遥控。必须考虑传输环境的障碍物，但是在需要的时候，可以使用镜子来约束红外线的传输。由于红外线可能会受到来自窗外或其它来源的强光干扰，所以应该使用可以产生强红外线的系统。注意，红外线是不受政府管理的，也没有传输率的限制。典型的传输率在10Mbps左右。

    窄频带（或单一频率）无线电 这种方式类似于无线电台的广播，你需要将发射器和接收器都调谐到一个“固定”的频率。这种信号可以穿透墙壁，并扩散到很广的区域，所以不需要相互瞄准。然而，窄频带无线电也存在一些问题，例如，无线电发射、FCC的控制，以及它们必须精确地调谐，以防止其它频率的干扰。Motorola在它的Altair区域使用窄带宽无线电传输技术，这家公司获得19GHz频域的许可，这种许可是根据地理位置来分配给顾客的。Motorola为它的产品分配所有的FCC许可。传输率为4，800Kbps。

    宽带无线电 这种技术在很广的频率范围内广播信息，从而避免了窄频带通信所固有的问题。使用一个代码来传播信号，接收站也使用相同的代码来提取这个信号。编码技术使得宽带信号可以在很广的频率范围进行工作，甚至在这个相同的频域内可以有其它一些宽带信号。宽带无线电并不与日常的无线电之间产生干扰，这是因为它的能量级非常的弱。传输率在250Kbps左右。

    另外一种局域网采用微波传输，它适合于小的短途系统，它适用于一个校园环境或在一个城市区域内的不同建筑物之间的互联（参见“微波通信”）。

    Black Box销售可以连接3公里距离以太网的无线LAN网桥，它避免了使用象T1线路或光纤缆线这样的广域连接，传输率在2Mbps的范围。它是一种提供协议透明的IEEE802．1D认可的介质访问控制层网桥。即使在恶劣气候下，它也能提供安全数据传输，并实现了宽带无线电技术。

    Black Box公司的网桥可以连接到任何细缆以太网或10Base－T网络，并且可以自学习识别这个局域网的所有地址。它可以使用三种天线。在点对点配置中，短范围天线和长范围天线分别提供1／2和3公里的传输距离。万向天线提供1／2公里传输距离的多点配置。BlackBox公司的联系地址是Pittsburgh，Pennsylvania，电话：412／746－5500。

    如果你对无线局域网有兴趣，可以与Motorola（800／233－0877）联系，它有窄频带产品。也可和NCR（800／237－2870）联系，它有宽带产品。或与Laser Communications（激光通信公司）（800－527－3740）联系，它有红外线产品。下面列出，其它一些厂家：

    Altair（Arlington Heights，Illinois），它是Motorola的一个分支，提供使用窄带18GHz频率的以太网网络。

    InfraLAN Technology（Cambridge，Massachusetts），提供在24米（80英尺）范围内的4Mbps和16Mbps的令牌环网络。

    NCR（Dayton，Ohio），提供WareLAN宽带型系统。

    Proxiim（Mountain View，California），提供宽带LAN产品。

    Telesysytems（Don Mills，Ontario），提供宽带基于以太网的网络。

    Windata（Northborough，Massachusetts），提供宽带基于以太网的网络。


  • 无线移动通信 Wireless Mobile Communication

    无线通信分为两类：无线移动通信（在下面将介绍）和无线局域网（LAN）通信（在“无线LAN通信”中介绍）。它们的传输设施根本不同。无线局域网通信使用发射器和接收器，它们都是放在公司希望的地方，并且属于这家公司所有。无线移动通信需要电话电信局或其它公共服务，来为“离开办公室”或“正在旅途中”的用户提供设施，使用分组无线电、蜂窝网络和卫星站来传输和接收信号。

    今天，移动通信用于与流动的销售人员、送货车辆、地质人员和其它一些人们保持联系。移动计算机用户使用无线通信和公司网络相连，并交换电子函件，传输文件，接收个人新闻或其它编址到他们的移动计算机或个人数字助理（PDA）的信息。这些PDA可以是Apple Newton、EO和Genenral Magic的设备。随着科技的发展，传输率将越来越高，而价格将越来越低。移动用户将花费很多时间通过与无线网络的连接来查询公司数据库或参加联机会议和会谈。

    操作系统厂商已经开始考虑移动用户的问题，他们创建了一些新的功能，例如跟踪移动用户的位置，并维持从一个会话到另一个会话的环境。例如，当一个移动用户从一个地点到了另一个地点，他或她切断连接；然后再重新连接到固定位置的远程系统，这个操作系统可以自动恢复连接并恢复上一次会话的台式系统环境。如果用户正在访问一个数据库，那么当他或她在进行连接时就可以发现上一次数据库查询的结果。PDA使用与大多数操作系统和应用程序不同的接口。然而，随着移动计算机用户的增长，厂商们正在为集成这些系统而工作。

    移动计算很自然地牵连了电话电信电讯公司或其它服务提供商。用户必须关心访问的级别（范围和信号穿透能力）、数据传输率、存储前递的能力，这些能力保证用户返回到工作范围内后，可以查取他们的消息。使用以前介绍的通信系统中的移动设备，其数据传输率是很低的，大约从8Kbps到19．2Kbps。错误检查的需求将严重地降低传输率。

    无线设备可以是单向的，也可以是双向的。单向通信包括只接收信号的BP机。双向通信设备使用分组无线电和蜂窝传输方式。SkyTel提供三个级别的服务：传输电话号码、语音－邮件消息提醒，或电子函件消息提醒。EMBARC与SkyTel竞争，它提供具有30，000个字符的消息传递能力，而SkyTel却只有240个字符。EMBARC还提供同时传输，例如用户可以在不同的远程系统修改信息。

    双向通信系统包括分组无线电网络和蜂窝系统，如下所述：

    Packet－Radio Communication分组无线电通信

    分组无线电通信将一次传输分解成许多小的包含源地址和目的地址，以及错误检测信息的数字分组。这些分组被上联到一个卫星，然后再进行广播。接收设备只接收编址到它的数字分组。由于这种传输是双向的，因而要使用查错和纠错技术。

    参见“Packet－Radio Communication 分组无线电通信”。

    Cellular Digital Packet Communication蜂窝数字分组通信

    蜂窝通信是一种提供用户和他们的家庭、办公室或网络之间进行双向通信的移动计算设备。这些设备具有电子函件处理能力，并且可以传输文件和其它信息。由于这些设备在本质上也是双向的，因而也需要查错和纠错技术的支持。参见“蜂窝数字分组数据”。

    在写这本书的时候，移动通信的未来前景尚不明确。Bob Metcalfe在Infoworld（8－16-93）上提出了与移动计算厂商们相反的观点。他指出，无线通信只是一种暂时性的潮流，并说：“在我们已经被日益增多的电磁信号污染的宇宙，决不会永远拥有所需的足够的兆赫频率，将信息在所有方向进行广播，而只有一个用户接收它，这无疑是一种能源上的巨大浪费。”

    相关条目：Cellular Digital Packet Data蜂窝数字分组数据；Mobile Computing移动计算；Packet－Radio Communication分组无线电通信。


  • 布线 Wiring

    参见EIA／TIA 568 Commercial Building Wiring Standard EIA／TIA 568商用建筑物布线标准；Cabling布缆。


 Wizard 向导
：一种交互式帮助实用程序，起初是微软公司为其Windows应用程序开发的(现在被广泛仿效)。向导通过多步操作的每一步引导用户，提供有帮助的信息，并在这一过程中解释选项功能。


  • 工作流软件 Workflow Software

    工作流软件的目的是，在一个机构内通过用电子文档来替换纸张文档系统，从而实现文档处理过程的自动化。局域网络可以提供将文档从一些存储设备中移进或移出，以及在需要时观察、修改文档，或对文档进行签署（表明它们具有权威性）的用户之间进行路由选择。工作流软件通过自动完成工作流程，从而消除人员必须的交接走动，鼓励工作组的协作办公。

    典型的工作流应用程序结合了具有电子消息传递功能和高级安全性功能的文档。其中高级安全性功能包括电子签名，以提供这个文档确实是来自特定来源的证据，并且提供它们已经被指定的某些关键人物进行了确认的证据。

    在财务管理环境，文档通常是从出纳员通过不同的处理和确认后转交到主管会计那里的。工作流分组可以为出纳员显示机构使用的一些特定表格。这个表格的一些域可以根据这一工作，以及这个出纳员管理这个表格的性质自动填写。可以对这些表格预定义路由选择，从而消除在手工纸张流中不可避免的一些头痛的管理问题。这些表格可以被直接传送到处理过程中下一个进行处理的那位人员那里。自动处理的功能可以避免在表格处理中可能出现的耽搁情况。例如，可以提醒用户必须按时处理，否则就会出现过期或其它由于没有按时处理而出现的问题。出版是协作环境的另外一个例子，它也可以利用工作流软件来提供工作效率。文档可以按步从作者到编辑再到印刷，其中通过使用网络和它的资源来进行存储，并且最终打印出完成的工作。

    下面是工作流软件的一些关键特征：

    文档根据预定义的路由进行分发。

    一些用户可以根据需要来访问和修改这个文档。每次修改都必须签上进行这次修改的人员姓名。可以加上一些希望哪些人员再阅读的注释。

    文档跟踪使得用户可以轻易得知文档在系统中流动时的位置，并且可以向那些耽误传送文档的用户发送催促信号，甚至可以撤消这个文档。

    工作流软件通常包括中央管理和文件处理系统，管理人员可以使用它们来授予不同级别的访问和安全性权限，以及建立工作流处理过程和跟踪工作流。

    锁定处理使得用户可以以一种安全的形式来完成和前递文档。当使用一次锁定时，其它用户就不能对这个用户进行的修改再进行改变了。它还不仅仅保护完成上述修改的用户，还保护接收方不会看见他或她没有进行过的修改。

    安全性是通过鉴别和数字签名来实现的。

    接收方可以确信发送方的正确性，可以证明这个文档是发送方发出的，并且可以证明它在传输过程中没有被改变。

    发送方可以确信由接收方对该文档进行过的任何变动都可以检查出来。

    从管理的角度来看，工作流软件可以帮助一个机构跟踪信息是如何流动的，以及如何更好地管理这种流动。工作流软件可以消除许多费时的活动，以及经常发生的昂贵的活动，例如会议、电话呼叫和特快专递。但是一旦用户转向使用这种新的软件，所需的带宽就会增加。工作流软件允许用户来观察大型的图象文件、图形、声音，甚至可以观看视频文档。这种类型的通信量将会使网络饱和。

    可以从许多厂商获得工作流软件，例如Action Technologies（Alameda，California），DEC（Maynard，Massachcusetts）、IBM（White Plains，New York）、Lotus Development（Cambridge，Massachusetts）等等。象Windows这样的图形用户环境非常适合工作流应用程序，其中图形、文本和其它来自许多不同应用程序的元素都被以对象的方式集成到复合文档中。Windows具有内置工作流功能，例如它的对象链接和嵌入（OLE）功能，并且Windows for Workgroups产品就是一种包括邮件和调度软件的网络群件包。

    Internet多功能函件传递扩展标准（MIME）是一种Internet标准，它为在电子函件消息中包括不同类型的数据（例如图形、音频、视频和文本等）提供了一条途径。其中，格式化功能允许用户指定字体类型、字号和文档的页的布局，因而它们就可以被其它系统中的不具有类似应用的用户进行阅读和翻译。

    标准规范化表示语言（SGMI）是超出美国信息交换标准代码（ASCⅡ）格式之外的一种文档规范，它为描述文档的格式提供了一条途径。它用于创建“智能”文件而不是“哑”（ASCII）文件。一个SGML文档包括定义文档中的每个部件的一些属性，因而使得文档硬件和软件独立。使用SGML文档格式，工作流软件供应商可以更加集中精力于功能性，而不是相互转换。用户和程序员希望能够在文档中存储关于执行事件，或具有激活与这个系统以及与它连接的输出设备兼容的格式信息。

    相关条目：Compound Document复合文档；Document Interchange Standards文档交换标准；Electronic Mail电子函件；Groupware 群件；Lotus Notes；Mail／Message Enable Applications 邮件／消息激活应用；Messaging Application Programming Interface消息传递应用程序编程接口；Object Linking and Embedding对象链接和嵌入；Standard Generalized Markup Language标准通用表示语言；Workflow Software工作流软件。


  • 工作组，（用户）组 Workgroups

    工作组是一个由许多在同一物理地点，而且被相同的局域网连接起来的用户组成的小组。相应地，一个工作组也可以是遍布一个机构的，但却被同一网络连接的用户构成的逻辑小组。在以上两种情况下，在工作组中的用户都可以以预定义的方式，共享文档、应用程序、电子函件和系统资源。一个工作组可以是用同一名字的简单的用户小组，例如在电子函件中的地址“Managers”或“Temps”等指明的小组。另一方面，这个工作组可以在这个网络上具有一些特权，例如对文件服务器或一些特殊应用的访问等等。

    工作组和工作组支持软件正在变得越来越普及。例如，在Microsoft Windows for Workgroups中Schedule+应用程序就可于帮助用户在他们的调度和安排会议方面进行协作。Microsoft的Windows开放软件体系结构（WOSA）是一种在Windows操作系统之间建立工作组激活功能的策略。使用这些功能，开发人员和用户可以创立或使用能够激励网络上的工作组和工作流活动的功能特征。WOSA包括了到公用消息传递系统、目录服务、安全性特征和访问后端数据库服务的接口。Apple的开放协作环境（AOCE）是针对Macintosh环境的一种类似策略。

    相关条目：Apple Open Collaborative Environment Apple开放协作环境；Electronic Mail电子函件；Groupware 群件；Users and Groups用户和组；Windows Open System Architecture Windows开放式系统体系结构。


  • Workplace操作系统 Workplace OS

    Workplace OS是一种强大的基于微内核的操作系统。它与OS／2使用相同的Workplace外壳图形用户界面，但是它提供一个64位的核心，该核心可以运行针对一些现有的操作系统设计的应用程序，例如DOS、Windows、UNIX，当然还有OS／2。这种微内核的设计保证了它可以在Motorola PowerPC微处理器，以及Intel80386、80486，和Pentium处理器上运行。

    Workplace OS是基于Carnegie－Mellon大学创造的Mach 3微内核技术的。Mach 3还用于OSF研究学院的OSF／1MK微内核OS。IBM对Mach 3微内核增加了一些增强功能，例如对称多处理、存储管理和安全性。分层体系结构允许这个微内核适用于许多不同的操作系统，例如：

    DOS，它的IBM版本不同于Microsoft版本的MS－DOS。

    OS／2，最初是由IBM和Microsoft共同开发的，但是现在归IBM所有。

    AIX，基于开放软件基金会（OSF）所做的工作。

    Workplace OS还归Taligent公司所有。它是一家独立的公司，由Apple和IBM建立。这家公司将利用对象技术来扩展OS／2的图形用户界面。Workplace OS已经支持对象技术，例如IBM系统对象模型（SOM）和分布式系统对象模型（DSOM）。

    相关条目：Distributed Computing Environment，OSF OSF的分布式计算环境；IBM Operating System IBM的操作系统；OSF／1，Open Software Foundation开放软件基金会的OSF／1操作系统，Remote Procedure Call远程过程调用；Windows NT，Microsoft Microsoft的Windows NT操作系统。


  • 工作站 Workstation

    今天，工作站是指连接到网络的计算机。在过去，工作站是指高性能的工程系统和计算机辅助设计／计算机辅助制造（CAD／CAM）系统。随着台式PC的功能变得越来越强，这一术语现在通常是指连接到网络的系统。类似于术语“结点”和“客户机”，但是客户机假设了一种客户机／服务器关系，其中，客户机工作站是用户和后端服务器进行交互的前端系统。

    台式系统管理任务组（DMTF）是一个由许多厂商组成的组织，它正在为管理和跟踪网络工作站上的资源定义一个标准。这个标准称为台式系统管理接口（DMI）。DMTF组织包括数字设备公司、Hewlett－Packard、Intel、Microsoft、Sun Connect、SynOptics通信公司，以及其它一些公司。

    相关条目：Desktop Management Interface台式系统管理接口；Networks 网络。


 WYSIWYG 所见即所得
：What You See Is What You Get 的首字母缩略词。它使得用户在视图中所看到文档与该文档的最终产品具有相同的样式，也允许用户在视图中直接编辑文本、图形、或文档中的其他元素。WYSIWYG 语言常常比标签语言容易使用，因为标签语言并没有对各种改变提供即时的视觉上的反馈。此术语通常发音为“wizzywig”。


  • X窗口，X Windows图形用户接口 X Window

    X窗口是一种用于UNIX系统的标准图形化用户界面（GUI），它是由麻省理工学院开发的。GUI是用鼠标器和键盘控制的，具有下拉菜单、在屏按钮、卷动条和为运行不同应用的重叠窗口界面。其它GUI环境的例子包括Apple的Macintosh、Microsoft的Windows和IBM的O3／2 Presentation Manager。然而，X窗口环境是一种可以在远程连接之上很好工作的客户机／服务器式的设计。

    考虑到开发人员，x窗口为开发基于图形的分布式应用程序提供软件工具和标准应用程序编程接口。完成的应用是与硬件无关的，这意味着它们可以在支持x窗口环境的任何系统上运行。完整的这种环境通常被简单地称为“X”。

    X窗口系统在位映射屏幕上的一个或多个窗口中运行程序。用户可以在每个窗口同时在系统上运行多个程序，并且通过用鼠标器点击它们来在窗口之间进行交换。图X－4示意了一个X窗口环境，并将在下面讨论：

    称为x服务器的程序在本地工作站上运行，并且管理它的窗口和程序。

    每个程序窗口都被称为x客户，并且与在同一个机器上运行的x服务器程序以客户机／服务器关系进行交互。

    X服务器处理所有X客户的处理程序，以及通过消息传递系统和其它客户交互工作。X服务器控制整个本地环境，因而当访问存储器和其它系统资源时，程序间进行合作。

    X服务器运行x窗口管理器程序，这个程序提供GUI界面。现在可以使用两种窗口管理器：Motif和Open Look。它们在功能上是类似的，并且运行相同的程序。

    在本地机器运行的x服务器可以和远程计算机上运行的程序进行交互，并且在本地窗口显示这些程序的输出。它是一种客户机／服务器的关系，但是本地服务器具有全权控制，并且远程进程被称为客户机，而不是服务器，这是因为它们是处于这个本地的x服务器的控制之下的。

    在Internet和其它广域网环境，上面最后一点是非常重要的。用户可以对运行在远程计算机上的程序进行工作。这个远程程序在它需要经常访问的资源（如磁盘数据）附近运行。只有需要修改用户屏幕的信息才被通过远程链路进行传输，从而避免了将整个程序和它的数据都传输到本地系统进行处理时可能出现的瓶颈。

    X服务器和远程X客户机之间的接口是面向事件的，并且是基于X协议的。这种协议在传输控制协议／Internet协议（TCP／IP）之上运行。在一些情况下，一些厂商通过增加象三维图象这样的功能来增强了X窗口环境。X窗口环境的一个优势是，服务器应用程序可以在任何平台上运行，并且这个应用程序可以在公用运输协议之上与这个客户机交换一组消息。于是，开发人员就可以在许多系统上建立X窗口－认可的应用程序，并且这些应用程序可以被任何支持X窗口的工作站访问。

    X窗口是开放软件基金会（OSF）的Motif和Open Look系统的用户接口。SunSoft的Solaris2操作系统也实现了由AT＆T开发的X窗口实现。


  • X．25 协议 X．25

    X．25协议是CCITT（ITU）建议的一种协议，它定义终端和计算机到分组交换网络的连接。分组交换网络在一个网络上为数据分组选择到达目的地的路由。x．25是一种很好实现的分组交换服务，传统上它是用于将远程终端连接到主机系统的。这种服务为同时使用的用户提供任意点对任意点的连接。如图x1所示，来自一个网络的多个用户的信号，可以通过多路选择通过X．25接口而进入分组交换网络，并且被分发到不同的远程地点。一种称为虚电路的通信信道在一条预定义的路径上连接端点站点通过网络。虽然X．25，吞吐率的主要部分是用于错误检查开销的，X．25接口不可支持高达64Kbps的线路，CCITT在1992年重新制定了这个标准，并将速率提高到2Mbps。

    X．25的分组交换体系结构具有一些优点和缺陷。信息分组通过散列网络的路由是根据这个分组头中的目的地址信息进行选择的。用户可以与多个不同的地点进行连接，而不象面向电路的网络那样在任何两点之间仅仅存在一条专用线路。由于分组可以通过路由器的共享端口进行传输的，所以就存在一定的分发延迟。虽然许多网络能够通过选择回避拥挤区域的路由来支持过载的通信量，但是随着访问网络人数的增多，用户还是可以感觉到性能变慢了。和此相反，面向电路的网络在两个地点之间提供一个固定的带宽，它不能适应超过这个带宽的传输的要求。

    X．25的开销比帧中继要高许多。例如，在X．25中，在一个分组的传输路径上的每个结点都必须完整地接收一个分组，并且在发送之前还必须完成错误检查。帧中继结点只是简单地查看分组头中的目的地址信息，并立即转发该分组，在一些情况下，甚至在它完整地接收一个分组之前就开始转发。帧中继不需要X．25中必须在每个中间结点中存在的用于处理管理、流控和错误检查的状态表。端点结点必须对丢失的帧进行检查，并请求重发。

    X．25受到了低性能的影响，它不能适应许多实时LAN对LAN应用的要求。然而，X．25很容易建立，很容易理解，并且已被远程终端或计算机访问，以及传输量较低的许多情况所接收。X．25可能是电话系统网络不可靠的国家建立可靠网络链路的唯一途径。许多国家使用X．25服务。与此不同，在一些国家获得可靠的专用线路并不是不可能的。

    在美国，大多数电讯公司和增值电信局（VAC）提供X．25服务，这些公司包括AT＆T、US Sprint、compuserve、Ameritech、Pacific Be1l和其它公司。还可以通过在用户所在地安装X．25交换设备，并用租用线路将这些地点连接起来，来建立专用的X．25分组交换网络。

    X．25是在开放式系统互联（OSI）协议模型之前提出的，所以一些用来解释x．25的专用术语是不同的。这种标准在三个层定义协议，它和OSI协议栈的底下三层是紧密相关的：

    物理层 它称为X．21接口，定义从计算机／终端（数据终端设备，DTE）到X．25分组交换网络中的附件结点的物理／电气接口。RS－232－C通常用于X．21接口。

    链路访问层 定义象帧序列那样的数据传输。使用的协议是平衡式链路访问规程（LAP－B），它是高级数据链路控制（HDLC）协议的一部分。LAP－B的设计是为了点对点连接。它为异步平衡模式会话提供帧结构、错误检查和流控机制。LAP－B为确信一个分组已经抵达网络的每个链路提供了一条途径。

    分组层 定义通过分组交换网络的可靠虚电路。这样，X．25就提供了点对点数据发送，而不是一点对多点发送。

    在X．25中，虚电路的概念是非常重要的。一条虚电路在穿越分组交换网络的两个地点之间建立一条临时性或永久性的“逻辑”通信信道。使用一条电路使用可以保证分组是按照顺序抵达的，这是因为它们都按照同一条路径进行传输。它为数据在网络上进行传输提供了可靠的方式。在X．25中有两种类型的虚电路：

    临时性虚电路 将建立基于呼叫的虚电路，然后在数据传输会话结束时拆除。

    永久虚电路 在两个端点结点之间保持一种固定连接。

    X．25使用呼叫建立分组，从而在两个端点站点之间建立一条通信信道。一旦这个呼叫建立了，在这两个站点之间数据分组就可以传输信息了。注意，由于X．25是一种面向连接的服务，因而分组不需要源地址和目的地址。虚电路为传输分组通过网络到达目的地提供了一条通信路径。然而，对分组授予了一个号码，这个号码可以被连接源地和目的地的信道鉴别。

    X．25网络易于安装和维护。它是根据发送的分组数据来收费的，在一些情况下，还会考虑连通的时间。牢记，其它一些服务更适合于高速局域网传输（例如帧中继）或专用连接。

    相关条目：Carrier Services电信电讯公司服务；Connection－Oriented and Connectionless Protocol面向连接和无连接协议；Networks网络；Packet－Switching Networks分组交换网络；Virtual Circuit虚电路；Wide Area Networks 广域网。


  • X．400消息处理系统 X．400 Message Handling System

    国际电报电话咨询委员会（CCITT）是国际远程通信联合会（ITU）的一个组成部分，CCITT定义了X．400MHS标准，它是一种在广域不同平台上运行的先存储再转发邮件系统之间交换消息的电子系统。在国际标准化组织（ISO）的术语中，X．400称为面向消息的文本互换系统（MOTIS）。这个标准的目的是，在多厂商产品、接口、以及公共和专用消息服务之间提供兼容性。

    电子函件和消息传递系统，是企业的计算策略中越来越重要的组成部分。这些系统的设计有助于用户之间保持相互联系和改进生产方式。另外，消息传递系统正在变成分布式环境进行程序开发的一种重要工具。一个消息可以携带一些来自用户的请求到达远程数据库。然后，这个远程数据库将响应包装成一个分组，再发送回这个用户。当然，这不是一种实时策略，但是在分布式环境，实时操作并不总是实际的。

    在网络、大型计算机系统和公用数据网上，已经存在许多不同的电子函件系统。例如，Internet消息传递标准是简单邮件运送协议（SMTP）。PROFS和SNAD在IBM大型计算机环境使用。VAXmail和All－In－1用于DEC环境。另外，在台式计算环境也可以获得无数的电子函件系统。一个单一机构可能会具有非常多的电子函件系统，它们是在以前各个部门和工作组维护他们自己的局域网络时实现的。随着这个企业进行了互联，通常使用电子函件网关系统来对不同系统之间的消息进行转换。现在，基于X．400的系统已经非常流行。

    X．400最初是在1984年宣布的，之后进行了不同的完善。它具有用于建立互操作的电子函件系统所需的协议、过程、部件、术语和测试方式。X．400基于包括下面介绍的部件的分布式客户机／服务器模型，如图X－2所示：

    用户代理（UA）UA是连接到X．400系统的每个用户计算机上运行的软件构件。它提供允许用户创建电子消息、阅读接收的电子消息或浏览消息表的功能。UA可以通过这个消息传递系统实现相互之间的通信，并且每个UA具有一个特有的名字。用户可以访问目录服务（例如本书介绍的X．500标准定义的服务）来查看这些特用的名字。

    消息传送代理（MTA）MTA接受来自UA的消息，并且将它们通过路由选择送到其它MTA。这个MTA必须对在消息中的地址信息进行转换，并且确定如何对这个消息进行路由选择。MTA包括一个X．500目录服务系统的代理。

    需要进行地址转换 这是因为在一个企业内部可能具有许多不同的网络类型。MTA对这个消息进行打包，并且用已经转换后的地址对它进行编址。然后，它将这个消息发送给接收方的MTA。

    消息存储（MS） MS是为由于用户的系统处于离线、或不可到达时，而不能直接将消息发送给这个用户的情况下，对这个消息存储的区域。

    访问单元（AU）AU为其它实体（例如传真电传用户等）提供对邮件系统的访问。

    目录系统（DS） 包含完整的关于其它X．400用户的名称和地址的列表。它通常跟随X．500标准。

    X．400消息结构对于所有系统是相同的。一个信头（envelope header）包括一个消息ID、源地址和目的地址、内容类型信息和加密信息。这些信息是MTA用于为消息选择路由的。在信头之后是内容头，它包括：To：、From：、cc：以及其它可以被接收方进行阅读的信息。在这个头之下是这个消息的体。

    在X．400中定义的其它服务包括分发列表、管理域和安全性功能：

    分发列表 是一个用户的组。对一个分发列表的邮件发送是自动地将邮件发送给这个列表中的所有用户。一个用户管理这个列表，并且只有指定的用户才可以对这个列表发送邮件。

    管理域 包括局域专用管理域（PRMD）和称为指导性管理域（ADMD）的公共X．400服务提供者。ADMD可以在全局范围将消息发送给远程地点。

    安全性 在X．400中指定的安全性功能包括，源地鉴别、对发送和接收的正确性的证据、对非授权用户的检查、对在传输期间对可能发生的消息修改的保护，以及其它功能。

    X．400 API协会（XAAPIA）是一个标准化组织，它实际地定义X．400消息传递系统的标准应用程序编程接口（API）。

    相关条目：CCITT；Electronic Mail 电子函件；Groupware群件；Message－Enabled Applications 消息－激活应用；Messaging API，E－mail电子函件的消息传递API；Workflow Software工作流软件；X．500 Directory Services X．500目录服务。


  • X．500目录服务 X．500 Directory Services

    X．500是一种CCITT（ITU）针对已经被国际标准化组织（SIO）接受的目录服务系统的建议。X．500定义一个机构如何在一个企业的全局范围内共享名字和与它们相关的对象。一个完整的X．500系统称为一个“目录”。X．500已经被接受作为提供世界范围的目录服务的一种国际标准。它与X．400电子函件标准密切相连。X．500是层次性的，其中的管理性域（机构、分支、部门和工作组）可以提供这些域内的用户和资源的信息。X．500被认为是实现一个目录服务的最好途径，但是它的实现需要很大投资，却没有其它方式的速度快。

    注释：NetWare目录服务（NDS）是X．500式实现的一个很好的例子，参见“目录服务，NetWare”，来获得这方面的更多的信息。

    X．500目录服务可以向需要访问网络任何地方资源的电子函件系统和应用，或需要知道在网络上的实体名字和地点的管理系统提供信息。这个目录是一个数据库，或在X．500描述中称为目录信息数据库（DIB）。在数据库中的实体称为对象。例如，有用户对象和资源对象，例如打印机对象。对象包括描述这个对象的信息。

    对象被组织成树形结构，这种结构模仿了一个机构的组织形式。例如，表示一个公司的部门或分支的对象从一个树的根处分支出来，如图X3所示。其中，有一些称为机构对象（organizational object）的类型，这时因为它们能够“包括”其它对象，例如机构单元对象（organizational unit objects），或公用名称对象（common name objects）。机构单元对象定义一个分支或部分的子分支，而一个公用名称对象是指表示物理实体，如人、打印机、服务器的端点结点。可以参见“目录服务命名，NetWare4．x”，那里进行了关于NetWare4．x环境下的对象类型和对象命名的完整讨论。

    这个目录的每个分支代表一个分支机构和部门，它们实际上是在不同的地理区域的。DIB的主备份是存放在其中的单一地点的。虽然远程用户可以访问这个DIB的主备份，但是这在广域网环境是很低效的。因此，在这个目录树中这个DIB被分解成分区，并且这些分区是存放在每个地点的服务器上的。只有相关的分区被复制到每个地点。当用户需要对象的信息时，首先查询本地的分区。如果在本地分区不能获得所需的信息，就通过广域网来查询这个主DIB。这种策略有助于降低长途费用，缩短访问时间，并且通过将DIB复制到其它地点间接地提供了一种备份效果。

    相关条目：CCITT；Directory Services 目录服务；Directory Services，NetWare NetWare目录服务；Distributed Database 分布式数据库；Domain Name Service域名字服务；Electronic Mail 电子函件；Partition Management分区管理；Replication复制，复置；X．400 Message Handling System X．400信报处理系统。


  • X／Open公司，X／Open国际联盟有限公司 X／Open

    X／Open国际联盟有限公司是一个欧洲基金会，它的建立是为了向UNIX环境提供标准。它主要的目标是促进对UNIX语言、接口、网络和应用的开放式系统协议。它还促进在不同的UNIX环境之间的应用程序的互操作性，以及支持对电气电子工程师协会（IEEE）对UNIX的可移植操作系统接口（POSIX）规范。

    相关条目：Common Open Soft Environment公用开放软件环境；Open Software Foundation开放软件基金会；OSF／1，Open Software Foundation OSF／1，开放软件基金会；POSIX；Transmission Control Protocol／Internet Protocol 传输控制协议／因特网协议；和UNIX。


 X2/DSL　调制解调器
：X2/DSL是一种3Com和US Robotics正在计划中的调制解调器，它支持56 Kbps 的速率，但同时当用户为它安装了升级软件后，它可以支持ADSL。3Com 称它为“您最后购买的调制解调器”。


  • Xerox网络系统 Xerox Network System

    XNS是由Xerox为以太网开发设计的一种对等层的网络通信标准。许多网络操作系统使用XNS，并且Novell NetWare的网间分组交换（IPX）也是因为它才流行起来的。


 XML 扩展标签语言
：eXtended Markup Language 的首字母缩略词。它是SGML 语言的一种压缩形式，它允许 Web 的开发者和设计者们创建自定义的标签，这样 XML 就比早期的 HTML 文档编码系统在组织和表现信息时具有更大的灵活性。


  • XMODEM协议 XMODEM Protocol

    XMODEM协议是一种使用拨号调制解调器的个人计算机通信中广泛使用的异步文件运输协议。这种协议以128字节块的形式传输数据，并且每个块都使用一个校验和过程来进行错误检测。如果接收方关于一个块的校验和与它在发送方的校验和相同时，接收方就向发送方发送一个认可字节。然而，这种对每个块都进行认可的策略将导致低性能，特别是具有很长传播延迟的卫星连接的情况时，问题更加严重。

    使用循环冗余校验的与XMODEM相应的一种协议称为XMODEM－CRC。还有一种是XMODEM－1K，它以1024字节一块来传输数据。ZMODEM是最有效的一个XMODEM版本，它不需要对每个块都进行认可。事实上，它只是简单地要求对损坏的块进行重发。ZMODEM对按块收费的分组交换网络是非常有用的。不需要认可回送分组在很大程度上减少了通信量。

    YMODEM也是一种XMODEM的实现。它包括XMODEM－1K的所有特征，另外在一次单一会话期间为发送一组文件，增加了批处理文件传输模式。

    相关条目：Asynchronous Communication异步通信；Communication 通信；Modems调制解调器。


 XON/XOFF　异步通信协议
：一种异步通信协议，接收设备或计算机使用特殊字符来控制发送设备或计算机传送的数据流。当接收计算机不能继续接收数据时，发送一个 XOFF 控制字符告诉发送方停止传送；当传输可以恢复时，该计算机发送一个 XON 字符来通知发送方。


 XQL XML查询语言
：XQL(XML Query Language)是一种定位XML文本中数据元素位置的方法。XML文件用于在用户计算机和网络之间传送数据，而XQL提供一种在一个或多个XML语言文件中查找特定对象的方法。这种语言可以内置于XML语言中，象JavaScript语言可以内置于HTML一样。


 XSLT XSL变换描述
：XSLT(XSL Transformations)是一种描述将XML的一种结构变换为XML的另一种结构的标准方法。XSLT是W3C提出的标准。XSLT说明如何将XML文档组织为另一种数据结构。XSLT用于描述如何变换XML文档的数据结构。


 XUL 扩展用户接口语言
：XUL(Extensible User-interface Language)是一种用于交换数据的标准，它主要用于描述用户接口。它具有独立于平台的特点，而且十分灵活，可以和XML等现在流行的语言相兼容。


 XUL　扩展用户接口语言
：XUL(Extensible User-interface Language)是一种用于交换数据的标准，它主要用于描述用户接口，具有独立于平台的特点，而且十分灵活，可以和XML等现在流行的语言相兼容。


  • Ymodem协议 Ymodem

    参见XMODEM Protocol XMODEM协议。


 Zip Drive Zip驱动器
：Iomega公司开发的一种磁盘驱动器，使用能存储100MB 数据的可移动磁盘（Zip 磁盘）。


  • ZIP 压缩文件格式

    一种程序压缩的档案文件格式，通常使用Winzip、PKZIP、ZipIT、gzip等压缩软件压缩文件而成。如果你听人说"zip文件"，就是指压缩后的一个打包文件。


 Zmodem　Zmodem协议
：它是Xmodem 文件传输协议的一种增强形式，不仅能传输更大的数据，而且错误率更小。包含一种名为检查点重启的特性，如果通信链接在数据传输过程中中断，能从断点处而不是从开始处恢复传输。


  • AppleTalk的区信息协议 Zone Information Protocol（ZIP），AppleTalk

    ZIP是一种AppleTalk的会话层协议，它维护和发现网络号码范围内的互联网络映射。AppleTalk名字联编（Binding）协议提供网间对本地转换服务，并使用ZIP来确定哪些网络包括了属于某域的结点。

    相关条目：Apple Computer Apple计算机公司；AppleTalk。


  • AppleTalk 的区信息表 Zone Information Table（ZIT），AppleTalk

    在AppleTalk网络上的ZIT表包括每个网络的信息。ZIT表是由AppleTalk互联网上的多个路由器进行维护的。

    相关条目：Apple Computer Apple计算机公司；AppleTalk。


  • AppleTalk的区广播地址 Zone Multicast Address，AppleTalk

    Apple Talk网络上的数据链路广播地址能够接收名字联编协议（Name Binding Protocal）的广播。

    相关条目：Apple Computer Apple计算机公司；AppleTalk。