XML 指南

XML基础
XML 主页
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 指南

写在前面的话

本文的英文版刊登在http://www.w3schools.com/xml/上，相信很多朋友都看过这个教材的英文版，小奀只是将之译成中文。对XML 编码一节，原文已经不适合中文读者，于是做了一些修改，对于初学者来说这是一个很不错的入门教程。由于XML技术发展的十分迅速，加上时间仓促，小奀的水平有限，书中一定有很多错误之处，在此恳请朋友们多多指教。

如果您有什么疑问，请给小奀发E-mail:ordm@163.com。

2003年2月1日

广 告 | 欢迎访问 蓝色理想|经典论坛 http://www.blueidea.com/


关于小奀

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

关于小奀

基本情况:

 | 姓 名 : 刘小奀(lytkd) 性 别 : 男 年 龄 : 25（马） 身 高 : 176cm 体 重 : 64kg 血 型 : B 星 座 : 巨蟹 学 历 : 本科 专 业 : 化工机械 | Tel:13070562773
补 丁: | 小奀,发音:xiao'en (奀音同恩) |

形象描述:

短发。小平头。近视眼。不上相。故照片和本人的观感有较大出入。
如果没被照片吓死或恶心死，建议看看本人。此段信息征女友用。

工作经历:

2001.07——至今 河北建设集团有限公司 设计员、助理工程师

能力自述:

有上进心及责任感，富于团队合作，有激情，有活力，品行端正；熟悉计算机的软硬件；有一定的web技术基础，熟悉HTML、CSS、JavaScript、VBScript、ASP、XML等语言,能够比较熟练的使用Dreamweaver、Fireworks、Flash等工具进行网页制作；对.NET有一些了解，能够用VC++.NET或C#.NET制作一些简单的小程序。

联系方式:

OICQ: | 21006659
E-mail: | lytkd@163.com
 | ordm@163.com


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

Beginning XML

The description below is the publishers own description.

Beginning XML

Title: Beginning XML

ISBN: 1861003412

Pub Date: June 2000

Pages: 800

Description

"Learn about Extensible Markup Language (XML) ?what it is, how it works and how to use it in your data exchange applications ?for the web, e-commerce and more! "z

This book explains and demonstrates XML and related technologies. This is the exciting new way of marking up and manipulating data within your applications. XML is platform independent and versatile, meaning that it is rapidly becoming a major technology. Anywhere that data is exchanged between applications or tiers is a potential application for XML. This book will teach you how to use it in your data exchange applications ?on the web, for e-commerce or in n-tier architectures ?by explaining XML theory, reinforced with plenty of practical examples and real life solutions.

Who is this book for

Beginning XML is for any developer who is interested in learning what XML is, what it can do, and how to use it in their web, e-commerce or data-storage applications. Some knowledge of mark up, scripting and/or object orientated programming languages and system architecture is advantageous, but not essential, as the basics of these techniques are explained as required.

What does the book cover

  • XML syntax and writing well formed XML
  • Using namespaces in XML
  • Adding style with CSS and XSL
  • Transforming XML into other formats with XSLT
  • XPath and XPointer for locating specific XML data
  • XLink for linking XML and non-XML resources
  • Manipulating XML documents programmatically with the DOM and SAX
  • XML validation using DTDs and Schema
  • Incorporating XML into traditional databases and n-tier architectures
  • Transmitting XML across a network with XML-RPC

Table of contents

Introduction
Chapter 1: What is XML?
Chapter 2: Well-Formed XML
Chapter 3: XML in the Browser: Cascading Style Sheets
Chapter 4: XSLT and XPath
Chapter 5: XSLT ?The Gory Details
Chapter 6: The Document Object Model (DOM)
Chapter 7: The Simple API for XML (SAX)
Chapter 8: Namespaces
Chapter 9: Basic Valid XML: DTDs
Chapter 10: Valid XML: Schemas
Chapter 11: Advanced Valid XML
Chapter 12: Linking XML
Chapter 13: XML and Databases
Chapter 14: Other Uses for XML
Case Study 1: Lydia's Lugnuts Web Store
Case Study 2: Discussion Group System
Case Study 3: XML for a Business-to-Business Application
Appendix A: The XML Document Object Model
Appendix B: SAX 1.0: The Simple API for XML
Appendix C: ASP Quick Start Tutorial
Appendix D: JavaScript Quick Start Tutorial
Appendix E: Support, Errata, and P2P.Wrox.Com
Appendix F: Useful Web Resources
Appendix G: XML Schema Datatypes

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

Designing Distributed Applications

The description below is the publishers own description.

Applications with XML

Title: Designing Distributed Applications with XML, ASP, IE5, LDAP and MSMQ

ISBN: 1861002270

Pub Date: April 1999

Pages: 458

Description

Designing Distributed Applications is all about creating Cooperative Network Applications. Their aim is to promote the re-use of intranet and Internet applications and maintain the viability of applications in the face of change.

Using Stephen's 5 Principles of Cooperative Network Application Development, you can create applications that can promote themselves on the network, sharing data and logic with clients of varying levels of sophistication. Using XML to define data exchange in such a way that future applications will also be able to negotiate an exchange format ?even in the face of minor programming errors or evolving data definitions. Using LDAP this can take place on a network where we query for the services without knowing their location. The result is a distributed computing environment that will remain robust while users and resources are in flux.

Summary of Contents

Chapter 1: Learning The 5 Principles of Cooperative Network Application Development
Chapter 2: Directories
Chapter 3: Structured Data Exchange
Chapter 4: Reconciling Data
Chapter 5: Metadata
Chapter 6: Platform Services, Combining the Old and the New
Chapter 7: How Do We Communicate
Chapter 8: Customer Service Case Study
Chapter 9: Customer Tracking Case Study
Chapter 10: Order Analysis Case Study
Appendix A: Toolkit Reference
Appendix B: Resources and References
Appendix C: IE5 XML Document Object Model
Appendix D: XML Schemas and Datatypes
Appendix E: XMLHTTP
Appendix F: Deployment Opens For Scriptlets
Appendix G: Support and Errata

View Sample Chapter

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

Essential XML Quick Reference

A Programmer's Reference to XML, XPath, XSLT, XML Schema, SOAP, and More

The description below is the publishers own description.

Essential XML

Title: Essential XML: A Programmer's Reference to XML, XPath, XSLT, XML Schema, SOAP, and More

ISBN: 0-201-74095-8

Pub Date: October 2001

Pages: 403

Description

A complete quick-reference to XML and its most important related technologies.

  • XML, SOAP, XML Schema, XPath, and XSLT -- all in one example-rich quick-reference.
  • Triple the coverage of its nearest competitor -- including up-to-the-minute information on BizTalk, schemas, and namespaces.
  • By two respected leaders in the XML community, DevelopMentor's Aaron Skonnard and Martin Gudgin.

XML and the technologies surrounding it have grown immensely in recent years -- in both use and complexity. There's more to know than any one individual can possibly remember. In Essential XML Quick Reference, two leading XML experts present an authoritative reference that covers all the XML-related technologies that matter. In one concise, accessible, example-rich guide, Aaron Skonnard and Martin Gudgin bring together critical information about XML, XSL, XSLT, schemas, namespaces, XPath, SAX, DOM, SOAP, even Microsoft's BizTalk. Following the hugely successful format pioneered by Patrick Chan's Java Almanacs, the authors provide a complete catalog of syntax references, combined with brief, to-the-point overviews of each technology and standard. This ultimate XML reference contains three times the coverage of its nearest competitor. For all developers and Web professionals familiar with the basics of XML.

Table of Contents

List of Acronyms.

Preface. Acknowledgments.

Chapters:

  1. XML 1.0 and Namespaces
  2. Document Type Definitions
  3. XPath 1.0
  4. XPointer, XInclude, and XML Base
  5. XSL Transformations 1.0
  6. SAX 2.0
  7. DOM Level 2
  8. XML Schema Datatypes
  9. XML Schema Structures
  10. SOAP 1.1

Index

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

Professional XML

The description below is the publishers own description.

Professional XML Title: Professional XML

ISBN: 1861003110

Pub Date: January 00

Pages: 1169

Subject Area

The Extensible Markup Language (XML) has emerged in just a few short years as nothing less than a phenomenon in computing. It is a concept elegant in its simplicity driving dramatic changes in the way Internet applications are written.

Book Overview

Professional XML is a broad compendium that investigates and describes how the total XML concept will work for programmers. It's the next edition of the popular XML Applications (Wrox 1998).

This book explains and demonstrates the essential techniques for designing, using, and displaying XML documents. First and foremost, this book covers the fundamentals of XML as they are codified by the W3C.

The focus of Professional XML is on real-world applications that use XML as an enabling technology. It presents good design techniques, and shows how to interface XML-enabled applications with Web applications and database systems. It explores the frontiers of XML and previews some nascent technologies. Whether your requirements are oriented toward data exchange or visual styling, this book will cover all the relevant techniques in the XML community.

Each chapter contains a practical example. As XML is a platform-neutral technology, the examples cover a variety of languages, parsers, and servers. All the techniques are relevant across all the platforms, so you can get valuable insight from the examples even if they are not implemented using your favorite platform.

Who Is This Book For?

Professional XML is for anyone who wants to use XML to build applications and systems. Web site developers can learn techniques to take their sites to the next level of sophistication. Managers, designers, and software architects can learn where XML fits into their systems and how to use it to solve problems in application integration.

Summary of contents:

Chapter 1: Introducing XML
Chapter 2: XML Syntax
Chapter 3: Document Type Definitions
Chapter 4: Data Modeling and XML
Chapter 5: The Document Object Model
Chapter 6: SAX 1.0: The Simple API for XML
Chapter 7: Namespaces and Schemas
Chapter 8: Linking and Querying
Chapter 9: Transforming XML
Chapter 10: XML and Databases
Chapter 11: Server to Server
Chapter 12: eBusiness and XML
Chapter 13: Styling XML
Chapter 14: Wireless Application Protocol
Chapter 15: Case Study 1 ?Data Duality
Chapter 16: Case Study 2 ?XML and Distributed Applications
Chapter 17: Case Study 3 ?Book Catalog Information Service
Chapter 18: Case Study 4 ?SOAP
Appendix A: Extensible Markup Language (XML) 1.0 Specification
Appendix B: IE5 XML Document Object Model
Appendix C: SAX 1.0: The Simple API for XML
Appendix D: XML Schemas and Data Types
Appendix E: IE5 XSL Reference
Appendix F: CSS Properties
Appendix G: Installing XT
Appendix H: Support and Errata
Index

View Sample Chapter

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

Professional XML Design and Implementation

The description below is the publishers own description.

Professional XML Design

Title: Professional XML Design and Implementation

ISBN: 1861002289

Pub Date: March 1999

Pages: 426

Description

XML is a mark up language which allows you to define your own tags, and to define data rather than format it. The overall concepts of XML are quite well understood but there is little information available about issues of developing applications using XML. By considering the decisions to be made at various stages of a project, via the Centaur case study, this book will help readers understand the various aspects of XML and its related technologies. It stresses the benefits of XML in informational systems, where it can be used to separate content from presentation, and in transactional systems, where it can act as a low-cost alternative to EDI protocols.

A relentlessly practical, and therefore unique, XML publication, Professional Design and Implementation is for all web developers who are familiar with ASP and HTML and who now want to use XML to develop web applications.

Summary of Contents

Introduction
Chapter 1: Introducing the Centaur Case Study
Chapter 2: XML Overview
Chapter 3: The Document Object Model
Chapter 4: Displaying XML
Chapter 5: XSL in Theory and Practice
Chapter 6: Further XML Techniques
Chapter 7: Under the Hood of Centaur
Chapter 8: The Interactive System
Chapter 9: The Transactional System
Appendix A: Build Your Own Centaur
Appendix B: Selective Code Listings
Appendix C: Extensible Markup Language (XML) 1.0 Specification
Appendix D: XML Schemas and Data Types
Appendix E: XML Resources and References
Appendix F: IE5 XSL Reference
Appendix G: XSL Stylesheets DTD
Appendix H: Links in XML
Appendix I: Support and Errata

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML by Example

The description below is the publishers own description.

XML by example

Title: XML by Example

ISBN: 0789722429

Pub Date: December 1999

Pages: 528

Description

XML by Example teaches Web developers to make the most of XML with short, self-contained examples every step of the way. The book presumes knowledge of HTML, the Web, Web scripting, and covers such topics as: Document Type Definitions, Namespaces, Parser Debugging, XSL (Extensible Stylesheet Language), and DOM and SAX APIs. At the end, developers will review the concepts taught in the book by building a full, real-world e-commerce application.

  • Focuses on teaching XML, not its surrounding technologies
  • Allows you to "see" things happen as you are taught, providing instant rewards and better understanding
  • The book concludes with a large real-world example of XML in e-commerce- the most popular application of XML

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML for the World Wide Web

The description below is the publishers own description.

xmlforwww

Title: XML for the World Wide Web

ISBN: 0-201-71098-6

Pub Date: October 2000

Pages: 272

Description

Web-maven Elizabeth Castro, who has penned Peachpit books on HTML, Perl and CGI, and Netscape, now tackles XML--an indispensable tool for creating personalized, updated content for each visitor on your site.

Whether you build Web pages for a living or you're taking on a new hobby, XML for the World Wide Web contains everything you need to create dynamic Web sites by writing XML code, developing custom XML applications with DTDs and schemas, transforming XML into personalized Web content through XSLT-based transformations, and professionally formatting XML documents with Cascading Style Sheets.

The real power of XML lies in combining information from various sources and generating personalized content for different visitors. Castro's easy-to-follow graphics show exactly what XML looks like, and her real-world examples explain how to transform and streamline your Web-site creation process by automatically updating content.

Table of Contents

Part 1: XML
Chapter 1: Writing XML

Part 2: DTDs
Chapter 2: Creating a DTD
Chapter 3: Defining Elements and Attributes in a DTD
Chapter 4: Entities and Notations in DTDs

Part 3: XML Schema and Namespaces
Chapter 5: XML Schema
Chapter 6: Defining Simple Types
Chapter 7: Defining Complex Types
Chapter 8: Using Namespaces in XML
Chapter 9: Namespaces, Schemas, and Validation

Part 4: XSLT and XPath
Chapter 10: XSLT
Chapter 11: XPath: Patterns and Expressions
Chapter 12: Test Expressions and Functions
Chapter 13: Setting up CSS
Chapter 14: Layout with CSS
Chapter 15: Formatting Text with CSS
Chapter 16: Links and Images: XLink and XPointer

Appendix A: XHTML
Appendix B: XML Tools
Appendix C: Special Symbols
Appendix D: Colors in Hex

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML Web Documents from Scratch

The description below is the publishers own description.

XML from Scratch

Title: XML Web Documents from Scratch

ISBN: 0789723166

Pub Date: March 2000

Pages: 288

Description

Jesse Liberty's XML Web Documents from Scratch is a road map to managing and publishing documents using XML and XSL. Concepts and techniques are taught and reinforced as readers create "BiblioTech," a Web-based book reader that displays the text of a book, provides a collapsible outline, and text search capabilities.

  • Design a complete Web-based document storage and retrieval program using XML
  • Written by best-selling author Jesse Liberty
  • Learn XML and XSL in the context of designing a Web-based book reader, BiblioTech

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

Teach Yourself XML in 21 Days

The description below is the publishers own description.

XML in 21 days

Title: Sams Teach Yourself XML in 21 Days

ISBN: 1575213966

Pub Date: April 1999

Pages: 600

Description

Sams Teach Yourself XML is an easy-to-use tutorial that breaks down the task of learning XML into 21 focused lessons. Readers learn through clear explanations of concepts, structured step-by-step tasks, and abundant code samples. This book covers all aspects of using XML to publish a wide range of content on the Web.

  • This easy-to-use tutorial teaches you everything you need to know to create XML documents and applications
  • Hands-on practical approach and well-documented code examples ensure that readers understand and learn XML scripting techniques
  • This book is an excellent companion to Teach Yourself HTML 4 in 21 Days.

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML IE5 Programmer's Reference

The description below is the publishers own description.

XML in IE5 Title: XML IE5 Programmer's Reference

ISBN: 1861001576

Pub Date: March 1999

Pages: 479

Subject Area

XML is creeping into the vocabulary and the arsenal of every web page author and web application programmer. Even if you haven't actually noticed it yet, XML is there and growing in influence. Some corporations have already chosen to build web-based applications that transfer data between client and server in XML format rather than as HTML within a page, or in the form of traditional recordsets through Remote Data Services.

Microsoft has undertaken to provide full support for XML and other associated standards in the latest version of Internet Explorer. These standards are set by the World Wide Web Consortium (W3C), and cover a whole range of different technologies.

Who is this Book For?

This book is for web developers who want to know more about what XML is, what its potential applications are, and what support is available for XML and its associated technologies right now in Microsoft Internet Explorer 5.

What does this Book Cover?

  • Provides a starting point for newcomers to XML
  • Covers Document Type Definitions and XML Schemas
  • Teaches all aspects of the XML Document Object Model
  • Explores tranformations using CSS and XSL stylesheets
  • Acts as a concise guide and reference to XML
  • Examines the XML-specific features of the IE5 browser
  • Looks at evolving XML standards and technologies
  • The fastest track to working with XML and XSL in IE5

Summary of Contents:

Chapter 1: What is XML?
Chapter 2: Creating XML Documents
Chapter 3: XML Schemas, Links and Pointers
Chapter 4: Using XML in HTML Documents
Chapter 5: The XML Document Object Model
Chapter 6: Using the Document Object Model
Chapter 7: Using CSS and XSL with XML
Chapter 8: IE5 Default and Custom Behaviors
Appendix A: IE5 XML Document Object Model
Appendix B: ADO Recordsets Reference
Appendix C: XML Schemas and Data Types
Appendix D: CSS Properties
Appendix E: IE5 XSL Reference
Appendix F: XML Behaviors Reference
Appendix G: Support and Errata

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML Step by Step

The description below is the publishers own description.

XML Step by Step

Title: XML Step by Step

ISBN: 0-7356-1020-7

Pub Date: July 2000

Pages: 400

Description

XML (Extensible Markup Language) is currently the most promising language for storing and delivering highly structured information on the Web. XML抯 structured syntax lets you describe virtually any type of information梖rom a simple recipe to a complex business database梐nd sort, filter, find, and manipulate that information in flexible ways. XML STEP BY STEP clearly explains the basics of XML and shows both nonprogrammers and Web developers how to create effective XML documents and display them on the Web. The book takes a hands-on learning approach and focuses on the most practical techniques that you can use now, even if you don抰 have extensive technical knowledge. A CD-ROM that comes with the book includes XML examples for all hands-on exercises, plus extensive links to further information and resources.

What you will Learn

  • What XML is, why it's needed, and how it's being used to solve real-world problems
  • The rules and techniques for creating well-formed and valid XML documents, based on the official specification of the W3C (World Wide Web Consortium)
  • How to display XML documents directly in Web browsers by using cascading style sheets (CSS) or Extensible Stylesheet Language (XSL)
  • How to display XML documents through conventional HTML (Hypertext Markup Language) pages using data binding, the XML Document Object Model (DOM), and the Microsoft瓸 Jscript瓸 scripting language
  • How to use XML with Microsoft Internet Explorer 5.5, Microsoft Windows瓸 98, and Microsoft Windows 2000

Table of Contents

Introduction
Chapter 1: Why XML?
Chapter 2: Creating and Displaying your first XML Document
Chapter 3: Creating Well-Formed XML Documents
Chapter 4: Adding Comments, Processing Instructions, and CDATA Sections
Chapter 5: Creating Valid XML Documents
Chapter 6: Defining and using Entities
Chapter 7: Displaying XML Documents using CSS
Chapter 8: Displaying XML Documents using Data Binding
Chapter 9: Displaying XML Documents using DOM Scripts
Chapter 10: Displaying XML using XSL
Appendix: Web Addresses for Further Information

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Books

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML Unleashed

The description below is the publishers own description.

XML Unleashed

Title: XML Unleashed

ISBN: 0672315149

Pub Date: December 1999

Pages: 992

Description

XML Unleashed is a complete and comprehensive reference for sophisticated Web developers that covers every possible use of XML, from creating Web documents to building sophisticated Web applications. It covers all aspects of XML technology, from DTDs, XSL, and X Pointers to manipulating XML with Java and JavaScript. See hundreds of professional programming techniques as well as code for more than 15 real-world XML applications involving e-commerce, database access, Web management, real estate, and healthcare. This book also includes reference material on SMIL, the XML-based language for Web multimedia.

  • The most comprehensive, detailed XML reference available
  • Written exclusively for the professional advanced-level web developer
  • Michael Morrison is a widely recognized author in this market

Buy this book at Amazon USA

Buy this book at Amazon UK


XML Tutorial

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 指南

XML 指南

在我们这个XML指南里你将学到什么是XML，XML和HTML有什么不同。你将学习如何在你的应用软件中使用XML。下面就开始学习XML吧。

XML 实例

通过例子来学习! 通过我们的编辑器，你可以编辑XML，点击测试按钮去查看结果。自己去试试吧。

XML 测验

在W3Schools里测试你的XML技能! 开始XML测验!

目录表格

XML 基础

XML初步介绍
什么是XML, XML和HTML有什么不同?

XML有什么用途
XML经常在许多不同的行业中用到。

XML语法
XML的语法规则非常简单并且十分严格。

XML元素
XML元素, 关联，内容和命名规则。

XML属性
How XML属性可以用来描述元素，提供元素的补充说明。

XML确认
一个好的正确的XML文档以及如何用DTD来定义XML文档。

XML的浏览器
目前两个最著名的浏览器都支持XML。

用微软的IE来查看XML
怎样用微软的IE去观看XML文件。

使用CSS来显示XML
怎样用微软的IE和CSS来显示XML文件。

使用XSL来显示XML
怎样用微软的IE和XSL来显示XML文件。

在HTML中植入XML
怎样在HTML文档中植入XML。

微软的XML解析器
怎样使用微软的XML解析器去打开和操作XML文档。

XML在现实生活中的应用
我们将看一下在现实生活中XML的应用。

XML 高级部分

XML命名空间
怎样使用XML命名空间来避免元素命名冲突。

XML CDATA
怎样让XML解析器知道某些文字不进行解析呢。使用CDATA。

XML编码
怎样把你的XML文档编码。

XML服务器
怎样在服务器上产生XML。

XML应用
怎样使用IE 5来操纵XML文件以及怎样产生一个完善的XML应用。

XML HTTP 请求
怎样利用HTTP从服务器发送请求。

HTML and XML的行为
怎样使用最新的CSS行为选择器来产生动态目录。

XML技术
XML技术重要的是理解和发展XML应用。

XML实例

XML 例子
大量的XML例子!!

XML资源

XML书籍
寻找一本有价值的XML书?阅读我们的评论吧!
XML 规范
很有用的一些网站，Enjoy it !


XML Tutorial

XML基础
XML 简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML规范

next

++主题：〖 XML规范和学习资源小结 〗

→XML的规范

XML 1.0规范
http://www.w3.org/TR/1998/REC-xml-19980210

CSS1规范
http://www.w3.org/TR/REC-CSS1

CSS2规范
http://www.w3.org/TR/1998/REC-CSS2-19980512/

XML Namespace规范
http://www.w3.org/TR/1999/REC-xml-names-19990114/

XSL规范
http://www.w3.org/TR/1999/WD-xsl-19990421/

XLink规范
http://www.w3.org/TR/xlink

XPointer规范
http://www.w3.org/TR/1998/WD-xptr-19980303

DOM 1.0规范
http://www.w3.org/TR/1998/REC-DOM-Level-1-19981001/

XML Schema规范
http://www.w3.org/TR/1998/NOTE-SOX-19980930

XML-QL规范
http://www.w3.org/TR/1998/NOTE-xml-ql-19980819/

矢量标记语言VML
http://www.w3.org/TR/1998/NOTE-VML-19980513

数学标记语言
http://www.w3.org/TR/1999/07/REC-MathML-19990707/

XHTML 1.0规范
http://www.w3.org/TR/Markup/

SVG规范
http://www.w3.org/Graphics/SVG/

------------------------------------------

→XML网站

W3C的XML
http://www.w3.org/XML

IBM的XML
http://www.software.ibm.com/XML/

Microsoft的XML
http://msdn.microsoft.com/xml/

Oracle的XML
http://www.oracle.com/xml

Textuality的
http://www.textuality.com/xml/

XMLINFO
http://www.xmlinfo.com/

xml-dev邮件列表
http://www.lists.ic.ac.uk/hypermail/xml-dev/

XML.com
http://www.xml.com/

Microstar的XML工具和资源
http://www.microstar.com/XML/index.html

Arbortext的XMLStyler
http://www.arbortext.com/xmlstyler

Netscape的XML
http://www.mozilla.org/rdf/doc/xml.html

XML One Conference
http://www.xmlconference.com/

DataChannel的XMl资源
http://www.datachannel.com/xml_resources/

Schema.net
http://www.schema.net/

XML交换
http://www.xmlx.com/

Visual XML
http://www.pieriou.com/visxml

XML.org
http://www.xml.org/

-----------------------------------
http://xml.apache.org/
是Apache XML Project的官方站点.

http://xml.apache.org/cocoon
http://xml.apache.org/cocoon2
是Cocoon和XSP技术的大本营.推荐!

http://xml.apache.org/fop/
介绍Apache FOP.

http://www.w3schools.com/
许多教程,XML,XSL,WML,DTD,Schema,CSS,Javascript等等.

http://zvon.org/
XML技术教程和技术参考,非常全面.

http://www.xml.com/
适合具有一定XML技术基础的读者.

http://www.xml.com.cn/
中国XML论坛,内容,技术,可读性一流.

http://www.xml.org.cn/
中国XML联盟.

-----------------------------
软件下载

Cocoon可以到http://xml.apache.org/站点去下载.
Tomcat可以到http://jakaarta.apache.org/站点去下载.
J2SE SDK可以到http://java.sun.com/站点去下载.
XMLSpy4.0可以到http://www.smlspy.com站点去下载.
Nokia WAP Toolkit可以到http://www.nokia.com站点去下载.

发表人:lytkd 2002-04-11 发表于 经典论坛

next


W3Schools Internal Note

To:
From:


Try It Yourself

[Ctrl+A 全部选择 提示：你可先修改部分代码，再按运行]


Try It Yourself

You can edit the text above, and click on the "Display result" button to see the result in the window to the right.


把你的鼠标放到这里:P


Title:
Artist:
Year:
Country:
Company:
Price:

用鼠标点击下面的 CD目录列表项试试 :

Title | Artist | Country | Company | Price | Year


Artist | Title
This is my CD collection


Title:
Artist:
Year:


Title | Artist | Year


Using the HttpRequest Object

status:

status text:

response:


Sending a query to the server and receiving the answer as XML:

Query:

Answer from server is:

XML from server is:


HTML using XML data

W3Schools.com Internal Note

To:
From:


XML Applications

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 应用程序

这一节示范了一个小型的XML应用程序框架。

从XML文档开始

首先我们建立一个简单的XML文档。

来看一下我们原始的XML文档，描述了CD目录。

<?xml version="1.0" encoding="ISO-8859-1"?>
<CATALOG>
<CD>
<TITLE>Empire Burlesque</TITLE>
<ARTIST>Bob Dylan</ARTIST>
<COUNTRY>USA</COUNTRY>
<COMPANY>Columbia</COMPANY>
<PRICE>10.90</PRICE>
<YEAR>1985</YEAR>
</CD>
.
.
... more ...
.

如果你使用IE5.0或者更高版本r, 浏览完整的XML文档。

将XML文档载入数据岛

数据岛可以访问XML文件。

通过数据岛，可以把XML文档引入到HTML页面中。

<xml src="cd_catalog.xml" id="xmldso" async="false">
</xml>

使用上面示例代码，可以把cd_catalog.xml文件载入一个叫"xmldso"的数据岛中。属性async="false"的作用是在HTML处理器开始处理XML数据以前，必须确保XML文档中的所有数据都被载入到内存中。

把XML数据绑定到HTML的表格元素中

HTML中的table元素可以用来显示XML数据。

为了使你的XML数据能在HTML页面中显示出来，必须把的数据岛绑定到一个HTML元素上。

把XML数据绑定到table元素，需要在table属性添加一个资源属性，并且在span元素中添加字段属性:

<table datasrc="#xmldso" width="100%" border="1">
<thead>
<th>Title</th>
<th>Artist</th>
<th>Year</th>
</thead>
<tr align="left">
<td><span datafld="TITLE"></span></td>
<td><span datafld="ARTIST"></span></td>
<td><span datafld="YEAR"></span></td>
</tr>
</table>

如果你使用的是IE5.0或者更高版本: 观看数据岛绑定的实例

把数据岛绑定到<span> 或者<div> 元素上

<span>或<div>元素都可以用来显示XML数据。

没有必要使用table元素来显示XML数据，数据可以通过数据岛绑定到任何一个HTML元素上。

所要做的就是在你得页面中添加一些<span> 或者<div>元素，使用数据资源属性把每一个元素和XML文档元素绑定起来，就象下面这样:

<br />Title:
<span datasrc="#xmldso" datafld="TITLE"></span>
<br />Artist:
<span datasrc="#xmldso" datafld="ARTIST"></span>
<br />Year:
<span datasrc="#xmldso" datafld="YEAR"></span>

或者象这样的形式:

<br />Title:
<div datasrc="#xmldso" datafld="TITLE"></div>
<br />Artist:
<div datasrc="#xmldso" datafld="ARTIST"></div>
<br />Year:
<div datasrc="#xmldso" datafld="YEAR"></div>

如果你使用IE5.0或者更高版本: 观看数据绑定到HTML元素上的实例。

注意如果你使用<div>元素,数据将会显示在新的一行里。

上面的例子，可以看到XML数据都显示在一行里。如果要控制数据换行，就必须在你的代码里添加一些脚本程序。

为你的XML数据添加导航脚本

可以通过脚本程序来实现导航功能。

添加数据岛方法，使用脚本函数movenext() 和 moveprevious() 来实现导航功能。

<script type="text/javascript">
function movenext()
{
x=xmldso.recordset
if (x.absoluteposition < x.recordcount)
{
x.movenext()
}
}
function moveprevious()
{
x=xmldso.recordset
if (x.absoluteposition > 1)
{
x.moveprevious()
}
}
</script>

如果你使用IE5.0或者更高版本:观看具有导航功能的XML数据绑定实例。

小结

如果你有创造力的话就可以编写出非常完善的应用程序。

如果你使用在这一页中学到的知识，在发挥一下想象力，就可以轻易的创造出完善的应用程序。

如果你使用IE5.0或者更高版本:观看一个做了一些修改的数据绑定实例。


XML Attributes

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 属性

跟HTML一样，XML元素再开始标记处可以由元素属性。

属性通常包含一些关于元素的额外信息。

XML属性

XML元素可以拥有属性。

你一定还记得这样的HTML代码吧: <IMG SRC="computer.gif">。src是img元素的属性，提供了关于img元素的额外信息。

在HTML中 (在XML中也一样)元素的属性提供了元素的额外信息。

<img src="computer.gif">
<a href="demo.asp">

书信提供的信息通常不是数据的一部分。在下面的例子中，类型和数据毫不相关，但对于操作这个元素的软件来说却相当重要。

<file type="gif">computer.gif</file>

引用风格"female" 还是 'female'?

属性值必须用引号引着。单引号、双引号都可以使用。例如一个人的性别，person元素可以这样写：

<person sex="female">

也可以这样写:

<person sex='female'>

上面的两种写法在一般情况下是没有区别的，使用双引号的应用更普遍一些。但是在某些特殊的情况下就必须使用单引号，比如下面的例子：

<gangster name='George "Shotgun" Ziegler'>

使用子元素还是使用属性

数据既可以存储在子元素中也可以存储在属性中。

请看下面的例子:

<person sex="female">
<firstname>Anna</firstname>
<lastname>Smith</lastname>
</person>

<person>
<sex>female</sex>
<firstname>Anna</firstname>
<lastname>Smith</lastname>
</person>

在第一个例子中，sex是一个属性，在第二个例子中，sex则是一个子元素。这两个例子都提供了相同的信息。

什么时候用属性，什么时候用子元素没有一个现成的规则可以遵循。我的经验是属性在HTML中可能相当便利，但在XML中，你最好避免使用。

我喜欢的风格

我更愿意把数据存储到子元素中。

下面的三个XML文档包含了相同的信息：

第一个例子使用了data属性：

<note date="12/11/99">
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

第二个例子使用了data元素:

<note>
<date>12/11/99</date>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

第三个例子使用了扩展的data元素: (这就是我推荐的样式):

<note>
<date>
<day>12</day>
<month>11</month>
<year>99</year>
</date>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

避免使用属性？

应该避免使用属性么？

这里有一些使用属性引发的问题：

  • 属性不能包含多个值（子元素可以）。
  • 属性不容易扩展。
  • 属性不能够描述结构（子元素可以）。
  • 属性很难被程序代码处理。
  • 属性值很难通过DTD进行测试。

如果使用属性来存储数据，那么所编写的XML文档一定很难阅读和操作。尽量使用元素来描述数据，仅使用属性来描述那些与数据关系不大的额外信息。

不要象下面的例子那样（如果你那么做了说明你还没有明白上面的观点）。

<note day="12" month="11" year="99"
to="Tove" from="Jani" heading="Reminder"
body="Don't forget me this weekend!">
</note>

属性规则的例外

规则总是有例外的。

我的关于属性的规则也有一个例外：

有些时候应该为一个元素设计一个ID引用，通过这个ID可以引用存取特定的XML元素，就象HTML中的name和id属性一样。请看下面的例子：

<messages>
<note ID="501">
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>
<note ID="502">
<to>Jani</to>
<from>Tove</from>
<heading>Re: Reminder</heading>
<body>I will not!</body>
</note>
</messages>

在上面的例子中，ID属性就相当于一个计数器，或者是一个唯一的标识符，在XML文档中标识不同的便条信息，他不是便条信息的一部分。

我们所要尽力向读者说明的是：元数据（与数据有关的数据）应该以属性的方式存储，而数据本身应该以元素的形式存储。


XML Behaviors

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 行为（behavior） - 新的DHTML?

行为（behavior）是一个CSS属性选择器。他指向一个包含了特殊代码并且能够改变HTML页面元素的XML文件（htc）。

行为（Behavior）并不是W3C标准，他只是Microsoft的技术。

行为——什么是行为？

行为是一个新的CSS属性

行为属性可以指向一个分离的XML文件，这个XML文件包含了能够改变XML或者HTML页面的元素或显示样式的脚本代码。

你明白了么？这是一种可以把脚本程序完全从HTML页面中分离出来的方法。这真是太好了，现在我们可以写一些脚本库，并且可以和任何一个我们想的元素联系起来。

行为如何工作？

看下面这个HTML文件。在<style>元素中定义了<h1>元素的行为:

<html>
<head>
<style>
h1 { behavior: url(behave.htc) }
</style>
</head>
<body>
<h1>Move your Mouse over me</h1>
</body>
</html>

去看看这个例子, 并且把鼠标放到文字上面看看。

行为代码存储在一个XML文档（behave.htc）中，如下所示:

<component>
<attach for="element" event="onmouseover"
handler="hig_lite" />
<attach for="element" event="onmouseout"
handler="low_lite" />
<script type="text/javascript">
function hig_lite()
{
element.style.color=255
}
function low_lite()
{
element.style.color=0
}
</script>
</component>

这个行为文件包含JavaScript脚本。 这个脚本由<component>元素组成，组成的元素也包含了脚本事件操作者，很漂亮的，不是么？


XML Books

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 书籍

这里列出了一些我们认为值得去看的XML数据。这些书的质量都是很好的。

我们已经看过这些书或者他们的早期版本。

//这些书评，我没有翻译，都是些很不错的书，可惜国内很难见到。

书名 | 描述
Essential XML | Essential Quick Reference October 2001 A Programmer's Reference to XML, XPath, XSLT, XML Schema, SOAP and More. If you are building XML-aware applications, attach this book to your utility belt.
xml for the www | XML for the World Wide Web October 2000 Everything you need to create dynamic Web sites by writing XML code.
XML Step by Step | XML Step by Step July 2000 Clearly explains the basics of XML and shows both nonprogrammers and Web developers how to create effective XML documents and display them on the Web.
Begin XML | Beginning XML June 2000 For anyone who is interested in learning what XML is, what it can do, and how to use it. Some knowledge of mark up and scripting is advantageous, but not essential, as the basics of these techniques are explained.
XML in 21 days | Teach Yourself XML in 21 days April 1999 An easy-to-use tutorial that breaks down the task of learning XML into 21 focused lessons. Readers learn through clear explanations of concepts, structured step-by-step tasks, and abundant code samples.
XML by example | XML by Example December 1999 Teaches Web developers to make the most of XML with short, self-contained examples every step of the way.
XML from scratch | XML Web Documents from Scratch March 2000 A road map to managing and publishing documents using XML and XSL.
XML unleashed | XML Unleashed December 1999 A complete and comprehensive reference for sophisticated Web developers that covers every possible use of XML, from creating Web documents to building sophisticated Web applications.
XML Prof | Professional XML January 2000 Describes how the total XML concept will work for programmers. The focus is on real-world applications. Professional XML is for anyone who wants to use XML to build applications and systems.
XML IE5 | XML IE5, Programmers Reference March 1999 For web developers who want to know more about what XML is, what its potential applications are, and what support is available for XML and its associated technologies right now in Microsoft Internet Explorer 5.
XML design | Professional XML Design and Implementation March 1999 For all web developers who are familiar with ASP and HTML and who now want to use XML to develop web applications.
Designing Distributed Applications | Designing Distributed Applications with XML, ASP and IE5 April 1999 All about creating Cooperative Network Applications. The aim is to promote the re-use of intranet and Internet applications and maintain the viability of applications in the face of change.


XML in Netscape and Internet Explorer

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 浏览器（Netscape、Explorer）

在我们这个XML指南里，我们把焦点放在Internet Explorer 5.0及其以后的版本上。

Web站点上的XML

许多应用程序都支持XML。我们主要研究Internet Explorer 5.X+

对此有些人可能会抱怨，但是我们只想把事情简单化，在网络环境中这时我们所知道的唯一一个真实测试XML例子的方法。

XML Netscape 6

Netscape 6 支持 XML。

在Netscape 6中察看XML源文件可以在页面上点鼠标右键，然后选择“察看源文件”。

XML Internet Explorer 5.0

IE 5.0 支持 XML 1.0 标准。

Internet Explorer 5.0 支持XML1.0标准和XML DOM(Document Object Model)的国际标准。这些标准都是W3C发布的（World Wide Web Consortium）。

Internet Explorer 5.0 支持下列 XML 特性：

  • 察看XML文档
  • 对W3C DTD标准的完全支持
  • 在HTML页面中以数据岛形式嵌入XML
  • 把XML数据绑定到HTML元素上
  • 使用XSL程序转换和显示XML文档
  • 使用CSS显示XML文档
  • 支持 XML DOM

Internet Explorer 5.0 也支持XML行为（XML Behaviors）:

  • 行为是Microsoft独有的技术
  • 行为可以从HTML页面中分离程序脚本
  • 行为可以见数据存储到客户端的硬盘上

在下一章中讲给出一些相关的例子。

如果你想了解更多关于nternet Explorer的信息你可以到W3Schools' Browser Information浏览最新的信息。


XML CDATA

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML CDATA

back next

在XML文档中的所有文本都会被解析器解析。

只有在CDATA部件之内的文本会被解析器忽略。

解析数据

XML 解析器通常情况下会处理XML文档中的所有文本。

当XML元素被解析的时候，XML元素内部的文本也会被解析:

<message>This text is also parsed</message>

XML解析器这样做的原因是XML元素内部可能还包含了别的元素，象下面的例子，name元素内部包含了first和last两个元素:

<name><first>Bill</first><last>Gates</last></name>

解析器会认为上面的代码是这样的:

<name>
<first>Bill</first>
<last>Gates</last>
</name>

转义字符

不合法的XML字符必须被替换为相应的实体。

如果在XML文档中使用类似"<" 的字符, 那么解析器将会出现错误，因为解析器会认为这是一个新元素的开始。所以不应该象下面那样书写代码:

<message>if salary < 1000 then</message>

为了避免出现这种情况，必须将字符"<" 转换成实体，象下面这样:

<message>if salary &lt; 1000 then</message>

下面是五个在XML文档中预定义好的实体:

&lt; | < | 小于号
&gt; | > | 大于号
&amp; | & | 和
&apos; | ' | 单引号
&quot; | " | 双引号

实体必须以符号"&"开头，以符号";"结尾。

注意: 只有"<" 字符和"&"字符对于XML来说是严格禁止使用的。剩下的都是合法的，为了减少出错，使用实体是一个好习惯。

CDATA部件

在CDATA内部的所有内容都会被解析器忽略。

如果文本包含了很多的"<"字符和"&"字符——就象程序代码一样，那么最好把他们都放到CDATA部件中。

一个 CDATA 部件以"<![CDATA[" 标记开始，以"]]>"标记结束:

<script>
<![CDATA[
function matchwo(a,b)
{
if (a < b && a < 0) then
{
return 1
}
else
{
return 0
}
}
]]>
</script>

在前面的例子中，所有在CDATA部件之间的文本都会被解析器忽略。

CDATA注意事项:

CDATA部件之间不能再包含CDATA部件（不能嵌套）。如果CDATA部件包含了字符"]]>" 或者"<![CDATA[" ，将很有可能出错哦。

同样要注意在字符串"]]>"之间没有空格或者换行符。

back next


XML in Data Islands

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML数据岛

使用IE5.0或者更高的版本，XML数据可以以数据岛的形式嵌入HTML页面。

在HTML页面中嵌入XML数据

使用非官方标准的<xml>标记可以将XML数据嵌入到HTML页面中。

XML数据可以象下面的例子那样嵌入HTML页面:

<xml id="note">
<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>
</xml>

或者象下面这样嵌入外部单独的XML文件:

<xml id="note" src="note.xml">
</xml>

注意那个<xml>标记是一个HTML元素，而不是一个XML元素。

数据绑定

XML数据岛可以绑定到HTML元素上（比如表格）。

在下面的例子中，一个XML数据岛（ID=cdcat）被从外部XML文档载入。一个HTML的表格绑定到此数据岛上。HTML表格内部的span元素使用datafld属性和XML文档相应的XML元素相互绑定。

<html>
<body>
<xml id="cdcat" src="cd_catalog.xml"></xml>
<table border="1" datasrc="#cdcat">
<tr>
<td><span datafld="ARTIST"></span></td>
<td><span datafld="TITLE"></span></td>
</tr>
</table>
</body>
</html>

如果你使用的是IE 5.0 或者更高版本, 你可以自己尝试一下try it yourself.

如果你使用的是IE 5.0 或者更高版本，你可以观看external XML file.

同样也可以实验this example, 论证元素<thead>, <tbody>, and <tfoot>.


XML and CSS

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

使用CSS来显示XML

使用CSS样式单 (Cascading Style Sheets) ,可以给XML文档添加额外的现实信息。

使用CSS来显示未来的XML文档么？

应该使用CSS来显示你未来的XML文档么？

不，我们不推荐这样做！但是我们还是应该实验一下:

我们先来看一个单纯的XML文档: The CD Catalog

然后我们来看CSS样式表单文件: The CSS file

最后，我们来看用CSS显示出来的XML文档: The CD Catalog formatted with the CSS file

这是用CSS样式单修饰的XML文档的一小部分代码片断:

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/css" href="cd_catalog.css"?>
<CATALOG>
<CD>
<TITLE>Empire Burlesque</TITLE>
<ARTIST>Bob Dylan</ARTIST>
<COUNTRY>USA</COUNTRY>
<COMPANY>Columbia</COMPANY>
<PRICE>10.90</PRICE>
<YEAR>1985</YEAR>
</CD>
<CD>
<TITLE>Hide your heart</TITLE>
<ARTIST>Bonnie Tyler</ARTIST>
<COUNTRY>UK</COUNTRY>
<COMPANY>CBS Records</COMPANY>
<PRICE>9.90</PRICE>
<YEAR>1988</YEAR>
</CD>
.
.
.
.
</CATALOG>

即使使用CSS的显示效果很好，我们不认为使用CSS样式单显示XML文档是未来Web开发的趋势。我们相信，使用XSL程序格式化XML文档将会是未来的趋势，目前最主要的浏览器都支持这种技术。

使用XML创建未来的主页？

你愿意使用XML来创建你未来的网站么？

不，我不认为这是一个好主意。我们也不拒绝去做这样一个尝试：A homepage written in XML.

我们不相信XML会直接用于创建未来的Web页面。

我们仍然相信，XHTML - 利用XML重新定义过的HTML可能是一个更好的选择: 情阅读我们的XHTML 指南 。


XML DTD

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 确认

符合语法的XML文档称为结构良好的XML文档。

通过DTD验证的XML文档称为有效的XML文档。

"结构良好的" XML文档

一个结构良好的XML文档应该使用正确的语法。

一个结构良好的XML文档应该遵守XML语法规则，前面一章给出的例子就是一个结构良好的XML文档：

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

"有效的" XML文档

一个有效的XML文档应该遵守DTD的描述。

一个有效的XML文档也是一个结构良好的XML文档，同时还必须符合DTD的规则。

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE note SYSTEM "InternalNote.dtd">
<note>
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

XML DTD

DTD定义了XML文档中可用的合法元素。

DTD的意图在于定义XML文档的合法建筑模块。他通过定义一系列合法的元素决定了XMl文档的内部结构。结构良好的XML文档不一定是有效的XML文档,但有效的XML文档一定是结构良好的XML文档。如果你想了解更多关于DTD的知识可以参考DTD 指南。

XML Schema

XML Schema(XML模式)是基于XML的DTD的替代品。

W3C使得DTD和Schema可以相互替代，读者可以在Schema 指南中了解到更多信息。

错误

XML文档中发生的错误将导致XML程序停止。

W3C的XML规范声明：如果程序在处理XML文档中发现一个有效的错误，那么此程序应该终止。这就是XML软件相对于容易编写的原因。所有的XML文档地都应该是协调一致的。

在HTML中，HTML文件可能包含很多错误，（比如一个元素有开始标记没有结束标记）这也是HTML浏览器体积之所以很大的一个原因，当他们发现错误的时候，他们有各自不同的方法来决定此HTML文件应该如何显示。

在XML中决不会发生这种情况。


XML Elements

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML元素

XML元素是可以扩展的，它们之间有关联。

XML元素有简单的命名规则。

XML元素是可以扩展的

XML文档可以被扩展一边携带更多的信息。

请看下面的XML便条例子：

<note>
<to>Lin</to>
<from>Ordm</from>
<body>Don't forget me this weekend!</body>
</note>

让我们来设想一个能够读取此XML文档的并能解读其中XML元素（<to>, <from>, 和<body>）的软件，可能的输出如下：

MESSAGE

To: Lin
From: Ordm

Don't forget me this weekend!

我们再来设想，如果便条的作者Ordm在这个XML文档中加入一些额外的信息，如下所示：

<note>
<date>2002-12-24</date>
<to>Lin</to>
<from>Ordm</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

那么原来的应用程序会中断或者崩溃么？

不会。应用程序仍然会正确的解读<to>, <from>, 和<body> 等元素，并且产生同样的输出。

XML文档是可以扩展的！

XML元素是相互关联的

XML元素之间是父元素和子元素的关系。

为了更好的理解XML术语，必须了解XML元素之间的关系如何，以及元素的内容是如何被描述的。

设想有这样一本书：

署名: XML 指南

第一章: XML入门简介

  • 什么是HTML
  • 什么是XML

第二章: XML语法

  • XML元素必须有结束标记
  • XML元素必须正确的嵌套

我们可以用XML文档来描述这本书：

<book>
<title>XML 指南</title>
<prod id="33-657" media="paper"></prod>
<chapter>XML入门简介
<para>什么是HTML</para>
<para>什么是XML</para>
</chapter>
<chapter>XML语法
<para>XML元素必须有结束标记</para>
<para>XML元素必须正确的嵌套</para>
</chapter>
</book>

在上面的代码中，Book元素是XML文档的根元素，title元素和chapter元素是book元素的子元素。Book元素是title元素和chapter元素的父元素。title元素，prod元素和chapter元素是平级元素，因为他们都有同一个父元素。

XML元素的内容

XML元素有不同的内容。

XML元素指的是从该元素的开始标记到结束标记之间的这部分内容。

XML元素有元素内容，混合内容，简单内容或者空内容。每个元素都可以拥有自己的属性。

在上面的例子中，book元素有元素内容，应为book元素包含了其它的元素。Chapter元素有混合内容，因为它里面包含了文本和其他元素。para元素有简单的内容，因为它里面仅有简单的文本。prod元素有空内容，因为他不携带任何信息。

在上面的例子中，只有prod元素有属性，id属性值是33-657，media属性值是paper。

XML元素命名

XML元素命名必须遵守下面的规则：

  • 元素的名字可以包含子母，数字和其他字符。
  • 元素的名字不能以数字或者标点符号开头。
  • 元素的名字不能以XML(或者xml，Xml,xMl...)开头。
  • 元素的名字不能包含空格。

自己“发明”的XML元素还必须注意下面一些简单的规则：

任何的名字都可以使用，没有保留字（除了XML），但是应该使元素的名字具有可读性，名字使用下划线是一个不错的选择。

例如: <first_name>, <last_name>.

尽量避免使用“-”，“.”，因为有可能引起混乱。

只要你愿意元素的名字可以很长，但也不要太夸张了哦。命名应该遵循简单易读的原则，例如：<book_title>是一个不错的名字，而<the_title_of_the_book>则显得罗嗦了。

XML文档往往都对应着数据表，我们应该尽量让数据库中的字段的命名和相应的XML文档中的命名保持一致，这样可以方便数据变换。

非英文/字符/字符串也可以作为XML元素的名字，例如<蓝色理想><经典论坛>这都是完全合法的名字。但是有一些软件不能很好的支持这种命名，所以尽量使用英文字母来命名。

在XML元素命名中不要使用":"，因为XML命名空间需要用到这个十分特殊的字符。


XML Encoding

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML编码

XML文档可以包含外文字符比如挪威语或者法语（中文当然也可以！这一部分还是不能照原文翻译，下面有些内容是我自己写的）

为了让你的解析器能够明白这些字符，你必须在XML文档中统一的字符编码标准。

Windows 95/98 记事本

Windows 95/98 记事本不能以Unicode的编码格式保存文件。

可以使用记事本来编辑和保存包含了外文字符的XML文档 (比如：挪威语或者法语或者中文)

<?xml version="1.0"?>
<note>
<from>小奀</from>
<to>小林</to>
<message>晚上一起去火锅呀</message>
</note>

但是如果你用浏览器打开这个用记事本编辑过的XML文档，将会出现一个错误open it with IE 5.0。

在Windows 95/98 记事本中使用编码

Windows 95/98 记事本编辑XML文件必须进行编码属性设置。

为了避免发生错误，可以在XML文档声明中加上一个encoding属性，指明此XML文档的编码类型，但是不要使用Unicode编码。

下面的编码类型不会导致错误，(用IE 5.0+浏览器观看), 并且汉字显示正常:

<?xml version="1.0" encoding="gb2312"?>

下面的编码类型不会导致错误，(用IE 5.0+浏览器观看), 并且汉字显示正常:

<?xml version="1.0" encoding="gbk"?>

下面的编码类型不会导致错误，(用IE 5.0+浏览器观看), 并且汉字显示不正常(乱码):

<?xml version="1.0" encoding="windows-1252"?>

下面的编码类型不会导致错误，(用IE 5.0+浏览器观看), 并且汉字显示不正常(乱码):

<?xml version="1.0" encoding="ISO-8859-1"?>

下面的编码类型不会导致错误，(用IE 5.0+浏览器观看),并且汉字显示正常:

<?xml version="1.0" encoding="UTF-8"?>

下面的编码类型会导致错误，(用IE 5.0+浏览器观看):

<?xml version="1.0" encoding="UTF-16"?>

使用Windows 2000 记事本

Windows 2000 记事本可以以Unicode编码格式保存文件。

Windows 2000 的记事本支持Unicode字符集。如果使用Win2000的记事本以Unicode的编码格式保存XML文档(请注意这里在XML声明中没有编码信息):

<?xml version="1.0"?>
<note>
<from>小奀</from>
<to>小林</to>
<message>晚上一起去火锅呀</message>
</note>

下面这个文件; note_encode_none_u.xml, 在IE5.0+中将不会出现错误，但如果你使用网景Netscape 6.2，就可能出错。读者比较 note_encode_none.xml 和 note_encode_none_u.xml这两个文件，如果单独看他们各自的源文件，是没有区别的，但为什么一个能显示，一个不能显示呢？答案就是Unicode字符集。

Windows 2000 记事本编码

Windows 2000记事本还可以以"UTF-16"编码格式保存文件。

如果你在XML文档中声明了编码属性而又以Unicode编码格式保存文件，将可能发生错误。

下面的代码将会导致错误 (用浏览器察看):

<?xml version="1.0" encoding="windows-1252"?>

下面的代码将会导致错误 (用浏览器察看):

<?xml version="1.0" encoding="ISO-8859-1"?>

下面的代码将会导致错误 (用浏览器察看):

<?xml version="1.0" encoding="UTF-8"?>

下面这个文件; note_encode_utf16_u.xml, 将会在IE5.0+中显示正常，在网景Netscape 6.2浏览器中将会出现错误。

<?xml version="1.0" encoding="UTF-16"?>

错误信息

当时用IE5.0或者更高版本浏览XML文档时，可能会遇到两中不同的编码错误:

在文本内容中发现一个非法字符(An invalid character was found in text content)。

如果你的XML文档和你的XML文档的编码格式不匹配就可能导致错误发生。通常情况是，XML文档包含一些“非英文”字符，并且使用了单字节编码的编辑器，而且没有在XML文档的声明中设置XML文档的编码格式。

不支持从当前的编码格式转换成另一种编码格式（Switch from current encoding to specified encoding not supported）。

如果XML文档以Unicode/UTF-16编码格式保存，但是XML文档的声明中却设置了编码格式是一些单字节的编码（比如 Windows-1252, ISO-8859-1 或者 UTF-8）；或者XML文档以单字节编码格式保存，但是XML文档的声明中却设置了编码格式是一些Unicode/UTF-16的编码形式，这样两种情况都会导致错误发生。

结论

结论:在保存XML文档之前在XML文档的声明中设置文档的编码格式，我的一些关于避免错误发生的建议:

  • 使用一种支持Unicode编码格式的编辑器。
  • 确信你知道自己正在使用那种编码格式。
  • 在XML文档中使用属性声明设置编码格式。


XML Examples

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 实例

浏览XML文件

一个最简单的XML文件 (note.xml)
一个有错误的XML文件（因为有错，所以不能正常浏览）
一个CD目录的XML文件
一个植物目录的XML文件
一个食品目录的XML文件

浏览使用dtd的XML文件

观看内部使用dtd的note.xml
观看外部引用dtd的note.xml

微软的XML解析器

浏览一个简单的XML文件 (xml_note.xml)
把XML文件载入解析器
通过XMl文档数的节点
把XML文件载入HTML页面

使用JavaScript脚本显示

浏览一个简单的XML页面 (xml_note.xml)
使用JavaScript脚本格式话上面的XML文件

XML 和 CSS

浏览CD目录的XML文件
浏览响应的CSS文件
浏览用CSS修饰过的XML文件

XML 和 XSL

浏览食物目录的XML文件
浏览相应的XSL文件
浏览被XSL修饰过的XML文件

数据绑定技术

浏览CD目录文件
把CD目录绑定到HTML的表格元素上
添加<thead>, <tfoot>, <tbody>元素

从数据库中输出XML

浏览从数据库中输出 XML 文档

转换成HTML显示

浏览CD目录的XML文件
浏览CD目录在HTML元素内部显示
浏览CD目录在HTML的表格中显示
浏览有导航的CD目录文件
一个简单的CD目录应用程序

向服务器发出XML数据请求

使用JavaScript向服务器发送XML请求
使用VBScript向服务器发送XML请求
向服务器发送一个请求
使用XML和服务器进行交互

XML 行为(.htc)

XML 行为实例


XML HTTP Requests

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML HTTP 请求

如果使用IE5.0或者更高版本的浏览器，可以通过HTTP请求从服务器端获取XML数据。

浏览器请求

通过浏览器可以发送HTTP请求，从服务器端获取XML数据:

var objHTTP = new ActiveXObject("Microsoft.XMLHTTP")
objHTTP.Open('GET','httprequest.asp',false)
objHTTP.Send()

下面的代码是在浏览器中显示从服务器端的得到的返回数据:

document.all['A1'].innerText= objHTTP.status
document.all['A2'].innerText= objHTTP.statusText
document.all['A3'].innerText= objHTTP.responseText

使用JavaScript脚本

使用VBScript脚本

与服务器的交互

通过HTTP请求就可以做到与服务器进行“交互”。

使用XML与服务器进行交互

我们在服务器端“捏造”了下面的ASP代码进行交互操作:

<%
response.ContentType="text/xml"
txt="<answer><text>12 Years</text></answer>"
response.write(txt)
%>

因此，无论你提问什么，回答永远是12年。在现实生活中，不得不去写大量的代码去分析问题并且响应出正确的答案。


XML Namespaces

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 命名空间

XML 命名空间提供了一种避免元素命名冲突的方法。

命名冲突

因为XML文档中使用的元素不是固定的，那么两个不同的XML文档使用同一个名字来描述不同类型的元素的情况就可能发生。而这种情况又往往会导致命名冲突。请看下面两个例子

这个 XML 文档在table元素中携带了水果的信息:

<table>
<tr>
<td>Apples</td>
<td>Bananas</td>
</tr>
</table>

这个 XML 文档在table元素中携带了桌子的信息(家具，不能吃的哦):

<table>
<name>African Coffee Table</name>
<width>80</width>
<length>120</length>
</table>

如果上面两个XML文档片断碰巧在一起使用的话，那么将会出现命名冲突的情况。因为这两个片断都包含了<table>元素，而这两个table元素的定义与所包含的内容又各不相同。

使用前缀解决命名冲突问题

下面的XML文档在table元素中携带了信息:

<h:table>
<h:tr>
<h:td>Apples</h:td>
<h:td>Bananas</h:td>
</h:tr>
</h:table>

下面的XML文档携带了家具table的信息:

<f:table>
<f:name>African Coffee Table</f:name>
<f:width>80</f:width>
<f:length>120</f:length>
</f:table>

现在已经没有元素命名冲突的问题了，因为这两个文档对各自的table元素使用了不同的前缀，table元素在两个文档中分别是(<h:table> 和<f:table>)。

通过使用前缀，我们创建了两个不同的table元素。

使用命名空间

下面的XML文档在table元素中携带了信息:

<h:table xmlns:h="http://www.w3.org/TR/html4/">
<h:tr>
<h:td>Apples</h:td>
<h:td>Bananas</h:td>
</h:tr>
</h:table>

下面的XML文档携带了家具table的信息:

<f:table xmlns:f="http://www.w3schools.com/furniture">
<f:name>African Coffee Table</f:name>
<f:width>80</f:width>
<f:length>120</f:length>
</f:table>

在上面两个例子中除了使用前缀外，两个table元素都使用了xmlns属性，使元素和不同的命名空间关联到一起。

命名空间属性

命名空间属性一般放置在元素的开始标记处，其使用语法如下所示:

xmlns:namespace-prefix="namespace"

在上面的例子中，命名空间定义了一个Internet 地址:

xmlns:f="http://www.w3schools.com/furniture"

W3C 命名规范声明命名空间本身就是一个统一资源标示符，Uniform Resource Identifier (URI)。

当我们在元素的开始标记处使用命名空间时，该元素所有的子元素都将通过一个前缀与同一个命名空间相互关联。

注意：用来标识命名空间的网络地址并不被XML解析器调用，XML解析器不需要从这个网络地址中查找信息，该网络地址的作用仅仅是给命名空间一个唯一的名字，因此这个网络地址也可以是虚拟的，然而又很多公司经常把这个网络地址值象一个真实的Web页面，这个地址包含了关于当前命名空间更详细的信息。
可以访问http://www.w3.org/TR/html4/.

统一资源标识符

通用资源标识符（A Uniform Resource Identifier (URI)）是一个标识网络资源的字符串。最普通的URI应该是统一资源定位符Uniform Resource Locator (URL)。URL用于标识网络主机的地址。另一方面，另一个不常用的URI是通用资源名字Universal Resource Name (URN)。在我们的例子中，一般使用的是URLs。

既然前面的例子使用的URL地址来标识命名空间，我们可以确信这个命名空间是唯一的。

默认的命名空间

定义一个默认的XML命名空间使得我们在子元素的开始标记中不需要使用前缀。他的语法如下所示:

<element xmlns="namespace">

下面的XML文档在table元素中包含了水果的信息:

<table xmlns="http://www.w3.org/TR/html4/">
<tr>
<td>Apples</td>
<td>Bananas</td>
</tr>
</table>

下面的XML文档包含了家具table的信息:

<table xmlns="http://www.w3schools.com/furniture">
<name>African Coffee Table</name>
<width>80</width>
<length>120</length>
</table>

使用命名空间

档开始使用XSL的时候,就会发现命名空间使用的是如此频繁。XSL样式单主要用于将XML文档转换成类似于HTML文件的格式。

如果看一下下面的XSL文档，就会发现有很多标记都是HTML标记。那些标记并不是HTML标记，是加了前缀的XSL,这个XSL前缀由命名空间"http://www.w3.org/TR/xsl"所标识:

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/TR/xsl">
<xsl:template match="/">
<html>
<body>
<table border="2" bgcolor="yellow">
<tr>
<th>Title</th>
<th>Artist</th>
</tr>
<xsl:for-each select="CATALOG/CD">
<tr>
<td><xsl:value-of select="TITLE"/></td>
<td><xsl:value-of select="ARTIST"/></td>
</tr>
</xsl:for-each>
</table>
</body>
</html>
</xsl:template>
</xsl:stylesheet>


XML Parser

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

微软的XML解析器

XML解析器可以读取、更新、创建、操作一个XML文档。

使用XML解析器

微软的XML解析器是和IE5.0+浏览器捆绑在一起的。

一旦你安装了IE5.0,那么就获得了XML解析器。这个浏览器除了被浏览器内部调用外，还可以在脚本中或者程序中调用。这个解析器的特点是支持与程序设计语言无关的编程模型，他支持以下技术:

  • JavaScript, VBScript, Perl, VB, Java, C++ 等等
  • W3C XML 1.0 和 XML DOM
  • DTD 和 XML文档验证

如果浏览器使用JavaScript作为脚本语言,那么利用下面的代码可以创建XML文档对象:

var xmlDoc=new ActiveXObject("Microsoft.XMLDOM")

如果浏览器使用VBScript作为脚本语言,那么利用下面的代码可以创建XML文档对象:

set xmlDoc=CreateObject("Microsoft.XMLDOM")

如果在ASP程序中使用VBScript脚本语言，那么就可以使用下面的代码形式:

set xmlDoc=Server.CreateObject("Microsoft.XMLDOM")

将XML文档载入解析器

使用脚本代码可以将XML文档载入解析器。

下面的代码可以将一个XML文档载入解析器:

<script type="text/javascript">
var xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.load("note.xml")
// ....... processing the document goes here
</script>

第二行代码创建Microsoft XML解析器的实例。

第三行代码关闭异步载入，确保XML解析器在把XML文档完全载入以前不会对XML文档进行解析。

第四行则告诉解析器需要载入的XML文档名字是note.xml。

把纯XML文档由字符载入解析器

解析器可以从一个文本字符串中载入XML文本。

下面的代码演示了将文本字符串载入解析器:

<script type="text/javascript">
var text="<note>"
text=text+"<to>Tove</to><from>Jani</from>"
text=text+"<heading>Reminder</heading>"
text=text+"<body>Don't forget me this weekend!</body>"
text=text+"</note>"
var xmlDoc = new ActiveXObject("Microsoft.XMLDOM")
xmlDoc.async="false"
xmlDoc.loadXML(text)
// ....... processing the document goes here
</script>

注意这里载入字符串使用的是"loadXML()"方法）（而不是前面用过的"load()"方法)， "loadXML()"是用于载入字符串，"load()"是用于载入XML文档。

使用JavaScript语言显示XML数据

可以使用JavaScript语言来显示XML数据。

JavaScript (或者 VBScript)可以从XML文档中导入数据，并将这些数据在HTML页面中显示出来。

下面我们来看一下XML和HTML是如何进行相互之间的互补的，首先来看一个XML 文档 (note.xml), 然后我们看一个包含了导入XML文档兵显示在HTML页面中的JavaScript脚本代码的HTML文档(note.htm) 。

去看看他是如何工作的, 自己尝试一下吧 new

你可以在我们的DOM School中了解更多的关于JavaScript的知识。


XML Quiz

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 测试

你可以在W3Schools测试你的XML技能。

测试

这个测试包含了20个问题，只能用很短的时间回答。

这个测试不是官方的，他只是能够让你知道自己了解多少关于XML的知识。

分数计算

正确得1分，满分20。

祝你好运! 开始进行测试//这个链接已经无效了,如果你还想继续测试的话，请访问http://www.w3schools.com/

下面是一些实例代码，很基础的东西:

tryit.asp-filename=behave.htm
tryit.asp-filename=cd_application.htm
tryit.asp-filename=cd_catalog_island.htm
tryit.asp-filename=cd_catalog_island_thead.htm
tryit.asp-filename=cd_first.htm
tryit.asp-filename=cd_list.htm
tryit.asp-filename=cd_navigate.htm
tryit.asp-filename=httprequest_js.htm
tryit.asp-filename=httprequest_vb.htm
tryit.asp-filename=node_parsertest.htm
tryit.asp-filename=note.htm
tryit.asp-filename=tryxml_send.htm
tryit.asp-filename=xml_note.htm
tryit.asp-filename=xml_note_traverse.htm
tryit.asp-filename=xml_send.htm


XML in Real Life

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

现实生活中的XML

XML最现实的一个例子就是装载信息。

实例: XML 新闻

XML新闻是一种交换新闻和其他信息的规范。

使用这样一种规范，使新闻工作制作者和新闻消费者跨越不同的硬件、软件、编程语言来生产、接收、存档各种各样的新闻信息变得更简单快捷。

一个XML新闻文档的例子:

<?xml version="1.0" encoding="ISO-8859-1"?>
<nitf>
<head>
<title>Colombia Earthquake</title>
</head>
<body>
<body.head>
<headline>
<hl1>143 Dead in Colombia Earthquake</hl1>
</headline>
<byline>
<bytag>By Jared Kotler, Associated Press Writer</bytag>
</byline>
<dateline>
<location>Bogota, Colombia</location>
<story.date>Monday January 25 1999 7:28 ET</story.date>
</dateline>
</body.head>
</body>
</nitf>

关于XML新闻更多的信息可以去访问网址: http://www.xmlnews.org/


XML Server

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

简单的XML服务器

不需要安装XML控件就可以在服务器上创建XML文档。

在服务器端存储XML文档

XML文件可以存储在网络服务器中。

就象其他的HTML文件一样，XML文件可以存储在网络服务器上。

打开你的记事本并写入下面的代码:

<?xml version="1.0" encoding="gb2312"?>
<note>
<from>小奀</from>
<to>小林</to>
<message>晚上一起去火锅呀</message>
</note>

然后把这个文件保存到你的服务器上，取名"note.xml"。

注意: 这个XML文件必须和你的其他HTML文件在同一个目录下面，并且 MIME 类型应该设置成 text/xml。

使用ASP产生XML文件

在服务器端即使没有安装XML软件也可以产生XML文件。

为了使服务器端可以对客户端产生动态XML响应，我们可以在的服务器上创建一个包含以下代码的简单的ASP页面:

<%
response.ContentType="text/xml"
response.Write("<?xml version='1.0' encoding='gb2312'?>")
response.Write("<note>")
response.Write("<from>小奀</from> ")
response.Write("<to>小林</to>")
response.Write("<message>晚上一起去火锅呀</message> ")
response.Write("</note>")
%>

注意：XML的内容必须设置正确。察看这个ASP页面，如果这个服务器支持ASP的话就会看到显示出来的内容和note.xml文件的一样。

(ASP = Active Server Pages。如果你不知道如何写ASP代码，你可以去参考我们的ASP 指南)

从数据库中产生XML文档

不用安装任何XML软件就可以从数据库中动态的导出XML文档。

我们把前面的例子稍加修改就可以实现从数据库中取得数据了。

下面是一个在服务器端动态生成XML数据的ASP页面例子:

<%
response.ContentType = "text/xml"
set conn=Server.CreateObject("ADODB.Connection")
conn.provider="Microsoft.Jet.OLEDB.4.0;"
conn.open server.mappath("../ado/database.mdb")
sql="select fname,lname from tblGuestBook"
set rs=Conn.Execute(sql)
rs.MoveFirst()
response.write("<?xml version='1.0' encoding='ISO-8859-1'?>")
response.write("<guestbook>")
while (not rs.EOF)
response.write("<guest>")
response.write("<fname>" & rs("fname") & "</fname>")
response.write("<lname>" & rs("lname") & "</lname>")
response.write("</guest>")
rs.MoveNext()
wend
rs.close()
conn.close()
response.write("</guestbook>")
%>

可以在这里观看实例页面。

上面的例子使用了ADO技术，如果你不了解ADO，可以访问我们的ADO 指南。


XML Syntax

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 语法

back next

XML的语法规则既简单又严格，非常容易学习和使用。

正因为如此，编写读取和操作XML的软件也是相对容易的事情。

一个XML文档的例子

XML文档使用了自描述的和简单的语法。

<?xml version="1.0" encoding="ISO-8859-1"?>
<note>
<to>Lin</to>
<from>Ordm</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

文档的第1行:XML声明——定义此文档所遵循的XML标准的版本，在这个例子里是1.0版本的标准，使用的是ISO-8859-1 (Latin-1/West European)字符集。

文档的第2行是根元素（就象是说“这篇文档是一个便条”）：

<note>

文档的第3--6行描述了根元素的四个子节点（to, from, heading,和 body）：

<to>Lin</to>
<from>Ordm</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>

文档的最后一行是根元素的结束：

</note>

你能从这个文档中看出这是Ordm给Lin留的便条么？难道能不承认XML是一种美丽的自描述语言么？

所有的XML文档必须有一个结束标记

在XML文档中, 忽略结束标记是不符合规定的。

在HTML文档中，一些元素可以是没有结束标记的。下面的代码在HTML中是完全合法的：

<p>This is a paragraph
<p>This is another paragraph

但是在XML文档中必须要有结束标记，象下面的例子一样：

<p>This is a paragraph</p>
<p>This is another paragraph</p>

注意: 你可能已经注意到了，上面例子中的第一行并没有结束标记。这不是一个错误。因为XML声明并不是XML文档的一部分，他不是XML元素，也就不应该有结束标记。

XML标记都是大小写敏感的

这与HTML不一样, XML标记是大小写敏感的。

在XML中, 标记<Letter>与标记<letter>是两个不同的标记。

因此在XML文档中开始标记和结束标记的大小写必须保持一致。

<Message>This is incorrect</message>   //错误的
<message>This is correct</message>     //正确的

所有的XML元素必须合理包含

在XML中不允许不正确的嵌套包含。

在HTML中，允许有一些不正确的包含，例如下面的代码可以被浏览器解析：

<b><i>This text is bold and italic</b></i>

在XML中所有元素必须正确的嵌套包含，上面的代码应该这样写：

<b><i>This text is bold and italic</i></b>

所有的XML文档必须有一个根元素

XML文档中的第一个元素就是根元素。

所有XML文档都必须包含一个单独的标记来定义，所有其他元素的都必须成对的在根元素中嵌套。XML文档有且只能有一个根元素。

所有的元素都可以有子元素，子元素必须正确的嵌套在父元素中，下面的代码可以形象的说明：

<root>
<child>
<subchild>.....</subchild>
</child>
</root>

属性值必须使用引号""

在XML中,元素的属性值没有引号引着是不符合规定的。

如同HTML一样，XML元素同样也可以拥有属性。XML元素的属性以名字/值成对的出现。XML语法规范要求XML元素属性值必须用引号引着。请看下面的两个例子，第一个是错误的，第二个是正确的。

<?xml version="1.0" encoding="ISO-8859-1"?>
<note date=12/11/99>
<to>Lin</to>
<from>Ordm</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

<?xml version="1.0" encoding="ISO-8859-1"?>
<note date="12/11/99">
<to>Tove</to>
<from>Jani</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

第一个文档的错误之处是属性值没有用引号引着。

正确的写法是: date="12/11/99". 不正确的写法: date=12/11/99.

使用XML,空白将被保留

在XML文档中，空白部分不会被解析器自动删除。

这一点与HTML是不同的。在HTML中，这样的一句话：

"Hello my name is Ordm"将会被显示成：“Hello my name is Ordm”,

因为HTML解析器会自动把句子中的空白部分去掉。

使用XML, CR / LF 被转换为 LF

使用 XML, 新行总是被标识为 LF（Line Feed，换行）。

你知道打字机是什么么？呵呵，打字机是在上个世纪里使用的一种专门打字的机器。^&^

当你用打字机敲完一行字后，你通常不得不再把打字头移动到纸的左端。

在Windows应用程序中，文本中的新行通常标识为 CR LF (carriage return, line feed，回车，换行)。在Unix应用程序中，新行通常标识为 LF。还有一些应用程序只使用CR来表示一个新行。

XML中的注释

在XML中注释的语法基本上和HTML中的一样。

<!-- 这是一个注释 -->

XML并没有什么特别的哦

XML确实没有什么特别的地方。他只是一些用尖括号扩在一起的普通的纯文本。

编辑普通文本的软件也可以编辑XML文档。

然而在一个支持XML的应用程序中，XML标记往往对应着特殊的操作，有些标记可能是可见的，而有些标记则可能不会显示出来，而不会有什么特殊的操作。

back next


XML Technologies

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML 技术概要

在这一节里，将要列出一些很重要的XML相关技术。这对理解和开发XML应用程序是很有帮助的。

XHTML - 可扩展HTML（Extensible HTML）

XHTML 使用XML重新定义了HTML 4.01的语法。XHTML 1.0是HTML的下一个版本。更多的请参考我们的XHTML 指南。

CSS - 层叠样式表单（Cascading Style Sheets）

CSS 样式单可以为XML文档添加显示信息。更多信息请阅读我们的CSS 指南。

XSL - 可扩展样式单语言（Extensible Style Sheet Language）

XSL由三部分组成: XML文档转换（XML Document Transformation ，又叫XSLT）,模式匹配语法（ a pattern matching syntax ，又叫XPath), 格式话对象（ a formatting object interpretation，XSL FO）。

XSLT - XML 转换语言（XML Transformation）

XSLT 是一种比CSS强大很多的语言。它可以将XML文档转换成其他格式的文档。。更多知识请阅读 XSL 指南。

XPath - XML匹配模式（XML Pattern Matching）

XPath是一种用于标识XML文档各个部分的语言。这是一种为了XSLT 和 XPointer而设计出来的语言。

XLink - XML链接语言（XML Linking Language）

链接语言（The XML Linking Language ，XLink）, 允许在不同的XML资源之间建立链接关系。

XPointer - XML指针语言（XML Pointer Language）

XML指针语言（The XML Pointer Language ，XPointer）, 标识XML文档的内部结构，例如元素、属性、内容等。

DTD - 文档类型定义 (Document Type Definition)

DTD主要用于定义编写XML文档所使用的元素。更多知识请参考 DTD 指南。

Namespaces - 命名空间

XML命名空间提供了一种可以把元素、属性、名字和URL地址引用相互关联的方法。

XSD - XML模式（XML Schema）

模式可以和DTD相互替代，并且功能更强大。模式使用XML格式编写，支持命名空间和数据类型。更多请参考 Schema 指南。

XDR - 数据简化（XML Data Reduced）

XDR是XML模式（XML Schema）的简化版本。IE5.0+浏览器支持XDR。

DOM - 文档对象模型（Document Object Model）

DOM定义了XML文档的接口、属性和方法。 更多请参考 DOM 指南。

XQL - XMl查询语言（XML Query Language）

XQL为存放XML文档中的数据提供一种便捷的查询语言。

SAX - XML的简单API(Simple API for XML)

SAX 是另一种读取和操作XML文档的编程接口。（与DOM类似）

W3C 介绍

互联网组织（The World Wide Web Consortium ，W3C）成立于1994年。主要通过发展各种WWW协议来领导Web。比如HTML, CSS 和 XML都是由W3C制定的。

W3C最重要的工作就是制定网络规范，或者描述一些构造Web的技术。

如果想了解更全面的XML标准请访问 W3C School。


XML Usage

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

如何使用XML?

首先要明确的是：XML是被设计用来存储数据、携带数据和交换数据的，他不是为了显示数据而设计的。

XML可以从HTML中分离数据

通过XML,你可以在HTML文件之外存储数据。

在不使用XML时，HTML用于显示数据，数据必须存储在HTML文件之内；使用了XML，数据就可以存放在分离的XML文档中。这种方法可以让你集中精力去到使用HTML做好数据的显示和布局上，并确保数据改动时不会导致HTML文件也需要改动。这样可以方便维护页面。

XML数据同样可以以“数据岛”的形式存储在HTML页面中。你仍然可以集中精力到使用HTML格式化和显示数据上去。

XML用于交换数据

通过XML,我们可以在不兼容的系统之间交换数据。

在现实生活中，计算机系统和数据库系统所存储的数据有N^N种形式,对于开发者来说，最耗时间的就是在遍布网络的系统之间交换数据。

把数据转换为XML格式存储将大大减少交换数据是的复杂性，并且还可以使得这些数据能被不同的程序读取。

XML 和 B2B

使用XML, 可以在网络中交换金融信息。

在不远的将来，我们可以期望看到很多关于XMl和B2B(Business To Business)的应用。

XML正在成为遍布网络的商业系统之间交换金融信息所使用的主要语言。许多与B2B有关的完全基于XML的应用程序正在开发中。

XML可以用于共享数据

通过XML,纯文本文件可以用来共享数据。

既然XML数据是以纯文本格式存储的，那么XML提供了一种与软件和硬件无关的共享数据方法。

这样创建一个能够被不同的应用程序读取的数据文件就变得简单了。同样，我们省级操作系统、升级服务器、升级应用程序、更新浏览器就容易多了。

XML可以用于存储数据

利用XML, 纯文本文件可以用来存储数据。

大量的数据可以存储到XML文件中或者数据库中。应用程序可以读写和存储数据，一般的程序可以显示数据。

XML可以充分利用数据

使用XML,你的数据可以被更多的用户使用。

既然XML是与软件、硬件和应用程序无关的，所以可以使你的数据可以被更多的用户、更多的设备所利用，而不仅仅是基于HTML标准的浏览器哦。

别的客户端和应用程序可以把你的XML文档作为数据源来处理，就像他们对待数据库一样，你的数据可以被各种各样的“阅读器”处理，这时对某些人来说是很方便的，比如盲人或者残疾人。

XML可以用于创建新的语言

XML是WAP和WML语言的母亲。

无线标记语言(WML，The Wireless Markup Language ), 用于标识运行于手持设备上（比如：手机）的Internet程序。

WML采用了XML的标准。你可以在WML 指南中详细的了解。

展望未来

如果开发者有足够的预见性，那么将来的应用程序都应该使用XML的形式来此存储数据。

将来我们所使用的字处理器、电子表格软件和数据库应该能够以纯文本的格式相互读取数据，而不需要经过格式转化的过程。

我们只能期盼微软和其他软件开发商也赞同这一点。//事实上微软正在大力发展XML的应用呢。


Viewing XML files

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

察看 XML 文件

原始的XML文件可以用IE 5.0 (或者更高的版本)或者Netscape 6来察看,但是如果希望让XML文档象Web页那样显示就必须添加一些额外的显示信息。

察看XML文件

我们可以使用IE5.0 (或者更高的版本)来浏览XML文档。你可以单击一个超链接或者是在浏览器的地址栏中输入URL地址，或者是在文件夹中双击XML文档。如果你用 IE打开XML文档后发现浏览器用带颜色的标识XML文档的根元素和子元素，XML元素的左边有一个"+"号，那么你可以单击这个“+”号，展开这个元素的下一级结构；如果元素的左边有一个"-"号，那么你也可以单击这个“-”号，收拢这个元素的下一级结构，如果你愿意察看XML文档的源文件，那么你可以在右键菜单中选择“察看源文件”。

我们也可以用Netscape 6来打开XML文档，并且也可以用右键选择“察看源文件” 当你用Netscape 6打开XML文档后，浏览器将用带颜色的代码显示根元素和子元素。

我们来看一个XML文件: note.xml

注意:不要指望XML文档可以象HTML文件那样格式化。

浏览不合格的XML文档

如果用IE浏览器打开一个不正确的XML文档，浏览器将会报告错误。

来看下面这个例子: note_error.xml

其它的例子

浏览一些XML文档可以帮助你找到学习XML的感觉。

我们为你收集了一些XML资料:

An XML CD catalog
这是我的父辈的CD收藏纪录，存储成XML数据格式。

An XML plant catalog
这是一个植物商店的植物产品目录，也存储成XML格式了。

A Simple Food Menu
这是一个餐馆的早餐食谱目录，同样也是XML格式的。

为什么XML在浏览器中的显示是这个样子呢？

单纯的XML文档并不包含如何显示数据的信息。

既然XML标记是由XML文档作者“创造”和“发明”的，那么我们不可能知道一个<table>标记是指HTML中的表格还是一个木桌子。

在没有任何额外的信息指示如何显示数据的情况下，IE浏览器一般以树状视图的形式显示XML数据。

在下面的及格小节中，我们将描述一些解决XML文档显示问题的方案，包括CSS, XSL, JavaScript,和XML数据岛。


XML Introduction - What is XML

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

XML入门简介

XML可以用来描述数据，重点是‘数据是什么’。

HTML则是用来显示数据，重点是‘如何显示数据’。

在学习XML之前你应该已经知道的知识

在你继续之前你应该具有下面一些基础的知识：

  • WWW, HTML 和设计网页的基础知识
  • 网页脚本语言，比如JavaScript 或者VBScript

你最好在学习XML之前就了解上面的内容，因为在XML的学习过程中将用到这些知识。

什么是XML?

  • XML是EXtensible Markup Language的缩写
  • XML是一种类似于HTML的标记语言
  • XML是用来描述数据的
  • XML的标记不是在XML中预定义的，你必须定义自己的标记
  • XML使用文档类型定义（DTD）或者模式（Schema）来描述数据
  • XML使用DTD或者Schema后就是自描述的语言

XML和HTML的主要区别是什么

XML是用来存放数据的

XML不是HTML的替代品，XML和HTML是两种不同用途的语言。

XML是被设计用来描述数据的，重点是：什么是数据，如何存放数据。
HTML是被设计用来显示数据的，重点是：显示数据以及如何显示数据更好上面。

HTML是与显示信息相关的, XML则是与描述信息相关的。

XML 什么也不做

XML 被设计成什么都不做的。

也许看起来很难理解，但事实上XML确实什么都不做。XML只是用来组织、存储和发送信息的。

下面的例子是Ordm给Lin的便条，使用的是XML格式：

<note>
<to>Lin</to>
<from>Ordm</from>
<heading>Reminder</heading>
<body>Don't forget me this weekend!</body>
</note>

这个便条有信息头，又信息主体，还包括发送人和接收人。尽管如此，这个XML文档仍然什么都不做，他只是用XML标记存储信息的文件。有人已经编写出来发送和接收并且显示这种格式信息的软件。

XML是自由的、可以扩展的

XML标记并不是预先规定好的，你必须创造你自己的标记。

在HTML文档中必须使用规则中定义好的标记。比如:<P><br><a></a>等等。

XML允许你定义自己的标记以及文档结构。

比如在上面例子中的"<to>"、"<from>"标记都不是在XML规范中事先定义好的。这些标记都是XML文档的作者“创造”出来的。

XML是HTML的补充

XML并不是HTML的替代品。

XML并不是HTML的替代品，理解这一点非常重要。在将来的网页开发中，XML将被用来描述、存储数据，而HTML则是用来格式化和显示数据的。

对于XML最好的形容可能是: XML是一种跨平台的，与软、硬件无关的，处理信息的工具。

XML在未来Web开发中的应用

XML无处不在

XML发展的非常迅速，这实在令人感到惊奇，有很多的软件开发商都采用了XML标准。

我们相信，在未来的Web开发中，XML将和HTML一样受到重视，他们都是Web技术的基础。XML将成为最普遍的数据操纵和数据传输的工具。

XML 笑话

问: 我该在什么时候使用XML?

答: 你可以在你的个人简历中写上你会XML。


XML and XSL

XML基础
XML 入门简介
XML 如何使用
XML 语法
XML 元素
XML 属性
XML 确认
XML 浏览器
XML 检视
XML 使用CSS
XML 使用 XSL
XML 数据岛
XML 解析器
XML 应用

XML 高级部分
XML 命名空间
XML CDATA
XML 编码
XML 服务器
XML 应用
XML HTTP
XML 行为
XML 技术

实例/测验
XML 例子
XML 测验

资源
XML 书籍
XML 规范

使用XSL来显示XML数据

使用XSL可以给XML文档添加上显示信息。

使用XSL来显示XML文档

XSL是XML的可扩展样式单语言。

XSL (全称是：可扩展的样式单语言，the eXtensible Stylesheet Language)比CSS样式单功能要强大的多。XSL的一个主要的用途就是将XML文档转换成HTML格式的文件，然后再交付给浏览器，由浏览器显示转换的结果:

如果你有网景6或者IE 5（或者更高的版本），你可以观看the XML file and the XSL style sheet.

在IE6中的显示结果：View the result in IE 6

在IE5中的显示结果：View the result in IE 5

注意下面的代码片断中的第二行:

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/xsl" href="simple.xsl"?>
<breakfast_menu>
<food>
<name>Belgian Waffles</name>
<price>$5.95</price>
<description>
two of our famous Belgian Waffles
</description>
<calories>650</calories>
</food>
</breakfast_menu>

如果你想了解更多关于XSL的知识，请阅读我们的XSL 指南。